COMEÇANDO

APRENDENDO A UTILIZAR O MUSESCORE

Guias
Partitura "Introdução"
Vídeos de instrução
Outros tutoriais
Vídeos

SUPORTE

Manual
Ajuda contextual
Fóruns
Como ...
Postar uma pergunta
Reportar um erro

INSTALLATION

Installation
Initial preferences

INSTALL ON WINDOWS

Install
  Start MuseScore
  Advanced users: Silent or unattended install
Uninstall
Troubleshooting
External links

INSTALL ON MACOS

Install
Uninstall
Install with Apple Remote Desktop

INSTALL ON LINUX

AppImage
  Step 1 - Download
  Step 2 - Give execute permission
  Step 3 - Run it!
  installing the AppImage (optional)
Using command line options
Distribution Packages
  Debian
  Fedora
  KDE neon 18.04 (bionic)
  Ubuntu, Kubuntu, Xubuntu,
External links

INSTALL ON CHROMEBOOK

Desktop program

LANGUAGE, TRANSLATIONS, AND EXTENSIONS

Change language
Resource Manager
Install/uninstall extension
Update translations
See also
External links

CHECKING FOR UPDATES

Automated update check
Check for update
See also

BASICS

CREATE A NEW SCORE

Start Center
Create new score
Enter score information
Choose template file
Choose instruments (or voice parts)
Add instruments
Add Staff / Add Linked Staff
Change order of instruments
Delete an instrument
Choose key signature and tempo
Choose time signature, pickup measure, and number of measures
Adjustments to score after creation
Add / delete / adjust measures
Add/edit text
Change instrument set-up
Hide a staff
MEASURE OPERATIONS

Select
  Single measure
  Range of measures

Insert
  Insert an empty measure into the score
  Insert multiple measures

Append
  Append an empty measure to the end of a score
  Append multiple measures to the end of a score

Delete
  Delete a single measure
  Delete a range of measures
  Remove empty trailing measures

Properties
  Staves
  Measure duration
  Other
    Exclude from measure count
    Break multi-measure rests
    Measure number mode
    Layout sketch
    Add to measure number
    Play Count

Numbering
  Split and join
  Join measures
  Split a measure

External links

VOICES

How voices are displayed
When to use voices
How to enter notes in different voices
Deleting and hiding rests
  Restoring deleted rests
Exchange voices of notes
Move notes to another voice (without swapping)
See also
External links

COPY AND PASTE

Summary of commands

Notes
  Copy or cut
  Paste
  Swap with Clipboard
  Copy pitch of a single note only

Other elements
  Copy or cut
  Paste
  Quick repeat
  Duplicate
  Paste half/double duration (version 3.1 and above)
  Selection filter

See also
External links

SELECTION MODES

Select a single object
  Select a single note
    Select a chord
    Select a single measure

Select an overlapping element
  Select a continuous range of objects
    1. Shift selection
    2. Shift + click selection
    3. Drag selection
  4. Select All
  5. Select section

Select a list of objects
Select all similar
What selections are useful for
See also

CONCERT PITCH

See also
External links

UNDO AND REDO

VIEWING AND NAVIGATION

View menu
  Show sidebars/panels
  Zoom in/out
  Toolbars
    *Non-linear tools*
    *Customize toolbar area*
  Workspaces
## ARPEGGIOs AND GLISSANDI
- Add symbol
- Adjust dimensions
- Custom symbols
- Arpeggios
- Glissandi (slides)
- Adjust start and end points of a glissando
- Wind instrument articulations
- Slide in/out
- External links

## ARTICULATIONS AND ORNAMENTS
- Articulations
- Ornaments
- Add articulation/ornament
- Add accidental to an ornament
- Keyboard shortcuts
- Adjust position
- Articulation and ornament properties
- See also
- External links

## BENDS
- Apply a bend
- Edit bend
- Text and line properties
- Bend shape and width
- Edit graphical display
- Adjust height
- Adjust position
- Custom bends
- External links

## BEAMS
- Adjust automatic note beaming
- Change beaming of individual notes
- Beam symbols and their effects
- Adjust beam angle
- Adjust beam height
- Make beam horizontal
- Adjust feathered beams
- Local relayout
- Flip note beam
- Reset Beam Mode
- See also
- External links

## BRACKETS
- Add
- Delete
- Change
- Edit
- Style

## BREATHS AND PAUSES
- Add symbol
- Adjust pause length

## GRACE NOTES
- Create grace notes
- Add a grace note
- Add a chord of grace notes
- Change pitch
- Change duration
- Manual adjustment
- Horizontal position
- Other adjustments
- External links

## HAIRPINs
- Add a hairpin
- Adjust length and height
- Cresc. and dim. lines
- Copy hairpins
- Edit hairpin properties
- Playback of hairpins

## LINES

---

See also
External links

---

ARPEGGIOS AND GLISSANDI

---

ARTICULATIONS AND ORNAMENTS

---

BENDS

---

BEAMS

---

BRACKETS

---

BREATHS AND PAUSES

---

GRACE NOTES

---

HAIRPINs

---

LINES

---
Applying lines to the score

To apply a line to just one note .................................................................................................................. 92
To apply a line across a range of notes ........................................................................................................... 92
To apply a line from a note to the end of that measure .................................................................................. 92
To apply a line across a range of measures ...................................................................................................... 92

Lines and playback properties ...................................................................................................................... 92
Adjust vertical position ................................................................................................................................... 92
Change length .................................................................................................................................................. 92
Text lines ......................................................................................................................................................... 93
Custom lines ................................................................................................................................................... 93
Copying lines ................................................................................................................................................... 93
Extended ornament lines .................................................................................................................................. 93
External links .................................................................................................................................................... 93

MEASURE RESTS ............................................................................................................................................ 93
Full measure rest .............................................................................................................................................. 93
To create one or more full measure rests ........................................................................................................ 93
To create a full measure rest in a particular voice ............................................................................................ 94
Multimeasure rest ............................................................................................................................................. 94
To display multimeasure rests ......................................................................................................................... 94
Break multimeasure rest .................................................................................................................................. 94

OCTAVE LINES ............................................................................................................................................... 94
Apply an octave line ......................................................................................................................................... 95
Change length .................................................................................................................................................. 95
Custom lines .................................................................................................................................................... 95
External links .................................................................................................................................................. 95

SLURS ............................................................................................................................................................... 95
Add slur in note-input mode ............................................................................................................................. 95
Add slur in Normal mode ................................................................................................................................... 95
Method 1 ......................................................................................................................................................... 96
Method 2 ......................................................................................................................................................... 96
Adjust slur ......................................................................................................................................................... 96
Extended slurs .................................................................................................................................................. 96
Dotted slurs ...................................................................................................................................................... 97
See also ............................................................................................................................................................ 97

TIES .................................................................................................................................................................. 97
Add ties in Note Input mode .............................................................................................................................. 97
Add ties in Normal mode .................................................................................................................................... 97
Method 1 .......................................................................................................................................................... 98
Method 2 ........................................................................................................................................................ 98
Add extra tied notes to a previously tied chord ................................................................................................. 98
Add ties to unison notes ..................................................................................................................................... 98
Flip a tie ............................................................................................................................................................. 98
See also ........................................................................................................................................................... 98
External links .................................................................................................................................................... 98

TREMOLO ...................................................................................................................................................... 98
Add a Tremolo .................................................................................................................................................. 99
Single note/chord tremolo .................................................................................................................................. 99
Two note/chord tremolo ...................................................................................................................................... 99
External links ................................................................................................................................................... 99

REPEATS AND JUMPS ................................................................................................................................. 99
Simple repeats ................................................................................................................................................ 99
1st and 2nd endings ......................................................................................................................................... 99
Playback ......................................................................................................................................................... 99
Repeat symbols and text .................................................................................................................................. 100
Jumps ............................................................................................................................................................... 100
Markers ........................................................................................................................................................... 100
Examples of jumps ........................................................................................................................................... 100
See also ........................................................................................................................................................... 101
External links .................................................................................................................................................. 101

TUPLETS ....................................................................................................................................................... 101
Create a tuplet .................................................................................................................................................. 101
Create a triplet in normal mode ...................................................................................................................... 101
Create a triplet in note input mode ................................................................................................................ 101
Create other tuplets ....................................................................................................................................... 102
Custom tuplets ................................................................................................................................................. 102
Delete a tuplet ................................................................................................................................................ 102
Change display of tuplets .............................................................................................................................. 102
Using the Inspector .......................................................................................................................................... 102
Using the Tuplets Style dialog ....................................................................................................................... 103
External links .................................................................................................................................................. 103

VOLTAS ........................................................................................................................................................... 103
To add a volta to the score ............................................................................................................................ 103
To change the number of measures that a volta covers .................................................................................. 103
Volta properties ............................................................................................................................................... 104
Playback .......................................................................................................................................................... 104
External links .................................................................................................................................................. 104
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>TRANSPOSITION</td>
<td>104</td>
</tr>
<tr>
<td>Manual transposition</td>
<td>104</td>
</tr>
<tr>
<td>Automatic transposition</td>
<td>105</td>
</tr>
<tr>
<td>Transpose Chromatically</td>
<td>106</td>
</tr>
<tr>
<td>To Key</td>
<td>106</td>
</tr>
<tr>
<td>By interval</td>
<td>106</td>
</tr>
<tr>
<td>Transpose Diatonically</td>
<td>106</td>
</tr>
<tr>
<td>Options</td>
<td>106</td>
</tr>
<tr>
<td>Transposing instruments</td>
<td>106</td>
</tr>
<tr>
<td>Concert pitch</td>
<td>106</td>
</tr>
<tr>
<td>Change staff transposition</td>
<td>106</td>
</tr>
<tr>
<td>External links</td>
<td>106</td>
</tr>
<tr>
<td>DRUM NOTATION</td>
<td>106</td>
</tr>
<tr>
<td>Percussion staff types</td>
<td>106</td>
</tr>
<tr>
<td>Note input methods</td>
<td>106</td>
</tr>
<tr>
<td>MIDI keyboard</td>
<td>107</td>
</tr>
<tr>
<td>Piano keyboard</td>
<td>107</td>
</tr>
<tr>
<td>Computer keyboard</td>
<td>107</td>
</tr>
<tr>
<td>Mouse</td>
<td>107</td>
</tr>
<tr>
<td>Drum input palette</td>
<td>108</td>
</tr>
<tr>
<td>Edit Drumset</td>
<td>108</td>
</tr>
<tr>
<td>Sticking</td>
<td>109</td>
</tr>
<tr>
<td>Add drum roll</td>
<td>109</td>
</tr>
<tr>
<td>External links</td>
<td>109</td>
</tr>
<tr>
<td>TABLATURE</td>
<td>109</td>
</tr>
<tr>
<td>Create a new tablature staff</td>
<td>109</td>
</tr>
<tr>
<td>With the New Score wizard</td>
<td>109</td>
</tr>
<tr>
<td>With the Instruments dialog</td>
<td>110</td>
</tr>
<tr>
<td>By changing staff type</td>
<td>110</td>
</tr>
<tr>
<td>Edit string data</td>
<td>110</td>
</tr>
<tr>
<td>Change tuning</td>
<td>111</td>
</tr>
<tr>
<td>Add a string</td>
<td>111</td>
</tr>
<tr>
<td>Delete a string</td>
<td>111</td>
</tr>
<tr>
<td>Mark unfretted string “open”</td>
<td>111</td>
</tr>
<tr>
<td>Change number of instrument frets</td>
<td>111</td>
</tr>
<tr>
<td>Change tablature display</td>
<td>111</td>
</tr>
<tr>
<td>Combine pitched staff with tablature</td>
<td>111</td>
</tr>
<tr>
<td>Create a new staff/tablature pair with the New Score Wizard</td>
<td>112</td>
</tr>
<tr>
<td>Create a new staff/tablature pair in an existing score</td>
<td>112</td>
</tr>
<tr>
<td>Create a staff/tablature pair from an existing staff</td>
<td>112</td>
</tr>
<tr>
<td>Enter notes in tablature</td>
<td>112</td>
</tr>
<tr>
<td>Using a computer keyboard</td>
<td>112</td>
</tr>
<tr>
<td>Using a mouse</td>
<td>113</td>
</tr>
<tr>
<td>Select note duration</td>
<td>113</td>
</tr>
<tr>
<td>Edit notes</td>
<td>113</td>
</tr>
<tr>
<td>In Note input mode</td>
<td>113</td>
</tr>
<tr>
<td>In Normal mode</td>
<td>113</td>
</tr>
<tr>
<td>Crosshead notes</td>
<td>113</td>
</tr>
<tr>
<td>Summary of keyboard commands</td>
<td>113</td>
</tr>
<tr>
<td>Note input mode</td>
<td>113</td>
</tr>
<tr>
<td>Normal mode</td>
<td>114</td>
</tr>
<tr>
<td>External links</td>
<td>114</td>
</tr>
<tr>
<td>SOUND AND PLAYBACK</td>
<td>114</td>
</tr>
<tr>
<td>MID-STAFF INSTRUMENT CHANGES</td>
<td>114</td>
</tr>
<tr>
<td>Effect of instrument change</td>
<td>114</td>
</tr>
<tr>
<td>Add an instrument change</td>
<td>114</td>
</tr>
<tr>
<td>See also</td>
<td>115</td>
</tr>
<tr>
<td>External links</td>
<td>115</td>
</tr>
<tr>
<td>MIXER</td>
<td>115</td>
</tr>
<tr>
<td>Opening the Mixer</td>
<td>115</td>
</tr>
<tr>
<td>Track Area</td>
<td>115</td>
</tr>
<tr>
<td>Master Gain</td>
<td>116</td>
</tr>
<tr>
<td>Track Area</td>
<td>116</td>
</tr>
<tr>
<td>Channel display arrow</td>
<td>116</td>
</tr>
<tr>
<td>Mute and Solo</td>
<td>117</td>
</tr>
<tr>
<td>Pan</td>
<td>117</td>
</tr>
<tr>
<td>Volume</td>
<td>117</td>
</tr>
<tr>
<td>Track name</td>
<td>117</td>
</tr>
<tr>
<td>Detail Area</td>
<td>117</td>
</tr>
<tr>
<td>Name</td>
<td>118</td>
</tr>
<tr>
<td>Track Color</td>
<td>118</td>
</tr>
<tr>
<td>Channel</td>
<td>118</td>
</tr>
<tr>
<td>Drumset</td>
<td>118</td>
</tr>
<tr>
<td>Pitch</td>
<td>118</td>
</tr>
<tr>
<td>Volume</td>
<td>118</td>
</tr>
<tr>
<td>Pan</td>
<td>118</td>
</tr>
<tr>
<td>Pan and Channel</td>
<td>118</td>
</tr>
<tr>
<td>Reverb / Chorus</td>
<td>118</td>
</tr>
<tr>
<td>Mute Voice</td>
<td>118</td>
</tr>
<tr>
<td>Hide Details Button</td>
<td>118</td>
</tr>
<tr>
<td>Sound</td>
<td>118</td>
</tr>
<tr>
<td>Mid-staff sound change (pizz., con sordino, etc.)</td>
<td>119</td>
</tr>
</tbody>
</table>
## PIANO ROLL EDITOR

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Opening the Piano Roll Editor</td>
<td>119</td>
</tr>
<tr>
<td>Overview</td>
<td>120</td>
</tr>
<tr>
<td>Navigation</td>
<td>121</td>
</tr>
<tr>
<td>Selecting Notes</td>
<td>121</td>
</tr>
<tr>
<td>Editing Notes</td>
<td>121</td>
</tr>
<tr>
<td>Controls</td>
<td>122</td>
</tr>
<tr>
<td>First Row</td>
<td>122</td>
</tr>
<tr>
<td>Second Row</td>
<td>122</td>
</tr>
<tr>
<td>Keyboard</td>
<td>124</td>
</tr>
<tr>
<td>Customization</td>
<td>124</td>
</tr>
</tbody>
</table>

## PLAY MODE

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Playback toolbar</td>
<td>124</td>
</tr>
<tr>
<td>Playback commands</td>
<td>124</td>
</tr>
<tr>
<td>Sampling playback</td>
<td>124</td>
</tr>
<tr>
<td>During playback</td>
<td>124</td>
</tr>
<tr>
<td>Loop playback</td>
<td>124</td>
</tr>
<tr>
<td>Play panel</td>
<td>125</td>
</tr>
</tbody>
</table>

## SOUNDFONTS AND SFZ FILES

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>SoundFonts</td>
<td>125</td>
</tr>
<tr>
<td>Uninstall</td>
<td>125</td>
</tr>
<tr>
<td>SFZ</td>
<td>125</td>
</tr>
<tr>
<td>Uninstall</td>
<td>125</td>
</tr>
<tr>
<td>Synthesizer</td>
<td>126</td>
</tr>
<tr>
<td>Install a SoundFont</td>
<td>126</td>
</tr>
<tr>
<td>Uninstall</td>
<td>126</td>
</tr>
<tr>
<td>Install an SFZ</td>
<td>126</td>
</tr>
<tr>
<td>Uninstall</td>
<td>126</td>
</tr>
<tr>
<td>List of downloadable soundfonts</td>
<td>126</td>
</tr>
<tr>
<td>GM SoundFonts</td>
<td>126</td>
</tr>
<tr>
<td>Orchestral soundfonts</td>
<td>126</td>
</tr>
<tr>
<td>Piano soundfonts</td>
<td>127</td>
</tr>
<tr>
<td>SF2 Pianos</td>
<td>127</td>
</tr>
<tr>
<td>SFZ Pianos</td>
<td>127</td>
</tr>
<tr>
<td>Unzipping downloaded soundfonts</td>
<td>127</td>
</tr>
<tr>
<td>Troubleshooting</td>
<td>128</td>
</tr>
<tr>
<td>See also</td>
<td>128</td>
</tr>
<tr>
<td>External links</td>
<td>128</td>
</tr>
</tbody>
</table>

## SWING

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply swing to a score section</td>
<td>128</td>
</tr>
<tr>
<td>Triplets in tempo marking</td>
<td>128</td>
</tr>
<tr>
<td>Return to straight rhythm</td>
<td>128</td>
</tr>
<tr>
<td>Apply swing globally</td>
<td>128</td>
</tr>
<tr>
<td>External links</td>
<td>130</td>
</tr>
</tbody>
</table>

## SYNTHESIZER

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview</td>
<td>130</td>
</tr>
<tr>
<td>Save/Load Synthesizer settings</td>
<td>130</td>
</tr>
<tr>
<td>Fluid</td>
<td>130</td>
</tr>
<tr>
<td>To load a soundfont</td>
<td>130</td>
</tr>
<tr>
<td>To reorder the soundfonts</td>
<td>130</td>
</tr>
<tr>
<td>To remove a soundfont</td>
<td>130</td>
</tr>
<tr>
<td>Zerberus</td>
<td>130</td>
</tr>
<tr>
<td>Volume</td>
<td>131</td>
</tr>
<tr>
<td>Effects</td>
<td>131</td>
</tr>
<tr>
<td>Zita 1 reverb</td>
<td>131</td>
</tr>
<tr>
<td>SC4 compressor</td>
<td>131</td>
</tr>
<tr>
<td>Tuning</td>
<td>132</td>
</tr>
<tr>
<td>Dynamics (versions 3.1 and above)</td>
<td>133</td>
</tr>
<tr>
<td>See also</td>
<td>133</td>
</tr>
</tbody>
</table>

## TEMPO

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a tempo marking</td>
<td>134</td>
</tr>
<tr>
<td>Edit tempo</td>
<td>134</td>
</tr>
<tr>
<td>Edit tempo text</td>
<td>135</td>
</tr>
<tr>
<td>Overriding the tempo marking</td>
<td>135</td>
</tr>
<tr>
<td>Ritardando and accelerando playback</td>
<td>135</td>
</tr>
<tr>
<td>Fermatas</td>
<td>135</td>
</tr>
<tr>
<td>See also</td>
<td>135</td>
</tr>
</tbody>
</table>

## DYNAMICS

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add a dynamic</td>
<td>136</td>
</tr>
<tr>
<td>Adjust properties</td>
<td>136</td>
</tr>
<tr>
<td>To edit the velocity of a dynamic</td>
<td>136</td>
</tr>
<tr>
<td>To adjust the range</td>
<td>136</td>
</tr>
<tr>
<td>Customize a dynamic</td>
<td>136</td>
</tr>
<tr>
<td>Single Note Dynamics (SND)</td>
<td>136</td>
</tr>
<tr>
<td>External links</td>
<td>137</td>
</tr>
</tbody>
</table>

## CAPO PLAYBACK

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>137</td>
</tr>
</tbody>
</table>
# TEXT

## TEXT BASICS
- Add text
- Text formatting
- Adjust position of text objects
- Text anchors

## TEXT EDITING
- Enter/exit text edit mode
- Keyboard shortcuts
- Symbols and special characters
- Special character shortcuts
- See also

## TEXT STYLES AND PROPERTIES
- Text styles
- Text objects
- Save and load text styles
- See also

## STAFF AND SYSTEM TEXT
- Staff text
- Staff text properties
- System text
- System text properties
- See also
- External links

## CHORD SYMBOLS
- Enter a chord symbol
- Keyboard commands
- Chord symbol syntax
- Edit a chord symbol
- Transpose chord symbols
- Chord symbol text
- Chord symbol style
- Appearance
- Note spelling
- Automatic Capitalization
- Positioning
- Caps
- Nashville Number System
- Roman Numeral Analysis
- Enter RNA
- Examples of RNA
- External Links

## FINGERING
- Add fingering to a single note
- Add fingering to several notes
- Easy fingering input mode (version 3.1 and above)
- Adjust position of fingering
- Single fingering
- Multiple fingering
- Edit fingering text

## LYRICS
- Enter a lyrics line
- First line
- Subsequent lines
- Special characters
- Verse numbers
- Melisma
- Ellipses (Lyric) slur / Synalepha
- Edit Lyrics
- Adjust properties of lyrics
- Adjust position of individual lyrics lines
- Copy lyrics to clipboard
- Paste lyrics from clipboard
- See also
- External links

## REHEARSAL MARKS
- Add a rehearsal mark
- Manual Placement
- Automatic placement
- Add an alphanumeric rehearsal mark
- Add a measure-number rehearsal mark
- Automatically resequence rehearsal marks
- Text style
- Search for a rehearsal mark
- See also
### ADVANCED TOPICS

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACCESSIBILITY</td>
<td>169</td>
</tr>
<tr>
<td>Introduction</td>
<td>169</td>
</tr>
<tr>
<td>Initial setup</td>
<td>169</td>
</tr>
<tr>
<td>Finding your way around</td>
<td>169</td>
</tr>
<tr>
<td>The score window</td>
<td>170</td>
</tr>
<tr>
<td>Score reading</td>
<td>170</td>
</tr>
<tr>
<td>Moving forwards or backwards in time</td>
<td>171</td>
</tr>
<tr>
<td>Moving between notes at a given point in time</td>
<td>171</td>
</tr>
<tr>
<td>Filtering score reading</td>
<td>171</td>
</tr>
<tr>
<td>Score playback</td>
<td>171</td>
</tr>
<tr>
<td>Score creation and editing</td>
<td>171</td>
</tr>
<tr>
<td>Creating a new score</td>
<td>171</td>
</tr>
<tr>
<td>Note input</td>
<td>172</td>
</tr>
<tr>
<td>Selection</td>
<td>172</td>
</tr>
<tr>
<td>Palettes</td>
<td>172</td>
</tr>
<tr>
<td>Menus and Shortcuts</td>
<td>172</td>
</tr>
<tr>
<td>Customization</td>
<td>173</td>
</tr>
<tr>
<td>External links</td>
<td>173</td>
</tr>
<tr>
<td>ALBUMS</td>
<td>173</td>
</tr>
<tr>
<td>Create album</td>
<td>173</td>
</tr>
<tr>
<td>Load album</td>
<td>174</td>
</tr>
<tr>
<td>Print album</td>
<td>174</td>
</tr>
<tr>
<td>Join scores</td>
<td>174</td>
</tr>
<tr>
<td>Save album</td>
<td>174</td>
</tr>
<tr>
<td>AUTOMATIC PLACEMENT</td>
<td>174</td>
</tr>
<tr>
<td>Default position</td>
<td>174</td>
</tr>
<tr>
<td>Change the default placement of an element</td>
<td>174</td>
</tr>
<tr>
<td>Manual adjustments</td>
<td>174</td>
</tr>
<tr>
<td>Adjust position of element</td>
<td>174</td>
</tr>
<tr>
<td>Place element above/below staff</td>
<td>175</td>
</tr>
<tr>
<td>Disable automatic placement</td>
<td>175</td>
</tr>
<tr>
<td>Stacking order</td>
<td>175</td>
</tr>
<tr>
<td>CROSS-STAFF NOTATION</td>
<td>175</td>
</tr>
<tr>
<td>See also</td>
<td>176</td>
</tr>
<tr>
<td>External links</td>
<td>176</td>
</tr>
<tr>
<td>EARLY MUSIC FEATURES</td>
<td>176</td>
</tr>
<tr>
<td>Unbarred (or unmetered) notation</td>
<td>176</td>
</tr>
<tr>
<td>Example</td>
<td>176</td>
</tr>
<tr>
<td>Mensurstrich</td>
<td>176</td>
</tr>
<tr>
<td>Ambitus</td>
<td>177</td>
</tr>
<tr>
<td>Mensural time signatures</td>
<td>177</td>
</tr>
<tr>
<td>See also</td>
<td>178</td>
</tr>
<tr>
<td>FIGURED BASS</td>
<td>178</td>
</tr>
<tr>
<td>Adding a new figured bass indication</td>
<td>178</td>
</tr>
<tr>
<td>Text format</td>
<td>178</td>
</tr>
<tr>
<td>Sigils</td>
<td>178</td>
</tr>
<tr>
<td>NOTEHEADS</td>
<td>200</td>
</tr>
<tr>
<td>-----------</td>
<td>-----</td>
</tr>
<tr>
<td>Notehead groups</td>
<td>200</td>
</tr>
<tr>
<td>Change notehead group</td>
<td>200</td>
</tr>
<tr>
<td>Change notehead type</td>
<td>200</td>
</tr>
<tr>
<td>Shared noteheads</td>
<td>200</td>
</tr>
<tr>
<td>Change offset noteheads to shared</td>
<td>200</td>
</tr>
<tr>
<td>Examples of notehead sharing</td>
<td>201</td>
</tr>
<tr>
<td>Remove duplicate fret marks</td>
<td>201</td>
</tr>
<tr>
<td>External links</td>
<td>201</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>PARTS</th>
<th>201</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create all parts</td>
<td>201</td>
</tr>
<tr>
<td>Create specific parts</td>
<td>202</td>
</tr>
<tr>
<td>Customize parts</td>
<td>202</td>
</tr>
<tr>
<td>Add instruments to a part</td>
<td>203</td>
</tr>
<tr>
<td>Remove instruments from a part</td>
<td>203</td>
</tr>
<tr>
<td>Select staves for an instrument</td>
<td>203</td>
</tr>
<tr>
<td>Select voices for an instrument</td>
<td>203</td>
</tr>
<tr>
<td>Delete a Part</td>
<td>204</td>
</tr>
<tr>
<td>Export parts</td>
<td>204</td>
</tr>
<tr>
<td>Save parts</td>
<td>204</td>
</tr>
<tr>
<td>Print a part</td>
<td>204</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>PLUGINS</th>
<th>204</th>
</tr>
</thead>
<tbody>
<tr>
<td>What are Plugins?</td>
<td>204</td>
</tr>
<tr>
<td>Installation</td>
<td>204</td>
</tr>
<tr>
<td>Windows</td>
<td>204</td>
</tr>
<tr>
<td>macOS</td>
<td>204</td>
</tr>
<tr>
<td>Linux</td>
<td>209</td>
</tr>
<tr>
<td>Enable/disable plugins</td>
<td>205</td>
</tr>
<tr>
<td>Create/edit/run plugins</td>
<td>205</td>
</tr>
<tr>
<td>Plugins installed by default</td>
<td>205</td>
</tr>
<tr>
<td>ABC Import</td>
<td>206</td>
</tr>
<tr>
<td>Notes → Color Notes</td>
<td>206</td>
</tr>
<tr>
<td>Create Score</td>
<td>206</td>
</tr>
<tr>
<td>ied/Chili</td>
<td>206</td>
</tr>
<tr>
<td>Notes → Note Names</td>
<td>206</td>
</tr>
<tr>
<td>Panel</td>
<td>206</td>
</tr>
<tr>
<td>random/random2</td>
<td>206</td>
</tr>
<tr>
<td>run</td>
<td>206</td>
</tr>
<tr>
<td>scoretst</td>
<td>206</td>
</tr>
<tr>
<td>Score/View</td>
<td>206</td>
</tr>
<tr>
<td>Walk</td>
<td>206</td>
</tr>
<tr>
<td>See also</td>
<td>206</td>
</tr>
<tr>
<td>External links</td>
<td>206</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>PREFERENCES</th>
<th>206</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td>207</td>
</tr>
<tr>
<td>Canvas</td>
<td>207</td>
</tr>
<tr>
<td>Note input</td>
<td>208</td>
</tr>
<tr>
<td>&quot;Note Input&quot;</td>
<td>208</td>
</tr>
<tr>
<td>MIDI Remote Control</td>
<td>209</td>
</tr>
<tr>
<td>Score</td>
<td>209</td>
</tr>
<tr>
<td>I/O</td>
<td>209</td>
</tr>
<tr>
<td>PortAudio (API / Device)</td>
<td>210</td>
</tr>
<tr>
<td>MIDI Input/Output /Output Latency</td>
<td>210</td>
</tr>
<tr>
<td>Jack Audio Server</td>
<td>210</td>
</tr>
<tr>
<td>Audio Engine</td>
<td>210</td>
</tr>
<tr>
<td>Import</td>
<td>210</td>
</tr>
<tr>
<td>Export</td>
<td>211</td>
</tr>
<tr>
<td>Shortcuts</td>
<td>211</td>
</tr>
<tr>
<td>Update</td>
<td>212</td>
</tr>
<tr>
<td>Advanced</td>
<td>213</td>
</tr>
<tr>
<td>See also</td>
<td>213</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>RECOVERED FILES</th>
<th>213</th>
</tr>
</thead>
<tbody>
<tr>
<td>Saving after session recovery</td>
<td>214</td>
</tr>
<tr>
<td>Finding recovered files</td>
<td>214</td>
</tr>
<tr>
<td>See also</td>
<td>214</td>
</tr>
<tr>
<td>External links</td>
<td>214</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SCORE COMPARISON</th>
<th>214</th>
</tr>
</thead>
<tbody>
<tr>
<td>Introduction</td>
<td>214</td>
</tr>
<tr>
<td>Select score</td>
<td>215</td>
</tr>
<tr>
<td>Choose view</td>
<td>215</td>
</tr>
<tr>
<td>View comparison</td>
<td>215</td>
</tr>
<tr>
<td>Leave comparison</td>
<td>215</td>
</tr>
<tr>
<td>Example</td>
<td>215</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SCORE PROPERTIES</th>
<th>215</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit meta tags</td>
<td>215</td>
</tr>
<tr>
<td>Pre-existing meta tags</td>
<td>216</td>
</tr>
<tr>
<td>Entering Work / Movement / Part metadata</td>
<td>216</td>
</tr>
<tr>
<td>Header/Footer</td>
<td>217</td>
</tr>
<tr>
<td>See also</td>
<td>217</td>
</tr>
</tbody>
</table>
## Staff / Part Properties 217

- Staff Types 218
- Staff / Part Properties: all staves 218
- Staff / Part Properties: plucked strings only 220

### Advanced Style Properties 220
- Template 220
- Standard and Percussion staff options 220
- Tablature staff options 220
- Tablature staff options: Fret Marks 220
- Tablature staff options: Note Values 220
- Preview 222

### Change instrument 222

### External links 222

## Staff Type Change 222

- Add a Staff Type Change 223
- Staff type change properties 223
- Example 223

## Timeline 224

### Overview 224
- Meta labels 224
- Meta rows 224
- Main grid 224

### Basic Interaction 224
- Select a measure 224
- Select multiple measures 224
- [Ctrl] selection 224
- [Shift] selection 224
- Clearing selection 225
- Meta values selection 225

### Scrolling 225
- Standard scrolling 225
- [Shift] scrolling 225
- [Alt] scrolling 225

### Labels Interaction 225
- Rearranging meta labels 225
- Collapsing the meta labels 225
- Hiding instruments 225

### Zooming 226

### Context Menus 226
- Meta labels context menu 226
- Meta rows context menu 226

### Tools 226
- Transpose 226
- Explode 226
- Implode 227
  - Apply implode to a single staff 227
  - Apply implode to multiple staves 227
- Voices 227
  - Measure 227
  - Remove selected range 227
- Fill with slashes 228
- Toggle rhythmic slash notation 228
- Respell pitches 228
- Regroup Rhythms 229
- Resequence rehearsal marks 229
- Unroll Repeats (version 3.1 and above) 229
- Copy lyrics to clipboard 229
- Image capture 229
- Remove empty trailing measures 229

### See Also 229

### External links 229

## Support 229

### Helping to Improve Translations 229
- Software translation 229
- Website and handbook translation 229

### Revert to Factory Settings 230
- Via menu 230
- Via command line 230
  - Instructions for Windows 230
  - Instructions for MacOS 230
  - Instructions for Linux 231

### See Also 231
Hardware incompatibilities
Software incompatibilities
  AVG Internet Security hangs MuseScore
  Font problem on macOS
  Font problem on Linux
  Save As dialog empty on Linux

GLOSSARY

A
B
C
D
E
F
G
H
I
J
K
L
M
N
O
P
Q
R
S
T
U
V

External links
Começando

Este capítulo ajuda você a instalar e executar o MuseScore pela primeira vez. Ele apresentará os vários recursos de aprendizado e ajuda.

Aprendendo a utilizar o MuseScore

O MuseScore fornece vários recursos de aprendizado para ajudar o novo usuário a começar.

Guias

Quando você executa o MuseScore pela primeira vez, a Janela de Inicialização aparece para ajudá-lo a configurar alguns recursos básicos do software. Um desses recursos é chamado Guias, e, como o nome sugere, ele oferece uma visita guiada ao programa.

- Para ativar este recurso, na página Guias do Assistente de Inicialização, marque "Sim" em resposta a "Você gostaria de ver as guias?"

Isso permitirá que a Guia seja executada quando o programa for aberto, apresentando os principais recursos da interface do usuário.

- Para finalizar a guia: pressione o botão Fechar.
- Para parar as guias mostradas quando você abre o MuseScore: Desmarque a opção "Continuar mostrando guias".
- Para habilitar as Guias novamente (quando o programa reabrir): Selecione Ajuda → Guias → Mostrar Guias.
- Para visualizar todas as guias novamente (quando o programa reabrir): Selecione Ajuda → Guias → Redefinir Guias.

Guias oferecidas atualmente:

- Introdução à interface do usuário.
- Entrada de notas e pausas na partitura.
- Inserindo símbolos de uma paleta.
Navegando na partitura com Linha do Tempo.
Navegando na partitura com o teclado.
Adicionar compassos de espera.
Posicionamento automático de símbolos.
Modificar as propriedades com o Inspetor.
Selecionar elementos.
Adicionar e edite linhas na partitura.

Partitura "Introdução"

A partitura interativa Introdução é uma introdução prática aos fundamentos de inserir elementos em uma partitura. Quando você abre o MuseScore pela primeira vez, ela será exibida na janela principal da Tela Inicial: basta clicar para abri-la. Siga as instruções escritas em azul e você será guiado pelas etapas básicas da escrita de partitura.

Nota: Se você não conseguir visualizar a partitura "Introdução", poderá encontrá-la no painel do lado direito da Tela Inicial. Clique nas setas para a direita ou esquerda para navegar pelas opções até aparecer a partitura.

Vídeos de instrução

O MuseScore oferece um conjunto completo de vídeos de instruções, cada um cobrindo um assunto específico. Você pode acessar esses vídeos de várias maneiras.

- Na página inicial do MuseScore, em MuseScore.org: Suporte/Tutoriais
- Na Tela Inicial: navegue até a página "Vídeos" no painel à direita.
- Use a lista de links na seção Vídeos (abaixo).
- Procure diretamente por “MuseScore in Minutes” no YouTube

Outros tutoriais

Na seção Tutoriais, no musescore.org você também encontrará tutoriais sobre tópicos mais específicos (e.g. MuseScore Drumline).

Vídeos

- Lição 1 — Configuração da partitura
- Lição 2 — Trabalhando com o MuseScore
- Lição 3 — Entrada de Nota
- Lição 4 — entrada de teclado MIDI
- Lição 5 — Mais ideias de entrada
- Lição 6 — Texto, Letras e Acordes
- Lição 7 — Notação de Tablatura e Percussão
- Lição 8 — Repetições e terminações, parte 1
- Lição 8 — Repetições e terminações, parte 2
- Lição 10 — Articulações, Dinâmica e Texto
- Lição 11 — Layout e Peças

Suporte

Se você tiver algum problema ao trabalhar com o MuseScore, há várias maneiras de obter ajuda e suporte.

Manual

Para acessar o Manual:

- Pelo site do MuseScore: selecione Suporte → Manual, no menu.
- Pelo programa do MuseScore: selecione Ajuda → Manual online, no menu.

Você pode navegar pelo Manual usando os menus ou fazer uma busca.

Ajuda contextual

Se você selecionar um elemento na sua partitura e pressionar F1, uma página da Web é aberta exibindo uma lista de links associados a esse elemento no Manual.

Fóruns

O MuseScore oferece várias opções de Fóruns on-line para colaboração do usuário. Você pode encontrar uma resposta aqui para o seu problema entre as postagens existentes. Uma pesquisa geral no site retornará uma lista de acessos relevantes para todos os fóruns e o Manual.
Como...

Algumas tarefas requerem o uso de várias técnicas diferentes. Estas podem ser difíceis de encontrar uma resposta no Manual. Soluções talvez sejam encontradas na seção Como...

Postar uma pergunta

Se não conseguir encontrar a resposta para o seu problema, você pode fazer uma pergunta no fórum suporte e relatários de bugs.

Quando você postar sua pergunta:

- Tente ser o mais preciso possível ao descrever o que você quer fazer e quais etapas você já tentou.
- Anexe a partitura que mostra o problema. Isso tornará muito mais fácil para os outros entenderem o problema — utilize a opção "File attachments" (anexos de arquivo) na parte inferior da página, logo abaixo dos botões Save e Preview.

Reportar um erro

Se você encontrar algo que você acha que é um bug, o primeiro passo é postá-lo no fórum suporte e relatários de bugs. Isso permitirá que outras pessoas ajudem a verificar se é um bug genuíno e aconselharão soluções alternativas, para que você possa continuar com a criação de partituras. Você encontrará mais detalhes sobre isso em Relatórios de bugs e solicitações de recursos.

Installation

MuseScore exists for various different operating systems, including Windows and macOS, as well as many Linux distributions and several BSD variants. All are available from the MuseScore download page.

Installation

When you have downloaded the software, follow the installation instructions for your operation system:

Install on Windows.
Install on macOS.
Install on Linux.
Install on Chromebook.

Initial preferences

The first time you start MuseScore after the installation, you will be asked to confirm your basic preferences:

![Help us improve MuseScore](image)
First, you can choose to authorize MuseScore (3.4 or later) to collect usage data, click on Yes, send anonymous reports or Don't send to continue:

The settings for language is retrieved from your installation, and should normally not need to be changed. Just click Next to continue:

followed by:
Select your keyboard layout in the drop down list, click Next to continue:

You will be now asked if you wish to take the Tours. If you are new to MuseScore keep the 'Yes' option checked, and click Next to continue:
Finally click Finish to start MuseScore.

Install on Windows

Install

If you’re on Windows 10, a 32-bit version of MuseScore can be installed from the Windows Store. Clicking here will open MuseScore’s page in the Store app. There you will only have to click Get the app > and MuseScore will be downloaded, installed and subsequently automatically updated.

Otherwise you can get the Windows installer from the download page of the MuseScore website. Click on the link to start the download (pick your choice of 64-bit or 32-bit). Your Internet browser will ask you to confirm that you want to download this file. Click Save File.

When the download finishes, double-click on the file to start the installation. Windows may prompt you with a security window to confirm this before running the software. Click Run to continue.

The installation process will now start

If you click Cancel, here or later, you’ll see:
If instead you click Next to continue, the setup wizard displays the terms of the free software license.

Read the terms of the license, make sure the box next to "I accept the terms in the License Agreement" is checked, and click Next to continue. Next the installer will ask you to confirm the location in which to install MuseScore.
If you are installing a newer version of MuseScore but still want to keep the old version on your computer, then you should change the folder (note that MuseScore 3 can coexist with MuseScore 2 and 1 with no changes needed). Otherwise click Next to continue.

Click Install to continue.

Give the setup wizard a few minutes to install the necessary files and configurations. You'll see

and finally
Click Finish to exit the installer. You may delete the installer file you downloaded.

Start MuseScore

To start MuseScore, from the menu, select Start → All Programs → MuseScore 3 → MuseScore 3.

Advanced users: Silent or unattended install

- You can install MuseScore silently with the following command

  msiexec /i MuseScore-X.Y.msi /qb-

Uninstall

You can uninstall MuseScore from the menu by selecting Start → All Programs → MuseScore 3 → Uninstall MuseScore; or via Windows' Control Panel. Note that this will not remove your scores nor your MuseScore settings.

Troubleshooting

The installer might be blocked by the system. If you don't manage to install MuseScore, right click the downloaded file and click Properties. If there is a message "This file came from another computer and might be blocked to help protect this computer", click on "Unblock", "OK" and double click on the downloaded file again.

External links

- How to install MuseScore on Windows without administrator rights
- How to run MuseScore as Administrator on Windows
- How to fix MuseScore installation error on Windows
- MSI command-line options
- Standard installer command-line options

Install on macOS

Install

You will find the DMG (disk image) file on the download page of the MuseScore website. Click on the macOS link to start the download. When the download is complete, double-click the DMG file to mount the disk image.
Drag and drop the MuseScore icon to the Applications folder icon.

If you are not logged in as administrator, macOS may ask for a password: click Authenticate and enter your password to proceed.

When the application has finished copying, eject the disk image. You can now launch MuseScore from the Applications folder, Spotlight, or Launchpad.

Note: As of macOS 10.15 "Catalina", the system has to be told to permit MuseScore to be allowed to access user parts of the file system. The first time you use it on Catalina, it will ask you if you wish to permit it; of course, answer "yes", but if you bypass this by accident, you can set it via System Preferences > Security and Privacy > Privacy > Files and Folders. Unlock with your Admin credentials, then navigate to MuseScore (whichever version(s) you have and want), add it or them to the list of apps, and select "Documents" and "Downloads" folders, or as you prefer.

Uninstall

Simply delete MuseScore from Applications folder (Admin access will be required to do that, however).

Install with Apple Remote Desktop

You can deploy MuseScore to multiple computers with the "Copy" feature of ARD. Since MuseScore is a self-contained application you can simply copy the application to the '/Application' folder on the target machines. It is also possible to install multiple versions of the application as long as their names differ.

Install on Linux

As of MuseScore 2.0.3 you can, for the first time, get hold of a copy for Linux straight from the download page, just like Windows and Mac users. This is possible thanks to the AppImage packaging format, which runs on pretty much all Linux distributions. If you prefer, there is still the option to get it the traditional way via your distribution's package manager (but you may have to wait for it to get packaged by the relevant maintainer). Of course, you can always build from source.

AppImage

The AppImage format is a new way of packaging Linux applications. AppImages are portable - they don't have to be installed - and they run on pretty much any Linux distribution. Dependencies are included in the one AppImage file.
Step 1 - Download

Before you download an AppImage, you need to know your processor's architecture. These terminal commands will show it:

```
arch
```

or

```
uname -m
```

The output will be something like "i686", "x86_64" or "armv7":

- i686 (or similar) - 32-bit Intel/AMD processor (found on older machines).
- x86_64 (or similar) - 64-bit Intel/AMD processor (modern laptop and desktop computers, most Chromebooks).
- armv7 (or later) - ARM processor (phones & tablets, Raspberry Pi 2/3 running Ubuntu Mate, some Chromebooks, usually 32-bit at present).

Now you can head over to the download page and find the AppImage that best matches your architecture. Once downloaded, the file will be named "MuseScore-X.Y.Z-$(arch).AppImage".

Step 2 - Give execute permission

Before you can use the AppImage you need to give permission for it to be run as a program.

**From the Terminal:**

This command gives the user (u) permission to execute (x) the AppImage. It works on all Linux systems.

```
cd ~/
chmod u+x MuseScore*.AppImage
```

Note: Use the "cd" command to change directory to wherever you saved the AppImage.

**From a File Manager:**

If you prefer to avoid the command line, there is usually a way give execute permission from inside a File Manager.

In GNOME Files (Nautilus), simply:

1. Right-click on the AppImage and select "Properties".
2. Open the "Permissions" tab.
3. Enable the option labelled "Allow executing file as a program".

The process may be slightly different in other file managers.

Step 3 - Run it!

Now you should be able to run the program simply by double-clicking on it!

When you downloaded the AppImage it was probably saved in your Downloads folder, but you can move somewhere else it at any time (e.g. you could put it on your desktop for easy access). If you ever want to remove it then simply delete it.

**Installing the AppImage (optional)**

You can run the AppImage without installing it, but you must install it if you want it to be completely integrated with your desktop environment. This has the following benefits:

- Adds the AppImage to your Applications Menu or Launcher
- Sets the correct icons for MuseScore's files (MSCZ, MSCX) and for MusicXML files (MXL, XML)
- Makes the AppImage available via your File Manager's right-click "Open with..." menu

To install it, run the AppImage from the Terminal with the "install" option (see immediately below). This copies a desktop file and various icons to your computer. If you want to remove them you will need to run the "remove" option before you delete the AppImage. This does not affect any scores created with any version of MuseScore.

**Using command line options**

Running the AppImage from the Terminal allows you to use various command line options. The AppImage has some special options in addition to MuseScore's normal command line options.

You will need to change directory (cd) to wherever the AppImage is saved your system, for example:

```
cd ~/Desktop
```
MuseScore* AppImage [option...]

Or give the path to the AppImage:

~/desktop/MuseScore*.AppImage [option...]

Use the "--help" and "man" options to get more information about the available command line options:

MuseScore* AppImage --help  # displays a complete list of command line options
MuseScore* AppImage man  # displays the manual page (explains what the options do)

**Distribution Packages**

**Debian**

(Ideally before, otherwise while or after) installing MuseScore itself, you can install one or more soundfont packages (if none is installed, the dependencies will pull in a suitable soundfont automatically):

- musescore-general-soundfont-small: the standard MuseScore_General soundfont in SF3 format, as shipped with MuseScore for other operating systems
- musescore-general-soundfont: the MuseScore_General HQ soundfont in SF3 format, as available via the Extensions manager
- musescore-general-soundfont-lossless: the MuseScore_General HQ soundfont in uncompressed SF2 format; takes up a lot more space on your hard disc, but offers the highest sound quality and extremely fast startup times
- fluid3mono-gm-soundfont: the old soundfont shipped with MuseScore 2.0 (antecessor of MuseScore_General), use only if resources are very tight or you need it
- timg6mb-soundfont: the old soundfont shipped with MuseScore 1.3; cannot substitute the others; use only if you need it; extremely tiny

Note: only the MuseScore_General soundfont (HQ or regular) supports single-note dynamics (SND), and you need at least version 0.1.6 of those soundfonts (from unstable or backports) for SND support!

The command `sudo update-alternatives --config MuseScore_General.sf3` can be used at any time to select the default soundfont used by MuseScore if you install more than one (note timg6mb-soundfont cannot be selected here).

Then, install the `musescore3` package for MuseScore 3.x (the current stable version) or `musescore` for MuseScore 2.x (there’s also `musescore-snapshot` for the unstable developer preview). The packages are available in the following distributions:

- musescore3: sid (unstable), bullseye (testing/Debian 11), buster-backports (stable/Debian 10), stretch-backports-sloppy (oldstable/Debian 9)
- musescore: buster (stable/Debian 10), stretch-backports (oldstable/Debian 9), jessie-backports-sloppy (oldoldstable/Debian 8)
- musescore-snapshot: experimental (usable on unstable)

See [https://backports.debian.org/Instructions/](https://backports.debian.org/Instructions/) for instructions on how to add an official Debian backports repository to your system and install packages from there.

Note: without the appropriate backports, older versions may be available: MuseScore 2.0.3 on stretch, MuseScore 1.3 on jessie. Using the latest 2.3.2 version for 2.x-format scores instead (or conversion to 3.x) is strongly recommended!

**Fedora**

1. Import the GPG key:

   ```sh
su
   rpm --import http://prereleases.musescore.org/linux/Fedora/RPM-GPG-KEY-Seve
   ```

2. Go to the download page of the MuseScore website. Click on the link for the stable Fedora download and choose the correct rpm package for your architecture.

3. Depending on your architecture, use one of the two sets of commands to install MuseScore

   - for arch i386
     ```sh
     su
     yum localinstall musescore-X.Y-1.fc10.i386.rpm
     ```

   - for arch x86_64
     ```sh
     su
     yum localinstall musescore-X.Y-1.fc10.x86_64.rpm
     ```

If you have difficulty with sound, see [Fedora 11 and sound](https://wiki.fedoraproject.org/wiki/Musescore/11_and_sound).
See also the hints for the various distributions on the download page.

KDE neon 18.04 (bionic)

The KDE neon packages are built on a different repository than the normal Ubuntu PPAs, as this is the only way for us to build packages for KDE neon. Due to limitations of the OpenSuSE Buildservice used, this currently only provides amd64 (64-bit PC) packages, no ARM packages (Slimbook or Pinebook remix).

All commands listed below must be entered in a terminal, one line each.

1. Remove the Ubuntu PPAs (all three of them) from your system if you've ever configured it before. This is generally in /etc/apt/sources.list or one of the files below /etc/apt/sources.list.d/; if you used add-apt-repository (the recommended way) to enable the PPA, you can remove them with:
   ```sh
sudo rm -f /etc/apt/sources.list.d/mscore-ubuntu-ubuntu-mscore*
   ```
   KDE neon is not compatible with the Ubuntu PPAs!

2. Install a few standard packages (usually they are already there, but just in case they aren't) to be able to securely download the repository signature key:
   ```sh
   sudo apt-get install wget ca-certificates
   ```

3. Download (via secure HTTPS connection) and install the repository signing key:
   ```sh
   wget -O - https://download.opensuse.org/repositories/home:/mirabile:/mscore/bionic-neon/Release.key | sudo apt-key add
   ```

4. Enable the repository:

   ```sh
   echo deb https://download.opensuse.org/repositories/home:/mirabile:/mscore/bionic-neon./ | sudo tee /etc/apt/sources.list.d/mscore.list
   ```

5. Make the new packages available:

   ```sh
   sudo apt-get update
   ```

Now, it's time to install one or more soundfont packages (ideally install the one you want before installing MuseScore):

- musescore-general-soundfont-small: the standard MuseScore_General soundfont in SF3 format, as shipped with MuseScore for other operating systems
- musescore-general-soundfont: the MuseScore_General HQ soundfont in SF3 format, as available via the Extensions manager
- musescore-general-soundfont-lossless: the MuseScore_General HQ soundfont in uncompressed SF2 format: takes up a lot more space on your hard disc, but offers the highest sound quality and extremely fast startup times
- fluidr3mono-gm-soundfont: the old soundfont shipped with MuseScore 2.0 (antecessor of MuseScore_General), use only if resources are very tight or you need it
- timgm6mb-soundfont: the old soundfont shipped with MuseScore 1.3; cannot substitute the others; use only if you need it; extremely tiny

If you skip this step, a suitable soundfont will be automatically installed when you install MuseScore itself in the final step.

**Note:** only the MuseScore_General soundfont (HQ or regular) supports single-note dynamics (SND), and you need **at least version 0.1.6** of those soundfonts (from our repository) for SND support!

The command `sudo update-alternatives --config MuseScore_General.sf3` can be used at any time to select the default soundfont used by MuseScore if you install more than one (note `timgm6mb-soundfont` cannot be selected here).

Finally, you can install the latest stable version of MuseScore with `sudo apt-get install musescore3` and the old 2.x version with `sudo apt-get install musescore` (the `musescore-snapshot` package with an instable developer preview is also available).

Ubuntu, Kubuntu, Xubuntu, ...

**WARNING:** these instructions are **not** for KDE neon users (see above)!}

MuseScore 2.x (the old version) is available from 18.10 (cosmic) to 19.10 (eoan) out of the box. Older Ubuntu releases carry older versions (18.04 (bionic) has 2.1, 16.04 (xenial) has 2.0, 14.04 (trusty) and 12.04 (precise) have 1.3 and 1.2, respectively). Similar to the Debian instructions, we recommend using the latest 2.3.2 version for old 2.x scores instead, or migrating those scores to MuseScore 3.

Besides the versions supplied by the distribution itself, the MuseScore Debian packager provides newer versions of MuseScore for older Ubuntu releases in official PPAs (package archives).

Please activate the Stable releases of MuseScore 3 repository on your system and then install the `musescore3` package, available for all releases from 18.04 (bionic) onwards. (It is not feasible to provide MuseScore 3 for older Ubuntu releases,
as those lack the minimum Qt version required by MuseScore 3.)

If you wish to install the older MuseScore 2, activate the Stable releases of MuseScore 2 PPA and install the musescore package, available for 12.04 (precise), 14.04 (trusty), 16.04 (xenial), and 18.04 (bionic) onwards. (Some intermediate releases may have slightly older MuseScore versions still available, but it’s best to update to the next LTS.) On the ancient 12.04 (precise) and 14.04 (trusty) releases, this will upgrade the Qt library in your system, which may break unrelated software (and on 12.04 even the C++ libraries are upgraded), mind you; best to upgrade to a newer LTS.

There’s also a MuseScore Nightly Builds (unstable development builds) PPA, from which the daring can install the musescore-snapshot package, for LTS, that is, 18.04 (bionic) only.

**WARNING:** these PPAs are only suitable for Ubuntu/Kubuntu/Xubuntu/… but not for Debian or KDE neon!

As with Debian, you can install one or more soundfont packages (ideally install the one you want before installing MuseScore, but if you don’t, a suitable one will be installed alongside MuseScore):

- musescore-general-soundfont-small: the standard MuseScore_General soundfont in SF3 format, as shipped with MuseScore for other operating systems
- musescore-general-soundfont: the MuseScore_General HQ soundfont in SF3 format, as available via the Extensions manager
- musescore-general-soundfont-lossless: the MuseScore_General HQ soundfont in uncompressed SF2 format: takes up a lot more space on your hard disc, but offers the highest sound quality and extremely fast startup times
- fluidr3mono-gm-soundfont: the old soundfont shipped with MuseScore 2.0 (antecessor of MuseScore_General), use only if resources are very tight or you need it
- timgm6mb-soundfont: the old soundfont shipped with MuseScore 1.3; cannot substitute the others; use only if you need it; extremely tiny

Note: only the MuseScore_General soundfont (HQ or regular) supports single-note dynamics (SND), and you need at least version 0.1.6 of those soundfonts (possibly from the PPA) for SND support!

The command `sudo update-alternatives --config MuseScore_General.sf3` can be used at any time to select the default soundfont used by MuseScore if you install more than one (note timgm6mb-soundfont cannot be selected here).

**External links**

- **How to run the MuseScore AppImage on Linux** - video

**Install on Chromebook**

**Desktop program**

MuseScore’s desktop program will work natively on Chrome OS’s Linux machine called Crostini. Follow the steps described in the video:

1. Install Linux Virtual Machine called Crostini. Go to Settings > Linux > Turn On
2. Download MuseScore AppImage package
3. Configure AppImage to run. Set `chmod +x` for the AppImage file
4. Run AppImage with `/` followed by the MuseScore package file name
5. Install required libraries if necessary, e.g.:
   - `sudo apt-get install libvorbisfile3`
   - `sudo apt-get install libnss3`
6. Install AppImage (using the `install` command line option) to avoid running it from Linux command line each time
7. Enjoy!

Watch this interactive video for more details

**Language, translations, and extensions**

MuseScore works with your “System” language (the one used for most programs, and generally depending on your country and the language settings of the PC, or account).

**Change language**

1. From the menu, select Edit → Preferences… (Mac: MuseScore → Preferences…);
2. In the General tab, select the desired language from the drop-down list in the Language section:
Resource Manager

The Resource Manager is used to install and uninstall extensions, and to handle the update of translations. To access the menu use one of the following options:

- From the menu bar, select Help → Resource Manager.
- From the menu bar, select Edit → Preferences... (Mac: MuseScore → Preferences...), open the General tab, and click on the Update translations button.

Install/uninstall extension

To install or uninstall an extension:
1. Select the Extensions tab in the Resource Manager.
2. Select the extension.
3. Click the Install or Uninstall button.

**Note:** Extensions currently include the MuseScore Drumline (MDL) (as of version 3.0) and the MuseScore General HQ soundfont (as of version 3.1).

**Update translations**

To update translation(s):

1. Select the Languages tab in the Resource Manager.
2. Click on the Update buttons for the language(s) you want to update.

**Note:** Almost all menus and dialogs will switch to the changed/updated translations immediately, but some won't use them until the program is restarted.

**See also**

- [Helping to improve translation](#)

**External links**

- [How to change the language in MuseScore](#)

**Checking for updates**

**Note:** These options are only available in the Mac and Windows versions of MuseScore (except the version from the Windows Store), as only those can be updated directly from MuseScore.org. Linux distributions (and the Windows Store) have different mechanisms to make updates available.

For the versions of MuseScore that can be directly updated, there are two ways to check for updates.

**Automated update check**

1. From the menu, select Edit → Preferences... (Mac: MuseScore → Preferences...);
2. Select the Update tab.
3. Ensure the box marked "Check for new version of MuseScore" is ticked. (It should be ticked by default):

   ![Automated Update Check](image)

   If you enable this option, MuseScore will check for updates on every start. On the Mac and Windows versions (excluding the Windows Store version), this option enables an auto-updater that will download and install updates automatically.

**Check for update**

1. From the menu, select Help → Check for Update:

   ![Check for Update](image)

2. A dialog will appear with the update status: either "No Update Available" or "An update for MuseScore is available:" followed by a link to download it.

**See also**

- [Preferences: Update](#)
Basics

This chapter shows you how to set up a new score using the MuseScore Wizard, and how to enter and edit basic music notation. The various parts of the program window are described—toolbars, Inspector, palettes etc.—as well as viewing and navigation options.

Create a new score

To create a new score, open the New Score Wizard (see Create new score, below): this can also be accessed via the Start Center.

Start Center

This is the window that displays when you open MuseScore for the very first time:

To open the Start Center (if not already visible), use any of the following options:

- Press F4.
- From the menu bar, select File → Start Center...

To stop the Start Center from showing when you open MuseScore:

- From the menu bar, select Edit → Preferences... (Mac: MuseScore → Preferences...) and uncheck "Show start center" in the Program Start section of the General tab.

From the Start Center you can:

- Create a new score (by clicking on the icon with the plus sign).
- View thumbnails of previously-opened scores: click on a thumbnail to open it.
- Open a score from your computer’s file system: click on Open a score ...
- Open the “Getting Started” tutorial score. Use the arrow buttons in the right-hand pane to access the link.
- Search sheet music on musecore.com.
- Access various other facilities (see right-hand pane).

Create new score

To open the New Score Wizard when the Start Center is not open, use one of the following options:

- Click on the New Score icon in the toolbar on the top left of the window;
- Use keyboard shortcut Ctrl+N (Mac: Cmd+N);
- From the menu, select File → New....

Enter score information
Step 1: Enter score information.

Enter the title, composer, or any other information as shown above, then click on Next. This step is optional: you can also add this information after the score is created (see Vertical frame).

Choose template file

Step 2: Choose template file.

In the left column is a list of solo, ensemble and orchestral templates, divided into categories according to musical style. If you have previously stored any custom templates in your user templates folder, these are displayed under the heading, “Custom Templates”. You can also use the Search bar (top left) to find specific templates.

To choose a score template:

- Click on the name of a score template to select it, then click Next; alternatively, just double-click the score template name. This will automatically take you to the next page of the Wizard (see Choose key signature and tempo, below).
- If you wish to create a score template from scratch, click on Choose Instruments (under “General”), then click Next.
Choose instruments (or voice parts)

The **Choose Instruments** window is divided into two columns:

- **The left column** contains a list of instruments, or voice parts to choose from. This list is categorized into instrument families, and clicking a category shows the full list of instruments in each family.
  
  The default entry is "Common instruments" but you can choose from others, including "Jazz instruments" and "Early music". There is a search box at the bottom of the instrument window: typing the name of an instrument there will search for it in "All instruments".

- **The right column** starts off empty, but will eventually contain a list of instruments for your new score in the order that they will appear.

**Add instruments**

To add instruments to the score, use any of the following options:

- Select one or more instruments in the left column and click **Add**.
- Double-click an instrument in the left column.

The instrument names, and their associated staff lines, now appear in the list of instruments in the right column. You can add more instruments or voice parts, as needed. Each instrument added in this way is allocated its own **Mixer** channel.

**Note**: If you want staves to share the same instrument, use the **Add staff** or **Add linked staff** commands instead (see below).

**Add Staff / Add Linked Staff**

To add a staff to an **existing** instrument in the score:

1. Select a staff in the score list on the right-hand side (e.g. see "Staff 1" in the image below). Click **Add Staff** or **Add Linked Staff**.
2. Adjust the **Staff type**, if applicable.
Summary of commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Staff added</th>
<th>Edit staves independently?</th>
<th>Share mixer channel?</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Staff</td>
<td>Unlinked</td>
<td>Yes</td>
<td>Yes</td>
<td>Guitar staff/tab, Piano grand staff</td>
</tr>
<tr>
<td>Add Linked Staff</td>
<td>Linked</td>
<td>No, Edit in one staff updates others</td>
<td>Yes</td>
<td>Guitar staff/tab</td>
</tr>
</tbody>
</table>

See also, Combine pitched staff with tablature.

Change order of instruments

To change the order of instruments (or staves) in the score:

- Click either an instrument name or a staff, in the right-hand column, and use the arrow buttons to move it higher/lower.

Delete an instrument

To delete an instrument, or staff line, from the score

- Select an instrument, or a staff line, in the right-hand column, and click Remove.

Choose key signature and tempo
Step 3: Choose key signature and tempo.

The wizard asks for two things: The initial key signature and tempo of the score. Select any of the former and click Next > to continue. An initial tempo can be set here too.

Choose time signature, pickup measure, and number of measures

Step 4: Choose time signature etc.

You can set your initial time signature here. If the score starts with a pickup measure (also known as an anacrusis or upbeat measure), then mark the Pickup measure checkbox and adjust the "Duration" accordingly. Measures is set to 32 by default: you can change the number here, or add/remove measures later from the score.

Click Finish to create your new score.

Adjustments to score after creation

Any settings you make in the New Score Wizard can always be changed when you start work on the score itself:

Add / delete / adjust measures

- Insert measures.
Append measures.
Delete measures.
Create a pickup measure.

Add/edit text

- Add text (Text basics).
- Edit text.

Change instrument set-up

To add, delete, or change the order of instruments:

- From the menu, select Edit → Instruments...; or use the keyboard shortcut, I. This opens the Instruments dialog which is virtually identical to the Choose Instruments dialog in the New Score Wizard (see above).

See also Change instrument (Staff properties).

Hide a staff

- To hide a staff permanently: Open the Instruments dialog (I) and untick the "Visible" box for that staff.
- To hide a staff under certain conditions: See the "Hide" options in the Score dialog, and Staff Properties.

Adjust layout and formatting

To adjust the distance between staves and systems, set page margins etc., see Layout and formatting.

Templates

A Template is simply a standard MuseScore file that has been stored in one of two "templates" folders: any files in these folders are automatically displayed on the "Choose template file" page of the New Score Wizard. Two templates folders are created by default:

- A system templates folder.
- A user templates folder.

System templates folder

This folder contains the templates installed with MuseScore and should not be modified. It can be found in the following locations:

- **Windows**: Usually at C:\Program Files\MuseScore 3\templates.
- **Linux**: Under /usr/share/mscore-xxx if you installed from the package manager. If you compiled MuseScore on Linux yourself, then look under /usr/local/share/mscore-xxx (with xxx being the version you are using).
- **MacOS**: Under /Applications/MuseScore 3.app/Contents/Resources/Template.

User templates folder

Any templates that you create for future use should be stored here. Once in the user "templates" folder, they will automatically appear on the "Choose template file" page of the New Score Wizard—under the heading "Custom Templates".

The default location of the user templates folder is as follows:

- **Windows**: %HOMEPATH%\Documents\MuseScore3\Templates.
- **MacOS and Linux**: ~/Documents/MuseScore3/Template.

To configure the location of your private templates folder:

- From the menu, select Edit → Preferences... → General.

See also

- Key signature
- Time signature
- Clef
- Tempo
- Staff properties
Note input

MuseScore allows you to enter music notation from any of four input devices: computer keyboard, mouse, MIDI keyboard, or virtual piano keyboard. The default input mode is step-time, in which notes or rests are entered one at a time. However, other input modes are also available.

After exiting the New Score Wizard, your new score will consist of a series of measures filled with measure rests:

As you enter notes in a measure, the measure rests are changed to appropriate rests to fill the remainder of the measure:

Notes of different durations on the same beat are entered by using voices:

Basic note entry

This section introduces you to the basics of entering notes and rests in step-time from a computer keyboard. It is also recommended that you work through the tutorial, “Getting Started: An introduction to note entry in MuseScore”. This is available from the Start Center.

Step 1. Select a starting position

Select a starting position for note input by clicking on a note or rest, or selecting a measure, with the mouse. If you don’t select a starting point, the cursor automatically defaults to the beginning of the score when you enter Note Input mode (“Step 2” below).

Step 2. Enter Note Input mode

To enter Note Input mode, use either of the following options:

- Click on the “N” icon (on the extreme left of the Note Input toolbar).
- Press N on your computer keyboard.

To exit Note Input mode, use any of the following options:

- Press N.
- Press Esc.
- Click on the toolbar “N” button.

Step 3. Select a duration

Still in Note Input mode, select a note duration using either of the following:

- Click on a corresponding note icon in the Note Input toolbar (directly above the document window):

- Enter the keyboard shortcut for that duration (see below).

Step 4. Enter the note or rest

- To enter a note pitch from A–G, simply click on the corresponding letter on your computer keyboard.
- To enter a rest, press 0 (zero).

This method of entry also works if you are not in Note Input mode—as long as you have a note/rest selected, or the score is newly-created (in which case note entry will default to the beginning).
Select a note/rest duration

The following keyboard shortcuts are used to select note/rest duration in **Note Input** mode:

- **64th** (hemidemisemiquaver): 1
- **32nd** (demisemiquaver): 2
- **16th** (semiquaver): 3
- **Eighth** (quaver): 4
- **Quarter** (crotchet): 5
- **Half** (minim): 6
- **Whole** (semibreve): 7
- **Double whole** (breve): 8
- **Longa**: 9
- **Dot**: (changes the selection into a dotted note/rest)

See also: **Tuplets**.

**Additional durations**

- **Double, triple and quadruple dots**: Apply from the note input toolbar in the advanced **workspace**; or via a custom shortcut.
- **128th** note (quasihemidemisemiquaver): Ditto.
- **256th, 512th or 1024th** durations: First enter a 128th note (or longer), then halve it as many times as needed using the shortcut **Q**.

**Input devices**

Music notation can be entered by:

- **Computer keyboard**.
- **Mouse**.
- **MIDI keyboard**.
- **Virtual Piano Keyboard**.
- Any combination of the above.

**Computer keyboard**

This section expands on **Basic note entry** (see above) and introduces you to the full range of commands available for entering notes or rests from the computer keyboard.

**Enter notes/rests**

You can enter a **note** by typing the corresponding letter on your keyboard. Thus, after entering **Note Input** mode, type: `5 C D E F G A B C`.

![Note Input Example]

**Note**: When you enter a note using the keyboard, MuseScore places it closest to the previous note entered (above or below).

To enter a **rest**, type "0" (zero). Thus, after entering **Note Input** mode, type: `5 C D 0 E`.

![Rest Example]

**Note**: The duration selected in the toolbar applies to both notes and rests.

If you want to enter a **dotted note**, press . (period/full stop) after selecting the duration.

For example, after entering **Note Input** mode, type: `. 5 C 4 D E F G A`.

![Dotted Note Example]

If you want to enter a tuplet (such as a triplet): see **Tuplets**.
If you want to write music with two or more simultaneous lines of independent melody on the same staff, see Voices.

Move notes up/down

To move a note up or down by a semitone:
- Press the ↑ or ↓ arrow.

To move a note up or down diatonically:
- Press Alt+Shift+↑ or Alt+Shift+↓.

To move a note up or down by one octave:
- Press Ctrl+↑ (Mac: Cmd+↑) or Ctrl+↓ (Mac: Cmd+↓).

Add accidentals

When a note is moved up or down with an arrow key (see above), any accidental required is automatically generated by the program. Accidentals can also be added manually—see Accidentals.

Chords

If you want to add a chord note above your previous entry:
- Press and hold Shift, then enter a note from A to G.

Thus, typing C, D, Shift+F, Shift+A, E, F results in:

To add a note at a specific interval above or below one or more notes:

1. Ensure that one or more notes are selected;
2. Use one of the following options:
   - From the menu, select Add → Intervals and choose an interval from the list;
   - Press Alt+1-9 for intervals above (intervals below are also possible by adding relevant shortcuts to the list in Preferences).

Note: To create chords with notes of different durations, you will need to use more than one Voice.

Insert notes

Normally, when you enter music in MuseScore, any existing notes or rests are overwritten. There are, however, several ways to insert notes:
- Insert extra measures into the score.
- Cut and paste a section of the score forward, then enter music into the gap.
- To insert a note, press Ctrl+Shift (Mac: Cmd+Shift) + the note name (A to G). This will insert a note of the selected duration and move the rest of the notes to the right in the same measure. If the measure exceeds the duration of the time signature, the blue plus will appear above the measure as in Insert Mode.

Delete notes

To delete a single note:
- Select the note and press Delete.

To delete a chord:

1. Press Esc to ensure that you are in Normal mode.
2. Press Shift and click on a note to select the chord.
3. Press Delete.

The delete command can also be applied to a range of notes/chords.

Keyboard shortcuts

Here is a list of useful editing shortcuts available in Note Input mode:
• ↑ (Up): Increase the pitch of a note by a semitone (uses ♯).
• ↓ (Down): Decrease the pitch of a note by a semitone (uses ♭).
• Alt+1-9: Add interval (unison to ninth) above current note.
• J: Change a note up or down to its enharmonic equivalent (e.g. D♯ to E♭). This alters the spelling in both concert pitch and transposed modes. See Accidentals.
• Ctrl+J (Mac Cmd+J): Change a note up or down to its enharmonic equivalent. This alters the spelling only in the current mode. See Accidentals.
• Alt+Shift+↑: Increase the pitch of a note using key signature.
• Alt+Shift+↓: Decrease the pitch of a note using key signature.
• R: Repeat the last entered note.
• Q: Halve the duration of the last entered note.
• W: Double the duration of the last entered note.
• Shift+Q: Decrease duration by a dot (for example, a dotted quarter note/crotchet becomes a quarter note/crotchet and a quarter note/crotchet becomes a dotted eighth note/quaver).
• Shift+W: Increase duration by a dot (for example, an eighth note/quaver becomes a dotted eighth note/quaver and a dotted eighth note/quaver becomes a quarter note/crotchet).
• Backspace: Undo last entered note.
• Shift+←: Exchange last entered note with the note before it (repeat to keep moving note earlier).
• Shift+→: Exchange note moved with Shift+← with the note that follows it.
• X: Flip direction of note stem (can be reset to Auto position in Inspector).
• Shift+X: Move note head to opposite side of stem (can be reset to Auto position in Inspector).
• Ctrl+Alt+1-4: Switch to corresponding voice.

Mouse

It's easy to enter notes with the mouse, but it is not the fastest way to enter lots of notes.

1. Click on the desired note duration symbol in the Note input toolbar.
2. Click on the score to add a pitch of the selected duration.
3. To add more notes to an existing chord, simply repeat step 2.
4. To replace an existing chord (rather than adding to it), press Shift before clicking.
5. To add a rest, right-click.

Note: If you hover the cursor over the score in Note Input Mode it will show you a preview of the note or rest you are about to add.

MIDI keyboard

You can also insert pitches using a MIDI keyboard.

1. Connect your MIDI keyboard to the computer and switch the former on.
2. Start MuseScore (this must be done after the keyboard is switched on).
3. Create a new score.
4. Click the rest (selecting it) in measure 1 to indicate where you want note input to begin.
5. Press N to enter note input mode.
6. Select a note duration such as 5 for quarter notes (crotchets), as described above.
7. Press a note on your MIDI keyboard.

The pitch should be added to your score.

Note: The default method of entry, Step-time allows you to enter one note at a time. Other note input modes are also available: see Note input modes.

If you have multiple MIDI devices connected to your computer, you may need to inform MuseScore which is the MIDI keyboard:

1. From the menu, select Edit → Preferences... (Mac: MuseScore → Preferences...).
2. Click on the I/O tab and select your device under the section labeled "MIDI input".
3. Click OK to exit. You will need to restart MuseScore to apply the change.

Virtual Piano Keyboard

You can also input notes using the on-screen piano keyboard.

- To toggle the display on and off: Press P (or select View → Piano).
- To resize the keyboard: Position the mouse pointer over the piano keys, hold down Ctrl (Mac: Cmd) and move the mouse scroll wheel up (larger) or down (smaller).

The method of note entry is similar to that for a midi keyboard:

1. Ensure that you are in Note Input mode.
2. To enter a:
   - Single note: Click on the appropriate piano key.
Chord: Select the note you wish to add to, press and hold Shift, then click on a piano key (in versions before 2.1, use Ctrl (Mac: Cmd)). Repeat as required.

Note input modes

MuseScore offers a variety of note input modes in addition to Step-time. All can be accessed by clicking the small arrow next to the "N" button on the left of the Note Input toolbar:

- Step-time (default): The default mode of note entry. See Basic note entry (above).
- Repitch: Replace pitches without changing rhythms.
- Rhythm: Enter durations with a single click or keypress.
- Real-time (automatic): Perform the piece at a fixed tempo indicated by a metronome beat.
- Real-time (manual): Perform the piece while tapping a key or pedal to set the beat.
- Insert: (Called "Timewise" until version 3.0.2) Insert and delete notes and rests within measures, automatically shifting subsequent music forwards or backwards.

Coloring of notes outside an instrument’s range

Depending on the skill of the musician, certain notes are considered beyond the range of a particular instrument. For informational purposes, MuseScore optionally colors notes red if they are outside the range of a "professional" player, and olive green/dark yellow if outside the range of an "early amateur." The colors appear on the computer screen, but not on printed copies.

To enable/disable note coloration and to set "professional" and "amateur" ranges, see Usable pitch range (Staff properties: all staves).

Small notes/small noteheads

1. Select the note(s) you want in small size.
2. Check the "Small" checkbox in the Inspector. The one in the Note section is used to only change the size of the individual notehead; the one in the Chord section will change the note head, stem, beam, and flag sizes all together.

By default, the small size is 70% of the normal size. You can change that setting in Format → Style... → Sizes.

Change notes or rests already entered

Change duration

Version 3.3.3 and above
1. Make sure you are in Normal mode.
2. Select one or more notes/rests, or note-stems/hooks. Apply the desired duration shortcut (listed above), or click on the equivalent duration icon in the toolbar.

Prior to version 3.3.3
1. Make sure you are in Normal mode.
2. Click on a note or rest. Apply the desired duration shortcut (listed above), or click on the equivalent duration icon in the toolbar.

Note: Increasing the duration will overwrite the notes or rests that follow it; decreasing the duration will add rests between it and the notes or rests following.
For example, to change three sixteenth rests into a single dotted eighth rest:

1. Click on the first sixteenth rest.
2. Hit 4 to turn it into an eighth rest.
3. Hit . to turn it into a dotted eighth rest.

As the duration increases, it overwrites the other two sixteenth rests following it.

Change pitch

To change the pitch of a single note:

1. Make sure that you're not in note input mode and that you have no other notes selected.
2. Select the desired note and use any of the following methods:
   - Drag the notehead up or down with the mouse;
   - Press the keyboard arrows: ↑ (Up) or ↓ (down);
   - Type a new note letter name (A…G). Use Ctrl+↑ or Ctrl+↓ to correct the octave, if necessary (Mac: Cmd+↑ or Cmd+↓). This will automatically turn on note input mode.

To change the enharmonic spelling of a note, select it and use the J command. For more information, see Accidentals.

To change the pitches of a passage of music by a constant interval, you can use Transposition.

To change the pitches of a passage of music to a different melody, while keeping the rhythm unchanged, use Re-pitch mode.

If your score contains a lot of misspelled accidentals, you might try the Respell Pitches command (see Accidentals: Respell pitches).

Change voice

To change one or more notes to a different voice, see Voices.

Change rest to note and vice versa

To change a rest to a note of the same duration:

1. Make sure you are not in note input mode (press Esc to exit).
2. Select the rest.
3. Enter the desired pitch by entering a note letter, A–G.

To change a note to a rest of the same duration:

1. Make sure you are not in note input mode (press Esc to exit).
2. Select the note.
3. Press 0 (Zero).

Note properties

- To adjust the horizontal position of a note/chord: see Offset notes.
- To edit note properties in general (spacing, offset, size, color, notehead direction, playback etc.): see Inspector and object properties.
- To adjust the layout of all notes in the score: see Layout and formatting, especially the sections about notes, accidentals and tuplets.

See also

- Note input modes
- Drum notation
- Tablature
- Tuplet
- Voices
- Shared noteheads
- Preferences

External links

- How to enter a chord
- How to enter a rest
- How to span a stem over two staves
- Video tutorial: MuseScore in Minutes: Lesson 3 - Note input
- Video tutorial: MuseScore in Minutes: Lesson 4 - MIDI Keyboard Input
Edit mode

`Edit mode` allows you to perform a wide range of editing operations on individual score elements, such as:

- Adjust the length and shape of slurs, lines, barlines etc.
- Add, delete and format text in text objects.
- Adjust the position of most score elements (but not text).

Enter edit mode

MuseScore versions 3.4 and above

For lines, hairpins, slurs, note-stems, note-beams, and barlines, use one of the following methods:

- Click on an element.
- Right-click on an element and, from the menu, select Edit Element.

For other elements, use one of the following methods:

- Double-click an element.
- Click on an object already selected (text-based objects only).
- Right-click on an element and, from the menu, select Edit Element.
- Click on an element and press Alt+Shift+E.

MuseScore versions prior to 3.4

Use one of the following methods:

- Double-click an element.
- Right-click on an element and, from the menu, select Edit Element.
- Click on an element and press Alt+Shift+E.

Exit edit mode

To exit `Edit mode` use any of the following:

- Press Esc.
- Click on a blank area of the document window.

Text

For text edit mode, see Text editing.

Lines

See Lines: Change length, and Adjust slur.

Notes

Offset notes

Sometimes it is necessary to shift a note to the right or left—to avoid a collision with another element or to override automatic notehead sharing for example:

1. Enter `Edit mode` on the desired note;
2. Press the arrow key in the direction (left or right) that you wish to nudge the note (or use Ctrl+← or Ctrl+→ for larger adjustments);
3. Press the Esc key. This will allow the note stem to be redrawn.

Alternatively, you can select the notehead and change the "Horizontal offset" (under "Chord") in the Inspector.

Adjust note stem length

1. Enter `Edit mode` on the desired note stem;
2. Use keyboard shortcuts (below) to extend or shorten the stem;
3. Exit edit mode.

Alternatively, you can select the stem and change the "Length Offset" (under "Stem") in the Inspector.
To reposition a note stem, you should select it and adjust the “X” or “Y” setting for the "Offset" under "Automatic placement" in the "Element" section of the Inspector.

Keyboard shortcuts

In Edit mode the following keyboard commands can be used to change the position of either (1) a score element (e.g. ornament, accidental etc.) or (2) an adjustment handle (e.g. slur, line etc.):

- ←: Move left 0.1 staff space
- →: Move right 0.1 staff space
- ↑: Move up 0.1 staff space
- ↓: Move down 0.1 staff space
- Ctrl+← (Mac: Cmd+←): Move left one staff space
- Ctrl→ (Mac: Cmd→): Move right one staff space
- Ctrl↑ (Mac: Cmd↑): Moves down one staff space
- Alt+←: Move left 0.01 staff space
- Alt→: Move right 0.01 staff space
- Alt↑: Move up 0.01 staff space
- Alt↓: Move down 0.01 staff space

The following commands only apply to adjustment handles:

- Shift←: Move end handle’s anchor left by one note/rest.
- Shift→: Move end handle’s anchor right by one note/rest.
- Tab: Go to next handle.

To undo all edits, ensure you are not in edit mode and press Ctrl+R.

See also

- Text editing
- Slur
- Bracket
- Line
- Beam
- Hairpin

Palettes

To the left of the document window is the palette area: a palette is a folder containing musical symbols (usually related) which can be applied to the score. Together, the palettes form the main part of a workspace.

To view or hide the palettes:

- From the menu, select View → Palettes; or use the keyboard shortcut, F9.

Single Palette Mode
If you only want to allow one palette to open at a time, right click at the top of the workspace and check the “Single palette” box. This will cause a palette to automatically close when you open a different one.

Open/close palette

To open or close a palette:

- Click on the arrow next to the palette name, or double click the palette name (in versions prior to MuseScore 3.3, click once on either the arrow or the palette name).

Apply symbols from a palette

Versions 3.4 or above

- Select one or more score elements, then click the desired palette symbol.
- Drag and drop the symbol onto the desired score element in the staff.

Versions prior to 3.4

- Select one or more score elements, then double-click the desired palette symbol.
- Drag and drop the symbol onto the desired score element in the staff.

Tip: To prevent accidental rearrangement of contents during use, right-click over a palette name and untick “Enable Editing.”

Once added to the score, objects can be copied, pasted, and duplicated—see Copy and paste.

Customise palettes

Note: In versions prior to MuseScore 3.3, only palettes in new workspaces can be customised—those in the Basic and Advanced workspaces are presets only. See Create new workspace. The “Enable editing” option for the palette should also be ticked (all versions, see Palette menu, below).

To add an existing score element (such as a line, text, dynamic, fretboard diagram etc.) to a custom palette:

- Press and hold Ctrl+Shift (Mac: Cmd+Shift), then drag the symbol onto the palette.

To add a symbol to a custom workspace from the Master palette:

- Drag the symbol from the Master Palette window into a custom palette.

To re-arrange a symbol in a palette:

- Drag the symbol to the new cell which you wish to display it in.

Palette menu

Right-clicking on the name of a palette in a custom workspace brings up this menu:

- **Palette Properties...**: Adjust the appearance of the open palette:

  - **Name**
  - **Cell Size: Width, Height**
  - **Element Offset**: Adjust the vertical offset of all elements in the palette.
  - **Scale**: Make all palette elements appear larger or smaller.
  - **Show grid**: Visually divide the palette into cells, one for each element.
  - **Show 'More Elements...'**: Create a cell which opens the Master Palette.

- **Insert New Palette**: Create a new empty palette.
- **Move Palette Up / Move Palette Down**: Reorder the palettes.
- **Enable Editing**: Allow modifying the contents of the palette.
- Save Palette: Save as an .mpal file.
- Delete Palette: Remove the palette from the workspace entirely.

Right-clicking on an element within a palette (if editing of the palette is enabled) brings up this menu:

- Clear: Remove the element from the palette
- Properties...: Open the Palette Cell Properties dialogue:
  - Name: The tooltip that appears when you mouse over the element.
  - Content offset (X, Y): Adjust the position of the element in the palette.
  - Content scale: Make the element appear larger or smaller in the palette.
  - Draw staff: Draw the five lines of a musical staff behind the palette element.
- More Elements: Open the relevant Master Palette section.

Note: Changing values in “Palette Cell Properties” only affects the appearance of elements in the palette. It does not change their sizes or offsets on the score page.

Behavior of applied text and lines

If the symbol you are adding to the score from a palette contains text element (e.g. staff text, dynamic, fingering, volta etc.), then properties such as font-type, font-size, text color, and alignment will adapt according to the following rules:

1. Text properties which have not been altered by the user will adopt the relevant, prevailing text styles.
2. Custom text-properties—i.e. those changed by the user before saving the symbol to a custom palette—remain as customized.

By contrast, the line properties of lines applied from a palette always remain unchanged (i.e. as set by the user before saving to a custom workspace, or as predefined in the Basic/Advanced workspaces).

See also

- Master palette

Workspaces

The workspace consists of several components, the main one being the palette area situated to the left of the document window.

Each palette is a folder containing musical symbols (usually related) which can be applied to the score.

- To open or close a palette: Click on the arrow next to the palette name, or double click the palette name (in versions prior to MuseScore 3.3, click once on either the arrow or the palette name).

To view or hide the palette area of the workspace

- Press, F9; alternatively, from the menu, select View → Palettes.

MuseScore provides two preset workspaces: Basic (the default option) and Advanced (a version with more palettes and symbols). These contain symbols drawn from the various sections of the Master palette. In addition, you can create your
own custom workspaces (below).

Switch between workspaces

Use one of the following methods:

- Select a new workspace from the drop-down menu. This is located either to the right of the Note Input Toolbar (in versions 3.3 and above); or at the bottom of the workspace panel (in versions prior to 3.3).
- From the menu, select View → Workspaces, and click on one of the options.

Docking/undocking

To dock or undock a workspace, see Side panels.

Create a new workspace

To create a new workspace:

1. Select an existing workspace (use the Switch between workspaces option if required);
2. Click the + button (next to the dropdown list), which displays the following dialog:

![Create New Workspace dialog]

Note: this can also be opened from the menu: View → Workspace → New;
3. Enter a name for the new workspace;
4. Tick the components that you want joined to the workspace, namely:
   - Toolbars: Allows you to customize the tool button display and the order in which they are displayed. Access this via View → Toolbars → Customize toolbars.
   - Menu bar: Allows you to change the menus and menu items displayed in the Menu bar. NOT IMPLEMENTED YET;
   - GUI components: Saves information with the workspace about the position of the GUI (Graphical user interface) components, and whether they are open or not. (e.g. Inspector, Timeline);
   - GUI Preferences: Saves the preferences selected for the GUI elements in Edit → Preferences, such as Theme and Canvas settings;
5. Press Save. The new workspace is added to the panel.

Edit a workspace

Note: In versions prior to MuseScore 3.3, only new workspaces can be edited—the Basic and Advanced workspaces are presets only. See Create new workspace.

- To change the palette display: see Palette menu.
- To change the palette contents: see Custom palettes.
- To change the overall workspace display: Select View → Workspace → Edit. This displays a window with the same options as the Create New Workspace dialog (above).

Save custom workspace

Any changes you make to the workspaces are automatically saved to the program (no further action required). Each custom workspace is saved as a separate file in a folder called "workspaces." Its location is as follows:

- Windows: C:\Users\[USERNAME]\AppData\Local\MuseScore\MuseScore3\ (actually %LOCALAPPDATA%\MuseScore\MuseScore3)
- MacOS: ~/Library/Application Support/MuseScore/MuseScore3/
- Linux: ${XDG_DATA_HOME:-~/.local/share}/MuseScore/MuseScore3/.

See also

- Palettes
- Master palette
Inspector

Displaying the Inspector

The Inspector appears by default on the right of your screen. To show or hide it:

- From the menu, select View and check or uncheck Inspector; alternatively, use the shortcut F8 (Mac: fn+F8).

To undock the Inspector panel:

- Click the double-chevron symbol or double-click the top bar of the panel.

To re-attach the panel double-click on the top bar again. See also: Side panels.

What the Inspector does

When you select any object in the score window, its properties are automatically displayed in the Inspector where they can be edited. Multiple elements can also be selected and edited together—as long as they are of the same type. However, if the selected objects are of different types, then the Inspector restricts you to editing color, visibility, and automatic placement only.

"Reset to style default" and "Set to style" buttons

When you select a score object, two types of buttons are clearly visible on the right-hand side of the Inspector:

- **Reset to style default**. Press this button to reset a particular property to the default value—i.e. the one shown in the Style menu.

- **Set as style**. Press this button to make the value of a particular property the new default for the style. This will update the Style menu and all other objects governed by that style.

Note: You can also edit styles directly from the Style menu.

Inspector categories

Properties are conveniently listed under categories in the Inspector. Categories can be identified by their bold lettering. For example, if you select a barline, you will see the following displayed at the top of the Inspector:

For details of the various categories and their properties, see below:

Element

All score elements—except frames, breaks and spacers—display this category in the Inspector when selected. The options are as follows:

- **Visible**: Uncheck this box to make selected elements invisible; alternatively, use the shortcut v (toggle). Invisible elements do not appear in the music when printed out or exported as a PDF or image. If you still want them to remain on display in the document window, make sure that the "Show Invisible" option is selected in View → Show Invisible. Invisible elements will then be colored light gray.
- **Color**: Click on the rectangle to open a "Color Select" dialog. Adjust the color and opacity of selected elements.

- **Automatic placement**: See Automatic placement.

- **Minimum distance**: Minimum distance from other elements when automatic placement is enabled.

- **Offset X/Y**: Allows you to position selected elements exactly (in terms of space units). A positive number moves the elements right or down; a negative number moves the elements left or up. Snap to grid buttons are also provided.

- **Stacking order (Z)**: See Automatic placement: Stacking order

**Element Group**

This category is displayed only when you have selected a mixture of different types of elements, and allows editing of color, visibility, and automatic placement only.

**Segment**

- **Leading Space**: Use this to increase or decrease the space before an element. This also affects any associated lyric syllables.

**Chord**

- **Offset X/Y**: This changes the position of every note in the same voice as the selected note(s). If you want to make changes to the position of just one note, use the Element category instead.
- **Small**: Make noteheads and stem small.
- **Stemless**: Make chord stemless.
- **Stem direction**: Choice of Auto, Up, or Down.

**Note**

This category allows you to make changes to selected notes (but for note position—see Element). It contains the following properties:

- **Small**: Make notehead smaller (you can specify the relative size of all small notes from the menu Format → Style... → Sizes...).
- **Head group**: See Notehead groups.
- **Head type**: See Notehead types.
- **Mirror head**: Position notehead to the left or right of the stem (default is "Auto").
- **Fix to line**: When ticked, the note is fixed to the top line of the standard 5-line staff.
- **Line**: A positive number moves the "fixed" note down; a negative number moves it upwards.
- **Play**: Unticking this box silences the note.
- **Tuning**: Adjust tuning of note to the nearest cent.
- **Velocity type**: Sets the MIDI velocity of notes directly. Choose one of two options:
  - **Offset**: Make the value shown in "Velocity" relative to the previous dynamic marking.
  - **User**: Make the value shown in "Velocity" absolute (i.e. the MIDI velocity is unaffected by dynamic markings).
- **Velocity**: Set the MIDI velocity according to the option displayed in "Velocity type."

**Select**

This category appears differently according to the selection you have made:

- **If you select a notehead**, the "Select" category displays buttons which allow you to easily switch the selection to the stem, beam, hook, duration dot (or dots) or tuplet number associated with the notehead (see image below).

- **If you select a range of measures**, the "Select" category allows you to select either all notes, grace notes, or rests.

**Beam**
This section is displayed in the Inspector when you select one or more note beams, and allows you to make fine adjustments to beam position and angle, and also change the spacing of beamed notes.

Clef

This section appears when you select a clef: the tick box allows you to turn on/off the display of a preceding courtesy clef.

Articulation

This category appears when you select an articulation or ornament. The following options are available:

- **Direction**: Whether the symbol points up or down: only applicable to certain symbols.
- **Anchor**: The vertical placement of the symbol:
- **Play**: Turn on/off playback effect.
- **Time stretch**: Only applicable to fermatas. Allows you to vary the pause in playback.
- **Ornament style**: A choice of default or Baroque playback.

Fretboard diagram

See [Fretboard diagrams](#).

Line

This category is displayed when a line is selected. Here, you can set various general properties.

- **Visible**: Hide or display just the line: any text remains visible.
- **Allow diagonal**: The default is horizontal (unticked). Tick if you want to edit the line to create a slope.
- **Line color/thickness/style**: Set various properties of the line.

Text Line Details

This category is displayed when a line is selected. It allows you to set the wording of a line, edit text properties, set line hooks, and align the text in relation to the line.

- **Begin hook / Height**: At the beginning of the line, specify None, 90° (vertical), 45° (angled), or 90° centered; set hook length.
- **End hook / Height**: Ditto for the very end of the line.
- **Begin Text / Continue Text / End Text**: Refers to text at the very beginning of the line; at the beginning of any continuation line; or at the end of the very last line. All have the same properties, as follows:
  - **Text**: Create or edit the text associated with the line.
  - **Font face / Size / Style**: Set the text properties, and/or edit the text style of the line.
  - **Align**: Set the horizontal and vertical alignment of the text in relation to the line.
  - **Placement**: Place the text on (Above/Below), or to the left of the line.
  - **Offset X / Y**: Adjust the x and y offsets for exact positioning.

Properties dialogs

Some object types have additional properties. These are accessed by right-clicking on the object and choosing a "... properties" option from the context menu. The settings available in these dialogs are explained in the description of the object type in Notation or Advanced topics.

See:

- Articulations and ornaments
- Time signatures
- Staff and system text
- Measure operations
- Staff/Part properties

See also

- Note input
- Layout and formatting
- Parts
Measure operations

Note: To ensure that inserted or appended measures display correctly, multimeasure rests should be set to off (toggle M).

Select

Single measure

- To select a single measure, click on a space within the measure.

Range of measures

- To select a continuous range of measures, see Shift + click selection and Shift selection.

Insert

Insert an empty measure into the score

Use one of the following options:

- Select a measure or a frame, then press Ins (Mac: Shift+I).
- Select a measure or a frame, then choose from the menu: Add → Measures → Insert Measure.

Insert multiple measures

Use one of the following options:

- Select a measure or a frame, then press Ctrl+Ins (Mac: Shift+Del+I); fill in the "Number of measures to insert" field and press OK.
- Select a measure or a frame, then choose from the menu: Add → Measures → Insert Measures...; fill in the "Number of measures to insert" field and press OK.

Append

Append an empty measure to the end of a score

Use one of the following options:

- Press Ctrl+B (Mac: Cmd+B).
- Select from the menu: Add → Measures → Append One Measure.

Append multiple measures to the end of a score

Use one of the following options:

- Press Alt+Shift+B (Mac: Alt+Shift+B); fill in the "Number of measures to append" field and press OK.
- Select from the menu: Add → Measures → Append Measures...; fill in the "Number of measures to append" field and press OK.

Delete

Delete a single measure

- Select the measure, and press Ctrl+Del (Mac: Cmd+Del).

Delete a range of measures

1. Select the range of measures to delete;
2. Press Ctrl+Del (Mac: Cmd+Del).

Notes: (1) In multi-staff scores, measure deletion also removes all corresponding measures in the other staves of the system; (2) If you wish to delete only the measure contents (and not the measure itself), use the Del command instead at step "2."

Remove empty trailing measures

To automatically remove any blank measures from the end of the score:

- From the menu, select Tools → Remove empty trailing measures.
Properties

To edit the properties of a measure, right-click an empty part of the measure and select Measure Properties...

You can use the buttons, at the bottom left of the dialog, to navigate to the previous or next measure.

Staves

- The **visible** property allows you to show/hide the notes and staff lines for the current measure.
- The **stemless** property allows you to show/hide all note stems for the current measure. Notes that normally have a stem such as half notes (minims) and quarter notes (crotchets) only show the note head when marked as stemless.

Measure duration

This feature allows you to adjust the time signature of a single measure regardless of the time signature indicated in the score. You can use it to create a **pickup measure** (also known as anacrusis or upbeat), cadenza, ad lib section etc.

**Nominal** is the **apparent** time signature and cannot be edited.  
**Actual** can be set to anything you like regardless of the **nominal** time signature.

**Example:** In the image below, the quarter note pickup measure has a **nominal** time signature of 4/4, but an **actual** time sig. of 1/4. The measures in the middle are in normal 4/4 time. The complementary measure at the end of the staff, with a dotted half note, has an **actual** time sig. of 3/4.

**Note:** A small - or + sign appears above the measure when its duration is smaller or larger than that indicated by the time signature (see image below). *This does not appear in any printed or PDF copy.* You can turn off these marks by unchecking "Mark Irregular Measures" in the View menu.

**Other**

**Exclude from measure count**

Use "Exclude from measure count" for "irregular" measures, i.e. ones that should not get counted in the measure numbering. Normally, a pickup measure is marked as "Exclude from measure count".
Break multi-measure rests

This property will separate a multi-measure rest at the start of the selected measure. This option should be checked before you turn on the "Create multi-measure rests" option in Format → Style → Score.

Multi-measure rests are automatically broken at important breaks, such as rehearsal marks, time signature changes, double barlines, irregular measures, etc. The default for scores is off, for parts is on.

Measure number mode

This allows you to control how measure numbers display on the selected measure. Choose "Auto," "Always Show," or "Always Hide" from the dropdown list.

Layout stretch

You can increase or decrease horizontal space between score elements (notes, rests, etc.) with this option. This provides a more precise control over the exact same measure spacing property as the menu commands or keyboard shortcuts for Increase/Decrease Stretch ( and ), which are accessed outside of the Measure Properties dialog while a measure is selected.

Add to measure number

You can also use the "Add to measure number" option to influence the measure numbering. You can enter positive or negative numbers here. Please note that this affects all subsequent measures. A value of "-1" has the same effect as marking a measure to be excluded from measure count.

Play Count

If a measure precedes an end repeat barline, this value controls the number of times that the repeat section plays back: see also, Repeats and jumps.

Numbering

By default, MuseScore numbers the first measure of each System (except for the first measure in a section), but other numbering options are available: see Format → Style → Measure Numbers.

- Mark the checkbox next to the "Measure Numbers" ("Bar Numbers") to turn on automatic measure numbers.
- Mark "Show first" if you want the first measure numbered.
- Mark "All staves" if you want numbers on all staves. Otherwise, only the top staff of each system shows measure numbers.
- Choose to show numbers on "Every system", which numbers the first measure of each line; or show numbers by "Interval" and specify the size of the interval. For example, an interval of 1 numbers every measure; an interval of 5 numbers every fifth measure.

Split and join

To make a measure longer or shorter in duration—without changing the time signature—you can adjust its Measure Properties (above). But it is also possible to join or split measures.

Join measures

Method A. To join two measures only:

- Select the barline between the two measures and press Ctrl+Del.

Method B. To join any number of measures:

1. Select the measures you want to join;
2. From the menu bar, select Tools → Measure → Join Selected Measures.

Notes: (1) If you select measures on only one staff in a score with multiple staves, the same measures will be joined in each staff of the system. (2) Beaming may be automatically modified.

Split a measure

Choose one of the following methods:

- Select a note; then hold Ctrl and double-click a barline in a palette.
- Hold Ctrl and drag a barline (from a palette) to the note that starts the next measure.
- Select a note; then, from the menu bar, select Tools → Measure → Split Measure Before Selected Note/Rest.
Note: If you select only one note from one staff, each staff of the system will be split at the same place.

**External links**

- How to delete measures
- How to span a measure over multiple systems (1.x)
- How to get scores without time signature (and clef)

**Voices**

A voice is a musical line or part which can have its own rhythm independently of other voices on the same staff. Voices are sometimes called "layers" in other notation software.

You can have up to 4 voices on each staff line. In a polyphonic measure, voice 1 (and 3) usually takes the up-stem notes and voice 2 (and 4) takes the down-stem notes.

![Voice 1 (up-stem notes) Voice 2 (down-stem notes)](image)

N.B. Be careful not to confuse the concept of MuseScore voices (1, 2, 3, 4) with the order of voices found in SATB vocal scores:

- In Open score SATB (where four staves are used for the four voices), use (MuseScore) voice 1 in each staff.
- In Close/Closed score SATB (where two staves are used for the four voices, e.g., as in hymnals), use only (MuseScore) voices 1 and 2 for both upper and lower staves.
- There is no need to use (MuseScore) voices 3 and 4 unless there are more than two parts in the same staff. This means that in the bass clef of a “close score”, the tenor is voice 1 and the bass is voice 2—beginners often without thinking assign the bass to 1, resulting in stem-direction confusion, or assign tenor to voice 3 and bass to voice 4, which then leads to confusing rests appearing in voice 1 (which cannot be deleted).

**How voices are displayed**

Selecting a section of the score highlights each voice in a different color: voice 1 blue, voice 2 green, voice 3 orange and voice 4 purple.

![Selecting a section of the score highlights each voice in a different color](image)

**When to use voices**

- If you need stems pointing in opposite directions within a chord, on a single staff.
- If you need notes of different durations within a single staff, played simultaneously.

**How to enter notes in different voices**

The following instructions show you how to notate a passage of music in two voices:

1. **Enter voice 1 notes first**: Make sure you are in note input mode: the Voice 1 button becomes highlighted in blue in the toolbar. Enter the notes in the top voice first. On inputting, some notes may have down-stems, but these will flip automatically when the second voice is added.

   ![The following excerpt shows a treble staff with just the voice 1 notes entered](image)

2. **Move cursor back to start of section**: When you have finished entering a section of voice 1 notes, press the → key repeatedly to move the cursor, note-by-note, back to the first note of the section; or alternatively use Ctrl+→ (Mac: Cmd+→) to move the cursor back one measure at a time. Or else you can simply exit note input mode (press Esc) and click directly on the first note.

3. **Enter voice 2 notes**: Make sure you are in note-input mode and that the voice 1 note at the beginning of the section is selected. Click on the “Voice 2” button (on the right of the toolbar), or use the shortcut Ctrl+Alt+2 (Mac: Ctrl+Shift+2).
Cmd+Alt+2). Enter all the lower voice notes (down-stem).

The following image shows the above example after the addition of voice 2 notes:

![Image of music notation example]

Deleting and hiding rests

All rests can be made invisible, if required: select the desired rest(s) and press V, or uncheck the "Visible" checkbox in the Inspector. Rests in voices 2, 3 or 4 (but not voice 1) can also be deleted (by selecting them and pressing Delete) but it is not recommended: make them invisible instead.

A voice 1 rest can only be deleted by removing that part of the measure from the score as well: see Remove selected range; or Delete measure(s).

Restoring deleted rests

If a rest has been deleted in voices 2-4, you will need to restore it before you can enter a note on that beat in that voice (the problem may arise, for example, in imported XML or MIDI files). The easiest way to fix such a measure is to exchange that voice with voice 1 twice. For the exact method, see Exchange voices of notes (below).

Exchange voices of notes

To swap the notes between any two voices:

1. Select one or more continuous measures (or a range of notes);
2. From the Menu bar, select Tools → Voices;
3. Select the option for the two voices you want to exchange.

Notes: (a) The selection can encompass content of any voice, but only two will be processed at once. (b) If you select a partial measure the operation will still apply to the whole measure.

Move notes to another voice (without swapping)

You can also move notes from one voice to another (without note-swapping):

1. Ensure you are not in note input mode.
2. Select one or more noteheads (in any voice).
3. Click on the destination voice in the Note Input toolbar or use the shortcut Ctrl+Alt+1–4 (Mac: Cmd+Alt+1-4).

Note: For a successful move, the following conditions need to be met:

- The chord in the destination voice must be the same duration as the note to be moved there.
- Alternatively, if the destination voice is occupied by a rest, it must be of sufficient duration to accommodate the moved note.
- Notes should not be tied.

See also

- Keyboard shortcuts: Voices
- Noteheads: Shared noteheads

External links

- How to merge/combine/implode two staves in one with two voices
- How to input multiple notes on a staff with different durations
- Video tutorial: How To Write Two Parts On One Staff: Voices

Copy and paste

MuseScore supports standard copy, cut, paste and swap with clipboard operations. These commands can be applied to a range of:

- Musical notes: e.g. to repeat a section of music, or shift a passage by a beat or a measure.
- Other score elements: such as articulations, staff text, dynamics, fingering etc.

Copy/cut/paste/swap commands are accessed in three ways:

- From the Edit menu (above the document window).
- From the menu displayed by right-clicking on an element or range of elements.
Using one of the standard **keyboard shortcuts**.

### Summary of commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Kbd Shortcut (Win)</th>
<th>Kbd Shortcut (Mac)</th>
<th>Right-click menu</th>
<th>Main menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
<td>Cmd+X</td>
<td>Cut</td>
<td>Edit → Cut</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
<td>Cmd+C</td>
<td>Copy</td>
<td>Edit → Copy</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
<td>Cmd+V</td>
<td>Paste</td>
<td>Edit → Paste</td>
</tr>
<tr>
<td>Swap with clipboard</td>
<td>Ctrl+Shift+X</td>
<td>Cmd+Shift+X</td>
<td>Swap with Clipboard</td>
<td>Edit → Swap with clipboard</td>
</tr>
</tbody>
</table>

**Note**: Before carrying out a copy, cut, paste or swap procedure, you should be in normal mode. Press the Esc key to exit into normal mode.

### Notes

You can cut, copy, paste or swap notes as follows:

#### Copy or cut

**To copy/cut a single chord**

1. Hold down Shift and click on a note in the chord.
2. Apply a Copy or Cut option (see table above).

**To copy/cut a range of chords**

1. Click on the first note or measure that you want to select.
2. Shift+Click on the last note or measure that you want to select. A blue rectangle highlights the region you selected.
3. Apply a Copy or Cut option (see table above).

#### Paste

1. Click on the note or measure where you want your pasted selection to begin.
2. Apply a Paste option (see table above).

#### Swap with Clipboard

The **swap with clipboard** operation combines two commands into one: (1) First it overwrites a selected part of the score with the contents of the clipboard, just like the paste command; (2) Secondly, it transfers the overwritten part of the score back to the clipboard, just like the copy command.

It can be used, for example, to swap two equal-length sections of a score, A and B:

1. Select section A, then apply the cut command;
2. Clear the selection (by pressing Esc or clicking on a blank area of the document window);
3. Press Shift and click on a note at the start of section B. Or, if B begins at the start of a measure, you can also simply select the measure;
4. Apply a Swap with clipboard option (see table above).
5. Section B is now in the clipboard. Paste it back to the blank area of score left by step “1."

#### Copy pitch of a single note only

It is possible to copy the pitch of a note only (and no other properties), by clicking on the notehead and applying the standard copy and paste, or copy and swap procedure. The pitch of the destination note changes to match that of the copied note but the duration remains the same.

### Other elements

Some elements such as staff text, dynamics, fingering, etc. can be cut, copied and pasted only one at a time. However, other elements support "multiple-selection" cut/copy/paste: such as **articulations** (sforzato, staccato etc.), **fretboard diagrams**, and **chord symbols**.

**Note**: The Swap with clipboard command is only intended for use with sections of music and not other score elements.

#### Copy or cut

1. Select the element (or elements).
2. Apply a Copy or Cut option (see table above).
Paste

1. Click on the note where you want your pasted selection to begin.
2. Apply one of the Paste options (see table above).

In the case of articulations, they are pasted to the destination notes in exactly the same order (continuous or intermittent) as they were in the initial selection.

Quick repeat

To quickly copy and paste a note, measure, or passage:

1. Select a chord, measure, or passage as described above.
2. Press R.

MuseScore copies and pastes the selected notation to a point immediately after the last note in the selection. Any existing music in the destination range is replaced.

Duplicate

To instantaneously copy and paste a text element, line, or other object:

1. Hold down Ctrl+Shift (Mac: Cmd+Shift), click on the element and drag it anywhere in the score.
2. Release the mouse button, and the selected element is cloned to the new location.

Paste half/double duration (version 3.1 and above)

These commands allows you to copy/cut a section of the score, then paste it back anywhere with all the note durations either halved or doubled.

1. In Normal mode, select a range of notes in the score;
2. Cut or copy the range;
3. Select a destination note (or measure);
4. From the menu, select one of the following:
   - Edit → Paste Half Duration.
   - Edit → Paste Double Duration.

Selection filter

The Selection Filter allows you to choose exactly which voices and elements you want to include in your selection.

- To display the Selection filter, press F6 (Mac: fn+F6); or from the menu, choose View → Selection Filter.

The Selection Filter appears by default below the Palettes. To change the viewing location, see Viewing and Navigation: Side panels.

Example: Suppose you want to copy measures 1 and 2 in the following passage (see image), to give measures 3 and 4:

1. Make sure the Selection Filter is displayed (see above);
2. Uncheck the "Articulations & Ornaments" and "Slurs" tickboxes;
3. Copy and paste the desired measures (in this example, 1-2 into 3-4).

Note: The Selection Filter works with the swap with clipboard command as well.

See also
If you want to change notes without altering the rhythm, you may combine re-pitch mode with copy and paste.

External links
- Video tutorial: Lyrics, copying & dynamics

Selection modes

Objects in the score—such as notes, measures, articulations etc.—can be selected in several ways: (1) one at a time, (2) as a continuous range, or (3) as a list.

Select a single object

Most score objects can be selected by simply clicking on them in Normal mode.

Select a single note

- In Normal mode, click on a notehead.

Note: Selecting a single note then copying and pasting it, will only copy and paste the pitch—not duration or other properties (such as stemless). To copy the entire note, including all properties, you need to hold down Shift—as for chord selection (below).

Select a chord

- In Normal mode, press and hold Shift, then click on a notehead in the chord.

Select a single measure

- Click on a blank space within the measure.

Note: To select a range of consecutive measures, see Shift selection and Shift + click selection (below).

Select an overlapping element

To select an element from a group of overlapping elements:

- Hold Ctrl and click until the desired element is selected.

Select a continuous range of objects

There are several ways to select a continuous range of notes, chords or measures:

1. Shift selection

   1. Make sure you are in Normal mode;
   2. Select the first note, chord, rest or measure in the range. You can extend the selection up or down to adjacent staves, if needed, using Shift+↑ or ↓;
   3. Then choose one of the following options:
      - To advance the selection one chord at a time to the right: Press Shift+→.
      - To advance the selection one chord at a time to the left: Press Shift←.
      - To advance the selection one measure at a time to the right: Press Shift+Ctrl+→ (Mac: Shift+Cmd+→).
      - To advance the selection one measure at a time to the left: Press Shift+Ctrl← (Mac: Shift+Cmd←).
      - To advance the selection to the beginning of the line: Press Shift+Home (Mac: Shift+Fn+←).
      - To advance the selection to the end of the line: Press Shift+End (Mac: Shift+Fn+→).
      - To extend the selection to the beginning of the score: Press Shift+Ctrl+Home (Mac: Shift+Cmd+Fn+←).
      - To extend the selection to the end of the score: Press Shift+Ctrl+End (Mac: Shift+Cmd+Fn+→).

2. Shift + click selection

To select a range of notes or rests:

   1. Make sure you are in Normal mode;
   2. Click on the first note or rest in the range;
   3. Press and hold Shift, then click on the last desired note or rest.

Note: The final selected element can be in the same staff or in staffs above or below the initial note/rest. All selected elements will be enclosed in a blue rectangle, including associated lines and articulations (but not voltas). You can repeat the operation to extend the selected range as required.
Select a range of measures

1. Click on a blank space in the first desired measure;
2. Hold down Shift, then click on a space in the last measure of the desired range.

Note: As with selecting notes, the range can be extended vertically as well as horizontally.

3. Drag selection

This method can be used to select notes or rests, or, independently, to select non-note symbols such as staccato dots, lyrics etc.:

- Press and hold Shift, then drag the cursor across the desired range.

4. Select All

This method selects the whole musical score including notes, rests and associated elements. Use one of the following options:

- Press Ctrl+A (Mac: Cmd+A).
- From the menu bar, select Edit → Select All.

5. Select section

This method is used to select a section—a region of the score starting and/or ending with an section break:

1. Click on an empty space in a measure in the section;
2. From the menu bar, select Edit → Select Section.

Note: See Copy and paste: Selection filter to disable certain types of elements from being selected in a range selection.

Select a list of objects

To select a list (or discontinuous range) of score elements:

1. Click on the first element;
2. Hold down Ctrl (Mac: Cmd) and successively click on the desired additional elements.

Note: This method cannot be used to select measures. Usesingle or range selection instead.

Select all similar

To select all elements of a specific type (e.g., all barlines, all text elements, all staccato markings):

1. Select an element;
2. Right click and choose Select...;
3. Several options are available:
   - All Similar Elements: Selects all elements in the score similar to the chosen object.
   - All Similar Elements in Same Staff: Selects all elements in the same staff similar to the chosen object.
   - All Similar Elements in Range Selection: Only applies if a range has been selected. Selects all elements in the range similar to the chosen object.
   - More...: opens a dialog that lets you fine-tune more options. For example, if you have a notehead selected, the dialog will look something like this:
Select
- Same notehead: In this example, only noteheads of the same group will be selected;
- Same pitch: Only noteheads of the same pitch will be selected;
- Same string: (tablature only) selects fretmarks on same string.
- Same type: All noteheads (of any group) will be selected;
- Same duration: Only noteheads of same duration will be selected;
- Same note name: Noteheads of that name in all octaves will be selected;
- Same staff: Only noteheads on the same staff will be selected.
- Same voice: Selects all notes of same voice.
- In selection:
- Same system:

Action
- Replace selection: The default option—starts the selection from scratch;
- Add to selection: Keeps everything you have already selected, and adds the current selection to it;
- Search in selection:
- Subtract from selection: Keep everything you have already selected, but takes away the current selection.

What selections are useful for
- Copy and paste
- Edit mode
- Inspector and object properties
- Tools

See also
- Basics chapter, esp. Note input
- Notation chapter, esp. Accidental
- Text chapter, esp. Text editing and Grid-based movement of symbols and staff text

Concert pitch
You can choose to display the score in either written or concert (sounding) pitch. Written pitch displays the score as it should look when printed for musicians to read. However, during preparation you may prefer the convenience of seeing the transposing instruments notated as they sound, without transposition. In this case you should select the "Concert pitch" option.

To toggle the score display between written or concert pitch:
- Press the Concert Pitch button (located in the top right of the toolbar area). When this button is highlighted the score is in concert pitch.

Before printing the score, exporting it to PDF or saving it online, you should ensure that the Concert Pitch button is off, and that the individual parts are correctly transposed.

See also
- Transposition: Transposing instruments
- Accidental: Respell pitches
Undo and redo

MuseScore remembers an unlimited number of undo/redo actions.

The standard shortcuts are:

- **Undo**: `Ctrl + Z` (Mac: `Cmd + Z`)
- **Redo**: `Ctrl + Shift + Z` or `Ctrl + Y` (Mac: `Cmd + Shift + Z`)

Or use the toolbar buttons:  

[Undo] [Redo]

Viewing and navigation

This chapter describes the options available in the View Menu, and in the Zoom and Page View/Continuous View menus (located in the toolbar above the score). It also details the various navigation commands and functions.

View menu

Show sidebars/panels

- **Palettes**: F9
- **Master palette**: Shift+F9 (Mac: Fn+Shift+F9)
- **Inspector**: F8 (Mac: Fn+F8)
- **Play Panel**: F11 (Mac: Fn+F11)
- **Navigator**
- **Timeline**: F12
- **Mixer**: F10 (Mac: Fn+F10)
- **Synthesizer**
- **Selection filter**: F6 (Mac: Fn+F6)
- **Piano keyboard**: P
- **Score comparison tool**

Zoom in/out

There are several ways to zoom the score in or out:

- **Keyboard shortcut**:
  - **Zoom In**: `Ctrl + +` (Mac: `Cmd + +`)
  - **Zoom Out**: `Ctrl + -` (Mac: `Cmd + -`).

- **View menu**:
  - **Zoom In**: View → Zoom In
  - **Zoom Out**: View → Zoom Out.

- **Mouse**
  - **Zoom In**: Scroll up with the mouse wheel while holding down `Ctrl` (Mac: `Cmd`)
  - **Zoom Out**: Scroll down with the mouse wheel while holding down `Ctrl` (Mac: `Cmd`).

- **Drop-down menu**: To set a specific zoom, use the dropdown menu in the standard toolbar to set the view magnification of the score (25–1600 %) or display it using the options "Page Width", "Whole Page", or "Two Pages".
You may type a custom zoom % into the dropdown field if your desired zoom level isn’t available by default.

- **To return to 100% zoom**: Use the shortcut Ctrl+0 (Mac: Cmd+0).

**Toolbars**

The **Toolbar** area is located between the **Menu bar** and the **document window**.

It contains the following toolbars:

- **File Operations**: New score, Load score, Save, Print, Undo, Redo.
- **Zoom/Page View**.
- **Playback controls**: Enable MIDI, Rewind, Play/Stop, Loop, Play Repeats, Metronome.
- **Concert Pitch**: Displays score in written or concert (sounding) pitch.
- **Image Capture**: Allows you to take a snapshot of part of the score.
- **Note Input**: Note entry mode, Duration, Tie, Rest, Accidentals, Flip stem direction, Voice (1, 2, 3, 4).

**Show/hide toolbars**

To show or hide certain toolbars:

- Select View → Toolbars, and tick/untick the options as required.
- Alternatively, right-click on an empty space in the toolbar area, or the title bar of the Inspector, and, from the menu, check or uncheck the required options.

**Note**: This option also allows you to show or hide the Timeline, Score Comparison Tool, Script Recorder, Piano Keyboard, Selection Filter, and Drumset Tools.

**Customize toolbar area**

- Select View → Toolbars, and click on “Customize Toolbars…”

The dialog shows the toolbars that can be customized on the left, the current tool buttons for the selected toolbar in the middle, and the buttons that can be added on the right. When you have selected a toolbar in the left panel, you can do any of the following actions:
- **Remove a toolbutton**: Select the button in the middle panel, and press→.
- **Add a toolbutton**: Select the button in the right panel, and press←.
- **Move a toolbutton**: Select the button in the middle panel, and move it up or down using ↑ or ↓.

*Note*: The tool bar cannot be customized unless a custom workspace is selected (see below).

**Workspaces**

Select this option to **create a custom workspace** or to **edit an existing workspace**.

**Show Status bar**

The **Status bar**, at the bottom of the screen, gives information about selected score elements. Tick/untick this option to display or hide.

**Split display**

It is possible to split the document display so as to view two documents at once, or to view two different parts of the same document. Tabs allow you to choose which document to display in each view. You can drag the barrier separating the two scores to adjust the amount of space in the window devoted to each:

- **Documents Side by Side**: Divides the window vertically into two score views.
- **Documents Stacked**: Divides the window horizontally into two score views, one above the other.

![Side by Side and Stacked displays](image)

**Visibility options**

This section allows you to display or hide various non-printing elements:

- **Show Invisible**: View/hide elements that have been made invisible for printing and export. If this option is ticked, invisible elements are shown in the score window as light gray.
- **Show Unprintable**: View/hide breaks and spacer symbols.
- **Show Frames**: View/hide the dotted outlines of frames.
- **Show Page Margins**: View/hide Page Margins.

**Mark irregular measures**

A dash at the top right of a measure indicates that its duration differs from that set by the time signature.

**Full screen**

Full Screen mode expands MuseScore to fill your screen so more content is visible.

**Page/Continuous View**

You can switch between different views of the score using the drop-down list in the toolbar area:

![Page View and Continuous View](image)

To scroll the score:

- **Vertically**: Move the mouse wheel up or down.
- **Horizontally**: Press Shift and move the mouse wheel up or down.

**Page View**
In **Page View**, the score is formatted as it will appear when printed or exported as a PDF or image file: that is, page by page, with margins. MuseScore applies system (line) and page breaks automatically, according to the settings made in **Page settings** and **Style**. In addition, you can apply your own system (line), page or section breaks.

To choose between **horizontal** or **vertical** page scrolling, see **Preferences: Canvas (Scroll pages)**.

**Continuous View**

In **Continuous View**, the score is shown as one unbroken system. Even if the starting point is not in view, measure numbers, instrument names, clefs, time and key signatures will always be displayed on the left of the window.

**Note**: Because the layout is simpler, MuseScore may perform faster in Continuous View than Page View.

**Single Page View**

In **Single Page View** the score is shown as a single page with a header but no margins, and with an infinite page height. System (line) breaks are added automatically, according to the settings made in **Page settings** and **Style**. In addition, you can apply your own system (line) or section breaks.

**Side panels**

The **workspaces**, **Inspector** and **Selection filter** are conveniently displayed as **side panels** to the left and right of the score window. To undock a side panel use one of the following methods:

- Drag the panel;
- Click on the double chevron at the top of the panel;
- Double click in the title area at the top of the panel.

To dock a panel use one of the following procedures:

- Drag the panel to the top/bottom of an existing side panel and it will stack vertically above/below that panel.
- Drag the panel to the middle of an existing side panel and it will overlay that panel. Both panels can then be accessed by tabs.

Alternatively, double-clicking the title bar of the panel will restore it to its previously docked position.

**Navigation**

**Commands**

Various commands are available to help you navigate more easily through the score. These are listed under **Keyboard shortcuts: Navigation**.

**Navigator**

The **Navigator** is an optional panel which displays page thumbnails of the score at the bottom or to the right of the document window.

- To view or hide the Navigator, select **View → Navigator**; or use a customized shortcut.

The Navigator appears at the bottom of the document window if scrolling pages horizontally; or on the right if scrolling pages vertically (see **Preferences: Canvas**).

The blue box represents the area of the score that is currently visible in the document window: drag the box, or click directly on the navigator panel to bring another part of the score into view. You can also drag the scrollbar.

**Timeline**

The **Timeline** panel provides a detailed overview of the score, with expanded possibilities for navigation and interaction.

- To display the **Timeline**, press **F12**; or select **View → Timeline**.
For details, see Timeline.

Find

The **Find** function allows you to speedily navigate to a specific measure, rehearsal mark or page number in the score:

1. Press **Ctrl+F** (Mac: **Cmd+F**), or select Edit → Find. This opens the **Find (or Go to) bar** at the bottom of the workspace.
2. Use one of the following options:
   - **To go to a numbered measure**: enter the measure number (counting every measure, starting with 1, irrespective of pickup measures, section breaks or manual changes to measure number offsets).
   - **To go to a numbered page**: enter the page number using the format pXX (where XX is the page number).
   - **To go to a numerical rehearsal mark**: enter the number using the format rXX (where XX is the name of the rehearsal mark).
   - **To go to a rehearsal mark starting with a letter**: enter the name of the rehearsal mark (the search is case insensitive).

   **N.B.**: It is best to avoid naming rehearsal marks with the single letters "R," "r," "P," "p," or one of these letters with an integer (e.g. "R1" or "p3"), as this can confuse the search algorithm.

See also

- **Save/Export/Print**
- **File format**
- **Layout and formatting**

Open/Save/Export/Print

In the **File** menu you can find options for opening, saving, exporting and printing your file:

Open

Apart from native format files (*.mscz and *.mscx), MuseScore can also open **MusicXML**, **compressed MusicXML** and **MIDI** files, as well as a variety of files in other **formats**.

To open any supported file:

1. Choose one of the following options:
   - **Press Ctrl+O**.
   - Click on the "Load score" icon on the left side of the toolbar area.
   - From the menu bar, select **File → Open** ...
2. Select a file and click **Open**; or simply double-click a file.

**Open recent** allows you to choose from a list of recently-opened scores.

Save
Save, Save As..., Save a Copy... and Save Selection... allow you to save native MuseScore files (.mscz and .mscx).

- **Save**: Save current score to file.
- **Save As...**: Save current score to new file.
- **Save a Copy...**: Save current score to new file, but continue to edit original file.
- **Save Selection...**: Save selected measures to new file.
- **Save Online...**: To save and share your scores on the web at MuseScore.com. For details, see Share scores online.

**Export**

Export... and Export Parts... allow you to create non-MuseScore files, such as PDF, MusicXML, MIDI, and various audio and image formats. In the Export dialog, you can choose which format to export to.

- **Export...**: Export current score to format of your choice.
- **Export Parts...**: Export current score and all linked parts to separate files in a format of your choice. **Note**: 'Export Parts...' is disabled (grayed out), if no such linked parts have been generated yet.

MuseScore remembers which format you picked the last time and makes that the default for the next time.

**Print**

Print... allows to print your MuseScore file directly to a printer from MuseScore. Depending on your printer you will have different options, but generally you can define the page range, number of copies and collation.

If you have a PDF printer installed, you could also "export" to PDF using Print, but it's usually better to use the native PDF option under Export for more accurate rendition. **Note**: For this to work properly with Adobe PDF, make sure to uncheck "Rely on system fonts only, do not use document fonts" in Printer properties.

**See also**

- File format
- Part extraction

**Share scores online**

MuseScore.com allows you to:

- View and listen to scores from a large repository created by the MuseScore community.
- Download any score in a variety of formats—MuseScore, MusicXML, PDF, MIDI, MP3.
- Upload your own scores: control whether to share them publicly or privately (via a secret link).
- Synchronize your score with a YouTube video ("Videoscores").

**Note**: A MuseScore Pro account is required for all scores not marked as PD (Public Domain) or "Original" work, the latter must also have the approval of the score owner.

**Create an account**

1. Visit MuseScore.com and click on "Create new account". Pick a username and enter a valid email and press "Create New Account".
2. Wait a few minutes for an email from MuseScore.com support. If no email arrives, check your spam folder.
3. Click the link in the email and visit your user profile to change your password.

**Share a score directly from MuseScore**

To save a score online:

1. Make sure that the Concert Pitch button is off, and that the individual parts are correctly transposed.
2. From the menu, select File → Save Online... The "Log in to MuseScore" dialog will appear:
3. Enter your email address or MuseScore username, and password, then click OK. **Note:** If you don't have a MuseScore account yet, create one first by clicking on the "Create an account" link. That will open your browser app and bring you to musescore.com/user/register.

4. Upon successfully logging in, you’ll be able to enter your score information.

- **Title:** The title of the score.
- **Description:** The descriptive text that will appear next to it.
- **Make the score private:** If ticked, the score can only be viewed via a private link. If unticked, the score is visible to all.
License: Choose an appropriate copyright license from the drop-down list. Note: Creative Commons license, allows people to use your scores under certain restrictions.

Tags: You can add tags to help identify scores on MuseScore.com. Use commas to separate multiple tags.

5. If the score already exists online, it will be updated automatically—you can add additional information in the changelog section of the dialog if required. This can retrieved on MuseScore.com under “Revision history” for that score. Uncheck Update the existing score to save online as a new score.

6. If you are using a different SoundFont than the default one and if you are able to export MP3 files (may not be the case on some Linux versions), a checkbox Upload score audio will be visible:

   ![Upload score audio](link)

   If the checkbox is checked, MuseScore will render the audio of the score using the current synthesizer settings and upload the audio to MuseScore.com.

Upload a score on MuseScore.com

You can also upload a score MuseScore.com itself:

1. Click the Upload link on MuseScore.com.
2. You have the same options as with the Save Online menu.
3. You also have access to more information, such as Genre.

Edit a score on MuseScore.com

If you want to make changes to one of your scores on MuseScore.com, edit the MuseScore file on your own computer, save it, and then do the following:

- If you originally shared the score directly from within MuseScore, simply go to File → Save Online... again to update the online score.
- If you originally uploaded the score via the Upload page on MuseScore.com, then you must follow these steps to update the online score:
  1. Go to the score page on MuseScore.com.
  2. Click the three dots menu on the right and choose “Update this score”.
  3. In the form, you can upload a replacement score file as well as change the accompanying information and privacy settings.

Switch to the direct method of updating an online score

It is much more convenient to update online scores from directly within MuseScore than by updating the score manually from the score page. Follow these steps if you originally uploaded the score via the Upload page and now want to switch to the direct method:

1. Go to the score page on MuseScore.com and copy the URL.
2. Open the score file on your computer with MuseScore.
3. From the menu, select File → Score Properties... and paste the URL into the “Source” field.

Now whenever you want to update the online score simply go to File → Save Online....

External links

- How to delete a score saved on MuseScore.com
- Download becomes a part of the Pro subscription

Notation

In the previous “Basics” chapter you learned how to enter notes and interact with the palettes. The “Notation” chapter describes the different types of notation in more detail, including more advanced music notation.

See also “Advanced topics”.

Barlines

A range of barline symbols for most ordinary purposes can be found in the Barlines palette (Basic workspace): repeat
barlines, only, are also available in the Repeats & Jumps palette (Basic and Advanced). Additional symbols can be found in the Barlines palette of the Advanced workspace. It is also possible to create your own custom barlines (see below).

---

**Change barline type**

To change an existing barline, use one of the following:

- Select a barline, or measure, in the score, then click an icon in the Barlines palette (double-click in versions prior to 3.4).
- Drag an icon from the Barlines palette onto a barline, or measure, in the score.
- Select an existing barline in the score, then adjust "Style" in the "Barline" section of the Inspector.

**To change a non-single to a single barline**

- Select the barline and press Del.

**To hide a barline:**

- Select the line and press V, or uncheck Visible in the Inspector.

**Insert barline**

To insert a new barline between existing ones, either:

- Drag an icon from the Barlines palette onto a note or rest.
- Select a note or rest, then click an icon in the Barlines palette (double-click in versions prior to 3.4).

**Split a measure**

You can insert a barline in order split a measure into two separate ones. Use one of the following methods:

- Press Ctrl (Mac Cmd) and drag the line from the Barline palette to the first note of the new measure.
- Select the first note of the new measure and press Ctrl (Mac Cmd) while you click a barline in the Barline palette (double-click in versions prior to 3.4).

**Note:** As of version 3.1 (or earlier), all barlines entered this way are entered as Normal Barlines. See also Split a measure.

**Custom barlines**

It is possible to create custom barlines by selecting one or more barlines, and adjusting the properties in the "Barlines" section of the Inspector:

- **Style:** Choose from a range of preset barlines.
- **Span to next staff:** Joins the selected barline to the barline in the staff below.
- **Span from:** Sets the position of the top of the barline. "0" is the top staff line. Positive numbers start lower down the staff, negative numbers above.
- **Span to:** Sets the position of the bottom of the barline (see "Span from").
- **Span presets:** Use the buttons to apply preset customized barlines.

See also Mensurstrich.

Changes to color and horizontal/vertical offset can also be made in the Inspector.

**Connect barlines**

Barlines may extend over multiple staves, as in the grand staff of a piano, or in an orchestral score to join instruments in the same section. To join barlines:

1. Enter Edit mode on a barline.
2. Click on the lower blue handle and drag it down to the staff you wish to connect to. The handle snaps into position so there is no need to position it exactly.

3. Press Esc to exit edit mode. This will update all other relevant barlines as well.

See also
- Measure operations
- Repeats and jumps for information on repeat barlines
- Add fermata to barline

Clefs

Commonly used Clefs (Treble, Bass, Alto, Tenor) can be found in the Clef palette in the Basic workspace. For a more complete range, see the Clefs palette in the Advanced workspace (see image below).

Add a clef

Add clef to beginning of measure

Method 1. To add a clef to beginning of a measure, whether or not it is the first measure in a system, use one of the following methods:
- Select a measure and click a clef symbol in the palette (double-click in versions prior to 3.4).
- Drag a clef from the palette onto a measure.

Method 2. To change the clef at the start of a system, use one of the following methods:
- Select the existing clef at the beginning of the system and click a new clef from the palette (double-click in versions prior to 3.4).
- Drag a new clef from the palette directly onto the existing clef.

Add mid-measure clef

- Click on a note, then click a clef in the palette (double-click in versions prior to 3.4).

Note: If the clef is not the first in the system, it will be drawn smaller.

In this image, the top staff starts with a treble clef and switches immediately to bass clef, then after a note and a rest, changes back to treble clef.
**Note:** Changing a clef does not change the pitch of any note. Instead, the notes move to preserve pitch. If you want, you can use Transposition in conjunction with a clef change.

**Courtesy clefs**

When a clef change occurs at the beginning of a system, a **courtesy clef** will be generated at the end of the previous system.

**To show or hide all courtesy clefs:**

1. From the menu, select **Format → Style... → Page**;
2. Check/uncheck "Create courtesy clefs."

It is also possible to show/hide courtesy clefs on a case-by-case basis:

1. "Create courtesy clefs" should already be ticked in the "General" menu (see above);
2. Select a clef and tick/untick "Show courtesy" in the Inspector.

**Remove a clef**

- Select a clef and press Del.

**Hide clefs**

**Display clef only in the first measure (for all staves)**

1. From the menu, select **Format → Style... → Page**;
2. Uncheck "Create clef for all systems."

**Display clef only in the first measure (for a particular staff)**

1. Right click on the staff (Mac:Ctrl-click) , select **Staff properties... and uncheck "Show clef;"
2. Open the **master palette** and select the "Symbols" section;
3. Drag and drop a clef from the master palette onto the first measure of the staff; OR select the first note and click a clef in the master palette (double-click in versions prior to 3.4).

**Note:** This option may be useful to TAB users who do not want the clef to repeat on every subsequent line.

**Hide all clefs in a particular staff**

1. Right click on the staff (Mac:Ctrl-click) , and select **Staff properties...**;
2. Uncheck "Show clef."

**Key signatures**

Standard **key signatures** are available in the Key Signatures palette in the Basic or Advanced workspaces. It is also possible to create **custom key signatures** (below).
Add a new key signature

Add new key signature to all staves

Use any of the following methods:

- Drag a key signature from the palette onto an empty part of a measure.
- Select a measure and click a key signature in the palette (double-click in versions prior to 3.4).
- Select a note and click a key signature in a palette (double-click in versions prior to 3.4).

Add new key signature to one staff only

If you wish to change the key signature of only one staff line, leaving others unchanged:

- Press Ctrl (Mac: Cmd) and hold while you drag a key signature from a palette onto a measure.

Replace an existing key signature

Replace key signature for all staves

Use any of the following methods:

- Drag a key signature from the palette onto the key signature to be replaced (or onto the measure containing the key signature).
- Select the key signature to be replaced, and click a new key signature in a palette (double-click in versions prior to 3.4).

Replace key signature for one staff only

If you wish to replace the key signature of only one staff, leaving others unchanged:

- Press Ctrl (Mac: Cmd) and hold while you drag a key signature from a palette onto the key signature to be replaced (or onto the measure containing the key signature).

Remove a key signature

Use any of the following methods:

- Click on an existing key signature and press Del.
- Drag the empty key signature ("open/atonal") from the palette (in the advanced workspace) onto the measure.

Naturals on key signature changes

By default, MuseScore only shows cancelling naturals when the key signature changes to that of C Major/A minor (no sharps or flats). In all other cases, it simply shows the new key signature without cancellations:

However, you can opt to display cancelling naturals for all key signature changes:

1. From the menu, select Format → Style... → Accidentals. You'll see the options:
2. Select one of the three options.

3. If you are in a part and want the new option to apply to all parts, click on Apply to all parts.
4. Click OK to exit.

For example, selecting the option "Before key signature if changing to fewer $\#$ or $b$" gives:

And the option "After key signature if changing to fewer $\#$ or $b$. Before if changing between $\#$ and $b$" gives:

Key signature changes and multi-measure rests

Multi-measure rests are interrupted if there is change of key signature:

Courtesy key signatures

To turn off the display of a particular courtesy key signature:

- Select the relevant key signature and untick "Show courtesy" in the "Key Signature" section of the Inspector.

To turn off the display of all courtesy key signatures:

- From the menu, select Format → Style... → Page, and untick "Create courtesy key signatures."

Note: Courtesy key signatures are not displayed at section breaks.

Custom key signatures

To create a custom key signature:

1. Press Shift+K to display the Key signatures section of the Master palette.
2. In the Create Key signature panel, drag accidentals from the palette onto the staff above to create the desired key signature. **Note**: The treble clef is only decorative—custom key signatures for any type of staff can be created here.

3. Use the Clear button, if required, to remove all accidentals from the "staff."

4. To move the new key signature into the library (center panel), press Add. To delete a key signature from the library, right-click it (Mac: Ctrl-click) and, in the drop-down menu, select Delete.

**Note**: A limitation of custom key signatures is that they cannot be transposed in the usual way. If a transposition is needed, or where there is a clef change, you will need to create a new custom key signature.

To move a key signature from the Master palette to a custom palette:

- Drag and drop the key signature onto a palette.

To apply a key signature to the score directly from the Master palette, use one of the following methods:

- Select a measure and click a key signature in the Master palette (double-click in versions prior to 3.4).
- Drag a key signature from the Master palette onto a measure; alternatively, to apply to one staff only, hold Ctrl (Mac: Cmd) while dragging.

### Accidentals

The most common types of **accidentals** are provided in the Accidentals toolbar above the score and in the Accidentals palette in the basic workspace.

<table>
<thead>
<tr>
<th>#</th>
<th>b</th>
<th>x</th>
<th>↓</th>
</tr>
</thead>
<tbody>
<tr>
<td>♯</td>
<td>♭</td>
<td>×</td>
<td>b</td>
</tr>
</tbody>
</table>

A more comprehensive range can be found in the Accidentals palette in the advanced workspace.

### Add accidental

**Accidentals** are automatically added to a note, as appropriate, when you increase or decrease its pitch:

- :: Increase the pitch of a note by one semitone (favors sharps).
- :: Decrease the pitch of a note by one semitone (favors flats).

To add either (i) a double flat or double sharp, (ii) a courtesy (also known as cautionary or reminder) accidental, or (iii) a non-standard accidental, use one of the following options:

- Select a note and click on an accidental in the toolbar above the score.
- Select a note and click an accidental in the Accidentals palette (double-click in versions prior to 3.4).
- Drag an accidental from the Accidentals palette onto a note.
If you wish to add brackets to a cautionary accidental, use one of the following:

- Select the accidental in the score and click the parentheses symbol in the Accidentals palette (double-click in versions prior to 3.4).
- Drag the parentheses symbol from the palette onto the accidental.
- Select the accidental and choose from the Bracket type dropdown in the Inspector.

If required, accidentals can be deleted by clicking on them and pressing Del.

Change enharmonic spelling

To change the enharmonic spelling of a note, or notes, in both written and concert pitch views:

1. Select a note, or group of notes;
2. Press J;
3. Continue pressing J to cycle through the enharmonic equivalents.

To change the enharmonic spelling in the written pitch view, without affecting the concert pitch view, or vice versa:

1. Select a note, or group of notes;
2. Press Ctrl+J (Mac: Cmd+J);
3. Continue pressing the same combination of keys to cycle through the enharmonic equivalents.

Note: If the pitches of selected notes are not all the same, the effect may be unpredictable.

Respell pitches

- From the menu, select Tools → Respell Pitches.

See also

- Key signature: Change

External links

- Accidental at Wikipedia
- Enharmonic at Wikipedia

Time signatures

Time signatures can be found in a Palette of the same name in both the Basic and Advanced workspaces.

Add or replace a time signature

Use any of the following methods:

- Select a time signature, measure, note or rest, and click a time signature in a palette (double-click in versions prior to 3.4).
- Drag and drop a time signature from a palette onto a space in a measure, or onto an existing time signature.

Delete a time signature

- To delete a time signature in the score, select it and press Del.

Create a time signature

If the time signature you require is not available in any of the existing palettes, it can be created as follows:

1. Press Shift+T to display the Time signatures section of the Master Palette.
2. Select a time signature to edit in the center panel.
3. In the Create Time Signature panel, edit the various parameters (numerator, denominator, text, beaming) to get the time signature and properties you want. To restore the default beaming pattern, press Reset.
4. Press Add to add the newly-created time signature to the center panel. To delete a time signature from the center
panel, right-click (Mac: Ctrl-click) on it and select Clear.
5. Drag and drop the time signature from the Master Palette to the desired score location.

This can be saved to a custom palette for future use, if desired.

Time signature properties

To display the Time Signature Properties dialog:

- Right-click (Mac: Ctrl-click) on a time signature and select Time Signature Properties….

![Time Signature Properties dialog]

- **Global value**: Shows the global time signature and is set automatically when you add a time signature to the score. It is the reference for beats (as shown in the status bar) and tempo markings.
- **Actual value**: Shows the time signature associated with a particular staff. This is normally the same as the global time signature, but can be set independently if required. See Local time signatures.
- **Appearance**: Allows you to edit the displayed text without affecting the underlying time signature. For an example, see Additive meters.
- **Note Groups**: Allows you to change the default beaming of notes associated with a time signature. See Change default beaming.

Change default beaming

To adjust note-beaming for a particular time signature:

1. Right-click (Mac: Ctrl-click) on the time signature and select Time Signature Properties…;
2. To break a note beam in the Note Groups panel, click on the note following it. To reset the beam, click in the same place. Alternatively, you can change beaming by dragging a beam icon onto a note, as follows:

   - ![Start beam at this note.](image)
   - ![Do not end beam at this note.](image)
   - ![1/8th note beam to left of this note.](image)
   - ![1/16 note beam to left of this note.](image)

Checking the box for "Also change shorter notes," means that any beam changes at one level are applied automatically to shorter durations as well. The Reset button cancels any changes made in that session.

Additive (composite) meters

Additive (or composite) time signatures are sometimes used to clarify the division of beats within a measure. To create an additive time signature:

1. Right-click (Mac: Ctrl-click) on a time signature in the score and select Time Signature properties…;
2. In the Appearance section, adjust the "Text" property as required;
3. Adjust note beaming in the Note Groups section if required.

**Note:** The Time Signatures section of the Master palette also allows you to create additive time signatures (see above).

**Local time signatures**

In certain cases a score may show staves with different time signatures running at the same time. For example, in Bach's 26. Goldberg Variation:

![Variation 26](image)

In the above example, the global time signature is 3/4, but the time signature of the upper staff has been set independently to 18/16.

To set a local time signature for just one staff:
- Hold down Ctrl (Mac: Cmd) and drag and drop a time signature from a palette onto an empty measure.

**Resize time signature**

- Select one or more time signatures and, in the "Time Signature" section of the Inspector, adjust the "Scale X" (width) and "Scale Y" (height) values.

**Pickup measures and cadenzas**

Occasionally you will need to decrease or increase the duration of a measure without changing the time signature—for example, in a pickup measure (anacrusis) or in a cadenza etc. See Measure operations: Measure duration.

**Time signature changes and breaks**

Multi-measure rests are interrupted when a time signature change occurs. Also, a section break will prevent a courtesy time signature being shown at the end of the previous measure.

**See also**
- Key signature

**External links**

- How To Using Polyrhythm, mixed meters and local time signatures in MuseScore
- Additive meters at Wikipedia.

**Arpeggios and glissandi**

Arpeggio and Glissando symbols can be found in the "Arpeggios & Glissandi" palette in the advanced workspace. This palette also includes strum arrows, an arpeggio bracket, wind instrument articulations, and slide in/slide out symbols.

Add symbol

To add an arpeggio, glissando etc. to the score, use one of the following methods:
Select one or more notes, then click a symbol in a palette (double-click in versions prior to 3.4).
Drag a symbol from a palette onto a note.

Adjust dimensions

To adjust the length and height of a symbol:

- Enter Edit mode for the symbol, and adjust the handles using keyboard shortcuts.

Custom symbols

After selecting a symbol, various useful properties can be adjusted in the "Glissando" or "Arpeggio" section of the Inspector.

Glissando

- Type: Choose between a straight or wavy line;
- Show text: Tick this box if you want the symbol to display text. Then set the wording, font-face, font-size and font-style underneath. Note: If there isn't enough room between notes, the text is not displayed;
- Play: Check/unchecked the box to turn playback on or off.
- Play style: Choose how the glissando plays back. There are four options: Chromatic, White keys, Black keys, Diatonic;

Arpeggio

- Stretch: Increase this to lengthen the duration of the arpeggio.
- Play: Untick if you don't want the symbol to affect playback.

If needed for future use, you can save the result in a custom palette.

Arpeggios

When an arpeggio or strum arrow is added to the score, it initially spans only one voice. To change the height, see Adjust dimensions (above). Playback of the symbol can be turned on or off in the Inspector.

Glissandi (slides)

A Glissando or, more informally, a slide, spans two consecutive notes. It may be wavy or straight, with or without text.
E.g.

Adjust start and end points of a glissando

To move an end handle vertically or horizontally, from one note to the next:

1. Enter edit mode on the symbol;
2. Click on the start or end handle:
   - Use Shift+↑↓ to move the handle up or down, from note to note.
   - Use Shift←→ moves the handle horizontally, from note to note.

Use this command to create cross-staff glissandi. Or to correct the positions of end handles when applying multiple glissandi to chords.
Wind instrument articulations

Fall, Doit, Plop and Scoop symbols are provided. To change the length and curvature, select the symbol, enter edit mode and adjust the handles as described in Edit mode: Lines.

Slide in/out

Slide in and Slide out lines can also be found in the "Arpeggios & Glissandi" palette. To edit the length and angle of a line, double-click on it and drag the handle (or use the Inspector or keyboard arrows for finer adjustment).

External links

- [Arpeggio](https://en.wikipedia.org/wiki/Arpeggio) at Wikipedia

Articulations and ornaments

A comprehensive set of symbols can be found in the Articulations palette in the Advanced workspace:

![Articulations Palette](image)

and the Ornaments palette (Advanced workspace):

![Ornaments Palette](image)

There is also an abbreviated version of Articulations in the Basic workspace.

![Articulations Palette (Basic)](image)

Articulations

Articulations are the symbols added to the score to show how a note or chord is to be played. The principal symbols in this group are:

- Fermatas
- Staccato
- Mezzo-staccato / Portato
- Staccatissimo
- Tenuto
- Sforzato
- Marcato

Specialist articulations are also included for bowed and plucked strings, wind instruments etc.

Ornaments

Ornaments include:

- Mordents, Inverted Mordents, Pralltrills
- Trills
- Turns
- Bends

Note: Appoggiaturas and acciaccaturas can be found in the Grace Notes palette.
Add articulation/ornament

Use either of the following methods:

- **Select** a note or a range of notes, then click a symbol in a palette (double-click in versions prior to 3.4).
- **Drag** a symbol from a palette onto a notehead.

**Add accidental to an ornament**

To apply an accidental to an existing ornament, such as a trill:

1. Select the note to which the ornament is attached;
2. Open the **Symbols section** of the **Master palette**;
3. Search for and **apply** the desired accidental to the score (small accidentals can be found using the search term "figured bass");
4. Drag the accidental into position (or reposition using keyboard shortcuts or the **Inspector**).

**Add fermata to a barline**

Use one of the following methods:

- **Select** a barline, then click a fermata symbol in a palette (double-click in versions prior to 3.4).
- **Drag** a fermata symbol from a palette onto a barline in the score.

**Note:** This does not affect playback.

**Keyboard shortcuts**

- **Toggle Staccato:** Shift+S
- **Toggle Tenuto:** Shift+N
- **Toggle Sforzato (accent):** Shift+V
- **Toggle Marcato:** Shift+O
- **Add Acciaccatura (grace note):** /

**Keyboard shortcuts** can be customized in MuseScore's **Preferences**.

**Adjust position**

Immediately after adding an articulation or ornament from a palette, the symbol is automatically selected: It can then be moved up or down from the keyboard as follows:

- Press up/down arrow keys for fine positioning (0.1 sp at a time);
- Press Ctrl+↑ or Ctrl+↓ (Mac: Cmd+↑ or Cmd+↓) for larger vertical adjustments (1 sp at a time).
- To flip a symbol to the other side of the note (where applicable), select it and press X.

To enable adjustments in all directions from the keyboard:

1. Enter **Edit mode** on the symbol;
2. Press arrow keys for fine positioning (0.1 sp at a time); or press Ctrl+Arrow (Mac: Cmd+Arrow) for larger adjustments (1 sp at a time).

You can also change the horizontal and vertical offset values in the **Inspector**. To position more than one symbol at a time, select the desired symbols and adjust the offset values in the **Inspector**.

**Note:** The symbol can also be repositioned by clicking and dragging, but for more precise control, use the methods above.

**Articulation and ornament properties**

These can be edited from the **Articulation** section of the **Inspector** and may include:

- **Placement:** Above or below the staff.
- **Direction:** Auto / Up / Down.
- **Anchor:** Adjust the vertical placement of the symbol.
- **Time stretch:** For fermatas, adjust the pause length.
- **Ornament style:** Default or Baroque.
- **Play:** Turn playback on or off.

For **Bend** properties, see **Bends**.

You can find additional global style settings for articulations and ornaments under **Articulations, Ornaments**.

**See also**
Bends, of various kinds, can be created with the Bend Tool. You can find this in the Articulations palette of the Advanced workspace. Any bend applied to the score can be customized in the Bend section of the Inspector.

Apply a bend

To apply one or more bends to the score, use one of the following options:

- Select one or more notes and double-click a bend symbol in the palette.
- Drag a bend symbol from the palette on to a note.

Edit bend

Text and line properties

1. Select the bend;
2. Adjust the following properties in the Bend section of the Inspector:
   - Line thickness.
   - Font, Size, Style: Properties of the text.
   - Play (checkbox): Whether the bend affects playback or not.

Global text and line properties for all bends in the score can be edited in Format → Style... → Bend.

Bend shape and width

Versions 3.4 and above

1. Make sure that the bend is selected.
2. In the "Bend" section of the Inspector use the Bend type dropdown to choose from a range of presets. "Bend" is the default option.
3. Make adjustments, as required, to the graphical display of the bend in the Inspector: see Edit graphical display (below).

Versions prior to 3.4

1. Select the bend and click on Properties in the Inspector; Alternatively, right-click on the bend and select "Bend Properties."
2. Choose from a range of presets under Bend type. "Bend" is the default option.
3. Make adjustments, as required, to the graphical display of the bend: see Edit graphical display (below).

Edit graphical display

The bend is represented by a graph consisting of gray lines connected by square, blue nodes (see image above). The slope of the line indicates the type of bend:

- Up-slope = Up-bend
- Down-slope = Down-bend
- Horizontal line = Hold
The vertical axis of the graph represents the amount by which the pitch is bent up or down: one unit equals a quarter-tone: 2 units a semitone, 4 units a whole-tone, and so on. The horizontal axis of the graph indicates the length of the bend: each gray line segment extends for 1 space (sp) in the score.

A bend is modified by adding or deleting nodes in the graph:

- To add a node, click on an empty intersection.
- To delete a node, click on it.

Adding a node lengthens the bend by 1 sp; deleting a node shortens the bend by 1 sp. The Start and End points of the bend can be moved up and down only.

Adjust height

The height of the bend symbol is automatically adjusted so that the text appears just above the staff. This height can be adjusted, if necessary, with a workaround:

1. Create another note vertically above the note (shortening the line) or below the note (extending the line) at which you want the bend to start.
2. Apply the bend to the created note.
3. To adjust the height of the bend move this created note vertically so that the bend symbol gets the desired height.
4. Drag the bend symbol to the correct position (to the original note).
5. Mark the created note invisible and silent (using the Inspector).

Adjust position

To adjust position use one of the following:

- Drag the bend symbol with a mouse.
- Click on the symbol and adjust the horizontal and vertical offsets in the Inspector.
- Double click on the symbol; or click on it and press Ctrl+E (Mac: Cmd+E); or right-click on the symbol and select "Edit element." Then use the arrow keys for fine positioning (0.1 sp at a time); or Ctrl+Arrow (Mac: Cmd+Arrow) for larger adjustments (1 sp at a time).

Custom bends

After a bend has been created in the score it can be saved for future use by dragging and dropping the symbol to a palette while holding down Ctrl+Shift (Mac: Cmd+Shift). See Custom Workspace.

External links

- Bending at wikipedia

Beams

Adjust automatic note beaming

By default, MuseScore beams notes according to settings in the Time Signature Properties dialog. To change this automatic pattern of note-beaming, see Change default beaming.

Change beaming of individual notes

MuseScore also allows you to override the default beaming of any note, using the beam symbols in the Beam Properties palette of the "Basic" or "Advanced" workspaces:

To change one or more note beams (except feathered beams, below), use one of the following methods:

- Drag and drop a beam symbol from the Beam Properties palette onto a note in the score.
- Select one or more notes in the score and click the desired symbol in the Beam Properties palette (double-click in versions prior to 3.4).

To apply feathered note beams, use either of the following methods:

- Drag and drop a feathered-beam symbol from the Beam Properties palette onto a note beam in the score.
- Select one or more note beams in the score, then click on a feathered-beam symbol in the Beam Properties palette (double-click in versions prior to 3.4).
Notes: (1) Feathered beams may use 2 or 3 lines depending on the tempo and the desired rate of the change; (2) To create a 2-line feathered beam, you need to start with a continuous run of beamed sixteenth notes; (3) To create a 3-line feathered beam, you need to start with continuous run of beamed thirty-second notes; (4) Playback of feathered beams is not supported.

Beam symbols and their effects

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>♫</td>
<td>Beam start</td>
<td>If the note is beamed to a previous note, break the beam.</td>
</tr>
<tr>
<td>♫</td>
<td>Beam middle</td>
<td>Create a beam from the selected note to the previous note (if applicable).</td>
</tr>
<tr>
<td>♫</td>
<td>No beam</td>
<td>Break beams before and after the selected note.</td>
</tr>
<tr>
<td>♫</td>
<td>Beam 16th sub</td>
<td>Start a second level beam at this note.</td>
</tr>
<tr>
<td>♫</td>
<td>Beam 32nd sub</td>
<td>Start a third level beam at this note.</td>
</tr>
<tr>
<td>AUTO</td>
<td>Automatic Beam</td>
<td>Apply default beaming as determined by the current time signature (see above).</td>
</tr>
<tr>
<td>🦊</td>
<td>Feathered beam, slower</td>
<td>Start feathered beam to indicate gradually slower tempo.</td>
</tr>
<tr>
<td>🦊</td>
<td>Feathered beam, faster</td>
<td>Start feathered beam to indicate gradually faster tempo.</td>
</tr>
</tbody>
</table>

Note: Be aware that the beam between two notes/rests is determined by both of the note/rests. For example: Two consecutive notes with a status of start beam here will not have a beam between them. If the two consecutive notes are willing to connect to each other they will beam, if one of them is not willing, the two notes will not beam.

Adjust beam angle

To adjust with the keyboard or mouse:

1. Enter edit mode on the note beam—the right adjustment handle is automatically selected.
2. Use the up/down arrows or drag the right end handle to change the angle of the beam;
3. Press Esc to exit edit mode.

To adjust with the Inspector:

1. Click on a note beam.
2. Tick the "User position" box in the "Beam" section of the Inspector;
3. Set the "Position" values to get the desired beam angle.

Adjust beam height

To adjust with the keyboard or mouse:

1. Enter edit mode on the note beam—the right adjustment handle is automatically selected.
2. Press Shift+Tab or click the left handle to select it;
3. Use the up/down arrows or drag the left end handle to change the height of the beam;
4. Press Esc to exit edit mode.

To adjust with the Inspector:

1. Click on a note beam.
2. Tick the "User position" box in the "Beam" section of the Inspector;
3. Set the "Position" values as desired.

Make beam horizontal

1. Select a note beam
2. Tick the "Force Horizontal" box in the "Beam" section of the Inspector;

Note: "Force Horizontal" in the "Beam" section of the Inspector can only be selected if "Custom position" has been deselected previously. This setting overrides the Custom Position values and automatically sets the horizontal bar to its original height.
If you want all note beams in the score to be horizontal there is a "Flatten all beams" option in Format → Style... → Beams. If this option is not selected, automatically inclined beams will be set according to the pitch of the connected notes. This global setting can be overridden for individual beams according to the methods described above.

Adjust feathered beams

To adjust feathered beams:

1. Select a note beam.
2. Adjust the values in the "Grow left" and "Grow right" boxes in the "Beam" section of the Inspector.

Local relayout

MuseScore spaces notes according to their time values, allowing for accidentals, lyrics etc. In systems where there is more than one staff, this may result in irregular note spacing, as in the following example:

Local relayout is a tickbox option in the Inspector allowing you to specify those passages in the score where you want the note spacing to be independent of other staves in the system. Applying "Local relayout" to the note beams in the top staff of the previous example results in a more even distribution of notes:

To do a local relayout:

1. Select one or more note beams.
2. Tick the option Local relayout in the "Beam" section of the Inspector.

Flip note beam

To flip a beam from above to below the notes, or vice-versa:

1. Select one or more note beams.
2. Use any of the following options:
   - Press the x key;
   - Press the "Flip direction" icon, in the toolbar.
   - Select a "Direction" option (Auto, Up or Down) in the "Beam" section of the Inspector.

Reset Beam Mode

To restore beams to the mode defined in the local time signatures:

1. Select the section of the score you want to reset. If nothing is selected, the operation will apply to the whole score;
2. Select Format → Reset Beams.

See also

- Cross-staff notation
- Edit mode
- Note input
- Change default beaming

External links

- How beams work
How to add a beam over a rest
How to place a beam between notes

Brackets

MuseScore provides brackets and a curly brace in the Brackets palette (Advanced workspace).

When a new score is created using a template, MuseScore automatically sets the correct brackets.

Add

To add a bracket or brace to systems, use one of two methods:

- Select a measure on the staff where you want the bracket/brace to start, and click the desired icon in a palette (double-click in versions prior to 3.4).
- Drag a bracket/brace icon from a palette on to the staff where you want the bracket/brace to start.

Delete

- Select the bracket and press Del.

Change

- Drag the desired icon from a palette onto an existing bracket/brace in the score.

Edit

When you first apply a bracket it only spans one staff. To extend to other staves:

1. Enter Edit mode.
2. Drag the handle downwards to span the required staves. The handle snaps into position, so exact placement is not required.

Style

The default thickness and distance from the system of brackets and braces can be adjusted in Format → Style... → System.

In the System Brackets section, you can set the properties for the brackets in the two boxes on the left, and the properties for the braces in the two boxes on the right.

Breaths and pauses

Breath and pause markings are available in the Breaths & Pauses palette (Advanced workspace).

Add symbol

To add a breath, or pause (aka caesura / "tram lines" / "railroad tracks") to the score, use one of the following options:

- Select a note or rest and click a breath or pause symbol in a palette (double-click in versions prior to 3.4).
- Drag a breath or pause symbol from a palette onto a note or rest in the score.
The symbol is placed after the note. Its position can be adjusted by editing the X and Y offsets in the Inspector, or, in edit mode, using the arrow keys.

Adjust pause length

You can adjust the pause length (in seconds) of the added symbol in the Inspector.

Grace notes

A grace note is a type of musical ornament, usually printed smaller than regular notes. The Short grace note, or Acciaccatura, appears as a small note with a stroke through the stem. The Long grace note, or Appoggiatura, has no stroke.

Create grace notes

Grace notes can be found in the "Grace notes" palette in the Basic or Advanced workspace.

Add a grace note

Use one of the following methods:

- Select a regular note and click a grace note in the palette (double-click in versions prior to 3.4).
- Drag a grace note symbol from a palette onto a regular note.
- Select a note and press / to create an acciaccatura only.

This will add a grace note of the same pitch as the regular note. To add a sequence of grace notes to a regular note, simply repeat the above actions as many times as required. See also, Change pitch (below).

Note: When a grace note is added to the score, a slur is not automatically created with it, so the latter needs to be added separately. See Slurs.

Add a chord of grace notes

Grace note chords are built up just like regular chords:

1. Enter the first note of the chord as shown above
2. Select this first grace note and enter subsequent notes as you would for any other regular chord (i.e. Shift+A...G).

You can also create a grace note chord by using the add interval shortcut in step 2: Alt+1...9 for intervals from a unison to a ninth above.

Change pitch

The pitch of a grace note can be adjusted just like a regular one:

1. Select one or more grace notes
2. Adjust pitch using the keyboard arrow commands, namely:
   - ↑ or ↓ to increase or decrease the pitch by a semitone;
   - Alt+Shift+↑ or Alt+Shift+↓ to increase or decrease the pitch one step at a time, according to the key signature.

Change duration

- Select the grace note and either click a duration icon on the toolbar, or apply the duration with the appropriate keyboard shortcut: i.e. 1...9 (see Note input).

Manual adjustment

Horizontal position

To adjust the horizontal space between a grace note and its regular parent note, use one of the following:

- Go into edit mode on the grace note, then use the left/right arrow keys to reposition as desired.
- Select the grace note and change the X-offset value in the Chord section of the Inspector.

Other adjustments
Various other properties of the grace note can be adjusted in the Inspector (see "Element," "Chord," and "Note" sections)—such as vertical position, size, stem properties etc. The exception is "Leading space" which only applies to standard notes.

External links
- Grace note at Wikipedia
- Appoggiatura at Wikipedia
- Acciaccatura at Wikipedia

Hairpins

Add a hairpin

Hairpins are symbols used to indicate gradual changes in volume in the score. There are two kinds: crescendo (getting louder) and decrescendo (getting quieter).

![Crescendo and Decrescendo](image)

To create a hairpin:
1. Select a range of notes or measures;
2. Use one of the following shortcuts:
   - <: to create a crescendo hairpin.
   - >: to create a diminuendo hairpin (decrescendo).

Alternatively, use one of the following options:
- Select a range of notes or measures, and click a hairpin in a palette (double-click in versions prior to 3.4).
- Drag and drop a hairpin from a palette onto a staff line.

Adjust length and height

A hairpin is a type of Line with playback properties, and its length is adjusted similarly:

1. Enter edit mode on the hairpin. Then click on the end handle that you want to move:

![Hairpin with handles](image)

2. Use one of the following shortcuts:
   - Shift+→ to move the end handle, and its anchor, right by one note or rest.
   - Shift← to move the end handle, and its anchor, left by one note or rest;

This method of extending or shortening the hairpin maintains playback integrity and allows it to cross line breaks:

![Extended hairpin](image)

3. To fine-tune the horizontal position of an end-handle (without changing playback), use the following shortcuts:
   - → to move the handle right by 0.1 sp.
   - ← to move the handle left 0.1 sp.
   - Ctrl+→ (Mac: Cmd+→) to move the handle right one sp.
   - Ctrl← (Mac: Cmd←) to move the handle left one sp.

To change the height of a hairpin

- Adjust the lower handle at the mouth of the hairpin (e.g. the blue square below):
Cresc. and dim. lines

In addition to hairpins, there are cresc. _ _ _ and dim. _ _ _ lines with the same function in the Lines palette. You can adjust the text, if desired, in the Text Line Core section of the Inspector.

To turn a hairpin into its equivalent text line

- Select the hairpin and, in the Hairpin section of the Inspector, select the appropriate line from “Type.”

Copy hairpins

From version 3.1, a hairpin can be cut, copied and pasted just like a text element: see Summary of cut / copy / paste commands.

For versions prior to 3.1, you can only duplicate a hairpin: see Copying lines.

Edit hairpin properties

Properties of the hairpin can be edited in the Inspector, as follows:

- **Element**: Edit the Y offset to change the height of the hairpin above or below the staff.
- **Line**: Edit line properties such as color, line style and thickness.
- **Text line core**: Add text and set text properties.
- **Hairpin**:
  - **Type**: Change the type of hairpin: crescendo, decrescendo or text.
  - **Circled tip**: Tick box to activate.
  - **Height**: The width at the mouth of the hairpin.
  - **Continue height**: The width of the hairpin at the end of a system, before it continues to the next system.
  - **Placement**: Set hairpin above or below the staff.
  - **Dynamic range**: Specify whether hairpin playback applies to a staff, part (default) or a system.
  - **Velocity change**: … across the span of the hairpin; from 0 to 127.
  - **Use single note dynamics** (as of version 3.1): When checked (default), allows the hairpin to change the dynamic of a single note if the instrument supports single note dynamics.
  - **Dynamic Mode** (as of version 3.1): Set the method used to change the dynamic: Linear (default), Ease-in and out, Ease-in, Ease-out, or Exponential.

Playback of hairpins

By default, a hairpin always affects playback when it spans a series of separate notes. In addition, for instruments supporting single note dynamics (e.g. strings, brass etc.), playback is also enabled across a single note or series of tied notes. (Note: Prior to version 3.1 hairpins only affected playback between notes, not that of single or tied notes.)

A hairpin only affect playback if there are appropriate dynamics somewhere before and after the hairpin. For example, a crescendo between p and f dynamics will affect playback; but a diminuendo between p and f will be ignored. And if there are two or more crescendos between p and f, all but the first will be ignored.

A hairpin may be used without dynamic marks, by adjusting “Velocity change” in the Inspector (values in the range 0 to 127).

**Lines**

The Lines palette of the Advanced workspace contains the following lines:
As you can see, the palette includes: Slurs, Hairpins, Volta brackets, Octave lines, and many others.

Applying lines to the score

Most lines (except Slurs, Volta brackets and the Ambitus) can be applied from a palette in the following ways:

To apply a line to just one note

1. Click on a note, then Ctrl+Click on the next note;
2. In a palette, click on a line (double-click in versions prior to 3.4).

To apply a line across a range of notes

1. Select a range of notes;
2. In a palette, click on a line (double-click in versions prior to 3.4).

To apply a line from a note to the end of that measure

Use any of the following methods:

- Click on a note, then, in a palette, click on a line (double-click the latter in versions prior to 3.4).
- Drag and drop a line onto the score.

To apply a line across a range of measures

1. Select one or more measures;
2. In a palette, click on a line (double-click in versions prior to 3.4).

Lines and playback properties

Some lines, such as Hairpins, Voltas, Ottavas etc., have a playback effect as well as being indicative. Each **end handle** is connected by a dotted line to an **anchor** on the staff (visible in Edit mode). These anchors indicate the extent of the playback effect.

Adjust vertical position

In **Normal mode**, apply one of the following methods:

- Click on one or more lines and change the vertical offset in the Inspector;
- Click on a line, press and hold Shift and drag it up/down with a mouse.

**Note:** You can also adjust the vertical position in **Edit** mode.

Change length
1. Enter **Edit mode** and click on an end handle;

2. Apply one of the following shortcuts:
   
   - Shift + → to move the end handle, and its anchor, right by one note (or, in the case of Volta, one measure)
   - Shift + ← to move the end handle, and its anchor, left by one note (or, in the case of Volta, one measure)

   **Note:** This method allows the line to span systems when required, and ensures that playback coincides with the line's visual extent.

3. If you wish to change the position of an end handle *without* changing the position of its anchor, apply one of the following:
   
   - → to move the handle right by 0.1 sp (1 sp = one staff space = the distance between two staff lines).
   - ← to move the handle left 0.1 sp.
   - Ctrl + → (Mac: Cmd + →) to move the handle right one sp.
   - Ctrl + ← (Mac: Cmd + ←) to move the handle left one sp.

   **Note:** You can also drag the endpoint handles with a mouse.

**Text lines**

A text line is a line that has text embedded within it—such as a volta, ottava, guitar barre line etc.

When you apply a text line to the score from a palette, the *line* properties always remain unchanged, but the *text* properties may, under certain circumstances, assume those of the current *style* for text lines. For details, see **Behavior of applied text and lines**.

**Custom lines**

Any line in the score can be customized by adjusting its properties in the *Inspector*, as follows:

1. Select the line;
2. If line hooks are needed, make a selection from *Begin hook*, *End hook* and *Height* (in the Text Line Core section);
3. To add text, tick *Begin Text*, *Continue Text* or *End Text*, then type in the "Text" box:
   
   - **Begin**: Text added here appears at the beginning of the line;
   - **Continue**: Text added here appears at the beginning of a continuation line;
   - **End**: Text added here appears at the end of the line;
4. Edit text properties and alignment as required;
5. Edit Placement: "Above" or "Below" sets the text so that it is on the line. "Left" places the text to the left of the line;
6. Make adjustments to the line color, thickness and style (solid, dashed etc.) in the Line section. The **Diagonal** option allows you to create a diagonal line by dragging the end handles;
7. To save the result for future use, see **Custom palettes**.

**Copying lines**

Once applied to the score, lines cannot be copied using the usual copy and paste procedures. However, you can duplicate lines within a score:

- Press and hold Ctrl + Shift (Mac: Cmd + Shift), click on the line and drag it to the desired location.

**Extended ornament lines**

To add an accidental to an extended ornament (e.g. a trill line), select the line and click on a symbol in the Accidentals palette (double-click in versions prior to 3.4).

**External links**

- Piano pedal marks at Wikipedia
- Guitar Barre at Wikipedia

**Measure rests**

**Full measure rest**

A whole rest, centered within a measure (shown below), is used to indicate that an entire measure (or a voice within a measure) is silent, regardless of time signature.

```
-
```

To create one or more full measure rests
Use the following method if all selected measures are "standard"—i.e. with no custom durations:

1. Select a measure, or range of measures.
2. Press Del.

If one or more of the measures contains a custom duration, use the following method instead:

1. Select a measure, or range of measures.
2. Press Ctrl+Shift+Del (Mac: Cmd+Shift+Del).

To create a full measure rest in a particular voice:

1. In the appropriate voice, enter a rest that extends for the full measure.
2. Make sure the rest is selected, then press Ctrl+Shift+Del (Mac: Cmd+Shift+Del).

**Multimeasure rest**

A multimeasure rest indicates a period of silence for an instrument: the number of measures is shown by the number above the staff.

Multimeasure rests are automatically interrupted at important points, such as double barlines, rehearsal marks, key- or time signature changes, section breaks, etc.

To display multimeasure rests:

To turn multimeasure rests on or off:

- Press M on your keyboard.

Alternatively:

1. From the menu, choose Format → Style…
2. Click on the "Score" tab, if it is not already selected;
3. Tick/untick "Create multi-measure rests". Here you can also set the minimum of empty measures to combine into a multi measure rest (see also Layout and formatting: Score).

**Note:** It is recommended that you enter all notes in the score first before enabling multi-measure rests.

**Break multimeasure rest**

You may want to have a multi-measure rest divided into two multi-measure rests:

1. Ensure that the option to display multimeasure rests in the score is off (see above).
2. Right-click on the measure where you want the second multi-measure rest to start;
3. From the menu, choose Measure Properties and tick "Break multi-measure rest."

See also: Measure operations: Break multimeasure rest.

**Octave lines**

Octave (Ottava) lines are used to indicate that a section of music is to be played one or more octaves above or below written pitch: The line may be dotted or solid. Ottavas are available in the Lines palette of the Basic and Advanced workspaces.

8——— or 8va——— : Play one octave above written pitch
8——— or 8va——— : Play one octave below written pitch

8va alta/bassa lines are particularly common in piano scores, though they are sometimes used in other instrumental music. A 15ma alta (2 octaves above) and 15ma bassa (2 octaves below) are also occasionally used.
MuseScore automatically adjusts playback of the score under the ottava to the correct pitch.

**Apply an octave line**

See [Applying lines to the score](#).

And to adjust the vertical position, see [Lines: Adjust vertical position](#).

**Change length**

See [Lines: Change length](#).

**Custom lines**

Ottavas can be customized just like any other line. See [Custom lines and line properties](#).

Properties unique to Octave lines can be adjusted in the **Ottava** section of the Inspector:

- **Type**: Change the Ottava line text.
- **Placement**: Set to "Above" or "Below" the staff.
- **Numbers only**: Untick for both number and text (e.g. "8va"). Tick for a number only (e.g. "8").

**External links**

- Octave at [Wikipedia](#)

---

**Slurs**

A slur is a curved line between two or more notes indicating that they are to be played *legato*—smoothly and without separation. Not to be confused with Ties, which join two notes of the same pitch.

There are a number of ways to add a slur to a score, and all may be useful depending on the context (adding a slur from the **lines palette** is also possible but not recommended).

**Add slur in note-input mode**

1. While in **Note input mode**, type in the first note in the slurred section;
2. Press **s** to begin the slurred section;
3. Type in the remaining notes in the slurred section;
4. Press **s** again to end the slurred section.

**Add slur in Normal mode**

**Method 1**

1. Make sure you are in **Normal mode**;
2. Select the note where you want the slur to start:
   ![Slur Example](#)
3. Press **s** to add a slur extending to the next note:
4. (Optional) Hold \textit{Shift} and press \textup{→} (right arrow key) to extend the slur to the next note. Repeat as required:

5. (Optional) Press \textit{X} to flip the slur direction:

6. Press Esc to exit edit mode.

\textbf{Method 2}

1. Make sure you are in \textit{Normal mode};
2. Select the note where you want the slur to start;
3. Choose one of the following options:
   \begin{itemize}
   \item To add a slur to one voice \textit{only}: Hold down Ctrl (Mac: \textit{Cmd}) and select the last note that you want the slur to cover.
   \item To add slurs to \textit{all} voices: Hold down \textit{Shift} (Mac: \textit{Cmd}) and select the last note that you want the slurs to cover.
   \end{itemize}
4. Press \textit{S}.

\textbf{Adjust slur}

If you only want to adjust the \textit{position} of a slur:

1. Select the slur;
2. Use any of the following methods:
   \begin{itemize}
   \item Drag the slur.
   \item Adjust the horizontal and vertical offset values in the \textit{Inspector}.
   \end{itemize}

To adjust \textit{all} the properties of a slur (length, shape and position):

1. Make sure you are \textit{not} in \textit{note input mode};
2. Go into \textit{Edit mode} on the slur;
3. Click on a handle to select it, or use Tab to cycle through the handles;
4. To move the \textit{left and right handles} from note to note, use the following shortcuts:
   \begin{itemize}
   \item Shift→: Move to next note.
   \item Shift←: Move to previous note.
   \item Shift↓: Move to lower voice (voice 2 to voice 1 etc.).
   \item Shift↑: Move to higher voice (voice 1 to voice 2 etc.).
   \end{itemize}
5. To adjust the position of \textit{any} handle, use any of the following methods:
   \begin{itemize}
   \item Drag the handle.
   \item Use the arrow keys for fine adjustment (0.1 sp, at a time). For larger adjustments (1sp, at a time) use Ctrl→←↑↓.
   \end{itemize}
6. Press Esc to exit edit mode.

\textbf{Note}: The two outer handles adjust the start and end of the slur, whilst the three handles on the curve adjust the contour. The middle handle on the straight line is used to move the whole slur up/down/left/right.

\textbf{Extended slurs}

A slur can span several systems and pages. The start and end of a slur is anchored to a note/chord or rest. If the notes are repositioned due to changes in the layout, stretch or style, the slur also moves and adjusts in size.

This example shows a slur spanning from the bass to the treble clef. Using the mouse, select the first note of the slur, hold down Ctrl (Mac: \textit{Cmd}) and select the last note for the slur, and press \textit{S} to add the slur.
x flips the direction of a selected slur.

**Dotted slurs**

Dotted slurs are sometimes used in songs where the presence of a slur varies between stanzas. Dotted slurs are also used to indicate an editor's suggestion (as opposed to the composer's original markings). To change an existing slur into a dotted or dashed slur, select it and then in Inspector (F8) change Line type from Continuous to Dotted Or Dashed.

**See also**

- Tie
- Edit mode
- Note input

**Ties**

A tie is a curved line between two notes of the same pitch, indicating that they are to be played as one combined note (see external links below). Ties are normally created between adjacent notes in the same voice, but MuseScore also supports ties between non-adjacent notes and between notes in different voices.

In note-input mode, if you specify a tie immediately after entering a note or chord, the program automatically generates the correct destination notes to go with the ties. Or, you can simply create ties “after the fact,” between existing notes.

**Note:** Ties, which join notes of the same pitch, should not be confused with slurs, which join notes of different pitches and indicate legato articulation.

**Add ties in Note Input mode**

The following command adds an identical tied chord to the selected chord.

1. Ensure that a note is selected (i.e. highlighted). This can be a single note, or part of a chord.
2. Select a new note duration for the following note(s), if required (but see “Note” below).
3. Press + or the tie button, \(\text{tie} \).  

**Note:** This shortcut works, as described above, only if there is no chord following the selected note. If there is, then the duration is ignored and the tied note is added instead to the following chord.

**Add ties in Normal mode**

**Method 1**

1. **Select** one or more noteheads in the "start" chord.

![Select one or more noteheads](image)

2. Press +, or the toolbar tie button, \(\text{tie} \).

![Press +, or the toolbar tie button](image)

Ties will be created between the selected note(s) and the next available note(s) of the same pitch.

To remove ties, as of MuseScore 3.3.3, use the same command (toggle)

**Method 2**
This method ties all notes in the ‘start’ chord (where possible):

1. Select the stem of the ‘start’ chord;
2. Press +, or click on the toolbar tie button.

Ties will be created between all the notes in the selected chord and the following notes of the same pitches.

To remove ties, as of MuseScore 3.3.3, use the same command (toggle).

Add extra tied notes to a previously tied chord

Occasionally you may need to return to an existing tied chord in order to add one or more extra tied notes. In this case a different command is used. For example:

1. Add the extra notes to the first chord. e.g.

2. In Note input mode, and with any of the notes in the first chord selected, press +. Corresponding notes are added to the following chord and the extra notes are tied:

Add ties to unison notes

A workaround is required to create ties between unison notes:

1. Create the first note as usual;
2. Any additional unison notes should be added at an interval other than unison: e.g. 2nd, 3rd, 4th etc.
3. Create a tied chord (as shown above): e.g.

4. Move the unison note(s) into position: e.g.

Flip a tie

x flips the direction of a selected tie, from above the note to below the note, or vice-versa.

See also

Slur

External links

- How to create ties leading into a 2nd ending
- Ties (music) at Wikipedia

Tremolo

Tremolo is the rapid repetition of one note or chord, or a rapid alternation between two notes or chords. Tremolo symbols can be found in the Tremolo palette in the advanced workspace: both one note and two note tremolos are possible.

A one-note or one-chord tremolo is indicated by strokes through the stem of the note or chord (or above/below if a whole note). E.g.
In a two-note or two-chord tremolo, bars are drawn between the notes. E.g.

Tremolo symbols are also used to notate drum rolls.

Add a Tremolo

Single note/chord tremolo

1. If a single note, select that note; if a chord, select any note in the chord;
2. Click the desired symbol in the Tremolo palette (double-click in versions prior to 3.4).

Alternatively, you can drag the tremolo symbol onto the applicable note.

Two note/chord tremolo

1. Input the notes at half the desired final duration;
2. If a single note, select the first note of the pair; if a chord, select any note from the first chord;
3. Click the desired symbol in the Tremolo palette (double-click in versions prior to 3.4).

Alternatively, you can drag the tremolo symbol onto the applicable note.

Example: To enter a two-note tremolo with the duration of a half note (minim), enter two normal quarter notes (crotchets). After applying a tremolo symbol to the first note, the note values automatically double to half notes.

External links

- Tremolo (Wikipedia)
- How to create ‘old style’ and other special tremolos? (MuseScore HowTo)

Repeats and jumps

Simple repeats

You can create a simple repeat by placing a start and an end repeat barline at the beginning and end of a passage. These can be applied from the Barlines or Repeats & Jumps palette.

Note: If the start of a repeat coincides with the beginning of a piece or section, the start repeat barline can be omitted if desired. Similarly, an end repeat barline can be omitted at the end of a score or section.

1st and 2nd endings

First create a simple repeat (as shown above), then apply the first and second time endings—see Voltas.

Playback

To hear repeats during playback, make sure the “Play Repeats” button on the toolbar is selected. Likewise, you can turn off repeats during playback by deselecting the button.

To set the number of times that a repeat section plays back:

1. Make sure the start and end repeat barlines are in place (e.g. simple repeats above).
2. Right-click on the last measure containing the end repeat barline and select Measure properties.
3. Adjust “Play count” as required.
Repeat symbols and text

Text and symbols related to repeats are located in the Repeats & Jumps palette (in the Basic and Advanced workspaces). This palette contains:

- Symbols for measure repeat, Segno, Segno Variation (Serpent), Coda, and Coda Variation (Codetta)
- D.S., D.C., al Coda, al Fine, To Coda, and Fine text
- Repeat barlines

To add a repeat symbol to the score use either of the following:

- Select a measure, then click the desired repeat symbol in the palette (double-click in versions prior to 3.4).
- Drag and drop a repeat symbol from the palette onto (not above!) the desired measure (so the measure changes color).

Jumps

Jumps are symbols in the score which tell the musician, and playback, to skip to a named marker (see below). Jumps include the various kinds of D.C. (Da Capo) and D.S. (Dal Segno) text.

Just like with simple repeats, make sure the "Play Repeats" button on the toolbar is selected so the jumps are honored. Likewise, you can turn off jumps during playback by deselecting the button.

Note: Jumps are taken only after all simple repeats are done.

If you click on a jump, some text boxes and a checkbox are displayed in the Jump section of the Inspector. These have the following effects on playback:

- **Jump to**: Playback jumps to the marker whose "Label" is the same as the "Jump to" tag.
- **Play until**: Playback continues until it reaches a marker whose "Label" is the same as the "Play until" tag.
- **Continue at**: Playback jumps to the next marker whose "Label" is the same as the "Continue" tag.
- **Play repeats**: Ticking this box tells MuseScore to play repeats after D.C. (Da Capo) or D.S. (Dal Segno) jumps. If this option is not ticked then simple Repeats are not taken after jumps and playback works as if it were the last repeat.

Note: The tags start and end, referring to the beginning and end of a score or section, are implicit and don't need to be added by the user.

Markers

Markers are the places referred to by the jumps. A list of markers (in addition to the implicit "start" and "end") follows:

- Segno (tag: segno)
- Segno Variation (tag: varsegno)
- Coda (tag: codab)
- Coda Variation (tag: varcoda)
- Fine (tag: fine)
- To Coda (tag: coda)

If you click on a marker, the following properties appears in the Marker section of the Inspector:

- **Marker type**: This can be changed from the dropdown list, if required.
- **Label**: This is the (identifier) tag associated with the marker. See also Jumps (above).

Examples of jumps
• **Da Capo (D.C.):** At the “D.C.” sign, playback jumps to the start (i.e. to the implicit `start` tag) and plays the entire score or section again (i.e. up to the implicit end tag).

• **Da Capo (D.C.) al Fine:** At the “D.C. al Fine” sign, playback jumps to the start (i.e. to the implicit `start` tag) and plays the score up to the Fine (i.e. the `fine` tag).

• **Dal Segno (D.S.) al Fine:** At the “D.S. al Fine” sign, playback jumps to the Segno symbol (i.e. the `segno` tag) and then plays up to the Fine (i.e. the `fine` tag).

• **Dal Segno (D.S.) al Coda:** At the “D.S. al Coda” sign, playback jumps to the Segno symbol (i.e. the `segno` tag) and then plays up to the To Coda (i.e. the `coda` tag). Playback then continues at the Coda symbol (i.e. the `codab` tag).

**Note:** The properties (i.e. the tag names) of jumps and markers can be set via the Inspector. You need to modify them if using multiple jumps and markers.

**See also**

- Barlines
- Volta

**External links**

- MuseScore in Minutes: Repeats and Endings, part 2 (video tutorial)
- How to separate a coda from the rest of the score (MuseScore HowTo)

**Tuplets**

Tuplets are used to write rhythms beyond the beat divisions usually permitted by the time signature. For example, a **triplet** consists of three notes in the time of two:

```
\begin{music}
\g clef=bass\f
g4 f4 e4 \hline
g4 f4 e4 \hline
g4 f4 e4 \hline
g3 f3 e3 \hline
g4 f4 e4 \hline
g4 f4 e4 \hline
\end{music}
```

And a **duplet** consists of two notes in the time of three:

```
\begin{music}
\g clef=bass\f
g4 f4 e4 \hline
g4 f4 e4 \hline
g3 f3 e3 \hline
g3 f3 e3 \hline
g4 f4 e4 \hline
g4 f4 e4 \hline
\end{music}
```

**Create a tuplet**

The exact method of tuplet entry depends on whether you are starting off in **Note input mode** or **Normal mode**. We’ll start off with a simple example: the creation of an eighth note triplet.

**Create a triplet in normal mode**

1. Select a note or rest that specifies the full duration of the desired triplet group. In the case of an eighth note triplet, you will need to select a quarter note or rest—as in the example below:

```
\begin{music}
\g clef=bass\f
g4 \hline
g4 \hline
\end{music}
```

2. Press the keyboard shortcut for a triplet, `Ctrl`+`3` (Mac: `Cmd`+`3`); alternatively use the menu, Add → Tuplets → Triplet. This will give the following result:

```
\begin{music}
\g clef=bass\f
g3 \hline
g3 \hline
g3 \hline
g3 \hline
\end{music}
```

3. The program automatically changes to note-input mode and selects the most appropriate duration—in this example an eighth note. Now enter the desired series of notes/rests. For example:

```
\begin{music}
\g clef=bass\f
g3 f3 e3 \hline
g3 f3 e3 \hline
g3 f3 e3 \hline
g3 f3 e3 \hline
\end{music}
```

**Create a triplet in note input mode**

1. Ensure you are in note input mode (press `N`).

101
2. Navigate to the note/rest (or blank measure) where you want the triplet to start (use the left/right arrow keys as required).

3. Select a final duration for the whole triplet group. In the case of an eighth note triplet, click on the quarter note in the note input toolbar (or press 5 on the keyboard).

4. Press the keyboard shortcut for a tuplet, Ctrl+3 (Mac: Cmd+3); alternatively, use the menu, Add → Tuplets → Triplet. This creates a triplet number/bracket and appropriately divides the original note/rest (see image above).

5. The program automatically selects the most appropriate duration—in this example an eighth note—allowing you to immediately start entering the desired series of notes/rests.

Create other tuplets

To create other tuplets substitute one of the following commands at the relevant step above:

- Press Ctrl+2–9 (Mac: Cmd+2–9). 2 for a duplet, 3 for a triplet etc.
- From the menu, select Add → Tuplets, then click on the desired option.

For more complex cases, see below.

Custom tuplets

To create other tuplets than the default options (e.g. 13 sixteenth notes in the space of one quarter note):

1. In Note input mode, select a note duration equaling the total duration of the tuplet; or, if in Normal mode, select a note or rest of the desired overall duration;

2. Open the Create Tuplet dialog from the menu: Add → Tuplets → Other...

3. Select the desired number ratio (e.g. 13/4 for thirteen sixteenth notes in the space of a quarter note) under "Relation" in the "Type" section. Specify "Number" and "Bracket" using the radio buttons in the "Format" section;

4. Click OK to close the dialog:

5. Enter the desired series of notes/rests.

Delete a tuplet

Use either of the following:

- Select the number or bracket and press Del.
- Select the entire tuplet, using the shift + click method, then press Del.
- Select any element of the tuplet, then in Inspector, in the bottom right corner, press the Tuplet button, then press Del.

Change display of tuplets

Using the Inspector

To change the display properties of tuplets in the score, select the tuplet numbers/brackets, and adjust the desired properties in the “Tuplet” section of the Inspector.
• **Direction**: 'Auto' places the bracket/number in the *default* position. 'Up' always places the bracket *above* the note heads; 'Down' always places the bracket *below* the note heads.

• **Number type**: Choice of 'Number', 'Ratio', or 'Nothing'.

• **Bracket type**: 'Automatic' hides the bracket for beamed notes and *shows* the bracket if the tuplet includes unbeamed notes or rests. 'Bracket' displays the bracket. 'None' hides the bracket.

**Using the Tuplets Style dialog**

To make fine adjustments to the way that all tuplets in the score are displayed: from the menu, select **Format → Style... → Tuplets**.

The legend below illustrates some of the properties that can be adjusted in the Tuplets style dialog:

(2) Vertical distance from stem.
(3) Vertical distance from note head.
(5) Distance before stem of first note.
(6) Distance after stem of last note.

**External links**

- [How to create triplets and other tuplets](#)
- [How to create nonstandard tuplets](#)
- [How To create triplets and other tuplets across measures](#)
- [Tuplet](#) at Wikipedia
- [The User Guide to Tuplets in MuseScore](#) [video]

**Voltas**

Volta brackets, or first and second ending brackets, are *lines* used to mark different endings for a *simple repeat*. Score playback automatically follows the repeat indications.

To add a volta to the score

Use one of the following methods:

- Select a measure, or range of measures and click a Volta icon in the *Lines palette* (double-click in versions prior to 3.4).
- Drag-and-drop a volta from the *Lines palette*, then adjust the length as required (see below).

**To change the number of measures that a volta covers**

1. Go into **Edit mode** on the volta. The end handle is automatically selected.
2. Press Shift→ to move the end handle *forward* one measure. Press Shift← to move the handle *backward* one measure. Repeat as required.

**Note**: When you select a start or end handle, a dashed line appears connecting it to an *anchor* point on the staff (see diagram, below). This anchor shows the position of the playback start/end points of the Volta. The Shift commands change the anchor point so playback always remains in sync with the *visual* start/end points. To make fine adjustments to the
visual start or end points, without affecting playback, use other keyboard arrow commands, or drag the handles with a mouse.

Volta properties

To make changes to Volta text

- Select the volta, and edit the properties in the Text Line Core section of the Inspector.

To specify the order of repeats:

- Select the volta, and in "Repeat list" Volta section of the Inspector) type in a number, or sequence of numbers separated by commas, to indicate the repeat(s) in which the volta is to be played.

For example, a first ending shows the number "1"; a second ending, the number "2" and so on. More complex repeats are also possible: e.g. a "Repeat list" displaying "1, 2, 4, 5, 7" indicates that the volta is to be played during repeats 1, 2, 4, 5, and 7, and so on.

Note: Each volta section, except the final one, needs to end with a **repeat barline**.

Playback

Sometimes a repeat plays more than two times. If you want to change the number of times MuseScore plays a repeat, go to the measure containing the end repeat barline and change its "Play count". See Measure operations: Other properties.

External links

- MuseScore in Minutes, Lesson 8: Repeats and Endings, Part 1
- How to create ties leading into a 2nd ending

Transposition

Transposition is the act of raising or lowering the pitch of a selection of notes by the same interval. You can choose to transpose notes either manually or by using the Transpose dialog.

Manual transposition

1. Select the notes that you wish to transpose;
2. Use any of the following options:
   - **To transpose chromatically**: Press ↑ or ↓. Repeat as required.
   - **To transpose diatonically**: Press Alt + Shift + ↑ or ↓. Repeat as required.
   - **To transpose by an octave**: Press Ctrl + ↑ or ↓ (Mac: Cmd + ↑ or ↓).
Automatic transposition

MuseScore’s Transpose dialog gives you more options for transposing notes.

Note: By default this dialog opens from the Tools menu, but you can also choose to open it using a keyboard shortcut (see Preferences).

Transpose Chromatically

To Key

To transpose notes up or down to the desired key:
1. Select the notes you want to transpose; no selection equals “select all.”
2. From the menu bar, choose Tools → Transpose…
3. Tick “Transpose Chromatically” and “To key”.
4. Tick/untick “Transpose key signature” and “Transpose chord symbols” if required.
5. Tick one of “Closest”, “Up” or “Down” and select a destination key signature from the drop-down menu.
6. Click OK.

By Interval

To transpose selected notes up or down in semitone increments:
1. Select the notes you want to transpose; no selection equals “select all”.
2. From the menu bar, choose Tools → Transpose…
3. Tick “Transpose Chromatically” and “By Interval”.
4. Tick/untick “Transpose key signature” and “Transpose chord symbols” if required.
5. Tick “Up” or “Down”; and select a transposition interval from the drop-down menu.
6. Click OK.

Transpose Diatonically

To transpose selected notes up or down by a diatonic interval:
1. Select the notes you want to transpose; no selection equals “select all”.
2. From the menu bar, choose Tools → Transpose…
3. Tick “Transpose Diatonically”.
4. Tick/untick “Keep degree alteration” and “Transpose chord symbols” if required.
5. Tick “Up” or “Down”; and select a transposition interval from the drop-down menu.
6. Click OK.
Options

Two options are available for both Chromatic and Diatonic transposition mode in the options area:

- Transpose chord symbols, if required.
- And the choice of Use Double♯ and ♭ or Single♯ and ♭ Only

Transposing instruments

Transposing instruments, such as the B-flat trumpet or E-flat alto sax, sound lower, or higher than their written pitch. MuseScore has a number of features to facilitate the scoring of these instruments.

Concert pitch

MuseScore's default viewing mode shows the musical notation in written pitch, but you can choose to display the score in concert pitch instead. In the latter mode, the musical notation of all instruments matches the actual pitches that you hear on playback.

- To change the view to concert pitch: Press the Concert Pitch button to highlight it.

You should ensure that the Concert pitch button is OFF before printing the main score or any parts.

Change staff transposition

Instrument transpositions are already set up in MuseScore. However, if you want a rare instrument or transposition that is not available in MuseScore, you may need to edit the instrument transposition manually.

1. Right-click an empty part of the instrument staff and select Staff/Part Properties….
2. At the bottom of the window, select the interval of transposition, any octave shifts, and whether the interval is "Up" (sounds higher than written) or "Down" (sounds lower than written).

You can also use the Change Instrument… button in the Staff/Part Properties window to automatically change the transposition to that of a different standard instrument.

External links

- How to transpose (MuseScore How-To)
- Concert pitch or not? (forum discussion)
- How to change enharmonic key signatures for transposing instruments (MuseScore How-To)

Drum notation

Entering percussion notation is somewhat different to entering notation for pitched instruments (such as the piano or violin).

Percussion staff types

When you create a percussion staff using the New Score Wizard or the Instruments dialog, MuseScore automatically chooses the most appropriate staff type (1-, 3-, or 5-line) for the instrument: this can be changed, if required, using the "Staff type" column on the Choose instruments / Instruments page. Any additional changes (e.g. to a 2-line staff) can be made from the score itself (see Advanced Style Properties).

On a 5-line percussion staff, each instrument is assigned a vertical staff position (line or space) and a notehead shape. For a drumset, one or two voices can be used. If the latter, voice 1 (the upper voice) usually contains (up-stem) notes played by the hands while voice 2 (the lower voice) usually contains (down-stem) notes played by the feet (see image below).

Drums

Note input methods

You can add notes to a percussion staff from any of the following:

- External MIDI keyboard;
- Piano keyboard (virtual);
- Computer keyboard;
- Mouse.
These methods can be used in any desired combination:

**MIDI keyboard**

To add notes to a percussion staff from a MIDI keyboard:

1. Ensure that the MIDI keyboard is connected and functioning correctly.  
   
   **Note:** If you click on the percussion staff without entering note input mode, you can demo the percussion instruments from the MIDI keyboard.

2. Click on the note or rest where you want to start.

3. Enter note input mode.

4. Select the correct voice. For example, snares, sidesticks and all cymbals are normally added to voice 1; bass drum to voice 2.

5. Set note duration.

6. Press an instrument key to add a note to the score. To add another note at the same position, keep the first key held down while pressing the second key.

**Note:** Refer to a GM2 drum map for details about which MIDI keyboard key corresponds to which percussion instrument. Some keyboards (e.g., Casio) display percussion symbols next to the keys as an aid to the user.

**Piano keyboard**

To add notes to a percussion staff from the virtual Piano Keyboard:

1. Ensure that the Piano keyboard is displayed. Press P (or select it from the menu, View → Piano Keyboard).

   **Note:** If you click on the percussion staff without entering note input mode, you can demo the percussion instruments from the Piano keyboard.

2. Click on the note or rest where you want to start.

3. Enter note input mode.

4. Select the correct voice. For example, snares, sidesticks and all cymbals are normally added to voice 1; bass drum to voice 2.

5. Set note duration.

6. Click on a (virtual piano) key to add a note to the score.

7. To add another note to an existing one, press Shift and hold it while pressing the new note (in versions before 2.1, use Ctrl (Mac: Cmd)).

**Note:** Refer to a GM2 drum map for details about which piano key corresponds to which percussion instrument.

By default, the piano keyboard is docked at the bottom of the screen—to the left of the Drum input palette. However you can undock it by dragging, then dock the panel in several ways:

- Drag the panel downwards to the center and it will overlay the Drum input palette, full length. Both panels can then be accessed by Tabs.
- Drag the panel downwards to the right/left and it will dock to the right/left of the Drum input palette.

**Computer keyboard**

To enter notes on a percussion staff using your computer keyboard:

1. Click on the note or rest where you want to start.

2. Enter note input mode. The Drum input palette now appears at the bottom of the screen (see below).

3. Select the desired note duration.

4. Press the shortcut key (A–G) for the instrument that you wish to enter—refer to the Drum input palette window.

5. If you wish to add another note to an existing one in that voice, press Shift + [A–G].

**Note:** Voice allocation is determined by the color of the note in the drum input palette: blue for voice 1, green for voice 2.

**Mouse**

To add a note to a percussion staff

Use the following method to add a new note or to replace an existing chord.

1. Select the note or rest where you want to start. You can also select a measure.

2. Press n to enter note input mode. The Drum input palette now appears at the bottom of the screen (see below).

3. Set note duration.

4. Choose one of the following options:
Double-click a note in the Drum input palette.
Select a note (e.g. Bass drum, or Snare) in the Drum input palette, then click a note or rest in the score.

To add a note to an existing chord in the percussion staff

1. Ensure you are in note input mode.
2. Select a note duration equal to the note you are adding to.
3. Click on the new note in the Drum input palette.
4. Click above or below the existing note in the percussion staff.

Note: Voice allocation is determined by the color of the note in the drum input palette: blue for voice 1, green for voice 2.

Drum input palette

When a percussion staff is selected and note input mode is ON, a window opens at the bottom of the screen called the Drum input palette. This window is essential for mouse input, and displays shortcuts for computer keyboard input, but can be ignored if using a MIDI keyboard or the virtual Piano Keyboard.

Each note in the palette represents a percussion instrument: hovering the mouse pointer over the note displays the instrument name.

The letters A–G (shown above certain notes in the palette) are designated as shortcuts for entering particular instruments (bass drum, snare, closed hi-hat etc.), rather than referring to note pitches. They can be changed or reallocated as desired in the Edit Drumset window.

When the Drum input palette is open, double-clicking a note in the palette or entering a shortcut letter will add that instrument note to the percussion staff. The color of the note in the palette shows the voice allocated for that note—blue for voice 1, green for voice 2. This can be changed in the Edit Drumset dialog if required.

This voice allocation applies only to keyboard and mouse entry of notes: entry via a MIDI keyboard or the virtual Piano keyboard allows any voice to be used.

Edit Drumset

To open the Edit Drumset window, use one of the following options:

- Click on the Edit Drumset button at the left of the Drum input palette.
- Right-click on a percussion staff and select "Edit Drumset...".

The Edit Drumset dialog displays the percussion instruments available and the MIDI notes/numbers to which they are allocated. It also determines how each instrument is displayed on the staff—its name, position, notehead type and note-stem direction. Any changes made here are automatically saved in the parent MuseScore file.

Clicking on a row in the left-hand column allows you to edit the display properties for that note as follows:

Name: The name you want displayed in the Drum input palette when you mouse over the note.
Notehead group: Choose a notehead for that instrument from a drop-down list of options (Note: choosing "Custom" activates "Edit noteheads" (below)).
**Edit Noteheads:** Allows you to customize the display further by specifying the noteheads for particular note durations.

**Default voice:** Assign to one of four voices. This does not affect input from a MIDI keyboard or the virtual Piano keyboard.

**Staff line:** This number indicates the staff line/space on which the note is displayed. "0" means that the note is displayed on the top line of the 5-line staff. Negative numbers move the note upwards step by step, while positive numbers move it downwards in the same way.

**Shortcut:** Assign a keyboard shortcut to enter that note.

**Stem Direction:** Auto, Up or down.

The customized drumset can be saved as a .drm file by pressing **Save As**. You can also import a customized drumset using the **Load** button.

**Sticking**

To enter sticking symbols (R, L):

1. Select a start note;
2. From the menu, select **Add → Text → Sticking**. Alternatively, set up a keyboard shortcut to do the same thing in **Preferences**;
3. Input the symbol just as you would normal text. To move forward or backwards to the next note, use the same keyboard shortcuts as for **chord symbols**;
4. To exit, press **Esc**, or click on a blank section of the score.

**Add drum roll**

To create a drum roll, use a **Tremolo**.

**External links**

- How to create jazz drum notation [MuseScore How-To]
- Video tutorial: MuseScore in Minutes: Lesson 7 - Tablature and Drum Notation [video]
- Drum Parts [video]
- Editing the Drum Palette in MuseScore 1.1 [video]
- Saving Drumset Changes in MuseScore 1.1 [video]
- Guide to Drum and Percussion Notation [video]

**Tablature**

Music for fretted, stringed instruments is commonly notated using **tablature**, also known as **tab**, which provides a visual representation of the strings and fret numbers:

![Tablature example](image)

Tablature can also be combined with traditional staff notation:

![Staff and tablature combination](image)

**Create a new tablature staff**

If you wish to create tablature as part of a new score, use the **New Score Wizard**. If you want to add tablature to an existing score, use the **Instruments** dialog. Or, alternatively, you can convert an existing standard staff. See below for details.

**With the New Score wizard**

To create tablature in a new score (for combined staff/tablature systems see →below):

1. Open the **New Score wizard**.
2. Enter the score details (optional). Click Next.
3. On the **Choose template file** page, click on Choose Instruments under “General”.
4. On the **Instruments** page, select the desired tablature in the “Strings – plucked” category, in the left-hand column. Then click Add.
5. Complete the rest of the New Score Wizard.

**Note:** If the desired tablature is not available in the *Choose Instrument* list, add a tablature staff anyway at step 4 (above). Then edit the tablature to your exact requirements using the *Staff/Part properties* dialog.

**With the Instruments dialog**

To add a single tablature staff to an existing score (for combined staff/tab system see below):

1. Open the **instruments** dialog (press i; or from the menu bar, select Edit → Instruments…).
2. Add the tab staff as described in *Add instruments* (“Create a new score”).

**By changing staff type**

To convert an existing standard staff to tablature, or tablature to a standard staff:

1. Right click on the staff and select Staff/Part Properties…. If “Instrument” is already set to a plucked-strings type, then go to step 3.
2. If “Instrument” is not a plucked-strings type, click on Change instrument and select an appropriate instrument from “Strings – Plucked.”
3. Click on Advanced Style properties, select the appropriate tablature option from “Template”, then press < Reset to Template. You can fine tune the display if necessary using the “Fret Marks” and “Note Values” tabs.
4. Click OK twice to exit.

**Edit string data**

**Change tuning**

**Note:** If you only want to view (rather than change) the instrument tuning, follow steps 1 and 2 only.

1. Right-click on the staff and select Staff/Part Properties…. 
2. Press the Edit String Data… button at the bottom of the dialog box. The *String Data* dialog opens:
3. Click on a string pitch and select Edit String… Or, alternatively, just double-click the string pitch.

4. Select a new pitch in the Note Selection box and click OK. Or, alternatively, just double-click the new pitch.

5. Click OK to close the "String Data" dialog box. Then click OK to close the "Staff/Part Properties" dialog.

Notes: (1) If tuning is changed when the tablature for that instrument already contains some notes, fret marks will be adjusted automatically (if possible); (2) Any change of tuning to a particular instrument applies only to the score at hand, and does not change any program default settings.

Add a string

1. Right-click on the staff, select Staff/Part Properties…, then press Edit String Data.
2. Click on a string pitch and select New String….
3. Select the new pitch and press OK—or, alternatively, just double-click the new pitch. The new string is inserted below the selected string.

Note: After adding a tablature string you will need to adjust the number of lines in the Staff/Part properties dialog.

Delete a string

1. Right-click on the staff, select Staff/Part Properties…, then press Edit String Data.
2. Click on a string pitch and select Delete String.

Note: After deleting a tablature string you will need to adjust the number of lines in the Staff/Part properties dialog.

Mark unfretted string "open"

This feature is used to mark a (bass) course as unstopped (i.e. like a harp string, only played in the open position): as on a Baroque lute or Theorbo etc. This means that only "0" (zero) or "a" is accepted as a fret mark; any other fret mark will be converted to 0/a.

1. Right-click on the staff, select Staff/Part Properties…, then press Edit String Data.
2. Check one or more boxes in the "Open" column.

Change number of instrument frets

This property defines the maximum fret number which can be entered on a tablature staff.

1. Right-click on the staff, select Staff/Part Properties…, then press Edit String Data.
2. Select or enter a new number in the Number of frets spin box.

Change tablature display

You can customize both the appearance of a tablature staff and the way that it displays the fret marks. To access these options:

1. Right click on the staff and select Staff/Part Properties….
2. Click on the Advanced Style Properties… button.

Combine pitched staff with tablature

Plucked-string instruments—such as the guitar—are commonly notated using both a music staff and tablature (TAB) together. MuseScore gives you the option of having the two staves either unlinked or linked:
1. **Unlinked Staves**: The advantage of using this option is that each staff can be edited independently. To transfer music notation from one staff to the other, select the desired range and copy and paste it onto the other staff.

2. **Linked Staves**: The staves are "mutually updating": i.e. any change you make to the notation in one staff is immediately applied to the other staff as well.

**A note on fret mark conflicts**: When the same note is entered in two different voices, MuseScore tries to ensure that the fret marks do not overlap on the same string. Any overlaps which do occur are marked with red squares: these appear only in the document window and not on any printed copy. In almost all cases (e.g. frets 0 to 4 on the 6th string), overlapping is the desired result and no further adjustment is required. You can hide the red marks by selecting "View" and unticking "Show Unprintable."

Create a **new staff/tablature pair with the New Score Wizard**

1. Open the **New Score wizard**.
2. Enter the score details (optional). Click **Next**.
3. On the Choose **template file** page, click on **Choose Instruments** under "General".
4. Select a pitched staff in the "Strings – Plucked" section of the left-hand column. Then click **Add**.
5. Select the newly-created staff line (i.e. marked "Staff …") in the right-hand column and choose one of two options:
   - Click **Add Staff** to create an **unlinked** staff/tab pair.
   - Click **Add Linked Staff** to create a **linked** staff/tab pair.
6. In the **Staff type** column, click on the dropdown list for the newly-created staff and select a tablature option (this can be modified later, if required, on the score page—see **Staff/Part Properties**).
7. Change the staff order using the button if needed.
8. Complete the rest of the New Score Wizard, or click **Finish**.

**Note**: To create unlinked staves with separate mixer channels, instead of step "5" (above), select a Tablature staff in the left-hand column and click **Add**. Then continue with steps 6 and 7.

Create a **new staff/tablature pair in an existing score**

1. Open the **Instruments** editor (press **I**, or from the menu bar, select **Edit → Instruments…**).
2. Then follow steps 4–8 above.

Create a **staff/tablature pair from an existing staff**

To add tablature to a plucked-string staff in the score (or vice versa):

1. Open the **Instruments** editor (press **I**, or from the menu bar, select **Edit → Instruments…**).
2. In the right-hand column, select the staff you want to create the staff/tab pair from, then follow one of the options shown in step 5 above.
3. Continue with steps 6–8 above.

**Enter notes in tablature**

**Using a computer keyboard**

1. In **Normal mode**, select the measure or existing note from which you want to begin note entry.
2. Switch to note input mode (§): a short 'blue rectangle' appears around one tablature string: this is the current string.
3. Select the duration of the note or rest that you wish to enter (see below).
4. Press the up/down arrow keys to move the cursor to the desired string. Use the left/right arrow keys to navigate through the score.
5. Press 0 to 9 to enter a fret mark from 0 to 9 on the current string; to enter numbers with several digits press each digit in sequence. Keys A to K (skipping I) can also be used: convenient when working in French tablature. For., M, N, use the alphanumeric keyboard and type respectively 10, 11, 12... **(Note**: You cannot enter a number higher than the "Number of frets" value set in the **Edit String Data** dialog).
6. Press ; (semicolon) to enter a rest of the selected duration.
7. You can enter notes in different voices if required—just as you would in a standard staff.

See also, **Edit notes** (below).

**Historical tablature**

Period notation for bass strings (lutes and sim.) is supported:

- **French tablature**: letters with prefixed slash-like strokes right under the tab body: i.e. 7th string: "a", 8th string: "/a", 9th string: "//a" and so on, all in the first position below the tab body.

- **Italian tablature**: numbers with 'ledger line'-like segment of string above the tab body: i.e. 7th string: "0" one
position above the tab body with one 'ledger line'; 8th string: "0" two positions above the tab body with two 'ledger
lines' and so on.

Input of fretmarks is via computer keyboard only: by moving the note entry cursor below (French) or above (Italian) the tab
body, 'shadow' slashes or ledger lines will indicate the target string to which the fret mark will be applied; pressing one of
the fret keys, will enter (and lay out) the note on that string.

Using a mouse

To enter notes into tablature with a mouse:

- Enter note input mode and select the note or rest duration (see below).
- Click on a string to create a note there. Notes are initially created on fret 0 (œa for French tablatures): to correct,
type in the right number from the keyboard.
- You can also increase/decrease the fret mark using Alt+Shift↑ or Alt+Shift↓.
- You can enter notes in different voices if required—just as you would in a standard staff.

See also, Edit notes (below).

Select note duration

In note input mode, you can use any of the following methods to set note duration in tablature:

- Press Shift+1 to Shift+9: Sets duration from a 128th note to a longa (availability of these shortcuts may depend on the
platform and/or keyboard layout);
- Press NumPad1 to NumPad9: Sets duration from a 128th note to a longa (if a numeric keypad exists and NumLock is on);
- Click on a note duration icon in the Note Input toolbar above the document window;
- Press Q to decrease the selected duration and W to increase it.

Edit notes

In Note input mode

To edit an existing fret mark in note-input mode:

- Position the cursor above the fret mark and simply retype the number.
- Increment or decrement the fret mark using Alt+Shift↑ or Alt+Shift↓.

In Normal mode

To edit an existing fret mark in Normal mode:

1. Select one or more fret marks.
2. Use any of the following commands:
   - To increment or decrement, without changing the string: Press ↑.
   - To increment or decrement, changing strings, when possible, to minimize the fret number: Press Alt+Shift↑.
   - To move to an adjacent string (if the string is free and can produce that note): Press Ctrl↑ (Mac: Cmd↑).
   Alternatively, use the mouse to drag the fret mark up or down to an adjacent string.

Note: The fret mark cannot be higher than the "Number of frets" value set in the Edit String Data dialog.

Crosshead notes

To change a fret mark to a crosshead note:

1. Select one or more fret marks in non-note-input mode.
2. Press Shift+X to toggles ghost noteheads on/off.

Summary of keyboard commands

Note input mode

<table>
<thead>
<tr>
<th>Type</th>
<th>to get</th>
</tr>
</thead>
<tbody>
<tr>
<td>↑</td>
<td>Select above string as current.</td>
</tr>
<tr>
<td>↓</td>
<td>Select below string as current.</td>
</tr>
<tr>
<td>Shift+1 to Shift+9</td>
<td>Select a duration (128th note to a longa)</td>
</tr>
<tr>
<td>NumPad 1 to NumPad 9</td>
<td>Select a duration (128th note to a longa)</td>
</tr>
<tr>
<td>Q</td>
<td>Decrease current input duration.</td>
</tr>
</tbody>
</table>
**Normal mode**

<table>
<thead>
<tr>
<th>Type:</th>
<th>to get:</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 to 9</td>
<td>Change duration of selected note or rest (128th note to longa)</td>
</tr>
<tr>
<td>Alt+Shift+↑</td>
<td>Increase the pitch of the selected note (MuseScore chooses the string).</td>
</tr>
<tr>
<td>↑</td>
<td>Increase the pitch without changing string.</td>
</tr>
<tr>
<td>Alt+Shift+↓</td>
<td>Decrease the pitch of the selected note (MuseScore chooses the string).</td>
</tr>
<tr>
<td>↓</td>
<td>Decrease the pitch without changing string.</td>
</tr>
<tr>
<td>Ctrl+↑ (Mac: Cmd+↑)</td>
<td>Move note to above string, keeping the pitch.</td>
</tr>
<tr>
<td>Ctrl+↓ (Mac: Cmd+↓)</td>
<td>Move note to below string, keeping the pitch.</td>
</tr>
<tr>
<td>Shift+X</td>
<td>Toggle the ghost notehead on/off.</td>
</tr>
</tbody>
</table>

**Effect of instrument change**

When an instrument change is made:

- The sound played will be changed to that of the new instrument from that point onward, but the mixer display remains unchanged.
- Subsequent notes are automatically adjusted to indicate the correct written pitch for the new instrument (but the new key signature still needs to be added manually—see below).
- The new instrument name will be displayed in front of the following systems.

**Add an instrument change**

1. Select the start point of the change by clicking on a note or rest;
2. Open the main palette by typing F9 (or from the View menu), and click on Text to open the text sub-palette:

   ![Text Palette]

3. Click on Change Instr (double-click in versions prior to 3.4);
4. The words "Change Instr." will appear above the anchor note or rest;
5. Double-click the text, then type Ctrl+A to select all of it;
6. Type the actual text you wish to be displayed, and exit text edit mode;
7. Right-click the text and choose "Change Instrument...".

**External links**

- [Video tutorial: MuseScore in Minutes: Lesson 7 - Tablature and Drum Notation](#)

**Sound and playback**

MuseScore has "Sound and playback" capabilities built-in. This chapter covers the playback controls and ways to extend the instrument sounds.

**Mid-staff instrument changes**

When a musician is required to double on a different instrument for a section of a piece, the instruction to switch instruments is generally placed above the staff at the beginning of that section. A return to the primary instrument is handled in the same manner.

MuseScore enables users to insert a special class of text called Change Instrument text for this purpose. This class of text is different from either Staff or System text in that it links the text to the playback and changes the sound to the new instrument.

**Add an instrument change**

1. Select the start point of the change by clicking on a note or rest;
2. Open the main palette by typing F9 (or from the View menu), and click on Text to open the text sub-palette:
8. Choose the instrument, then click OK:

9. Insert a new key signature, if required, at the change, for the staff in question.

**Note:** Mid-staff instrument changes are limited to the same type of staff. For example, you cannot change between a percussion staff and a pitched instrument staff or vice versa.

**See also**

- Change instrument
- Mid-staff sound change

**External links**

- How to change instrument sound (e.g. pizz., con sordino) midway through score

**Mixer**

The Mixer allows you to change instrument sounds, adjust volume and panning, and make other adjustments to the playback for each staff.

**Opening the Mixer**

To display/hide the mixer, use one of the following:

- Press F10 (Mac: fn+F10).
- From the main menu, select View → Mixer.

The Mixer is split into a Details Area on the top and a Track Area below.

**Track Area**
The track area is at the bottom and displays the **Master Gain** as well as a row of tracks.

**Master Gain**

The Master Gain controls the overall output volume. To adjust it, click and drag the slider handle or enter a value in the box underneath.

**Track Area**

The Track Area displays allows you to adjust the volume of the instruments used by your staves.

MuseScore creates one “part track” for each staff in your score. These part tracks can be further subdivided into “channel tracks” corresponding to the different sounds used within the staff. While many staves only need a single channel track, others require multiple channels so that the instrument can play more than one sound (e.g. a violin which can play in arco, tremolo or pizzicato voices); or because of a **Mid-staff instrument change**. These extra channel tracks can be shown or hidden by clicking the arrow button on top of the track control.
Expanded part track, showing the child tracks in pink.

Channel display arrow

Every **part track** has a button on the top with an arrow on it, enabled, when that instrument has multiple channels, like e.g. violin (for arco, pizzicato, tremolo), disabled otherwise. When clicked, this will toggle whether the channel tracks of the staff are displayed next to it. **Channel tracks** do not have an arrow button. Instead, the name of the track they are a part of is displayed.

Mute and Solo

At the top of each track is a green **solo** button and a red **mute** button: each can be toggled on or off. If any Solo button is checked then only tracks that have solo lit will play. If no solo is lit, all parts can potentially play. Mute does the opposite: any track that has mute lit will not play. By using a combination of mute and solo buttons, you can control which instruments are heard during playback.

Pan

The dial below the mute button controls panning left and right. You can click and drag on the dial to change the pan value. **Note**: MuseScore does not yet support pan values for the part track, so the part track displays the pan value of the first channel instead. Setting the pan value of the part track will automatically set all of its children to the same value as well.

Volume

The slider in the middle of the track controls the playback volume. **Note**: MuseScore does not yet support volume values for the part track, so the part track displays the volume value of the first channel instead. Setting the volume value of the part track will automatically set all of its children to the same value as well.

Track name

The text box at the bottom of the track contains the current name of the track’s part or channel.

Detail Area

The details area displays and provides finer control of the currently selected track.
Name

The name of the part this track is associated with. Both part tracks and channel tracks display the part name. **Note:** The part name is editable, but this only have effect for the Mixer. The channel name is not editable.

Track Color

This is a color the user can choose to help distinguish a particular part. Double clicking on this swatch will allow you to choose a different color for displaying the name of this track. Setting the color of a part track will automatically change the colors of all its child tracks.

Channel

If a channel track is selected, the channel name is displayed here.

Drumset

Indicates if this part represents a melodic instrument or a drumkit. For regular melodic instruments, each pitch in the same patch usually has the same timbre, while drumkit patches usually have different timbres for each pitch.

Patch

This is the actual Sound from the soundfont that is used to render your instrument.

Volume

The overall loudness with which the sound is played.

Pan

The panning applied to the part.

Port and Channel

The output MIDI port and channel the part is played on.

Reverb / Chorus

The reverb/chorus value sent to MIDI out. This is information sent to MIDI devices and will not affect MuseScore's built in audio playback.

Mute Voice

This allows you to mute individual voices within each staff. Each row represents a different staff within a part. So pressing '2' on the top row will mute the second voice on the first staff of the part.

Hide Details Button

At the bottom of the detail area is a wide button with a tiny triangle on it. Clicking this button will hide the detail area to give you more room. Clicking on it again will restore the detail area.

Sound

The "Sound" drop-down menu lists every instrument supported by your current SoundFont. If you have multiple SoundFonts loaded in the Synthesizer, all the patches from all the SoundFonts (and/or SFZ files) will appear in a single
long list—in the order previously set in the Synthesizer.

Tip: To find an instrument, click on the “Sound” list and type the first letter of the instrument name. Repeat as required.

Mid-staff sound change (pizz., con sordino, etc.)

Some instruments come with multiple channels in the Mixer that can be used to change sounds midway through a score. For example, a staff for a stringed instrument (violin, viola, cello etc.) is allocated three channels: one for “arco” (or “normal”), another for “pizzicato” and another for “tremolo.” A trumpet staff will have one channel for “normal” and another reserved for “mute,” and so on.

The following instructions use pizzicato strings as an example, but the same principle can be applied to any other instrument staff that allows sound changes.

1. Select the first note of the section you want to be pizzicato;
2. From the main menu, choose Add → Text → Staff Text;
3. Type “pizz.” This text is for visual reference only and does not affect playback;
4. Right-click on the applied staff text and select Staff Text Properties…;
5. In the “Change Channel” tab of the “Staff Text Properties” dialog, select one or more voices on the left;
6. From the dropdown menu, select pizzicato;
7. Click OK to return to the score.

Every note after the staff text you added now sounds pizzicato. To return to a normal strings sound later in the piece, follow the same guidelines as above except type “arco” in step 3 and select arco in step 6.

See also
- SoundFont
- Synthesizer
- Change instrument

External links
- How to change instrument sound (e.g. pizz., con sordino) midway through score

Piano Roll Editor

The Piano Roll Editor allows you edit individual notes and tweak aspects of their playback.

Opening the Piano Roll Editor

To open the Piano Roll Editor (PRE), right click on a measure in the score and choose the Piano Roll Editor option from the context menu. The Piano Roll Editor will open showing the staff and measure where you clicked. If the Piano Roll Editor is already open, it will be updated to show the new staff and measure you clicked on.
The Piano Roll Editor is divided into several sections. At the very top is a row of buttons and controls that affect playback and can modify notes. The name of the part being edited is at the top right.

The central portion contains the **Note Display Area** which allows you to view and edit notes. Each note is displayed as a block, with yellow blocks representing selected notes, and darker green blocks representing unselected notes (these colors can be changes in the Preferences). Given sufficient space, each block will display its pitch on the left and the voice it is assigned to on the right. Changing the size of the note blocks is covered in the **navigation** section.

To the left of the Note Display Area is the **Keyboard**. By clicking on a key in the Keyboard, you can hear a sample of that note playing. As you move the mouse in either the Node Display Area or the Keyboard, a key on the keyboard will light to corresponding to the pitch you are over. You can also hover your mouse over a particular key to get more information about that pitch. If you are using a Drumkit, the keys of the keyboard will show the name of the drum assigned to that particular pitch. For instruments that are not concert C, the keyboard will be adjusted so that the C of the keyboard matches the C of the instrument.
Along the top of the Note Display Area is the **Measure Ruler** which displays the current position of the playback head, as well as the current looping range if it set.

The bottom of the editor contains the **Levels Display Area**. It is a bar graph showing extra data values assigned to each note, such as its **velocity** or **cutoff** time. To the left of the Levels Display Area is a dropdown menu allowing you to select the type of data you wish to see displayed or edited.

**Navigation**

There are several ways to move about in the Piano Roll Editor. First of all, you can click and drag on the scroll bars on the edges of the Note Display Area.

The mouse wheel can also be used to pan and zoom as follows:

- **Scroll vertically**: Mouse wheel.
- **Scroll horizontally**: Shift + mouse wheel.
- **Zoom vertically**: Ctrl + mouse wheel.
- **Zoom horizontally**: Ctrl+Shift + mouse wheel.

To jump to a particular measure, switch back to score view and find the measure you wish to see. Then right click on the measure and select Piano Roll Editor. The Piano Roll Editor will scroll to center on the measure you clicked.

**Selecting Notes**

In the Note Display Area, you can click on single notes or click and drag to select a group of notes. Holding down the modifier keys will affect how your selection changes:

- **Shift**: Invert existing selection: i.e. notes that were previously selected are deselected, and notes which were not selected are selected. Useful for toggling a note between selected and not selected.
- **Ctrl**: Add notes to selection.
- **Ctrl+Shift**: Subtract notes from selection.

**Editing Notes**

**To change the pitch of a selection of notes** Drag a selected note up or down to a new pitch; or press the ↑ or ↓ arrows. **Note**: Dragging the note horizontally to change the start time is not supported at the moment.

**To delete a selection of notes** Press the Del key.

**To move a note selection to another voice** Click the desired voice number button at the top of the editor.

**To add notes**

Notes can be inserted by clicking in the Piano Note Area with the modifier keys held. These edit operations will use the beat or subbeat line to the left of the spot where you click as the point where a note is altered:

- **Ctrl**: A note of the current insert note duration will be added at the subbeat and pitch where you clicked. The note insert length is the same as the one you use to add notes in note entry mode in the score. If you wish to change the duration, you will need to select this in the Score View as the Piano Roll Editor does not currently have these buttons. If notes already exist in this location, a chunk will be cut out of them to make room for the note you are inserting, unless they happen to have the same start time and duration of the note you're adding, in which case the new note will simply be appended to the existing chord. Tuplets are currently not supported, and so will be ignored.
Shift: Looks for a chord that already spans this subbeat line. If it finds one, appends a new pitch to the existing chord. Otherwise, this is a rest and the rest will be replaced with a note of equal start time and duration to the existing rest.

Ctrl+Shift: Looks for a chord or rest that spans this subbeat. This chord will be cut in two at this subbeat line. Tuplets are currently not supported, and so will be ignored.

To edit note event data:

Note event data can be changed in the Levels Display Area. To edit event data such as velocity or cutoff time, first select the notes you wish to edit in the note area. Then click in the Levels Display Area on the corresponding bar; the value of the level will changed to correspond to the point where you clicked. You can also click and drag in this area to change the levels of several notes with a single gesture. If you want the levels to all be set to the same value, hold shift while dragging. Only selected notes will have their value changed - this is to prevent you from accidentally changing the values of other notes.

The Levels area can display the same data in multiple ways. For example, velocity data can be displayed both as absolute (i.e., relative to the output midi volume) and relative (i.e., as an offset to the dynamics value). You can switch between these display modes as you see fit.

Controls

From left to right the controls have these functions;

First Row

Undo
Undoes the last action

Redo
Redoes the last action

MIDI Toggle
Toggles MIDI input

Rewind
Rewind to start of score.

Play
Starts/stops playback.

Loop Playback
Sets the range of and toggles looping playback.

Play Repeats
Toggles whether repeats are played.

Pan Roll During Playback
If set, the window will automatically scroll to center on the playback head during playback.

Metronome
Toggle metronome.

Wave
Currently does nothing.

Voice Numbers
Moves selected notes to chosen voice.

Part
Name of part currently being viewed/edited.

Second Row
Cursor
Provides feedback on the current measure and pitch of the position of the mouse within the Note Display Area.

Subdiv
Subdivides the beat by adding extra divisions to the Note Display Area. The value indicated the number of times the beat will be subdivided. So for 4/4 time, a division of 2 will draw grid lines at every eighth note; a division of 3 at every sixteenth note, and so on. Setting the subdivision is necessary for some editing operations if you wish to place notes off the beat.

For larger numbers of subdivisions, you may need to be zoomed in to see the extra grid lines since grid lines are not drawn below a certain density. Combines with the tuplet control which also affects grid line placement.

Tuplet
Adds additional grid lines, subdividing the beat to show the rhythmic placement of tuplets. For example, setting tuplets to 3 will show the beat subdivided into three parts. Combines with the subdiv control to show subdivisions of the tuplet. For example, setting tuplets to 3 and subdiv to 2 will draw grid lines showing the tuplet beats subdivided into two parts - i.e., the beat will be subdivided into 6.

Selecting a tuplet mode other than 1 will disable some of the note insertion tools for the Piano Roll Editor. For larger numbers of subdivisions, you may need to be zoomed in to see the extra grid lines since grid lines are not drawn below a certain density.

Stripe pattern
Changes the pattern of stripes shown behind the notes in the Note Display Area. By default the pitches of C major are highlighted, but you can change this to highlight the pitches of a different key, or even scales such as the diminished or whole tone.

Velocity
Shows the velocity of the currently selected note (only one note may be selected). Indicates the loudness of the note. This can be expressed as 'Offset' or 'User':

- Offset: Value is treated as a multiplier for the velocity already set by the dynamics.
- User: This is the raw value being sent to MIDI and overrides the dynamics value. Values are between 0 and 127, where 64 is "middle, neither loud nor soft".

When you switch from User to Offset or vice versa, the value will be recalculated to best match the value in the other system. This way you could, for example, switch to User mode to set the value as you would like it to sound when outputting MIDI and then switch to Offset so that this value respects the dynamic marking instead of overriding it. At the moment you switch back, the offset value will be recalculated to match the User value in loudness but will no longer act as an override so you may later change the dynamic.

Pitch
Shows the pitch and octave of the selected note in text format (i.e. f#4). The pitch will change if the note is dragged up or down to a new pitch. Currently cannot be edited.

OnTime
Shifts the start of the note in time, which can be used to modify the playing style. Negative values will make the note sound earlier, positive will make it sound later. The duration of the note corresponds to a value of 1000 (e.g. setting the value to 250 will make the note sound 1/4 of its duration later).

Length

123
Set the time that the note is sounding, which may be used to modify the degree of "legato". Lower values will make the note sound more staccato, higher values will make it sound more legato. The duration of the note corresponds to a length of 1000, but the value can be set higher. 950 is usually considered "non-legato".

Keyboard

Some keys are hooked up to perform special actions:
- ↑: Move selected notes up one semitone
- ↓: Move selected notes down one semitone
- Del: Delete selected notes
- Space: Start/stop playback

Customization

The Piano Roll Editor will display in both normal mode and dark mode. If you wish to change the colors the Piano Roll Editor uses to display in these modes, they can be adjusted in the Preferences under the Advanced tab. All the Piano Roll Editor related properties begin with ui/pianoroll/light for light mode and ui/pianoroll/dark for dark mode.

Play mode

Playback toolbar

Basic playback functions are accessed from the Play toolbar located above the document window:

From left to right, the icons are:
- Toggle 'Midi input':
- Rewind to start position: Playback returns to the beginning of the score, or to the start of the loop (if one is set).
- Start or stop playback See Start/stop playback
- Toggle loop playback: See Loop playback.
- Play repeats: Turn off if you want playback to ignore repeats.
- Pan score during playback: Turn off if you want the score to remain stationary.
- Play metronome: Toggles metronome ON and OFF.

Playback commands

Start/stop playback

To start playback:
1. Click on a note, rest or the blank part of a measure to establish the starting point. If no selection is made, playback returns to the place it left off; or, if no previous playback, to the start of the score.
2. Press the Play button; or press Space.

During playback you can jump to a specific note or rest in the score by simply clicking on it.

To stop playback:
- Press the Play button; or press Space.

During playback

Once playback has started, the following commands are available:
- Go back to previous chord: ←
- Advance to next chord: →
- Go back to start of previous measure: Ctrl+← (Mac: Cmd+←)
- Advance to start of next measure: Ctrl+→ (Mac: Cmd+→)
- Rewind to start of score: Home (Mac: Cmd+Home); or press the Rewind button (playback toolbar).

During playback you can still use keyboard shortcuts to open and close panels, such as Play, Synthesizer, Mixer etc.

Loop playback

- Playback should be off, and the "Loop playback button" on.
- Select the desired region of the score for loop playback.
- Press the playback button.
Playback will now cycle within the region marked by the blue flags.

- Use the "Loop playback" button to toggle the loop on or off.

See also: **Play Panel** (below).

**Play panel**

To open the Play Panel use one of the following options:

- Press F11 (Mac: Fn+F11).
- From the menu bar, select View → Play Panel.

The Play Panel allows you to make temporary changes to tempo and volume, to loop playback between specified points etc.

- **Loop playback**: Select a start note and click on the Loop in button; select an end note and click on the Loop out button. Press Play to hear the loop. The controls also work during playback.
- **Rewind, Play**: Playback controls.
- **Metronome**: Toggle metronome playback ON or OFF.
- **Count in**: (Conductor icon) Adds a count-in when you start playback at the start of a measure. Extra beats are added if you start mid-measure. Toggles ON and OFF.
- **Tempo**: Make temporary change to tempo. This is displayed as a percentage and as a bpm (beats per minute). Double-click to reset. (Note: Permanent changes to tempo should be made using tempo text)
- **Volume**: Make temporary change to volume (resets when program is reopened). Note: To change the default playback volume of the score, see **Synthesizer**.

**SoundFonts and SFZ files**

Audio playback is provided by MuseScore's onboard synthesizer, which houses a large selection of virtual (or software) instruments—including percussion and sound effects.

MuseScore supports virtual instruments in two formats:

- **SoundFont** (.sf2/.sf3): A single file containing one or more virtual instruments.
- **SFZ** (.sfz): A set of audio and definition files containing one or more virtual instruments.

**SoundFonts**

MuseScore comes with its own GM (General MIDI) SoundFont, **MuseScore_General.sf3**, containing over 128 instruments, sound effects and various drum/percussion kits.

GM (General MIDI) is a universal format, so once your score is set up for correct playback using MuseScore's native Soundfont, you should be able to export it in a format of your choice and have it play back on any other user's computer.

Many different Soundfonts are available on the Internet: some free, some commercial. For a list of free soundfonts, see below.

**Install a SoundFont**

After finding and decompressing a SoundFont (see →below), double-click to open it. In most cases, the SoundFont file type will already be associated with MuseScore, and MuseScore will start and a dialog will appear asking if you want to install the SoundFont. Occasionally an application other than MuseScore will be associated with the SoundFont file type; if this is the case, you will need to right-click or control-click on the file, so as to display a menu from which you can choose to open the file in MuseScore. In either case, when the dialog appears asking if you want to install the SoundFont, click "Yes" to place a copy of the SoundFont file in MuseScore's SoundFonts directory. This directory can be viewed or changed in MuseScore's Preferences, but the default location is:
- Windows: %HOMEPATH%\Documents\MuseScore3\Soundfonts
- macOS and Linux: ~/Documents/MuseScore3/Soundfonts

In contrast to user-added SoundFonts, the initial default SoundFont installed with MuseScore is located in a system directory, meant only for that purpose, which should not be modified. This directory and its default SoundFont file is:

- Windows x86 (32-bit) / MuseScore x86: %ProgramFiles%\MuseScore 3\sound\MuseScore_General.sf3
- Windows x64 (64-bit) / MuseScore x86: %ProgramFiles(x86)%\MuseScore 3\sound\MuseScore_General.sf3
- Windows x64 (64-bit) / MuseScore x64_64: %ProgramFiles%\MuseScore 3\sound\MuseScore_General.sf3
- macOS: /Applications/MuseScore 3.app/Contents/Resources/sound/MuseScore_General.sf3
- Linux (Ubuntu): /usr/share/mscore-xxx/sounds/MuseScore_General.sf3 (with xxx being the MuseScore version)

Uninstall

To uninstall a SoundFont, simply open the folder where its file is installed and delete it.

SFZ

An SFZ is a collection of files and directories, an SFZ file and a bunch of actual sound files in WAV or FLAC format, with the SFZ file being a text file that basically describes what sound file is located where and to be used for what instrument and pitch range.

Install an SFZ

After downloading an SFZ (see → below), you need to manually extract all the files that belong to the SFZ (the SFZ file itself and all the subdirectories) into the directory listed above. Leave the subdirectories and their contents as they are.

Uninstall

To uninstall an SFZ, simply open the folder where its files are installed (see above) and delete them all.

Synthesizer

Once a SoundFont has been installed on your system, it also needs to be loaded into the Synthesizer. See To load a soundfont.

Mixer

The Mixer allows you to easily change the sounds for each staff (even while the score is playing). For further details, see Mixer.

List of downloadable soundfonts

GM SoundFonts

The following sound libraries conform to the General MIDI (GM2) standard. This specification gives you a sound set of 128 virtual instruments, plus percussion kits.

- GeneralUser GS (29.8 MB uncompressed)
  Courtesy of S. Christian Collins
- Magic Sound Font, version 2.0 (67.8 MB uncompressed)
- Arachno SoundFont, version 1.0 (148 MB uncompressed)
  Courtesy of Maxime Abbey
- MuseScore 1 came with TimGM6mb (5.7 MB uncompressed)
  License: GNU GPL, version 2
  Courtesy of Tim Brechbill
- MuseScore 2 (up to version 2.1) came with FluidR3Mono_GM.sf3 (13.8 MB).
- MuseScore 2 (as of version 2.2) and 3 come with MuseScore_General.sf3 (35.9 MB) SF2 version (208 MB)).
  License: released under the MIT license
  Courtesy of S. Christian Collins
- MuseScore 3 on top offers an HQ version of that soundfont as an extension
- Timbres of Heaven, version 3.2 (369 MB uncompressed)
  Courtesy of Don Allen

Orchestral soundfonts
Sonatina Symphonic Orchestra (503 MB uncompressed)
Downloads: SoundFont | SFZ format
License: Creative Commons Sampling Plus 1.0

Aegean Symphonic Orchestra
Courtesy of Ziya Mete Demircan (352 MB uncompressed)

Piano soundfonts

SF2 Pianos

- Acoustic grand piano, release 2016-08-04
  Description: Yamaha Disklavier Pro Grand Piano, sf2 format, 36MiB compressed, 113MiB uncompressed, 121 samples, 5 velocity layers
  More information: http://freepats.zenvoid.org/ including other soundfonts.
  License: Creative Commons Attribution 3.0
  Courtesy of Roberto Gordo Saez

- Salamander C5 Light (24.5 MB uncompressed)
  Courtesy of Ziya Mete Demircan

SFZ Pianos

- Salamander Grand Piano
  Downloads: version 2 | version 3
  Description: Yamaha C5, 48kHz, 24bit, 16 velocity layers, between 80 MB and 1.9 GB uncompressed
  License: Creative Commons Attribution 3.0
  Courtesy of Alexander Holm

- Detuned Piano (244 MB uncompressed)
  License: Creative Commons Attribution-ShareAlike 3.0

- Plucked Piano Strings
  Description: 44.1kHz, 16bit, stereo, 168 MB uncompressed
  License: Creative Commons Attribution-ShareAlike 3.0

- The City Piano
  Description: Baldwin Baby Grand, 4 velocity layers, 696 MB uncompressed
  License: Public domain
  Courtesy of Big Cat Instruments

- Kawai Upright Piano, release 2017-01-28
  Description: 68 samples, 44KHz, 24bit, stereo, 2 velocity layers, 58MiB uncompressed
  License: GNU General Public License version 3 or later, with a special exception
  Courtesy of Gonzalo and Roberto

Unzipping downloaded soundfonts

Since soundfonts are large, they are often zipped (compressed) into a variety of formats, including .zip, .sfArk, and .tar.gz. You need to unzip (decompress) these files before they can be used.

- ZIP is standard compression format supported by most operating systems.
- sfArk is a compression format designed especially for compressing SoundFont files. To decompress it, use Polyphone (cross-platform software); or this online service: https://cloudconvert.com/sfark-to-sf2
- .tar.gz is a popular compression format for Linux. Windows users can use 7-Zip, Mac users can use The Unarchiver, or macOS' built-in Archive Utility. Note that if using 7-Zip, you will need to apply decompression twice —once for GZip and once for TAR.

Troubleshooting

If the toolbar play panel is greyed out, or not visible, follow the instructions below to get your sound working again:

1. Right-click on the menu bar and make sure there is a check mark next to the Playback Controls menu item. If this step does not solve your problem, go to Step 2.
2. If the play panel disappears after changing the SoundFont, go to Edit → Preferences... → I/O tab and click OK without making any changes. After restarting MuseScore, the play panel should reappear.

If you are setting up a SoundFont for the first time, please use one of the recommended SoundFonts listed above.

If playback stutters, then your computer may not be able to handle the SoundFont being used. The following advice may help:

- Reduce the amount of RAM (memory) used by MuseScore by using a smaller SoundFont. See the list above for suggestions.
- Increase the amount of RAM available for MuseScore by quitting all applications except MuseScore. If you still have problems and a large SoundFont is important to you, consider more RAM for your computer.
See also

- Synthesizer
- Mixer

External links

- How to change the SoundFont or add another
- The SFZ Format (for details about the sfz specification)

Swing

MuseScore’s **swing** feature allows you to change the playback of your score from a straight to a swing rhythm. Swing can be applied globally or only to a section of the score, and is fully variable.

Apply swing to a score section

To apply swing to all staves in a system:

1. Click on the note where you want swing to start;
2. Click **Swing** in the Text palette (double-click in versions prior to 3.4);
3. Edit the Swing text as required;
4. If you need to vary swing from the default setting, right click the Swing text and select **System text properties...**. Click on the "Swing Settings" tab and adjust note duration and "Swing ratio" as required.

To apply swing only to specific staves in a system:
1. Click on the note where you want swing to start;
2. Add Staff text;
3. Edit the appearance of the text as required;
4. Right-click on the text, select Staff Text Properties..., and click on the "Swing settings" tab. Modify as required;
5. Repeat steps 1–4 for other staves if needed.

Swing text can be edited and formatted just like any other text object.

**Triplet in tempo marking**

Often this notation is used to indicate swing:

\[ \text{\includegraphics[width=0.5\textwidth]{triplet.png}} \]

MuseScore does not have a way to include a triplet in text as a tempo marking, but there is an easy workaround:

1. Add Swing text as described above and make it invisible (shortcut v, or un-tick "Visible" in the Inspector);
2. Add an appropriate Image of the required tempo marking to the score. These can be downloaded from the bottom of the "How To" page: How to create a visual swing marking.
3. Resize and reposition the image as required.

**Return to straight rhythm**

If you want playback to return to straight time after a swing section, use one of the following options:

**Use and modify** a Swing text. (prior to version 3.4).

1. Add Swing text to the first note or rest of the "straight" section (see above).
2. Edit the text to indicate a return to straight time: e.g. "Straight."
3. Right-click on the text and select System Text Properties... Click on the "Swing Settings" tab and set "Swing to "Off."

**Use the Straight text** as per version 3.4.

- Add Straight text from the Master palette text to the first note or rest of the "straight" section (see above).

**Apply swing globally**

If you wish to apply swing to the whole score, you can do so from the menu:

1. Select Format → Style... → Score.
2. In the "Swing Settings" section, set the desired note value and "swing ratio."
2. In the “Swing Settings” section, set the desired note value and “swing ratio.”

External links
- How to create a visual swing marking
- Swing (jazz performance style) (Wikipedia)

Synthesizer

Overview

To display the Synthesizer: from the menu, select View → Synthesizer.

The Synthesizer controls MuseScore’s sound output and allows you to:
- Load and organize different sound sample libraries to play back the music.
- Apply effects such as reverb and compression.
- Adjust overall tuning.
- Alter the output volume.
- Select Midi Continuous Controllers to use with Single Note Dynamics (versions 3.1 and above).

The Synthesizer window is divided into the following sections/tabs:
- Fluid: A software synthesizer that plays SF2/SF3 SoundFont sample libraries.
- Zerberus: A software synthesizer that plays SFZ format sample libraries.
- Master Effects: Used to apply multi-effects to the score.
- Tuning: Used to adjust overall playback tuning.
- Dynamics (versions 3.1 and above): Used to configure Single Note Dynamics Midi controllers.

Save/Load Synthesizer settings

The buttons at the bottom of the Synthesizer window have the following functions:

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set as Default</td>
<td>Saves all current synthesizer settings as the default settings. These are automatically applied to the Synthesizer when you open MuseScore.</td>
</tr>
<tr>
<td>Load Default</td>
<td>Loads the last saved default settings to the Synthesizer.</td>
</tr>
<tr>
<td>Save to Score</td>
<td>Saves all current synthesizer settings to the current score only.</td>
</tr>
<tr>
<td>Load from</td>
<td></td>
</tr>
</tbody>
</table>
**Score** loads the settings from the current score to the synthesizer.

**Notes:**
1. "Synthesizer settings" include the order of SoundFonts and SFZ files, effects set-up, master tuning and volume.
2. Only one set of Synthesizer settings can be in effect at a time—i.e. if multiple scores are open at once, it is not possible to make changes to the Synthesizer in one score and leave other scores' settings untouched.
3. Changes to synthesizer settings will not be heard in exported audio files unless saved to the score first (see table, above). See also Tuning (below).

**Fluid**

Click on the Fluid tab to access the control panel for SF2/SF3SoundFont sample libraries. By default, the SoundFont MuseScore_General.sf3 should already be loaded.

You can load, rearrange and delete soundfonts as required. Playback can be shared between any combination of different soundfonts (and/or SFZ files). The order of soundfonts in Fluid is reflected in the default order of instruments in the mixer.

**To load a soundfont**

1. Click on the Add button
2. Click on a soundfont in the list.

To be able to load the soundfont, it first needs to be installed in your Soundfonts folder. This will ensure that it appears in the list in step 2 (above).

**To reorder the soundfonts**

1. Click on a soundfont
2. Use the up/down arrows (on the right-hand side) to adjust the order.
3. Repeat with other soundfonts in the list if required.
4. Or use the double up arrow (on the top right-hand side) to move any SoundFont to the top of the list.

The order of virtual instrument sets in the Synthesizer is reflected in the order of instruments listed in the Mixer. So, if playback of a score depends on a mix of instrument sets, it is advisable to save the Synthesizer configuration to the score in question by pressing the Save to Score button. When you next wish to play back the score, press the Load from Score button to load the same configuration. However, remember this only sets the order of instruments—not the instruments themselves, which should be in place on your computer.

**To remove a soundfont**

1. Click on the name of the soundfont
2. Click on the Delete button.

This removes the soundfont from the synthesizer but does not uninstall it from the Soundfonts folder: it will still be available if you wish to reload it later.

**Zerberus**

Click on the Zerberus tab to access the control panel for SFZ sound sample libraries. You can add, delete or reorder files.
in a similar way to the Fluid tab. Note that, as with Fluid, the SFZ files must first be installed in your soundfonts folder before they can be loaded into the synthesizer.

Volume

The slider on the right of the Synthesizer controls the playback volume: any changes made here last only to the end of the session, unless saved to the score or set as the new default.

Effects

The Master Effects tab of the Synthesizer allows you to add reverb and compression to your score.

Master Effects with Zita1 Reverb and SC4 Compressor.

To turn an effect on or off:

- Select an option from the drop-down list next to Effect A or Effect B (the effects are applied in series, A → B).

To store and load effects configurations, use the buttons at the bottom of the Synthesizer window. See Synthesizer settings (above) for details.

Zita 1 reverb

The Zita 1 stereo reverb module allows you to simulate the ambience of anything from a small room to a large hall. The pre-delay, reverb time and tone of the reverb can be finely tuned using the controls provided:

- **Delay**: Set a pre-delay for the reverb from 20-100 ms.
- **Low RT60** (Low frequency reverb time): Use the grey control to adjust the center frequency (50–1000 Hz) of the low frequency band which you want to affect: the green control adjusts the reverb time (1–8 secs) of this frequency band.
- **Mid RT60** (Mid-range reverb time): Adjust the reverb time (1–8 secs) of the mid-range frequency band.
- **HF Damping**: Adjusts the high frequency component of the reverb. Increasing this value increases the frequency of the cut-off point and makes the reverb appear brighter and longer.
- **EQ1**: Allows you to cut or boost (-15 to +15) a frequency band (center = 40 Hz - 2 KHz) in the lower part of the spectrum.
- **EQ2**: Allows you to cut or boost (-15 to +15) a frequency band (center = 160 Hz - 10 KHz) in the higher part of the spectrum.
- **Output**: Controls the amount of effect applied. "Dry" is no effect. "Wet" indicates 100% reverb. "Mix" is a 50/50 balance of wet/dry signal.

**Note**: EQ1 and EQ2 affect the tone of the reverb only, not the dry (unprocessed) signal.

To quickly set up an effects patch, set "Output" to "Mix" and adjust the "Mid RT60" control to the desired reverb time. Then fine tune the effect as explained above.

SC4 compressor

The SC4 stereo compressor gives you fine control over the playback's dynamic range, reducing the volume variation between loud and soft sounds. It offers the following controls:
- **RMS**: Adjusts the balance between RMS (0) and Peak (1) compression. In the former, the compressor responds to averaged-out levels in the signal; in Peak mode, the compressor responds to peak levels.
- **Attack**: (1.5–400 ms) The length of time it takes for compression to engage fully after the signal exceeds the threshold level.
- **Release**: (2–800 ms) The time it takes for compression to return to zero after the signal falls below the threshold level.
- **Threshold**: (in dB) The signal level above which compression starts to take effect. Lowering the threshold increases the amount of signal that is compressed.
- **Ratio**: The amount of compression applied to the signal above the threshold. The higher the ratio, the greater the compression. Varies between 1:1 and 20:1.
- **Knee**: Allows you to select a range between “soft knee” and “hard knee”. The softer the knee, the more gradual the transition between uncompressed and compressed signal.
- **Gain**: Compression tends to lower the volume, so use this control to boost the signal as required.

To quickly set-up, try setting RMS = 1, Threshold = -20 db, Ratio = 6. Increase Gain to restore the lost volume. Then fine-tune as explained above.

**Tuning**

The Tuning tab is where you can adjust the program’s **master tuning**. For Concert Pitch instruments, A4 = 440 Hz by default.

![Tuning Tab](image)

To change the Master tuning:

- Enter a new value in the **Master tuning** field, then press Change Tuning.

**Notes**: (1) This tuning applies to all scores in the current session only. To make this the program default or to store it to a particular score, see **Save/Load Synthesizer settings**. (2) To apply the new tuning to exported audio files (WAV, MP3, OGG), press Save to Score before exporting.

**Dynamics (versions 3.1 and above)**

Click on the **Dynamics** tab to access the control panel for Single Note Dynamics:
• **Dynamics method:** You can choose either between 1) Default (single-note dynamics and velocity), 2) Velocity only (no single-note dynamics), 3) CC events only (constant velocity).
• **CC to use:** Depending on the SoundFont you use, you may have to choose the Continuous Controller to use, 1) CC 1, 2) CC 2 (default), 3) CC 4, 4) CC 11.

In the **Advanced Settings** box, you can choose to enable or disable the Expression Controller for Instruments Sound:
• **Switch all patches:** Select 1) To Expressive (to enable for all instruments sounds), 2) To Non-Expressive (to disable for all instruments sounds), 3) Reset All (Reset all instruments sounds to defaults)

**See also**
- SoundFont
- Mixer

**Tempo**

**Tempo markings** can be found in the Tempo palette of the Basic and Advanced workspaces. They are supplied as metronome marks, but can be subsequently edited to display any tempo or expression you want. Playback tempo can be varied throughout the score by using multiple tempo markings, visible or invisible.

**Add a tempo marking**

Use any of the following methods:

- Select a note or rest and press the **keyboard shortcut** Alt+Shift+T.
- Select a note or rest, and from the **menu bar** choose **Add → Text... → Tempo Marking**.
- Select a note or rest and click an appropriate metronome mark in the **Tempo palette** (double-click in versions prior to 3.4);
- Drag-and-drop a metronome mark from the **Tempo palette** directly onto a note or rest.

**Note:** If a tempo marking is applied from the menu or using a keyboard shortcut, the beat note automatically follows the time signature. The advantage of applying from a palette is that you can choose which beat note to use.

**Edit tempo**

To change the tempo of an existing metronome mark in the score:

1. Go into **Edit mode** on the tempo mark in question;
2. Edit the metronome number and/or the beat note as required;
3. Exit **Edit mode**.

You can also override the tempo of an existing metronome mark from the **Inspector**:

1. Select the tempo mark;
2. Untick “Follow text” in the **Tempo text** section of the **Inspector**;
3. Set the desired playback tempo in the “Tempo” field underneath.

Note: Playback may be faster or slower if the tempo setting in the play panel is at a percentage other than 100%.

**Edit tempo text**

Tempo marks can be edited and formatted just like any other text object. To set text properties or text style, see Text styles and properties.

The tempo indicated by a metronome mark usually persists even if overwritten by an expression—such as Andante, Moderato etc. You can also add further text to a plain metronome mark. e.g.

\[ \text{Andante} \, \, \frac{j}{4} = 75 \]

**Overriding the tempo marking**

You can temporarily override the indicated tempo, and play the score back at any tempo you like using the play panel:

1. Display the play panel: View → Play Panel or F11 (Mac: fn+F11):

![Play Panel]

2. Move the tempo slider up or down as required. The tempo is shown both as an absolute value and as a percentage of the currently indicated tempo mark. Double-click the tempo slider to reset it.

Note: BPM is always measured and displayed in quarter note beats per minute, regardless of the (denominator of the) time signature in effect.

**Ritardando and accelerando playback**

You can simulate ritardando (“rit.”) and accelerando (“accel.”) playback by adding hidden tempo markings to the score. The printed indication to the musician should be added as staff/system text in addition.

In the example illustrated below, the tempo was originally 110 BPM (beats per minute). At the ritardando, the tempo decreases by 10 BPM on the first note of each measure. Each tempo change is made invisible by unchecking the Visible checkbox in the Inspector, so that only the ritardando shows on the printed score:

![Tempo Change Example]

A plugin has been developed to automate this process: TempoChanges

**Fermatas**

Fermatas, available in the Articulations and Ornaments palette, have a Time stretch property that can be set via the Inspector. By default, this property is set to 1.00. To have MuseScore play back a fermata for twice its normal duration, click on the fermata and set “Time stretch” to 2.00. This of course does not work for fermatas applied to barlines, as barlines don’t have a duration to stretch.
See also

- Play mode
- Time signature

Dynamics

Dynamics are symbols indicating the relative loudness of a note or phrase of music. They can be found in the Dynamics palette in either the Basic or Advanced workspace.

<table>
<thead>
<tr>
<th>ppp</th>
<th>pp</th>
<th>p</th>
<th>mp</th>
</tr>
</thead>
<tbody>
<tr>
<td>mf</td>
<td>f</td>
<td>f'</td>
<td>fff</td>
</tr>
<tr>
<td>fp</td>
<td>f</td>
<td>f'</td>
<td>f'f</td>
</tr>
<tr>
<td>sff</td>
<td>sfp</td>
<td>sfp'</td>
<td>rf'</td>
</tr>
<tr>
<td>sf</td>
<td>f'</td>
<td>m</td>
<td>r</td>
</tr>
<tr>
<td>s</td>
<td>z</td>
<td>a</td>
<td></td>
</tr>
</tbody>
</table>

Additional dynamics are available in the Master Palette (Shift+F9).

Note: if you wish to adjust the overall playback volume of the score, use the volume slider in the Play Panel, or Synthesizer.

Add a dynamic

To apply a dynamic to the score, use one of the following methods:

- Select a note and click a dynamic symbol in a palette (double-click in versions prior to 3.4).
- Drag a dynamic symbol from a palette onto a note.

To create a crescendo or decrescendo, see Hairpin.

Adjust properties

The default dynamic of the score is mf (mezzoforte)—set at MIDI velocity 80 (out of 127). Depending on the dynamic governing a particular section of the score, velocity (and the resulting loudness) may be less than or greater than this.

To edit the velocity of a dynamic

- Select the dynamic and, in the Dynamic section of the Inspector edit the Velocity value—higher for louder, lower for softer.

To adjust the range

Note: Range = the staves in the system affected by the dynamic.

- Select the dynamic, and in the Dynamic section of the Inspector, choose an option from "Dynamic range". The default is "Part," which means that all staves for a particular instrument will be affected. "Staff" limits the effect to the staff attached to the dynamic. "System" means that all staves in the system will be affected by the dynamic.

Customize a dynamic

Dynamics can be edited just like any other text object. Special character shortcuts can be used to add the following symbols:

- Ctrl+Shift+F (Mac: Cmd+Shift+F): Forte f.
- Ctrl+Shift+M (Mac: Cmd+Shift+M): Mezzo m.
- Ctrl+Shift+R (Mac: Cmd+Shift+R): Rinforzando r.
- Ctrl+Shift+S: Sforzando s.
- Ctrl+Shift+N (Mac: Cmd+Shift+N): Niente n.
- Ctrl+Shift+Z (Mac: Cmd+Shift+Z): Z z.

You can also edit the velocity and range etc. (see above). If desired, you can save the result for future use in a custom palette.

Single Note Dynamics (SND)
As of version 3.1, MuseScore supports single note dynamics. In addition to editing the velocity, you can also edit the velocity change in the inspector. Entering a number into this field will change the velocity of the note by approximately that amount after the initial velocity is played. A negative number can be used to lower the volume after the initial note and a positive number will make the note play louder after the initial volume. See links (below) for further details.

External links
- Video tutorial: Lesson 10 - Articulations, Dynamics and Text
- Using Single Note Dynamics (Wikipedia)
- Dynamics (Wikipedia)

Capo playback

MuseScore allows you to transpose the playback of a staff, without affecting the music notation. This simulates the effect of a capo (Wikipedia) on the instrument.

To add a capo:

1. Add staff text to the note/rest from which you want capo playback to start;
2. Right-click on the staff text, select Staff Text Properties..., then click on the Capo Settings tab;
3. Check the “Capo Settings” checkbox, and set Capo fret to the fret number you wish to apply the capo at (each fret increases the pitch by a semitone);
4. Click Ok to apply your changes;
5. Edit the wording of the text as desired.

Capo playback will apply from the note that the staff text is attached to, until either the next staff text with “Capo Settings” enabled, or until the end of the score. A Capo fret setting of "No capo" will remove any capo previously set for a staff, returning it to its original tuning.

Text

There are many different kinds of text objects in MuseScore (see tables below); text may also be found incorporated into lines. This chapter shows you how to create, format and edit text objects, and also includes information about the following types of text:

<table>
<thead>
<tr>
<th>Text type</th>
<th>Uses</th>
</tr>
</thead>
<tbody>
<tr>
<td>Staff text</td>
<td>General purpose text attached to a single staff: appearing only in that instrument part.</td>
</tr>
<tr>
<td>System text</td>
<td>General purpose text attached to a single staff: appearing in all instrument parts.</td>
</tr>
<tr>
<td>Chord symbols</td>
<td>Display the chords associated with a melody: usually above the staff.</td>
</tr>
<tr>
<td>Fingering</td>
<td>Numbers or letters attached to notes showing which fingers to use.</td>
</tr>
<tr>
<td>Lyrics</td>
<td>Create lyrics attached to a melody.</td>
</tr>
<tr>
<td>Rehearsal marks</td>
<td>Facilitate rehearsals, divide score into sections, bookmark passages etc.</td>
</tr>
</tbody>
</table>

For other types of text available in MuseScore, follow the links below:

<table>
<thead>
<tr>
<th>Text type</th>
<th>Uses</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dynamics</td>
<td>Indicate the loudness of a note or phrase.</td>
</tr>
<tr>
<td>Figured bass</td>
<td>Period notation for keyboarders.</td>
</tr>
<tr>
<td>Frame text</td>
<td>Title/composer/lyricist details at the start of a score; songsheet lyrics etc.</td>
</tr>
<tr>
<td>Headers/Footer</td>
<td>Page numbers, copyright info etc. at the top/bottom of a page.</td>
</tr>
<tr>
<td>Instrument text</td>
<td>Apply mid-staff instrument changes.</td>
</tr>
<tr>
<td>Repeats and jumps</td>
<td>Da Capo, Dal segno, Fine etc.</td>
</tr>
<tr>
<td>Roman Numeral Analysis (RNA)</td>
<td>A chord analysis system.</td>
</tr>
<tr>
<td>Sticking</td>
<td>Letters (L and R) attached to (drum) notes showing which hand or foot to use.</td>
</tr>
<tr>
<td>Swing text</td>
<td>Change from straight to swing time, and vice versa.</td>
</tr>
<tr>
<td>Tempo marks</td>
<td>Apply metronome and/or expression marks.</td>
</tr>
<tr>
<td>Text-lines</td>
<td>Voltas, ottavas, pedal lines, guitar barre lines etc.</td>
</tr>
</tbody>
</table>

Text basics

Add text

To add a text-based element to the score, use one of the following general methods:
• **Keyboard shortcut:** For example, press Ctrl+T to enter **Staff text**, Ctrl+L to enter **Lyrics**, and so on.
• **Menu command:** **Add → Text** allows you to choose from a range of text-based elements.
• **Workspace:** Select a note and click an icon in one of the palettes (double-click in versions prior to 3.4); or, alternatively, drag a symbol from a palette onto the staff. E.g. **Swing text, Tempo text** etc.

**Notes:** (1) The exact method depends on the type of text you are adding (see **Text**). (2) For general-purpose **text boxes** attached to staves, see **Staff and system text**.

**Text formatting**

When a **text object** is created in MuseScore, it assumes the corresponding **Text Style**: all **staff text**, for example, has a unique **Text Style**, as have tempo markings, dynamics, chord symbols etc. Each **Text Style** consists of a number of text properties (font-face, font-size, font-style etc.), which can be viewed, mainly, in the **Text Styles** dialog (Format → Style... → **Text Styles**).

A newly-created **text object** starts off with identical text properties to the **Text Style**. These can be viewed in the Inspector:

![Inspector](Image)

However, these text properties are **not** limited to those of the default **Text Style**: if need be, you can edit them in the **Inspector independently** of **Text Style**.

Finally, if you want to apply formatting to specific characters in a **text object** (font-face, font-size, Bold, Italic, Underline, superscript, subscript), you can do so in **text edit mode**.

**Adjust position of text objects**

To position a text object, use any of the following methods:

• Drag the object.
• Select the object and adjust the X or Y offset values in the **Inspector**.
• Select the object and apply any of the following keyboard shortcuts:
  - ←: Move text left 0.1 **staff space**.
  - →: Move text right 0.1 **staff space**.
  - ↑: Move text up 0.1 **staff space**.
  - ↓: Move text down 0.1 **staff space**.
  - Ctrl← (Mac: **Cmd**←): Move text left one **staff space**.
  - Ctrl→ (Mac: **Cmd**→): Move text right one **staff space**.
  - Ctrl↑ (Mac: **Cmd**↑): Move text up one **staff space**.
  - Ctrl↓ (Mac: **Cmd**↓): Moves text down one **staff space**.

**Text anchors**

When you apply a text element to the score, its **anchor** position will depend on the type:

• **Title, Subtitle, Composer, Poet:** Anchored to a frame.
• **Fingering:** Anchored to note heads.
• **Lyrics:** Anchored to a time position (a note/chord, but not a rest).
• **Chord symbol:** Anchored to a time position.
• **Staff text:** Anchored to a time position.
• **System text:** Anchored to a time position.
• **Sticking:** Anchored to a time position.

**Text editing**

**Text edit mode** allows you to add or delete text, and apply formatting (e.g. **bold**, **italic**, underline etc.) to individual characters.
Enter/exit text edit mode

To enter Text edit mode use one of the following methods:

- Double-click a text object.
- Click on an already selected text object.
- Right-click on a text object and select Edit element.
- Click on a text object and press Alt+Shift+E.

Note: Creating a new text object (see Text basics) also puts the program into text edit mode.

You can access the various formatting functions from the Text toolbar, which appears below the document window:

To exit Text edit mode use one of the following:

- Press Esc.
- Click on a part of the score outside the edit window.

Keyboard shortcuts

In Text edit mode, the following keyboard shortcuts are available:

- Ctrl+B (Mac: Cmd+B) toggles bold face.
- Ctrl+I (Mac: Cmd+I) toggles italic.
- Ctrl+U (Mac: Cmd+U) toggles underline.
- Home End ← → ↑ ↓ moves cursor.
- Backspace (Mac: Delete) removes character to the left of the cursor.
- Del (Mac: ← Delete or fn+Del) removes character to the right of the cursor.
- ↵ starts new line.
- F2 (Mac: fn+F2) Inserts special characters (see below).

Symbols and special characters

You can use the Special Characters window to insert quarter notes, fractions, and many other kinds of special symbols or characters into your text. A few symbols can also be accessed by shortcut (see below).

To open Special Characters, use any of the following methods:

- Click on the icon in the text toolbar (below the score window).
- Press F2 (Mac: fn+F2).
Note: (1) This only works in Text edit mode; (2) The Special Characters dialog should not be confused with the menu item of the same name in the macOS version of MuseScore.

The dialog is divided into 3 tabs: Common symbols, musical symbols and unicode symbols. The musical and unicode tabs are further subdivided into alphabetically-arranged categories.

Double-clicking an item in the Special Characters dialog immediately adds it to the text where the cursor is positioned. Multiple items can be applied without closing the dialog box, and the user can even continue to type normally, delete characters, enter numerical character codes etc., with it open.

Special character shortcuts

In Text edit mode the following keyboard shortcuts can be used to access certain special characters:

- Ctrl+Shift+: **Sharp**♯
- Ctrl+Shift+B (Mac: Cmd+Shift+B): **Flat**♭
- Ctrl+Shift+H (Mac: Cmd+Shift+H): **Natural**♮
- Ctrl+Shift+P (Mac: Cmd+Shift+P): **Piano**p
- Ctrl+Shift+F (Mac: Cmd+Shift+F): **Forte**f
- Ctrl+Shift+M (Mac: Cmd+Shift+M): **Mezzo**m
- Ctrl+Shift+R (Mac: Cmd+Shift+R): **Rinforzando**r
- Ctrl+Shift+S: **Sforzando**s
- Ctrl+Shift+N (Mac: Cmd+Shift+N): **Niente**n
- Ctrl+Shift+Z (Mac: Cmd+Shift+Z): **Zz**

See also

- Chord symbol
- Lyrics
- Frame
- Edit mode

Text styles and properties

Text styles

When you create a text object, it initially assumes the properties of the Text Style applicable to its class. Staff text objects, for example, have their own style, as do tempo markings, lyrics, chord symbols, and so on.

To view and edit any Text Style: select Format → Style... → Text Styles. This gives you access to the following properties:

- Name: Change the name of a user style if desired.
- Font face / Font size: The name of the font (e.g. Times New Roman, Arial etc.) and its size in points.
- **Follow staff size**: Whether text size changes in proportion to score scaling.
- **Font style**: The font style to use, e.g. Italic, Bold or Underline.
- **Align**: Horizontal (left, center, right) and Vertical.
- **Color**: Color of the text.
- **Offset X/Y**: Horizontal and vertical offsets in sp. units.
- **Frame**: Choose to have a circular or square frame around the text.
- **Border**: Color of the frame border.
- **Highlight**: Color of the background within the frame.
- **Thickness**: Thickness of the line of the frame in space units.
- **Margin**: Inner frame margin in space units.

- **Corner radius**: For box frame, radius of rounded corner.

**Notes**: Opacity is set by the parameter “Alpha channel” in the “Select Color” dialog: a value between 0, transparent, and 255, opaque.

Alternatively, you can edit the properties of a **Text Style** by selecting an object of the desired style in the score, adjusting its properties in the **Inspector**, and clicking the **Set as style** buttons as you go. This will automatically update the **Text Style** and all relevant text objects in the score.

**Text objects**

If you want to format a **particular text object** in the score differently to its **Text Style**, select it and adjust its text properties in the **Inspector**.

![Text Inspector](image)

If you have made changes to a particular text property in the Inspector, but want to revert that property to the **Text Style** definition, press the "Reset to style default" button.

**Save and load text styles**

Text Styles (together with all other styles in a document) can be saved as a **style file** and loaded into other MuseScore files. See **Save and load style**.

**See also**

- Text editing
- Header/Footer
- Behavior of applied text and lines

**Staff and system text**

**Staff Text** or **System Text** is invaluable as general purpose text. To apply to the score, use one of the following methods:

- Select a note or rest; then for **Staff text**, press Ctrl+T; or for **System text**, press Shift+Ctrl+T.
- Select a note or rest; then select the desired option from **Add → Text**.
- Select a note or rest; then click the desired text from a palette (double-click in versions prior to 3.4).
- Drag the desired text from a palette onto a note or rest.

This will create an empty bounding box for **text entry**. Press Esc or click on an empty space outside the box to exit.

Apart from their indicative use, staff and system text also have optional playback properties: see below.

**Summary of differences**:

<table>
<thead>
<tr>
<th>Text style</th>
<th>Applies to?</th>
<th>Playback (if applicable)</th>
<th>Appears in Instrument parts?</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Staff text</strong></td>
<td>Staff only</td>
<td>Staff only</td>
<td>Staff instrument only</td>
</tr>
<tr>
<td><strong>System Text</strong></td>
<td>All system staves</td>
<td>All system staves</td>
<td>All instruments</td>
</tr>
</tbody>
</table>

141
Staff text

Staff Text is applied to one staff (or Grand staff) in the score, and is indicative only for that staff; any playback effect associated with the text is limited in the same way. The text will appear in the corresponding instrument part.

If you choose to hide empty staves, any staff text belonging to an empty staff will also be hidden.

Staff text can, for example, be used to apply indications such as Solo or Pizzicato to one staff in a score. Depending on what the instructions of the staff text are, MIDI playback of that staff at the text location can be altered to match the instructions by right-clicking on the staff text and selecting Staff Text Properties… See Mid-staff sound change.

Staff text properties

To access Change channel, Swing Settings, and Capo Settings:

- Right-click on the text and choose "Staff Text properties," then click on the relevant tab.

System text

System text is applied to one staff in the score, but is indicative for every staff in the system. Any associated playback properties are applied to the whole system. The text will appear in all instrument parts.

System text is never hidden by the hide empty staves feature.

System text properties

To add or edit Swing:

- Right-click on the text and choose System Text properties, then click on the Swing Settings tab.

See also

- Mid-staff sound change

External links

- How to change instrument sound (e.g. pizz., con sordino) midway through score

Chord symbols

Chord symbols are an abbreviated way of representing musical chords (see Chord names and symbols (Wikipedia) for further details). For example:

\[
\text{FMaj7} \quad (\text{B7#11}) \quad \text{B} \quad \text{F#07} / \text{A} \quad \text{Gm}
\]

Note: To fill measures with slashes, see Fill with slashes or Toggle rhythmic slash notation.

As well as conventional chord symbol notation, MuseScore as of version 3.3 also supports the Nashville Number System (NNS), and Roman Numeral Analysis (RNA).

Enter a chord symbol

1. Select a start note or a slash;
2. Press Ctrl+K (Mac: Cmd+K);
3. The cursor is now positioned above the staff ready for input. Enter the chord symbol just like normal text, as follows:
   - Root note: A, B, C, D, E, F, G.
   - Sharp: # (hash symbol).
   - Flat: b (small letter "b").
   - Double sharp: x (small letter "x") or ## (two hash symbols).
   - Double flat: bb (small letter "b" twice).
   - Natural: natural (Note: there should be no space before the "natural", but there needs to be a space afterwards if there is more chord text to follow, e.g. for B♭m, entered as "Bnatural m", the space with Ctrl+Space).
   - For other symbols, see Chord symbol syntax (below).
4. Move the cursor forward or backwards to continue entering or editing chord symbols (see Keyboard commands below);
5. Exit chord symbol mode by pressing Esc.

When you exit a chord symbol, the characters entered will automatically assume the correct format: by default root note
typed in lower case will turn into upper case (for alternative options, see Automatic Capitalization); a “#”, “b” or “natural” will turn into a proper sharp (♯), flat (♭) or natural (♮) and so on. Do not try to use actual flat, sharp and natural signs as MuseScore will not understand those properly.

Keyboard commands

The following commands are available during chord symbol entry:

- Space move Cursor to next note, rest, or beat
- Shift+Space move cursor to previous note, rest, or beat
- Ctrl+Space (Mac: Cmd+Space) add a space to the chord name
- : move cursor to next beat
- : move cursor to previous beat
- Tab move cursor to next measure
- Shift+Tab move cursor to previous measure
- Ctrl (Mac: Cmd) plus number (1 - 9) move Cursor by duration corresponding to number (e.g.; half note for 6)
- Esc exit.

Chord symbol syntax

MuseScore understands most of the abbreviations used in chord symbols:

- **Major**: M, Ma, Maj, ma, maj, Δ (type: or ˆ for the triangle)
- **Minor**: m, mi, min, -
- **Diminished**: dim, ° (entered with lowercase letter, shows as ° if using the Jazz style, as o otherwise)
- **Half-diminished**: ø (type 0, zero). Alternatively, you can, of course, choose abbreviations such as mi7b5 etc.
- **Augmented**: aug, +
- The following abbreviations are also valid: extensions and alterations like b9 or #5, sus, alt, and no3; inversions and slash chords, such as C7/E; commas; parentheses, which can enclose part, or even all, of a chord symbol.

Edit a chord symbol

An existing chord symbol can be edited in a similar way to ordinary text: See Text editing.

Transpose chord symbols

Chord symbols are automatically transposed by default if you apply the menu Transpose command to the containing measures. If this is not required, you can untick the “Transpose chord symbols” option in the same dialog.

Chord symbol text

To adjust the appearance of all chord symbol text, use any of the following options:

- From the main menu, choose Format → Style → Text Styles → Chord Symbol. Then edit the text properties as required.
- Select a chord symbol and make changes in the Inspector, pressing the “Set as style” buttons as you go.

Chord symbol style

To access formatting options for chord symbols:

- From the menu, select Format → Style... → Chord Symbols. Adjustable properties are listed under the following headings:

Appearance

Three options are possible: **Standard** and **Jazz** and **Custom**. You can select between these using the radio buttons.

- In the **Standard** style, chords are rendered simply, with the font determined by your chord symbol text style.

  \[
  \begin{align*}
  \text{G} & \quad \text{Em7} & \quad \text{Am7} & \quad \text{D7} \\
  \end{align*}
  \]

- In the **Jazz** style, the MuseJazz font is used for a handwritten look, with distinctive superscript and other formatting characteristics. The Jazz style is selected by default if you use any of the Jazz templates.
• The **Custom** style option allows you to customize the look of chord symbols (and also ensures compatibility with older scores). Select a customized **Chord symbols style file** in the field below: this can be created by copying and modifying one of the pre-existing files in the "styles" folder. Documentation can be found in the same folder. Note, however, that this is for advanced users only, and there is no guarantee these files will be supported in the future.

**Note spelling**

By default, MuseScore uses letter names for chord symbols. For users in regions where other note naming schemes are used, MuseScore provides the following controls:

- **Standard**: A, Bb, B, C, C#,...
- **German**: A, Bb, H, C, C#,...
- **Full German**: A, B, H, C, Cis,...
- **Solfeggio**: Do, Do#, Reb, Re, ...
- **French**: Do, Do#, Re#, Re, ...

**Automatic Capitalization**

By default, MuseScore automatically capitalizes all note names on exit, regardless of whether you entered them in upper or lower case. However, you can also choose other automatic capitalization options:

- **Lower case minor chords**: c, cm, cm7,...
- **Lower case bass notes**: C/e,...
- **All caps note names**: DO, RE, MI,...

You can also turn off the automatic capitalization completely, in which case note names are simply rendered the way you type them.

**Positioning**

- **Distance to fretboard diagram**: If a fretboard diagram is present, this value is the height at which the chord symbol is applied above the diagram (negative values can be used).
- **Minimum chord spacing**: The space to leave between chord symbols.
- **Maximum barline distance**: Changes the size of the gap between the last chord symbol in the measure and the following barline. You only need to adjust this value if there is a continuous problem in the score with overlap between the last symbol in one measure and the first symbol in the next.

**Note**: In addition to the settings described here, the default position of applied chord symbols is also determined by settings in the **Text Styles** dialog. The effect is cumulative.

**Capo**

Enter the number of the capo position at which you want to display substitute chords, in brackets, after all chord symbols in the score.

**Nashville Number System**

The Nashville Number System (NNS), available in MuseScore since version 3.3, is a shorthand way of representing chords based on scale degrees rather than chord letters. This allows an accompaniment to be played in any key from the same chord chart.

To start entering Nashville notation:

1. Select a start note;
2. From the menu, select `Add` → `Text` → `Nashville Number`.

Just as with standard chord symbols, you can type Nashville notation normally and MuseScore will do its best to recognize and format the symbols appropriately. The same shortcuts used for navigation when entering standard chord symbols (e.g. Space, see above) are available for Nashville notation as well.

```plaintext
1 17 4Δ 4m
```

---

The Custom style option allows you to customize the look of chord symbols (and also ensures compatibility with older scores). Select a customized Chord symbols style file in the field below: this can be created by copying and modifying one of the pre-existing files in the “styles” folder. Documentation can be found in the same folder. Note, however, that this is for advanced users only, and there is no guarantee these files will be supported in the future.

**Note spelling**

By default, MuseScore uses letter names for chord symbols. For users in regions where other note naming schemes are used, MuseScore provides the following controls:

- **Standard**: A, B♭, B, C, C♯,...
- **German**: A, B♭, H, C, C♯,...
- **Full German**: A, B, H, C, Cis,...
- **Solfeggio**: Do, Do♯, Re♭, Re,...
- **French**: Do, Do♯, Ré♭, Ré,...

**Automatic Capitalization**

By default, MuseScore automatically capitalizes all note names on exit, regardless of whether you entered them in upper or lower case. However, you can also choose other automatic capitalization options:

- **Lower case minor chords**: c, cm, cm7,...
- **Lower case bass notes**: C/e,...
- **All caps note names**: DO, RE, MI,...

You can also turn off the automatic capitalization completely, in which case note names are simply rendered the way you type them.

**Positioning**

- **Distance to fretboard diagram**: If a fretboard diagram is present, this value is the height at which the chord symbol is applied above the diagram (negative values can be used).
- **Minimum chord spacing**: The space to leave between chord symbols.
- **Maximum barline distance**: Changes the size of the gap between the last chord symbol in the measure and the following barline. You only need to adjust this value if there is a continuous problem in the score with overlap between the last symbol in one measure and the first symbol in the next.

**Note**: In addition to the settings described here, the default position of applied chord symbols is also determined by settings in the **Text Styles** dialog. The effect is cumulative.

**Capo**

Enter the number of the capo position at which you want to display substitute chords, in brackets, after all chord symbols in the score.

**Nashville Number System**

The Nashville Number System (NNS), available in MuseScore since version 3.3, is a shorthand way of representing chords based on scale degrees rather than chord letters. This allows an accompaniment to be played in any key from the same chord chart.

To start entering Nashville notation:

1. Select a start note;
2. From the menu, select `Add` → `Text` → `Nashville Number`.

Just as with standard chord symbols, you can type Nashville notation normally and MuseScore will do its best to recognize and format the symbols appropriately. The same shortcuts used for navigation when entering standard chord symbols (e.g. Space, see above) are available for Nashville notation as well.

```plaintext
1 17 4Δ 4m
```
Roman Numeral Analysis

As of MuseScore 3.3, the Roman Numeral Analysis system is supported—a type of musical analysis where chords are represented by upper and lower case Roman numerals (I, ii, III, iv etc.), superscripts, subscripts and other modifying symbols. It is used to notate and analyze the harmony of a composition independent of its key (see External links for further details).

Note: Unlike standard chord symbols and Nashville notation, which MuseScore formats using its own algorithms, RNA uses the free and open source Campania font to format the symbols. This allows MuseScore to format the symbols as you type, rather than applying the formatting only when you are done. Also, if you install the Campania font on your system normally, you can use it in other programs as well and benefit from the same formatting.

Enter RNA

1. Select a start note;
2. From the menu, select Add → Text → Roman Numeral Analysis. Alternatively, set up a keyboard shortcut to do the same thing in Preferences;
3. Input the RNA symbols for the chord just like normal text, as follows;
   - Major chord: Upper case roman numerals
   - Minor chord: Lower case roman numerals
   - Diminished chord: 0 (lower case)
   - Half-diminished chord: 0 (zero)
   - Augmented chord: +
   - Chord inversions: Enter up to 3 single-digit numbers, top note first
   - Accidentals: # (sharp), b (flat)
   - For other symbols, see the image below, "Examples of RNA".
4. Move the cursor forward or backwards to continue entering or editing symbols for other chords;
5. When RNA is completed, exit by pressing Esc, or by clicking on a blank section of the score.

Just as with standard chord symbols, you can type Roman numeral analysis normally and MuseScore will do its best to recognize and format the symbols appropriately. The same shortcuts used for navigation when entering standard chord symbols are available for Roman numeral analysis as well (see Keyboard commands (above)).

Examples of RNA

![Example of RNA](image)

External Links

- [Nashville Number System](https://en.wikipedia.org/wiki/Nashville_number_system) (Wikipedia)
- [Roman Numeral Analysis](https://en.wikipedia.org/wiki/Roman_numerals_in_music) (Wikipedia)
- [Campania font](https)

Fingering

Fingering symbols for various instruments are found in the Fingering palette in the Advanced workspace.

![Fingering Symbols](image)

- **Keyboard** music employs the numbers 1–5 to represent fingers of the left or right hand. There is also a fingering positioner plugin to help you optimize the layout of piano or keyboard fingerings.
Guitar music uses the numbers 0–4 to represent left-hand fingering (T is occasionally used for the thumb). Right-hand fingering is indicated by the letters p, i, m, a, c. Circled numbers represent instrument strings.

The last five symbols in the palette are used for lute fingering in historical music.

Note: To enable the display of fingering in tablature, right-click on the TAB, and select Staff/Part Properties… → Advanced Style Properties; then check the box labelled “Show fingering in tablature”.

Add fingering to a single note

Use any of the following methods:

- Select a note and click one of the fingering symbols in a Palette (double-click in versions prior to 3.4).
- Drag and drop a fingering symbol from a palette onto a note

When fingering is added to a note, the focus immediately shifts to the symbol, so you can adjust it right away.

Add fingering to several notes

1. Select the desired notes;
2. Click a fingering symbol in a palette (double-click in versions prior to 3.4).

Easy fingering input mode (version 3.1 and above)

This special feature allows you to add fingering quickly and easily to successive notes.

1. Choose one of the following options:
   - Add the first fingering symbol using one of the methods shown above: this can be a “Left Hand Guitar Fingering”, “Fingering” or “String Number”;
   - For “Fingering” only, select a note and press the keyboard shortcut for “Add fingering” (defined in Preferences: Shortcuts); then type the desired number;
2. Choose one of the following options:
   - To move the cursor to the next note: Press Space, or Alt→;
   - To move the cursor to the previous note: Shift+Space, or Alt ←;
3. Type the desired number;
4. Repeat steps 2 and 3 as required;
5. Press Esc, or click on an empty space in the document window, to exit.

Adjust position of fingering

Single fingering

To change the position of one symbol, use any of the following methods:

- For fine adjustments (0.1 sp) use the arrow keys; For larger adjustments (1 sp) use Ctrl←→↑↓.
- Change X and Y offsets in the Inspector.
- Drag the symbol using your mouse.

Multiple fingering

To change the position of multiple symbols:

1. Select the desired fingering symbols;
2. Adjust using the X and Y offsets in the Inspector.

Note: You can also use the fingering positioner plugin mentioned above to optimize the layout of piano fingerings.

To restore a symbol to its default position, select it and press Ctrl+R.

Edit fingering text

Fingering symbols are text objects and can be edited in the usual way. Text properties and overall style can be adjusted in the Inspector.

Lyrics

Enter a lyrics line

First line

1. Enter the notes of the melody line;
2. Select the note where you want to start entering lyrics;
3. To enter lyrics mode, type Ctrl+L (Mac: Cmd+L); or from the main menu, Select Add → Text → Lyrics;
4. Type a syllable;
5. Use the following options to continue entering lyrics:
   - Go to the next syllable: Press Space (or Ctrl+→ (Mac: Alt+→)) at the end of a syllable.
   - Hyphen (to connect syllables): Press - at the end of a syllable.
   - Go to the previous syllable: Press Shift+Space (or Ctrl+← (Mac: Alt+←)).
   - Move left: Press ← (left arrow). If the cursor is at the beginning of a syllable, it will jump to the previous one.
   - Move right: Press → (right arrow). If the cursor is at the end of a syllable, it will jump to the next one.
   - Move to the syllable below: Press ↓ (down arrow).
   - Move to the syllable above: Press ↑ (up arrow).
   - Start new lyrics line: Press Enter (Return) at the end of an existing lyrics syllable (Note: Don't use the Enter key from the numeric keypad!).
6. To exit lyrics mode, press Esc or click outside of the text box.

Subsequent lines

If you want to add another lyrics line to an existing one (e.g. a 2nd or 3rd verse etc.):

1. Choose one of the following options:
   - Select the note where you want to start the new lyrics line. Enter lyrics mode as shown in step 3 (above). The cursor moves to a new (blank) line.
   - Enter text edit mode on an existing syllable, go to the end of the syllable and press Enter (Return). The cursor moves to the next line.
2. Continue entering lyrics from step 4 (above).

Example:

```
| A - des - te, fi - del - ces, |
| Can - tot nunc hym - nos |
| Er - go qui na - tus |
```

Special characters

In most cases, lyrics can be edited just like normal text. However, special keyboard shortcuts are required to enter the following characters:

- **Character space**: Ctrl+Space (Mac: ~ + Space).
- **- (hyphen)**: Ctrl+- (Mac: Alt+-) or AltGr+-.
- **Line feed**: Ctrl+Enter (Mac: Alt+Return) or Enter (from the numeric keypad).

Verse numbers

To number verses, simply type the number (e.g. 1.) and a space before the first syllable. MuseScore will automatically align the numbers and first syllable correctly.

Melisma

A **melisma** is a syllable or word that extends over two or more notes. It is indicated by an underline extending from the base of a syllable to the last note of the melisma. The underline is created by positioning the cursor at the end of a syllable and pressing Shift+_; once for each note in the melisma. See the image below:
The above lyric was created in the following manner:

1. Type the letters, soul.
2. At the end of the word, press Shift+_.
3. Type the letters To, then press Esc.

For non-last syllables to extend, just use additional dashes-, usually only one of them will show (more when the distance between the syllables is large enough), and the syllable will right-align to the first note, similar to last syllables that got notated with a melisma, see above.

Elision (Lyric) slur / Synalepha

Two syllables under a note can be joined with an elision slur, also known as a "lyric slur" or "synalepha". For example:

To create the example lyric text, starting with the syllable text "te":

1. Type te;
2. Click on the keyboard icon in the bottom-left corner of the screen, or press F2 to open the Special Characters palette;
3. Use one of the following options:
   - Double-click one of the three elision slurs in the "Common Symbols" tab: "Narrow elision", "Elision", or "Wide elision" (these can be found between the "C Clef" and the "p" dynamic—see image below):
   

   ![Special Characters Palette](image)

   - Double-click the elision slur found after the 7/8 fraction in the "Common Symbols" tab (next to last character in the image above). Depending on the font, add one or more spaces before/after the slur using Ctrl+Space (Mac: Alt+Space).

   **Note:** Not all fonts include the "undertie" character (U+203F "undertie", present in "Special Characters" mainly for compatibility with MuseScore 1.x scores). To find out which fonts on your computer support it, see "fontlist" (look for any font that shows a tie between "te" and "A" instead of a blank rectangle).

4. Type A.
Edit Lyrics

1. Enter text edit mode on an existing syllable;
2. Use standard text editing commands to make changes;
3. Continue entering lyrics (see above); or exit lyrics mode by pressing Esc.

Adjust properties of lyrics

To make global adjustments to the properties of all lyrics in the score:

1. From the menu, select Format → Style... → Lyrics;
2. Edit Placement, Line height, Margins, Dash and Melisma properties as required.

Adjust position of individual lyrics lines

To adjust the position of a particular lyrics line:

1. Select the lyrics line: i.e. right click on a word in the line, and (from the menu) choose Select → More...; then check the relevant options, which should include “Same system”;
2. Adjust the X and Y offsets in the Inspector.

Copy lyrics to clipboard

To copy all lyrics to the clipboard:

- From the menu bar, select Tools → Copy Lyrics to Clipboard.

Paste lyrics from clipboard

To copy and paste lyrics from a text file (say) into a score:

1. Enter the notes in the score to which the lyrics will be attached.
2. Set up your lyrics in a text file, with appropriate spaces, hyphens, line-breaks etc.
3. Copy the lyrics from the text-file into the clipboard.
4. Select the start note in MuseScore, and press Ctrl+L (Mac: Cmd+L) (step 3 under Enter lyrics in a score).
5. Repeatedly applying paste will enter successive words of the lyrics. You may need to enter melismas and make other corrections as you go along.

See also

- Text
- Chord symbol

External links

- How to insert Lyrics
- How to move lyrics
- How to copy lyrics, or lyrics with rhythm
- How to add a block of text to a score
- Video tutorial: MuseScore in Minutes: Lesson 6 - Text, Lyrics and Chords

Rehearsal marks

Rehearsal marks can be used in a number of ways:

- To identify specific points in a score to facilitate rehearsing.
- As bookmarks in the score to which you can instantly navigate—using the Find/Search command.
- To mark the various sections in the score.

Typically, rehearsal marks consist of one or more letters and/or numbers, and appear in sequence in the score—e.g. A, B, C..., or 1, 2, 3... etc. Alternatively, they may display measure numbers (usually larger than standard measure numbers, boldface and/or enclosed in boxes). Multi-measure rests are automatically broken before and after rehearsal marks.

Rehearsal marks can be added to the score (i) automatically—which ensures that they are named in sequence—or (ii) manually, allowing you to name them as you wish.

Add a rehearsal mark

Manual Placement
To create a rehearsal mark manually:

1. Click on a note (or rest) at the desired location;
2. Select one of the following options:
   - Press Ctrl+M (Mac: Cmd+M);
   - From the menu, choose Add → Text → Rehearsal Mark;
3. Enter the desired text.

Automatic placement

Add an alphanumeric rehearsal mark

Use either of the following options:

- Click on a note (or rest) at the desired location, then click the [B1] rehearsal mark icon in the "Text" palette (double-click in versions prior to 3.4).
- Drag and drop the rehearsal mark from the "Text" palette onto the score.

Notes: (1) By default, marks are added in the sequence, A, B, C etc. (2) To change the format of subsequently-added marks (to lower case letters, or numbers), edit the previous rehearsal mark accordingly. (3) Marks added between existing rehearsal marks append a number or letter to the previous mark: it is a good idea to apply the Resequence command afterwards (see below).

Add a measure-number rehearsal mark

1. Add the first rehearsal mark in the series as an alphabetical one; then edit it to read the same as the number of the measure it is attached to;
2. Add subsequent marks as shown above. They will automatically adopt the measure-number format.

Automatically resequence rehearsal marks

MuseScore allows the user to automatically re-order a series of rehearsal marks if they have got out of sequence for any reason. Use the following method:

1. Before making a selection, you can, if desired, establish a new format for the rehearsal marks (lower/upper case, number, or measure number) by manually altering the first mark in the range accordingly.
2. Select the range of measures you wish to apply the Resequence command to (if there is no selection then the program assumes you wish to resequence all measures).
3. From the menu, select Tools → Resequence Rehearsal Marks.

MuseScore automatically detects the sequence based on the first rehearsal mark in the selection—all rehearsal marks in the selection are then altered accordingly. The following sequences are possible:

- A, B, C etc.
- a, b, c etc.
- Numerical: 1, 2, 3 etc.
- Numerical: according to measure numbers. This requires the number of the first mark in the series to be equal to the number of the measure it is attached to.

Text style

Rehearsal marks are a variety of system text, appearing both on the score and on every part. By default, they are in a large bold font, and enclosed in frames with rounded corners. All aspects of their appearance can be changed globally via the rehearsal mark Text style.

Search for a rehearsal mark

See Find (Viewing and navigation).

See also

- Text properties

External links

- Rehearsal Letter (Wikipedia article)

Formatting

Layout and formatting
Layout and formatting options for the score are accessed from the **Format** menu.

**Ways to affect layout**

The main commands and dialogs affecting score layout are listed immediately below. Other formatting options are covered further down the page (but for text, see **Text styles and properties**).

- **Page Settings**: Adjust the overall dimensions of your score such as page size, page margins, and scaling.
- **Increase/Decrease Layout Stretch**: Adjust the score spacing by stretching or squashing selected measures.
- **Score**: Set overall score details, such as music font, display of multi-measure rests, and whether to hide empty staves.
- **Page**: Adjust staff and system spacing, score and lyric margins etc.
- **Measure Style**: Set the measure spacing, which affects the number of measures per line.
- **Sizes**: Set the default size of "small" and grace notes, small staves and small clefs.

Other commands:

- **Add/Remove System Breaks**: Set the number of measures per system.
- **Breaks and spacers**: Apply system, page or section breaks. You can also add extra space between particular systems or staves where needed.

**Style**

The **Style** submenu contains dialogs which allow you to adjust the global formatting of many score elements. To open **Style**:

- From the menu, select **Format** → **Style**...
- Right click on a space in the document window and select **Style**....
- Use a keyboard shortcut (see **Shortcuts**).

The **Style** dialogs are as follows:

**Score**

To open the **Score** dialog, select **Format** → **Style**... → **Score**.

This dialog allows you to set global properties, such as the music font, display of multimeasure rests, whether or not to hide empty staves, swing playback etc.

- **Musical symbols font**: Choice of display in Emmentaler, Bravura or Gonville fonts. Tick the box to "automatically load style settings based on font."
- **Musical text font**: Choice of display in Emmentaler, Bravura, Gonville or MuseJazz fonts.
- **Display in concert pitch**: Tick this option to display the score at concert pitch. If unticked the score is displayed at written pitch.
- **Create multimeasure rests**: Tick to display multimeasure rests.
  - **Minimum number of empty measures**: The default is 2.
  - **Minimum width of measure**: The default width is 4 sp.
- **Hide empty staves within systems**: This option saves space by hiding those staves in a system which consist of only empty measures. Used for condensed scores.
- **Don't hide empty staves in first system**: Always display staves in first system even if they consist of empty measures.
- **Display note values across measure boundaries**: A feature useful for notating early music. See **Unbarred notation**.
- **Hide instrument name if there is only one instrument**: You don't usually need to display the instrument name in this case.
- **Swing settings**: allows you to control the degree of swing for the whole score.
  - **Swing**: Choice of OFF (default) / Eight Note / Sixteenth note.
Select swing ratio: The default is 60%.

If you prefer to set swing on the score page, see Swing.

Page

To open the Page dialog, select Format → Style... → Page.

This dialog allows you to adjust the overall layout of your score by changing the spacing of margins, systems, staves, lyrics lines, and frames. You can also control the display of key signatures, time signatures, and clefs.

The diagram below is a guide to various parameters under the control of this dialog:

- **Music top margin**: The distance between the top staff line of the first staff on the page and the top page margin.
- **Music bottom margin**: The distance between the bottom staff line of the last staff on the page and the bottom page margin.
- **Staff distance**: The space between staves which are not part of a grand staff (see below).
- **Grand staff distance**: The space between staves that share the same instrument—such as the piano, organ, or those of a guitar staff/tab pair.

*Note: To alter the space above one particular staff see Extra distance above staff (Staff properties)*

- **Min. system distance**: The minimum distance allowed between one system and the next.
- **Max. system distance**: The maximum distance allowed between one system and the next.
- **Vertical frame top margin**: The default margin height above a vertical frame.
- **Vertical frame bottom margin**: The default margin height below a vertical frame.
- **Last system fill threshold**: If the last system is longer than this percentage of the page width, it gets stretched to fill that width.

The following check boxes allow you to control the display of clefs, time signatures, and key signatures—including the courtesy kind.

- Create clef for all systems / Create key signature for all systems / Create courtesy clefs / Create courtesy time signatures / Create courtesy key signatures.

Sizes

To open the Sizes dialog, select Format → Style... → Sizes.

Sets the proportional size of "small" notes and grace notes, as well as small staves and small clefs. Changing this would be unusual.
Header, Footer

To open the **Header, Footer** dialog, select Format → Style... → Header, Footer.

This allows you to add header and footer text using meta tags (see Score properties)—such as page numbers, page headers, copyright information etc. For example, you can create different Headers and Footers for even and odd pages, such as putting page numbers on the right for odd-numbered pages and on the left for even-numbered pages.

If you hover with your mouse over the Header or Footer text region, a list of macros will appear, showing their meaning, as well as the existing meta tags and their content.

To create a header or footer for an individual part, that part needs to be the active tab. To create a header or footer for a score with linked parts, make sure the main score is in the active tab.

Measure Numbers

To open the **Measure Numbers** dialog, select Format → Style... → Measure Numbers.

This allows you to specify whether measure numbers will appear in the score, and, if so, at what intervals. You can also set the font properties.

System

To open the **System** dialog, select Format → Style... → System.

This dialog allows you to adjust certain properties of all systems.

Brackets:

- **System bracket thickness**: Set the width of system brackets.
- **Brace thickness**: Set the width of system braces.
- **System bracket distance**: Set the distance between system brackets and the start barlines.
- **Brace distance**: Set the distance between system braces and the start barlines.

See also Brackets.

Dividers:

- **Left / Right**: Specify whether to show system dividers, what types, and apply global positioning offset values.

Clefs

To open the **Clefs** dialog, select Format → Style... → Clefs.

Choose the style of the default tablature clef: Standard or Serif.

Accidentals

To open the **Accidentals** dialog, select Format → Style... → Accidentals.

Allows you to specify how the score displays key signature accidentals at key changes. See Naturals on key signature changes.

Measure

To open the **Measure** dialog, select Format → Style... → Measure.

For details, see Measure.

Barlines

To open the **Barlines** dialog, select Format → Style... → Barlines.

- **Show repeat barline tips** ("winged repeats")
- **Barline at start of single staff**: Whether to show barlines at the beginning of a staff.
- **Barline at start of multiple staff**: Whether to show barlines at the beginning of multiple staves.
- **Scale barlines to staff size**: Affects "small" staves only.

Other properties allow you to set the thickness of "thin," "thick" and double barlines, the distance between double barlines, and the repeat barline to dot distance.
Notes

To open the Notes dialog, select Style → General... → Notes. The dialog can also be opened direct from the score by right-clicking on any note and selecting “Style...”

Here you can adjust the distance and thickness of note-related objects (stems, ledger lines, dots, accidentals). Changing these would be unusual.

Beams

To open the Beams dialog, select Style → General... → Beams.

This allows you to set the overall properties of note beams in the score:

- **Beam thickness**
- **Beam distance**: The vertical distance between beams.
- **Broken beam minimum length**: Affects secondary beams where they do not fully extend from note to note.

Ticking the Flattten all beams option means that all note beams will be horizontal only—not sloped.

Tuplets

To open the Tuplets dialog, select Format → Style... → Tuplets.

Vertical Distance from Notes:

- **Maximum slope**: Limit the slope of tuplet brackets.
- **Vertical distance from stem**: Refers to tuplet numbers and brackets.
- **Vertical distance from notehead**: Refers to tuplet numbers and brackets.

Horizontal distance from notes:

- **Distance before stem of first note**: Sets default position of start of tuplet bracket when above/below note stems.
- **Distance before head of first note**: Sets default position of start of tuplet bracket when above/below noteheads.
- **Distance after stem of last note**: Sets default position of end of tuplet bracket when above/below note stems.
- **Distance after head of last note**: Sets default position of end of tuplet bracket when above/below noteheads.

Brackets:

- **Bracket thickness**
- **Bracket hook height**: Sets the default length of the vertical hooks at the ends of tuplet brackets

Properties:

- **Direction / Number type / Bracket type**

Arpeggios

To open the Arpeggios dialog, select Format → Style... → Arpeggios.

Here you can change the distance to note, line thickness, and hook length of the following arpeggio and strum symbols:

```
\|/ \_ /
```

Slurs/Ties

To open the Slurs/Ties dialog, select Format → Style... → Slurs/Ties.

- **Line thickness at end**
- **Line thickness middle**
- **Dotted line thickness**
- **Minimum tie length**
- **Autoplace min. distance**

Hairpins

To open the Hairpins dialog, select Format → Style... → Hairpins.

Here you can set the default properties of hairpins (crescendo and decresendo lines):

- **Placement**: Whether to place above or below the staff.
- **Position above/below**: Set a numerical value in sp. units.
- **Height**: The width of the mouth of the hairpin.
- **Continue height
- **Autoplacement**: distance to dynamics
- **Line thickness**

**Volta**

To open the **Volta** dialog, select Format → Style... → Volta.

Here you can set the default properties of **voltas**:

- **Default position**: Set X- and Y-offsets.
- **Hook height**: The length of descending lines at the ends of voltas.
- **Line thickness
- **Line style**: A solid line is the default option, but there are dotted and dashed alternatives.

**Ottava**

To open the **Ottava** dialog, select Format → Style... → Ottava.

Here you can set the default properties of **ottavas** (octave lines):

- **Numbers only**: If unticked, the ottava also displays "va" or "vb" after the number.
- **Position above/below**: Set the X- and Y-offsets for the ottava.
- **Hook height above/below**: The length of the ascending/descending line at the end of the ottava.
- **Line thickness
- **Line style**: A dotted line is the default option, but there are solid, dotted and dashed alternatives.

**Pedal**

To open the **Pedal** dialog, select Format → Style... → Pedal.

Here you can set the default properties of **pedallines**:

- **Placement**: Below or above the staff.
- **Position above/below**: Set the exact default position using offset values.
- **Line thickness
- **Line style**: solid is the default but there is a range of dashed and dotted options.

**Trill**

To open the **Trill** dialog, select Format → Style... → Trill.

Here you can set the default placement of **Trilllines**:

- **Placement**: Below or above the staff.
- **Position above/below**: Set the exact default position using offset values.

**Vibrato**

To open the **Vibrato** dialog, select Format → Style... → Vibrato.

Here you can set the default placement of **Vibratolines**:

- **Placement**: Below or above the staff.
- **Position above/below**: Set the exact default position using offset values.

**Bend**

To open the **Bend** dialog, select Format → Style... → Bend.

Here you can set the display properties of **Bends**. This includes the line thickness, arrow width and font properties.

**Text Line**

To open the **Text Line** dialog, select Format → Style... → Text Line.

Here you can set the default placement of **text lines**:

- **Placement**: Below or above the staff.
- **Position above/below**: Set the exact default position using offset values.
Articulations, Ornaments

To open the **Articulations, Ornaments** dialog, select Format → Style... → Articulations, Ornaments.

This dialog allows you set the default placement distances and size (as a percentage) of articulations and ornaments.

Fermatas

To open the **Fermatas** dialog, select Format → Style... → Fermatas.

This dialog allows you set the default placement of fermatas.

Staff Text

To open the **Staff text** dialog, select Format → Style... → Staff Text.

This dialog allows you set the default placement and autoplacement properties of staff text.

Tempo Text

To open the **Tempo text** dialog, select Format → Style... → Staff Text.

This dialog allows you set the default placement and autoplacement properties of tempo text.

Lyrics

To open the **Lyrics** dialog, select Format → Style... → Lyrics.

![Lyrics dialog](image)

**Lyrics Text**

- **Placement**: Default position of lyric lines in relation to the staff; Above or Below.
- **Position above / Position below**: The X and Y offsets for “Placement.”
- **Line height**: Default distance between lyric lines.
- **Min. top margin**: Minimum distance between the lyric lines and the parent staff’s skyline.
- **Min. bottom margin**: Minimum distance between the lyric lines and the skyline of the next staff.
- **Min. distance**: Minimum distance between lyrics syllables.
- **Align verse number**.

**Lyrics Dash**

- **Min. dash length**: Minimum length of inter-syllable dashes.
- **Max. dash length**: Maximum length of inter-syllable dashes.
- **Max. dash distance**: Maximum distance allowed between dashes. Reducing this value allows more dashes to form between syllables where possible—and vice versa.
- **Dash thickness**: The (vertical) thickness of the dash.
- **Dash pad**:
- **Dash y position ratio**: Affects the vertical placement of the dash.
- **Always force dash**: Tick to ensure that a dash is always visible between syllables.
Lyrics melisma

- Melisma thickness: The (vertical) thickness of the melisma.
- Melisma pad:
- Align:

See also, Melismas.

Dynamics

To open the Dynamics dialog, select Format → Style... → Dynamics.

This dialog allows you set the default placement and autoplacement properties of dynamics.

Rehearsal Marks

To open the Rehearsal Marks dialog, select Format → Style... → Rehearsal Marks.

This dialog allows you set the default placement and autoplacement properties of rehearsal marks.

Figured Bass

To open the Figured Bass dialog, select Format → Style... → Figured Bass.

This allows you to set the default font, style, alignment and position of figured bass.

Chord Symbols

To open the Chord Symbols dialog, select Format → Style... → Chord Symbols.

This section allows you to adjust the format and positioning of chord symbols:

Appearance:
- Choose a default chord symbol style—Standard, Jazz or Custom.

Note spelling:
- Choose the spelling convention for chord symbols and whether to use capital or small letters.

Positioning:
- Distance to fretboard diagram: The distance (in sp. units) from a chord symbol to a fretboard diagram when both are applied to the same location on a staff. This value overrides the above “Default vertical position” setting. The user can choose to place a chord symbol below a fretboard diagram by entering a negative value.
- Minimum chord spacing: The minimum space to allow between chord symbols.
- Maximum barline distance: Increases the distance between the final chord symbol in a measure and the following barline. You may wish to adjust this value if there is a recurring problem in the score with overlap between the final chord symbol in one measure and the following chord symbol.

Capo:
- Capo fret position: Enter the number of the capo position at which you want to display substitute chords, in brackets, for all chord symbols in the score.

Fretboard Diagrams

To open the Fretboard Diagrams dialog, select Format → Style... → Fretboard Diagrams.

This section allows you to adjust the format and positioning of fretboard diagrams:

- Default vertical position: the distance in sp. units from a newly applied fretboard diagram to a staff. A negative value may be used.
- Scale: Increase or decrease the size of the fretboard diagram in the score.
- Fret offset number font size: Increase or decrease the size of a fret number displayed next to a diagram.
- Position Left/Right: Display fret number to the left or right of the fretboard diagram.
- Barre line thickness: Make barre lines in fretboard diagrams thicker or thinner.

Text Styles

To open the Text Styles dialog, select Format → Style... → Text Styles.
This dialog allows you to set the formatting of all text styles. Individual text styles can also be set from the Inspector.

**OK / Cancel / Apply buttons**

Any changes made in the Style dialog are immediately applied to the score, but can be rescinded at any time by pressing Cancel—which also exits the dialog. Press OK to save your changes to the score and close the window.

If you are making formatting adjustments in an instrument part, use the Apply to all Parts button to apply all changes to all parts in the score.

**Page Settings...**

See Page settings.

**Add / Remove System breaks**

This tool adds or removes system breaks over all or part of the score:

1. Select a range of measures: if no selection is made, the command is applied to the whole score.
2. Choose Format → Add/Remove System Breaks…. The following dialog appears.

3. Choose one of the following options:
   - Break systems every X (select number) measures;
   - Add system break at end of each system;
   - Remove current system breaks;
4. Press OK.

**Stretch**

Used to increase, decrease or reset the horizontal spacing of notes within selected measures.

Increase / Decrease layout stretch

1. Select a range of measures. Or use Ctrl+A to select the whole score.
2. Choose one of two options:
   - To **increase stretch**:
     - Use the shortcut { (right curly bracket) (Mac: Ctrl+Alt+9).
     - Or from the menu bar, select Format → Stretch → Increase Layout Stretch.
   - To **decrease stretch**:
     - Use the shortcut } (left curly bracket) (Mac: Ctrl+Alt+8).
     - Or from the menu bar, select Format → Stretch → Decrease Layout Stretch.

Reset stretch

To reset stretch to the default spacing of 1:

1. Select a range of measures. Or use Ctrl+A to select the whole score.
2. From the menu, select Format → Stretch → Reset Layout Stretch.

See also Measure Properties: Layout stretch. This allows you to set the stretch more precisely.

**Reset Style**

To reset all text styles to the “factory” default settings:

- From the menu, select Format → Reset Style.
Reset Beams

To restore beams to the mode defined in the local time signatures:

1. Select the section of the score you want to reset. If nothing is selected, the operation will apply to the whole score;
2. Select Format → Reset Beams.

See also Beams.

Reset Shapes and Positions

The Reset Shapes and Positions command restores the default positions, note stem directions and shapes (slurs, ties etc.) for selected score elements. To apply:

1. Select the elements or the region of the score that you wish to reset. Or use Ctrl+A to select the whole score.
2. Press Ctrl+R; or, from the menu, select Format → Reset Shapes and positions.

Load / Save style

It is easy to transfer a complete set of styles (all General Style settings, all text styles, and page settings) from one score to the other using the Load/Save Style feature.

To load a customized style:

1. Go to Format → Load Style...
2. Navigate to and select the Style file (.mss) and click Open (or double click on the file).

All existing styles in the score should update automatically.

To save a customized style:

1. Go to Format → Save Style...
2. Name and save the style file (the default folder is set in your Preferences). Styles are stored as *.mss files.

Note: You can also define a preferred style for scores and parts in the Score section of MuseScore’s Preferences.

See also

- To edit spacing between notes
- Upgrading from MuseScore 1.x, local relayout

External links

- Tutorial – How to create large-print stave notation (MSN)
- MuseScore in 10 Easy Steps: Part 10A Layout and Formatting (a video tutorial)
- MuseScore in 10 Easy Steps: Part 10B Layout and Formatting (a video tutorial)

Measure

To open the Measure dialog, select Format → Style... → Measure.

This allows you to adjust the distance between various items within measures.

Introduction

If you change a measure style property, MuseScore automatically adjusts the score to maintain the correct spacing between notes and rests according to best music engraving practice. It will also correctly reposition any elements attached to notes or rests, such as fingerings, dynamics, lines etc.

All settings related to measure width and note spacing are minimum values. Measures are automatically stretched, if necessary, to maintain existing page margins.

All the properties listed below use the staff space (abbreviated to “sp”) as the basic unit of measurement. See Page settings: Scaling for more details.

Options

- Minimum measure width: Sets the minimum horizontal length of measures. In measures containing very little content (e.g., a single whole note or whole measure rest), the measure will only shrink as far as this minimum.

- Spacing (1=tight): Condenses or expands the space after notes or rests. This setting thus affects not only space
between notes but also between the last note and the ending barline. For the space between the beginning of the measure and the first note or rest, see Note left margin (below).

- **Note left margin**: Sets the distance from the start barline to the first note.

- **Barline to grace note distance**: Sets the distance between a barline and a grace note that occurs before the first actual note in a measure (independently of the "Note left margin" setting).

- **Barline to accidental distance**: Sets the distance between a barline and an accidental placed before the first note in a measure (independently of the "Note left margin" setting).

- **Note to barline distance**: Sets the distance from the last note to the following barline.

- **Minimum note distance**: Specifies the smallest amount of space MuseScore will allow after each note (depending on other factors, more space may be allowed).

- **Clef left margin**: Sets the distance between the very beginning of each line and the clef. (This option is rarely needed.)

- **Key signature left margin**: Sets the distance between the beginning of the measure and a key signature.

- **Time signature left margin**: Sets the distance between the beginning of the measure and a time signature (if there is no key signature in between).

- **Time signature to barline distance**: To be added

- **Clef/key right margin**: Sets the distance between a mid-staff clef or key signature and the following note or rest.

- **Clef to barline distance**: Sets the distance between a barline and a clef change preceding it.

- **Clef to key distance**: Sets the distance from the clef to a key signature following it.

- **Clef to time signature distance**: Sets the distance from the clef to the time signature following it (if there is no key signature in between).

- **Key to time signature distance**: Sets the distance from a key signature to the following time signature.

- **Key to barline distance**: To be added.

- **System header distance**: Sets the distance from a clef or key signature at the beginning of a system to the first note or rest.

- **System header with time signature distance**: Sets the distance from a time signature at the beginning of a system to the first note or rest.

- **Multimeasure rest margin**: Sets the distance between a multi-measure rest and the barlines on either side.

- **Staff line thickness**: Sets the thickness of the lines of the staff, which allows you to make the staff thicker and darker, if you need greater visibility on your printouts.

  **Note**: Changes to an individual measure's Stretch (using Format → Stretch → Increase/Decrease Layout Stretch) are calculated after, and proportional to, the global Spacing setting.

**Page settings**

**Page settings** allows you to adjust the overall dimensions of your score such as page size, page margins, and scaling. It is one of the main layout tools in MuseScore—along with the options available from Format → Style…

To open the **Page settings** dialog: from the menu, select Format → Page Settings....
**Page size**

Here you can select the paper format, either by standard name (e.g., Letter or A4), or by specifying the height and width in either mm or inches (use the radio buttons to choose which unit of measurement to use). The initial default page size depends on your localization—in the United States, Letter size paper is standard.

You can also choose to format your music in **Landscape** or **Portrait** orientation using the radio buttons. You can optionally use **Two sided** layout (i.e., book format, with mirror left and right margins for even and odd pages—see below).

**Odd/Even Page Margins**

The **Even Page Margins** and **Odd Page Margins** settings allow you to define the printable area of your pages. Aside from changing the margins around the music on the page, other settings, such as the positions of headers and footers, are calculated relative to the margins defined here.

If the "Two sided" checkbox under "Page Size" is selected, you can set margins differently for mirroring odd and even pages. Otherwise, only one set of margins can be modified, but will apply to all pages.

To display page margins in your score on screen (though not in print), go to **View** → **Show Page Margins**.

**Scaling**

The **Scaling** property allows you to increase or decrease the size of your score.

In MuseScore, the sizes of score elements, such as note heads, note stems, accidentals, clefs etc., are defined in terms of a unit of measurement called a **staff space**—abbreviated to **sp**, (see Glossary). As you change the “Staff space” setting, *all* score elements follow suit and thus correct proportions are maintained. The exception is **Text** in which you can set an *absolute* value, independent of “Scaling.”

**Note**: Changing the “Scaling” does not always change the number of systems per page, because system distance can vary between limits set under "Min system distance" and "Max system distance" (see **Format** → **Style...** → **Page**).

**Unit**

Here you can choose to display the values in Inches or millimeters.

**First page number**

Sets the number of the first page of the particular score. Page numbers below 1 won't get printed—e.g., setting the first page number to -1 would result in the first and second page showing no page number, and page number 1 appearing on the third page.

**Apply to all Parts**
The Apply to all Parts button is available when modifying apart, rather than the main score (see Part extraction). If you change the page settings of one part and want the rest of the parts to have the same settings, this button will apply the change to all parts in one go.

Breaks and spacers

The Breaks & Spacers palette contains the following non-printing symbols:

The first three symbols are called breaks; the vertical lines are known as spacers.

Breaks

A break can be applied to either a measure or a frame. There are three types:

- **System break**: Forces the next part of the score to start in a new system.
- **Page break**: Forces the next part of the score to start on a new page.
- **Section break**: Forces the next part of the score to start in a new system and starts a new section (see below). It can be combined with a page break if required.

Notes: (1) Break symbols are visible on the screen, but do not appear on printouts. (2) To add (or remove) system breaks over all or part of the score, see Add/Remove System breaks. (3) To split a measure, see Measure operations: Split and join.

Add a break to a measure

Breaks can be added using either (1) a keyboard shortcut; or (2) a break symbol from a palette.

Using a keyboard shortcut

To add a **System break** or a **Page break** only:

1. Select any one of the following:
   - Barline;
   - Measure;
   - Notehead;
   - Text element associated with a staff (e.g. lyric syllable, chord symbol, staff text etc.);
   - Range of measures (if you choose this option, a break will be applied before and after the selection);
2. Choose one of the following options:
   - **System break**: Press `↵` (toggle).
   - **Page break**: Press `Ctrl+↵` (Mac: `Cmd+↵`) (toggle).

Using a palette break symbol

Any break can be added from a workspace palette:

1. Select any one of the following:
   - Barline;
   - Measure;
   - Notehead;
   - Text element associated with a staff (e.g. lyric syllable, chord symbol, staff text etc.);
   - Range of measures (if you choose this option, a break will be applied before and after the selection);
2. Click a break symbol in a palette (double-click in versions prior to 3.4). Repeat to toggle off.
   - Alternatively, drag any break symbol from a palette onto a measure.

Add a break to a frame

To add a break to a frame, use one of the following options:

- Drag a break from a palette onto a frame.
- Select a frame then click a palette break symbol (double-click in versions prior to 3.4).

Delete breaks

Use one of the following options:

- Select one or more breaks and press `Delete`.
See also: Add / Remove System breaks

Move a break

Although breaks are not visible on printed output, you can reposition one, if required, by entering edit mode on it and using the keyboard arrow buttons (see Adjust position of text objects).

Section break

A Section break, as the name suggests, is used to create separate sections within a score. Like a system break, it forces the next measure or frame to begin a new system, and can also be used in association with a page break if required. A section break could be used, for example, to divide a piece into separate movements.

Each section can have its own measure numbering independent of the rest of the score. By default, the first measure of a section is numbered "1" (see image below), though like the first measure of the score itself, the number is not displayed unless configured in the measure properties dialog. The same dialog can be used to change the numbering according to your preference.

If you change Time signature or Key signature at the beginning of the new section, there will be no courtesy signature at the end of the previous section. See example below:

![Example image of section break](image)

When you play back the score, the program adds a short pause between each section. In addition, the first end repeat barline in a section always sends the playback cursor to the beginning of the section, so a start repeat barline is optional.

The following properties can be adjusted in the Inspector after selecting the section break:

- Pause: Length of pause at end of section.
- Start new section with long instrument names (checkbox).
- Start new section with measure number one (checkbox).

Prior to version 3.4, the same properties are accessed by right-clicking the break and selecting Section Break Properties.

Spacers

There are three types of spacers:

- **Staff spacer up**: An up-pointing arrow. For adding space above a staff.
- **Staff spacer down**: A down-pointing arrow. For adding space below a staff.
- **Staff spacer fixed down**: Looks like a capital letter "I." For fixing the distance between two staves (useful to override style or autoplace settings in one spot only). Negative values are possible.

Note: Spacers cannot be applied to a frame.

Add a spacer

Use either of the following options:

- Select a measure, then click a palette spacer symbol (double-click in versions prior to 3.4).
- Drag a spacer symbol from a palette onto a measure.

Spacer symbols are visible on the screen, but do not appear on printouts.

Note: Spacers are designed for local adjustments only. If you wish to adjust the space between staves across the whole score, use the settings in Format → Style... → Page instead.

Adjust a spacer

To adjust the height of a spacer, choose one of these options:

- Click the spacer and drag the blue end-handle up and down (double-click in versions prior to 3.4).
- Click the spacer and use the ↑ keys and/or Ctrl+↑ to move the end-handle up and down (double-click in versions prior to 3.4).
- Click on the spacer and adjust the height property in the Inspector.
Delete a spacer

- Click on the spacer and press the Del key.

See also

- Add/Remove System breaks

Frames

A Frame is a rectangular container for empty space, text or pictures in the score. It can be one of three types:

- **Horizontal**: Used to create a break in a particular system. Can contain one or more text objects and/or images.
- **Vertical**: Inserted above a system or appended to the last system. Can contain one or more text objects and/or images.
- **Text**: Inserted above a system or appended to the last system. Can contain one text object only.

Horizontal frame

A horizontal frame is used to create a break in a system. For example, you can:

- Create a coda, with an adjustable gap separating it from the rest of the score (as in the example below).

![Example of horizontal frame]

- Create an offset at the beginning of the score, where there is no staff name to perform the same function.
- Create an adjustable right margin at the end of a system.
- Create space for some text or image(s).
- Create a space between a 'historical incipit' and the beginning of the modern edition.

Insert/append horizontal frame

See Create a Frame (below).

Adjust width of horizontal frame

Use one of the following methods:

- Click (double-click prior to version 3.4) the frame and drag the handle to the right or left.
- Select the frame and adjust "Width" in the Inspector.

Add text or image to horizontal frame

- **To add text**: Right-click on the frame and select Add → Text.
- **To add an image**: Right-click on the frame and select Add → Picture.

Vertical frame

A vertical frame can be inserted above a system or appended to the last system. It can contain one or more text objects and/or images. The height is adjustable and the width equals the system width.

It can be used, for example, to:

- Create an area at the head of a score for Title/Subtitle/Composer/Lyricist text etc. (see below).
- Add single- or multi-column lyric text (at the end of a score).
- Create a title page.
- Create subtitles and other annotations between systems.

Insert/append vertical frame

See Create a Frame (below).

Adjust height of vertical frame
Use one of the following methods:

- Click (double-click prior to version 3.4) the frame and drag the handle up or down.
- Select the frame and adjust "Height" in the Inspector.

Edit vertical frame properties

Selecting the frame allows you to adjust various parameters in the Inspector:

![Inspector](image)

**Top Gap**: Adjusts distance between frame and element above.

**Bottom Gap**: Adjusts distance between frame and element below.

**Height**: Adjusts height of the frame.

**Left Margin**: Moves left-aligned text objects to the right.

**Right Margin**: Moves right-aligned text objects to the left.

**Top Margin**: Moves top-aligned text objects downwards (see also Format → Style... → Page).

**Bottom Margin**: Moves bottom-aligned text objects upwards (see also Format → Style... → Page).

Add text or image to vertical frame

- **To add text**: Right-click on the frame, select Add, and choose one of the text options.
- **To add an image**: Right-click on the frame and select Add → Picture.

You can create as many objects as you like within a frame. Their positions can be adjusted independently by dragging or, more accurately, by altering the offset values in the Inspector. To format text objects, see Text editing and Text styles and properties.

Insert horizontal frame in vertical frame

- Right-click on the frame and select Add → Insert Horizontal Frame.

The horizontal frame is automatically left-aligned and fills the entire vertical frame. To right-align it:

1. Reduce the width of the horizontal frame.
2. Deselect the frame then drag it to the right. To restore left-alignment, drag the frame to the left.

"Title" frame

A vertical frame is automatically created at the beginning of a score, showing the title, subtitle, composer, lyricist etc., when you fill in the information fields provided on page 1 of the New Score Wizard.

If the score does not have a vertical frame at the beginning, you can create one as follows:

1. From the menu, select Add → Text → Title/Subtitle/Composer/Lyricist;
2. Type the desired text;
3. Press Esc, or click on an empty space, to exit.

Text frame

A **Text frame** looks like a vertical frame, but is specialized for text input: one text object is allowed per frame. The height automatically expands to fit the content and there is no height adjustment handle.

A text frame can be used, for example, to:

- Create lyric text at the end of a score.
- Create subtitles and other annotations between systems.
Insert/ append text frame

See Create a Frame (below).

Edit text frame properties

Selecting the frame allows you to adjust various parameters in the Inspector:

**Top Gap:** Adjusts distance between frame and element above.
**Bottom Gap:** Adjusts distance between frame and element below.
**Height:** Not applicable to text frames.
**Left Margin:** Moves left-aligned text objects to the right.
**Right Margin:** Moves right-aligned text objects to the left.
**Top Margin:** Moves top-aligned text objects downwards.
**Bottom Margin:** Moves bottom-aligned text upwards.

Create a frame

Insert a frame into the score

From the menu:
1. **Select** a measure;
2. From the menu select Add → Frames → Insert Horizontal/Vertical/Text Frame.

From a measure:
1. Right click on a measure;
2. **Select** Add → Insert Horizontal/Vertical/Text Frame.

From a palette:

See Apply symbols from a palette.

Append a frame to the score

From the menu select Add → Frames → Append Horizontal/Vertical/Text Frame.

Delete a frame

Use one of the following:
1. Select the frame boundary and press **Del**.
2. Select the frame boundary, then right-click on the frame and select **Delete**.

Apply a break

System, page or section breaks can be applied to frames as well as measures. Use one of two methods:
1. Select a frame and click (double-click prior to version 3.4) a palette break symbol (for example, in the Breaks & Spacers palette).
2. Drag a break symbol from a palette onto a frame.

See also

- **Text Properties**: to put a visual frame (border) around text.
- **Insert measures**: to insert measures before a frame.

External links

- [How to add a block of text to a score](#)
- [Page Formatting in MuseScore 1.1 - 1. Frames, Text & Line Breaks](#) [video]

Images

You can use **Images** to illustrate scores, or to add symbols that are not included in the standard palettes. MuseScore supports the following formats:

- PNG (*.png)
- JPEG (*.jpg and *.jpeg)
- SVG (*.svg) (MuseScore currently does not support SVG shading, blurring, clipping or masking.)
Add image

Use one of the following options:

- Drag-and-drop an image file (from outside MuseScore) either into a vertical or horizontal frame, or onto a note or rest in the score.
- Right-click on a frame, select Add → Picture, then pick an image from the file selector.

Cut/copy and paste image

1. Click on an image in the score.
2. Apply any of the standard copy/cut commands.
3. Click on a note, rest or frame.
4. Apply any of the standard paste commands.

Modify image

To modify the width/height of an image, double-click it and drag any of the handles. If you want to adjust width or height separately, untick “Lock aspect ratio” first in the Inspector.

You can adjust the position of an image by simply dragging it.

See also

- Image capture
- Custom palettes

External links

- How to create an ossia with image capture
- How to create an ossia with another staff

Image capture

MuseScore’s image capture feature allows you to save a snapshot of any part of the score window. PNG, PDF and SVG formats are supported.

Save a snapshot

1. Click on the Toggle image capture button.
2. Press Shift + drag, to create a new selection rectangle.
3. Fine tune the rectangle position, if required, by dragging it and/or changing the “Position” values in the “Lasso” section of the Inspector.
4. Fine tune the rectangle area, if required, by dragging the handles, and/or changing the “Size” values in the Inspector.
5. Right-click on the selection rectangle to open the Image Capture menu. Select the desired option:
   - Save As (Print Mode). This saves an image of the selection area as it would look if printed, e.g.
   - Save as (Screenshot Mode). This saves a selection of the actual screen, including any line break symbols, invisible elements etc., e.g.
Image capture menu

Right-clicking on the selection rectangle opens the **Image Capture** menu (Mac: `⌘` + click, or 2-finger-tap):

- **Copy**: Choose this to copy an image before pasting it in the same or another MuseScore file.
- **Copy with Link to Score**: Choose this to copy an image including a link to the MuseScore file. When pasting this into a program that supports this, you can click on the image to open the MuseScore file.
- **Resolution**: Set the resolution, and hence the size of the saved or copied image. Try 100 dpi to start with, if you are unsure.
- **Transparent background**: Turn image transparency on or off.
- **Auto re-size to page**: Adjusts the selection rectangle to fit the page.
- **Resize to A/B/C/D**: Choose a customized selection rectangle (as set below).
- **Set Standard Size**: Resize the selection rectangle, then choose "Set size A/B/C/D" to store it.

See also

- **Image**

External links

- [Create an ossia with image capture](#)
- [How to create an ossia with another staff](#)

Align elements

While dragging an element:

- To constrain movement to the **horizontal** only: Click and hold on the element, press `Ctrl`, then drag the element left or right.
- To constrain movement to the **vertical** only: Click and hold on the element, press `Shift`, then drag the element up or down.

Snap to grid

**Snap to grid** is a feature which allows you to **drag** an element in precise steps—useful for exact positioning.

To enable snap to grid, select an element and click one or both of the snap to grid buttons, located to the right of the X (horizontal) and Y (vertical) offset fields in the **Inspector**. You can then **drag** the element in steps equal to the **grid spacing**. The default value is 0.5 sp.

To change the **grid spacing**:

1. Right-click on any of the snap to grid buttons in the Inspector, and select **Configure Grid**.
2. Set values for the horizontal and vertical grid spacing as required. Note that this is a fractional setting.

Advanced topics
Accessibility

Introduction

This document is written for blind and visually impaired users of MuseScore 3. It is not intended to provide a full description of all of the features of MuseScore; you should read this in conjunction with the regular MuseScore documentation.

MuseScore comes with support for the free and open source NVDA screen reader for Windows. You can also install scripts to enable support for JAWS. Soon we will support Orca on Linux, and eventually we hope to support other screen readers such as VoiceOver and Narrator. Currently, unsupported screen readers will usually read menus and dialogs, but reading the score note by note currently requires one of the supported screen readers.

Beginning with MuseScore 3.3, most of the features of MuseScore are fully accessible, it is viable both as a score reader and editor. Previous versions were more limited with respect to editing.

Initial setup

When you run MuseScore for the first time, you will be asked some questions on startup. We recommend you accept the defaults, but answer "no" to the question about showing tours, since these unfortunately are not yet accessible.

When MuseScore starts, the first thing you normally see is the Start Center window. This shows you a list of recent scores that you can access via Shift+Tab and then using the left and right cursor keys. You may find it easier to open scores directly from the File menu, however so you can press Esc to close the Start Center if you prefer. In fact you may want to permanently disable it. After closing the Start Center, open the Edit menu (Alt+E), choose Preferences, and in the General tab, uncheck Show Start Center, then close the Preferences window.

MuseScore includes keyboard shortcuts for many of its commands, and others that do not have shortcuts defined by default can be customized later, in Edit, Preferences, Shortcuts.

Finding your way around

The user interface in MuseScore works much like other notation programs or other document-oriented programs in general. It has a single main document window within which you can work with a score. MuseScore supports multiple document tabs within this window. It also supports a split-screen view to let you work with two documents at once, and you can have multiple tabs in each window.

In addition to the score window, MuseScore has a menu bar that you can access via the shortcuts for the individual menus:

- File: Alt+F
- Edit: Alt+E
- View: Alt+V
- Add: Alt+A
- Format: Alt+O
- Tools: Alt+T
- Plugins: Alt+P
- Help: Alt+H

Hint: once you have opened a menu, it may take several presses of the Up or Down keys before everything is read properly. Also, if at any point the screenreader stops responding, a useful trick to kickstart it again is to press Alt to move focus to the menu bar, then Esc to return to the score. Sometimes switching to another application then back can help as well.

In addition to the menu bar, there are also a number of toolbars, palettes, and sub-windows within MuseScore, and you can cycle through the controls in these using Tab (or Shift+Tab to move backwards through this same cycle). When you first start MuseScore, or load a score, focus should be in the main score window.

If nothing is selected (press Esc to clear any selection), pressing Tab takes you to a toolbar containing a series of buttons for operations like New, Open, Play, and so forth. Tab will skip any buttons that aren’t currently active. The names and shortcuts (where applicable) for these buttons should be read by your screen reader.

Once you have cycled through the buttons on the toolbar, the next window Tab will visit is the Palettes. This is used to add various elements to a score (dynamics, articulations, and so forth).

If an element is selected in the score, the first window visited by Tab is the Inspector, which is used for making various manual adjustments in your score. Many of these features are based on the visual appearance of the score (although a few relate to playback).

If you have opened one of the additional optional windows, such as the Selection Filter, the Tab key will also visit these.
You can close windows you do not need by going to the View menu and making sure none of the first set of checkboxes is selected (the windows that appear before the Zoom settings). By default, only the Palettes and Inspector should be selected. See Initial Setup for instructions for disabling the Start Center. F9 can be used to toggle the Palettes while F8 will toggle the Inspector.

To return focus to the score window after visiting the toolbar, or a subwindow, press Esc. If something was selected before visiting the other window, the selection is left intact, but pressing Esc once focus is in the score window clears the selection. The selection is automatically restored when you commence navigation using the accessibility commands described below.

The score window

When you first start MuseScore 3 an empty example score is loaded by default. If you wish to experiment with editing features, this would be a good place to begin. Otherwise, you will probably want to start by loading a score. MuseScore uses the standard shortcuts to access system commands like Ctrl+O (Mac: Cmd+O) to open a file, Ctrl+S (Mac: Cmd+S) to save, Ctrl+W (Mac: Cmd+W) to close, etc.

If you press Ctrl+O (Mac: Cmd+O) to load a score, you are presented with a fairly standard file dialog. MuseScore can open scores in its own format (MSCZ or MSCX) as well as import scores in the standard MusicXML format, in MIDI format, or from a few other programs such as Guitar Pro, Capella, and Band-in-a-Box. Once you have loaded a score, it is displayed in a new tab within the score window. You can move between the tabs in the score window using Ctrl+Tab (does not apply for Mac). Hint: if the name of the score in the current tab is not read, ask your screen reader to read the title bar.

To read the score note by note, see below, but there are a few other interesting things you can do with a loaded score. You can press Space to have MuseScore play the score for you. You can use File / Export to convert to another format, including PDF, PNG, WAV, MP3, MIDI, MusicXML, etc. And of course, you can print it via File / Print or Ctrl+P (Mac: Cmd+P).

If a score contains multiple instruments, it may already have linked parts generated. Linked parts are presented as part tabs within score tabs, but currently, there is no way to navigate these part tabs using the keyboard. The parts would not normally contain information different from the score; they would just be displayed differently (each part on its own page). If a score does not already have parts generated, you can do so through File / Parts, and that dialog is accessible. If you wish to print the parts, you can work around the inability of accessing part tabs individually by using the File / Export Parts dialog, which automatically exports PDF's (or other formats) for all parts in one step.

Score reading

When you first load a score, the score window has the keyboard focus, but there will be nothing selected. The first step to reading a score is to select something, and the most natural place to begin is with the first element of the score. After a score is loaded, Alt+Right (Mac: Alt+Right) will select the literal first element, which is likely the title; Ctrl+Home (Mac: Cmd+Home) will select the first "musical" element (usually a clef or an initial barline).

As you navigate between elements, your screen reader should give the name of the selected element. You will hear it read the name of the element (for example, "Treble clef") and also give position information (for example, "Measure 1; Beat 1; Staff 1; Violin"). The amount of information read is optimized to not repeat information that has not changed. Pressing Shift currently interrupts the reading, which might also be useful.

Most navigation in MuseScore is centered around notes and rests only—it will skip clefs, key signatures, time signatures, barlines, and other elements. So if you just use the standard Right and Left keys to move through your score, you will only hear about notes and rests (and the elements attached to them). However, there are two special accessibility commands that you will find useful to gain a more complete summarization of the score:

- Next element: Alt+Right (Mac: Alt+Right)
- Previous element: Alt+Left (Mac: Alt+Left)

These commands include clefs and other elements that the other navigation commands skip, and also navigate through all voices within the current staff, whereas other navigation commands such as Right and Left only navigate through the currently selected voice until you explicitly change voices. For instance, if you are on a quarter note on beat 1 of measure 1, and there are two voices in that measure, then pressing Right will move on to the next note of voice 1—which will be on beat 2—whereas pressing Alt+Right (Mac: Alt+Right) will stay on beat 1 but move to the note on voice 2. Only once you have moved through all notes on the current beat on the current staff will the shortcut move you on to the next beat. The intent is that this shortcut should be useful for navigating through a score if you don't already know what the contents are.

When you navigate to an element, your screen reader should read information about it. For notes and rests, it will also read information about elements attached to them, such as lyrics, articulations, chord symbols, etc. The accessibility commands will also navigate through those elements individually.

One important note: Up and Down by themselves, with Shift, or with Ctrl / Cmd are not useful shortcuts for navigation! Instead, they change the pitch of the currently selected note or notes. Be careful not to inadvertently edit a score you are trying to read. Up and Down should only be used with Alt if your intent is navigation only. See the list of navigation shortcuts below.

If you should lose track of your place in the score - or if you lose the selection completely - press Shift+L ("location") to get the current location.
Moving forwards or backwards in time

The following shortcuts are useful for moving “horizontally” through a score:

- Next element: Alt+Right
- Previous element: Alt+Left
- Next chord or rest: Right
- Previous chord or rest: Left
- Next measure: Ctrl+Right
- Previous measure: Ctrl+Left
- Go to measure: Ctrl+F
- First element: Ctrl+Home
- Last element: Ctrl+End

Moving between notes at a given point in time

The following shortcuts are useful for moving “vertically” through a score:

- Next element: Alt+Right
- Previous element: Alt+Left
- Next higher note in voice, previous voice, or staff above: Alt+Up
- Next lower note in voice, next voice, or staff below: Alt+Down
- Top note in chord: Ctrl+Alt+Up
- Bottom note in chord: Ctrl+Alt+Down

The Alt+Up and Alt+Down commands are similar to the Alt+Right and Alt+Left commands in that they are designed to help you discover the content of a score. You do not need to know how many notes are in a chord, how many voices are in a staff, or how many staves are in a score in order to move vertically through the score using these commands.

Filtering score reading

Excluding certain elements like lyrics, or chord names while reading the score is possible by using the Selection filter (F6). Uncheck those elements you don’t want to read. However, this feature may not currently be implemented.

Score playback

The Space bar serves both to start and stop playback. Playback will start with the currently selected note if one is selected; where playback was last stopped if no note is selected; or at the beginning of the score on first playback.

MuseScore supports looped playback so you can repeat a section of a piece for practice purposes. To set the “in” and “out” points for the loop playback via the Play Panel (F11):

1. First select the note in the score window where the loop should start;
2. Go to the Play Panel and press the Set loop In position toggle button;
3. Back to the score window, navigate to the note where you want the loop to end;
4. Switch again to Play Panel, and press the Set loop Out position toggle button;
5. To enable or disable the loop, press the Loop Playback toggle button.

You can also control the loop playback and control other playback parameters, such as overriding the basic tempo of a score, using the View / Play Panel (F11).

Score creation and editing

While some advanced score editing techniques require visual inspection of the score, and a small number of commands may require the mouse, as of MuseScore 3.3 most score editing features are fully accessible.

You can enter music into the default empty score (a score with one staff, using a piano sound), or edit an existing score that you have opened already, or you can create a new score with the set of instruments you want.

Creating a new score

To create a new score, use File, New or Ctrl+N. A wizard then walks you through the score creation process.

The first screen of the wizard has fields to enter the title, composer, and other information. The second allows you to select a template (predefined scores for common ensembles like choral SATB or jazz big band) or to select instruments. The third allows you to select an initial key signature and tempo. Sometimes this screen gets skipped, so if this happens, press the Back button to go back. To select a key, use Up and Down. The key signature control does not work well with some screenreaders, but if you give the “read current line” command (e.g., NVDA+L), it may read the currently-selected key. The next and final screen of the wizard allows you to select an initial time signature, pickup (anacrusis), and the number of measures to start with.

Once you have a score, you can begin editing it.
Note input

To enter notes, you need to be in note input mode. First, navigate to the measure in which you would like to enter notes, then press N. Almost everything about note input is designed to be keyboard accessible, and the standard documentation should be good to help you through the process. Bear in mind that MuseScore can either be in note input or normal mode, and it won’t always be clear which mode of these you are in. When in doubt, press Esc. If you were in note input mode, this will take you out. If you were in normal mode, you will stay there, although you will also lose your selection.

The basic process of note input is to first select a duration (for example, using shortcuts 4-5-6 for eighth, quarter, half), then enter a note by typing its letter name. Once a duration is selected you can enter multiple notes of the same duration. Press 0 to enter a rest.

The Up and Down keys raise or lower the pitch by a half step, adding or removing accidentals as necessary. To change enharmonic spelling of a note, press J.

To enter a tie, select the duration of the tied note then press+. To create triplets, select the total duration for the triplet, then press Ctrl+3 (similarly for quadruplets and other tuplets). To enter music in multiple voices on a single staff, pressing Ctrl+Alt plus a number from 1 to 4 will switch to that voice (keep in mind, the first voice for each staff is always voice 1).

There is much more to note input in MuseScore. See for the section on Note Input in the Handbook.

Selection

MuseScore supports the usual keyboard shortcuts for selection. Navigating is the same as selecting for single elements. To select a range of elements, navigate to the first, press and hold Shift, then navigate to the second. Ctrl+A will select the entire score.

Palettes

As mentioned previously, many symbols other than notes are entered from the palettes window. The basic use model is, first select the element or elements in the score you want to apply the palette item to, then apply the palette element. There are a few different ways to select the palette element.

The simplest method to use at first is to simply browse the palettes window by keyboard. To reach the palettes window, press Shift+Tab. The screenreader may not specifically tell you that you are in the palettes window, but you will discover that you are as you navigate. Depending on whether you have used the palettes before, focus may be where you left off, or at the top. Press Tab a few times to get to the first palette within the window (Clefs). You can browse the list of palettes using the Up and Down cursor keys. The Right cursor key opens a palette, and then all four cursor keys can be used to navigate through the elements (they are arranged in a table). You can also use Tab to navigate the palette names and contents.

Once you have found a palette item you want to apply, press Enter to apply it to the currently-selected score elements and return focus to the score. The next time you press Shift+Tab to return to the palettes, the last-used palette item will still be selected, so Enter will apply it again. The screenreader may stop responding after applying a palette item, even though focus has returned to the score, but the trick of pressing Alt followed by Esc should get it working again.

You can also use the palette search facility to quickly find a palette item. The search box is one of the first elements at the top of the palette, so you can navigate to it, or you can define a shortcut (Edit, Preferences, Shortcuts) for the “Palette search” command, which will subsequently take you directly to the search box. Once you are in the box, type the first few characters of a search term, and only palette items matching that search will shown. You can then navigate to the search results and find the element you want. The Down cursor will take you directly to the first search result, then you can use Right after that. However, on some systems MuseScore may crash when using the palette search function with a screen reader enabled.

Another way to reach the palettes window is with the F9 shortcut, which toggles the palettes window on and off. By default, the palettes window is open, so pressing F9 will close it, but then pressing it again opens the window and puts the cursor in the search box.

There is one other useful technique for palette accessibility, and that is the “Apply current palette element” command (for which you can define a shortcut). If you are in the score, this will apply the last-used palette element automatically (the equivalent of Shift+Tab followed by Enter).

Menus and Shortcuts

Some elements can be added or edited via menu commands or keyboard shortcuts. The Edit menu has standard copy and paste commands (and the usual shortcuts work too). The Add menu has commands to add notes, tuplets, measures, frames, text, and some lines. The Format menu has commands relating mostly to the visual appearance of the score (e.g., page and staff size, position and size of symbols, fonts used for text), which can be extremely useful in producing large print a.k.a. “modified stave notation” scores (see below). The Tools menu has a number of other useful commands, including ones to remove measures or other selected ranges, to transpose a selection, to join and split measures, and more. Any of these commands have shortcuts defined by default that should be read by a screenreader. You can define custom shortcuts for most of the rest in Edit, Preferences, Shortcuts.
There are also shortcuts for a number of palette items, and the possibility to define others (although many palette items currently do not support this). Some useful shortcuts to remember include:

- Ctrl+T: staff text
- Alt+Shift+T: tempo
- Ctrl+L: lyrics
- Ctrl+K: chord symbol
- Ctrl+M: rehearsal mark
- S: slur
- Shift+S: staccato
- Shift+V: accent
- Shift+N: tenuto
- Shift+O: marcato
-Slash: grace note
-less than: crescendo
-greater than: diminuendo

**Customization**

You can customize the keyboard shortcuts by opening the Edit menu, selecting Preferences, then navigating to the Shortcuts tab. Once there, Tab will take you to the list of shortcuts, and you can navigate the list directly with the Up and Down cursor keys, but it is a very long list. You can instead hit Tab a few more times to reach the Search box, then type the first few characters of the command to filter the list, then navigate back to the list.

Once you have found the command you wish to customize, press Enter. You can then press the key combination you wish to be the shortcut. It can be a single key, a key with Shift, Ctrl, and/or other modifiers, or even a sequence or two or more keys pressed in succession. After entering the shortcut you wish, press Tab to get to the Add or Replace button (Tab is the only key that won't be interpreted as part of a shortcut sequence). If you reach Cancel without ever seeing Add or Replace, it means the shortcut you choose conflicts with another. Navigate back to the where you typed the shortcut and it will tell you the name of the command it conflicts with. Hit Tab to get to the Clear button to clear it, then try again with a different shortcut.

At some point, we may provide a set of special accessibility-optimized shortcuts. There is already a facility in the shortcut dialog to save and load shortcut definitions, so it is possible to share shortcut definitions with other users.

**External links**

- [MuseScore Accessibility Demo (YouTube)](https://www.youtube.com/watch?v=dQw4w9WgXcQ)
- [Creating a New Score in MuseScore with NVDA](https://www.nvaccess.org/docs/4的女人音楽用.pdf)
- [Inputting notes in MuseScore with NVDA](https://www.nvaccess.org/docs/4的女人音楽用.pdf)
- [Creating Modified Stave Notation in MuseScore](https://www.nvaccess.org/docs/4的女人音楽用.pdf)

**Albums**

The Album feature is has been disabled for the initial 3.0 release. It will come back in a later patch release

The Album Manager allows you to prepare a list of multiple scores and save the list as an album file ("*.album"), print all the scores as one long print job with consistent page numbers, or even join the scores into a single new MSCZ score. This is ideal for preparing an exercise book or combining multiple movements of an orchestration.

To open the Album Manager, go to File → Album...

1. To create a new album, click the New button. Fill in a title in the "Album Name:" box at the top.
2. To add scores to the album, click Add Score. A file selection dialog will appear and let you choose one or multiple scores from your file system. Click OK.
3. The scores you add will appear in a list in the Album Manager. You can rearrange their order by selecting a score and clicking the Up or Down button.

Load album

If you have previously created an album, you can open it through the Album Manager by clicking the Load button. A file selection dialog will appear to let you load the .album file from your file system.

Print album

To print an album as if it were a single document, click Print Album. The scores loaded into the Album Manager are printed in the order they are listed in with the correct page numbers, ignoring the page number offset values in Layout → Page Settings → First page number for all but the first score. As the album is printed in one print job, double-sided printing (duplex printing) also works as expected.

Join scores

To combine multiple scores into a single .mscz file, click Join Scores. The scores are combined in the selected order into one single score. If not already present, line- and section breaks are added to the last measure of frame of each score in the combined file. All style settings are taken from the first score, different style settings from subsequent score are ignored.

All the scores should have the same number of parts and staves for this to work correctly, ideally with the same instruments in the same order. If the scores have the same total number of instruments but not the same ones, or not in the same order, then the instrument names from the first score will overwrite ones from subsequent scores. If some of the scores have fewer instruments than the first score, then empty staves will be created for those sections. Any part or staff that is not present in the first score will be lost in the joined score.

Save album

Upon clicking the Close button, you will be prompted to save your album as a .album file. This file is not the same as a joined score: it simply consists of the list of scores. Album files can be loaded into the Album Manager as described above.

Automatic placement

MuseScore's automatic placement (AP) feature ensures that, in most cases, elements are correctly spaced and do not collide or overlap with each other.

Note: When you create an element, AP is automatically enabled, but can be turned off if required (see Disable automatic placement).

Default position

A newly-created element, such as staff text or fingering, assumes a default position on the staff specified by "positional" properties contained in the Style menu. These "positional" properties may include things such as:

- **Placement**: Whether the element appears above or below the staff.
- **Offset**: For elements with no "Placement above/below" properties, this specifies the default position. See Offset X/Y.
- **Autoplacement min distance**: Minimum distance from other elements when autoplace is enabled.

For details of the settings available for each element type, see Layout and formatting: Style.

Change the default placement of an element

Use one of the following methods:

- From the menu, select Format → Style; choose an element type and then adjust the placement/position settings.
- Select a relevant element in the score and change the placement/position settings in the Inspector; then press the Set as style” button (s) to update the Style settings.

Manual adjustments

Adjust position of element

Use one of the following methods:

- Select the element and adjust the X and Y offsets in the Inspector (see X and Y offsets).
• **Move the element using the arrow buttons.** Change to **edit mode** first, if necessary.

• **Drag and drop the element using the mouse.** Use this method in preference to the above, if you want to move an element across another one (e.g. fingering across a slur). Once located on the other side you can use the X/Y offsets in the Inspector, or the keyboard arrow keys to fine tune the position.

**Place element above/below staff**

Elements with a “Placement” property available in the **Inspector** can be easily moved from above the staff to below it, and vice versa:

1. Select one or more elements.
2. Use one of the following methods:
   - Change the “Placement” setting in the Inspector.
   - Press X to toggle between above/below.

**Note:** When automatic placement is enabled for an element, you cannot position it in a way that causes a collision with other elements.

**Disable automatic placement**

- Select the element and uncheck the “Automatic placement” box in the **Inspector**.

The element reverts to its default position. It can be repositioned as desired and is no longer avoided when placing other elements.

**Stacking order**

To change the value for **Stacking order**:

- Select the element and change the “Stacking order” value in the **Inspector**.

In cases where elements are allowed to overlap, **Stacking order** controls the order in which they are placed on top of each other. The element with the lower value will be placed behind.

**Cross-staff notation**

In piano scores, it is common to write a musical phrase extending across both staves—bass and treble. This can be entered in MuseScore as follows:

1. Enter the notation in one staff to begin with. e.g.

   ![Example notation](image)

2. Select a note and press Ctrl+Shift + ↓/↑ (Mac: Cmd+Shift + ↓/↑). This moves all the notes in that voice down/up to the other staff. e.g.

   ![Example notation](image)

   **Note:** If you only want to move certain notes in a chord you need to ensure that they are in a separate voice.

3. To adjust the beam, double-click it to show the handles. Use the **keyboard arrows** or drag the handles to change the beam angle and height:

   ![Example notation](image)
See also

- Barlines: How to extend barlines over multiple staves.
- Beams: How to adjust beam angle and height.

External links

- How to span a chord or stem over two staves (MuseScore “Howto”)

Early music features

MuseScore offers several specialized functions to create engravings of early music (particularly medieval and renaissance) akin to commercial editions from the 20th century onwards.

Unbarred (or unmetered) notation

In MuseScore, notes lasting longer than the duration of a measure are normally tied across barlines. However MuseScore has a special feature which allows it to display the note values intact, without splitting and tying them in this way. This enables you to notate music which is unbarred (i.e. not divided into measures), such as that of the renaissance:

1. From the menu bar, select Format → Style... → Score.
2. Tick the box labelled “Display note values across measure boundaries ... .”
3. Click “OK” or “Apply.” The existing score is immediately updated.

Example

1. The example below shows an excerpt from the original score of “De Profundis Clamavi” for 4 voices by Nicolas Champion:

2. The same excerpt displayed in MuseScore:

3. And after activating “Display note values across measure boundaries ... .”

4. To get rid of the barlines, just untick the “Show barlines” box in the Staff / Part properties dialog. See also Mensurstrich (below).

Note: The feature is still in development and may contain bugs. The longest supported note value is the longa (a dotted longa is still broken up and tied over).

Mensurstrich

Since a complete lack of barlines could make performing the music more difficult for current musicians, many modern engravers settled on a compromise called Mensurstrich, where barlines are drawn between, but not across, staves.
To place barlines between staves:

1. In the lowest staff (usually the bottom staff of a system) where the proposed Mensurstriche is required, uncheck "Show barlines" in the Staff / Part Properties dialog;
2. In the staff above where you want the Mensurstriche, right-click on one barline and choose Select → All Similar Elements (or select a set of barlines, one above the other, with Select → All Similar Elements in Range);
3. In the Barline section of the Inspector, tick the "Span to next staff" option;
4. In the Barline section of the Inspector, adjust the "Span from" value so that the top of the barlines meet the bottom line of the staff;

Note: It is important to work from the lowest staff upwards.

Ambitus

Before there was the concept of an absolute pitch, performers were required to transpose vocal music to a singable range for their ensemble "on the fly." To aid them, an ambitus was sometimes included, marking the entire range of a voice at the beginning of the piece.

To apply an ambitus, use one of the following methods:

- Drag the ambitus symbol (from the Lines palette of the Advanced workspace) onto a clef.
- Select one or more clefs, then click (double-click prior to version 3.4) the ambitus symbol (in the Lines palette of the Advanced workspace).

When applied, the ambitus automatically displays the note range of the score: if there is a section break then only the note range of the section is displayed. Beyond the section break a new ambitus may be applied.

The note range of the ambitus can be adjusted manually by selecting it and changing the "Top note" and "Bottom note" values in the Inspector. For automatic adjustment click the Update Range button in the inspector.

Mensural time signatures

In the mensural notation system, time signatures did not define the length of a measure, but the length of breves and semibreves. MuseScore supports mensural time symbols as a display method in the Time signature properties dialog rather than as symbols, but they are just for show, as the proportion of e.g. half notes per whole notes cannot be modified.

One way to make use of these symbols is to replicate when composers of the renaissance had multiple voices in different time signatures simultaneously without using tuplets. Edit the time signature on a per-staff basis, as long as the beginning and end of a measure in all staves match up. If they do not, then consider increasing the size of the measures to the lowest common denominator.
De Profundis Clamavi for 5 voices by Josquin Des Prez

See also

- Measure Operations: Split and join

Figured bass

Adding a new figured bass indication

1. Select the note to which the figured bass applies
2. Press the Figured Bass shortcut (default Ctrl+G; can be changed in Preferences)
3. Enter the text in the editor ‘blue box’ as required (see below)
4. Press Space to move to the next note ready for another figured bass indication (or click outside the editor box to exit it)

With Space, the editor advances to the next note, or rest of the staff to which figured bass is being added. To move to a point in between, or to extend a figured bass group for a longer duration, see below Group Duration.

Tab advances the editing box to the beginning of the next measure.

Shift+Space moves the editing box to the previous staff note or rest.

Shift+Tab moves the editing box to the beginning of the previous measure.

Text format

Digits

Digits are entered directly. Groups of several digits stacked one above the other are also entered directly in a single text, stacking them with Enter:

Accidentals

Accidentals can be entered using regular keys:

To enter: type:
double flat bb
flat b
natural h
sharp #
double sharp ##

These characters will automatically turn into the proper signs when you leave the editor. Accidentals can be entered before, or after a digit (and of course, in place of a digit, for altered thirds), according to the required style; both styles are
properly aligned, with the accidental 'hanging' at the left, or the right.

Combined shapes

Slashed digits or digits with a cross can be entered by adding, / or + after the digit (combining suffixes); the proper combined shape will be substituted when leaving the editor:

![Combined shapes example](image)

The built-in font can manage combination equivalence, favoring the more common substitution:

1+, 2+, 3+, 4+ result in 1⁺, 2⁺, 3⁺, 4⁺ (or 1⁺, 2⁺, 3⁺, 4⁺)

and 5\, 6\, 7\, 8\, 9 result in 5\, 6\, 7\, 8\, 9 (or 5\, 6\, 7\, 8\, 9)

Please remember that / can only be combined with 5; any other 'slashed' figure is rendered with a question mark.

+ can also be used before a digit; in this case it is not combined, but it is properly aligned ('+' hanging at the left side).

Parentheses

Open and closed parentheses, both round: '(', ')' and square: '[', ']' can be inserted before and after accidentals, before and after a digit, before and after a continuation line; added parentheses will not disturb the proper alignment of the main character.

Notes:

- The editor does not check that parentheses, open and closed, round or square, are properly balanced.
- Several parentheses in a row are non-syntactical and prevent proper recognition of the entered text.
- A parenthesis between a digit and a combining suffix ('+', '\', '/') is accepted, but prevents shape combination.

Continuation lines

Continuation lines are input by adding an '_' (underscore) at the end of the line. Each digit of a group can have its own continuation line:

![Continuation line example](image)

Continuation lines are drawn for the whole duration of the figured bass group.

'Extended' continuation lines

Occasionally, a continuation line has to connect with the continuation line of a following group, when a chord degree has to be kept across two groups. Examples (both from J. Boismortier, *Pièces de viole*, op. 31, Paris 1730):

![Extended continuation line examples](image)

In the first case, each group has its own continuation line; in the second, the continuation line of the first group is carried 'into' the second.
This can be obtained by entering several (two or more) underscores “___” at the end of the text line of the first group.

Duration

Each figured bass group has a duration, which is indicated by a light gray line above it (of course, this line is for information only and it is not printed or exported to PDF).

Initially, a group has the same duration of the note to which it is attached. A different duration may be required to fit several groups under a single note or to extend a group to span several notes.

To achieve this, each key combination of the list below can be used:

- to advance the editing box by the indicated duration
- AND
- to set the duration of the previous group up to the new editing box position.

Pressing several of them in sequence without entering any figured bass text repeatedly extends the previous group.

Type: to get:

| Ctrl+1 | 1/64 |
| Ctrl+2 | 1/32 |
| Ctrl+3 | 1/16 |
| Ctrl+4 | 1/8 (quaver) |
| Ctrl+5 | 1/4 (crochet) |
| Ctrl+6 | half note (minim) |
| Ctrl+7 | whole note (semibreve) |
| Ctrl+8 | 2 whole notes (breve) |

(The digits are the same as are used to set the note durations)

Setting the exact figured bass group duration is only mandatory in two cases:

1. When several groups are fit under a single staff note (there is no other way).
2. When continuation lines are used, as line length depends on the group duration.

However, it is a good practice to always set the duration to the intended value for the purposes of plugins and MusicXML.

Editing existing figured basses

To edit a figured bass indication already entered:

- Select it, or the note it belongs to and press the same Figured Bass shortcut used to create a new one or
- Double-click it

The usual text editor box will open with the text converted back to plain characters (‘b’, ‘#’ and ‘h’ for accidentals, separate combining suffixes, underscores, etc.) for simpler editing.

Once done, press Space to move to a next note, or click outside the editor box to exit it, as for newly created figured basses.

Style

To configure how figured bass is rendered: from the menu, select Format → Style…. → Figured Bass.
• **Font**: The dropdown list contains all the fonts which have been configured for figured bass. A standard installation contains only one font, "MuseScore Figured Bass," which is also the default font.

• **Size**: Select a font-size in points. *Note: This value is also modified by any change made to **Scaling** (Format → Page Settings…), or **Scale** ("Staff properties").

• **Vertical Position**: The distance (in spatia) from the top of the staff to the top margin of the figured bass text. Negative values go up (figured bass above the staff) and positive values go down (figured bass below the staff: a value greater than 4 is needed to step over the staff itself).

• **Line Height**: The distance between the base line of each figured bass line, as a percentage of font size.

The following picture visualizes each numeric parameter:

![Diagram of vertical position, size, and line height]

• **Alignment**: Select the vertical alignment: with **Top**, the top line of each group is aligned with the main vertical position and the group 'hangs' from it (this is normally used with figured bass notation and is the default); with **Bottom**, the bottom line is aligned with the main vertical position and the group 'sits' on it (this is sometimes used in some kinds of harmonic analysis notations):

![Top and Bottom alignment examples]

• **Style**: Chose between "Modern" or "Historic." The difference between the two styles is shown below:

![Modern and Historic style examples]

**Proper syntax**

For the relevant substitutions and shape combinations to take effect and for proper alignment, the figured bass mechanism expects input texts to follow some rules (which are in any case, the rules for a syntactical figured bass indication):

• There can be only one accidental (before or after), or only one combining suffix per figure;
• There cannot be both an accidental **and** a combining suffix;
• There can be an accidental without a digit (altered third), but not a combining suffix without a digit.
• Any other character not listed above is not expected.
If a text entered does not follow these rules, it will not be processed: it will be stored and displayed as it is, without any layout.

**Summary of keys**

<table>
<thead>
<tr>
<th>Type:</th>
<th>to get:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+G</td>
<td>Adds a new figured bass group to the selected note.</td>
</tr>
<tr>
<td>Space</td>
<td>Advances the editing box to the next note.</td>
</tr>
<tr>
<td>Shift+Space</td>
<td>Moves the editing box to the previous note.</td>
</tr>
<tr>
<td>Tab</td>
<td>Advances the editing box to the next measure.</td>
</tr>
<tr>
<td>Shift+Tab</td>
<td>Moves the editing box to the previous measure.</td>
</tr>
<tr>
<td>Ctrl+1</td>
<td>Advances the editing box by 1/64, setting the duration of the previous group.</td>
</tr>
<tr>
<td>Ctrl+2</td>
<td>Advances the editing box by 1/32, setting the duration of the previous group.</td>
</tr>
<tr>
<td>Ctrl+3</td>
<td>Advances the editing box by 1/16, setting the duration of the previous group.</td>
</tr>
<tr>
<td>Ctrl+4</td>
<td>Advances the editing box by 1/8 (quaver), setting the duration of the previous group.</td>
</tr>
<tr>
<td>Ctrl+5</td>
<td>Advances the editing box by 1/4 (crochet), setting the duration of the previous group.</td>
</tr>
<tr>
<td>Ctrl+6</td>
<td>Advances the editing box by a half note (minim), setting the duration of the previous group.</td>
</tr>
<tr>
<td>Ctrl+7</td>
<td>Advances the editing box by a whole note (semibreve), setting the duration of the previous group.</td>
</tr>
<tr>
<td>Ctrl+8</td>
<td>Advances the editing box by two whole notes (breve), setting the duration of the previous group.</td>
</tr>
<tr>
<td>Ctrl+Space</td>
<td>Enters an actual space; useful when figure appears “on the second line” (e.g., 5 4 -&gt; 3).</td>
</tr>
<tr>
<td>BB</td>
<td>Enters a double flat.</td>
</tr>
<tr>
<td>B</td>
<td>Enters a flat.</td>
</tr>
<tr>
<td>H</td>
<td>Enters a natural.</td>
</tr>
<tr>
<td>#</td>
<td>Enters a sharp.</td>
</tr>
<tr>
<td>##</td>
<td>Enters a double sharp.</td>
</tr>
<tr>
<td>_</td>
<td>Enters a continuation line.</td>
</tr>
<tr>
<td>__</td>
<td>Enters an extended continuation line.</td>
</tr>
</tbody>
</table>

**File formats**

MuseScore can import and export a wide variety of file formats, allowing you to share and publish scores in the format that best meets your needs.

**MuseScore native format**

MuseScore saves files in the following native formats:

- *.mscz: The default MuseScore file format. Being compressed it takes up relatively little disk space.
- *.mscx: An uncompressed MuseScore file format, mainly used for debugging or storing in a versioning system.
- *.mscz, / *.mscx: These are backup files. Notice the point (full stop) added before the file name, and the comma added to the file extension.

**A note about fonts:** MuseScore does not embed text fonts in saved or exported native format files. If you want your MuseScore file to be viewed by other MuseScore users, make sure you are using the built-in FreeSerif or FreeSans font families for your text, or a font that the other parties have installed too. If a system does not have the fonts specified in your original file, MuseScore will use a fallback option, which may cause your score to appear differently.

**MuseScore format (.mscz)**

MSCZ is the standard MuseScore file format and recommended for most uses. A score saved in this format takes up very little disk space, but preserves all the necessary information. The format is a ZIP-compressed version of .mscx files and includes any images the score may contain and a thumbnail.

**Uncompressed MuseScore format (.mscx)**

MSCX is the uncompressed version of the MuseScore file format. A score saved in this format will retain all information, except images. It can be opened with a text editor, allowing the user access to the file's source code.

**MuseScore backup file (.mscz) or (.mscx)**

Backup files are created automatically and saved in the same folder as your normal MuseScore file. The backup copy contains the previously saved version of the MuseScore file and can be important if your normal copy becomes corrupted, or for looking at an older version of the score.

The backup file adds a period to the beginning of the file name (.) and a comma (,) to the end (e.g., if your normal file is...
called "untitled.mscz", the backup copy will be "untitled.mscz," and the period and comma need to be removed from the name in order to open the backup file in MuseScore. As it is stored in the same folder as your normal MuseScore file, you may also need to give it a unique name (e.g. changing "untitled.mscz" to "untitled-backup1.mscz").

Note: In order to see the MuseScore backup files, you may need to change your system settings to "Show hidden files". See also How to recover a backup copy of a score.

Graphic files (export only)

MuseScore can export a score as a graphic file in either PDF, PNG or SVG format.

PDF (*.pdf)

PDF (Portable Document Format) files are ideal for sharing your sheet music with others who do not need to edit the content. This is a very widely-used format and most users will have a PDF viewer of some kind on their computers.

To set the resolution of exported PDFs:

1. From the menu bar, choose Edit → Preferences... (Mac: MuseScore → Preferences...), and select the "Export" tab;
2. Set the resolution in the "PDF" section.

PNG (*.png)

PNG (Portable Network Graphics) files are based on a bitmap image format, widely supported by software on Windows, Mac OS, and Linux, and very popular on the web. MuseScore creates PNG images as they would appear if printed, one image per page.

To set the resolution of exported PNG images:

1. From the menu bar, choose Edit → Preferences... (Mac: MuseScore → Preferences...), and select the "Export" tab;
2. Set the resolution and transparency in the PNG/SVG section.

Note: If you want to create images that show only parts of the score (with or without screen-only items such as frame boxes, invisible notes, and out-of-range note colors), use Image capture instead.

SVG (*.svg)

SVG (Scalable Vector Graphics) files can be opened by most web browsers (except Internet Explorer before version 9) and most vector graphics software. However, most SVG software does not support embedded fonts, so the appropriate MuseScore fonts must be installed to view these files correctly. SVG is the current format for all scores saved on MuseScore.com.

To set resolution and transparency of exported SVG files, see the instructions under PNG (above). Note that MuseScore does not (yet) support gradients on export (although it does for images in a score).

Audio files (export only)

MuseScore can create normalized, stereo audio of the score in any of the following formats WAV, MP3, OGG VORBIS, FLAC. To export an audio file:

1. From the menu, select File → Export...;
2. Choose the desired format from the dropdown menu, then press Save.

You can adjust the sample rate of all audio formats as follows:

1. From the menu bar, select Edit → Preferences... (Mac: MuseScore → Preferences...), and click on the Export tab;
2. Set "Sample rate" in the "Audio" section.

WAV audio (*.wav)

WAV (Waveform Audio Format) is an uncompressed sound format. This was developed by Microsoft and IBM, and is widely supported by software for Windows, OS X, and Linux. It is an ideal format for use when creating CDs, as full sound quality is preserved. For sharing via email or the internet, use a compressed alternative such as MP3.

MP3 (*.mp3)

MP3 is a very widely-used compressed audio format. MP3 files are ideal for sharing and downloading over the internet due to their relatively small size.

To set the MP3 bitrate:

1. From the menu bar, choose Edit → Preferences... (Mac: MuseScore → Preferences...), and select the "Export" tab;
2. Set the MP3 bitrate in the "Audio" section.

**FLAC audio (.*flac)**

Free Lossless Audio Codec (FLAC) is compressed audio format. FLAC files are approximately half the size of uncompressed audio and just as good quality. Windows and OS X do not have built-in support for FLAC, but software such as the free and open source VLC media player can play FLAC files on any operating system.

**Ogg Vorbis (.*ogg)**

Ogg Vorbis is intended as a patent-free replacement for the popular MP3 audio format (which MuseScore also supports —see above). Like MP3, Ogg Vorbis files are relatively small (often a tenth of uncompressed audio), but some sound quality is lost. Windows and OS X do not have built-in support for Ogg Vorbis. However, software such as VLC media player and Firefox can play Ogg files on any operating system.

**Share with other music software**

MuseScore can import and export MusicXML and MIDI files; it is also able to import a variety of native format files from other music notation programs.

**MusicXML (.*xml, *.musicxml)**

MusicXML is the universal standard for sheet music. It is the recommended format for sharing sheet music between different scorewriters, including MuseScore, Sibelius, Finale, and more than 100 others. MuseScore imports *.*xml and *.*musicxml, but exports only *.*musicxml. If you need *.*xml (because the program you want to import it needs that), you need to rename it yourself after the export.

**Compressed MusicXML (.*mxl)**

Compressed MusicXML creates smaller files than regular MusicXML. This is a newer standard and isn’t as widely supported by older scorewriters, but MuseScore has full import and export support.

**MIDI (.*mid, *.midi, *.kar)**

MIDI (Musical Instrument Digital Interface) is a format widely supported by sequencers and music notation software. For details of the protocol see the MIDI Association website.

MIDI files are very useful for playback purposes but contain little in the way of score layout information (formatting, pitch spelling, voicing, ornaments, articulations, repeats, key signatures etc.). To share files between different music notation software, MusicXML is recommended instead.

For details about how to import MIDI files see MIDI import.

**MuseData (.*md) (import only)**

MuseData is a format developed by Walter B. Hewlett beginning in 1983 as an early means of sharing music notation between software. It has since been eclipsed by MusicXML, but several thousand scores in this format are still available online.

**Capella (.*cap, *.*capx) (import only)**

CAP and CAPX files are created by the score writer Capella. MuseScore imports version 2000 (3.0) or later fairly accurately.

**Bagpipe Music Writer (.*bww) (import only)**

BWW files are created by the niche score writer Bagpipe Music Writer.

**BB (.*mgu, *.*sgu) (import only)**

BB files are created by the music arranging software, Band-in-a-Box. MuseScore's support is currently experimental.

**Overture (.*ove) (import only)**

OVE files are created by the score writer Overture. This format is mainly popular in Chinese-language environments, such as Mainland China, Hong Kong, and Taiwan. MuseScore’s support is currently experimental.

**Guitar Pro (.*gtp, *.gp3, *.gp4, *.gp5, *.*gpx) (import only)**
GP files are created by Guitar Pro.

Power Tab Editor (*.ptb) (import only)

PTB files are created by Power Tab Editor. MuseScore’s support is currently experimental.

See also
- Open/Save/Export/Print
- Recovered files

External links
- How to recover a backup copy of a score

Fretboard diagrams

Note: This page applies to MuseScore 3.1 and above only. Users of versions prior to 3.1 should go to Fretboard diagrams (prior to version 3.1).

Fretboard Diagrams overview

MuseScore allows the use and creation of fretboard (or chord) diagrams. They usually appear above the staff on lead sheets and piano scores. They are commonly used for guitar chords, but MuseScore permits the creation of diagrams for any instrument.

Below is a simple example of Fretboard Diagrams use.

(Note: Fretboard Diagrams are an alternative to and quite different from Tablature, which is a specialized notation form that is preferred by some string instrument players.)

The Fretboard Diagram mechanism can be used in several different ways.

1. **Standard chords.** A set of 21 common chord diagrams for the guitar are found in the Fretboard Diagrams palette in the Advanced Workspace. These consist of a single example of a major, minor, and seventh chord for each diatonic scale tone (CDEFGAB). These 21 chords are adequate for many simple pop or folk music scores. See the overview of this palette below.

2. **Modified chords.** In many cases, the standard chords from the Fretboard Diagrams palette are used as a starting point for creating modified chord diagrams, via the Inspector. This technique enables chord extensions, alterations, different voicings, different positions, etc. to be applied to the 21 standard diagrams. There are literally thousands of guitar chords in general use, making a comprehensive palette or dictionary impractical. See How to use Fretboard Diagrams for examples.

3. "Freehand" chords. More advanced guitarists often prefer to start from a blank chord grid, and then draw the specific chord tones desired. See How to use Fretboard Diagrams for examples.

Note: Many aspects of music notation follow well-established engraving standards. Guitar chord diagrams are an exception. Usage has varied widely from year to year, from publisher to publisher, from teacher to teacher, and from arranger to arranger. Many inconsistent practices persist today, and distinct styles of chord notation are preferred in different musical genres and regions. For this reason, the MuseScore Fretboard Diagram interface supports diagrams of various types. Users are free to choose their preferences.

Overview of the standard guitar chord palette

The Fretboard Diagrams palette in the Advanced Workspace provides 21 diagrams, comprising a single major, minor, and seventh chord for each diatonic scale tone (CDEFGAB). The name of each diagram appears when the cursor hovers over
The entry.

Note: This range of chord diagrams, or indeed any selection of 21 chords, would not typically be sufficient for publication purposes. Arrangers must consider many other voicings, positions, and chord qualities. This palette is also an example of the diverse diagram formats in use, as discussed above. These 21 chords happen to incorporate open/mute string indicators (the X and O symbols above the diagrams). Although those symbols do often appear in published scores, their usage varies by context. For example, jazz arrangements generally omit mute string indicators, unless contextually important, and rarely use open strings.

Additional palettes that contain a broader range of standard chords are expected to be available in the future. These would try to address the needs of specific musical genres and situations.

Overview of creating modified or custom chords

Modified Fretboard Diagrams are created by adding and then editing an existing diagram from the palette. By modifying standard chords, it is possible to create Fretboard Diagrams for any playable chord, and to reflect fingering on any Western fretted stringed instrument, regardless of tuning, number of strings, or number of frets. Most of the material below deals with the process of modifying diagrams and creating new ones.

Custom diagrams can be saved to a custom palette if desired for future use. Modified diagrams can of course be copied/pasted within a score in the usual ways.

To add a Fretboard Diagram

To add a Fretboard Diagram to the score, use one of the following methods:

- Select a note in voice 1 and double-click a Fretboard Diagram from the palette.
- Drag and drop a Fretboard Diagram from a palette to the desired position in the score.

As the cursor hovers over the chosen diagram within the palette, its name will appear as a pop-up hint (see the example in the overview).

Chord Symbols linked to Fretboard Diagrams

When adding a Fretboard Diagram to a score, a chord symbol is also automatically created. The chord symbol is normally placed above the diagram, and uses the chord name from the chord's palette cell. Automatic placement and formatting of a diagram's chord symbol is controlled by style settings (see style settings, below).

A Fretboard Diagram's generated chord symbol can be selected, moved, and modified like any other text element. It behaves generally like the normal chord symbols that are added using Add → Text → Chord Symbol or the shortcut Ctrl+K.
Note 1: A field on the Chord Symbols style page (Style submenu: select Format → Style... → Chord symbols) – rather than on the Fretboard Diagrams style page – controls the chord symbol's "Distance to Fretboard Diagram". This value interacts with the Element "Minimum distance" field, within the Inspector, to control automatic placement of the chord symbol relative to the diagram. Note also that the Fretboard Diagram's "top edge" includes the blank space where open/mute string indicators would appear, even if that area is empty. This may leave a larger gap than is desired. As usual, manual placement can be used to override the automatic settings.

Note 2: Automatic chord symbols generated for Fretboard Diagrams are not completely integrated with normal Chord Symbols that may be directly associated with notes on the staff. Specifically, focus does not flow from a Fretboard Diagram's chord symbol back to the sequence of other symbols on the page when using Space to move through the chord symbols. This minor issue will be addressed in a future update.)

Use of Chord Symbols with Fretboard Diagrams

- Add a diagram's Chord Symbol automatically simply be adding a Fretboard Diagram as described above.
- Delete a diagram's Chord Symbol by selecting the symbol and deleting it, as with any text item.
- Add a new Chord Symbol to a diagram without one by selecting the Fretboard Diagram and using Add → Text → Chord Symbol or the shortcut Ctrl+K.

To adjust a Fretboard Diagram's element properties (position, color, stacking order...)

The position of a Fretboard Diagram can be adjusted using the keyboard arrows in Edit mode, or with the X- and Y-offsets in the "Element" section at the top of the Inspector.

Visibility, Color and Stacking order can also be adjusted in the "Element" section: see the diagram under editing.

To adjust global/default Fretboard Diagram style properties

Certain default and global properties of Fretboard Diagrams (see diagram below) can be adjusted from the Style submenu: select Format → Style... → Fretboard Diagrams. Some of these properties are subject to override via the Inspector; but most affect all Fretboard Diagrams in the score.

- Default vertical position specifies the default placement of the diagram relative to the staff. (Subject to override via Inspector).
- Scale specifies the default scale (i.e. diagram size). (Subject to override via Inspector).
- Fret number font size and ...position control placement of fret numbers on all diagrams. (Global).
- Barre line thickness controls how large a line is used to represent a barre on all diagrams. By default, this is the...
same thickness as the solid dots. A smaller line will allow dots to be visible under the barre, for situations where that is desirable. (Global).

- **Relative dot size** controls the size of dots on all diagrams, relative to the size of the scaled grid. (Global).
- **String spacing** controls the spacing between strings, and thus the total width of all diagrams. (Global).
- **Fret spacing** controls the spacing between frets, and thus the total height of all diagrams relative to the number of frets they each display. (Global).

Most Fretboard Diagram properties exposed by the Inspector offer "reset to style default" and "save as style default" buttons. These values do not typically appear on the style page, but are manipulated via the Inspector.

**To edit a Fretboard Diagram**

When a Fretboard Diagram is selected, it can be edited in the Inspector as follows:

The Inspector displays three sections related to the Fretboard Diagram:

- An Element section that controls the Fretboard Diagram's visibility, placement, color, and other aspects that are used in common with other MuseScore elements; see adjust element properties and the Inspector for details.
- A Fretboard Diagram section, with control fields and buttons that define the appearance of this diagram.
- A magnified version of the Fretboard Diagram, showing its details and allowing editing.

Below is an example of the Inspector with a Fretboard Diagram selected.

| Inspector with Fretboard Diagram selected. |

**Editing Fretboard Diagram properties**

(See Inspector properties above in the editing example.)

- To adjust the **scale (size)** of the diagram: Use **Scale**.
- To adjust the diagram's **placement relative to the staff**: Use **Placement**.
- To adjust the **number of instrument strings**: Use **Strings**. Strings are added/removed from the left side of the diagram.
- To adjust **how many frets to display** (i.e. the height of the diagram): Use **Frets**. Frets are added/removed from the bottom of the diagram.
- To adjust the **first fret position**: Use **Fret number**. A digit is shown next to the first visible fret.
- To specify **thickening of the nut** (a heavy line above the first fret): Use **Show nut**.
- Place the **finger dots** as described below.
Finger dot editing (basic use)

(See Inspector properties above in the editing example.)

- To remove all current dots, use the "Clear" button above the diagram. (Note: you could save a blank grid in a custom palette, as a starting point for custom diagrams.)
- To create a dot, click on a fret in the diagram at the bottom of the inspector; click again to remove the dot.
- To move a dot, clear its current position by clicking on it; then create the desired dot.
- To create a barre or partial barre: Click the "Barre" button above the diagram; then click at the leftmost position desired for the barre. The barre will extend to the right edge of the fretboard. Keyboard shortcut: Holding the Shift key, click on the string where you want a barre to begin.
- To end a barre before the rightmost string: Click the "Barre" button above the diagram; then click at the rightmost position desired on an existing barre. The barre will end at that string. Keyboard shortcut: Holding the Shift key, click on the string where you want a barre to end.
- To delete a barre: Click the "Barre" button above the diagram; then click at the leftmost position of the barre. It will be removed. Keyboard shortcut: Holding the Shift key, click on the leftmost position of the barre.
- To create multiple barres: Use the above steps to create one than one barre, e.g. to show the third finger covering two strings.
- To adjust the barre thickness: Use the Style options (Format->Style->Fretboard Diagrams) to adjust the barre line thickness relative to the dots. This will allow dots to be visible on the barre, for cases where that is desired.
- To indicate open and mute strings (optional). Click just above the diagram to toggle a string between:
  - Open (o)
  - Mute/unplayed (x)
  - No indication

Finger dot editing (advanced use)

Some arrangers and educators use a more advanced form of Fretboard Diagram that a) incorporates multiple types of "dot", and that b) allows multiple dots per string.

This technique is particularly associated with the many books and arrangements published by Ted Greene and his successors. (Note: No other notation software currently supports this diagram style.)

- **Multi-dot notation style.** With this approach, the round dots are played first. Then, on successive beats, the notes represented by the other dots are then played in order. This allows a single diagram to represent several beats of music. (The usual sequence is: dot → X → square → delta. Usage varies however.) Here are two examples of multi-dot diagrams.

- **Optional-note notation style.** Another use of multiple dots per string allows other symbols to show optional notes, rather than delayed notes. Typically, a related chord voicing is shown, such as an optional extension or an optional rootless chord version. Here is an example of an optional extension.

MuseScore Fretboard Diagrams allow the creation of these and other types of multi-symbol diagrams. A chord is first created and edited using the basic steps described above. Then, the multiple dot buttons above the diagram are used to
1. To **begin adding multiple dots** (i.e. symbols) to a diagram, click "**Multiple dots**".
2. To **add another dot to a string**, click above or below an existing symbol. The next symbol in sequence will be placed at that position, e.g. if there is already a dot, an X will appear next.
3. To **remove any symbol from a diagram**, click on it.
4. To **enter a particular symbol out of sequence**, click on the button with that symbol before adding the dot; e.g. to enter an X on a string with no current dots, because that note should be played after the rest of the chord, click on the X and then place it as desired.

(Note: Experienced users of **Ted Greene** style diagrams will find that several secondary features from Ted's diagrams are not yet supported in MuseScore. These include: a. Displaying the fret number on a higher fret than the first visible fret. b. Allowing the note symbols to include digits, not just the four dot styles currently supported. c. Allowing the creation of annotation on and between diagrams, such as circling a particular note, or drawing lines linking notes in adjacent diagrams. However, MuseScore does provide many tools for drawing and annotation that can serve in place of these techniques.)

(Note: Because multi-note symbols are not standardized, even within the **Ted Greene** community, users must be careful to indicate how they are being used within a given score.)

**External links**

- [How to use Fretboard Diagrams for custom/complex chords](#)

**Fretboard diagrams (prior to version 3.1)**

_Note: This page applies to versions of MuseScore prior to 3.1 only. Users of MuseScore 3.1 and above should go to Fretboard diagrams._

A range of **fretboard** (or **chord**) diagrams for the guitar are provided in the Fretboard Diagrams palette in the Advanced Workspace.

You can create a chord diagram for any fretted, stringed instrument by editing an existing one. It can be saved to a custom palette for future use if required.

**Add a fretboard diagram**

To add a fretboard diagram to the score, use one of the following methods:

- Select a note in voice 1 and double-click a fretboard diagram from **palette**.
- Drag and drop a fretboard diagram from a palette to the desired position in the score.

As the cursor hovers over the chosen diagram within the palette, its name will appear as a pop-up hint.

**Edit a fretboard diagram**

When a fretboard diagram is selected, it can be edited in the **Inspector** as follows:

- To adjust the **number of instrument strings**: Use Strings.
- To adjust the **fret position number**: Use **Offset**.
- To adjust how many frets to display (height-wise): Use **Frets**.
To place the finger dots: Click on a fret to establish a dot; click again to remove the dot.
To create a barre or partial barre: First make sure that the desired fret position is clear of black dots (click on a dot to remove it). Then, holding the Shift key, click on the string where you want the barre to begin. (Note: Only one barre can be applied per diagram; a partial barre must end on the first string).
To delete a barre: Click on the black dot where the barre begins.
To indicate open and mute strings (if applicable): Click just above the diagram to toggle a string between:
- Open (o)
- Mute/unplayed (x)
- No indication.
To adjust the size: Use the Scale property.

To adjust a diagram's element properties

The position of a Fretboard Diagram can be adjusted using the keyboard arrows in Edit mode; or with the X- and Y-offsets in the "Element" section at the top of the Inspector.

Visibility, Color and Stacking order can also be adjusted from the "Element" section.

To adjust a diagram's style properties

Certain default and global properties of Fretboard Diagrams (e.g. barre thickness, vertical position, scale, fret-number font-size and position) can be adjusted from the Style submenu: select Format → Style... → Fretboard Diagrams. Some of these properties are subject to override via the Inspector; but most affect all Fretboard Diagrams in the score.

Layer (experimental)

This feature is still experimental and only visible if MuseScore is started using the '-e' option, see Command line options.

For the Open-Goldberg project, the ability to create different versions of the score was needed. One version is the "Urtext", a score which is close to the original version of Bach. A second version could be a Czerny variation, which in addition to the Urtext, contains fingerings.

The layer feature allows creating different versions out of one score file. If you want to add fingerings, you have to create a layer and tag the fingerings elements with the layer name.

First, create layers:

Second, create a score variant:
Add the visible layer to the score variant, then select all fingerings and tag them with the name of the score variant:

Default layer:

Czerny layer:
See also

- Command line options

MIDI import

MuseScore can import MIDI files (.mid/.midi/.kar) and convert them into music notation.

- To import a MIDI file, use the standard Open command. This converts the MIDI file into a MuseScore file using default settings.

The MIDI Import Panel appears at the bottom of the screen: you can expand this by dragging the interface with the document window upwards. The panel shows all the tracks in the file (only those with note events are shown) and allows you to adjust parameters affecting the conversion process. If there are multiple tracks, then one more track is added at the top of the list to select all tracks at once.

- To accept the default conversion: Simply press the "X" symbol on the top-left of the Import Panel to close it. The panel can be re-opened at any time during the session by pressing "Show MIDI import panel" at the bottom of the document window.

- To reimport the file: Adjust the desired parameters in the Import Panel (see below) and press Apply. If you have made changes to the Import Panel but wish to UNDO them, press Cancel. To close the Import Panel, press the "X" symbol at the top-left of the panel.

Mouse wheel scrolling (MIDI Import Panel): Vertical scrolling is the default. For horizontal scrolling, press Shift or Ctrl while using the wheel.

Available operations

MuseScore instrument

Assign a MuseScore instrument (listed in instruments.xml or in specified custom xml file in Preferences) that defines staff name, clef, transposition, articulations, etc.

Quantization

Quantize MIDI notes by some regular grid. The grid MAX resolution can be set via the drop-down menu:
- Value from preferences (default) - quantization value is taken from the main Preferences dialog of MuseScore (in the "Import" tab)
- Quarter, Eighth, 16th, 32nd, 64th, 128th - user-defined values

However, the actual quantization grid size is adaptive and reduces when the note length is small, so for each note the quantization value is different. But there is an upper limit for the quantization value, and that value can be set by the user as "max. quantization".

For example, if some note is long - say, half note, and the max. quantization is set to 8th, then the note will be quantized with the 8th-note grid, not the half- or quarter-note grid as it supposed to be by the algorithm. Such quantization scheme allows to quantize all notes in the score (with different lengths!) adequately.

**Max. voices**
Sets maximum count of allowed musical voices.

**Search tuplets**
When enabled, this option attempts to detect tuplets and applies the corresponding quantization grid to the tuplet chords.

**Is human performance**
If enabled, this option reduces the accuracy of MIDI-to-score conversion in favor of readability. It is useful for unaligned MIDI files, when no regular quantization grid is provided. For such files the automatic beat tracking algorithm is used which tries to detect the bar positions throughout the piece.

**2x less measure count**
The option is active for unaligned MIDI files (when "Is human performance" is checked by default). It halves measure count obtained in the internal beat tracking operation. It may be convenient when the beat tracking gives 2x more frequent bar subdivision than necessary.

**Time signature**
The option is active for unaligned MIDI files. The user can choose an appropriate time signature for the whole piece if the default detected value is wrong. The option is useful because it handles imported tuplets correctly unlike the direct time signature setting from the palette.

**Split staff**
This option is suited mainly for piano tracks - to assign notes to the left or right hand of the performer. It uses constant pitch separation (the user may choose the pitch via sub-options) or floating pitch separation (depending on the hand width - sort of a guess from the program point of view).

For drum tracks ("Percussion" sound in the track list) it splits the staff into multiple staves, each of which gets only one drum pitch (i.e. drum sound). There is also a sub-option to allow/disallow the application of the square bracket for the newly created set of drum tracks.

**Clef changes**
Small clefs can be inserted within a staff to keep chords closer to the 5 staff lines. Clef changes depend on the average pitch of the chord. Tied groups of notes are not broken by the clef insertion (if it occurs, one can report a bug for algorithm in importmidi_clef.cpp). This option is available for non-drum tracks only.

**Simplify durations**
Reduces number of rests to form more "simple" note durations. For drum tracks this option can remove rests and lengthen notes as well.

**Show staccato**
Option to show/hide staccato markings in the score.

**Dotted notes**
Controls whether MuseScore will use dotted notes or ties.

**Show tempo text**
Shows/hides tempo text markings in the score.

**Show chord names**
Shows/hides chord names in the score, if any, for XF MIDI file format.

**Recognize pickup measure**
When enabled, this option doesn’t change the time signature of the first bar that is shorter than the second bar. It is also called anacrusis. This option is only available for all tracks at once.

**Detect swing**
MuseScore tries to detect swing, and automatically replace a pattern of 4th + 8th notes in triplets (for the most common swing feel, 2:1), or a dotted 8th + 16th pattern (for shuffle, 3:1), with two straight 8ths and a "Swing" or "Shuffle" text at the beginning.

**Master palette**

The **Master Palette** is a repository of symbols used to populate the workspaces (Basic, Advanced, and Custom). It is also used to create new Time Signatures and Key Signatures.

To open, use either of the following options:
- Press Shift+F9 (Mac: fn+Shift+F9).
- From the menu, select View → Master Palette.
The Master palette is divided into sections based on symbol type. Hovering the mouse over an item shows a tool tip (a short definition in black on yellow background).

To transfer a Master palette item to a custom palette:

- Drag the symbol from the Master Palette window into a custom palette.

**Note:** Except for the Symbols section (below), it is not usual to add items directly to the score from the Master palette: use the workspace palettes instead. However, if desired, items can be added directly using either (i) drag-and-drop or (ii) by selecting one or more notes/rests and double-clicking the item.

**Symbols**

The Symbols section of the Master Palette is a large repository of hundreds of musical symbols in addition to those found in the preset workspaces. You can open it from the Master Palette, or directly from the score by using the shortcut.

Find a symbol

The Symbols subcategories can be displayed by clicking on “Symbols”. Use the font menu on the bottom right of the box to specify Emmentaler-, Gonville- or Bravura-specific symbols. You can search for a particular symbol by entering a keyword in the search box.

Apply a symbol
To add an item to the score from the Symbols section, use any of the following options:

- Drag and drop a symbol onto a staff.
- Select a note or rest and double-click a symbol.

The position of the symbol can be adjusted by dragging or by changing the horizontal / vertical offsets in the Inspector. Color and visibility can also be adjusted in the Inspector.

**Note:** Elements from the Symbols section do not follow any positioning rules (in many cases unlike identical elements from other sections of the Master Palette), nor do they affect score playback.

**Connect symbols**

Elements from the Symbols section can be connected to each other on the score page, so that they can be moved as one unit:

1. Apply first symbol to the score. Adjust position as required.
2. Double click, or drag-and-drop, a second element onto the first symbol. Adjust position as required.

Drag the first element and the attached element will follow.

**See also**

- Palettes and workspaces
- Symbols and special characters (add musical symbols to text objects)

**Note input modes**

MuseScore allows you to choose from any of several note input modes. **Step-time** (see below) is the default, but others can be accessed by clicking the small dropdown arrow next to the note entry button on the note input toolbar.

**Step-time**

This is the default method of note input and involves entering notes one at a time: first by selecting a note duration using the mouse or keyboard, then choosing a pitch using the mouse, keyboard, MIDI keyboard or virtual piano.

For details see **Basic note entry**.

**Re-pitch**

Re-pitch mode allows you to correct the pitches of a sequence of notes while leaving their durations unchanged (not to be confused with **Accidental: Respell pitches**).

1. Select a note as your starting point;
2. Select the **Re-Pitch** option from the **Note input** drop-down menu; or use the keyboard shortcut, Ctrl+Shift+I (Mac: Cmd+Shift+I).
3. Now enter pitches using the keyboard, MIDI keyboard or virtual piano keyboard.

You can also use the **Re-pitch** function to create a new passage from an existing one of the same sequence of durations—by copying and pasting the latter, then applying Re-pitch.

**Rhythm**

Rhythm mode allows you to enter durations with a single keypress. Combining Rhythm and Re-pitch modes makes for a very efficient method of note entry.

1. Select your starting point in the score and enter Rhythm mode.
2. Select a duration from the note input toolbar, or press a duration shortcut (numbers 1-9) on your computer keyboard. A note will be added to the score with the selected duration. In contrast to **Basic note entry**, pressing the . key will toggle dotting or not dotting all subsequent durations. All following rhythms will be dotted until the . key is pressed.
again. Unlike Basic note entry, the dot is to be pressed prior to entering the rhythm.

3. Entering rests is similar to adding dotted notes. Press the 0 key to toggle entering rests. All rhythms entered will be rests until the 0 key is pressed again. This can be used concurrently with dotted notes.

4. Continue pressing duration keys to enter notes with the chosen durations.

5. Now use Re-pitch mode to set the pitches of the notes you just added.

Real-time (automatic)

The Real-time modes basically allow you to perform the piece on a MIDI keyboard (or MuseScore's virtual piano keyboard) and have the notation added for you. However, you should be aware of the following limitations which currently apply:

- It is not possible to use a computer keyboard for Real-time input
- You cannot enter tuplets or notes shorter than the selected duration
- You cannot enter notes into more than one voice at a time

However, these restrictions mean that MuseScore has very little guessing to do when working out how your input should be notated, which helps to keep the Real-time modes accurate.

In the automatic version of Real-time input, you play at a fixed tempo indicated by a metronome click. You can adjust the tempo by changing the delay between clicks from the menu: Edit → Preferences... → Note Input (Mac: MuseScore → Preferences... → Note Input).

1. Select your starting position in the score and enter Real-time (automatic) mode.
2. Select a duration from the note input toolbar.
3. Press and hold a MIDI key or virtual piano key (a note will be added to the score).
4. Listen for the metronome clicks. With each click the note grows by the selected duration.
5. Release the key when the note has reached the desired length.

The score stops advancing as soon as you release the key. If you want the score to continue advancing (e.g. to allow you to enter rests) then you can use the Real-time Advance shortcut to start the metronome.

Real-time (manual)

In the manual version of Real-time input, you have to indicate your input tempo by tapping on a key or pedal, but you can play at any speed you like and it doesn't have to be constant. The default key for setting the tempo (called "Real-time Advance") is Enter on the numeric keypad (Mac: fn+Return), but it is highly recommended that you change this to a MIDI key or MIDI pedal (see below).

1. Select your starting position in the score and enter Real-time (manual) mode.
2. Select a duration from the note input toolbar.
3. Press and hold a MIDI key or virtual piano key (a note will be added to the score).
4. Press the Real-time Advance key. With each press the note grows by the selected duration.
5. Release the note when it has reached the desired length.

Real-time Advance shortcut

The Real-time Advance shortcut is used to tap beats in manual Real-time mode, or to start the metronome clicks in automatic Real-time mode. It is called "Real-time Advance" because it causes the input position to move forward, or "advance", through the score.

The default key for Real-time Advance is Enter on the numeric keypad (Mac: fn+Return), but it is highly recommended that you assign this to a MIDI key or MIDI pedal via MuseScore's MIDI remote control. The MIDI remote control is available from the menu: Edit → Preferences... → Note Input (Mac: MuseScore → Preferences... → Note Input).

Alternatively, if you have a USB footswitch or computer pedal which can simulate keyboard keys, you could set it to simulate Enter on the numeric keypad.

When the notes are entered they will be placed just before the selected starting element, which will be highlighted with a square blue marker. The start element and any subsequent notes or rests within the same measure will be shifted forward. You can move the insertion point forward and backward using the arrow keys → or ←, and the new insertion point will then be highlighted.

Insert

Insert Input mode (called Timewise in versions prior to 3.0.2) allows you to insert and delete notes and rests within measures, automatically shifting subsequent music forwards or backwards. Measure duration is automatically updated as you go.

1. Make sure you are in Note input mode, and that you have the element selected where you want to start inserting notes/rests;
2. Click on the arrow next to the Note input icon, and select Insert (or if Insert is the current default, just press n);
3. Enter a note or rest as you would in Step-Time mode. Each note is inserted before the current cursor position.
4. Move the cursor forward and backward if required (using the arrow keys), to change the insertion point.

Alternatively, if you have only one or two notes to insert, you may prefer to use a shortcut:

- Press Ctrl+Shift (Mac: Cmd+Shift) while adding the note by Mouse-click or keyboard shortcut (A-G).

If, at any time, the total duration of the notes and rests within the measure does not match the time signature, a small + or - sign will be shown above the measure.

See also: Remove selected range (Tools).

Normal mode

To leave Note Input mode, click on the Note Input tool button, press N, or press Esc. This puts you in Normal mode, in which you can change durations and delete notes or rests as follows:

- If you select a note and press Del the note will be replaced by a rest of the same duration.
- If you select a note or rest and press Ctrl+Del the note/rest will be deleted, and subsequent notes moved backward (see Remove selected range).
- If you reduce the duration of a note or rest the remaining duration will be filled with rests.
- If you increase the duration of a note or rest it will subtract duration from the subsequent notes/rests to make up the duration. If this is done on the last note/rest in the measure, a note or rest with the required duration will be inserted in the start of the following measure, and the two will be tied together.

See also

- Note input
- Copy and paste

External links

- Video: Semi-Realtime MIDI Demo Part 1: New note entry modes (YouTube)
- Introduction to the new Repitch Mode (YouTube)

Notehead schemes

You can choose any one of nine notehead schemes for a standard staff. To set a notehead scheme:

- Right-click on a staff and select Staff/Part Properties...; click on Advanced Style Properties... and choose from the "Notehead scheme" dropdown list.

The schemes are as follows:

- Normal: This is the default scheme and the one the vast majority of people will use: it is also the only scheme in MuseScore 1 and 2. It uses normal noteheads which can be changed via the Noteheads palette or the Inspector.
- Pitch name: Noteheads automatically and dynamically change to include the English pitch name in the notehead.
- German pitch name: Just like the previous one but B will be replaced by H, and Bb by B.
- Solfège Movable Do (also called Tonic Solfa): Noteheads include the solfege syllable, depending on the degree in the scale. It uses Ti and not Si.
- **Solfège Fixed Do**: Noteheads include the solfege syllable for the note name. As used in France, Italy, Spain, etc... It uses Si and not Ti.

- **4 Shape (Walker)**: Noteheads follow the four-shape system used in books such as William Walker’s *Southern Harmony* (1835).

- **7 Shape (Aikin)**: Noteheads follow the seven-shape system used in books such as Jesse B. Aikin’s *The Christian Minstrel* (1846), and books by the Ruebush & Kieffer Publishing Company. It’s the most used 7-shape system.

- **7 Shape (Funk)**: Noteheads follow the seven-shape system used in books such as Joseph Funk’s *Harmonia Sacra* (1851).

- **7 Shape Walker**: Noteheads follow the seven-shape system used in books such as William Walker’s *Christian Harmony* (1867).

(For more info about the different variant of shape notes, see the [SMuFL specification](#))

The setting applies to a given staff and the notehead will be used when entering and editing notes. Here is an example.
Noteheads

A range of alternative noteheads can be accessed via the Note Heads palette of the Advanced workspace, or the Inspector (see Change notehead group, below).

Note: The design of the notehead may vary depending on the music font selected (Emmentaler, Gonville or Bravura). Those in the palette are displayed as half notes in Bravura font.

Notehead groups

MuseScore supports a range of notehead styles:

- **Normal**: A standard notehead.
- **Crosshead** (Ghost note): Used in percussion notation to represent cymbals. It also indicates muted and/or percussive effects in stringed instruments such as the guitar.
- **Diamond**: Used to indicate harmonic notes in instruments such as the guitar, violin etc.
- **Slash**: Used to notate rhythms (e.g. guitar strums).
- **Triangle up/down**: Used in percussion notation.
- **Shape notes**: Do, Re, Mi, Fa, Sol, La, Ti.
- **Circle cross**: Used in percussion notation.
- **Circled noteheads**
- **Slashed notehead**: A notehead with an oblique line through it.
- **Plus noteheads**
- **Alt. Brevis**: Used in early music notation.
- **Brackets** (Parentheses): applied around an existing note (or accidental).

Change notehead group

To change the shape of one or more noteheads in the score, use one of the following:

- Select one or more notes and click a notehead in a palette (double-click in versions prior to 3.4).
- Drag a notehead from a palette onto a note in the score.
- Select one or more notes and change the notehead in the Inspector, using the drop-down list under Note → Head group (not supported for drum staves).

Change notehead type

Occasionally you may need to change the apparent duration of a notehead—i.e. notehead type—without altering its actual, underlying duration:

1. Select one or more notes.
2. Choose one of the following options from the Inspector under Note → Head type:
   - **Auto**: Automatic, i.e. apparent duration = actual duration.
   - **Whole**: Whole notehead, regardless of actual duration.
   - **Half**: Half notehead, regardless of actual duration.
   - **Quarter**: Quarter notehead, regardless of actual duration.
   - **Breve**: Breve notehead, regardless of actual duration.

Shared noteheads

When two notes in different voices, but of the same written pitch, fall on the same beat, one of two things may happen:

- The notes may share the same notehead.
- The notes may be offset: i.e. arranged side by side.

MuseScore uses the following rules:

- Notes with stems in the same direction do not share noteheads.
- Dotted notes do not share noteheads with undotted notes.
- Black notes do not share noteheads with white notes.
- Whole notes never share noteheads.

Note: If two unison notes occur in the same voice they are always offset.

Change offset noteheads to shared

Offset noteheads can be turned into shared noteheads in one of two ways:

- Make the smaller-value notehead invisible by selecting it and using the keyboard shortcut (or unchecking the "Visible" option in the Inspector).
- Alter the notehead type of the shorter-duration note to match the longer one by switching "Head type" in the "Note"
section of the Inspector: change the Head type from the default "Auto" to a specific duration.

Examples of notehead sharing

1. In the first example below, the notes of voices 1 and 2 share noteheads by default, because they are all black, undotted notes:

   ![Example 1](image1)

2. By contrast, in the next example, white notes cannot share noteheads with black notes, so are offset to the right:

   ![Example 2](image2)

   To create a shared notehead, make the black eighth note invisible or change its head type to match that of the white note (as explained above):

   ![Example 2 modified](image3)

Remove duplicate fret marks

In certain cases, a shared notehead, when pasted to a tablature staff, may result in two separate fret marks on adjacent strings. To correct this, make any extraneous tablature notes invisible by selecting them and using the keyboard shortcut V (or by unchecking the "visible" option in the Inspector).

External links

- [Shape notes](https://en.wikipedia.org/wiki/Shape_notes) at Wikipedia.
- [Ghost notes](https://en.wikipedia.org/wiki/Ghost_notes) at Wikipedia.

Parts

MuseScore allows you to not only create and print a full score but also to generate individual player's parts from it.

A part can be created from a specific instrument staff in the main score or even from a specific voice within a staff. This allows you to display multiple parts (e.g. Flute 1 & 2) on a single staff in the score but to extract them as separate parts.

Create all parts

The most straightforward method is to create all parts at once. Parts are generated on a one-to-one basis from the corresponding instruments in the score:

1. From the menu, select File → Parts...
2. Click All Parts (MuseScore 3.2-3.3.4: Generate; prior to MuseScore 3.2: New All) (parts are named with the instrument name, and a number added to differentiate parts that have the same label in the main score).
3. Click OK.

The parts can now be accessed by clicking on tabs above the document window.

Create specific parts

This method allows you to generate specific parts for only selected instruments (rather than all-at-once):

1. In the Parts window click Single Part (prior to MuseScore 3.4 New) to create a part;
2. In the center pane, type the words you want to use for the "Part title" (this also serves for the corresponding part of the filename when exporting);
3. Pick the instrument that you want to appear in your part from the "Instruments in Score" pane, and press + to add it to the "Instruments in Part" pane.

If you wish to create more parts, repeat steps 1 through 3 (above) for each part.

4. Click OK to save the parts.

You have now finished setting up the parts. You do not need to do this again, unless you add or remove an instrument from your full score.

Customize parts

Once you have generated a part (or all parts), you can select any part at the top and use the controls at the bottom to control not only what instrument is in the part, but also which staves and voices within the instrument are included.
Add instruments to a part

To add instruments to an existing part:

1. Select the part in the "Parts" pane.
2. Select the instrument from the "Instruments in Score" pane.
3. Press + to add it to the "Instruments in Part" pane.

Remove instruments from a part

To remove instruments from an existing part:

1. Select the part in the "Parts" pane.
2. Select the instrument from the "Instruments in Part" pane.
3. Press - to remove the instrument.

Select staves for an instrument

To select the staves of an instrument to include in the part:

1. Select the part in the "Parts" pane.
2. Click the arrow next to the instrument in "Instruments in Part" to expand the listing to show all staves and voices of the instrument.
3. Select the staff to be removed.
4. Press - to remove it from the instrument.

Select voices for an instrument

1. Select the part in the "Parts" pane.
2. Click the arrow next to the instrument in "Instruments in Part" to expand the listing to show all staves and voices of the instrument.
3. Uncheck the voices to be removed.

Note: If you select only voice 1 for a given staff, then only the content in voice 1 for that staff will be included in the part. Thus, in order to share flute 1 & 2 on the same staff, you will need to enter all notes onto both voices, even in passages where they share content. You also cannot enter the two parts as chords in the passages where they share rhythms.
Delete a Part

1. Open the Parts dialog (File → Parts...);
2. Select the relevant Part in the “Parts” pane;
3. Press Delete.

Export parts

1. From the menu, select File → Export Parts...;
2. Navigate to the place you want them to be exported to and select the file format (PDF is the default);
3. For filename just enter whatever prefix is useful for all parts, or leave the default (the filename of your score);
4. Click ok.

This will generate files with the names "<title>" + "." + "<part name>.<extension>". In addition, when exporting as PDF, this will also generate "<title>" + ".-Score_And_Parts.pdf".

Save parts

Parts and score are “linked”, which means that any change to the content in one will affect the other, but changes to the layout will not. When you have the parts created, they are saved along with the score (if you open the score you have tabs for the score and every part you created).

However, if you wish to save a part individually:

1. Make sure the part is “active.” Select its tab if not;
2. From the menu, select File → Save As....

Print a part

1. Make sure the part is “active.” Select its tab if not;
2. From the menu, select File → Print to open the print dialog.

Plugins

What are Plugins?

Plugins are small pieces of software that add a particular feature to MuseScore. By enabling a plugin, a new menu option is appended to the Plugins menu: subsequently, when this option is selected, the plugin performs a particular task in the score.

Some plugins come pre-installed with MuseScore—see Plugins installed by default (below). You can find many more plugins in the plugin repository: some work with MuseScore 3, others only with older versions of MuseScore, and some work with either. To tell one from the other: MuseScore 3.x and 2.x plugin code files have an extension of .qml; for older versions, it is .js.

Warning: Plugins can potentially contain bad or malicious code, which can compromise or damage your scores or system. Plugins are entirely unvetted (except for those that are installed by default). You either need to trust the author or check the code yourself.

Installation

Note: Some plugins may require the installation of other components (fonts, e.g.) to work. Check the plugin’s documentation for more information.

Most plugins are provided as ZIP archives: download the plugin’s .zip file and unzip (unzip) it to one of the directories mentioned below (depending on your OS). If the plugin is provided directly as an uncompressed .qml file, simply download it and place into one of the same directories.

Once a plugin is installed, it needs to be enabled in the Plugin Manager in order to use it—see Enable/disable Plugins.

Windows

MuseScore looks for pre-installed plugins in %ProgramFiles%MuseScore 3\Plugins (or %ProgramFiles(x86)%MuseScore 3\Plugins for the 32-bit versions) and in %LOCALAPPDATA%MuseScoreMuseScore 3\plugins on Windows 7 and later.

New plugins should not be installed in the above folders, and neither should the folders be modified. Instead add new plugins to %HOMEPATH%Documents\MuseScore3\Plugins; alternatively, specify a different folder to look for plugins in MuseScore’s Preferences.

macOS
On macOS, MuseScore looks for pre-installed plugins in the MuseScore bundle in `/Applications/MuseScore 3.app/Contents/Resources/plugins` (to reveal files in the app bundle, right click on MuseScore 3.app and choose “Show package contents”), and in `~/Library/Application Support/MuseScore/MuseScore 3/plugins`.

New plugins should not be installed in the above folders, and neither should the folders be modified. Instead add new plugins to `~/Documents/MuseScore3/Plugins`; alternatively, specify a different folder to look for plugins in MuseScore’s Preferences.

Linux

In Linux, MuseScore looks for pre-installed plugins in `/usr/share/mscore-3.0/plugins` and in `~/.local/share/data/MuseScore/MuseScore 2/plugins`.

New plugins should not be installed in the above folders, and neither should the folders be modified. Instead add new plugins to `~/Documents/MuseScore3/Plugins`; alternatively, specify a different folder to look for plugins in MuseScore’s Preferences.

Enable/disable plugins

To be able to access the installed plugins from the Plugins menu, they need to be enabled in the Plugin Manager:

You do this simply by checking the appropriate tick box. This adds the name of the plugin to the list in the Plugins menu.

Create/edit/run plugins

It is possible to create new or edit existing plugins and run them via the Plugin Creator:

Documentation of all available elements can also be found here.

Plugins installed by default
Some plugins come pre-installed with MuseScore, but they are not enabled by default. See Enable/disable plugins (above) to enable plugins.

**ABC Import**

This plugin imports ABC text from a file or the clipboard and converts it to MusicXML. Internet connection is required, because it uses an external web-service for the conversion.

**Notes → Color Notes**

This demo plugin colors notes in the selected range (or the entire score), depending on their pitch. It colors the note head of all notes in all staves and voices according to the Boomwhackers convention. Each pitch has a different color. C and C♯ have a different color. C♯ and D♭ have the same color.

To color all the notes in black, just run that plugin again (on the same selection). You could also use the ‘Remove Notes Color’ plugin for this.

**Create Score**

This demo plugin creates a new score. It creates a new piano score with 4 quarter notes: C, D, E, F. It’s a good start to learn how to make a new score and add notes from a plugin.

**helloQml**

This demo plugin demonstrates some basic tasks.

**Notes → Note Names**

This plugin names notes in a selected range or for the entire score. It displays the names of the notes (as staff text) according to MuseScore’s language settings: voices 1 and 3 notes above the staff; voices 2 and 4 notes below the staff; and chord notes in a comma separated list, starting with the top note.

**Panel**

This demo plugin creates a GUI panel.

**random/random2**

Creates a random score.

**run**

This demo plugin runs an external command. Probably this will only work on Linux.

**scorelist**

This test plugin iterates through the score list.

**ScoreView**

Demo plugin to demonstrate the use of a ScoreView

**Walk**

This test plugin walks through all elements in a score

**See also**

- Tools

**External links**

- Plugins for 3.x

**Preferences**

You can customize many of MuseScore’s default behaviors via the menu Edit → Preferences… (Mac: MuseScore → Preferences…).

The Preferences dialog has multiple tabs:
Reset All Preferences to Default will reset all preferences to the ones MuseScore had when you installed it. Ok will save the settings and close the dialog. Cancel will close the dialog without applying changes. Apply will make changes take effect without closing the dialog.

General

Here you can define:

- **Program Start**: Tick the boxes as appropriate to specify which score and what panels (Play Panel, Navigator, Start Center) you want to see when MuseScore opens. Also select if Tours will be active.
- **Folders**: Specify the default folders for score files, style files, custom score templates, plugins, additional SoundFonts, images, and extensions.
- **Language**: Choose the language used by the program. Translations may be updated from here too. Note that language translation updates can also be done via the menu: Help → Resource Manager.
- **Telemetry**: Tick/untick to authorize MuseScore to collect usage data. The type of data collected is listed, and updated as needed, in telemetry.
- **Theme**: Specify a dark or light theme, and the width and height of icons. Set display "Font face" and "Font size".
- **Auto Save**: How frequently the program autosaves.
- **OSC Remote Control**

Canvas
Use Canvas to set your preferred color and wallpaper for the score background and paper. The default "Background" is dark blue (RGB 20, 36, 51; Alpha 255) and the default "Paper," white.

- **Background**: Use this to set the color or background around the score pages. Select "Color" then click on the bar to the right and make a choice from the color picker; or select "Wallpaper," click on the file icon and set a background image.
- **Paper**: Sets the color or background of the score pages. Controls identical to "Background" (above). You can also tick/untick "Use the same color in palettes".
- **Scroll Pages**: This defines the way that the pages are laid out in the score. Choose "Horizontally" for a row layout, or "Vertically" for a column layout. To limit scrolling, tick "Limit scroll area to page borders".
- **Miscellaneous**: "Draw antialiased" (the default option) makes diagonal lines and edges of shapes look smoother. "Proximity for selecting elements" controls the distance the mouse may be from an object and still act on it. Smaller numbers require more precision, making it harder to click on small objects. Larger numbers are less precise, making it harder not to click on nearby objects unintentionally. Choose a comfortable working value.

**Note input**

On this tab there are note input and MIDI remote control preferences. Here the following can be set:

**Note Input**
- **Enable MIDI Input**: Leave checked to allow MIDI input of notes.
- **Color notes outside of usable pitch range**: For details, see [Coloring of notes outside an instrument’s range](#) and **Usable pitch range** (Staff properties: all staves).
- **Delay between notes in automatic real-time mode**: See [Real-time (automatic)](#).
- **Play notes when editing**: When ticked, MuseScore **sounds** the note when it is entered or selected. Tick “Play whole chord when adding note,” if you want to hear all the notes of a chord when it is added to. You can also edit the "Default duration".

**MIDI Remote Control**

**Midi Remote Control** allows you to use certain keys on your MIDI keyboard to enter notes and rests and to select note durations, without involving the computer mouse or (computer) keyboard. The default setting is off.

**To assign a command to a MIDI key:**

1. Ensure that "MIDI Remote Control" is checked (your MIDI keyboard should be connected before opening the program).
2. Click the red button next to the option you wish to assign a MIDI key to: the red button now lights up.
3. Press a MIDI keyboard key. The red button becomes unlit and the green button lights up instead. The MIDI key has now been assigned to the desired option.
4. Repeat “2” and “3” to assign other keys.

Once you have defined your key settings you can use the MIDI keyboard to control note input operations. You can verify your key settings by observing the MuseScore **Note Input toolbar** while pressing the MIDI keys.

To temporarily deactivate Midi Remote Control: uncheck "Midi Remote Control": all MIDI input key action buttons are now greyed out. **Note**: Your key assignments are always saved between MuseScore sessions and are not affected by deactivation.

**Notes**: (1) The “Clear” option turns off all the green buttons for the current MuseScore session but all the user-recorded MIDI key settings are retained and will be reloaded on the next session. (2) A MIDI key setting that is activated cannot afterwards be turned off, and the green button will always remain lit: however it can be overwritten with a different MIDI key by using the red button again. (3) If the same MIDI key is accidentally assigned to more than one option, then all the associated green buttons remain lit although only one will work. To fix, see "(2)".

**Score**

![MuseScore Preferences](image)

Score preferences include

- Default instrument list files (two may be selected)
- Default style for score and parts (see Load/Save Style)
- Default zoom

**I/O**
PortAudio (API / Device)

This enables you to set the audio interface (API) and specify the device to be used for audio playback: e.g. built-in speakers/headphones, USB headset, wireless, etc.

MIDI Input/Output/Output Latency

When an external MIDI input device is connected, its identifier appears in MIDI Input. When the device is connected for the first time, you also need to select the correct MIDI Output option in order to enable note input and correct audio playback (e.g. in Windows, this might be "MMS<device name>"): then close and reopen the program to confirm the changes.

Jack Audio Server

Check these options as required if using the JACK Audio Connection Kit.

Audio Engine

In case of lost communication between your audio device or your MIDI keyboard and MuseScore (no sound output or MIDI action), click on Restart Audio and MIDI Devices to restore them.

Import
These settings determine how files from other sources are imported:

- Using either the built in MuseScore style or a style you choose (see Load/Save Style)
- Guitar Pro and Overture character sets
- MusicXML layout options
- Shortest note in MIDI files

**Export**

These settings determine how various files are exported from MuseScore:

- **PNG**: PNG/SVG image resolution (in DPI) and whether to use transparent background.
- **MIDI**: Whether to expand repeats in exported MIDI files.
- **Audio**: Set audio sample rate, MP3 bitrate, and whether to "normalize" exported audio.
- **MusicXML**: Whether to export the layout and how to export system and page breaks to MusicXML.

**Shortcuts**
This tab lists all the commands in MuseScore and any keyboard shortcuts associated with them. Shortcuts listed in preferences also appear next to their associated commands in the menus.

- **To search for a particular command**: Enter its name in the “Search” box near the bottom of the window.

- **To create a new shortcut for a command**
  1. Select an existing entry in the list.
  2. Click Define...; or just double click the entry.
  3. Enter the new shortcut using up to four keys. Press Clear if you need to re-enter the shortcut.
  4. Press Replace to change the existing shortcut; or Add, to keep the old shortcut and add the new one.

  **Note**: Some shortcuts, including default ones, may not work with some keyboards.

- **To reset a shortcut to its system default**: Select a command in the list and press Reset Shortcut to Default.

- **To save the shortcuts list**: Press Save and save to a file name of your choice.

- **To load a saved shortcuts list**: Press Load etc.

- **To clear all shortcuts for an entry**: Select the entry and press Clear.

- **To print out the shortcuts list** (incl. export to pdf): Press Print etc.

**Update**
This sets whether MuseScore will check for updates and extensions at startup.

Updates may be checked manually in Help → Check for updates.

Advanced

Allows you to control specific settings for "application, "export", "i/o" and "user interface", as well as color settings.

See also

- Keyboard shortcuts
- Language settings and translation updates
- Update checking

Recovered files

If MuseScore or your computer should crash, or if power is lost, a pop-up message upon restarting MuseScore will ask if you wish to restore the previous session:
Click Yes, to initiate attempted recovery of files from the interrupted session. Or click No to ignore message.

Saving after session recovery

When MuseScore recovers files after a crash, it renames them with the full path name added in front of the original file name. This very long name will appear in the tab(s) above the active score window.

To ensure that the file is saved in its original location. You should immediately save the restored file using the "Save As..." option: this will open a window to allow you to navigate to the correct folder and directory. If you use the "Save" command instead, the file will be saved in its current location which is unlikely to be the original one.

Finding recovered files

In the event that "Save" is used instead of "Save As..." with a recovered file, you will have to find the files in your computer. The actual location of those files will vary, depending on your operating system, and in which directory MuseScore is installed.

For Windows 7, with a default installation of MuseScore to the x86 program files directory, recovered files are auto-saved to C:\Program Files (x86)\MuseScore 2\bin (actually %ProgramFiles(x86)\MuseScore 2\bin).

For Windows 10, look in C:\Users\[User Name]\AppData\Local\VirtualStore\Program Files (x86)\MuseScore 2\bin (actually %LOCALAPPDATA%\VirtualStore%ProgramFiles(x86):~3\MuseScore 2\bin).

You may need to run a system-wide search in order to find files saved directly after a session recovery. Use keywords from the original file name as well as wildcards, and specify the date modified.

See also

Save/Export/Print

External links

How to recover a backup copy of a score

Score Comparison

The Score Comparison Tool allows you to compare two versions of a score to find the differences between them.

Introduction

To open the Score Comparison Tool:

- From the menu, select View → Score Comparison Tool.

The dialog opens below the document window and consists of three sections (left to right):

- Choose scores to compare: Select the scores you want to compare.
- Diff mode: Select how to view the comparison.
- Comparison: A line by line comparison of the scores is displayed.
Select score

The first step is to select the score. Use the combo box next to "Score 1" to choose between the currently open scores, or click on the browse button to open the File Explorer and select a score from disk. Secondly, use the next combo box on the right to choose whether the first score should be the current version, or the last saved version. Score 2 is set to the same score you selected for Score 1, but you may choose another of the open scores.

When you have selected the scores and versions press Compare to do the comparison.

Choose view

"Intelligent comparison" is the default option in Diff mode: this displays the differences between the scores in a human-readable format (e.g. "Measure 1: Note: property pitch changed from B4 to C5"). Change the Diff Mode selection to "Raw" if you prefer to see the results displayed in XML code.

View comparison

When you press Compare a list of differences will be displayed to the right, and the score view will automatically change to Documents Stacked. In the Comparison section, double-click on a difference from the list and both score views will automatically pan to show you the changed element, which will also be highlighted.

Leave comparison

To exit the Score Comparison tool, turn off the two options "Score Comparison Tool" and "Documents Stacked" in the View menu.

Example

Below you will see two small scores with a few differences between them.

Last saved:

Current:

The result of the comparison will look like this:

| Measure 1: inserted element Rest | Measure 1: inserted element Chord |
| Measure 1: Chord: markup changes: durationType | Measure 1: Chord: markup changes: durationType |
| Measure 1: Note: property pitch changed from E5 to G5 | Measure 2: inserted element Hairpin |

Score properties

The Score Properties dialog contains document meta tags such as "workTitle," "Composer," "Copyright" etc. To view the dialog:

1. Make sure that the applicable score or instrument part is the active tab;
2. From the menu, select File → Score Properties.

Several meta tags are generated automatically when you create a score using the New Score Wizard, and others may be added later. Meta tags can also be incorporated into a header or footer if required—see below.

Edit meta tags

1. Make sure that the applicable score or instrument part is the active tab;
2. From the menu, select File → Score Properties;
3. Edit the text of the various meta tags as required;
4. To add another meta tag, click on the New button. Fill in the "New tag name" field and press OK;

Pre-existing meta tags

Every score displays the following fields in Score Properties:

- **File Path**: The score file's location on your Computer.
- **MuseScore Version**: The version of MuseScore the score was last saved with.
- **Revision**: The revision of MuseScore the score was last saved with.
- **API-Level**: The file format version.
- **arranger**: (empty)
- **composer**: This is initially set to the same text as "Composer" on the first page of the New Score Wizard.
- **copyright**: This is initially set to the same text as "Copyright" on the first page of the New Score Wizard.
- **creationDate**: Date of the score creation. This could be empty, if the score was saved in test mode (see Command line options).
- **lyricist**: This is initially set to the same text as "Lyricist" on the first page of the New Score Wizard.
- **movementNumber**: (empty)
- **movementTitle**: (empty)
- **originalFormat**: This tag exists only if the score is imported (see file formats).
- **platform**: The computing platform the score was created on. This might be empty if the score was saved in test mode.
- **poet**: (empty)
- **source**: May contain a URL if the score was downloaded from or saved to MuseScore.com.
- **translator**: (empty)
- **workNumber**: (empty)
- **workTitle**: This is initially set to the same text as "Title" on the first page of the New Score Wizard.

Entering Work / Movement / Part metadata

- **workNumber** is the number of the larger work (e.g. 8—for "The Four Seasons," Op. 8, by Vivaldi).
- **workTitle** is the title of the larger work (e.g "The Four Seasons,").
- **movementNumber** is the number of the movement in the larger work (e.g. 3 for Autumn).
- **movementTitle** is the title of the movement in the larger work (e.g."Autumn").

It is customary, when using the New Score Wizard, to create a work with the **movementTitle** as title (even though it ends up in **workTitle** then) and, directly after creating the score, amending this information in the Score Properties dialogue.

Every part additionally has the following meta tag, generated and filled on part creation:

- **partName**: The name of the part as given on part creation (which is also used to fill the corresponding part name
text in the top vertical frame—be aware that later changes to one are not reflected in the other.

**Header/Footer**

To show the content of one or more meta tags in a header or footer for your score/part:

1. Make sure that the correct score or instrument part is the active tab;
2. From the menu, select Format → Style... → Header, Footer:

![Image of Header and Footer settings dialog]

If you hover with your mouse over the Header or Footer text region, a list of macros will appear, showing their meaning, as well as the existing meta tags and their content.

<table>
<thead>
<tr>
<th>Special symbols in header/footer:</th>
</tr>
</thead>
<tbody>
<tr>
<td>$p$ - page number, except on test page</td>
</tr>
<tr>
<td>$SN$ - page number, if there is more than one page</td>
</tr>
<tr>
<td>$SP$ - page number, on all pages</td>
</tr>
<tr>
<td>$n$ - number of pages</td>
</tr>
<tr>
<td>$f$ - file name</td>
</tr>
<tr>
<td>$f$ - file path- name</td>
</tr>
<tr>
<td>$d$ - current date</td>
</tr>
<tr>
<td>$D$ - creation date</td>
</tr>
<tr>
<td>$m$ - last modification time</td>
</tr>
<tr>
<td>$M$ - last modification date</td>
</tr>
<tr>
<td>$C$ - copyright, on first page only</td>
</tr>
<tr>
<td>$c$ - copyright, on all pages</td>
</tr>
<tr>
<td>$S$ - the $S$ sign here</td>
</tr>
<tr>
<td>$Stag$ - meta data tag, see below</td>
</tr>
</tbody>
</table>

- Available meta data tags and their current values:
  - arranger:
  - composer:
  - copyright:
  - creationDate: 2016-03-02
  - lyricist:
  - movementNumber:
  - movementTitle:
  - platform:
  - poet:
  - source:
  - translator:
  - workNumber:
  - workTitle: Test

3. Add tags (e.g. $:workTitle:$) and macros (e.g. $M$) to the appropriate boxes, as required;
4. Click Apply to see how the header or footer looks in the score. Make corrections to the dialog if required;
5. If an instrument part is in the active tab, click Apply to all parts, if you want to apply these settings to all the score parts;
6. Click OK to assign the header or footer and exit the dialog.

See also

- Layout and formatting: Header and footer
- Command line options: Test mode

**Staff / Part properties**

The **Staff / Part Properties** dialog allows you to make changes to the display of a staff, adjust its tuning and transposition, change instrument etc. To open:
Right-click on a staff and select Staff/Part Properties...

Staff / Part Properties dialog, as of version 3.0.

Staff Types

For practical purposes, there are four different types of staff:

1a. **Standard staff I**. A pitched staff used for most instruments except fretted, plucked-string ones.
1b. **Standard staff II**. A pitched staff containing a *fretted, plucked-string instrument*, with options to set the number of instrument strings and tuning.
2. **Tablature staff**. A staff containing a *fretted, plucked-string instrument*, which displays music as a series of fret-marks on strings. Also contains options to set the number of instrument strings and tuning.
3. **Percussion staff**. A pitched staff for percussion instruments.

It is possible to change one type of staff into another using the **Instruments** dialog, as long as the original staff is loaded with the right instrument. For example, in order to change a standard staff to tablature, it must contain a plucked-string instrument. Similarly, to change a standard staff to a percussion staff you need to ensure that it has an appropriate percussion instrument loaded and so on.

Most options in the Staff / Part properties dialog are common to all staves, but each type also has one or two specific options of its own.

**Staff / Part Properties: all staves**

The following Staff Properties options are common to all staves:

**Lines**
The number of lines making up the staff.

**Line Distance**
The distance between two staff lines, measured in spaces (abbr.: sp.). **Note**: It is not recommended to change this value from the default shown. If you need to make the staff larger or smaller, use the Page Settings dialog instead.

**Extra distance above staff**
Increases or decreases the distance between the selected staff and the one above in all systems. **Note**: This setting does not apply to the top staff of a system, which is controlled by the minimum/maximum system distance (see Layout and formatting: Format → Style → Page).

**Notes**: To alter the spacing above just one staff line in a particular system, see **Breaks and Spacers**.

**Scale**
Changes the size of the selected staff and all associated elements, as a percentage (to adjust the overall score size, use
Scaling from the Format → Page Settings… menu).

Hide when empty
Together with the "Hide empty staves" setting in Format → Style → Score, this determines if the staff will be hidden when it is empty.

Possible values:
- **Auto** (default): The staff will be hidden if it is empty and "Hide empty staves" is set.
- **Always**: The staff will be hidden when empty, even if "Hide empty staves" is not set.
- **Never**: The staff will never be hidden when empty.
- **Instrument**: For instruments containing multiple staves, the staff is hidden only if all staves for that instrument are empty.

Show clef
Whether the staff clef will be shown.

Show time signature
Whether the staff time signature(s) will be shown or not.

Show barlines
Whether the staff barlines will be shown.

Hide system barline
Show/hide barline at left-hand edge of the staff.

Do not hide if system is empty
Never hide this staff, even if the entire system is empty. This overrules any "Hide empty staves" setting in Format → Style → Score.

Small staff
Create a reduced-size staff. You can set the default from the menu in Format → Style → Sizes.

Invisible staff lines
Make staff lines invisible.

Staff line color
Use a color picker to change the color of the staff lines.

Cutaway
Used to create a cutaway staff in which only measures containing notes are visible (e.g. ossias [Wikipedia]; or cutaway scores). This can be used independently of "Hide when empty" or "Hide empty staves".

Instrument
The instrument loaded in the Instruments dialog or Select Instrument dialog. The sound associated with this instrument can be changed, if desired, in the Mixer.

*Note:* The properties below (i.e. Part Name, Long Instrument Name etc.) are set to the default values defined in the MuseScore instruments.xml file. If trackName has not been defined, the value of longName (i.e. "Long instrument name"—see below) is used instead.

Part name
The name of the part. This is also displayed in the Mixer and the Instruments dialog. Any edits you make to the Part name affect only that particular instrument and no other.

Long instrument name
Name displayed to the left of the staff in the first system of the score. The long instrument name may also be edited directly as a text object (see Text editing).

Short instrument name
Name displayed to the left of the staff in subsequent systems of the score. The short instrument name may also be edited directly as a text object (see Text editing). Editing affects all occurrences in the score.

Usable pitch range
- **Amateur**: Notes outside this range will be colored olive green/dark yellow in the score.
- **Professional**: Notes outside this range will be colored red in the score.

To disable out-of-range coloration of notes: From the menu, select Edit → Preferences… (Mac: MuseScore → Preferences…), click on the "Note Input" tab, and uncheck "Color notes outside of usable pitch range."

See also, Coloring of notes outside an instrument's range.
Transpose written pitches to sound
This option ensures that the staves of transposing instruments display music at the correct written pitch. Set the transpose in term of a musical interval (plus octave if required) up or down.

Use single note dynamics (as of version 3.1)
Leave ticked to allow playback of single note dynamics (such as sfz etc.) and hairpins, diminendo and crescendo lines on single (or tied) notes.

Navigation arrows
Use the ↑ and ↓ buttons, at the bottom left of the Staff Properties window, to navigate to the previous or next staff.

Staff / Part Properties: plucked strings only

Number of strings
Displays the number of instrument strings.

Edit String Data...
This button opens a dialog box which allows you to set the number and tuning of strings. See Change string tuning.

Advanced Style Properties
Clicking the Advanced Style Properties... button opens a window giving access to advanced display options for the staff. These will vary depending on the staff type chosen: see the relevant sections below for details.

Template
At the bottom of the Advanced Style Properties dialog there are a number of buttons which allow you to easily change the following:

- The number of lines displayed by a percussion staff
- The staff type of a plucked-string instrument For example, you can change from standard staff to tablature and vice versa, or select from a number of tablature options.

1. Make a selection from the drop-down list labelled “Template”;
2. Press < Reset to Template >;
3. Press OK to accept the changes and exit the dialog (or Cancel to cancel the operation).

Standard and Percussion staff options

Show clef / time signature / barlines / key signature / ledger lines
Option to turn the display of these elements ON or OFF.

Stemless
If checked, staff notes will have no stem, hook or beam.

Notehead scheme
See Notehead scheme.

Tablature staff options

Upside down
If not checked, the top tablature line will refer to the highest string, and the bottom tablature line to the lowest string (this is the most common option). If checked, the top tablature line refers to the lowest string, and the bottom tablature line to the highest line (e.g. Italian-style lute tablatures). For example:

![Tablature Example]

‘Upside down’ tablature.

Tablature staff options: Fret Marks

Fret marks are the numbers or letters used to indicate the location of notes on the fingerboard. The following group of properties define the appearance of fret marks:

Font
The font used to draw fret marks. 8 fonts are provided supporting all the necessary symbols in 8 different styles (modern Serif, modern Sans, Renaissance, Phalèse, Bonneuil-de Visée, Bonneuil-Gaultier, Dowland, Lute Didactic).

**Size**
Font size of fret marks in typographic points. Built-in fonts usually look good at a size of 9-10pt.

**Vertical offset**
MuseScore tries to place symbols in a sensible way and you do not usually need to alter this value (set to 0) for built-in fonts. If the font has symbols not aligned on the base line (or in some other way MuseScore does not expect), this property allows you to move fret-marks up (negative offsets) or down (positive offsets) for better vertical positioning. Values are in sp.

**Marks are**
Choice of Numbers (‘1’, ‘2’...) or Letters (‘a’, ‘b’...) as fret marks. When letters are used, ‘j’ is skipped and ‘k’ is used for the 9th fret.

**Marks are drawn**
Choice of placing fretmarks On lines or Above lines. For example:

![Fretmark letters placed above line.](image)

**Lines are**
Choice of Continuous (lines pass through fret marks) or Broken (a small space appears in the line where the fretmark is displayed). For example:

![Tablature with lines broken.](image)

**Show back-tied fret marks**
If unticked, only the first note in a series of tied notes is displayed. If ticked, all notes in the tied series are displayed.

**Show fingering in tablature**
Tick to allow the display of fingering symbols applied from a palette.

**Tablature staff options: Note Values**
This group of properties defines the appearance of the symbols indicating note values.

**Font**
The font used to draw the value symbols. Currently 5 fonts are provided supporting all the necessary symbols in 5 different styles (modern, Italian tablature, French tablature, French baroque (headless), French baroque). Used only with the Note symbols option.

**Size**
Font size, in typographic points. Built-in fonts usually look good at a size of 15pt. Used only with the Note symbols option.

**Vertical offset**
Applies only when Note symbols is selected (see below). Use negative offset values to raise the note value symbols, positive values to lower them.

**Shown as:**
- **None**: No note value will be drawn (as in the examples above)
- **Note symbols**: Symbols in the shape of notes will be drawn above the staff. When this option is selected, symbols are drawn only when the note value changes, without being repeated (by default) for a sequence of notes all of the same value. E.g.
• **Stems and beams**: Note stems and beams (or hooks) will be drawn. Values are indicated for each note, using the same typographic mechanics as for a regular staff; all commands of the standard Beam Palette can be applied to these beams too. E.g.

```plaintext
\text{\begin{align*}
\text{\textbf{2}} & \text{3} \\
\text{\textbf{4}} & \text{5} \\
\text{\textbf{6}} & \text{7} \\
\text{\textbf{8}} & \text{9} \\
\end{align*}}
```

**Repeat:**

If several notes in sequence have the same duration, you can specify if and where to repeat the same note symbol. I.e.

- **Never**
- **At new system**
- **At new measure**
- **Always**

**Note**: This option is only available if "Shown as: Note symbols" is selected (see above).

**Stem style:**

- **Beside staff**: Stems are drawn as fixed height lines above/below the staff.
- **Through staff**: Stems run through the staff to reach the fret marks.

**Note**: This option is only available when "Shown as: Stems and Beams" is selected (see above).

**Stem position:**

- **Above**: Stems and beams are drawn above the staff.
- **Below**: Stems and beams are drawn below the staff.

**Note**: This option is only available when "Shown as: Stems and Beams" and "Stem style: Beside staff" is selected (see above).

**Half notes:**

- **None**
- **As short stems**
- **As slashed stems**

**Note**: This option is only available when "Shown as: Stems and Beams" and "Stem style: Beside staff" is selected (see above).

**Show rests**

Whether note symbols should be used to indicate also the rests; when used for rests, note symbols are drawn at a slightly lower position. Used only with the *Note symbols* option.

**Preview**

Displays a short score in tablature format with all the current parameters applied.

**Change instrument**

You can change any instrument in a score to a different instrument at any time. The following method updates instrument sound, staff name, and staff transposition all at once.

1. Right-click on an empty part of any measure OR on the instrument name and choose Staff Properties...
2. Click on Change Instrument... (under "Part Properties");
3. Choose your new instrument and click OK to return to the Staff Properties dialog;
4. Click OK again to return to the score.

*Not to be confused with Mid-staff instrument change.*

**External links**

- [How to turn a staff into an ossia](#)

**Staff Type Change**

You can change the appearance of a staff mid-score by adding a **Staff type change** element to a measure, and adjusting
its properties in the Inspector.

Add a Staff Type Change

1. Select a measure in the score and, in the "Text" palette, click (double-click prior to version 3.4) the "Staff type change" symbol, $\text{staff change}$; alternatively, drag the "Staff type change" icon onto a measure;
2. Select the symbol, and adjust its properties (see below) in the Inspector as required.

Staff type change properties

When you alter a Staff type change property in the Inspector, the new value takes precedence over the value shown in the global Staff properties dialog. Only those property values in "Staff Properties" that cannot be changed in the "Staff type change" dialog will be valid throughout the score.

The properties that can be altered in the Staff type change dialog in the Inspector are:

**Offset**
How far the changed staff shall be moved up or down: measured in spaces (abbr.: sp).

**Small**
Tick the box to create a reduced-size staff.

**Scale**
Changes the size of the staff and all associated elements, as a percentage.

**Lines**
The number of lines making up the staff.

**Line distance**
The distance between two staff lines, measured in spaces (abbr.: sp).

**Step offset**
How many steps up or down the notes in the staff are offset.

**Show barlines**
Whether the staff barlines will be shown.

**Show ledger lines**
Whether ledger lines will be shown for notes above/below the staff lines.

**Slash style**
Whether the notes shall be shown in standard or slash style.

**Notehead scheme**
Allows selection of how noteheads are displayed.

**Generate clefs**
Whether the staff clef will be shown.

**Generate time signatures**
Whether the staff time signature(s) will be shown or not.

**Generate key signatures**
Whether the staff key signatures will be shown or not.

Example

To illustrate the use of Staff type change, the staff shown below was created using the following steps:

1. Add a Staff type change to measure 2.
2. Set size to "Small".
4. Add a second Staff Type Change to measure 3.
5. Change "Lines" to 7,
Afterwards the global Staff Properties are changed using Staff properties:

1. Set "Lines" to 2.
2. Change "Staff Line Color".

As can be seen, the change in "Lines" is only effective up to the first staff type change, whereas the change to "Staff Line Color" is effective throughout the score.

Timeline

Introduction

The timeline was developed as part of the Google Summer of Code 2017, and is included for the first time in MuseScore 3.0.

Overview

The timeline is a navigation tool that displays an abstraction of the score to the order of measure numbers and instrument names. There are four parts to the timeline:

Meta labels

This is found in the top left corner of the timeline. These are the names of the meta rows.

Instrument labels

This is found in the bottom left corner of the timeline. These are the names of the rows in the main grid.

Meta rows

This is found in the top right corner of the timeline. These hold the meta values of the score.

Main grid

This is found in the bottom right corner of the timeline. This holds multiple 'cells' (a specific measure and staff in the score represented as a square)

Meta

Meta are elements found on the score that are not notes, but are still important to the score (key signature, time signature, tempo, rehearsal marks, bar lines, and jumps and markers).

Basic interaction

Select a measure

To select a measure in the timeline, press the mouse button on the cell. A blue box will appear around the selected cell and the respective measure in the score will be selected. The score view will place the selected measure in view.

Select multiple measures

Drag selection

Holding Shift and holding the left mouse button and dragging the mouse over the main grid will create a selection box. Upon releasing the mouse button, all the cells underneath the selection box will be selected, as well as all the measures in the score.
If a cell is already selected, holding Shift and selecting another cell in the timeline will stretch the selection to that new cell, similar to how the score does.

If no cells are currently selected, holding Ctrl and selecting a cell will select the entire measure.

Clearing selection

To clear selection, holding Ctrl and clicking anywhere on the grid or the meta rows will clear any current selection.

Meta values selection

Selecting the meta values on the timeline will attempt to select the respective meta values in the score.

Scrolling

Standard scrolling

Scrolling the mouse wheel up or down will move the grid and instrument labels down or up respectively. The meta labels and rows do not move.

[Shift] scrolling

Holding Shift and scrolling the mouse wheel up or down will move the grid and meta rows left or right respectively. The meta labels and instrument labels do not move.

[Alt] scrolling

Holding Alt and scrolling the mouse wheel up or down will move the grid and meta rows left or right respectively, faster than Shift scrolling. The meta labels and instrument labels do not move.

Dragging

To drag the contents of the timeline, hold the left mouse button and move it around.

Labels interaction

Rearranging meta labels

All meta labels besides the measures meta may be rearranged in any way. By moving the mouse cursor onto one of the meta labels, small up and down arrows will appear. Click the left mouse button on the up arrow to swap the meta label with the one above it. Click the left mouse button on the down arrow to swap the meta label with the one below it.

Collapsing the meta labels

In order to hide all the meta labels while keeping all the meta information on the timeline, there is an arrow that appears on the measures meta when the mouse is over it. Click the left mouse button on the large up arrow to collapse all the currently visible meta rows into one row, where the meta values are staggered in that row. Click the left mouse button on the large down arrow to expand the meta rows again.

Hiding instruments

All instruments--hidden or not--will be displayed on the timeline. To start this interaction, the mouse cursor is moved over an instrument label. A small eye will appear on the right side of the label that is open if the instrument is visible on the score, and closed if the instrument is hidden. Click the left mouse button on the eye to toggle between the two options.
Zooming

To zoom in or out of the score, hold Ctrl and scroll the mouse wheel up or down respectively.

Context menus

To bring up a context menu, right click on the timeline. There are three context menus found in these locations: meta labels, instrument labels, and meta rows.

Meta labels context menu

Upon clicking the right mouse button on the meta labels, a context menu appears that displays all possible meta labels as well as two options: “Hide all” and “Show all.” Next to each meta label in the menu, there is a check box that shows if the meta label is currently being shown on the timeline. To show or hide one of the meta labels, select the box of the meta label in the context menu. Selecting “Hide all” will hide all meta labels except for the measures meta. Selecting “Show all” will display all meta labels.

Meta rows context menu

Clicking the right mouse button on the meta rows will display the same context menu as the meta labels.

Instrument context menu

Clicking the right mouse button on the instrument labels will display a context menu with the option to “Edit Instruments.” Selecting this will bring you to the same dialog as Edit > Instruments... or pressing I for the shortcut.

Tools

A number of useful commands can be found in the Tools menu.

Transpose

This opens the Transpose dialog with various options for transposing passages of music.

See Automatic transposition.

Explode

The explode command allows you to select a passage of music in a single staff and split (explode) the chords into their constituent notes or voices as follows:

- If the passage is all in voice 1, the top note of the chord is retained on the top staff, while the lower notes are moved to subsequent staves.
- If the passage contains multiple voices, voice 1 notes are retained on the top staff, while other voices are moved to subsequent staves. All exploded voices are now in voice 1.

To explode a section of the score:

1. Ensure that there are enough staves underneath the source staff to receive the exploded notes. Create extra staves if necessary using the Instruments dialog.
2. Choose one of two options:
   - Select a range of measures in the source staff: this allows all notes to be exploded if there are enough staves available.
   - Select a range of measures that includes both the source staff and also extends downwards to include one or more destination staves: This limits the number of exploded notes/voices to the number of selected staves.
3. Choose Tools → Explode.

Notes: (1) If the selection is all in voice 1, MuseScore will discard the lowest note(s) of any chord that contains more notes than the number of staves in the selection. (2) If the selection is all in voice 1, and if a given chord has fewer notes than
the number of destination staves, then notes will be duplicated as needed so that every staff receives a note. (3) Any existing music in the destination staves is overwritten. (4) If you select a partial measure, the explode command will automatically expand it to a full measure.

**Implode**

The **Implode** command works in the opposite way to "explode":

- With *one staff* selected, all notes in voices 1–4 are combined into voice 1.
- With *multiple staves* selected, the notes in the *second staff* are copied to the first available voice in the *top staff*, the notes in the *third staff* are copied to the next available voice in the *top staff* and so on.

**Apply implode to a single staff**

1. **Select** a range of measures in the desired staff.
2. **Choose** Tools → Implode.

All selected notes in the staff are now displayed in voice 1.

**Apply implode to multiple staves**

1. Ensure that there is only one voice in each staff.
2. **Select** a range of measures in the *destination staff* and extend this selection downwards to include the other staves to be imploded.
3. **Choose** Tools → Implode.

**Voices**

This allows you to swap the voices of a selected measure-range of notes. See [Exchange voices](#).

**Measure**

Join or split measures. See [Measure operations: Split and join](#).

**Remove selected range**

This command is used to completely remove an element, or range of elements from the score.

**To remove measures (including partial measures):**

1. **Select** a range of notes/rests, or a range of measures;
2. Use one of the following methods:
   - Press **Ctrl+Del**.
   - **Select** Tools → Remove selected range.

**Note:** If the selected range includes only part of a measure, the result will include a measure of smaller duration than the indicated *Time Signature*. This is indicated by a small - (minus) sign just above the system.

**To join measures:**

1. Select (i.e. click on) a barline;
2. Use one of the following methods:
   - Press **Ctrl+Del**.
   - **Select** Tools → Remove selected range.

The following table is a comparative summary of the **Delete** and **Remove selected Range** commands when applied to *single* elements:

<table>
<thead>
<tr>
<th>Selected Element</th>
<th>Apply Delete</th>
<th>Apply Remove selected range</th>
</tr>
</thead>
<tbody>
<tr>
<td>Note</td>
<td>Replaces with rest</td>
<td>Removes score section</td>
</tr>
<tr>
<td>Rest (voice 1)</td>
<td>No effect</td>
<td>Removes score section</td>
</tr>
<tr>
<td>Rest (voices 2-4)</td>
<td>Deletes rest</td>
<td>Removes score section</td>
</tr>
<tr>
<td>Barline</td>
<td>No effect</td>
<td>Deletes barline and joins measures</td>
</tr>
<tr>
<td>Measure</td>
<td>Replaces contents with rest</td>
<td>Removes measure</td>
</tr>
</tbody>
</table>

**Note:** To *insert* notes, see [Insert](#).
Fill with slashes

This command fills the selection with slashes, one per beat:

1. **Select** one or more measures;
2. From the menu, select **Tools → Fill With Slashes**.

If a measure is empty the slashes are added to voice 1, full-sized and centered on the middle line of the staff:

![Example of Fill With Slashes](image)

**Notes:** (1) If there are already notes in a measure in the selection, the command will put the slashes into the *first available empty voice*. (2) Voice 2 slashes are full-sized and centered on the middle line of the staff; voices 3 slashes appear *small and above* the staff; voice 4 slashes are *small and below* the staff. (3) If a measure contains notes in all 4 voices, voice 1 will be overwritten. (4) All slashes are set to not transpose or playback.

Toggle rhythmic slash notation

This command toggles selected notes between normal notes and rhythmic slash notation:

1. **Select** a range of notes or measures (Note: use the **selection filter** if you need to exclude certain voices);
2. From the menu, select **Tools → Toggle Rhythmic Slash Notation**.

The selected noteheads are changed to *slash noteheads* which do not transpose or playback.

![Example of Toggle Rhythmic Slash Notation](image)

Slash-notehead notes in voices *one or two* are fixed to the middle staff line; those in voices *three or four* are small (*“accent” notation*) and fixed above or below the staff:

![Example of Slash-Noteheads](image)

In *percussion staves*, notes in voices 3 and 4 are not converted to small slashes but to small notes above or below the staff.

![Example of Percussion Staves](image)

Respell pitches

Corrects accidentals to fit in with the current key signature. See **Accidentals: Respell pitches**.

Regroup Rhythms

This option corrects note *ties*, durations and *beaming* so that they are grouped according to standard music notation practice. For example:

Before:

![Example of Before](image)

After:

![Example of After](image)

Any notes that are tied and are the same length as a dotted note will be changed to the dotted note with two limitations. (i) Only the last note of a group of tied notes will have a single dot. Notes with more than one dot are not produced using this option. (ii) Dotted notes will not span from one group of beamed notes to another unless their duration is the same as all of the beam groups it covers. Any notes with more than one dot will be regrouped according to the above rules.
To apply:

1. **Select** the section of the score you want to reset. If nothing is selected, the operation will apply to the whole score;
2. **Select Tools → Regroup Rhythms.**

**Note:** This is an experimental feature and there are known bugs. Articulations and ornaments are deleted and some pitches respelled. Ties across barlines may be lost on UNDO.

**Resequence rehearsal marks**

The **Resequence Rehearsal Marks** command allows you to re-order the numbering/lettering of rehearsal marks if, for any reason, they have got out of sequence. For details see [Automatically resequence rehearsal marks](#).

**Unroll Repeats (version 3.1 and above)**

This command creates a copy of the score (in a new tab), eliminates the repeat barlines and notates the repeat sections in full instead.

**Copy lyrics to clipboard**

This command copies all the lyrics of the score to the clipboard:

- From the menu, select **Tools → Copy Lyrics to Clipboard.**

**Image capture**

Take a snapshot of a selected part of the document window. PNG, PDF and SVG formats are supported. See [Image capture](#).

**Remove empty trailing measures**

This automatically removes any blank measures at the end of the score.

See also

- [Breaks and spacers](#)
- [Rehearsal marks](#)

**External links**

- [How to merge/combine/implode two staves in one with two voices](#)

**Support**

This chapter describes how to find help using MuseScore: the best places to look, the best way to ask a question on the forums, and tips for reporting a bug.

**Helping to improve translations**

You can help translate the MuseScore software and documentation into your own language, as mentioned in [Development / Translating](#).

**Software translation**

1. Ask in the [forum to improve translation](#)
2. Connect to Transifex/MuseScore [http://translate.musescore.org](http://translate.musescore.org), which will redirect you to [https://www.transifex.com/projects/p/musescore](https://www.transifex.com/projects/p/musescore)
3. Select the language and then the section you want to help with (MuseScore, Instruments, Start Center or tours)
4. Click on the "translate" button (the button text will depend on your language...)
5. Search for "strings" (informational meaning) you want to translate (you could filter "already translated items")

Here is a technical explanation: [Continuous translation for MuseScore 2.0](#)

**Website and handbook translation**

See [Translation instructions](#)

See also
Revert to factory settings

MuseScore has the option to revert back to the standard built-in presets or "factory-settings". This can be necessary if your settings are corrupted. **Warning:** Reverting to factory settings removes any changes you have made to the preferences, palettes, or window settings. This is not a commonly needed procedure; consult the forums first, as there may be a way to solve your problem without resetting everything.

Via menu

If MuseScore still starts, it is possible to revert from within MuseScore. Go to Help → Revert to Factory Settings. A warning dialog will appear:

Clicking Yes resets all MuseScore's settings as if the program was installed for the first time, and MuseScore will immediately restart. No will safely cancel the revert.

Via command line

If MuseScore does not start, you must run this process via the command line.

**Instructions for Windows**

1. If you have MuseScore open, you need to close it first (File → Quit)
2. Type ⊞Win+R to open the Run dialog. Alternatively select "Start" using your mouse and type "run," then click the "Run" program.
3. Click Browse...
4. Look for MuseScore3.exe on your computer. The location may vary depending on your installation, but it is probably something similar to My Computer → Local Disk → Program Files → MuseScore 3 → bin → MuseScore3.exe
5. Click Open to leave the Browse dialog and return to the Run dialog. The following text (or something similar) should display in the Run dialog

   C:\Program Files\MuseScore 3\bin\MuseScore3.exe (actually %ProgramFiles%\MuseScore 3\bin\MuseScore3.exe)

   For the 32-bit version of MuseScore in a 64-bit version of Windows, the location is

   C:\Program Files (x86)\MuseScore 3\bin\MuseScore3.exe (actually %ProgramFiles(x86)%\MuseScore 3\bin\MuseScore3.exe)

   For the Windows Store version (Windows 10), it is pretty well hidden, search for it via Windows Explorer

6. Click after the quote and add a space followed by a hyphen and a capital F:

   -F

7. Press OK

After a few seconds, MuseScore should start and all the settings reverted to "factory settings".

For advanced users, the main preference file is located at:

- C:\Users\[USERNAME]\AppData\Roaming\MuseScore\MuseScore3.ini (actually %APPDATA%\MuseScore\MuseScore3.ini)

The other preferences (palettes, session, shortcuts, workspaces...) are in:

- C:\Users\[USERNAME]\AppData\Local\MuseScore\MuseScore3 (actually %LOCALAPPDATA%\MuseScore\MuseScore3)

For the Windows Store version (Windows 10), these are pretty well hidden, search for them via Windows Explorer

**Instructions for MacOS**
1. If you have MuseScore open, you need to quit the application first (MuseScore → Quit).
2. Open Terminal (in Applications/Utilities, or via Spotlight search) and a session window should appear.
3. Type (or copy/paste) the following command into your terminal line (include the ‘/’ at the front):

   `/Applications/MuseScore 3.app/Contents/MacOS/mscore -F`

This resets all MuseScore preferences to factory settings and immediately launches the MuseScore application. Note that you cannot quit the Terminal without quitting MuseScore. You can safely quit MuseScore, quit the Terminal, and then reopen MuseScore in the normal fashion, ready to continue using.

For advanced users, the main MuseScore preference file is located at ~/Library/Preferences/org.musescore.MuseScore3.plist. The other preferences (palettes, session, shortcuts, workspaces...) are in ~/Library/Application Support/MuseScore/MuseScore3/.

Instructions for Linux

The following is true for Ubuntu, and most likely all other Linux distributions and UNIX-style operating systems.

1. If you have MuseScore open, you need to quit the application first (File → Quit).
2. From the Ubuntu main menu, choose Applications → Accessories → Terminal. A Terminal session window should appear.
3. Type, (or copy/paste) the following command into your terminal line (Ctrl+Shift+V to paste in Terminal):

   `mscore -F`

   Or, if you are using the AppImage version, you must first use the `cd` command to change directory to wherever you saved the AppImage. For example, if you saved it to your Desktop (and there is only one):

   `cd ~/Desktop
   ./MuseScore*.AppImage -F`

This resets all MuseScore preferences to factory settings and immediately launches the MuseScore application. You can now quit Terminal, and continue using MuseScore.

For advanced users, the main MuseScore preference file is located at ${XDG_CONFIG_HOME:-~/.config}/MuseScore/MuseScore3.ini.

The other preferences (palettes, session, shortcuts, workspaces, ...) are in ${XDG_DATA_HOME:-~/.local/share}/MuseScore/MuseScore3/.

See also

- Command line options

Bug reports and Feature requests

Before filing bug reports or feature requests in the Issue Tracker it is recommended first to post it in the relevant Forum so others may help establish a bug as genuine, or provide ideas and second opinions for new features. Include a link to such discussion when creating the Issue.

Bug reports

Before posting in the issue tracker:

- Try to reproduce the issue with the latest nightly. You may also view the version history to check whether it has been fixed/implemented already.
- Please include as much of the following information as you know and limit each issue to one report:
  - Version/revision of MuseScore you are using (e.g. version 3.0, revision 871c8ce). Check Help → About...
  - Operating system being used (e.g. Windows 7, macOS 10.12 or Ubuntu 14.04)
  - Describe the precise steps that lead to the problem (where do you click, what keys do you press, what do you see, etc.). If you are not able to reproduce the problem with the steps, it is probably not worth reporting it as the developers will not be able to reproduce (and solve) it either. Remember that the goal of a bug report is not only to show the problem, but to allow others to reproduce it easily.
- Please remember:
  - Attach the score that shows the problem, at least a minimal example —use the “File attachments” option at the bottom of the page, just above the Save and Preview buttons when you’re typing your post.

Feature requests
When posting in the Issue Tracker:

- Be brief, but describe the goal as precisely as you can
- Describe the context in which the new feature is intended to work
- Suggest a specific workflow, if you can

External links

- How to write a good bug report: step-by-step instructions
- How to attach a file

Appendix

Keyboard shortcuts

Most keyboard shortcuts can be customized via the menu: select Edit → Preferences... → Shortcuts (Mac: MuseScore → Preferences... → Shortcuts). Below is a list of some of the initial shortcut settings.

Navigation

Beginning of score: Home (Mac: Fn+→)
Last page of score: End (Mac: Fn←)
Find (measure number, rehearsal mark, or pXX when XX is a page number): Ctrl+F (Mac: Cmd+F)

Next score: Ctrl+Tab
Previous score: Shift+Ctrl+Tab

Zoom in: Ctrl++ (doesn't work on some systems) (Mac: Cmd++); or Ctrl (Mac: Cmd) + scroll up
Zoom out: Ctrl+- (Mac: Cmd++); or Ctrl (Mac: Cmd) + scroll down

Next page: Pg Dn; or Shift + scroll down (Mac: Fn+) Previous page: Pg Up; or Shift + scroll up (Mac: Fn+)

Next measure: Ctrl→ (Mac: Cmd→)
Previous measure: Ctrl← (Mac: Cmd←)

Next note: →
Previous note: ←

Note below (within a chord or on lower staff): Alt↓
Note above (within a chord or on higher staff): Alt↑

Top note in chord: Ctrl+Alt↑ (Ubuntu uses this shortcut for Workspaces instead)
Bottom note in chord: Ctrl+Alt↓ (Ubuntu uses this shortcut for Workspaces instead)

Next element (accessibility): Alt→
Previous element (accessibility): Alt←

Note input

Begin note input mode: N
Leave note input mode: N or Esc

Duration

1 ... 9 selects a duration. See also Note input.

Half duration of previous note: Q
Double duration of previous note: W
Decrease duration by one dot: (as of version 2.1) Shift+Q (e.g. a dotted quarter note becomes a quarter note; a quarter note becomes a dotted eighth note)
Increase duration by one dot: (as of version 2.1) Shift+W (e.g. an eighth note becomes a dotted eighth note; a dotted eighth note becomes a quarter note)

Voices

To select a voice in note input mode.

Voice 1: Ctrl+Alt+1 (Mac: Cmd+Alt+1)
Voice 2: Ctrl+Alt+2 (Mac: Cmd+Alt+2)
Voice 3: Ctrl+Alt+3 (Mac: Cmd+Alt+3)
Voice 4: Ctrl+Alt+4 (Mac: Cmd+Alt+4)

Pitch

Pitches can be entered by their letter name (A-G), or via MIDI keyboard. See Note input for full details.

Repeat previous note or chord: R (the repeat can be of a different note value by selecting duration beforehand)

Repeat selection: R (The selection will be repeated from the first note position after the end of the selection)

Raise pitch by octave: Ctrl+↑ (Mac: Cmd+↑)
Lower pitch by octave: Ctrl+↓ (Mac: Cmd+↓)

Raise pitch by semi-tone (prefer sharp): ↑
Lower pitch by semi-tone (prefer flat): ↓
Raise pitch diatonically: Alt+Shift+↑
Lower pitch diatonically: Alt+Shift+↓

Change enharmonic spelling in both written and concert pitch views: J
Change enharmonic spelling in current view only: Ctrl+J (Mac: Cmd+J)

Rest: 0 (zero)

Interval

Add interval above current note: Alt+[Number]

Layout

Flip direction (stem, slur, tie, tuplet bracket, etc.): X
Mirror note head: Shift+X
Increase stretch of measure(s): }
Decrease stretch of measure(s): { 
Line break on selected barline: Return
Page break on selected barline: Ctrl+Return (Mac: Cmd+Return)

Articulations

Staccato: Shift+S
Tenuto: Shift+N
Sforzato (accent): Shift+V
Marcato: Shift+O
Grace note (acciaccatura): / 
Crescendo: <
Decrescendo: >

Text entry

Staff text: Ctrl+T (Mac: Cmd+T)
System text: Ctrl+Shift+T (Mac: Cmd+Shift+T)
Tempo text: Alt+Shift+T
Rehearsal Mark: Ctrl+M (Mac: Cmd+M)

Lyrics entry

Enter lyrics on a note: Ctrl+L (Mac: Cmd+L)
Previous lyric syllable: Shift+Space
Next lyric syllable: if the current and the next syllables are separated by a '-', else Space
Move lyric syllable left by 0.1sp: ←
Move lyric syllable right by 0.1sp: →
Move lyric syllable left by 1sp: Ctrl+- (Mac: Cmd+-)
Move lyric syllable right by 1sp: Ctrl+- (Mac: Cmd+-)
Move lyric syllable left by 0.01sp: Alt+-
Move lyric syllable right by 0.01sp: Alt+-

Up to previous stanza: Ctrl+↑ (Mac: Cmd+↑)
Down to next stanza: Ctrl+↓ (Mac: Cmd+↓)

For more lyric shortcuts, see Lyrics.

Display
Timeline: F12 (Mac: fn+F12)
Play Panel: F11 (Mac: fn+F11)
Mixer: F10 (Mac: fn+F10)
Palette: F9 (Mac: fn+F9)
Inspector: F8 (Mac: fn+F8)
Piano Keyboard: P
Selection filter: F6
Display full screen: Ctrl+U

Miscellaneous
Toggle visibility on selected element(s): V
Show Instruments dialog: I
Toggle multi-measure rests on or off: M
Reset element to default location: Ctrl+R (Mac: Cmd+R)

See also
- Preferences: Shortcuts

Command line options

MSCORE(1) — General Commands Manual Page

NAME
mscore, MuseScore3 — MuseScore 3 sheet music editor

SYNOPSIS
You can launch MuseScore from the command line by typing

- mscore [options] [filename …] (Mac and Linux/BSD/Unix)
- musescore [options] [filename …] (Linux/BSD/Unix)
- MuseScore3.exe [options] [filename …] (Windows)

[options] and [filename] are optional. For this to work the MuseScore executable must be in %PATH% (Windows) resp. $PATH (Mac and Linux). If it is not, see Revert to factory settings for detailed instructions on how and where to find and execute the MuseScore executable from the command line on the various supported platforms.

A more detailed synopsis follows:

mscore [-deFfhILmnOPRstvw]
    [-a | --use-audio driver]
    [-b | --bitrate bitrate]
    [-c | --config-folder pathname]
    [-D | --monitor-resolution DPI]
    [-E | --install-extension extension file]
    [-j | --job file.json]
    [-M | --midi-operations file]
    [-o | --export-to file]
    [-p | --plugin name]
    [-r | --image-resolution DPI]
    [-S | --style style]
    [-T | --trim-image margin]
    [-x | --gui-scaling factor]
    [--debug]
    [--diff]
    [--dump-midi-in]
    [--dump-midi-out]
    [--experimental]
    [--export-score-parts]
    [--factory-settings]
    [--force]
    [--help]
    [--layout-debug]
    [--load-icons]
    [--long-version]
    [--new-score]
    [--no-fallback-font]
    [--no-midi]
DESCRIPTION

MuseScore is a Free and Open Source WYSIWYG cross-platform multi-lingual music composition and notation software, released under the GNU General Public Licence (GPLv2).

Running mscore without any extra options launches the full graphical MuseScore program and opens any files specified on the command line.

The options are as follows:

-a | --use-audio driver
   Use audio driver: one of jack, alsain, portaudio, pulse

-b | --bitrate bitrate
   Set MP3 output bitrate in kbit/s

-c | --config-folder pathname
   Override configuration and settings directory

-D | --monitor-resolution DPI
   Specify monitor resolution (override autodetection)

-d | --debug
   Start MuseScore in debug mode

-E | --install-extension extension file
   Install an extension file; soundfonts are loaded by default unless -e is also specified

-e | --experimental
   Enable experimental features, such as layers

-F | --factory-settings
   Use only the standard built-in presets ("factory settings") and delete user preferences; compare with the -R option (see also Revert to factory settings)

-f | --force
   Ignore score corruption and version mismatch warnings in "converter mode"

-h | --help
   Display an overview of invocation instructions (doesn't work on Windows)

-I | --dump-midi-in
   Display all MIDI input on the console

-i | --load-icons
   Load icons from the filesystem; useful if you want to edit the MuseScore icons and preview the changes

-j | --job file.json
   Process a conversion job (see EXAMPLES below)
-L | --layout-debug
Start MuseScore in layout debug mode

-M | --midi-operations file
Specify MIDI import operations file (see EXAMPLES below)

-m | --no-midi
Disable MIDI input

-n | --new-score
Start with the New Score wizard regardless whether it's enabled or disabled in the user preferences

-O | --dump-midi-out
Display all MIDI output on the console

-o | --export-to file
Export the given (or currently opened) file to the specified output. The file type depends on the extension of the filename given. This option switches to “converter mode” and avoids the graphical user interface.

-P | --export-score-parts
When converting to PDF with the -o option, append each part's pages to the created PDF file. If the score has no parts, all default parts will temporarily be generated automatically.

-p | --plugin name
Execute the named plugin

-R | --revert-settings
Use only the standard built-in presets (“factory settings”) but do not delete user preferences; compare with the option

-r | --image-resolution DPI
Set image resolution for conversion to PNG files. Default: 300 DPI (actually, the value of “Resolution” of the PNG option group in the Export tab of the preferences)

-S | --style style
Load a style file first; useful for use with the -o option

-s | --no-synthesizer
Disable the integrated software synthesizer

-T | --trim-image margin
Trim exported PNG and SVG images to remove whitespace surrounding the score. The specified margin, in pixels, will be retained (use 0 for a tightly cropped image). When exporting to SVG, this option only works with single-page scores.

-t | --test-mode
Set test mode flag for all files

-v | --version
Display the name and version of the application without starting the graphical user interface (doesn't work on Windows)

-w | --no-webview
Disable the web view component in the Start Centre

-x | --gui-scaling factor
Scale the score display and other GUI elements by the specified factor; intended for use with high-resolution displays
--diff
    Print a conditioned diff between the given scores

--long-version
    Display the full name, version and git revision of the application without starting the graphical user interface (doesn't work on Windows)

--no-fallback-font
    Don't use Bravura as fallback musical font

--raw-diff
    Print a raw diff between the given scores

--run-test-script
    Run script tests listed in the command line arguments

--score-media
    Export all media (except MP3) for a given score as a single JSON document to stdout

--score-mp3
    Generates an MP3 for the given score and exports it as a single JSON document to stdout

--score-parts-pdf
    Generates parts data for the given score and exports it as a single JSON document to stdout

--template-mode
    Save files in template mode (e.g. without page sizes)

MuseScore also supports the automatic Qt command line options.

Batch conversion job JSON format

The argument to the -j option must be the pathname of a file comprised of a valid JSON document honoring the following specification:

- The top-level element must be a JSONArray, which may be empty.
- Each array element must be a JSONObject with the following keys:
  - in: Value is the name of the input file (score to convert), as JSONString.
  - plugin: Value is the filename of a plugin (with the.qml extension), which will be read from either the global or per-user plugin path and executed before the conversion output happens, as JSONString. Optional, but at least one of plugin and out must be given.
  - out: Value is the conversion output target, as defined below. Optional, but at least one of plugin and out must be given.
- The conversion output target may be a filename (with extension, which decided the format to convert to), as JSONString.
- The conversion output target may be a JSONArray of filenames as JSONString, as above, which will cause the score to be written to multiple output files (in multiple output formats) sequentially, without being closed, re-opened and re-processed in between.
- If the conversion output target is a JSONArray, one or more of its elements may also be, each, a JSONArray of two JSONStrings (called first and second half in the following description). This will cause part extraction: for each such two-tuple, all extant parts of the score will be saved individually, with filenames being composed by concatenating the first half, the name (title) of the part, and the second half. The resulting string must be a valid filename (with extension, determining the output format). If a score has no parts (excerpts) defined, this will be silently ignored without error.
- Valid file extensions for output are:
  - flac  Free Lossless Audio Codec (compressed audio)
  - metajson  various score metadata (JSON)
mid  standard MIDI file
mlog  internal file sanity check log (JSON)
mp3  MPEG Layer III (lossy compressed audio)
mpos  measure positions (XML)
mscx  uncompressed MuseScore file
mscz  compressed MuseScore file
musicxml  uncompressed MusicXML file
mxml  compressed MusicXML file
ogg  OGG Vorbis (lossy compressed audio)
pdf  portable document file (print)
png  portable network graphics (image) — Individual files, one per score page, with a hyphen-minus followed by the page number placed before the file extension, will be generated.
spos  segment positions (XML)
svg  scalable vector graphics (image)
wav  RIFF Waveform (uncompressed audio)
xml  uncompressed MusicXML file

See below for an example.

ENVIRONMENT

SKIP_LIBJACK
  Set this (the value does not matter) to skip initialization of the JACK Audio Connection Kit library, in case it causes trouble.

XDG_CONFIG_HOME
  User configuration location; defaults to ~/config if unset.

XDG_DATA_HOME
  User data location; defaults to ~/local/share if unset.

Note that MuseScore also supports the normal Qt environment variables such as QT_QPA_GENERIC_PLUGINS, QT_QPA_PLATFORM, QT_QPA_PLATFORMTHEME, QT_QPA_PLATFORM_PLUGIN_PATH, QT_STYLE_OVERRIDE, DISPLAY, etc.

FILES

/usr/share/mscore-3.0/ contains the application support data (demos, instruments, localization, system-wide plugins, soundfonts, styles, chords, templates and wallpapers). In the Debian packages, system-wide soundfonts are installed into /usr/share/sounds/sf2/, /usr/share/sounds/sf3/ or /usr/share/sounds/sfz/, respectively, instead.

The per-user data (extensions, plugins, soundfonts, styles, templates) and files (images, scores) are normally installed into subdirectories under ~/.MuseScore3 but may be changed in the configuration. Note that snapshot, alpha and beta versions use MuseScore3Development instead of MuseScore3 in all of these paths.

$XDG_CONFIG_HOME/MuseScore/MuseScore3.ini contains the user preferences, list of recently used files and their locations, window sizes and positions, etc. See above for development version paths.

$XDG_DATA_HOME/data/MuseScore/MuseScore3/ contains updated localization files downloaded from within the program, plugin information, cached scores, credentials for the musescore.com community site, session information, synthesizer settings, custom key and time signatures and shortcuts. See above for development version paths.

EXAMPLES

Convert a score to PDF from the command line

mscore -o 'My Score.pdf' 'My Score.mscz'

Run a batch job converting multiple documents

238
mscore -j job.json

This requires the file `job.json` in the current working directory to have content similar to the following:

```
[{
    "in": "Reunion.mscz",
    "out": "Reunion-coloured.pdf",
    "plugin": "colornotes.qml"
},
{
    "in": "Reunion.mscz",
    "out": [
        "Reunion.pdf",
        "Reunion.musicxml",
        "Reunion.mid"
    ],
},
{
    "in": "Piece with excerpts.mscz",
    "out": [
        "Piece with excerpts (Partitura).pdf",
        "Piece with excerpts (part for Violin).pdf",
        "Piece with excerpts.mid"
    ],
}]
```

The last part of the job would, for example, cause files like `Piece with excerpts (part for Violin).pdf` to be generated alongside the conductor’s partitura and a MIDI file with the full orchestra sound, whereas the equivalent part of the Reunion conversion will be silently ignored (because the Reunion piece (a MuseScore demo) has no excerpts defined).

**MIDI import operations**

The attached `midi_import_options.xml` is a sample MIDI import operations file for the `-M` option.

**DIAGNOSTICS**

The `mscore` utility exits 0 on success, and >0 if an error occurs.

**SEE ALSO**

`fluidsynth(1)`, `midicsv(1)`, `timidity(1)`, `qtoptions(7)`

[https://musescore.org/handbook](https://musescore.org/handbook) — Online Handbook, full user manual

[https://musescore.org/forum](https://musescore.org/forum) — Support Forum

[https://musescore.org/en/node/278582](https://musescore.org/en/node/278582) — Reverting to factory settings (troubleshooting)

[https://musescore.org/project/issues](https://musescore.org/project/issues) — Project Issue Tracker — Please check first to if the bug you’re encountering has already been reported. If you just need help with something, then please use the support forum instead.


**STANDARDS**

MuseScore attempts to implement the following standards:

- MusicXML 3.1 (score interchange format)
- SF2 (SoundFont 2.01)
- SF3 (SoundFont with OGG Vorbis-compressed samples)
- SFZ (Sforzato soundfont)
- SMuFL (Standard Music Font Layout 1.20)

**HISTORY**
MuseScore was split off the MusE sequencer in 2002 and has since become the foremost Open Source notation software.

AUTHORS

MuseScore is developed by Werner Schweer and others.

This manual page was written by mirabilos <tg@debian.org>.

CAVEATS

The automatic Qt command line options are removed from the argument vector before the application has a chance at option processing; this means that an invocation like mscor e -S -r everse has no chance at working because the -r everse is removed by Qt first.

BUGS

- MuseScore does not honor /etc/papersize.
- Probably some more; check the project's bug tracker (cf. SEE ALSO).

MuseScore—December 18, 2018

New features in MuseScore 3

MuseScore 3 includes a number of new and improved features. For a brief summary, see the Release notes for MuseScore 3. More details can be found in the summaries below and by referring to the relevant pages of the handbook.

Automatic Placement

MuseScore initially places elements in the score according to (a) the properties specified in style defaults and (b) any manual adjustments made. For elements that have automatic placement enabled, however, MuseScore will attempt to avoid collisions by moving one or more of them as needed.

See Automatic placement.

Default position

The default position for most elements is controlled by settings in Format → Style. You can either change the default there, or, in the Inspector, apply a manual adjustment (see below) and then use the "Set as style" control (to the right of the value you wish to set).

The specific properties you can set vary by element type but include:

- placement (whether the element appears above or below the staff by default)
- position above/below (specific positions when placed above or below)
- offset (same as position above/below, for which placement is the default)
- autoplace min distance (minimum distance from other elements when autoplace is enabled)

See Automatic placement.

Manual adjustments

Many elements can be placed either above or below the staff. To flip an element from above to below or vice versa, use the "Placement" setting in the Inspector, or press the shortcut “X”.

Manual adjustments to position can be performed by dragging or by changing the offsets in the Inspector. Neither method will allow you to position an element in a way that causes a collision, however. To take full control of the position of an element, you can disable automatic placement for it.

See Automatic placement.

Disabling automatic placement

To disable automatic placement for an element, untick the "Automatic placement" box in the Inspector. The element will revert to its default position, and it will no longer be considered when automatically placing other elements.

See Automatic placement.

Stacking order
The "Stacking order" setting in the Inspector controls which elements overlap which in the cases where they actually do overlap and are not moved due to autoplacement. See Automatic placement.

**Text Formatting**

Formatting of text is controlled by three factors:

- The text style associated with the element sets the defaults for properties such as the font, alignment, and frame.
- Changes to these text properties can be applied to selected elements via the Inspector.
- Custom formatting can be applied to specific characters within the text using the text toolbar.

See [Text basics](#), [Text styles and properties](#).

**Text Styles**

Each text element has a text style associated with it. The default style for an element is determined by the type of the element itself - staff text defaults to the Staff text style, dynamics to the Dynamics text style, etc. This text style determines the default font face, size, style (bold/italic/underline), alignment, and frame properties.

You can change the defaults for any of these text styles using Format → Style → Text Styles. For instance, you can make rehearsal marks bigger, or change lyrics to be italicized. This will affect all existing elements using that style as well as elements you add later. Some elements also contain a limited set of text style controls in their own sections of the Format → Style dialog (although this might not be the case in the final release). The settings are linked: you can change the font size for measure numbers in either Format → Style → Measure Numbers, or in Format → Style → Text Styles: Measure Number. The effect is the same: all measure numbers in the score will take on this size. You can also change the defaults for a text style using the Inspector; see [Text Properties](#) below.

For most text elements that you create directly (like staff text, rehearsal marks, and lyrics), you can apply a different text style using the Style control in the Inspector. This will cause them to display using that style instead of the "native" style for the element. For example, you can select one or more staff text elements and give them the Tempo style to force them to display as if they were tempo markings.

See [Text basics](#), [Text styles and properties](#).

**Text Properties**

The text style controls the default properties for elements using that style, but you can override any of these properties for selected elements using the Inspector. For example, you can select a handful of staff text elements using Ctrl+click, then use the Inspector to make them larger. The Reset to Default button next to each property control returns it to the default. You can also click the Set as Style button to change the style to match. So another way to change the size of all measures numbers is to select one, change its size in the Inspector, then click Set as Style.

See [Text basics](#), [Text styles and properties](#).

**Custom Formatting**

Custom formatting is applied to text using the toolbar at the bottom of the main window in the same manner as in previous releases. Thus, you can embolden one word in a sentence while the rest is normal, or superscript a particular character etc. You can also remove all custom formatting from select text elements using the "Remove Custom Formatting" button in the Inspector. This returns the text to the settings currently shown in the Inspector.

See [Text editing](#).

**Staff Type Change**

You can change various staff properties mid-score, including staff size, notehead scheme (e.g., for pitch name noteheads), generation of time signatures, and others. The staff type change element is found on the Text palette (currently, but see #278205: Move Staff Type Change to another palette (it is not text)! - it may move). Add it to the measure where you want the change to occur, then use the Inspector to change properties of the staff type change element.

See [Staff Type Change](#).

**Temporary and Cutaway Staves**

To create a temporary staff that appears on certain systems only: first add the staff normally (Edit / Instruments), then add notes, then right-click the staff, click Staff Properties, and set "Hide when empty" to "Always". This will cause the staff to show only where needed even without needing to turn on "Hide empty staves" for the whole score (in Format / Style). The default for "Hide when empty" is "Auto", meaning the staff will be hidden when empty if "Hide empty staves" is enabled.
Additional values include "Never" (the staff will not be hidden when empty even if "Hide empty staves" is enabled) and "Instrument" (for instruments containing multiple staves, the staff is hidden only if all staves for that instrument are empty).

To create a cutaway staff in which only the measures containing notes are visible (for ossia or cutaway scores, for example), right-click the staff, click Staff Properties, and enable the "Cutaway" option. This can be used independently of "Hide when empty" or "Hide empty staves".

System Dividers

System dividers are a set of short diagonal lines that are used to visually separate systems on a page. MuseScore can add these to your score automatically. In Format → Style → System, you can enable dividers on the left, right, or both, and you can set their default position. You can also adjust the position of individual dividers in your score manually or mark them invisible (this currently does not survive saving).

Staff Spacing

As part of the automatic placement in MuseScore, staves are now spaced automatically, so you can set a comfortable minimum distance and depend on MuseScore to open up more space where needed. You can use staff spacers as in MuseScore 2 to increase distance between staves, but MuseScore 3 now also provides a way to decrease it—the "fixed" staff spacer, found on the Breaks & Spacers palette. Just add the spacer and adjust its height. This will also prevent MuseScore from automatically adding more space to avoid collisions, allowing you to manage this yourself.

See Spacers.

Don't Break

Currently disabled

In addition to the system, page, and section breaks familiar from MuseScore 2, the "Breaks & Spacers" palette now contains a new "Don't Break" element. This allows you to force two measures to be kept together, for example, if there is some complex passage that spans the measures and you want to make sure they are adjacent. If both measures don't fit on a system, MuseScore moves them both to the next system. (Currently, this leaves a "hole" at the end of the first staff - is this a bug or is there some purpose behind it?)

Parts from Voices

In addition to the ability to generate parts from the different instruments in your score, you can now also associate a part with a specific staff within the instrument or even a specific voice within a specific staff. This allows you to combine multiple parts (e.g., Flute 1 & 2) onto a single staff in the score while still generating separate parts.

The Parts dialog now contains two sections at the bottom, Instruments in Score and Instruments in Part. Once you have generated a part (or all parts) using the New and New All buttons, you can select any part at the top and use the controls at the bottom to control not only what instrument is in the part, but also which staves and voices within the instrument are included.

To add an instrument to a part, select it from "Instruments in Score" and press "+". To remove an instrument from a part, select it from "Instruments in Part" and press "-". To customize the part at the staff or voice level, click the arrow next to the instrument in "Instruments in Part" to expand the listing to show all staves and voices of the instrument. You can remove a staff by selecting it and pressing "-", or remove a voice by unchecking it.

Limitations: If you select only voice 1 for a given staff, then only the content in voice 1 for that staff will be included in the part. Thus, in order to share flute 1 & 2 on the same staff, you will need to enter all notes onto both voices, even in passages where they share content. You also cannot enter the two parts as chords in the passages where they share rhythms.

Explode and Implode

Explode has been updated to allow separation of voices as well as notes. See Explode.

The implode tool (Tools / Implode) works in one of two modes.

With a single staff selected, the implode command merges notes in different voices into chords where possible (when notes are on the same beat and have the same duration). This is the same as recent versions of MuseScore, although some bugs have been fixed.

With multiple staves selected, the implode command combines the content of the first four non-empty voices (on any staves) into multiple voices on the top selected staff. This is different from MuseScore 2, where notes would be combined into chords rather than using multiple voices, and thus required the rhythms to match. The MuseScore 3 approach preserves the original rhythms even where they differ, and is intended to produce the expected results when combining two different parts onto one staff for use with the parts from voices feature, or when reducing an open (four-stave) SATB score into a closed (two-stave) version. To further merge the voices into chords where possible, simply run the command again.
Insert mode

You can insert and delete notes and have the measure automatically expand or contract to accommodate the change. This can be useful in creating unmetered music or in ordinary editing.

To insert a note before the currently-selected note, press Ctrl+Shift while adding the note normally. For example, in note input mode, Ctrl+Shift+click will insert a note of the currently-selected duration at that location. Ctrl+Shift+B will insert a B of the currently-selected duration before the note at the current cursor position. You can also switch to Insert mode using the dropdown menu next to the note input button on the toolbar. In this mode, all notes you add act as if you were pressing Ctrl+Shift - they are inserted rather than replacing the existing notes or rests at that location.

To delete notes, you must be in normal (not note input) mode. Select either a single note or a range and press Ctrl+Del.

See Note input modes, Remove selected range (Tools)

Split/Join Measures

To split a measure before a given note, simply insert a barline from the palette at that point while holding Ctrl. For example, you can select the note, and Ctrl+double-click the barline in the palette, or Ctrl+drag the barline to the note. You can also use Tools → Measure → Split Measure Before Selected Note/Rest.

To join two measures, Ctrl+Del the barline between them. You can also use the menu command Tools → Measure → Join Measures.

See Measure operations.

Timeline

The Timeline presents a graphical overview of your score. To access it, use View → Timeline (F12). The top portion of the Timeline shows the location of tempo, key, and time signature changes as well as rehearsal marks, repeats, and double barlines. The bottom portion shows the staves of your score, with non-empty measures highlighted. You can click anywhere within this view to jump to the corresponding spot in the score.

See Timeline

Score Comparison Tool

The Score Comparison Tool (View / Score Comparison Tool) allows you to compare two versions of a score to find the differences between them. Select the two scores you want to compare and whether you want to compare the current version or the last saved version (note you can compare the current version of a score against the last saved version of the same score to see what you have changed since the last save), then click the Compare button. A list of differences of differences will be displayed to the right. The score view will automatically change to Documents Side by Side, with the two scores you have selected displayed within. Double-click on a difference from the list and both score views will automatically pan to show you the changed element, which will also be highlighted.

Normally you would want the default Intelligent comparison, which displays the differences in human-readable format (e.g. "Measure 1: Note: property pitch changed from B4 to C5"). There is also a Raw mode to show the results according to the actual XML code.

See Score comparison.

Mixer

See Mixer.

Piano Roll Editor

See Piano roll editor (preliminary page).

Capo changes

Capo changes are now a property of staff text, and can be used to automatically change the pitch of all notes that follow them, up until another capo change.

See Capo playback.

Fretboard Diagrams

New UI. See Fretboard diagrams.
External links

- Release notes for MuseScore 3.x
- Transitioning from version 2 to version 3

Known limitations of MuseScore 3.x

While all members of the development team did their best to make the software easy to use and bug-free, there are some known issues and limitations in MuseScore 3.x.

Local time signatures

The local time signature feature, which allows you to have different time signatures in different staves at the same time, is very limited. You can only add a local time signature to measures that are empty, and only if there are no linked parts. When adding notes to measures with local time signatures, you can enter notes normally via note input mode, but copy and paste does not work correctly and may lead to corruption or even crashes. The join and split commands are disabled for measures with local time signatures.

Regroup Rhythms

The Regroup Rhythms command found under the Tools menu may have unintended side effects, including changing the spelling of pitches and deleting some elements like articulations, glissandos, tremolos, grace notes and, esp. on undo, ties. Use this tool with caution on limited selections, so that you can tell if any unwanted changes are made.

Tablature staff linked with standard staff

When entering multiple-note chords on a standard staff in a linked staff/tablature system, the notes should be entered in order from the top (first) string to the bottom string to ensure correct fret assignment.

This limitation does not apply if entering notes directly onto a tablature staff, or when using unlinked staff/tablature system.

Mixer

Changing settings in the mixer other than the sound doesn't mark the score 'dirty'. That means if you close a score you may not get the warning "Save changes to the score before closing?". Changing mixer values are also not undoable.

Header & footer

There is no way to edit Header and Footer in a WYSIWYG manner. The fields in Format → Style → Header, Footer are plain text. They can contain "HTML like" syntax, but the text style, layout, etc. can't be edited with a WYSIWYG editor.

Upgrade from MuseScore 1.x or 2.x

How to upgrade MuseScore

Download and install the latest version from the download page as described at Installation.

Installing MuseScore 3 won't uninstall 1.x nor 2.x —all three versions can coexist peacefully and can even be used in parallel. So this isn't really an upgrade but an installation of a new and different program.

Opening 1.x or 2.x scores in MuseScore 3

MuseScore 3 significantly improved the typesetting quality to make scores attractive and easier to read. Improvements cover many items such as beam slope, stem height, layout of accidentals in chords and general note spacing. However, this means that sheet music made with MuseScore 1.x or 2.x looks slightly different from sheet music made with 3.x.

It also means that scores saved with 3.x won't open with 1.x nor 2.x.

To prevent you from accidentally overwriting your 1.x or 2.x scores, 3.x treats them as an import, which means:

- The score gets marked as being modified, even if you haven't changed anything
- On exiting MuseScore you're asked to save the score (as a result from the above)
- MuseScore uses the "Save As" dialog to save it, not the "Save" dialog
- MuseScore uses the score's title to create a default filename rather than taking the old filename

Relayout

If you did not manually adjust the layout of a 1.x or 2.x score, then MuseScore uses the 3.x typesetting engine to layout the score. If you did touch the layout of the 1.x or 2.x score, the individual adjustments you may have made should remain
after opening it in MuseScore 3.x, but due to slight changes in the surrounding layout they may still not appear correct in context. If you wish to reset even manual adjustments to use the 3.x typesetting engine throughout, select the complete score with the shortcut Ctrl+A (Mac: Cmd+A) and reset the layout with Ctrl+R (Mac: Cmd+R).

Note: When you open a 1.x or 2.x file in MuseScore 3, it will ask you if you want to reset the layout to the defaults.

Getting the sound from MuseScore 1.x

While the sound in 2.x/3.x has been much improved, you may still prefer the sound from MuseScore 1.x. In that case, you can get the 1.x sound in 3.x by downloading the 1.3 SoundFont and add it in 3.x. You can do this in two steps:

1. Download the 1.3 SoundFont named TimGM6mb
2. Install and use the TimGM6mb SoundFont in 2.0

Known incompatibilities

Hardware incompatibilities

The following software is known to crash MuseScore on startup:

- Samson USB Microphone, driver name "Samson ASIO Driver", samsonasiodriver.dll. More info
- Digidesign MME Refresh Service. More info
- Windows XP SP3 + Realtek Azalia Audio Driver. More info
- Wacom tablet. More info and QTBUG-6127

Software incompatibilities

- Maple virtual cable is known to prevent MuseScore from closing properly.
- KDE (Linux) window settings can cause the whole window to move when dragging a note. Changing the window settings of the operating system avoids the problem.
- Nitro PDF Creator may prevent MuseScore from starting on Windows 10, if being used as the default printer. Same for Amyumi/Quickbooks PDF Printer, see here and also some cloud printing services, see here.
- Creative Sound Blaster Z Series ASIO driver may prevent MuseScore from starting on Windows 10.
- Untrusted Font Blocking policy prevents MuseScore from starting (except in debug mode, i.e. using the -d option) on Windows 10. (Solution in the links provided here)
- The SteelSeries Engine 3 Audio Visualizer will prevent MuseScore from starting up, or cause MuseScore to crash if the Audio Visualizer is started when MuseScore is already running.

AVG Internet Security hangs MuseScore

MuseScore requires access to your internet connection with AVG. MuseScore doesn't need an internet connection to function, but if AVG blocks it, MuseScore hangs.

If AVG prompts you, Allow MuseScore and check "Save my answer as a permanent rule and do not ask me next time."

If it doesn't prompt you anymore,

1. Open the AVG user interface (right-click on the AVG icon, close to your clock -> Open AVG User Interface
2. Click on Firewall
3. Click Advanced Settings
4. Click Applications
5. Find MSCORE.EXE in the list and double click it
6. Change Application Action to Allow for All

Font problem on macOS

MuseScore is known to display notes as square when some fonts are damaged on macOS.

To troubleshoot this issue:

1. Go to Applications -> Font Book
2. Select a font and press #+A to select them all
3. Go to File -> Validate Fonts
4. If any font is reported as damaged or with minor problems, select it and delete it
5. Restart MuseScore if necessary

In this forum article, a user believes to have found the font "Adobe Jenson Pro (ajenson)" to be the culprit, regardless of not being reported as broken, or problematic as per the above validation, and solved the problem by deleting that font, so this is worth checking too.

Font problem on Linux
If the default desktop environment application font is set to bold, MuseScore will not display the notes properly. To troubleshoot this issue (gnome 2/*MATE users):

1. Right-click on your desktop and select Change Desktop background
2. Click on Fonts tab
3. Set Regular style for Application font
4. Restart MuseScore if necessary

For GNOME 3/SHELL users

1. Open the shell and open “Advanced Settings”
2. Click on the Fonts option in the list
3. Set the default font to something non-bold
4. Restart MuseScore if necessary

Save As dialog empty on Linux

Some users reported that the Save As dialog is empty on Debian 6.0 and Lubuntu 10.10. To troubleshoot this issue:

1. Type the following in a terminal
   
   which mscore

2. The command will answer with the path of mscore. Edit it with your preferred text editor and add the following line at the beginning

   export QT_NO_GLIB=1

Launch MuseScore and the problem should be solved.

Glossary

The glossary is a work in progress—please help if you can. You can discuss this page in the documentation forum.

The list below is a glossary of frequently used terms in MuseScore as well as their meaning. The differences between American English and British English are marked with "(AE)" and "(BE)", respectively.

A

Acciaccatura

♫ A short → grace note which appears as a small note with a stroke through the stem. It is quickly executed and technically takes no value from its associated note.

Accidental

A sign appearing in front of a note that raises or lowers its pitch. The most common accidentals are → sharps, → flats, or → naturals, but double sharps and double flats are also used. Also → koron, and → sori and other quarter tone accidentals. Accidentals affect all notes on the same → staff position only for the remainder of the measure in which they occur, but they can be canceled by another accidental. In notes tied across a → barline, the accidental continues across the → barline to the tied note, but not to later untied notes on the same → staff position in that measure.

Ambitus

Note (or vocal) range used in a → staff. Used particularly in Early Music

Anacrusis

See → Pickup measure.

Anchor

The point of attachment to the score of objects such as Text and Lines: When the object is dragged, the anchor appears as small brown circle connected to the object by a dotted line. Depending on the object selected, its anchor may be attached to either (a) a note (e.g. fingerign), (b) a staff line (e.g. staff text), or (c) a barline (e.g. repeats).

Appoggiatura

A long → grace note which takes value from its associated note. Its functions include: passing tone, anticipation, struck suspension, and escape tone.

Arpeggio

An arpeggio tells the performer to break up the chord into the constituent notes, playing them separately and one after the other. An arrow on the arpeggio indicates the direction in which the player should play the notes of the chord.
B

Bar (BE)
See → measure.

Barline
Vertical line through a → staff, staves, or a full → system that separates → measures.

Beam
Notes with a duration of an → eighth (\(\tfrac{1}{8}\)) or shorter either carry a → flag or a beam. Beams are used for grouping notes.

BPM
Beats Per Minute is the unit for measuring tempo, traditionally counted in quarter note durations. See → metronome mark

Breve
Brevis
A double whole note or breve is a note that has the duration of two whole notes.

C

Caesura
A caesura (\(/\)) is a brief, silent pause. Time is not counted for this period, and music resumes when the director signals.

Cent
An interval equal to one hundredth of a semitone.

Chord
A group of two or more notes sounding together. To select a chord in MuseScore, press \(\text{Shift}\) and click on a note. In the Inspector, however, the word “Chord” only covers notes in the same voice as the selected note(s).

Clef
Sign at the beginning of a → staff, used to tell which are the musical notes on the lines and between the lines. Clefs are very useful for → transposition.

Concert pitch
Enables you to switch between concert pitch and transposing pitch (see Concert pitch and Transposition).

Crotchet (BE)
See → Quarter note.

D

Double Flat
A double flat (\(\flat\flat\) or \(\natural\)) is a sign that indicates that the pitch of a note has to be lowered two semitones.

Double Sharp
A double sharp (\(\sharp\sharp\) or \(\natural\)) is a sign that indicates that the pitch of a note has to be raised two semitones.

Demisemiquaver (BE)
A thirty-second note.

Duplet
See → tuplet.

Dynamic
A symbol indicating the relative loudness of a note or phrase of music—such as asmf (mezzoforte), p (piano), f (forte) etc., starting at that note.

Dynamic, Single note
A dynamic marking which applies only to one note—such as sfz (sforzando), fp (fortepiano) etc.

E

Edit mode
The program mode from which you can edit various score elements.

Eighth note
A note whose duration is an eighth of a whole note (semibreve). Same as a quaver (BE).

Endings
See → volta.

Enharmonic notes
Notes that sound the same pitch but are written differently. Example: G♯ and A♭ are enharmonic notes.

F
Flag
See → beam.

Flat
Sign (♭) that indicates that the pitch of a note has to be lowered one semitone.

G
Grace note
Grace notes appear as small notes in front of a normal-sized main note. See → acciaccatura and → appoggiatura.

Grand Staff (AE)
Great Stave (BE)
A system of two or more staves, featuring treble and bass clefs, used to notate music for keyboard instruments and the harp.

H
Half Note
A note whose duration is half of a whole note (semibreve). Same as a minim (BE).

Hemidemisemiquaver (BE)
A sixty-fourth note.

I
Interval
The difference in pitch between two notes, expressed in terms of the scale degree (e.g. major second, minor third, perfect fifth etc.). See Degree (Music) (Wikipedia).

J
Jump
In MuseScore, "jumps" are notations such as “D.S. al Coda”, found in the “Repeats & Jumps” palette.

K
Key Signature
Set of → sharps or → flats at the beginning of the → staves. It gives an idea about the tonality and avoids repeating those signs all along the → staff.
A key signature with B flat means F major or D minor tonality.

Koron
An Iranian → accidental which lowers the pitch of a note by a quarter tone (in comparison to the → flat which lowers a note by a semitone). It is possible to use this accidental in a → key signature.
See also → Sori.

L
Longa
A longa is a quadruple whole note.

Ledger Line
Line(s) that are added above or below the staff.

M
Measure (AE)
A segment of time defined by a given number of beats. Dividing music into measures provides regular reference points to pinpoint locations within a piece of music. Same as → bar (BE).

Metronome mark
Metronome marks are usually given by a note length equaling a certain playback speed in → BPM. In MuseScore, metronome marks are used in Tempo texts.

Minim (BE)
See → Half note.
A natural (♮) is a sign that cancels a previous alteration on notes of the same pitch.

**Normal mode**

The operating mode of MuseScore outside note input mode or edit mode; press Esc to enter it. In **Normal mode** you can navigate through the score, select and move elements, adjust Inspector properties, and alter the pitches of existing notes.

**Note input mode**

The program mode used for entering music notation.

**Operating System (OS)**

Underlying set of programs which set up a computer, enabling additional programs (such as MuseScore). Popular OSes are Microsoft Windows, macOS, and GNU/Linux.

Not to be confused with a sheet music → system.

**Part**

Music to be played or sung by one or a group of musicians using the same instrument. In a string quartet, 1st part = Violin 1, 2nd part = Violin 2, 3rd part = Viola, 4th part = Cello, in a choir there might be parts for soprano, alto, tenor and bass. A part has one or more → staves (e.g. Piano has 2 staves, Organ can have 2 or 3 staves).

**Pickup Measure** (also known as an Anacrusis or Upbeat)

Incomplete first measure of a piece or a section of a piece of music. See Measure duration and Create new score: Pickup measure. Also Exclude from measure count.

**Quadruplet**

See → tuplet.

**Quarter note**

A note whose duration is a quarter of a whole note (semibreve). Same as a crotchet (BE).

**Quaver (BE)**

See → eighth note.

**Quintuplet**

See → tuplet.

**Respell Pitches**

Tries to guess the right accidentals for the whole score (see Accidentals).

**Rest**

Interval of silence of a specified duration.

**Re-pitch mode**

Allows you to rewrite an existing passage of music by changing the note pitches without altering the rhythm.

**Semibreve (BE)**

A whole note (AE). It lasts a whole measure in 4/4 time.

**Semiquaver (BE)**

A sixteenth note.

**Semihemidemisemiquaver (Quasihemidemisemiquaver) (BE)**

An hundred and twenty eighth note.

**Sextuplet**

See → tuplet.

**Slash chord**

See Slash chord (Wikipedia).

**Slash notation**

A form of music notation using slash marks placed on or above/below the staff to indicate the rhythm of an accompaniment: often found in association with chord symbols. There are two types: (1) Slash notation consists of a rhythm slash on each beat: the exact interpretation is left to the player (see Fill with slashes); (2) Rhythmic slash notation indicates the precise rhythm for the accompaniment (see Toggle rhythmic slash notation).

**SFZ**

A virtual instrument format supported by MuseScore (along with → SoundFonts). An SFZ library consists of one or more SFZ text files, each defining a particular instrument setup, and many audio sound samples.

**Sharp**
Sign (♯) that indicates that the pitch of a note has to be raised one semitone.

**Slur**
A curved line over or under two or more notes, meaning that the notes will be played smooth and connected (legato).
See also → tie.

**Sori**
An Iranian → accidental which raises the pitch of a note by a quarter tone (in comparison to the sharp which raises it by a semitone). It is possible to use this accidental in a → key signature.
See also → Koron.

**SoundFont**
A virtual instrument format supported by MuseScore (along with → SFZ). A SoundFont is a special type of file (extension .sf2, or .sf3 if compressed) containing sound samples of one or more musical instruments. In effect, a virtual synthesizer which acts as a sound source for MIDI files. MuseScore 2.2 comes with the SoundFont "MuseScore_General.sf3" pre-installed.

**Spatium (plural: Spatia) / Space / Staff Space / sp. (abbr./unit)**
The distance between the midpoints of two lines of a music staff (or one-quarter the size of the full five-line staff, assuming a hypothetical staff line thickness of 0). The sizes of most elements in the score are based on this setting (see Page settings).

**Staff (AE) / Staves (plural)**
A set of lines and spaces, each representing a pitch, on which music is written. In ancient music notation (before 11th century) the staff may have any number of lines.

**Staff Space**
See Spatium (above).

**Stave (BE)**
See Staff (above).

**Step-time input**
MuseScore's default note input mode, allowing you to enter music notation one note (or rest) at a time.

**System**
Set of staves to be read simultaneously in a score.
See also → Operating System (OS).

**T**

**Tie**
A curved line between two or more notes on the same pitch to indicate a single note of combined duration:

- Quarter note + Tie + Quarter note = Half note
- Quarter note + Tie + Eighth note = Dotted Quarter note
- Quarter note + Tie + Eighth note + Tie + 16th note = Double Dotted Quarter note

See also → slur.

**Transposition**
The act of moving the pitches of one or more notes up or down by a constant interval. There may be several reasons for transposing a piece, for example:

1. The tune is too low or too high for a singer. In this case the whole orchestra will have to be transposed as well —easily done using MuseScore.
2. The part is written for a particular instrument but needs to be played by a different one.
3. The score is written for an orchestra and you want to hear what the individual instruments sound like. This requires changing the transposing instrument parts to concert pitch.
4. A darker or a more brilliant sound is desired.

**Triplet**
See → tuplet.

**Tuplet**
A tuplet divides its next higher note value by a number of notes other than given by the time signature. For example a → triplet divides the next higher note value into three parts, rather than two. Tuplets may be: → triplets, → duplets, → quintuplets, and other.

**U**

**Upbeat**
See → pickup measure.

**V**

**Velocity**
The velocity property of a note controls how loudly the note is played. This usage of the term comes from MIDI synthesizers. On a keyboard instrument, it is the speed with which a key is pressed that controls its volume. The usual scale for velocity is 0 (silent) to 127 (maximum).
Voice

Polyphonic instruments like Keyboards, Violins, or Drums need to write notes or chords of different duration at the same time on the same staff. To write such things each horizontal succession of notes or chords has to be written on the staff independently. In MuseScore you can have up to 4 voices per staff. Not to be confused with vocalists, singing voices like soprano, alto, tenor and bass, which are better viewed as instruments.

Volta

In a repeated section of music, it is common for the last few measures of the section to differ. Markings called voltas are used to indicate how the section is to be ended each time. These markings are often referred to simply as endings.

External links

- http://www.robertcarney.net/musical-terms-definitions.htm