GETTING STARTED

INSTALLATION

INSTALL ON WINDOWS
- Install
  - Start MuseScore
  - Uninstall
- Troubleshooting
- External links

INSTALL ON MACOS
- Install
- Uninstall
- Install with Apple Remote Desktop
- External links

INSTALL ON LINUX
- AppImage
  - Step 1 - Download
  - Step 2 - Give execute permission
  - Step 3 - Run it!
  - Installing the AppImage (optional)
  - Using command line options
- Distribution Packages
  - Fedora
- External links

INSTALL ON CHROMEBOOK
- Desktop program
- Android app (playback only)
- External links

CREATE A NEW SCORE
- Start Center
- Create new score
  - Enter score information
  - Choose template file
  - Choose instruments (or voice parts)
  - Add instruments
  - Add Staff / Add Linked Staff
  - Change order of instruments
  - Create an instrument
  - Choose key signature and tempo
  - Choose time signature, pickup measure, and number of measures
- Adjustments to score after creation
  - Add/delete measures
  - Add/edit text
  - Change instrument set-up
  - Hide a staff
  - Adjust layout and formatting
- Templates
  - System templates folder
  - User templates folder
- See also
- External links

LANGUAGE SETTINGS AND TRANSLATION UPDATES
- Change language
- Update translation
- See also
- External links

CHECKING FOR UPDATES
- Automated update check
- Check for update
- See also

BASICS

NOTE INPUT
- Basic note entry
  - Step 1. Select a starting position
  - Step 2. Enter Note Input mode
  - Step 3. Select a duration
Step 4. Enter the note or rest

Select a note/rest duration

Input devices

- Computer keyboard
- Input devices
- MIDI keyboard
- Virtual Piano Keyboard

Input modes

- Coloring of notes outside an instrument's range
- Small notes/small noteheads
- Change notes or rests already entered
- Change notes or rests already entered
- Change note and vice versa
- Note properties
- See also
- External links

EDIT MODE

- Enter/exit edit mode
- Text
- Lines
- Notes
- Offset notes
- Adjust note stem length
- Keyboard shortcuts

PALETTES AND WORKSPACES

- Workspaces
- Custom workspace
- Palettes
- Open/close palette
- Apply symbols from a palette
- Preset palettes (Advanced workspace)
- Custom palettes
- Palette menu
- See also

INSPECTOR AND OBJECT PROPERTIES

- Inspector
- Inspector categories
- Element
- Element Group
- Segment
- Chord
- Note
- Select
- Beam
- Clef
- Properties dialogs
- Articulation properties
- Fretboard diagram properties
- Line properties
- Measure properties
- Staff properties
- Text properties
- Time signature properties

MEASURE OPERATIONS

- Select
- Single measure
- Range of measures
- Insert
- Insert an empty measure into the score
- Insert multiple measures
- Append
- Append an empty measure to the end of a score
- Append multiple measures to the end of a score
- Delete
- Delete a single measure
- Delete a range of measures
- Properties
- Staves
Measure duration
Other
Exclude from measure count
Add to measure number
Layout stretch
Play Count (as of version 2.1) / Repeat count (prior to version 2.1)
Break multi-measure rests
Numbering
Split and join
Join measures
Split a measure
External links

VOICES
When to use voices
How to enter notes in different voices
Deleting and hiding rests
Restoring deleted rests
Exchange voices of notes
Move notes to another voice (without swapping)
See also
External links

COPY AND PASTE
Summary of commands
Notes
Copy or cut
Paste
Swap with Clipboard
Copy pitch of a single note only
Other elements
Copy or cut
Paste
Quick repeat
Duplicate
Selection filter
See also
External links

SELECTION MODES
Select a single object
Select a single note
Select a chord
Select a single measure
Select a continuous range of objects
1. Shift selection
2. Shift + click selection
3. Drag selection
4. Select All
5. Select section
Select a list of objects
Select all similar
What selections are useful for
See also

VIEWING AND NAVIGATION
View menu
Show sidebars/panels
Zoom in/out
Toolbars (display)
Show Status bar
Split display
Visibility options
Full screen
Page/Continuous View
Page View
Continuous View
Toolbars
Side panels
Navigation
Navigator
Find
See also

OPEN/SAVE/EXPORT/PRINT
Open
Save
Export
Print
### UNDO AND REDO

- Create an account
- Share a score directly from MuseScore
- Upload a score on MuseScore.com
- Edit a score on MuseScore.com
- Switch to the direct method of updating an online score

### SHARE SCORES ONLINE

- Create an account
- Share a score directly from MuseScore
- Upload a score on MuseScore.com
- Edit a score on MuseScore.com
- Switch to the direct method of updating an online score

### CONCERT PITCH

- See also
- External links

### NOTATION

#### BARLINES

- Change barline type
- Insert barline
- Custom barlines
- Connect barlines
- See also

#### CLEFS

- Add a clef
  - Add clef to beginning of measure
  - Add mid-measure clef
-Courtesy clefs
- Remove a clef
- Hide clefs
  - Display clef only in the first measure (for all staves)
  - Display clef only in the first measure (for a particular staff)
  - Hide all clefs in a particular staff

#### KEY SIGNATURES

- Add a new key signature
  - Add new key signature to all staves
  - Add new key signature to one staff only
- Replace an existing key signature
  - Replace key signature for all staves
  - Replace key signature for one staff only
- Remove a key signature
- Naturals on key signature changes
- Key signature changes and multi-measure rests
- Courtesy key signatures
- Custom key signatures

#### TIME SIGNATURES

- Add a time signature to a score
- Delete a time signature
- Create a time signature
- Time signature properties
  - Change default beaming
  - Additive (composite) meters
  - Local time signatures
- Pickup measures and cadenzas
- Time signature changes and breaks
- See also
- External links

#### ACCIDENTALS

- Add accidental
- Change enharmonic spelling
- Respell pitches
- See also
- External links

#### ARPEGGIOS AND GLISSANDI

- Arpeggios
- Glissandi (slides)
  - Adjust start and end points
  - Custom glissandi
Wind instrument articulations 76
Slide in/out 76
External links 77

ARTICULATIONS AND ORNAMENTS 77

Articulations 77
Ornaments 77
Add articulation/ornament 77
   Add accidental to an ornament 77
   Add fermata to a barline 78
Keyboard shortcuts 78
Adjust position 78
Articulation properties 78
See also 78
External links 78

BENDS 78
Apply a bend 78
Edit a bend 79
Adjust height 79
Adjust position 79
Custom bends 80

BEAMS 80
Beam symbols 80
Change note beaming 80
Adjust beam with the keyboard/mouse 81
   Adjust beam angle 81
   Adjust beam height 81
Adjust beam with the inspector 81
   Adjust beam angle 81
   Adjust beam height 81
   Make the beam horizontal 81
   Adjust feathered beams 81
   Local relayout 81
Flip note beam 82
Reset Beam Mode 82
See also 82
External links 82

BRACKETS 82
Add 82
Delete 82
Change 83
Edit 83
Style 83

BREATHS AND PAUSES 83
Add symbol 83
Adjust position 83
Adjust pause length 83

GRACE NOTES 83
Create grace notes 84
Change pitch 84
Change duration 84
Manual adjustment 84
External links 84

HAIRPINS 84
Add a hairpin 84
Adjust length 85
Cresc. and dim. lines 85
Hairpin playback 86

LINES 86
Applying lines to the score 86
   To apply a line to just one note 86
   To apply a line across a range of notes 86
   To apply a line from a note to the end of that measure 87
   To apply a line across a range of measures 87
Adjust vertical position 87
Change length 87
Text lines 87
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Custom lines and line properties</td>
<td>87</td>
</tr>
<tr>
<td>Copying lines</td>
<td>88</td>
</tr>
<tr>
<td>Extended ornament lines</td>
<td>88</td>
</tr>
<tr>
<td>External links</td>
<td>88</td>
</tr>
<tr>
<td><strong>MEASURE RESTS</strong></td>
<td>88</td>
</tr>
<tr>
<td>Full measure rest</td>
<td>88</td>
</tr>
<tr>
<td>To create one or more full measure rests</td>
<td>88</td>
</tr>
<tr>
<td>To create a full measure rest in a particular voice</td>
<td>88</td>
</tr>
<tr>
<td>Multimeasure rest</td>
<td>88</td>
</tr>
<tr>
<td>To display multimeasure rests</td>
<td>88</td>
</tr>
<tr>
<td>Break multimeasure rest</td>
<td>88</td>
</tr>
<tr>
<td><strong>OCTAVE LINES</strong></td>
<td>89</td>
</tr>
<tr>
<td>Apply an octave line</td>
<td>89</td>
</tr>
<tr>
<td>Change length</td>
<td>89</td>
</tr>
<tr>
<td>Custom lines</td>
<td>90</td>
</tr>
<tr>
<td>External links</td>
<td>90</td>
</tr>
<tr>
<td><strong>SLURS</strong></td>
<td>90</td>
</tr>
<tr>
<td>Add slur in note-input mode</td>
<td>90</td>
</tr>
<tr>
<td>Add slur outside note-input mode</td>
<td>90</td>
</tr>
<tr>
<td>Method 1</td>
<td>90</td>
</tr>
<tr>
<td>Method 2</td>
<td>90</td>
</tr>
<tr>
<td>Adjust slur</td>
<td>91</td>
</tr>
<tr>
<td>Extended slurs</td>
<td>91</td>
</tr>
<tr>
<td>Dotted slurs</td>
<td>91</td>
</tr>
<tr>
<td>See also</td>
<td>91</td>
</tr>
<tr>
<td><strong>TIES</strong></td>
<td>92</td>
</tr>
<tr>
<td>Tie notes together</td>
<td>92</td>
</tr>
<tr>
<td>Tie chords together</td>
<td>92</td>
</tr>
<tr>
<td>Add tied notes in note input mode</td>
<td>92</td>
</tr>
<tr>
<td>Add a tied chord in note input mode</td>
<td>92</td>
</tr>
<tr>
<td>Tied unison notes</td>
<td>93</td>
</tr>
<tr>
<td>Flip a tie</td>
<td>93</td>
</tr>
<tr>
<td>See also</td>
<td>93</td>
</tr>
<tr>
<td>External links</td>
<td>93</td>
</tr>
<tr>
<td><strong>TREMOLO</strong></td>
<td>93</td>
</tr>
<tr>
<td><strong>TUPLETS</strong></td>
<td>93</td>
</tr>
<tr>
<td>Create a tuplet</td>
<td>94</td>
</tr>
<tr>
<td>Create a triplet in normal mode</td>
<td>94</td>
</tr>
<tr>
<td>Create a triplet in note input mode</td>
<td>94</td>
</tr>
<tr>
<td>Create other tuplets</td>
<td>94</td>
</tr>
<tr>
<td>Custom tuplets</td>
<td>94</td>
</tr>
<tr>
<td>Delete a tuplet</td>
<td>95</td>
</tr>
<tr>
<td>Change display of tuplets</td>
<td>95</td>
</tr>
<tr>
<td>Using the Inspector</td>
<td>95</td>
</tr>
<tr>
<td>Using the Style menu</td>
<td>96</td>
</tr>
<tr>
<td>External links</td>
<td>97</td>
</tr>
<tr>
<td><strong>REPEATS AND JUMPS</strong></td>
<td>97</td>
</tr>
<tr>
<td>Simple repeats</td>
<td>97</td>
</tr>
<tr>
<td>1st and 2nd endings</td>
<td>98</td>
</tr>
<tr>
<td>Playback</td>
<td>98</td>
</tr>
<tr>
<td>Repeat symbols and text</td>
<td>98</td>
</tr>
<tr>
<td>Jumps</td>
<td>98</td>
</tr>
<tr>
<td>Markers</td>
<td>99</td>
</tr>
<tr>
<td>Examples of jumps</td>
<td>99</td>
</tr>
<tr>
<td>See also</td>
<td>99</td>
</tr>
<tr>
<td>External links</td>
<td>99</td>
</tr>
<tr>
<td><strong>VOLTAS</strong></td>
<td>99</td>
</tr>
<tr>
<td>To add a volta to the score</td>
<td>99</td>
</tr>
<tr>
<td>To change the number of measures that a volta covers</td>
<td>100</td>
</tr>
<tr>
<td>Text</td>
<td>100</td>
</tr>
<tr>
<td>Playback</td>
<td>101</td>
</tr>
<tr>
<td>External links</td>
<td>101</td>
</tr>
<tr>
<td><strong>TRANSPOSITION</strong></td>
<td>101</td>
</tr>
<tr>
<td>Manual transposition</td>
<td>101</td>
</tr>
<tr>
<td>Automatic transposition</td>
<td>101</td>
</tr>
<tr>
<td>Transpose Chromatically</td>
<td>102</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>--------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td><strong>DRUM NOTATION</strong></td>
<td>103</td>
</tr>
<tr>
<td>Percussion staff types</td>
<td>103</td>
</tr>
<tr>
<td>Note input methods</td>
<td>103</td>
</tr>
<tr>
<td>MIDI keyboard</td>
<td>104</td>
</tr>
<tr>
<td>Piano keyboard</td>
<td>104</td>
</tr>
<tr>
<td>Computer keyboard</td>
<td>104</td>
</tr>
<tr>
<td>Mouse</td>
<td>104</td>
</tr>
<tr>
<td>Drum input palette</td>
<td>105</td>
</tr>
<tr>
<td>Edit Drumset</td>
<td>105</td>
</tr>
<tr>
<td>Roll</td>
<td>106</td>
</tr>
<tr>
<td>External links</td>
<td>106</td>
</tr>
<tr>
<td><strong>TABLATURE</strong></td>
<td>106</td>
</tr>
<tr>
<td>Create a new tablature staff</td>
<td>107</td>
</tr>
<tr>
<td>With the New Score wizard</td>
<td>107</td>
</tr>
<tr>
<td>With the Instruments dialog</td>
<td>108</td>
</tr>
<tr>
<td>By changing staff type</td>
<td>108</td>
</tr>
<tr>
<td>Edit string data</td>
<td>108</td>
</tr>
<tr>
<td>Change tuning</td>
<td>108</td>
</tr>
<tr>
<td>Add a string</td>
<td>109</td>
</tr>
<tr>
<td>Delete a string</td>
<td>109</td>
</tr>
<tr>
<td>Mark untented string &quot;open&quot;</td>
<td>109</td>
</tr>
<tr>
<td>Change number of instrument frets</td>
<td>110</td>
</tr>
<tr>
<td>Change tablature display</td>
<td>110</td>
</tr>
<tr>
<td>Combine pitched staff with tablature</td>
<td>110</td>
</tr>
<tr>
<td>Create a staff/tablature pair with the New Score wizard</td>
<td>110</td>
</tr>
<tr>
<td>Create a staff/tablature pair in an existing score</td>
<td>110</td>
</tr>
<tr>
<td>Create a staff/tablature pair from an existing staff</td>
<td>111</td>
</tr>
<tr>
<td>Enter notes in tablature</td>
<td>111</td>
</tr>
<tr>
<td>Using a computer keyboard</td>
<td>111</td>
</tr>
<tr>
<td>Using a mouse</td>
<td>111</td>
</tr>
<tr>
<td>Selected note duration</td>
<td>112</td>
</tr>
<tr>
<td>Edit notes</td>
<td>112</td>
</tr>
<tr>
<td>Note input mode</td>
<td>112</td>
</tr>
<tr>
<td>Non note input mode</td>
<td>112</td>
</tr>
<tr>
<td>Crosshead notes</td>
<td>112</td>
</tr>
<tr>
<td>Summary of keyboard commands</td>
<td>112</td>
</tr>
<tr>
<td>Note input mode</td>
<td>112</td>
</tr>
<tr>
<td>Normal mode</td>
<td>113</td>
</tr>
<tr>
<td>External links</td>
<td>113</td>
</tr>
<tr>
<td><strong>SOUND AND PLAYBACK</strong></td>
<td>113</td>
</tr>
<tr>
<td><strong>MID-STAFF INSTRUMENT CHANGES</strong></td>
<td>113</td>
</tr>
<tr>
<td>Instrument changes as of version 2.1</td>
<td>113</td>
</tr>
<tr>
<td>Instrument changes in version 2.0</td>
<td>113</td>
</tr>
<tr>
<td>Incompatibilities</td>
<td>114</td>
</tr>
<tr>
<td>Add an instrument change</td>
<td>114</td>
</tr>
<tr>
<td>See also</td>
<td>115</td>
</tr>
<tr>
<td>External links</td>
<td>115</td>
</tr>
<tr>
<td><strong>MIXER</strong></td>
<td>115</td>
</tr>
<tr>
<td>Mute and Solo</td>
<td>116</td>
</tr>
<tr>
<td>Dials</td>
<td>116</td>
</tr>
<tr>
<td>Sound</td>
<td>116</td>
</tr>
<tr>
<td>Mid-staff sound change (pizz., con sordino, etc.)</td>
<td>116</td>
</tr>
<tr>
<td>See also</td>
<td>116</td>
</tr>
<tr>
<td>External links</td>
<td>116</td>
</tr>
<tr>
<td><strong>PLAY MODE</strong></td>
<td>117</td>
</tr>
<tr>
<td>Playback commands</td>
<td>117</td>
</tr>
<tr>
<td>Start/stop playback</td>
<td>117</td>
</tr>
<tr>
<td>During playback</td>
<td>117</td>
</tr>
<tr>
<td>Play panel</td>
<td>117</td>
</tr>
<tr>
<td>Count in</td>
<td>118</td>
</tr>
<tr>
<td>Metronome playback</td>
<td>118</td>
</tr>
<tr>
<td>Loop playback</td>
<td>118</td>
</tr>
</tbody>
</table>

**SOUNDFONTS AND SFZ FILES** 118
SoundFonts 119
Install a SoundFont 119
Uninstall 119
SFZ 119
Install an SFZ 119
Uninstall 119
Synthesizer 120
List of downloadable soundfiles 120
GM SoundFonts 120
Orchestral soundfiles 120
Piano soundfiles 120
SFZ Pianos 120
SF2 Pianos 121
Unzipping downloaded soundfiles 121
Troubleshooting 121
See also 121
External links 122

SWING 122
Apply swing to a score section 122
Triplet in tempo marking 122
Return to straight rhythm 122
Apply swing globally 122
External links 122

SYNTHESIZER 123
Overview 123
Save/Load Synthesizer settings 123
Fluid 123
To load a soundfont 123
To reorder the soundfonts 124
To remove a soundfont 124
Zerberus 124
Volume 124
Effects 125
Zita 1 reverb 125
SC4 compressor 126
Tuning 126
See also 127

TEMPO 127
Add a tempo marking 127
Edit tempo 127
Edit tempo text 127
Overriding the tempo marking 128
Ritardando and accelerando playback 128
Fermatas 128
See also 128

DYNAMICS 128
Add a dynamic 129
Adjusting playback volume for a dynamic 129
Adjusting range for a dynamic 129
List of dynamics in palettes 129
Edit a dynamic 129
See also 129
External links 129

TEXT 129

TEXT BASICS 130
Add text 130
Format text 130
Adjust position of text objects 130
Text anchors 131

TEXT EDITING 131
Enter/exit text edit mode 131
Keyboard shortcuts 131
Symbols and special characters 132
Special character shortcuts 132
See also 133

TEXT STYLES AND PROPERTIES 133
Text Style 133
<table>
<thead>
<tr>
<th>IMAGE CAPTURE</th>
<th>177</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save a snapshot</td>
<td>177</td>
</tr>
<tr>
<td>Image capture menu</td>
<td>177</td>
</tr>
<tr>
<td>See also</td>
<td>178</td>
</tr>
<tr>
<td>External links</td>
<td>178</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>ALIGN ELEMENTS</th>
<th>178</th>
</tr>
</thead>
<tbody>
<tr>
<td>Snap to grid</td>
<td>178</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>ADVANCED TOPICS</th>
<th>178</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACCESSIBILITY</td>
<td>178</td>
</tr>
<tr>
<td>Introduction</td>
<td>178</td>
</tr>
<tr>
<td>Initial setup</td>
<td>178</td>
</tr>
<tr>
<td>Finding your way around</td>
<td>179</td>
</tr>
<tr>
<td>The score window</td>
<td>179</td>
</tr>
<tr>
<td>Score reading</td>
<td>180</td>
</tr>
<tr>
<td>Moving forwards or backwards in time</td>
<td>180</td>
</tr>
<tr>
<td>Moving between notes at a given point in time</td>
<td>180</td>
</tr>
<tr>
<td>Filtering score reading</td>
<td>181</td>
</tr>
<tr>
<td>Score playback</td>
<td>181</td>
</tr>
<tr>
<td>Score editing</td>
<td>181</td>
</tr>
<tr>
<td>Customization</td>
<td>181</td>
</tr>
<tr>
<td>External links</td>
<td>181</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>ALBUMS</th>
<th>181</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create album</td>
<td>182</td>
</tr>
<tr>
<td>Load album</td>
<td>182</td>
</tr>
<tr>
<td>Print album</td>
<td>182</td>
</tr>
<tr>
<td>Join scores</td>
<td>182</td>
</tr>
<tr>
<td>Save album</td>
<td>182</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>CROSS-STAFF NOTATION</th>
<th>182</th>
</tr>
</thead>
<tbody>
<tr>
<td>See also</td>
<td>183</td>
</tr>
<tr>
<td>External links</td>
<td>183</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>EARLY MUSIC FEATURES</th>
<th>183</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unbarred (or unmetered) notation</td>
<td>183</td>
</tr>
<tr>
<td>Example</td>
<td>184</td>
</tr>
<tr>
<td>Mensurstrich</td>
<td>184</td>
</tr>
<tr>
<td>Ambitus</td>
<td>185</td>
</tr>
<tr>
<td>Mensural time signatures</td>
<td>185</td>
</tr>
<tr>
<td>See also</td>
<td>186</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>FIGURED BASS</th>
<th>186</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding a new figured bass indication</td>
<td>186</td>
</tr>
<tr>
<td>Text format</td>
<td>186</td>
</tr>
<tr>
<td>Digits</td>
<td>186</td>
</tr>
<tr>
<td>Accidentals</td>
<td>187</td>
</tr>
<tr>
<td>Combined shapes</td>
<td>187</td>
</tr>
<tr>
<td>Parentheses</td>
<td>187</td>
</tr>
<tr>
<td>Grace lines</td>
<td>188</td>
</tr>
<tr>
<td>Duration</td>
<td>188</td>
</tr>
<tr>
<td>Editing existing figured basses</td>
<td>189</td>
</tr>
<tr>
<td>Style</td>
<td>189</td>
</tr>
<tr>
<td>Proper syntax</td>
<td>191</td>
</tr>
<tr>
<td>Summary of keys</td>
<td>191</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>FILE FORMATS</th>
<th>191</th>
</tr>
</thead>
<tbody>
<tr>
<td>MuseScore native format</td>
<td>191</td>
</tr>
<tr>
<td>MuseScore format (*.mscz)</td>
<td>192</td>
</tr>
<tr>
<td>Uncompressed MuseScore format (*.mscz)</td>
<td>192</td>
</tr>
<tr>
<td>MuseScore backup file (<em>.mscz), or (</em>.mscx)</td>
<td>192</td>
</tr>
<tr>
<td>Graphic files (export only)</td>
<td>192</td>
</tr>
<tr>
<td>PDF (*.pdf)</td>
<td>192</td>
</tr>
<tr>
<td>PNG (*.png)</td>
<td>192</td>
</tr>
<tr>
<td>SVG (*.svg)</td>
<td>192</td>
</tr>
<tr>
<td>Audio files (export only)</td>
<td>193</td>
</tr>
<tr>
<td>WAV audio (*.wav)</td>
<td>193</td>
</tr>
<tr>
<td>MPS (*.mp3)</td>
<td>193</td>
</tr>
<tr>
<td>FLAC audio (*.flac)</td>
<td>193</td>
</tr>
<tr>
<td>Ogg Vorbis (*.ogg)</td>
<td>193</td>
</tr>
<tr>
<td>Share with other music software</td>
<td>193</td>
</tr>
<tr>
<td>MusicXML (*.xml, *.musicxml)</td>
<td>194</td>
</tr>
<tr>
<td>Compressed MuseXML (*.mxl)</td>
<td>194</td>
</tr>
</tbody>
</table>
### MIDI Import

- MIDI (*.mid, *.midi, *.kar)
- MuseData (*.md) (import only)
- Capella (*.cap, *.capx) (import only)
- Bagpipe Music Writer (*.bww) (import only)
- BBI (*.bgi, *.bgg) (import only)
- Overture (*.ove) (import only)
- Guitar Pro (*.gtp, *.gp3, *.gp4, *.gp5, *.gpx) (import only)

See also

- External links

### Fretboard Diagrams

- Add a fretboard diagram
- Edit fretboard diagram
- Adjust position, size, color
- Fretboard diagram style

### MIDI Import

- Available operations

### Master Palette

- Symbols
  - Find a symbol
  - Apply a symbol
  - Connect symbols

See also

### NOTE Input Modes

- Step-time
- Re-pitch
- Rhythm
- Real-time (automatic)
- Real-time (manual)
  - Real-time Advance shortcut

See also

- External links

### Noteheads

- Notehead groups
- Change notehead group
- Change notehead type
- Shared noteheads
  - Change offset noteheads to shared
  - Examples of notehead sharing
  - Remove duplicate fret marks

External links

### Parts

- Set up all parts at once
- Define specific parts
- Delete a Part
- Export the parts
- Save the parts
- Print a part

### Plugins

- Overview
- Installation
- Windows
- macOS
- Linux

Enable/disable plugins

Create/edit/run plugins

Plugins installed by default

- ABC Import
- Break Every X Measures
- Notes → Color Notes
- Create Score
- helloQml
- Notes → Note Names
- Panel
- random
- random2
- run
- scorelist
- ScoreView
- Walk

See also
## REVERT TO FACTORY SETTINGS

### MuseScore 2.0.3 and above

Instructions for Windows

Instructions for MacOS

Instructions for Linux

See also

### KNOWN INCOMPATIBILITIES

#### Hardware incompatibilities

#### Software incompatibilities

- AVG Internet Security hangs MuseScore
- Font problem on macOS
- Font problem on Linux
- Save As dialog empty on Linux

## APPENDIX

### KEYBOARD SHORTCUTS

- Navigation
- Note input
- Duration
- Voices
- Pitch
- Interval
- Layout
- Articulations
- Text entry
- Lyrics entry
- Display
- Miscellaneous

See also

### KNOWN LIMITATIONS OF MUSESCORE 2.X

- Local time signatures
- Regroup Rhythms
- Tablature staff linked with standard staff
- Mixer
- Header & footer

### COMMAND LINE OPTIONS

- Qt Toolkit Options

See also

### GLOSSARY

### TABLE OF CONTENTS

## GETTING STARTED

## BASICS

## NOTATION

## SOUND AND PLAYBACK

## TEXT

## FORMATTING

## ADVANCED TOPICS

## NEW FEATURES IN MUSESCORE 2.0
<table>
<thead>
<tr>
<th>SUPPORT</th>
<th>243</th>
</tr>
</thead>
<tbody>
<tr>
<td>APPENDIX</td>
<td>243</td>
</tr>
</tbody>
</table>
This handbook is for MuseScore version 2.0 and above. It is maintained by the MuseScore community. Find out how you can help.

Getting started

This chapter helps you to install and run MuseScore for the first time. The chapter will also show you how to create a new score.

Installation

MuseScore exists for various different operating systems, including Windows and macOS, as well as many Linux distributions and several BSD variants.

Install on Windows

Install

If you’re on Windows 10, MuseScore can be installed from the Windows Store. Clicking here will open MuseScore’s page in the Store app. There you will only have to click Get the app > and MuseScore will be downloaded and installed.

Otherwise you can get the Windows installer from the download page of the MuseScore website. Click on the link to start the download. Your Internet browser will ask you to confirm that you want to download this file. Click Save File.

When the download finishes, double-click on the file to start the installation. Windows may prompt you with a security window to confirm this before running the software. Click Run to continue, you’ll then briefly see

![Windows Installer](attachment://image1.png)

followed by

![MuseScore 2 Setup](attachment://image2.png)

In case you don't see this installer window but something else, it's possible that the .msi extension is not associated with msiexec.exe. Either you can fix the association, or download and use the portable version of MuseScore instead.

Continuing you’ll see
If you click Cancel, here or later, you'll see:

If instead you click Next to continue, the setup wizard displays the terms of the free software license.
Read the terms of the license, make sure the box next to "I accept the terms in the License Agreement" is checked, and click Next to continue. Next the installer will ask you to confirm the location in which to install MuseScore.

If you are installing a newer version of MuseScore but still want to keep the old version on your computer, then you should change the folder (note that MuseScore 2 can coexist with MuseScore 1 with no changes needed). Otherwise click Next to continue.

Click Install to continue.

Give the setup wizard a few minutes to install the necessary files and configurations. You'll see
and finally

Click Finish to exit the installer. You may delete the installer file you downloaded.

Start MuseScore

To start MuseScore, from the menu, select Start → All Programs → MuseScore 2 → MuseScore 2.

Uninstall

You can uninstall MuseScore from the menu by selecting Start → All Programs → MuseScore 2 → Uninstall MuseScore; or via Windows' Control Panel. Note that this will not remove your scores nor your MuseScore settings.

Troubleshooting

On Windows XP and Vista, the installer might be blocked by the system. If you don't manage to install MuseScore, right click the downloaded file and click Properties. If there is a message "This file came from another computer and might be blocked to help protect this computer", click on "Unblock", "OK" and double click on the downloaded file again.

External links

- How to install MuseScore on Windows without administrator rights
- How to run MuseScore as Administrator on Windows
• How to change the language in MuseScore

Install on macOS

Install

You will find the DMG (disk image) file on the download page of the MuseScore website. Click on the macOS link to start the download. When the download is complete, double-click the DMG file to mount the disk image.

Drag and drop the MuseScore icon to the Applications folder icon.

If you are not logged in as administrator, macOS may ask for a password: click Authenticate and enter your password to proceed.

When the application has finished copying, eject the disk image. You can now launch MuseScore from the Applications folder, Spotlight, or Launchpad.

Uninstall

Simply delete MuseScore from Applications folder.

Install with Apple Remote Desktop

You can deploy MuseScore to multiple computers with the "Copy" feature of ARD. Since MuseScore is a self-contained application you can simply copy the application to the ‘/Application’ folder on the target machines. It is also possible to install multiple versions of the application as long as their names differ.

External links
How to run MuseScore 2.x on Mac OS X 10.6

How to change the language in MuseScore

Install on Linux

As of MuseScore 2.0.3 you can, for the first time, get hold of a copy for Linux straight from the download page, just like Windows and Mac users. This is possible thanks to the AppImage packaging format, which runs on pretty much all Linux distributions. If you prefer, there is still the option to get it the traditional way via your distribution's package manager (but you may have to wait for it to get packaged by the relevant maintainer). Of course, you can always build from source.

AppImage

The AppImage format is a new way of packaging Linux applications. AppImages are portable - they don't have to be installed - and they run on pretty much any Linux distribution. Dependencies are included in the one AppImage file.

Step 1 - Download

Before you download an AppImage, you need to know your processor's architecture. These terminal commands will show it:

`arch`

or

`uname -m`

The output will be something like "i686", "x86_64" or "armv7":

- i686 (or similar) - 32-bit Intel/AMD processor (found on older machines).
- x86_64 (or similar) - 64-bit Intel/AMD processor (modern laptop and desktop computers, most Chromebooks).
- armv7 (or later) - ARM processor (phones & tablets, Raspberry Pi 2/3 running Ubuntu Mate, some Chromebooks, usually 32-bit at present).

Now you can head over to the download page and find the AppImage that best matches your architecture. Once downloaded, the file will be named "MuseScore-X.Y.Z-$(arch).AppImage".

Step 2 - Give execute permission

Before you can use the AppImage you need to give permission for it to be run as a program.

From the Terminal:

This command gives the user (u) permission to execute (x) the AppImage. It works on all Linux systems.

```
   cd ~/Downloads
   chmod u+x MuseScore*.AppImage
```

Note: Use the "cd" command to change directory to wherever you saved the AppImage.

From a File Manager:

If you prefer to avoid the command line, there is usually a way give execute permission from inside a File Manager.

In GNOME Files (Nautilus), simply:

1. Right-click on the AppImage and select "Properties".
2. Open the "Permissions" tab.
3. Enable the option labelled "Allow executing file as a program".

The process may be slightly different in other file managers.

Step 3 - Run it!

Now you should be able to run the program simply by double-clicking on it!

When you downloaded the AppImage it was probably saved in your Downloads folder, but you can move somewhere else it at any time (e.g. you could put it on your desktop for easy access). If you ever want to remove it then simply delete it.
Installing the AppImage (optional)

You can run the AppImage without installing it, but you must install it if you want it to be completely integrated with your desktop environment. This has the following benefits:

- Adds the AppImage to your Applications Menu or Launcher
- Sets the correct icons for MuseScore's files (MSCZ, MSCX) and for MusicXML files (MXL, XML)
- Makes the AppImage available via your File Manager's right-click "Open with..." menu

To install it, run the AppImage from the Terminal with the "install" option (see immediately below). This copies a desktop file and various icons to your computer. If you want to remove them you will need to run the "remove" option before you delete the AppImage. This does not affect any scores created with any version of MuseScore.

Using command line options

Running the AppImage from the Terminal allows you to use various command line options. The AppImage has some special options in addition to MuseScore's normal command line options.

You will need to change directory (cd) to wherever the AppImage is saved your system, for example:

```bash
cd ~/Desktop
./MuseScore*.AppImage [option...]
```

Or give the path to the AppImage:

```bash
~/desktop/MuseScore*.AppImage [option...]
```

Use the "--help" and "man" options to get more information about the available command line options:

```bash
./MuseScore*.AppImage --help  # displays a complete list of command line options
./MuseScore*.AppImage man    # displays the manual page (explains what the options do)
```

Distribution Packages

Fedora

1. Import the GPG key:

```bash
su
rpm --import http://prereleases.musescore.org/linux/Fedora/RPM-GPG-KEY-Seve
```

2. Go to the download page of the MuseScore website. Click on the link for the stable Fedora download and choose the correct rpm package for your architecture.

3. Depending on your architecture, use one of the two sets of commands to install MuseScore

   - for arch i386
     ```bash
     su
     yum localinstall musescore-X.Y-1.fc10.i386.rpm
     ```

   - for arch x86_64
     ```bash
     su
     yum localinstall musescore-X.Y-1.fc10.x86_64.rpm
     ```

If you have difficulty with sound, see Fedora 11 and sound. See also the hints for the various distributions on the download page.

External links

- How to run the MuseScore AppImage on Linux - video
- How to change the language in MuseScore

Install on Chromebook
Desktop program

MuseScore's desktop program will not work natively on Chrome OS, but there are some workaround solutions:

1. Since Chrome OS 69, certain chromebook models are able to run Linux apps and so you can install MuseScore for Linux as provided on our Download page. Feedback about the installation process and supported hardware is welcome on the forum.

2. Via software-on-demand service such as rollApp. By just visiting this website, you can run MuseScore in the browser. You can access your scores via cloud services such as Google Drive or save them to your online MuseScore account through the menu File → Save Online.... Note that currently, sound and playback does not work on rollApp.

3. Via Crouton. Involves installing a Linux based operating system which runs in parallel with Chrome OS, and then installing MuseScore on Linux.

Android app (playback only)

Alternatively, it is possible to install MuseScore's Android app on recent Chromebooks. You will need to update to the latest version of Chrome OS first. See the Chromebook support documentation for help installing Android apps on Chromebooks, and a list of supported devices. The app only supports playback of existing scores, not score editing or creation, but you can sign-in to your MuseScore account for easy access to all your scores on MuseScore.com.

External links

- How to run MuseScore on a Chromebook
- Check the installation procedure from the comments in this thread
- How to change the language in MuseScore

Create a new score

To create a new score, open the New Score Wizard (see Create new score, below): this can also be accessed via the Start Center.

Start Center

This is the window that displays when you open MuseScore for the very first time:
To open the Start Center (if not already visible), use any of the following options:

- Press F4.
- From the menu bar, select View → Start Center...

From the Start Center you can:

- Open the "Getting Started" tutorial score.
- View thumbnails of previously-opened scores: click on a thumbnail to open it.
- Open a score from your computer’s file system: click on Open a score ...
- Create a new score (by clicking on the icon with the plus sign).
- See the "In the spotlight" score of the day.
- Search sheet music on musecore.com.
- Link to mobile apps
- Link to follow MuseScore on social networks

Create new score

To open the New Score Wizard when the Start Center is not open, use one of the following options:

- Click on the New Score icon in the toolbar on the top left of the window;
- Use keyboard shortcut Ctrl+N (Mac: Cmd+N);
- From the menu, select File → New....

**Note:** The following subheadings may differ slightly in versions prior to MuseScore 2.2.

Enter score information

![Create New Score](image)

*Step 1: Enter score information.*

Enter the title, composer, or any other information as shown above, then click on Next >. This step is optional: you can also add this information after the score is created (see Vertical frame).

Choose template file
Step 2: Choose template file.

Here, you can choose from a range of solo, ensemble and orchestral templates. Any custom templates stored in your user templates folder will be displayed under the heading, "Custom Templates". From version 2.2, you can use the Search bar (top right) to find specific templates.

- Click on a template to select it. This will automatically take you to the next page of the Wizard (Chose key signature and tempo).
- Alternatively, to choose exactly which instruments to include in your score, click on the "Choose Instruments" template (under "General").

Choose instruments (or voice parts)
The **Choose Instruments** window is divided into two columns:

- The **left column** contains a list of instruments, or voice parts to choose from. This list is categorized into instrument families, and clicking a category shows the full list of instruments in each family.

  The default entry is "Common instruments" but you can choose from others, including "Jazz instruments" and "Early music". There is a search box at the bottom of the instrument window: typing the name of an instrument there will search for it in "All instruments".

- The **right column** starts off empty, but will eventually contain a list of instruments for your new score in the order that they will appear.

**Add instruments**

To add instruments to the score, use any of the following options:

- Select one or more instruments in the left column and click **Add**.
- Double-click an instrument in the left column.

The instrument names, and their associated staff lines, now appear in the list of instruments in the right column. You can add more instruments or voice parts, as needed. Each instrument added in this way is allocated its own **Mixer** channel.

**Note:** If you want staves to share the same instrument, use the **Add staff** or **Add linked staff** commands instead (see below).

**Add Staff / Add Linked Staff**

To add a staff to an **existing** instrument in the score:

1. Select a staff in the score list on the right-hand side (e.g. see "Staff 1" in the image below). Click **Add Staff** or **Add Linked Staff**.
2. Adjust the **Staff type**, if applicable.
Summary of commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Staff added</th>
<th>Edit staves independently?</th>
<th>Share mixer channel?</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Staff</td>
<td>Unlinked</td>
<td>Yes</td>
<td>Yes</td>
<td>Guitar staff/tab, Piano grand staff</td>
</tr>
<tr>
<td>Add Linked Staff</td>
<td>Linked</td>
<td>No. Edit in one staff updates others</td>
<td>Yes</td>
<td>Guitar staff/tab</td>
</tr>
</tbody>
</table>

See also, Combine pitched staff with tablature.

Change order of instruments

To change the order of instruments (or staves) in the score:

- Click either an instrument name or a staff, in the right-hand column, and use the ↑ or ↓ buttons to move it higher/lower.

Delete an instrument
To **delete** an instrument, or staff line, from the score

- Select an instrument, or a staff line, in the right-hand column, and click **Remove**.

**Choose key signature and tempo**

![Image of key signature and tempo selection](image)

**Step 3: Choose key signature and tempo.**

The wizard asks for two things: The initial key signature and tempo of the score. Select any of the former and click **Next >** to continue. An initial tempo can be set here too.

**Choose time signature, pickup measure, and number of measures**

![Image of time signature and pickup measure selection](image)

**Step 4: Choose time signature etc.**

You can set your initial **time signature** here. If the score starts with a **pickup measure** (also known as an **anacrusis** or **upbeat** measure), then mark the **Pickup measure** checkbox and adjust the “Duration” accordingly.
Measures is set to 32 by default: you can change the number here, or add/remove measures later from the score.

Click Finish to create your new score.

Adjustments to score after creation

Any settings you make in the New Score Wizard can always be changed when you start work on the score itself:

Add/delete measures

To add/delete measures or create a pickup measure, see Measure operations.

Add/edit text

To add text, see Add text (Text basics). To change existing text, see Text editing.

Change instrument set-up

To add, delete, or change the order of instruments: from the menu, select Edit → Instruments...; or use the keyboard shortcut, I. This opens the Instruments dialog which is virtually identical to the Choose Instruments dialog in the New Score Wizard (see above).

See also Change instrument (Staff properties).

Hide a staff

- To hide a staff permanently: Open the Instruments dialog (I) and uncheck the "Visible" box for that staff.
- To hide a staff under certain conditions: See the "Hide" options in the Score menu, and Staff Properties.

Adjust layout and formatting

To adjust the distance between staves and systems, set page margins etc., see Layout and formatting.

Templates

A Template is simply a standard MuseScore file that has been stored in one of two "templates" folders: any files in these folders are automatically displayed on the "Choose template file" page of the New Score Wizard. Two templates folders are created by default:

- A system templates folder.
- A user templates folder.

System templates folder

This folder contains the templates installed with MuseScore and should not be modified. It can be found in the following locations:

Windows: Usually at C:\Program Files\MuseScore 2\templates; or in the 64-bit versions at C:\Program Files (x86)\MuseScore 2\templates.

Linux: Under /usr/share/mscore-xxx if you installed from the package manager. If you compiled MuseScore on Linux yourself, then look under /usr/local/share/mscore-xxx (with xxx being the version you are using).

MacOS: Under /Applications/MuseScore 2.app/Contents/Resources/templates.

User templates folder

Any templates that you create for future use should be stored here. Once in the user "templates" folder, they will automatically appear on the "Choose template file" page of the New Score Wizard—under the heading "Custom Templates". Note: prior to version 2.3, you need to restart MuseScore in order to see a newly-added template.

The default location of the user templates folder is as follows:

Windows: %HOMEPATH%\Documents\MuseScore2\Templates.

MacOS and Linux: ~/Documents/MuseScore2/Templates.
To configure the location of your private templates folder:

- From the menu, select Edit → Preferences... → General.

See also

- Key signature
- Time signature
- Clef
- Tempo
- Staff properties

External links

- Video tutorial: MuseScore in Minutes: Lesson 1 - Score Setup

Language settings and translation updates

MuseScore will be installed and work with your “System” language (the one used for most programs, and generally depending on your country and the language settings of the PC, or account).

Change language

1. From the menu, select Edit → Preferences... (Mac: MuseScore → Preferences...);

2. In the General tab, select the desired language from the drop-down list in the Language section:

![MuseScore Preferences](image)

3. To update translations, click on the Update translations button. Then click on the Update buttons for the languages you want to update (for an alternative method, see below).

As then indicated, you will have to exit and reopen MuseScore for changes and updates to take effect.

Update translation

You can update the translation as explained above, via the preferences settings, but there is another method:

1. From the menu, select Help → Resource Manager;

2. Click on the Update buttons for the languages you want to update.
Here too you will have to exit and reopen MuseScore for the update to take effect.

See also

- Helping and improve translation

External links

- How to change the language in MuseScore

Checking for updates

There are two ways to check for updates.

Automated update check

1. From the menu, select Edit → Preferences... (Mac: MuseScore → Preferences...);
2. Select the Update tab:

3. Tick the box marked "Check for new version of MuseScore."
Now MuseScore will check for updates on every start and notify you, if need be.

Check for update

1. From the menu, select Help → Check for Update:

2. A dialog will appear with the update status: either "No Update Available" or "An update for MuseScore is available:" followed by a link to download it.

Note: These options are only available in the Mac and Windows versions of MuseScore (except the version from the Windows Store), as only those can be updated directly from MuseScore.org. Linux distributions (and the Windows Store) have different mechanisms to make updates available.

See also

- Preferences: Update

Basics

The previous "Getting started" chapter guides you through the installation and process for creating a new score. The "Basics" chapter gives an overview of MuseScore and describes the general methods for interacting with the score.

Note input

MuseScore allows you to enter music notation from any of four input devices: computer keyboard, mouse, MIDI keyboard, or virtual piano keyboard. The default input mode is step-time, in which notes or rests are entered one at a time. However, other input modes are also available.

After exiting the New Score Wizard, your new score will consist of a series of measures filled with measure rests:

As you enter notes in a measure, the measure rests are changed to appropriate rests to fill the remainder of the measure:

Notes of different durations on the same beat are entered by using Voices:
Basic note entry

This section introduces you to the basics of entering notes and rests in step-time from a computer keyboard. It is also recommended that you work through the tutorial, "Getting Started: An introduction to note entry in MuseScore". This is available from the Start Center.

Step 1. Select a starting position

Select a starting position for note input by clicking on a note or rest, or selecting a measure with the mouse. If you don't select a starting point, the cursor automatically defaults to the beginning of the score when you enter Note Input mode ("Step 2" below).

Step 2. Enter Note Input mode

To enter Note Input mode, use either of the following options:

- Click on the "N" button (on the extreme left of the Note Input toolbar).
- Press N on your computer keyboard.

To exit Note Input mode, use any of the following options:

- Press N.
- Press Esc.
- Click on the toolbar "N" button.

Step 3. Select a duration

Still in Note Input mode, select a note duration using either of the following:

- Click on a corresponding note icon in the Note Input toolbar (directly above the document window).
- Enter the keyboard shortcut for that duration (see below).

Step 4. Enter the note or rest

- To enter a note pitch from A–G, simply click on the corresponding letter on your computer keyboard.
- To enter a rest, press 0 (zero).

This method of entry also works if you are not in Note Input mode—as long as you have a note/rest selected, or the score is newly-created (in which case note entry will default to the beginning).

Note: Note input in MuseScore overwrites existing notes or rests in a measure. If you need to insert notes you can make room for them by moving a section of the score using the copy and paste command. You can also insert new measures at any point (see Measure operations: Insert).

Select a note/rest duration

The following keyboard shortcuts are used to select note/rest duration in Note Input mode:

- 64th (hemidemisemiquaver): 1
- 32nd (demisemiquaver): 2
- 16th (semiquaver): 3
- Eighth (quaver): 4
- Quarter (crotchet): 5
- Half (minim): 6
- Whole (semibreve): 7
- Double whole (breve): 8
- Longa: 9
- Dot: . (changes the selection into a dotted note/rest)
- Double dot: Use a custom shortcut (or apply by clicking on the icon in the note input toolbar)
- Triple dot: Use a custom shortcut.

See also: Tuplets.

Input devices
Music notation can be entered by:

- Computer keyboard.
- Mouse.
- MIDI keyboard.
- Virtual Piano Keyboard.
- Any combination of the above.

**Computer keyboard**

This section expands on "Basic note entry" (see above) and introduces you to the full range of commands available for entering notes or rests from the computer keyboard.

**Enter notes/rests**

You can enter a note by typing the corresponding letter on your keyboard. Thus, after entering **Note Input** mode, type: \texttt{5 C D E F G A B C}.

\[ \begin{array}{cccccccc}
    \text{C} & \text{D} & \text{E} & \text{F} & \text{G} & \text{A} & \text{B} & \text{C} \\
\end{array} \]

**Note:** When you enter a note using the keyboard, MuseScore places it closest to the previous note entered (above or below).

To enter a rest, type "0" (zero). Thus, after entering **Note Input** mode, type: \texttt{5 C D 0 E}.

\[ \begin{array}{ccccccc}
    \text{C} & \text{D} & \text{E} & \text{F} & \text{G} & \text{A} & \text{B} \\
\end{array} \]

**Note:** The duration selected in the toolbar applies to both notes and rests.

If you want to enter a dotted note, press . (period/full stop) after selecting the duration.

For example, after entering **Note Input** mode, type: \texttt{5 . C D E F G A}.

\[ \begin{array}{ccccccc}
    \text{C} & \text{D} & \text{E} & \text{F} & \text{G} & \text{A} & \text{B} \\
\end{array} \]

If you want to enter a tuplet: see **Tuplets**.

If you want to write music with two or more simultaneous lines of independent melody (i.e. polyphony): see **Voices**.

**Move notes up/down**

To move a note up or down by a semitone:
- Press the ↑ or ↓ arrow.

To move a note up or down diatonically:
- Press Alt+Shift+↑ or Alt+Shift+↓.

To move a note up or down by one octave:
- Press Ctrl+↑ (Mac: ⌘+↑) or Ctrl+↓ (Mac: ⌘+↓).

**Add accidentals**

When a note is moved up or down with an arrow key (see above), any accidental required is automatically generated by the program. Accidentals can also be added manually—see **Accidentals**.

**Chords**
If you want to add a chord note above your previous entry:

- Press and hold Shift, then enter a note from A to G.

Thus, typing C, D, Shift + F, Shift + A, E, F results in:

![Musical notation](image)

To add a note at a specific interval above or below one or more notes:

1. Ensure that one or more notes are selected.
2. Use one of the following options:
   - From the menu, select Notes → Add Interval... and chose an interval from the list;
   - Press Alt+1-9 for intervals above (intervals below are also possible by adding relevant shortcuts to the list in Preferences).

Note: To create chords with notes of different durations, you will need to use more than one Voice.

Keyboard shortcuts

Here is a list of useful editing shortcuts available in Note Input mode:

- ↑ (Up): Increase the pitch of a note by a semitone (uses #).
- ↓ (Down): Decrease the pitch of a note by a semitone (uses b).
- Alt+1-9: Add interval (unison to ninth) above current note.
- J: Change note up or down to enharmonic note (alters the spelling in both concert pitch and transposed modes). See Accidentals.
- Ctrl+J (Mac Cmd+J): Change note up or down to enharmonic (alters the spelling only in the current mode). See Accidentals.
- Alt+Shift+: Increase the pitch of a note using key signature.
- Alt+Shift-: Decrease the pitch of a note using key signature.
- R: Repeat the last entered note.
- Q: Halve the duration of the last entered note.
- W: Double the duration of the last entered note.
- Shift+Q (as of version 2.1): Decrease duration by a dot (for example, a dotted quarter note/crotchet becomes a quarter note/crotchet and a quarter note/crotchet becomes a dotted eighth note/quaver).
- Shift+W (as of version 2.1): Increase duration by a dot (for example an eighth note/quaver becomes a dotted eighth note/quaver and a dotted eighth note/quaver becomes a quarter note/crotchet).
- Backspace: Undo last entered note.
- Shift+-: Exchange last entered note with the note before it (repeat to keep moving note earlier).
- Shift+-: Exchange note moved with Shift+- with the note that follows it.
- X: Flip direction of note stem (can be reset to Auto position in Inspector).
- Shift+X: Move note head to opposite side of stem (can be reset to Auto position in Inspector).

Mouse

It’s easy to enter notes with the mouse, but it is not the fastest way to enter lots of notes.

1. Click on the desired note duration symbol in the Note input toolbar.
2. Click on the score to add a pitch of the selected duration.
3. To add more notes to an existing chord, simply repeat step 2.
4. To replace an existing chord (rather than adding to it), press Shift before clicking.

Note: If you hover the cursor over the score in Note Input Mode it will show you a preview of the note or rest you are about to add.

MIDI keyboard

You can also insert pitches using a MIDI keyboard.

1. Connect your MIDI keyboard to the computer and switch the former on.
2. Start MuseScore (this must be done after the keyboard is switched on).
3. Create a new score
4. Click the rest (selecting it) in measure 1 to indicate where you want note input to begin
5. Press N to enter note input mode
6. Select a note duration such as quarter notes (crotchets), as described above
7. Press a note on your MIDI keyboard.

The pitch should be added to your score.

Note: The MIDI keyboard enters one note or chord at a time. This mode of note input (often called "step-time entry") is fast and reliable. Beginning with version 2.1 MuseScore introduced a limited real time entry mode, in which the musician plays a passage and MuseScore tries to produce the notation.

If you have multiple MIDI devices connected to your computer, you may need to inform MuseScore which is the MIDI keyboard. Go to Edit → Preferences... (Mac: MuseScore → Preferences...). In the preferences dialog, click on the I/O tab and select your device under the section labeled "PortAudio".

Virtual Piano Keyboard

You can also input notes using the on-screen piano keyboard.

- To toggle the display on and off: Press P (or select View → Piano).
- To resize the keyboard: Position the mouse pointer over the piano keys, hold down Ctrl (Mac: Cmd) and move the mouse scroll wheel up (larger) or down (smaller).

The method of note entry is similar to that for a MIDI keyboard:

1. Ensure that you are in Note Input mode.
2. To enter a:
   - Single note: Click on the appropriate piano key.
   - Chord: Select the note you wish to add to, press and hold Shift, then click on a piano key (in versions before 2.1, use Ctrl (Mac: Cmd)). Repeat as required.

Input modes

In addition to the existing Step-time and Repitch modes, three more input modes have been added in MuseScore 2.1 (see links below). All can be accessed by clicking the small arrow next to the "N" button on the left of the Note Input toolbar.

- Step-time (default): The default mode of note entry. See Basic note entry (above).
- Repitch: Replace pitches without changing rhythms.
- Rhythm: Enter durations with a single click or keypress.
- Real-time (automatic): Perform the piece at a fixed tempo indicated by a metronome beat.
- Real-time (manual): Perform the piece while tapping a key or pedal to set the beat.

Coloring of notes outside an instrument’s range

Depending on the skill of the musician, certain notes are considered beyond the range of a particular instrument. For informational purposes, MuseScore optionally colors notes red if they are outside the range of a "professional" player, and olive green/dark yellow if outside the range of an "early amateur." The colors appear on the computer screen, but not on printed copies.
To enable/disable note coloration and to set "professional" and "amateur" ranges, see Usable pitch range (Staff properties: all staves).

Small notes/small noteheads

1. Select the note(s) you want in small size.
2. Check the "Small" checkbox in the Inspector. The one in the Note section is used to only change the size of the individual notehead; the one in the Chord section will change the note head, stem, beam, and flag sizes all together.

By default, the small size is 70% of the normal size. You can change that setting in 

Change notes or rests already entered

Change duration

To change the length of a single note or rest:

1. Make sure you are not in note input mode (press Esc to exit) and have no other notes selected.
2. Click on the note or rest and use the duration shortcuts listed above, or the duration icons in the toolbar, to change it to the duration of your choice.

Increasing the duration will overwrite the notes or rests that follow it; decreasing the duration will add rests between it and the notes or rests following.

For example, to change three sixteenth rests into a single dotted eighth rest:

1. Click on the first sixteenth rest.
2. Hit 4 to turn it into an eighth rest.
3. Hit . to turn it into a dotted eighth rest.

As the duration increases, it overwrites the other two sixteenth rests following it.

Change pitch

To change the pitch of a single note:

1. Make sure that you're not in note input mode and that you have no other notes selected.
2. Select the desired note and use any of the following methods:
   - Drag the notehead up or down with the mouse;
   - Press the keyboard arrows: ↑ (Up) or ↓ (down);
   - Type a new note letter name (A…G). Use Ctrl+↑ or Ctrl+↓ to correct the octave, if necessary (Mac: Cmd+↑ or Cmd+↓).

To change the enharmonic spelling of a note, select it and use the J command. For more information, see Accidentals.

To change the pitches of a passage of music by a constant interval, you can use Transposition.

To change the pitches of a passage of music to a different melody, while keeping the rhythm unchanged, use Re-pitch mode.

If your score contains a lot of misspelled accidentals, you might try the Respell Pitches command (see Accidentals: Respell pitches).

Change rest to note and vice versa

To change a rest to a note of the same duration:
1. Make sure you are not in note input mode (press Esc to exit).
2. Select the rest.
3. Enter the desired pitch by entering a note letter, A–G.

To change a note to a rest of the same duration:

1. Make sure you are not in note input mode (press Esc to exit).
2. Select the note.
3. Press 0 (Zero).

**Note properties**

- To adjust the horizontal position of a note/chord: see Offset notes.
- To edit note properties in general (spacing, offset, size, color, notehead direction, playback etc.): see Inspector and object properties.
- To adjust the layout of all notes in the score: see Layout and formatting, especially the sections about notes, accidentals, and tuplets.

**See also**

- Note input modes
- Drum notation
- Tablature
- Tuplet
- Voices
- Shared noteheads
- Preferences

**External links**

- How to enter a chord
- How to enter a rest
- How to span a stem over two staves
- Video tutorial: MuseScore in Minutes: Lesson 3 - Note input
- Video tutorial: MuseScore in Minutes: Lesson 4 - MIDI Keyboard Input
- Video tutorial: MuseScore in Minutes: Lesson 5 - More Input Ideas
- Video: Semi-Realtime MIDI Demo Part 1: New note entry modes (available as of MuseScore 2.1)

**Edit mode**

**Edit mode** allows you to perform a wide range of editing operations on individual score elements, such as:

- adjust the length and shape of slurs, lines, barlines etc.
- add, delete and format text in text objects.
- adjust the position of most score elements (but not text).

**Enter/exit edit mode**

To enter Edit mode use any of the following methods:

- Double-click an element.
- Right-click on an element and, from the menu, select Edit Element.
- Click on an element and press Ctrl+E (Mac: Cmd+E).

To exit Edit mode use any of the following:

- Press Esc.
- Click on a blank area of the document window.

**Text**

For text edit mode, see Text editing.
Lines

Lines—such as slurs, ties, hairpins, voltas etc.—display square adjustment handles in Edit mode; these turn blue when selected. A slur, for example, looks like this:

![Slur Diagram]

The end handles are used to adjust the length of the line. The middle handle is used to adjust its vertical position. In the case of slurs and ties, there are also three more handles to adjust the shape of the curve (see image above).

To reposition a handle, click on it and use a keyboard shortcut (see below). Alternatively you can drag the handle with a mouse.

Each end handle is connected by a dotted line to an anchor on the staff. The start and end anchors mark the boundaries of the region of the score under the control of the line. By default, an end handle is positioned vertically above its anchor.

- **To move both an end handle and its attached anchor**: Click on the handle and use Shift+→ or Shift+←.
- **To move an end handle without affecting its anchor**: Click on the handle and use either the left/right keyboard arrows or a corresponding Ctrl (Mac: ⇧) command. See keyboard shortcuts below.

Notes

Offset notes

Sometimes it is necessary to shift a note to the right or left—to avoid a collision with another element or to override automatic notehead sharing for example:

1. Enter Edit mode on the desired note;
2. Press the arrow key in the direction (left or right) that you wish to nudge the note (or use Ctrl+← or Ctrl+→ for larger adjustments);
3. Press the Esc key. This will allow the note stem to be redrawn.

Alternatively, you can select the notehead and change the "Horizontal offset" (under "Chord") in the Inspector.

Adjust note stem length

1. Enter Edit mode on the desired note stem;
2. Use keyboard shortcuts (below) to extend or shorten the stem;
3. Exit edit mode.

Note: To reposition a note stem, you should select it and adjust the "Horizontal offset" in the Inspector.

Keyboard shortcuts

In Edit mode the following keyboard commands can be used to change the position of either (1) a score element (e.g. ornament, accidental etc.) or (2) an adjustment handle (e.g. slur, line etc.):

- ←: Move left 0.1 staff space.
- →: Move right 0.1 staff space
- ↑: Move up 0.1 staff space
- ↓: Move down 0.1 staff space
- Ctrl+← (Mac: ⇧ + ←): Move left one staff space
- Ctrl+→ (Mac: ⇧ + →): Move right one staff space
- Ctrl+↑ (Mac: ⇧ + ↑): Move up one staff space
- Ctrl+↓ (Mac: ⇧ + ↓): Moves down one staff space
- Alt+←: Move left 0.01 staff space
- Alt+→: Move right 0.01 staff space
- Alt+↑: Move up 0.01 staff space
- Alt+↓: Move down 0.01 staff space

The following commands only apply to adjustment handles:
- Shift← : Move end handle's anchor left by one note/rest.
- Shift→ : Move end handle's anchor right by one note/rest.
- Tab: Go to next handle.

See also

- Text editing
- Slur
- Bracket
- Line
- Beam
- Hairpin

Palettes and workspaces

To the left of the document window is the Workspace. This can be toggled on and off using the menu command, View → Palettes, or the shortcut, F9.

A workspace, in turn, consists of a number of palettes. Each palette is a folder containing a group of musical symbols.

Workspaces

MuseScore provides two preset workspaces: Basic (the default option) and Advanced (a version with more palettes and symbols). These contain symbols drawn from the various sections of the Master palette. In addition, you can create your own custom workspaces (below).

- To switch between workspaces: Use the drop-down menu at the bottom of the workspace panel.

The names of palettes within a workspace are listed under the title "Palettes."

Single Palette Mode

If you only want to allow one palette to open at a time, right click at the top of the workspace and check the “Single palette” box. This will cause a palette to automatically close when you open a different one.

Docking/undocking

To dock or undock a workspace, see Side panels.
Custom workspace

A custom workspace allows you to select which palettes are listed, and to customize the contents of those palettes.

To create a customizable workspace:

1. Select an existing workspace. Use the drop-down list at the bottom of the workspace panel if needed.
2. Click the + button, enter a name for the new workspace and press OK. The new workspace is added to the panel.

Alternatively you can use the menu option:

1. Select Edit → Workspaces, and chose a workspace.
2. Select New. Fill in the new workspace name and click OK.

Right-clicking over the workspace will display a menu: this has options allowing you to insert, delete, rename and reorder the palettes within it. The contents of individual palettes can be edited in a similar fashion once you’ve checked “Enable Editing” for a palette. For more details, see Custom palettes and Palette menu (below).

Palettes

Open/close palette

- Click once on the name of the palette or its accompanying side-arrow.

Apply symbols from a palette

A palette symbol may be applied to the score using one of the following methods:

- Select one or more score elements and double click the palette symbol.
- Drag and drop the symbol onto the desired score element in the staff.

Tip: To prevent accidental rearrangement of contents during use, right-click over a palette name and untick “Enable Editing.”

For example, to add tenuto marks (—) to a selection of notes:

1. Select the desired notes.
2. In the Articulations & Ornaments palette, double-click on the tenuto symbol

Once added to the score, objects can be copied, pasted, and duplicated—see Copy and paste.

Preset palettes (Advanced workspace)

The more fully-featured Advanced workspace contains the following palettes:

- Grace Notes
- Clefs
- Key Signatures
- Time Signatures
- Barlines
- Lines
- Arpeggios and Glissandi
- Breaths and pauses
- Brackets
- Articulations and Ornaments
- Accidentals
- Dynamics
- Fingering
- Note Heads
- Tremolo
- Repeats and Jumps
- Tempo
- Text
- Breaks and Spacers
- Bagpipe Embellishments
Once you have created a custom workspace (see above), and enabled editing (see Palette menu below), you can customize the palettes within it to your own requirements.

To add an existing score element (such as a line, text, dynamic, fretboard diagram etc.) to a custom palette:

- Press and hold Ctrl+Shift (Mac: Cmd+Shift), then drag the symbol onto the palette.

To add a symbol to a custom workspace from the Master palette:

- Drag the symbol from the Master Palette window into a custom palette.

To re-arrange a symbol in a custom palette:

- Drag the symbol to the cell you want it to display in: it will swap places with the symbol currently occupying that cell.

Palette menu

Right-clicking on the name of a palette in a custom workspace brings up this menu:

- **Palette Properties...**: Adjust the appearance of the open palette:

  - **Name**
  - **Cell Size: Width, Height**
  - **Element Offset**: Adjust the vertical offset of all elements in the palette.
  - **Scale**: Make all palette elements appear larger or smaller.
  - **Show grid**: Visually divide the palette into cells, one for each element.
  - **Show 'More Elements...’**: Create a cell which opens the Master Palette.

- **Insert New Palette**: Create a new empty palette.
- **Move Palette Up / Move Palette Down**: Reorder the palettes.
- **Enable Editing**: Allow modifying the contents of the palette.
- **Save Palette**: Save as an .mpal file.
- **Load Palette**: Load an .mpal file.
- **Delete Palette**: Remove the palette from the workspace entirely.

Right-clicking on an element within a palette (if editing of the palette is enabled) brings up this menu:

- **Clear**: Remove the element from the palette
- **Properties...**: Open the Palette Cell Properties dialogue:
  - **Name**: The tooltip that appears when you mouse over the element.
  - **Content offset (X, Y)**: Adjust the position of the element in the palette.
  - **Content scale**: Make the element appear larger or smaller in the palette.
  - **Draw staff**: Draw the five lines of a musical staff behind the palette element.
- **More Elements**: Open the relevant Master Palette section.

*Note*: Changing values in “Palette Cell Properties” only affects the appearance of elements in the palette. It does not change their sizes or offsets on the score page.

Behavior of applied text and lines
If the symbol you are adding to the score from a palette contains a text element (e.g. staff text, dynamic, fingering, volta etc.), then properties such as font-type, font-size, text color, and alignment will adapt according to the following rules:

1. Text properties which have not been altered by the user will adopt the relevant, prevailing text styles.
2. Custom text-properties—i.e. those changed by the user before saving the symbol to a custom palette—remain as customized.

By contrast, the line properties of lines applied from a palette always remain unchanged (i.e. as set by the user before saving to a custom workspace, or as predefined in the Basic/Advanced workspaces).

See also

- Master palette

Inspector and object properties

Most score elements have properties that can be edited in one of two ways:

- Click on any element, and many of its properties can be viewed and changed from the Inspector panel on the right-hand side of your screen.
- Right-click on an element and select an option with the word Properties in it. This option opens a dialog with advanced properties, only available for certain types of elements.

Inspector

The Inspector is shown by default on the right of your screen. It can be displayed or hidden from the menu: select View and check/uncheck Inspector, or use the shortcut F8 (Mac: fn+F8).

In the Inspector, the properties of any selected object are displayed and can be edited. This applies to virtually every single element in the score window—notes, text, barlines, articulations etc. Multiple elements can also be selected and edited simultaneously, as long as they are of the same type. However, if the selected objects are of different types, then the Inspector restricts you to editing color and visibility only.

The Inspector panel can be un-docked to become a floating panel by clicking the double-chevron symbol or double-clicking the top bar of the panel.

To re-attach the panel double-click on the top bar again. See also: Side panels.

Inspector categories

When you select one or more elements of a specific type, the properties which can be edited are conveniently divided into categories in the Inspector. Categories can be identified by their bold, centered lettering. For example, if you select a barline, you will see the following displayed at the top of the Inspector:

For details about how to adjust the properties of various score elements, refer to the relevant sections in the handbook.
However, a few general points will be covered here:

**Element**

All score elements, except frames, breaks and spacers, display this category in the Inspector when selected. The various options are as follows:

- **Visible**: Uncheck this box to make selected elements invisible; alternatively, use the shortcut V (toggle). Invisible elements do not appear in the music when printed out or exported as a PDF or image. If you still want them to remain on display in the document window, make sure that the "Show Invisible" option is selected in View → Show Invisible. Invisible elements will then be colored light gray.

- **Color**: Click on the rectangle to open a "Color Select" dialog. Adjust the color and opacity of selected elements.

- **Horizontal offset / Vertical offset**: Allows you to position selected elements exactly (in terms of space units). A positive number moves the elements right or down; a negative number moves the elements left or up. Snap to grid buttons are also provided.

**Element Group**

This category is displayed only when you have selected a mixture of different types of elements, and allows editing of color and visibility only.

**Segment**

This category is used to increase or decrease the space before/after an element in a music staff. Adjusting leading/trailing space here also affects any associated lyric syllables.

**Chord**

This category is displayed only if notes are selected. Any change to a notehead property under Chord affects the whole chord (i.e. all the notes in one voice) at that location—and not just the selected note. If you want to make changes to the position of just one note in a chord, then use the Element category (above).

**Note**

This category allows you to make changes to selected notes (but for note position—see Element). It contains the following properties:

- **Small**: Make notehead smaller (you can specify the relative size of all small notes from the menu Style → General… → Sizes…).
- **Head group**: See Notehead groups.
- **Head type**: See Notehead types.
- **Mirror head**: Position notehead to the left or right of the stem (default is "Auto").
- **Tuning**: Adjust tuning of note to the nearest cent.
- **Play**: Unticking this box silences the note.
- **Velocity type**: Sets the MIDI velocity of notes directly. Chose one of two options:
  - **Offset**: Make the value shown in "Velocity" relative to the previous dynamic marking.
  - **User**: Make the value shown in "Velocity" absolute (i.e. the MIDI velocity is unaffected by dynamic markings).
- **Velocity**: Set the MIDI velocity according to the option displayed in "Velocity type."
- **Fix to line**: When ticked, the note is fixed to the top line of the standard 5-line staff.
- **Line**: A positive number moves the "fixed" note down; a negative number moves it upwards.

**Select**

This category appears differently according to the selection you have made:

- **If you select a notehead**, the "Select" category displays buttons which allow you to easily switch the selection to the stem, beam, hook, duration dot (or dots) or tuplet number associated with the notehead (see image below).
• If you select a range of measures, the "Select" category allows you to select either all notes, grace notes (from version 2.1) or rests.

Beam

This section is displayed in the Inspector when you select one or more note beams, and allows you to make fine adjustments to beam position and angle, and also change the spacing of beamed notes. See Adjust beam with the inspector.

Clef

This section appears when you select a clef: the tick box allows you to turn on/off the display of a preceding courtesy clef.

Properties dialogs

Properties of some objects are accessed by right-clicking on the object and choosing a "Properties" option from the context menu: these are in addition to the object's properties displayed in the Inspector.

(Note: Properties should not be confused with Styles. Changes to properties only affect the single element selected; all style controls apply to the entire score.)

Articulation properties

Right-click on an articulation and select Articulation Properties... See Articulations and ornaments.

Fretboard diagram properties

Right-click on a fretboard diagram and select Fretboard Diagram Properties... Allows you to create custom fretboard diagrams. See Edit fretboard diagram.

Line properties

Right-click on a line and select Line Properties... There are settings for the beginning, end, or continuation of the line. You can add or remove text, adjust the text's placement, and set the length and angle of optional hooks. Click the ... button to access text properties for text included in the line. See Custom lines and line properties.

Measure properties

Right-click on an empty part of the measure and select Measure Properties... Adjust visibility, bar duration, repeats, stretch and numbering. See Measure properties.

Staff properties

Right-click either an empty part of a measure or the name of an instrument and select Staff Properties... This dialog allows you to adjust attributes of both the single staff and the instrument it is a part of. See Staff properties.

Text properties

Right click on a text-based element and select Text Properties... See Text styles and properties. If the element is a line with text in it, see → above.

Time signature properties

Right-click on a time signature and select Time Signature Properties... Used to adjust appearance of time sig. and beam
properties of notes. See Time signatures.

See also

- Measure operations
- Note input
- Layout and formatting
- Staff properties
- Part extraction

Upload

<table>
<thead>
<tr>
<th>Csatolmány</th>
<th>Méret</th>
</tr>
</thead>
<tbody>
<tr>
<td>Note inspector.jpg</td>
<td>67.14 KB</td>
</tr>
<tr>
<td>Staffproperties.jpg</td>
<td>91.41 KB</td>
</tr>
<tr>
<td>Buttonstaffproperties.jpg</td>
<td>1.03 KB</td>
</tr>
<tr>
<td>Staffproperties2ndaccess.jpg</td>
<td>22.51 KB</td>
</tr>
<tr>
<td>View_en.png</td>
<td>25.03 KB</td>
</tr>
<tr>
<td>Note inspector.png</td>
<td>133.85 KB</td>
</tr>
<tr>
<td>Measure Properties 1.png</td>
<td>53.21 KB</td>
</tr>
<tr>
<td>notes.png</td>
<td>2.65 KB</td>
</tr>
<tr>
<td>inspector_select.png</td>
<td>3.25 KB</td>
</tr>
<tr>
<td>Barline inspector.png</td>
<td>10.85 KB</td>
</tr>
<tr>
<td>Measure Properties 2.png</td>
<td>60.54 KB</td>
</tr>
<tr>
<td>inspector-top-bar.png</td>
<td>3.08 KB</td>
</tr>
<tr>
<td>Previous_Next_Buttons.png</td>
<td>7.36 KB</td>
</tr>
<tr>
<td>Staff_Properties_en.png</td>
<td>30.14 KB</td>
</tr>
<tr>
<td>clef_inspector.png</td>
<td>2.09 KB</td>
</tr>
</tbody>
</table>

Measure operations

Note: To ensure that inserted or appended measures display correctly, multimeasure rests should be set to off (toggleM).

Select

Single measure

- To select a single measure, click on a space within the measure.

Range of measures

- To select a continuous range of measures, see Shift + click selection and Shift selection.

Insert

Insert an empty measure into the score

Use one of the following options:

- Select a measure or a frame, then pressIns (no shortcut on Mac).
- Select a measure or a frame, then chose from the menu Add → Measures → Insert Measure.

Insert multiple measures

Use one of the following options:

- Select a measure or a frame, then pressCtrl+Ins (no shortcut on Mac); fill in the "Number of measures to insert" field and press OK.
- Select a measure or a frame, then chose from the menu Add → Measures → Insert Measures...; fill in the "Number of measures to insert" field and press OK.
Append

Append an empty measure to the end of a score

Use one of the following options:

- Press Ctrl+B (Mac: ⌘+B).
- Select from the menu: Add → Measures → Append One Measure.

Append multiple measures to the end of a score

Use one of the following options:

- Press Alt+Shift+B (Mac: Option+Shift+B); fill in the "Number of measures to append" field and press OK.
- Select from the menu: Add → Measures → Append Measures...; fill in the "Number of measures to append" field and press OK.

Delete

Delete a single measure

1. Select the measure;
2. Press Ctrl+Del (Mac: Cmd+Del); or from the menu, select Edit → Measures → Delete Selected Measures.

Delete a range of measures

1. Select the range of measures to delete;
2. Press Ctrl+Del (Mac: Cmd+Del); or from the menu, select Edit → Measures → Delete Selected Measures.

Notes: (1) In multi-staff scores, measure deletion also removes all corresponding measures in the other staves of the system; (2) If you wish to delete only the measure contents (and not the measure itself), use the Del command instead at step "2."

Properties

To edit the properties of a measure, right-click an empty part of the measure and select Measure Properties...:

You can use the buttons, at the bottom left of the dialog, to navigate to the previous or next measure.

Staves
visible property allows you to show/hide the notes and staff lines for the current measure.

*stemless* property allows you to show/hide all note stems for the current measure. Notes that normally have a stem such as half notes (minims) and quarter notes (crotchets) only show the note head when marked as stemless.

**Measure duration**

This feature allows you to adjust the time signature of a single measure regardless of the time signature indicated in the score. You can use it to create a *pickup measure* (also known as *anacrusis or upbeat*), *cadenza*, *ad lib* section etc.

![Measure Duration]

- **Nominal** is the *apparent* time signature and cannot be edited.
- **Actual** can be set to anything you like regardless of the *nominal* time signature.

**Example:** In the image below, the quarter note pickup measure has a *nominal* time signature of 4/4, but an *actual* time sig. of 1/4. The measures in the middle are in normal 4/4 time. The complementary measure at the end of the staff, with a dotted half note, has an *actual* time sig. of 3/4.

![Musical Example]

**Other**

**Exclude from measure count**

Use *"Exclude from measure count"* for "irregular" measures, i.e. ones that should not get counted in the measure numbering. Normally, a pickup measure is marked as *"Exclude from measure count"*.

**Add to measure number**

You can also use the *"Add to measure number"* option to influence the measure numbering. You can enter positive or negative numbers here. Please note that this affects all subsequent measures. A value of "-1" has the same effect as marking a measure to be excluded from measure count.

**Layout stretch**

You can increase or decrease horizontal space between score elements (notes, rests, etc.) with this option. This provides a more precise control over the exact same measure spacing property as the menu commands or keyboard shortcuts for *Increase/Decrease Stretch* ( and ), which are accessed outside of the Measure Properties dialog while a measure is selected.

**Play Count (as of version 2.1) / Repeat count (prior to version 2.1)**

If the measure contains an end *repeat* barline, you can define how often it is played.

**Break multi-measure rests**

This property will separate a *multi-measure rest* at the start of the selected measure. This option should be checked before you turn on the *"Create multi-measure rests"* option in *Style → General...*, in the *"Score"* tab.

Multi-measure rests are automatically broken at important breaks, such as rehearsal marks, time signature changes, double barlines, *irregular measures*, etc. The default for scores is *off*, for *parts* is *on*.

**Numbering**

MuseScore automatically numbers the first measure of each System (except for the first system, actually except for a measure with the number 1), but more numbering options are possible. From the main menu, choose *Style → General...*, in the left pane, choose *"Header, Footer, Numbers"* tab. At the bottom of the right pane is the *"Measure Numbers"* (*"Bar Numbers"*) section.
Mark the checkbox next to the "Measure Numbers" ("Bar Numbers") to turn on automatic measure numbers.

Mark "Show first" if you want the first measure numbered.

Mark "All staves" if you want numbers on all staves. Otherwise, only the top staff of each system shows measure numbers.

Choose to show numbers on "Every system" which numbers the first measure of each line, or show numbers by "Interval" and specify the size of the interval. For example, an interval of 1 numbers every measure; an interval of 5 numbers every fifth measure.

Split and join

You may want to have a longer or shorter measure without changing the time signature. You can change a measure's duration in Measure Properties, but there is now a new option to split or join measures. (Beams may be automatically modified.)

Join measures

1. Select the measures you want to join;
2. From the menu bar, select Edit → Measure → Join Selected Measures.

Note: If you select measures on only one staff in a score with multiple staves, the same measures will be joined in each staff of the system.

For example, the image below shows the result of applying the Join command to four measures in the top staff:

![Image of joined measures]

Split a measure

1. Select a note (or chord);
2. From the menu bar, select Edit → Measure → Split Measure Before Selected Note.

Note: If you select only one note from one staff, each staff of the system will be split at the same place.

External links

- How to delete measures
- How to span a measure over multiple systems
- How to get scores without time signature (and clef)

Voices

A voice is a musical line or part which can have its own rhythm independently of other voices on the same staff. Voices are sometimes called "layers" in other notation software.

You can have up to 4 voices on each staff line. In a polyphonic measure, voice 1 usually takes the up-stem notes and voice 2 takes the down-stem notes.

![Image of voices]

N.B. Be careful not to confuse the concept of MuseScore voices (1, 2, 3, 4) with the order of voices found in vocal scores (SATB etc.). In particular, when creating a closed SATB score, use only (MuseScore) voices 1 and 2 for both upper and lower parts.
lower staves. There is no need to use (MuseScore) voices 3 and 4 unless there are more than two parts in the same staff.

**When to use voices**

- If you need stems pointing in opposite directions within a chord, on a single staff.
- If you need notes of different durations within a single staff, played simultaneously.

**How to enter notes in different voices**

The following instructions show you how to notate a passage of music in two voices:

1. **Enter voice 1 notes first**: Make sure you are in note input mode: the Voice 1 button becomes highlighted in blue in the toolbar. Enter the notes in the top voice first. When inputting, some notes may have down-stems, but these will flip automatically when the second voice is added.

   The following excerpt shows a treble staff with just the voice 1 notes entered:

   ![Voice 1 Notes Example]

2. **Move cursor back to start of section**: When you have finished entering a section of voice 1 notes, press the ← key repeatedly to move the cursor, note-by-note, back to the first note of the section; or alternatively use Ctrl← (Mac: Cmd←) to move the cursor back one measure at a time. Or else you can simply exit note input mode (press Esc) and click directly on the first note.

3. **Enter voice 2 notes**: Make sure you are in note-input mode and that the voice 1 note at the beginning of the section is selected. Click on the "Voice 2" button (on the right of the toolbar), or use the shortcut Ctrl+Alt+2 (Mac: Cmd+Option+2). Enter all the lower voice notes (down-stem).

   The following image shows the above example after the addition of voice 2 notes:

   ![Voice 2 Notes Example]

**Deleting and hiding rests**

All rests can be made invisible if required (select the rest and press V, or uncheck the "Visible" checkbox in the Inspector). Rests in voices 2, 3 or 4 can also be deleted but it is not usually recommended: make them invisible instead. Rests in voice 1 cannot be deleted.

**Restoring deleted rests**

If a rest has been deleted in voices 2-4, you will need to restore it before you can enter a note on that beat in that voice (the problem may arise, for example, in imported XML or MIDI files). The easiest way to fix such a measure is to exchange that voice with voice 1 twice. For the exact method, see Exchange voices of notes (below).

**Exchange voices of notes**

To swap the notes between any two voices:

1. Select one or more continuous measures (or range of notes);
2. From the Menu bar, select Edit → Voices;
3. Select the option for the two voices you want to exchange.

**Notes**: (a) The selection can encompass content of any voice, but only two will be processed at once. (b) If you select a partial measure the operation will still apply to the whole measure.

**Move notes to another voice (without swapping)**

You can also move notes from one voice to another (without note-swapping):

1. Ensure you are not in note input mode.
2. Select one or more noteheads (in any voice).
3. Click on the destination voice in the Note Input toolbar or use the shortcut Ctrl+Alt+1–4 (Mac: Cmd+Option+1–4).

Note: For a successful move, the following conditions need to be met:

- The chord in the destination voice must be the same duration as the note to be moved there.
- Alternatively, if the destination voice is occupied by a rest, it must be of sufficient duration to accommodate the moved note.
- Notes should **not** be tied.

See also

- Keyboard shortcuts: Voices
- Noteheads: Shared noteheads

External links

- [How to merge/combine/implode two staves in one with two voices](#)
- [Video tutorial: How To Write Two Parts On One Staff: Voices](#)

Copy and paste

MuseScore supports standard **copy**, **cut**, **paste** and (from version 2.1) **swap with clipboard** operations. These commands can be applied to a range of:

- **Musical notes**: e.g. to repeat a section of music, or shift a passage by a beat or a measure.
- **Other score elements**: such as articulations, staff text, dynamics, fingering etc.

Note: **Lines** cannot be copied but they can be **duplicated** (see below).

Copy/cut/paste/swap commands are accessed in three ways:

- From the **Edit menu** (above the document window).
- From the menu displayed by **right-clicking** on an element or range of elements.
- Using one of the standard **keyboard shortcuts**.

Summary of commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Kbd Shortcut (Win)</th>
<th>Kbd Shortcut (Mac)</th>
<th>Right-click menu</th>
<th>Main menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
<td>Cmd+X</td>
<td>Cut</td>
<td>Edit → Cut</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
<td>Cmd+C</td>
<td>Copy</td>
<td>Edit → Copy</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
<td>Cmd+V</td>
<td>Paste</td>
<td>Edit → Paste</td>
</tr>
<tr>
<td>Swap with clipboard</td>
<td>Ctrl+Shift+X</td>
<td>Cmd+Shift+X</td>
<td>Swap with clipboard</td>
<td>Edit → Swap with</td>
</tr>
</tbody>
</table>

Note: Before carrying out a copy, cut, paste or swap procedure, you should be **in normal mode**. Press the Esc key to exit into normal mode.

Notes

You can cut, copy, paste or swap notes as follows:

**Copy or cut**

**To copy/cut a single chord**

1. Hold down Shift and click on a note in the chord.
2. Apply a **Copy or Cut** option (see table above).

**To copy/cut a range of chords**

1. Click on the first note or measure that you want to select.
2. Shift+Click on the last note or measure that you want to select. A blue rectangle highlights the region you selected.
3. Apply a **Copy** or **Cut** option (see table above).

**Paste**

1. Click on the note or measure where you want your pasted selection to begin.
2. Apply a **Paste** option (see table above).

**Swap with Clipboard**

Available from version 2.1 onwards, the **swap with clipboard** operation combines two commands into one: (1) First it overwrites a selected part of the score with the contents of the clipboard, just like the *paste* command; (2) Secondly, it transfers the overwritten part of the score back to the clipboard, just like the *copy* command.

It can be used, for example, to swap two equal-length sections of a score, A and B:

1. Select section A, then apply the **cut** command; 
2. Clear the selection (by pressing **Esc** or clicking on a blank area of the document window);
3. Press **Shift** and click on a note at the start of section B. Or, if B begins at the start of a measure, you can also simply **select** the measure;
4. Apply a **Swap with clipboard** option (see table above).
5. Section B is now in the clipboard. **Paste** it back to the blank area of score left by step "1."

**Copy pitch of a single note only**

It is possible to copy the **pitch** of a note only (and no other properties), by clicking on the notehead and applying the standard copy and paste, or copy and swap procedure. The pitch of the destination note changes to match that of the copied note but the duration remains the same.

**Other elements**

Score elements such as staff text, dynamics, fingering, etc. can be cut, copied and pasted **one at a time** (but from version 2.2 **multiple-selection** cut/copy/paste is possible for fretboard diagrams).

Multiple-selection cut/copy/paste is available for **articulations** such as sforzato, staccato etc.

**Note**: The Swap with clipboard command is only intended for use with sections of music and not other score elements.

**Copy or cut**

1. **Select** the element (or elements).
2. Apply a **Copy** or **Cut** option (see table above).

**Paste**

1. Click on the note where you want your pasted selection to begin.
2. Apply one of the **Paste** options (see table above).

In the case of articulations, they are pasted to the destination notes in exactly the same order (continuous or intermittent) as they were in the initial selection.

**Quick repeat**

To quickly copy and paste a note, measure, or passage:

1. Select a chord, measure, or passage as described above.
2. Press **R**.

MuseScore copies and pastes the selected notation to a point immediately after the last note in the selection. Any existing music in the destination range is replaced.

**Duplicate**

To instantaneously copy and paste a text element, line, or other object:
1. Hold down Ctrl+Shift (Mac: Cmd+Shift), click on the element and drag it anywhere in the score.
2. Release the mouse button, and the selected element is cloned to the new location.

Selection filter

The Selection Filter allows you to chose exactly which voices and elements you want to include in your selection.

- To display the Selection filter, press F6 (Mac: fn+F6); or from the menu, choose View → Selection Filter.

The Selection Filter appears by default below the Palettes. To change the viewing location, see Viewing and Navigation: Side panels.

Example: Suppose you want to copy measures 1 and 2 in the following passage (see image), to give measures 3 and 4:

1. Make sure the Selection Filter is displayed (see above);
2. Uncheck the "Articulations & Ornaments" and "Slurs" tickboxes;
3. Copy and paste the desired measures (in this example, 1-2 into 3-4).

Note: The Selection Filter works with the swap with clipboard command as well.

See also

If you want to change notes without altering the rhythm, you may combine transposition or re-pitch mode with copy and paste.

External links

- Video tutorial: Lyrics, copying & dynamics

Selection modes

Objects in the score—such as notes, measures, articulations etc.—can be selected in several ways: (1) one at a time, (2) as a continuous range, or (3) as a list.

Select a single object

Most score objects can be selected by simply clicking on them in "normal" (i.e. not note-input) mode.

Select a single note

1. Make sure you are not in note input mode;
2. Click on a note.

Note: Selecting a single note then copying and pasting it, will only copy and paste the pitch—not duration or other properties (such as stemless). To copy the entire note, including all properties, you need to hold down Shift—as for chord selection (below).

Select a chord
1. Make sure you are not in note input mode;
2. Press and hold Shift, then click on a note in the chord.

Select a single measure

- Click on a blank space within the measure.

**Note:** To select a range of consecutive measures, see **Shift selection** and **Shift + click selection** (below).

Select a continuous range of objects

There are several ways to select a continuous range of notes, chords or measures:

1. **Shift selection**

   1. Make sure you are not in note entry mode;
   2. Select the first note, chord, rest or measure in the range. You can extend the selection up or down to adjacent staves, if needed, using Shift+↑ or ↓;
   3. Then choose one of the following options:
      - To advance the selection one chord at a time to the right: Press Shift+→.
      - To advance the selection one chord at a time to the left: Press Shift←.
      - To advance the selection one measure at a time to the right: Press Shift+Ctrl→ (Mac: Shift+Cmd→).
      - To advance the selection one measure at a time to the left: Press Shift+Ctrl← (Mac: Shift+Cmd←).
      - To advance the selection to the beginning of the line: Press Shift+Home (Mac: Shift+Fn←).
      - To advance the selection to the end of the line: Press Shift+End (Mac: Shift+Fn→).
      - To extend the selection to the beginning of the score: Press Shift+Ctrl+Home (Mac: Shift+Cmd+Fn←).
      - To extend the selection to the end of the score: Press Shift+Ctrl+End (Mac: Shift+Cmd+Fn→).

2. **Shift + click selection**

   To select a range of notes or rests:

   1. Make sure you are not in note entry mode;
   2. Click on the first note or rest in the range;
   3. Press and hold Shift, then click on the last desired note or rest.

   **Note:** The final selected element can be in the same staff or in staffs above or below the initial note/rest. All selected elements will be enclosed in a blue rectangle, including associated lines and articulations (but not voltas). You can repeat the operation to extend the selected range as required.

Select a range of measures

1. Click on a blank space in the first desired measure;
2. Hold down Shift, then click on a space in the last measure of the desired range.

**Note:** As with selecting notes, the range can be extended vertically as well as horizontally.

3. **Drag selection**

   This method can be used to select notes or rests, or, independently, to select non-note symbols such as staccato dots, lyrics etc.:

   - Press and hold Shift, then drag the cursor across the desired range.

4. **Select All**

   This method selects the whole musical score including notes, rests and associated elements. Use one of the following options:

   - Press Ctrl+A (Mac: Cmd+A).
   - From the menu bar, select Edit → Select All.

5. **Select section**
This method is used to select a **section**—a region of the score starting and/or ending with a **section break**:

1. Click on an empty space in a measure in the section;
2. From the menu bar, select **Edit → Select Section**.

*Note: See Copy and paste: Selection filter to disable certain types of elements from being selected in a range selection.*

**Select a list of objects**

To select a **list** (or discontinuous range) of score elements:

1. Click on the first element;
2. Hold down Ctrl (Mac: Cmd) and successively click on the desired additional elements.

*Note: This method cannot be used to select measures. Use **single** or **range** selection instead.*

**Select all similar**

To select all elements of a specific type (e.g., all barlines, all text elements, all staccato markings):

1. Select an element;
2. Right click and chose **Select…**;
3. Several options are available:
   - **All Similar Elements**: Selects all elements in the score similar to the chosen object.
   - **All Similar Elements in Same Staff**: Selects all elements in the same staff similar to the chosen object.
   - **All Similar Elements in Range Selection**: Only applies if a range has been selected. Selects all elements in the range similar to the chosen object.
   - **More...**: Opens a dialog that lets you fine-tune more options. For example, if you have a notehead selected, the dialog will look something like this (as of version 2.1—previous versions had fewer options):

   ![Select Notes](image)

   - **Select**
     - Same notehead: In this example, only noteheads of the same group will be selected;
     - Same pitch: Only noteheads of the same pitch will be selected;
     - Same type: All noteheads (of any group) will be selected;
     - Same duration: Only noteheads of same duration will be selected;
     - Same note name: Noteheads of that name in all octaves will be selected;
     - Same staff: Only noteheads on the same staff will be selected.

   - **Action**
     - Replace selection: The default option: starts the selection from scratch;
     - Add to selection: Keeps everything you have already selected, and adds the current selection to it;
     - Search in selection:
     - Subtract from selection: Keep everything you have already selected, but takes away the current selection.
What selections are useful for

- Copy and paste
- Edit mode
- Inspector and object properties
- Tools

See also

- Basics chapter, esp. Note input
- Notation chapter, esp. Accidental
- Text chapter, esp. Text editing and Grid-based movement of symbols and staff text

Viewing and navigation

This chapter describes the options available in the View Menu, and in the Zoom and Page View/Continuous View menus (located in the toolbar above the score). It also details the various navigation commands and functions.

View menu

Show sidebars/panels

- Start center: F4
- Palettes: F9
- Master palette: Shift+F9
- Inspector: F8
- Play Panel: F11
- Navigator: F12
- Mixer: F10
- Synthesizer
- Selection filter: F6
- Piano keyboard: P

Zoom in/out

There are several ways to zoom the score in or out:

- **Keyboard shortcut:**
  - Zoom In: Ctrl++ (Mac: Cmd ++)
  - Zoom Out: Ctrl + (Mac: Cmd +).

- **View menu:**
  - Zoom In: View → Zoom In
  - Zoom Out: View → Zoom Out.

- **Mouse**
  - Zoom In: Scroll up with the mouse wheel while holding down Ctrl (Mac: Cmd)
  - Zoom Out: Scroll down with the mouse wheel while holding down Ctrl (Mac: Cmd).

- **Drop-down menu:** To set a specific zoom, use the dropdown menu in the standard toolbar to set the view magnification of the score (25–1600 %) or display it using the options "Page Width", "Whole Page", or "Two Pages".
To return to 100% zoom: Use the shortcut Ctrl+0 (Mac: Cmd+0).

Toolbars (display)

As of MuseScore 2.1, this menu option allows you to hide or display the toolbars above the document window: File Operations, Playback Controls, Concert Pitch, Image Capture, Note Input (see Toolbars below).

Show Status bar

The Status bar, at the bottom of the screen, gives information about selected score elements. Tick/untick this option to display or hide.

Split display

It is possible to split the document display so as to view two documents at once, or to view two different parts of the same document. Tabs allow you to choose which document to display in each view. You can drag the barrier separating the two scores to adjust the amount of space in the window devoted to each:

- Documents Side by Side: Divides the window vertically into two score views.
- Documents Stacked: Divides the window horizontally into two score views, one above the other.

Visibility options

This section allows you to display or hide various non-printing elements:

- Show Invisible: View/hide elements that have been made invisible for printing and export. If this option is ticked, invisible elements are shown in the score window as light gray.
- Show Unprintable: View/hide breaks and spacer symbols.
- Show Frames: View/hide the dotted outlines of frames.

Full screen

Full Screen mode expands MuseScore to fill your screen so more content is visible.

Page/Continuous View

You can switch between two different views of the score using the drop-down list in the toolbar area:
To scroll the score:

- **Vertically:** Move the mouse wheel up or down.
- **Horizontally:** Press Shift and move the mouse wheel up or down.

**Page View**

In **Page View**, the score is formatted as it will appear when printed or exported as a PDF or image file: that is, page by page, with margins. MuseScore applies system (line) and page breaks automatically, according to the settings made in **Page settings** and **Style: General**. In addition, you can apply your own system (line), page or section breaks.

To choose between **horizontal** or **vertical** page scrolling, see **Preferences: Canvas (Scroll pages)**.

**Continuous View**

In **Continuous View**, the score is shown as one unbroken system. Even if the starting point is not in view, measure numbers, instrument names, clefs, time and key signatures will always be displayed on the left of the window.

Note: Because the layout is simpler, MuseScore may perform faster in Continuous View than Page View.

**Toolbars**

The **Toolbar** area is located between the **Menu bar** and **document window**. It contains symbols which allow you to perform certain operations. It can be divided into the following toolbars:

- **File Operations:** New score, Load score, Save, Print, Undo, Redo.
- **Zoom/Page View.**
- **Playback controls:** Enable MIDI, Rewind, Play/Stop, Loop, Play Repeats, Metronome.
- **Concert Pitch:** Displays score in written or concert (sounding) pitch.
- **Image Capture:** Allows you to take a snapshot of part of the score.
- **Note Input:** Note entry mode, Duration, Tie, Rest, Accidentals, Flip stem direction, Voice (1, 2, 3, 4).

To choose which toolbars to display, right-click on an empty space in the toolbar area (or on the title bar of the Inspector) and, from the menu, check or uncheck the required options. This menu also allows you to view or hide the **Piano keyboard, Selection sidebar, Palettes, the Inspector**, and (if already displayed) the “**Drum Tools**” (i.e. **Drum input palette**).

These display options can also be accessed in the **View menu**, and, as of 2.1, in **View → Toolbars**.

**Side panels**

The **workspaces, Inspector and Selection filter** are conveniently displayed as **side panels** to the left and right of the score window. To undock a side panel use one of the following methods:
Drag the panel;
Click on the double chevron at the top of the panel;
Double click in the title area at the top of the panel.

To dock a panel use one of the following procedures:

- Drag the panel to the top/bottom of an existing side panel and it will stack vertically above/below that panel.
- Drag the panel to the middle of an existing side panel and it will overlay that panel. Both panels can then be accessed by tabs.

Alternatively, double-clicking the title bar of the panel will restore it to its previously docked position.

Navigation

There are various commands available to help you navigate through the score. These are listed under Keyboard shortcuts: Navigation.

Navigator

The **Navigator** is an optional panel which allows you to navigate a long score more easily, or go to specific pages. To view/hide, go to the View → Navigator, or use the shortcut F12 (Mac: fn+F12). It appears at the bottom of the document window if scrolling pages horizontally, or on the right-hand side of the document window if scrolling pages vertically (see Preferences: Canvas).

The blue box represents the area of the score that is currently visible in the main window. You can drag either the blue box or the scroll bar, or click on an area to immediately go to it.

Find

The **Find** function allows you to speedily navigate to a specific measure, rehearsal mark or page number in the score:

1. Press Ctrl+F (Mac: Cmd+F), or select Edit → Find. This opens the **Find** (or Go to) bar at the bottom of the workspace.

2. Use one of the following options:
   - **To go to a numbered measure**: enter the measure number (counting every measure, starting with 1, irrespective of pickup measures, section breaks or manual changes to measure number offsets).
   - **To go to a numbered page**: enter the page number using the format pXX (where XX is the page number).
   - **To go to a numerical rehearsal mark**: enter the number using the format rXX (where XX is the name of the rehearsal mark (as of version 2.1).
   - **To go to a rehearsal mark starting with a letter**: enter the name of the rehearsal mark (the search is case insensitive).

**N.B.** It is best to avoid naming rehearsal marks with the single letters "R," "r," "P," "p," or one of these letters with an integer (e.g. "R1" or "p3"), as this can confuse the search algorithm.

See also
Open/Save/Export/Print

In the **File** menu you can find the following options:

- **Open**, Open recent.
- **Save**, Save As..., Save a Copy..., Save Selection..., Save Online...
- **Export**, Export Parts...
- **Print**...

Apart from native format files (*.mscz and *.mscx), MuseScore can also open **MusicXML**, **compressed MusicXML** and **MIDI** files, as well as a variety of files in other **formats**.

To open any supported file:

1. Chose one of the following options:
   - Press **Ctrl+O**.
   - Click on the “Load score” icon on the left side of the toolbar area.
   - From the menu bar, select **File → Open**.
2. Select a file and click **Open**; or simply double-click a file.

**Open recent**... allows you to chose from a list of recently-opened scores.

**Save**

**Save**..., **Save As**..., **Save a Copy**... and **Save Selection**... allow you to save native MuseScore files (.mscz and .mscx).

- **Save**...: Save current score to file.
- **Save As**...: Save current score to new file.
- **Save a Copy**...: Save current score to new file, but continue to edit original file.
- **Save Selection**...: Save selected measures to new file. In MuseScore versions earlier than 2.1, to ensure that the file is saved correctly, the time signature needs to be displayed in the first measure of the selected passage, unless it is 4/4.
- **Save Online**...: To save and share your scores on the web at [MuseScore.com](http://MuseScore.com). For details, see Share scores online.
Export

Export... and Export Parts... allow you to create non-MuseScore files, such as PDF, MusicXML, MIDI, and various audio and image formats. In the Export dialog, you can choose which format to export to:

- Export...: Export current score to format of your choice.
- Export Parts...: Export current score and all linked parts to separate files in a format of your choice.

MuseScore remembers which format you picked the last time and makes that the default for the next time. Note: There is a known issue with Windows XP and Vista, where you have to manually (un)set the filename’s extension when choosing a different format than the one selected the previous time.

Print

Print... allows to print your MuseScore file directly to a printer from MuseScore. Depending on your printer you will have different options, but generally you can define the page range, number of copies and collation.

If you have a PDF printer installed, you could also "export" to PDF using Print, but it’s usually better to use the native PDF option under Export for more accurate rendition. Note: For this to work properly with Adobe PDF, make sure to uncheck "Rely on system fonts only, do not use document fonts" in Printer properties.

See also

- File format
- Part extraction

Undo and redo

MuseScore remembers an unlimited number of undo/redo actions.

The standard shortcuts are:

- Undo Ctrl+Z (Mac: ⌘+Z)
- Redo Ctrl+Shift+Z or Ctrl+Y (Mac: ⌘+Shift+Z)

Or use the toolbar buttons:

Share scores online

Go to musescore.com/sheetmusic to view other scores from MuseScore.

You can save and share your scores online at MuseScore.com. You can choose to save a score privately for personal access from any computer, or share it publicly. MuseScore.com enables the viewing and playback of scores in your web browser - an additional feature entitled VideoScores allows synchronization between the score and a YouTube video. For use outside of a web browser, you can download the score in a variety of formats (including PDF, MIDI, MP3, MusicXML, and the original MuseScore file).

Create an account
1. Visit MuseScore.com and click on "Create new account". Pick a username and enter a valid email and press "Create New Account".
2. Wait a few minutes for an email from MuseScore.com support. If no email arrives, check your spam folder.
3. Click the link in the email and visit your user profile to change your password.

**Share a score directly from MuseScore**

To save a score online:

1. Make sure that the Concert Pitch button is off, and that the individual parts are correctly transposed.
2. From the menu, select File → Save Online.... The "Log in to MuseScore" dialog will appear:

![Log in to MuseScore dialog](image)

3. Enter your email address or MuseScore username, and password, then click OK. **Note:** If you don't have a MuseScore account yet, create one first by clicking on the "Create an account" link. That will open your browser app and bring you to musescore.com/user/register.

4. Upon successfully logging in, you'll be able to enter your score information.
- **Title**: The title of the score.
- **Description**: The descriptive text that will appear next to it.
- **Make the score private**: If ticked, the score can only be viewed via a private link. If unticked, the score is visible to all.
License: Chose an appropriate copyright license from the drop-down list. Note: Creative Commons license allows people to use your scores under certain restrictions.

Tags: You can add tags to help identify scores on MuseScore.com. Use commas to separate multiple tags.

5. In case you already saved the score online earlier, it will automatically update the existing one, and, as of version 2.1, you can enter some additional information in a changlog section of the dialog, which you can then retrieve on MuseScore.com under “Revision history” for that score. Uncheck Update the existing score to save online as a new score.

6. (As of version 2.1) If you are using a different SoundFont than the default one and if you are able to export MP3 files, a checkbox Upload score audio will be visible:

If the checkbox is checked, MuseScore will render the audio of the score using the current synthesizer settings and upload the audio to MuseScore.com.

Upload a score on MuseScore.com

You can also upload a score directly on MuseScore.com.

1. Click the Upload link on MuseScore.com.
2. You have the same options as with the Save Online menu.
3. You have also access to more information, such as Genre.

Note: Should you reach the five score upload limit, you can still upload scores directly from MuseScore, but only the last five are visible. If you wish more than this amount, upgrade to a Pro Account first.

Edit a score on MuseScore.com

If you want to make changes to one of your scores on MuseScore.com, edit the MuseScore file on your own computer, save it, and then do the following:

- If you originally shared the score directly from within MuseScore, simply go to File → Save Online... again to update the online score.
- If you originally uploaded the score via the Upload page on MuseScore.com, then you must follow these steps to update the online score:
  1. Go to the score page on MuseScore.com.
  2. Click the three dots menu on the right and choose “Update this score”.
  3. In the form, you can upload a replacement score file as well as change the accompanying information and privacy settings.

Switch to the direct method of updating an online score

It is much more convenient to update online scores from directly within MuseScore than by updating the score manually from the score page. Follow these steps if you originally uploaded the score via the Upload page and now want to switch to the direct method:

1. Go to the score page on MuseScore.com and copy the URL.
2. Open the score file on your computer with MuseScore.
3. From the menu, select File → Score Properties... and paste the URL into the “Source” field.

Now whenever you want to update the online score simply go to File → Save Online....

External links

- How to delete a score saved on MuseScore.com

Concert pitch
You can choose to display the score in either *written* or *concert* (sounding) pitch. Written pitch displays the score as it *should* look when printed for musicians to read. However, during preparation you may prefer the convenience of seeing the transposing instruments notated as they *sound*, without transposition. In this case you should select the “Concert pitch” option.

To toggle the score display between *written* or *concert* pitch use one of the following options:

- Press the Concert Pitch button (located in the top right of the toolbar area). When this button is highlighted the score is in concert pitch.
- From the menu bar, select Notes and tick/untick the Concert Pitch option.

Before printing the score, exporting it to PDF or saving it online, you should ensure that the Concert Pitch button is off, and that the individual parts are correctly transposed.

See also

- Transposition: Transposing instruments
- Accidental: Respell pitches

External links

- Concert pitch (Wikipedia article)
- Transposing Instrument (Wikipedia article)
- Concert pitch or not?? (MuseScore forum discussion)

**Notation**

In the previous “Basics” chapter you learn how to enter notes and interact with the palettes. The “Notation” chapter describes the different types of notation in more detail, including more advanced music notation.

See also “Advanced topics”.

**Barlines**

Barline symbols are available in the Barlines palette:

```
\nn\n\n\n\n\n\n\n\n```

**Change barline type**

To change an existing barline, use one of the following:

- Select a barline, then double click on a symbol in the Barlines palette.
- Drag a symbol from the Barlines palette onto a barline in the score.
- Drag a symbol from the Barlines palette onto a measure.
- Select a measure, then double-click on a symbol in the Barlines palette.
- Select a barline then adjust “Style” in the “Barline” section of the Inspector.

**To change a non-single to a single barline**

- Select the barline and press Del.

**To hide a barline:**

- Select the line and press V, or uncheck Visible in the Inspector.

**Insert barline**

To insert a new barline between existing ones, either:
- Drag a symbol from the Barlines palette onto a note or rest.
- Select a note or rest, then double-click a symbol in the Barlines palette.

Custom barlines

It is possible to create custom barlines by selecting one or more barlines, and adjusting the properties in the "Barlines" section of the Inspector:

- **Style**: Chose from a range of preset barlines.
- **Spanned staves**: The maximum equals the number of staves in the system.
- **Span from**: Sets the position of the top of the barline. "0" is the top staff line. Positive numbers start lower down the staff, negative numbers above.
- **Span to**: Sets the position of the bottom of the barline (see "Span from").
- **Span preset**: Set a span preset option.

See also, Mensurstrich.

Changes to color and horizontal/vertical offset can also be made in the Inspector.

Connect barlines

Barlines may extend over multiple staves, as in the grand staff of a piano, or in an orchestral score to join instruments in the same section. To join barlines:

1. Double-click on a barline to enter **Edit mode**.

2. Click on the lower blue handle and drag it down to the staff you wish to connect to. The handle snaps into position so there is no need to position it exactly.

3. Press Esc to exit **edit mode**. This will update all other relevant barlines as well.

See also

- Measure operations
- Add fermata to barline

Clefs

Commonly used **Clefs** (Treble, Bass, Alto, Tenor) can be found in the Clefs palette in the Basic workspace. For a more complete range, see the Clefs palette in the Advanced workspace (see image below).
Note: You can tailor the display of clefs to your specific requirements using a custom palette.

Add a clef

Add clef to beginning of measure

Method 1—add clef to beginning of a measure, whether or not it is the first measure in a system

- Select a measure and double-click a clef symbol in the palette, OR
- Drag a clef from the palette onto a measure.

Method 2—only for changing the clef at the start of a system

- Select the existing clef at the beginning of the system and double-click a new clef from the palette, OR
- Drag a new clef from the palette directly onto the existing clef.

Add mid-measure clef

To create a mid-measure clef:

- Click on a note, then double-click a clef in the palette.

Note: If the clef is not the first in the system, it will be drawn smaller.

In this image, the top staff starts with a treble clef and switches immediately to bass clef, then after a note and a rest, changes back to treble clef.

![Image of music notation with clefs]

Note: Changing a clef does not change the pitch of any note. Instead, the notes move to preserve pitch. If you want, you can use Transposition in conjunction with a clef change.

Courtesy clefs

When a clef change occurs at the beginning of a system, a courtesy clef will be generated at the end of the previous system.

To show or hide all courtesy clefs:

1. From the menu, select Style → General... → Page;
2. Check/uncheck "Create courtesy clefs."

It is also possible to show/hide courtesy clefs on a case-by-case basis:

1. "Create courtesy clefs" should already be ticked in the "General" menu (see above);
2. Select a clef and tick/untick "Show courtesy" in the Inspector.

Remove a clef

- Select a clef and press Del.

Hide clefs

Display clef only in the first measure (for all staves)

1. From the menu, select Style → General... → Page;
2. Uncheck "Create clef for all systems."
Display clef only in the first measure (for a particular staff)

1. Right click on the staff, select Staff properties... and uncheck "Show clef;"
2. Open the master palette and select the "Symbols" section;
3. Drag and drop a clef from the master palette onto the first measure of the staff; OR select the first note and double-click a clef in the master palette.

Note: This option may be useful to TAB users who do not want the clef to repeat on every subsequent line.

Hide all clefs in a particular staff

1. Right click on the staff, and select Staff properties...;
2. Uncheck "Show clef."

Key signatures

Standard key signatures are available in the Key Signatures palette in the Basic or Advanced workspaces. It is also possible to create custom key signatures (below).

Add a new key signature

Add new key signature to all staves

Use any of the following methods:
- Drag a key signature from the palette onto an empty part of a measure.
- Select a measure and double-click a key signature in the palette.
- Select a note and double-click a key signature in a palette.

Add new key signature to one staff only

If you wish to change the key signature of only one staff line, leaving others unchanged:
- Press Ctrl (Mac: ⌘) and hold while you drag a key signature from a palette onto a measure.

Replace an existing key signature

Replace key signature for all staves

Use any of the following methods:
- Drag a key signature from the palette onto the key signature to be replaced (or onto the measure containing the key signature).
- Select the key signature to be replaced, and double-click a new key signature in a palette.

Replace key signature for one staff only

If you wish to replace the key signature of only one staff, leaving others unchanged:
- Press Ctrl (Mac: ⌘) and hold while you drag a key signature from a palette onto the key signature to be replaced (or onto the measure containing the key signature).
Remove a key signature

Use any of the following methods:

- Click on an existing key signature and press Del.
- Drag the empty key signature from the palette (in the advanced workspace) onto the measure.

Naturals on key signature changes

By default, MuseScore only shows cancelling naturals when the key signature changes to that of C Major/A minor (no sharps or flats). In all other cases, it simply shows the new key signature without cancellations:

![Key Signatures Example](image)

However, you can opt to display cancelling naturals for all key signature changes:

1. From the menu, select Style → General... → Accidentals. You'll see the options:

![Accidentals Settings](image)

2. Select one of the three options.

3. If you are in a part and want the new option to apply to all parts, click on Apply to all parts.

4. Click OK to exit.

For example, selecting the option "Before key signature if changing to fewer ♯ or ♭" gives:

![Example 1](image)

And the option "After key signature if changing to fewer ♯ or ♭. Before if changing between ♯ and ♮" gives:

![Example 2](image)

Key signature changes and multi-measure rests

Multi-measure rests are interrupted if there is change of key signature:

![Multi-Measure Rests Example](image)

Courtesy key signatures

To turn off the display of a particular courtesy key signature:

- Select the relevant key signature and untick "Show courtesy" in the "Key Signature" section of the Inspector.

To turn off the display of all courtesy key signatures:

- From the menu, select Style → General... → Page, and untick "Create courtesy key signatures."
Note: Courtesy key signatures are not displayed at section breaks.

Custom key signatures

To create a custom key signature:

1. Press Shift+K to display the Key signatures section of the Master palette.

2. In the Create Key signature panel, drag accidentals from the palette onto the "staff" above to create the desired key signature. Use the Clear button, if required, to remove all accidentals from the "staff."

3. Press Add to move the new key signature into the library (center panel).

Note: Playback of custom key signatures is not currently supported.

To move a key signature from the Master palette to a custom palette:

- Drag and drop the key signature onto a palette.

To apply a key signatures to the score directly from the Master palette, use one of the following methods:

- Select a measure and double-click a key signature in the Master palette.
- Drag a key signature from the Master palette onto a measure.
Time signatures

Time signatures can be found in a Palette of the same name in both the Basic and Advanced workspaces.

Add a time signature to a score

To add a time signature, use any of the following methods:

- Drag and drop a time signature from a palette onto a space in a measure.
- Select a measure and then double-click a time signature in a palette.
- Select any note or rest and double-click a time signature in a palette.

The time signature will appear at the beginning of the measure in question.

To replace a time signature, use any of the following methods:

- Drag and drop a time signature onto an existing time signature.
- Select a time signature in the score, then double-click a time signature in a Palette.

Delete a time signature

To delete a time signature in the score, select it and press Del.

Create a time signature

If the time signature you require is not available in any of the existing palettes, it can be created as follows:

1. Press Shift+T to display the Time signatures section of the Master Palette.
2. Select a time signature to edit in the center panel.
3. In the Create Time Signature panel, edit the various parameters (numerator, denominator, text, beaming) to get the time signature and properties you want. To restore the default beaming pattern, press Reset.
4. Press Add to add the newly-created time signature to the center panel. To delete a time signature from the center panel, right-click on it and select Clear.
5. Drag and drop the time signature from the Master Palette to the desired score location.

To move a time signature from the Master Palette to a custom palette:

- Drag and drop the time signature onto a palette in a custom workspace.

Time signature properties

To display the Time Signature Properties dialog:

- Right-click on a time signature and select Time Signature Properties....
- **Global value**: Shows the global time signature and is set automatically when you add a time signature to the score. It is the reference for beats (as shown in the status bar) and tempo markings.
- **Actual value**: Shows the time signature associated with a particular staff. This is normally the same as the global time signature, but can be set independently if required. See [Local time signatures](#).
- **Note Groups**: Allows you to change the default beaming of notes associated with a time signature. See [Change default beaming](#).
- **Appearance**: Allows you to edit the displayed text without affecting the underlying time signature. For an example, see [Additive meters](#).

### Change default beaming

To adjust note-beaming for a particular time signature:

1. Right-click on the time signature and select, **Time Signature Properties…**;

2. To break a note beam in the **Note Groups** panel, click on the note following it. To reset the beam, click in the same place. Alternatively, you can change beaming by dragging a beam icon onto a note, as follows:

   - ![Start beam at this note.](image)
   - ![Do not end beam at this note.](image)
   - ![1/8th note beam to left of this note.](image)
   - ![1/16 note beam to left of this note.](image)

The **Reset** button cancels any changes made in that session.

**Note**: As of version 2.1, checking the box for “Also change shorter notes,” means that any beam changes at one level are applied automatically to shorter durations as well. In versions before 2.1 you must adjust beams for the different note durations independently.

### Additive (composite) meters

Additive (or composite) time signatures are sometimes used to clarify the division of beats within a measure. To create an additive time signature:

1. Right-click on a time signature in the score and select **Time Signature properties…**;

2. In the **Appearance** section, adjust the “Text” property as required;

3. Adjust note beaming in the **Note Groups** section if required.
Note: The Time Signatures section of the Master palette also allows you to create additive time signatures (see above).

Local time signatures

In certain cases a score may show staves with different time signatures running at the same time. For example, in Bach's 26. Goldberg Variation:

![Variation 26](image)

In the above example, the global time signature is 3/4, but the time signature of the upper staff has been set independently to 18/16.

To set a local time signature for just one staff:

- Hold down Ctrl (Mac: Cmd) and drag and drop a time signature from a palette onto an empty measure.

Pickup measures and cadenzas

Occasionally you will need to decrease or increase the duration of a measure without changing the time signature—for example, in a pickup measure (anacrusis) or in a cadenza etc. See Measure operations: Measure duration.

Time signature changes and breaks

Multi-measure rests are interrupted when a time signature change occurs. Also, a section break will prevent a courtesy time signature being shown at the end of the previous measure.

See also

- Key signature

External links

- How To Using Polyrhythm, mixed meters and local time signatures in MuseScore
- Additive meters at Wikipedia.

Accidentals

The most common types of accidentals are provided in the Accidentals toolbar above the score and in the Accidentals palette in the basic workspace. A more comprehensive range can be found in the Accidentals palette in the advanced workspace.

<p>| | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>#</td>
<td>b</td>
<td>×</td>
<td>b</td>
</tr>
<tr>
<td>( )</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Add accidental
Accidentals are automatically added to a note, as appropriate, when you increase or decrease its pitch:

- ↑: Increase the pitch of a note by one semitone (favors sharps).
- ↓: Decrease the pitch of a note by one semitone (favors flats).

To add either (i) a double flat or double sharp, (ii) a courtesy (also known as cautionary or reminder) accidental, or (iii) a non-standard accidental, use one of the following options:

- Select a note and click on an accidental in the toolbar above the score.
- Select a note and double-click an accidental in the Accidentals palette (basic or advanced workspace).
- Drag an accidental from the Accidentals palette on to a note.

If you wish to add parentheses to a cautionary accidental, use one of the following:

- Select the accidental in the score and double-click the parentheses symbol in the Accidentals palette.
- Drag the parentheses symbol from the palette onto the accidental.
- Select the accidental and check the "Has bracket" box in the Inspector (as of version 2.1).

If you later change the pitch of a note with cursor keys, manual settings to the accidental are removed.

If required, accidentals can be deleted by clicking on them and pressing Del.

Change enharmonic spelling

To change the enharmonic spelling of a note, or notes, in both written and concert pitch views:

1. Select a note, or group of notes;
2. Press J;
3. Continue pressing J to cycle through the enharmonic equivalents.

To change the enharmonic spelling in the written pitch view, without affecting the concert pitch view, or vice versa:

1. Select a note, or group of notes;
2. Press Ctrl+J (Mac: Cmd+J);
3. Continue pressing the same combination of keys to cycle through the enharmonic equivalents.

Note: If the pitches of selected notes are not all the same, the effect may be unpredictable.

Respell pitches

- From the menu, select Notes → Respell Pitches.

See also

- Key signature: Change

External links

- Accidental at Wikipedia
- Enharmonic at Wikipedia

Arpeggios and glissandi

Arpeggio and Glissando symbols can be found in the "Arpeggios & Glissandi" palette in the advanced workspace. This palette also includes strum arrows, an arpeggio bracket, wind instrument articulations, and slide in/slide out symbols.
To add a symbol to the score, use one of the following methods:

- Select one or more notes, then double-click a symbol in the "Arpeggios & Glissandi" palette.
- Drag a symbol from the "Arpeggios & Glissandi" palette onto a note.

Any symbol can be customized by adjusting its properties in the Inspector. Edit handles are also provided in most cases to allow adjustment of length/curvature in Edit mode. If needed for future use, you can save the result in a custom palette.

**Arpeggios**

When an arpeggio or strum arrow is added to the score, it initially spans only one voice. However, you can easily adjust its height by double-clicking the symbol and dragging the handles up or down (for finer adjustment use the keyboard arrows). Playback of the symbol can be turned on or off in the Inspector.

**Glissandi (slides)**

A Glissando or, more informally, a slide, spans two consecutive notes, normally in the same voice.

Adjust start and end points

1. Double-click the symbol to enter edit mode;
2. Click on the start or end handle:
   - Use Shift↑↓ to move the handle up or down, from note to note.
   - Use Shift←→ moves the handle horizontally, from note to note.

This method also allows you to move handles between notes in different voices or even from one staff to another—for cross-staff glissandi, for example. You can also use the keyboard arrow buttons or Ctrl + arrow to make final adjustments to the positions of the handles.

**Custom glissandi**

To customize the glissando to your requirements, select it and adjust the Inspector properties as follows:

- **Type:** Choose between a straight or wavy line;
- **Text:** Edit, or delete the text. *Note:* If there isn't enough room between notes, the text is not displayed;
- **Style:** Choose how the glissando plays back. There are four options: Chromatic, White keys, Black keys, Diatonic;
- **Play:** Check/uncheck the box to turn playback on or off.

**Wind instrument articulations**

Fall, Doit, Plop and Scoop symbols are provided. To change the length and curvature, select the symbol, enter edit mode and adjust the handles as described in **Edit mode: Lines**.

**Slide in/out**
Slide in and Slide out lines can also be found in the “Arpeggios & Glissandi” palette. To edit the length and angle of a line, double-click on it and drag the handle (or use keyboard arrows for finer adjustment).

External links

- Arpeggio at Wikipedia
- Glissando at Wikipedia

Articulations and ornaments

A comprehensive set of symbols can be found in the Articulations and Ornaments palette in the Advanced workspace:

<table>
<thead>
<tr>
<th>Symbols</th>
</tr>
</thead>
<tbody>
<tr>
<td>♩</td>
</tr>
<tr>
<td>♩</td>
</tr>
<tr>
<td>♩</td>
</tr>
<tr>
<td>♩</td>
</tr>
<tr>
<td>♩</td>
</tr>
<tr>
<td>♩</td>
</tr>
</tbody>
</table>

There is also an abbreviated version in the Basic workspace.

Articulations

Articulations are the symbols added to the score to show how a note or chord is to be played. The principal symbols in this group are:

- Fermatas
- Staccato
- Mezzo-staccato / Portato
- Staccatissimo
- Tenuto
- Sforzato
- Marcato

Specialist articulations are also included for bowed and plucked strings, wind instruments etc.

Ornaments

Ornaments include:

- Mordents, Inverted Mordents, Praltrillers
- Trills
- Turns
- Bends

Note: Appoggiaturas and acciaccaturas can be found in the Grace Notes palette.

Add articulation/ornament

Use either of the following methods:

- Select a note or a range of notes, then double-click a symbol in a palette.
- Drag a symbol from a palette onto a notehead.

Add accidental to an ornament

To apply an accidental to an existing ornament, such as a trill:

1. Select the note to which the ornament is attached;
2. Open the Symbols section of the Master palette.
3. Search for and apply the desired accidental to the score (small accidentals can be found using the search term "figured bass");
4. Drag the accidental into position (or reposition using keyboard shortcuts or the Inspector).

Add fermata to a barline

A fermata can be applied directly to a barline by selecting the barline and double-clicking the fermata from a palette. This does not affect playback though.

Keyboard shortcuts

- Toggle Staccato: Shift+S
- Toggle Tenuto: Shift+N
- Toggle Sforzato (accent): Shift+V
- Toggle Marcato: Shift+O
- Add Acciaccatura (grace note): /

Keyboard shortcuts can be customized in MuseScore's Preferences.

Adjust position

Immediately after adding an articulation or ornament from a palette, the symbol is automatically selected: It can then be moved up or down from the keyboard as follows:

- Press up/down arrow keys for fine positioning (0.1 sp at a time);
- Press Ctrl+↑ or Ctrl+↓ (Mac: Cmd+↑ or Cmd+↓) for larger vertical adjustments (1 sp at a time).
- To flip a symbol to the other side of the note (where applicable), select it and press X.

To enable adjustments in all directions from the keyboard:

1. Double click on the symbol to enter Edit mode, or click on it and press Ctrl+E (Mac: Cmd+E), or right-click on the symbol and select "Edit element";
2. Press arrow keys for fine positioning (0.1 sp at a time); or press Ctrl+Arrow (Mac: Cmd+Arrow) for larger adjustments (1 sp at a time).

You can also change the horizontal and vertical offset values in the Inspector. To position more than one symbol at a time, select the desired symbols and adjust the offset values in the Inspector.

Note: The symbol can also be repositioned by clicking and dragging, but for more precise control, use the methods above.

Articulation properties

Most properties of articulations/ornaments can be edited from the Inspector. Other properties (i.e. direction and anchor position) can also be accessed by right-clicking on the symbol and selecting Articulation Properties....

You can also make global adjustments to all existing and subsequently-applied articulations by selecting Style... ➔ General... ➔ Articulations, Ornaments.

See also

- Grace notes

External links

- Ornaments at Wikipedia

Bends

A variety of simple and complex (multi-stage) bends can be created with the Bend Tool, located in the Articulations and Ornaments palette of the Advanced workspace.

Apply a bend
To apply one or more bends to the score, use one of the following options:

- Select one or more notes and double-click a bend symbol in the palette.
- Drag a bend symbol from the palette on to a note.

**Edit a bend**

To edit a bend, use one of the following:

- Right click on a bend symbol in the score and select "Bend properties."
- Select a bend symbol in the score and press "Properties" in the "Bend" section of the inspector.

![MuseScore Bend Properties](image)

Preset options are available, if needed, on the left hand side of the Bend properties window. The current bend is represented by a graph consisting of gray lines connected by square, blue nodes (see image above). The slope of the line indicates the type of bend:

- Up-slope = Up-bend
- Down-slope = Down-bend
- Horizontal line = Hold

The vertical axis of the graph represents the amount by which the pitch is bent up or down: one unit equals a quarter-tone: 2 units a semitone, 4 units a whole-tone, and so on. The horizontal axis of the graph indicates the length of the bend: each gray line segment extends for 1 space (sp) in the score.

A bend is modified by adding or deleting nodes in the graph:

- To **add** a node, click on an empty intersection.
- To **delete** a node, click on it.

Adding a node **lengthens** the bend by 1 sp; deleting a node **shortens** the bend by 1 sp. The Start and End points of the bend can be moved up and down only.

**Adjust height**

The height of the bend symbol is automatically adjusted so that it appears just above the staff. This height can be reduced, if necessary, with a workaround:

1. Create another note on the top line (or space) of the staff, vertically above the note at which you want the bend to start.
2. Apply the bend to the higher note first: this will give you a bend symbol with the lowest height.
3. To increase the height of the bend move this note downward.
4. Drag the bend symbol downwards to the correct position.
5. Mark the top note invisible and silent (using the inspector).

**Adjust position**

To adjust position use one of the following:

- Drag the bend symbol with a mouse.
• Click on the symbol and adjust the horizontal and vertical offsets in the Inspector.
• Double click on the symbol; or click on it and press Ctrl+E (Mac: Cmd+E); or right-click on the symbol and select “Edit element.” Then use the arrow keys for fine positioning (0.1 sp at a time); or Ctrl+Arrow (Mac: Cmd+Arrow) for larger adjustments (1 sp at a time).

### Custom bends

After a bend has been created in the score it can be saved for future use by dragging and dropping the symbol to a palette while holding down Ctrl+Shift (Mac: Cmd+Shift). See Custom Workspace.

### Beams

**Note beams** are set automatically, based on the time signature. To adjust the default beaming, right-click on a time signature and select “Time Signature Properties.” See Change default beaming for details.

However, if you want to adjust note beaming manually, on a case-by-case basis, use the **beam symbols** found in the Beam Properties palette in the “Basic” or “Advanced” workspaces:

![Beam Symbols](image)

#### Beam symbols

The following is a list of beam symbols and their effects:

- ![Beam Symbol](image) Start a beam at this note (or rest).
- ![Beam Symbol](image) Do not end a beam at this note (or rest).
- ![Beam Symbol](image) Do not beam this note.
- ![Beam Symbol](image) Start a second level beam at this note.
- ![Beam Symbol](image) Start a third level beam at this note.
- ![Beam Symbol](image) (back to) Automatic mode: the mode MuseScore chooses on note input, dependent on current time signature and its beam settings.
- ![Beam Symbol](image) Start feathered beam (slower) at this note.
- ![Beam Symbol](image) Start feathered beam (faster) at this note.

#### Change note beaming

To change one or more note beams (except feathered beams, below), use either of the following methods:

- Drag and drop a beam symbol from a workspace onto a note in the score.
- **Select** one or more notes in the score and double click the desired workspace beam symbol.

To apply **feathered note beams**, use either of the following methods:

- Drag and drop a feathered-beam symbol from a workspace onto a note beam in the score.
- Select one or more note beams in the score, then double click on a feathered-beam symbol in the workspace.

**Notes**: (1) Feathered beams may use 2 or 3 lines depending on the tempo and the desired rate of the change; (2) To create a 2-line feathered beam, you need to start with a continuous run of beamed sixteenth notes; (3) To create a 3-line feathered beam, you need to start with continuous run of beamed thirty-second notes; (4) Playback of feathered beams is not supported.
Adjust beam with the keyboard/mouse

Adjust beam angle

1. Double-click on a note beam or select it and press \texttt{Ctrl+E} to put it into \texttt{edit mode}—the right end handle is automatically selected.
2. Use the up/down arrows or drag the right end handle to change the angle of the beam.
3. Press \texttt{Esc} to exit edit mode.

Adjust beam height

1. Double-click on a note beam or select it and press \texttt{Ctrl+E} to put it into \texttt{edit mode}—the right end handle is automatically selected.
2. Press \texttt{Shift+Tab} or click the left handle to select it
3. Use the up/down arrows or drag the left end handle to change the height of the beam.
4. Press \texttt{Esc} to exit edit mode.

Adjust beam with the inspector

Alternatively, you can use the \texttt{Inspector} for all of these operations:

Adjust beam angle

1. Click on a note beam.
2. Tick the "User position" box in the "Beam" section of the \texttt{Inspector}.
3. Set the "Position" values to get the desired beam angle.

Adjust beam height

1. Click on a note beam.
2. Tick the "User position" box in the "Beam" section of the \texttt{Inspector}.
3. Set the "Position" values as desired.

Make the beam horizontal

1. Select a note beam.
2. Tick the "Horizontal" box in the "Beam" section of the inspector.
3. If desired, adjust the beam height with the keyboard/mouse: see above.

If you want all note beams in the score to be horizontal there is a "Flatten all beams" option in \texttt{Style → General → Beams}.

Adjust feathered beams

To adjust feathered beams:

1. Select a note beam.
2. Adjust the values in the "Grow left" and "Grow right" boxes in the "Beam" section of the \texttt{Inspector}.

Local relayout

MuseScore (following accepted music engraving practice) spaces notes according to their time values, allowing for accidentals, lyrics etc. In systems where there is more than one staff, this may result in irregular note spacing, as in the following example:

\begin{figure}
\centering
\includegraphics[width=0.5\textwidth]{example.png}
\caption{Local relayout example}
\end{figure}

Local relayout is a tickbox option in the \texttt{Inspector} allowing you to specify those passages in the score where you want...
the note spacing to be independent of other staves in the system. Applying "Local relayout" to the note beams in the top staff of the previous example results in a more even distribution of notes:

![Image of note beams]

To do a local relayout:

1. Select one or more note beams.
2. Tick the option **Local relayout** in the “Beam” section of the **Inspector**.

**Flip note beam**

To flip a beam from above to below the notes, or vice-versa:

1. Select one or more note beams.
2. Use any of the following options:
   - Press the **X** key;
   - Press the "Flip direction" icon in the bottom right of the toolbar area.
   - Select a "Direction" option (Auto, Up or Down) in the "Beam" section of the **Inspector**.

**Reset Beam Mode**

To restore beams to the mode defined in the local time signatures:

1. Select the section of the score you want to reset. If nothing is selected, the operation will apply to the whole score;
2. Select **Layout → Reset Beam Mode**.

**See also**

- **Cross-staff notation**
- **Edit mode**
- **Note input**

**External links**

- **How to add a beam over a rest**
- **How to place a beam between notes**

**Brackets**

MuseScore provides standard **brackets** and a curly **brace** within the **Brackets palette** in the advanced **workspace**.

![Brackets and brace]

**Add**

To add a bracket or brace to systems, use one of two methods:

- Drag a bracket symbol from a palette on to an empty space in the first measure of the staff where you want the bracket to start.
- Select the first measure of the staff where you want the bracket to start and double-click a bracket symbol in a palette.

**Delete**

- Select the bracket and press **Del**.
Change

- Drag a bracket symbol from a palette onto an existing bracket in the score.

Edit

When you first apply a bracket it only spans one staff. To extend to other staves:

1. Enter Edit mode.
2. Drag the handle downwards to span the required staves. The handle snaps into position, so exact placement is not required.

Style

The default thickness and distance from the system of brackets and braces can be adjusted in Style → General… → System.

Breaths and pauses

Breath and pause markings are available in the Breaths & Pauses palette in the advanced workspace.

Add symbol

To add a breath or pause (the latter also called a caesura, or informally "tram lines" or "railroad tracks") to the score, use one of the following options:

- Select a note or rest and double-click a breath or pause symbol in a palette
- Drag a breath or pause symbol from a palette onto a note or rest in the score.

The symbol is placed after the note.

Adjust position

To adjust the position of the breath or pause, use any of the following options:

- Click on the symbol and adjust the Horizontal or Vertical offsets in the Inspector.
- Enter edit mode on the symbol, and use arrow key shortcuts.

Adjust pause length

From version 2.1 onwards, you can adjust the pause length (in seconds) of the added symbol using the "Breath" or "Caesura" category in the Inspector.

Grace notes

A grace note is a type of musical ornament, usually printed smaller than regular notes. The Short grace note, or Acciaccatura, appears as a small note with a stroke through the stem. The Long grace note, or Appoggiatura, has no stroke.
Create grace notes

Grace notes can be found in the "Grace notes" palette in the Basic or Advanced workspace.

Add a grace note

Use one of the following methods:

- Select a regular note and double click a grace note in a palette;
- Drag a grace note symbol from a palette onto a regular note;
- Select a note and press / to create an acciaccatura only.

This will add a grace note of the same pitch as the regular note. To add a sequence of grace notes to a regular note, simply repeat the above actions as many times as required. See also, Change pitch (below).

Note: When a grace note is added to the score, a slur is not automatically created with it, so the latter needs to be added separately. See Slurs.

Add a chord of grace notes

Grace note chords are built up just like regular chords:

1. Enter the first note of the chord as shown above
2. Select this first grace note and enter subsequent notes as you would for any other regular chord (i.e. Shift+A...G).

You can also create a grace note chord by using the add interval shortcut in step 2: Alt+1...9 for intervals from a unison to a ninth above.

Change pitch

The pitch of a grace note can be adjusted just like a regular one:

1. Select one or more grace notes
2. Adjust pitch using the keyboard arrow commands, namely:
   - ↑ or ↓ to increase or decrease the pitch by a semitone;
   - Alt+Shift↑ or Alt+Shift↓ to increase or decrease the pitch one step at a time, according to the key signature.

Change duration

If you want to change the duration of a previously created grace note, select it and choose a duration from the toolbar or enter with one of the keys 1...9 (see Note input).

Manual adjustment

The position of a grace note after a note (such as a trill termination) may have to be adjusted by selecting the note, going into edit mode and using the left/right keyboard arrows; or change the chord offset values in the Inspector.

External links

- Grace note at Wikipedia
- Appoggiatura at Wikipedia
- Acciaccatura at Wikipedia

Hairpins

Add a hairpin

Hairpins are line objects. To create a hairpin:

1. Select a range of notes or measures;
2. Use one of the following shortcuts:
   - <: to create a crescendo hairpin.
   - >: to create a diminuendo hairpin (decrescendo).

Alternatively, use one of the following options:

- Select a range of notes or measures, and double-click a hairpin in a palette.
- Drag and drop a hairpin from a palette onto a staff line.

Adjust length

1. Double-click on the hairpin to enter **edit mode**. Then click on the end handle that you want to move:

2. Use one of the following shortcuts:
   - Shift+→ to move the end handle, and its anchor, right by one note or rest.
   - Shift← to move the end handle, and its anchor, left by one note or rest;

This method of extending or shortening the hairpin maintains playback integrity and allows it to cross line breaks:

3. To change the position of an end handle **without** changing the position of its anchor, use the following shortcuts:
   - → to move the handle right by 0.1 sp.
   - ← to move the handle left 0.1 sp.
   - Ctrl+→ (Mac: Cmd+→) to move the handle right one sp.
   - Ctrl← (Mac: Cmd←) to move the handle left one sp.

**Note:** The commands listed in step 3 are only used to tweak the final appearance of the hairpin (e.g. see image below): they do not change its playback extent nor do they allow it to cross line breaks. If you want the latter, use the Shift+→ or Shift← commands instead (step 2).

**Note:** The "Reset" command (Ctrl+R (Mac: Cmd+R)) will undo these small adjustments, but will not undo anchor changes.

Cresc. and dim. lines

In addition to hairpins, there are cresc. _ _ _ _ _ and dim. _ _ _ _ _ lines with the same function in the **Lines** palette.

To change the text (e.g. to cresc. poco a poco, or decresc. instead of dim), right-click on the line and choose **Line Properties**.

To turn a hairpin into its equivalent text line:

1. Select the hairpin.
2. In the **Inspector**, set "Line style" to "Wide dashed."
3. In the Inspector, select the "Text line" checkbox.

Hairpin playback

Crescendo and diminuendo lines only affect playback from one note to the next: they have no affect (currently) on the playback of a single note or a series of tied notes.

By default, hairpins will affect playback only if dynamics are used before and after the hairpin. For example, a crescendo spanning notes between \( p \) and \( f \) dynamics will cause a dynamic change on playback. However, between any two successive dynamics only the first appropriate hairpin will have effect: a diminuendo between \( p \) and \( f \) will be ignored; of two or more crescendos between \( p \) and \( f \), all but the first will be ignored.

A hairpin may be used without dynamic marks, by adjusting "Velocity change" in the Inspector (values in the range 0 to 127).

Lines

The Lines palette of the Advanced workspace includes the following types of lines:

- Slur
- Hairpins (crescendo and diminuendo)
- Volta brackets (1st, 2nd, 3rd time endings etc.)
- Octave lines (8va, 8vb, 15ma etc)
- Keyboard pedal markings
- Extended ornament lines (Trills etc)
- Guitar barre line
- Straight line
- Ambitus (early music symbol)

Applying lines to the score

Most lines (except Slurs, Volta brackets and the Ambitus) can be applied from a palette in the following ways:

To apply a line to just one note

1. Click on a note, then Ctrl+Click on the next note;
2. Double-click a line.

To apply a line across a range of notes
1. **Select** a range of notes; 
2. Double-click a line.

To apply a line from a note to the end of that measure

Use any of the following methods:

- Click on a note, then double click a line.
- Drag and drop a line onto the score.

To apply a line across a range of measures

1. **Select** one or more measures; 
2. Double click a line.

**Adjust vertical position**

To adjust the vertical position of one or more lines:

1. Ensure you are not in note-input or edit mode.
2. Use either of the following:
   - Click on one or more lines and change the vertical offset in the Inspector;
   - Click on a line, press and hold *Shift* and drag it up/down with a mouse.

**Note:** You can also adjust the vertical position in *Edit* mode.

**Change length**

1. Ensure you are not in *note input* mode (press *Esc* to exit); 
2. Double click the line that you want to change to enter *edit* mode; 
3. Click on an end handle and use one of the following shortcuts:
   - *Shift+→* to move the end handle, and its anchor, right by one note (or, in the case of *Voltas*, one measure)
   - *Shift←* to move the end handle, and its anchor, left by one note (or, in the case of Voltas, one measure);
4. To change the position of an end handle without changing the position of its anchor, use the following:
   - *→* to move the handle right by 0.1 sp (1 sp = one staff space = the distance between two staff lines).
   - *←* to move the handle left 0.1 sp.
   - *Ctrl+→* (Mac: *Cmd+→*) to move the handle right one sp.
   - *Ctrl←* (Mac: *Cmd←*) to move the handle left one sp.

**Note:** You can also drag the endpoint handles with a mouse.

**Text lines**

A **text line** is a line that has text embedded within it—such as a *volta*, *ottava*, guitar barre line etc.

When you apply a text line to the score from a palette, the **line properties** (see below) always remain unchanged, but the properties of embedded text may vary depending on circumstances. See **Behavior of applied text and lines** for details.

**Custom lines and line properties**

Lines may contain features such as embedded text or hooks at the ends (e.g. *ottavas* and *voltas*). They can be customized once they have been added to the score, and the results saved to a *workspace* for future use:

1. Right-click on a line and select *Line Properties...*; 
2. Add any text you want to appear in the line;
   - **Begin:** Text added here appears at the beginning of the line.
   - **Continue:** Text added here appears at the beginning of a continuation line.
   - **End:** Text added here appears at the end of the line.
Click on the ... buttons to adjust the Text properties at each position as required.

3. If a hook is required, tick the appropriate Hook box, and adjust the hook length and angle;

4. Select an option from Place: "Above or "Below" positions the text so that it overlaps the line; "Left" places the text to the left of the line;

   Note: Additional placement options are available in the Text properties dialog (see step 2, above).

5. Click OK to exit Line Properties;

6. Make adjustments to Color, Thickness and Line type (solid, dashed etc.) in the Line section of the Inspector.
   Ticking Diagonal here allows you to create a diagonal line by dragging the end handles;

7. If you wish to save the resulting line for future use, see Custom palettes.

Copying lines

Once applied to the score, lines cannot be copied using the usual copy and paste procedures. However, you can duplicate lines within a score: press and hold Ctrl+Shift (Mac: Cmd+Shift), click on the line and drag it to the desired location.

Extended ornament lines

To add an accidental to an extended ornament, such as a trill line, select the line and double-click a symbol from the Accidentals palette.

External links

- Piano pedal marks at Wikipedia
- Guitar Barre at Wikipedia

Measure rests

Full measure rest

A whole rest, centred within a measure (shown below), is used to indicate that an entire measure (or a voice within a measure) is silent, regardless of time signature.

To create one or more full measure rests

Use the following method if all selected measures are "standard"—i.e. with no custom durations:

1. Select a measure, or range of measures.
2. Press Del.

If one or more of the measures contains a custom duration, use the following method instead:

1. Select a measure, or range of measures.
2. Press Ctrl+Shift+Del (Mac: Cmd+Shift+Del).

To create a full measure rest in a particular voice

1. In the appropriate voice, enter a rest that extends for the full measure.
2. Make sure the rest is selected, then press Ctrl+Shift+Del (Mac: Cmd+Shift+Del).

Multimeasure rest

A Multimeasure rest indicates a period of silence for an instrument: the number of measures is shown by the number above the staff.
Multimeasure rests are automatically interrupted at important points, such as double barlines, rehearsal marks, key- or time signature changes, section breaks, etc.

To display multimeasure rests

To turn multimeasure rests on or off:
- Press M on your keyboard.

Alternatively:
1. From the menu, choose Style → General...
2. Click on the "Score" tab, if it is not already selected;
3. Tick/untick "Create multi-measure rests."

Note: It is recommended that you enter all notes in the score first before enabling multi-measure rests.

Break multimeasure rest

You may want to have a multi-measure rest divided into two multi-measure rests:
1. Ensure that the option to display multimeasure rests in the score is off (see above).
2. Right-click on the measure where you want the second multi-measure rest to start;
3. From the menu, chose Measure Properties and tick "Break multi-measure rest."

See also: Measure operations: Break multimeasure rest.

Octave lines

Octave (Ottava) lines are used to indicate that a section of music is to be played one or more octaves above or below written pitch: The line may be dotted or solid. Ottavas are available in the Lines palette of the Basic and Advanced workspaces.

8 or 8va : Play one octave above written pitch
8 or 8vb : Play one octave below written pitch

8va/8vb lines are particularly common in piano scores, though they are sometimes used in other instrumental music. 15ma (2 octaves above) and 15mb (2 octaves below) are also occasionally used.

Apply an octave line

Use one of the following:
- Select a range of notes, then double click an octave line from a palette.
- Select one or more measures, then double click an octave line from a palette.
- Click on a note, then double-click an octave line from the palette (extends line from selected note to end of bar).
- Drag an octave line from a palette onto a note (extends line from selected note to end of bar).

See also, Lines: Adjust vertical position.

Change length

See Lines: Change length.
Custom lines

Octaves can be customized just like any other line. See Lines: Custom lines and line properties.

External links

- Octave at Wikipedia


Slurs

A slur is a curved line between two or more notes indicating that they are to be played legato—smoothly and without separation. Not to be confused with Ties, which join two notes of the same pitch.

There are a number of ways to add a slur to a score, and all may be useful depending on the context (adding a slur from the lines palette is also possible but not recommended).

Add slur in note-input mode

1. While in note input mode, type in the first note in the slurred section;
2. Press $S$ to begin the slurred section;
3. Type in the remaining notes in the slurred section;
4. Press $S$ again to end the slurred section.

Add slur outside note-input mode

Method 1

1. Make sure you are not in note input mode and select the first note that you want the slur to cover:

2. Press $S$ to add a slur extending to the next note:

3. (Optional) Hold $\text{Shift}$ and press $→$ (right arrow key) to extend the slur to the next note. Repeat as required:

4. (Optional) Press $X$ to flip the slur direction:

5. Press $\text{Esc}$ to exit edit mode:

Method 2

1. Make sure you are not in note input mode:
2. Select the note where you want the slur to start;
3. Chose one of the following options:
   - To add a slur to one voice only: Hold down Ctrl (⌘ on a Mac) and select the last note that you want the slur to cover.
   - To add slurs to all voices: Hold down Shift (⌘ on a Mac) and select the last note that you want the slurs to cover.
4. Press S.

Adjust slur

If you only want to adjust the position of a slur:
1. Select the slur;
2. Use any of the following methods:
   - Drag the slur.
   - Adjust the horizontal and vertical offset values in the Inspector.

To adjust all the properties of a slur (length, shape and position):
1. Make sure you are not in note input mode;
2. Double-click the slur to enter edit mode (or select it and press Ctrl+E; or right-click it and select "Edit Element");
3. Click on a handle to select it, or use Tab to cycle through the handles;
4. To move the left and right handles from note to note, use the following shortcuts:
   - Shift+→: Move to next note.
   - Shift←: Move to previous note.
   - Shift+: Move to lower voice (voice 2 to voice 1 etc.).
   - Shift+: Move to higher voice (voice 1 to voice 2 etc.).
5. To adjust the position of any handle, use any of the following methods:
   - Drag the handle.
   - Use the arrow keys for fine adjustment (0.1 sp. at a time). For larger adjustments (1 sp. at a time) use Ctrl+Arrow.
6. Press Esc to exit edit mode.

Note: The two outer handles adjust the start and end of the slur, whilst the three handles on the curve adjust the contour. The middle handle on the straight line is used to move the whole slur up/down/left/right.

Extended slurs

A slur can span several systems and pages. The start and end of a slur is anchored to a note/chord or rest. If the notes are repositioned due to changes in the layout, stretch or style, the slur also moves and adjusts in size.

This example shows a slur spanning from the bass to the treble clef. Using the mouse, select the first note of the slur, hold down Ctrl (Mac: ⌘) and select the last note for the slur, and press S to add the slur.

X flips the direction of a selected slur.

Dotted slurs

Dotted slurs are sometimes used in songs where the presence of a slur varies between stanzas. Dotted slurs are also used to indicate an editor’s suggestion (as opposed to the composer’s original markings). To change an existing slur into a dotted or dashed slur, select it and then in Inspector (F8) change Line type from Continuous to Dotted or Dashed.

See also
- Tie
- Edit mode
- Note input
Ties

A tie is a curved line between two notes of the same pitch, indicating that they are to be played as one note with a combined duration (see external links below). Ties are normally created between adjacent notes in the same voice, but MuseScore also supports ties between non-adjacent notes and between notes in different voices.

In note-input mode, if you specify a tie immediately after entering a note or chord, the program automatically generates the correct destination notes to go with the ties. Or, you can simply create ties "after the fact," between existing notes.

Note: Ties, which join notes of the same pitch, should not be confused with slurs, which join notes of different pitches and indicate legato articulation.

Tie notes together

1. Press Esc to make sure you are not in note input mode.

2. Click on a note, or use Ctrl (Mac: Cmd) + click to select more than one note.

3. Press + or the tie button,.

Ties will be created between the selected note(s) and the following note(s) of the same pitch.

Tie chords together

To tie all the notes in a chord at once, either:

- Click on the stem of the chord, or
- Hold down Shift and click on any note in the chord.

Then press + or the tie button. Ties will be created between all the notes in the selected chord and the following notes of the same pitches.

Add tied notes in note input mode

To create a single note tie during note input:

1. Select a single note (one that is not part of a chord).

2. Select a new note duration for the following note, if required (but see "Note" below).

3. Press + or the tie button,.

Note: This shortcut works, as described above, only if there is no chord following the selected note. If there is, then the duration is ignored and the tied note is added instead to the following chord.

Add a tied chord in note input mode
1. Make sure one note is selected in a chord.
2. Select a new note duration for the following chord, if required (but see "Note" below).
3. Press + or the tie button, 

**Note:** This shortcut works, as described above, only if there is no chord following the selected note. If there is, then the duration is ignored and the tied notes are added instead to the following chord.

**Tied unison notes**

If the chords to be tied contain unison notes the best way to ensure correct notation is:

1. Assign each note of a unison pair to a separate voice.
2. Ensure that one of the unison pairs is set to "stemless" (to remove the duplicate stem and tail).
3. Apply the ties voice by voice. Make adjustments for position, length as required.

**Flip a tie**

x flips the direction of a selected tie, from above the note to below the note, or vice-versa.

**See also**

Slur

**External links**

- How to create ties leading into a 2nd ending
- Ties (music) at Wikipedia

**Tremolo**

Tremolo is the rapid repetition of one note, or a rapid alternation between two notes or chords. It is indicated by strokes through the stems of the notes or chords. If the tremolo is between two, the bars are drawn between them. Tremolo symbols are also used to notate drum rolls.

The tremolo palette in the advanced workspace contains separate symbols for one note tremolos (shown with stems below) and for two note tremolos (shown with no stem below).

To add tremolo to a single note, select the note head and double-click the desired symbol in the tremolo palette.

In a two note tremolo, every note has the value of the whole tremolo duration. To enter a tremolo with the duration of a half note (minim), enter two normal quarter notes (crotchets), and after applying a tremolo symbol to the first note, the note values automatically double to half notes.

**Tuplets**

Tuplets are used to write rhythms beyond the beat divisions usually permitted by the time signature. For example, a sixteenth note triplet divides an eighth note beat into three sixteenth notes instead of two:

In 6/8 time, an eighth note duplet divides a dotted quarter note into two eighth notes instead of three:
Create a tuplet

The exact method of tuplet entry depends on whether you are starting off in Note input mode or Normal mode. We'll start off with a simple example: the creation of an eighth note triplet.

Create a triplet in normal mode

1. Select a note or rest that specifies the full duration of the desired triplet group. In the case of an eighth note triplet, you will need to select a quarter note or rest—as in the example below:

2. From the main menu, choose Notes → Tuplets → Triplet, or press Ctrl+3 (Mac: ⌘+3). This will give the following result:

3. The program automatically changes to note-input mode and selects the most appropriate duration—in this example an eighth note. Now enter the desired series of notes/rests. For example:

Create a triplet in note input mode

1. Ensure you are in note input mode (press N).
2. Navigate to the note/rest (or blank measure) where you want the triplet to start (use the left/right arrow keys as required).
3. Select a final duration for the whole triplet group. In the case of an eighth note triplet, click on the quarter note in the note input toolbar (or press 5 on the keyboard).
4. From the main menu, choose Notes → Tuplets → Triplet, or press Ctrl+3 (Mac: ⌘+3). This creates a triplet number/bracket and appropriately divides the original note/rest (see image above).
5. The program automatically selects the most appropriate duration—in this example an eighth note—allowing you to immediately start entering the desired series of notes/rests.

Create other tuplets

To create other tuplets (Duplet (2) to Nonuplet (9)), substitute one of the following commands at the relevant step above:

- Press Ctrl+2–9 (Mac: Cmd+2–9).
- From the menu, select Notes → Tuplets, then click on the desired option.

For more complex cases, see below.

Custom tuplets

To create other tuplets than the default options (e.g. 13 sixteenth notes in the space of one quarter note):

1. In Note input mode, select a note duration equaling the total duration of the tuplet; or, if in Normal mode, select a note or rest of the desired overall duration;
2. Open the Create Tuplet dialog from the menu: Notes → Tuplets → Other...;
3. Select the desired number ratio (e.g. 13/4 for thirteen sixteenth notes in the space of a quarter note) under "Relation" in the "Type" section. Specify "Number" and "Bracket" using the radio buttons in the "Format" section;
4. Click OK to close the dialog:

![Image of tuplet example]

5. Enter the desired series of notes/rests.

**Delete a tuplet**

To delete any tuplet, select the number/bracket and press Del.

**Change display of tuplets**

- To change the way that tuplets are displayed in the score, adjust the properties in the "Tuplet" section of the Inspector.
- Some general settings for tuplets can also be found in Style → General... → Tuplets.

**Using the Inspector**

To change the display properties of tuplets in the score, select the tuplet numbers/brackets, and adjust the desired properties in the "Tuplet" section of the Inspector:

![Image of Inspector dialog]

If neither the number nor the bracket of the tuplet is shown in the score, select a note from the tuplet, then use the Tuplet button in the Inspector to display the "Tuplet" section:

![Image of Inspector dialog]

**Direction**

- "Auto" places the bracket/number in the default position.
- "Up" places the bracket above the note heads, regardless of the stem, or beam position.
• "Down" places the bracket below the note heads, regardless of the stem, or beam position.

**Number type**

• "Number" shows an integer.
• "Relation" shows a ratio of two integers.
• "Nothing" turns off number display.

![Image of a musical staff with a tuplet notation showing number and bracket types]

**Bracket type**

• "Automatic" hides the bracket for beamed notes and shows the bracket if the tuplet includes unbeamed notes or rests.
• "Bracket" displays the bracket.
• "Nothing" hides the bracket.

**Using the Style menu**

To make fine adjustments to the way all tuplets in the score are displayed, from the menu, select **Style → General...** and select **Tuplets**.
Two adjustments are possible: Vertical and Horizontal

- Vertical adjustment has three options with values in space units and one (un)ticked option
  - Maximum slope: default value is 0.50; range is from 0.10 to 1.00
  - Vertical distance from stem (see (2) below): default value is 0.25; range is from -5.00 to 5.00
  - Vertical distance from note head (see (3) below): default value is 0.50; range is from -5.00 to 5.00
  - Avoid the staves: by default ticked

- Horizontal has four options with values in space units
  - Distance before the stem of the first note (see (5) below): default value is 0.50; range is from -5.00 to 5.00
  - Distance before the head of the first note: default value is 0.00; range is from -5.00 to 5.00
  - Distance after the stem of the last note (see (6) below): default value is 0.50; range is from -5.00 to 5.00
  - Distance after the head of the last note: default value is 0.00; range is from -5.00 to 5.00

External links

- How to create triplets and other tuplets
- How to create nonstandard tuplets
- Tuplet at Wikipedia
- The User Guide to Tuplets in MuseScore [video]

Repeats and jumps

Simple repeats

You can create a simple repeat by placing a start and an end repeat barline at the beginning and end of a passage. These barlines are applied from the Barlines palette, and, as of version 2.1, also from the Repeats & Jumps palette.
Note: If the start of a repeat coincides with the beginning of a piece or section, the start repeat barline can be omitted if desired. Similarly, an end repeat barline can be omitted at the end of a score or section.

1st and 2nd endings

First create a simple repeat (as shown above), then apply the first and second time endings—see Voltas.

Playback

To hear repeats during playback, make sure the "Play Repeats" button on the toolbar is selected. Likewise, you can turn off repeats during playback by deselecting the button.

To set the number of times that a repeat section plays back:

1. Make sure the start and end repeat barlines are in place (e.g. Simple repeats above).
2. Right-click on the last measure before the end repeat barline and select Measure properties.
3. Adjust "Play count" ("Repeat count" prior to version 2.1) as required.

Repeat symbols and text

Text and symbols related to repeats are located in the Repeats & Jumps palette (in the Basic and Advanced workspaces). This palette contains:

- Symbols for measure repeat, Segno, Coda, and, as of version 2.1, repeat barlines
- D.S., D.C., To Coda, and Fine text

To add a repeat symbol to the score use either of the following:

- Drag and drop a repeat symbol from the palette onto (not above!) the desired measure (so the measure changes color).
- Select a measure, then double-click the desired repeat symbol in the palette.

Jumps

Jumps are symbols in the score which tell the musician, and playback, to skip to a named marker (see below). Jumps include the various kinds of D.C. (Da Capo) and D.S. (Dal Segno) text.

If you click on a jump, some text boxes and a checkbox are displayed in the Jump section of the Inspector. These have the following effects on playback:

- Jump to: Playback jumps to the marker whose "Label" is the same as the "Jump to" tag.
- Play until: Playback continues until it reaches a marker whose "Label" is the same as the "Play until" tag.
- Continue: Playback jumps to the next marker whose "Label" is the same as the "Continue" tag.
- Play repeats: (As of version 2.2) Ticking this box tells MuseScore to play repeats after D.C. (Da Capo) or D.S. (Dal Segno) text.
If this option is not ticked then simple Repeats are not taken after jumps and playback works as if it were the last repeat. Note: Ticking this option makes no difference to playback in versions prior to 2.2.

Note: The tags start and end, referring to the beginning and end of a score or section, are implicit and don’t need to be added by the user.

Markers

Markers are the places referred to by the jumps. A list of markers (in addition to the implicit "start" and "end") follows:

- Segno (tag: segno)
- Segno Variation (tag: varsegno)
- Coda (tag: codab)
- Coda Variation (tag: varcoda)
- Fine: (tag: fine)
- To Coda: (tag: coda)

If you click on a marker, the following properties appears in the Marker section of the Inspector:

- Marker type: This can be changed from the dropdown list, if required.
- Label: This is the (identifier) tag associated with the marker. See also Jumps (above).

Examples of jumps

- Da Capo (D.C.): At the “D.C.” sign, playback jumps to the start (i.e. to the implicit start tag) and plays the entire score or section again (i.e. up to the implicit end tag).
- Da Capo (D.C.) al Fine: At the “D.C. al Fine” sign, playback jumps to the start (i.e. to the implicit start tag) and plays the score up to the Fine (i.e. the fine tag).
- Dal Segno (D.S.) al Fine: At the “D.S. al Fine” sign, playback jumps to the Segno symbol (i.e. the segno tag) and then plays up to the Fine (i.e. the fine tag).
- Dal Segno (D.S.) al Coda: At the “D.S. al Coda” sign, playback jumps to the Segno symbol (i.e. the segno tag) and then plays up to the To Coda (i.e. the coda tag). Playback then continues at the Coda symbol (i.e. the codab tag).

Note: The properties (i.e. the tag names) of jumps and markers can be set via the Inspector. You need to modify them if using multiple jumps and markers.

See also

- Barlines
- Volta

External links

- MuseScore in Minutes: Repeats and Endings, part 2 (video tutorial)
- How to separate a coda from the rest of the score (MuseScore HowTo)

Voltas

Volta brackets, or first and second ending brackets, are used to mark different endings for a repeat.

![Volta Example]

To add a volta to the score

Use one of the following methods:

- Select a measure, or range of measures and double-click a Volta icon in the Lines palette.
- Drag-and-drop a volta from the Lines palette, then adjust the length as required (see below).
To change the number of measures that a volta covers

1. Double-click the volta to enter edit mode. The end handle is automatically selected.
2. Press Shift→ to move the end handle forward one measure. Press Shift← to move the handle backward one measure. Repeat as required.

Note: Only the Shift commands will alter the playback start and end points of the volta. To make fine adjustments to the visual start or end points you can use other keyboard arrow commands, or drag the handles with a mouse, but these do not affect the playback properties.

When you select a start or end handle, a dashed line appears connecting it to an anchor point on the staff. This anchor shows the position of the playback start or end point of the Volta.

Text

You can change the text and many other properties of a volta bracket using the line properties dialog. Right-click on a volta bracket and choose Line Properties.... The figure below shows the volta text as "1.-5."

You can also right-click on the volta and bring up the volta properties dialog. From here, you can change both the displayed Volta text (the same from the line properties above) and the repeat list. If you want one volta to be played only on certain repeats and another volta on other repeats, enter the repeat times in a comma separated list. In the example below, this volta will be played during repeat 1, 2, 4, 5 and 7. Another volta will have the other ending, like 3, 6 and possibly other higher numbers like 8, 9, etc.
Playback

Sometimes a repeat plays more than two times. In the figure above, the volta text indicates that it should play five times before it continues. If you want to change the number of times MuseScore plays a repeat, go to the measure containing the end repeat barline and change its Play count (Repeat Count prior to version 2.1). See Measure operations: Other properties for details.

External links

- MuseScore in Minutes, Lesson 8: Repeats and Endings, Part 1
- How to create ties leading into a 2nd ending

Transposition

Transposition is the act of raising or lowering the pitch of a selection of notes by the same interval. You can choose to transpose notes either manually or by using the Transpose dialog.

Manual transposition

1. Select the notes that you wish to transpose;
2. Use any of the following options:
   - To transpose chromatically: Press ↑ or ↓. Repeat as required;
   - To transpose diatonically: Press Alt + Shift + ↑ or ↓. Repeat as required;
   - To transpose by an octave: Press Ctrl + ↑ or ↓ (Mac: Cmd + ↑ or ↓).

Note: In versions prior to 2.1, F2 (Mac: fn+F2) transposes the whole score and key signature UP one semitone. Shift+F2 (Mac: Shift+fn +F2) transposes the score and key signature DOWN one semitone.

Automatic transposition

MuseScore's Transpose dialog gives you more options for transposing notes.
Note: By default this dialog opens from the Notes menu, but you can also chose to open it using a keyboard shortcut (see Preferences).

Transpose Chromatically

By Key

To transpose notes up or down to the nearest key:

1. Select the notes you want to transpose; no selection equals "select all.";
2. From the menu bar, choose Notes → Transpose...;
3. Tick "Transpose Chromatically" and "By key;"
4. Tick/untick "Transpose key signature" and "Transpose chord symbols" if required;
5. Tick one of "Closest," "Up" or "Down;" and select a destination key signature from the drop-down menu;
6. Click OK.

By Interval

To transpose selected notes up or down in semitone increments:

1. Select the notes you want to transpose; no selection equals "select all.";
2. From the menu bar, choose Notes → Transpose...;
3. Tick "Transpose Chromatically" and "By Interval;"
4. Tick/untick "Transpose key signature" and "Transpose chord symbols" if required;
5. Tick "Up" or "Down;" and select a transposition interval from the drop-down menu;
6. Click OK.

Transpose Diatonically

To transpose selected notes up or down by a diatonic interval:

1. Select the notes you want to transpose; no selection equals "select all.";
2. From the menu bar, choose Notes → Transpose...;
3. Tick "Transpose Diatonically;"
4. Tick/untick "Transpose key signature" and "Transpose chord symbols" if required;
5. Tick "Up" or "Down;" and select a transposition interval from the drop-down menu;
6. Click OK.

Transposing instruments
Transposing instruments, such as the B-flat trumpet or E-flat alto sax, sound lower, or higher than their written pitch. MuseScore has a number of features to facilitate the scoring of these instruments.

Concert pitch

MuseScore's default viewing mode shows the musical notation in written pitch, but you can choose to display the score in concert pitch instead. In the latter mode, the musical notation of all instruments matches the actual pitches that you hear on playback.

To switch to concert pitch, use one of the following options:

- Press the Concert Pitch button to highlight it.
- From the menu bar, select Notes and tick the Concert Pitch option.

You should ensure that the Concert pitch button is OFF before printing the main score or any parts.

Change staff transposition

Instrument transpositions are already set up in MuseScore. However, if you want a rare instrument or transposition that is not available in MuseScore, you may need to edit the instrument transposition manually.

1. Right-click an empty part of the instrument staff and select Staff Properties....
2. At the bottom of the window, select the interval of transposition, any octave shifts, and whether the interval is "Up" (sounds higher than written) or "Down" (sounds lower than written).

You can also use the Change Instrument... button in the Staff Properties window to automatically change the transposition to that of a different standard instrument.

External links

- How to transpose (MuseScore How-To)
- Concert pitch or not?? (forum discussion)

Drum notation

Entering percussion notation is somewhat different to entering notation for pitched instruments (such as the piano or violin). However, it is recommended that you first read the chapter on Note input for pitched instruments before proceeding.

Percussion staff types

When you create a percussion staff using the New Score Wizard or the Instruments dialog, MuseScore automatically chooses the most appropriate staff type (1-, 3-, or 5-line) for the instrument: this can be changed, if required, using the "Staff type" column on the Choose instruments / Instruments page. Any additional changes (e.g. to a 2-line staff) can be made from the score itself (see Advanced Style Properties).

On a 5-line percussion staff, each instrument is assigned a vertical staff position (line or space) and a notehead shape. For a drumset, one or two voices can be used. If the latter, voice 1 (the upper voice) usually contains (up-stem) notes played by the hands while voice 2 (the lower voice) usually contains (down-stem) notes played by the feet (see image below).

![Drum notation example](image)

Note input methods

You can add notes to a percussion staff from any of the following:

- External MIDI keyboard;
- Piano keyboard (virtual);
- Computer keyboard;
- Mouse.
These methods can be used in any desired combination:

**MIDI keyboard**

To add notes to a percussion staff from a **MIDI keyboard**:

1. Ensure that the MIDI keyboard is connected and functioning correctly.
   
   **Note**: If you click on the percussion staff without entering **note input** mode, you can **demo** the percussion instruments from the MIDI keyboard.

2. Click on the note or rest where you want to start.

3. Enter **note input** mode.

4. Select the correct **voice**. For example, snares, sidesticks and all cymbals are normally added to voice 1; bass drum to voice 2.

5. Set **note duration**.

6. Press an instrument key to add a note to the score. To add another note at the same position, keep the first key held down while pressing the second key.

   **Note**: Refer to a **GM2 drum map** for details about which MIDI keyboard key corresponds to which percussion instrument. Some keyboards (e.g., Casio) display percussion symbols next to the keys as an aid to the user.

**Piano keyboard**

To add notes to a percussion staff from the virtual **Piano Keyboard**:

1. Ensure that the Piano keyboard is displayed. Press **P** (or select it from the menu, **View → Piano Keyboard**).
   
   **Note**: If you click on the percussion staff without entering **note input** mode, you can **demo** the percussion instruments from the Piano keyboard.

2. Click on the note or rest where you want to start.

3. Enter **note input** mode.

4. Select the correct **voice**. For example, snares, sidesticks and all cymbals are normally added to voice 1; bass drum to voice 2.

5. Set **note duration**.

6. Click on a (virtual piano) key to add a note to the score.

7. To add another note to an existing one, press **Shift** and hold it while pressing the new note (in versions before 2.1, use **Ctrl** (Mac: **Cmd**)).

   **Note**: Refer to a **GM2 drum map** for details about which piano key corresponds to which percussion instrument.

By default, the piano keyboard is docked at the bottom of the screen—to the left of the Drum input palette. However you can undock it by dragging, then dock the panel in several ways:

- Drag the panel downwards to the center and it will overlay the Drum input palette, full length. Both panels can then be accessed by Tabs.
- Drag the panel downwards to the right/left and it will dock to the right/left of the Drum input palette.

**Computer keyboard**

To enter notes on a percussion staff using your computer keyboard:

1. Click on the note or rest where you want to start.

2. Enter **note input** mode. The **Drum input palette** now appears at the bottom of the screen (see **below**).

3. Select the desired **note duration**.

4. Press the shortcut key (**A–G**) for the instrument that you wish to enter—refer to the Drum input palette window.

5. If you wish to add another note to an existing one in that voice, press **Shift + [A–G]**.

   **Note**: Voice allocation is determined by the color of the note in the drum input palette: blue for voice 1, green for voice 2.

**Mouse**

**To add a note to a percussion staff**
Use the following method to add a new note or to replace an existing chord.

1. Select the note or rest where you want to start. You can also select a measure.
2. Press N to enter note input mode. The Drum input palette now appears at the bottom of the screen (see below).
3. Set note duration.
4. Choose one of the following options:
   - Double-click a note in the Drum input palette.
   - Select a note (e.g. Bass drum, or Snare) in the Drum input palette, then click a note or rest in the score.

To add a note to an existing chord in the percussion staff

1. Ensure you are in note input mode.
2. Select a note duration equal to the note you are adding to.
3. Click on the new note in the Drum input palette.
4. Click above or below the existing note in the percussion staff.

Note: Voice allocation is determined by the color of the note in the drum input palette: blue for voice 1, green for voice 2.

Drum input palette

When a percussion staff is selected and note input mode is ON, a window opens at the bottom of the screen called the Drum input palette. This window is essential for mouse input, and displays shortcuts for computer keyboard input, but can be ignored if using a MIDI keyboard or the virtual Piano Keyboard.

Each note in the palette represents a percussion instrument: hovering the mouse pointer over the note displays the instrument name.

The letters A–G (shown above certain notes in the palette) are designated as shortcuts for entering particular instruments (bass drum, snare, closed hi-hat etc.), rather than referring to note pitches. They can be changed or reallocated as desired in the Edit Drumset window.

When the Drum input palette is open, double-clicking a note in the palette or entering a shortcut letter will add that instrument note to the percussion staff. The color of the note in the palette shows the voice allocated for that note—blue for voice 1, green for voice 2. This can be changed in the Edit Drumset dialog if required.

This voice allocation applies only to keyboard and mouse entry of notes: entry via a MIDI keyboard or the virtual Piano keyboard allows any voice to be used.

Edit Drumset

To open the Edit Drumset window, use one of the following options:

- Click on the Edit Drumset button at the left of the Drum input palette.
- Right-click on a percussion staff and select "Edit Drumset...".
The **Edit Drumset** dialog displays the percussion instruments available and the MIDI notes/numbers to which they are allocated. It also determines how each instrument is displayed on the staff—its name, position, notehead type and note-stem direction. **Any changes made here are automatically saved in the parent MuseScore file.**

Clicking on a row in the left-hand column allows you to edit the display properties for that note as follows:

**Name**: The name you want displayed in the Drum input palette when you mouse over the note.

**Notehead**: Chose a notehead for that instrument from a drop-down list of options (if set to "Invalid," the instrument will not display in the Drum input palette).

**Staff line**: This number indicates the staff line/space on which the note is displayed. "0" means that the note is displayed on the top line of the 5-line staff. Negative numbers move the note upwards step by step, while positive numbers move it downwards in the same way.

**Stem Direction**: Auto, Up or down.

**Default voice**: Assign to one of four voices. This does not affect input from a MIDI keyboard or the virtual Piano keyboard.

**Shortcut**: Assign a keyboard shortcut to enter that note.

The customized drumset can be saved as a .drm file by pressing **Save**. You can also import a customized drumset using the **Load** button.

**Note**: In MuseScore 2.1, some of the pitches in the Tenor Drums instrument do not play back; there is a DRM file designed to fix this, which you can download [here](#), via right-click → Save target as.

**Roll**

To create a drum roll, use **Tremolo**.

**External links**

- [How to create jazz drum notation](#) [MuseScore How-To]
- [Video tutorial: MuseScore in Minutes: Lesson 7 - Tablature and Drum Notation](#)
- [Drum Parts](#) [video]
- [Editing the Drum Palette in MuseScore 1.1](#) [video]
- [Saving Drumset Changes in MuseScore 1.1](#) [video]
- [Guide to Drum and Percussion Notation](#)

**Tablature**
Music for fretted, stringed instruments is commonly notated using tablature, also known as tab, which provides a visual representation of the strings and fret numbers:

Tablature can also be combined with traditional staff notation:

Create a new tablature staff

If you wish to create tablature as part of a new score, use the New Score Wizard. If you want to add tablature to an existing score, use the Instruments dialog. Or, alternatively, you can convert an existing standard staff. See below for details.

With the New Score wizard

To create tablature in a new score (for combined staff/tablature systems see below):

1. Open the New Score wizard.
2. Enter the score details (optional). Click Next.
3. On the Choose template file page, click on Choose Instruments.
4. On the Instruments page, select one (or more) tablature options under "Plucked strings" in the left-hand column (see image below). Then click Add.

Note: You can use the dropdown list above the Instrument list to change the category displayed. Alternately you can search for the instrument using the "Search" field below the Instrument list.

5. Complete the rest of the New Score Wizard.
If the desired tablature is not available in the Choose Instrument list:

1. At step "4" (above), select an existing "Plucked strings" tablature staff.
2. Press Add to move it to the right-hand column.
3. Check the drop-down menu to the right of the newly-added instrument for the most suitable Tab option, if any.
4. Complete the rest of the New Score wizard and exit.
5. Modify the number of strings and tuning of the tablature, if needed, in the Staff properties window (see below).
6. Change the Instrument name in Staff Properties, if required.

This allows you to create tablature for any chromatically-fretted instrument.

With the Instruments dialog

To add a single tablature staff to an existing score (for combined staff/tab system see below):

1. Open the instruments dialog (press I; or from the menu bar, select Edit → Instruments…).
2. Add the tab staff as described in Add instruments ("Create a new score").

By changing staff type

To convert an existing standard staff to tablature, or tablature to a standard staff:

1. Right click on the staff and select Staff Properties…. If “Instrument” is already set to a plucked-strings type, then exit staff properties and go to step 4.
2. If “Instrument” is not a plucked-strings type, click on Change instrument and select an appropriate instrument from “Plucked strings.”
3. Click on OK twice to exit staff properties.
4. Open the instruments dialog (press I, or from the menu bar select Edit → Instruments…).
5. Click on the staff in the right-hand column and change the “Staff type” to the desired option.
6. Click OK to exit the Instrument editor and return to the score page.

Note: If you subsequently need to make further adjustments to the staff (e.g. tuning, number of lines/strings etc.), right click on the staff and select Staff Properties….

Alternative method (using just the "Staff Properties" dialog):

1. Right click on the staff and select Staff Properties….
2. If the Instrument displayed is in the "Plucked strings" category, go to step 4.
3. If the Instrument displayed is not in the "Plucked strings" category, click Change instrument and select an appropriate instrument from "Plucked strings". Click on OK.
4. Click Advanced Style Properties…, change “Template” to the desired option and press < Reset to Template >.
5. Click OK twice to close the Staff Properties dialog box.

Note: Other adjustments to the staff (e.g. tuning, number of lines/strings etc.), can also be made in the Staff Properties… dialog.

Edit string data

Change tuning

Note: If you only want to view (rather than change) the instrument tuning, follow steps 1 and 2 only.

1. Right-click on the staff and select Staff Properties….
2. Press the Edit String Data… button at the bottom of the dialog box. The **String Data** dialog opens:

3. Click on a string pitch and select **Edit String…** Or, alternatively, just double-click the string pitch.

4. Select a new pitch in the **Note Selection** box and click **OK**. Or, alternatively, just double-click the new pitch.

5. Click **OK** to close the "**String Data**" dialog box. Then click **OK** to close the "**Staff/Part Edit Properties**" dialog box.

**Notes:** (1) If tuning is changed when the tablature for that instrument already contains some notes, fret marks will be adjusted automatically (if possible); (2) Any change of tuning to a particular instrument applies *only* to the score at hand, and does not change any program default settings.

**Add a string**

1. Right-click on the staff, select **Staff Properties…**, then press **Edit String Data**.
2. Click on a string pitch and select **New String…**.
3. Select the new pitch and press **OK**—or, alternatively, just double-click the new pitch. The new string is inserted *below* the selected string.

**Note:** After adding a tablature string you will need to adjust the number of lines in the **Staff properties** dialog.

**Delete a string**

1. Right-click on the staff, select **Staff Properties…**, then press **Edit String Data**.
2. Click on a string pitch and select **Delete String**.

**Note:** After deleting a tablature string you will need to adjust the number of lines in the **Staff properties** dialog.

**Mark unfretted string "open"**
This feature is used to mark a (bass) course as unstopped (i.e. outside of the fingerboard and always sounding open): as on a Baroque lute or Theorbo etc. This means that only "0" (zero) or "a" is accepted as a fret mark: any other fret mark will be converted to 0/a.

1. Right-click on the staff, select Staff Properties..., then press Edit String Data.
2. Check one or more boxes in the "Open" column.

**Change number of instrument frets**

This property defines the maximum fret number which can be entered on a tablature staff.

1. Right-click on the staff, select Staff Properties..., then press Edit String Data.
2. Select or enter a new number in the Number of frets spin box.

**Change tablature display**

You can customize both the appearance of a tablature staff and the way that it displays the fret marks. To access these options:

1. Right click on the staff and select Staff Properties....
2. Click on the Advanced Style Properties... button.

**Combine pitched staff with tablature**

Plucked-string instruments—such as the guitar—are commonly notated using both a music staff and tablature (TAB) together. MuseScore gives you the option of having the two staves either unlinked or linked:

1. **Unlinked Staves**: You can enter, delete or edit notation in one staff without affecting the other. To transfer music notation from one staff to the other, select the desired range and copy and paste it into the other staff.
2. **Linked Staves**: Any changes you make in one staff are automatically applied to the other staff as well ("mutual translation").

**A note on fret mark conflicts**: When the same note is entered in two different voices, MuseScore tries to ensure that the fret marks do not overlap on the same string. Any overlaps which do occur are marked with red squares: these appear only in the document window and not on any printed copy. In almost all cases (e.g. frets 0 to 4 on the 6th string), overlapping is the desired result and no further adjustment is required. As of version 2.2, you can hide the red marks by selecting "View" and unticking "Show Unprintable."

**Create a staff/tablature pair with the New Score wizard**

1. Open the New Score wizard.
2. Enter the score details (optional). Click Next.
3. On the Choose template file page, click on Choose Instruments.
4. Select a pitched staff in the "Plucked strings" section of the left-hand column. Then click Add.
5. Select the newly-created staff line (i.e. marked "Staff ") in the right-hand column and chose one of two options:
   - Click Add Staff to create an unlinked staff/tab pair.
   - Click Add Linked Staff to create a linked staff/tab pair.
6. In the Staff type column, click on the dropdown list for the newly-created staff and select a tablature option (this can be modified later, if required, on the score page—see Staff Properties).
7. Complete the rest of the New Score Wizard, or click Finish.

**Note**: To create unlinked staves with separate mixer channels, instead of step "5" (above), select a Tablature staff in the left-hand column and click Add. Then continue with steps 6 and 7.

**Create a staff/tablature pair in an existing score**

1. Open the Instruments editor (press I, or from the menu bar, select Edit → Instruments...).
2. Select a pitched staff in the "Plucked strings" section of the left-hand column. Then click Add.
3. Select the newly-created staff line (i.e. marked "Staff ") in the right-hand column and chose one of two options:
   - Click Add Staff to create an unlinked staff/tab pair.
   - Click Add Linked Staff to create a linked staff/tab pair.
4. In the Staff type column, click on the dropdown list for the newly-created staff and select a tablature option (this can be modified later, if required, on the score page—see Staff Properties).
5. Change the staff order using the \textsuperscript{↑} button if needed.
6. Click \textit{OK} to return to the score.

\textit{Note:} To create unlinked staves with \textit{separate} mixer channels, instead of step "3" (above), select a Tablature staff in the left-hand column and click \textit{Add}. Then continue with steps 4–6.

\textbf{Create a staff/tablature pair from an existing staff}

To add tablature to a plucked-string staff in the score (or vice versa):

1. Open the \textbf{Instruments} editor (press \textit{I}, or from the menu bar, select \textit{Edit} \to \textit{Instruments…}).
2. Select the staff line (marked "Staff 1") in the right-hand column that you want to add to.
3. Chose one of two options:
   \begin{itemize}
   \item Click \textit{Add Staff} to create an \textit{unlinked} staff/tab pair
   \item Click \textit{Add Linked Staff} to create a \textit{linked} staff/tab pair
   \end{itemize}
4. In the \textbf{Staff type} column, click on the dropdown list for the newly-created staff and select an option (this can be modified later, if required, on the score page—see \textit{Staff Properties}).
5. Change the staff order using the \textsuperscript{↑} button if needed.
6. Click \textit{OK}.

\textit{Notes:} To create unlinked staves with \textit{separate} mixer channels, instead of step "3" (above), select an appropriate staff in the left-hand column and click \textit{Add}. Then continue with steps 4–6.

\textbf{Enter notes in tablature}

\textbf{Using a computer keyboard}

\begin{itemize}
\item First, ensure that you are not in note-input mode. Select the measure or existing note from which you want to begin note entry.
\item Switch to note input mode (\textit{N}): a short 'blue rectangle' appears around one tablature string: this is the \textit{current string}.
\item Select the duration of the note or rest that you wish to enter (see \textit{below}).
\item Press the up/down arrow keys to move the cursor to the desired string. Use the left/right arrow keys to navigate through the score.
\item Press 0 to 9 to enter a fret mark from 0 to 9 on the current string; to enter numbers with several digits press each digit in sequence. Keys A to K (skipping I) can also be used: convenient when working in French tablature. For L, M, N, use the alphanumeric keyboard and type respectively 10, 11, 12...
\end{itemize}

\textit{Note:} You cannot enter a number higher than the "Number of frets" value set in the \textit{Edit String Data} dialog.

\begin{itemize}
\item Press ; (semicolon) to enter a rest of the selected duration.
\item You can enter notes in different \textit{voices} if required—just as you would in a standard staff.
\end{itemize}

See also, \textit{Edit notes} (below).

\textbf{Historical tablature}

As of version 2.1, period notation for bass strings (lutes and sim.) is supported:

\begin{itemize}
\item \textbf{French tablature}: letters with prefixed slash-like strokes right under the tab body: i.e. 7th string: "a", 8th string: "/a", 9th string: "//a" and so on, all in the first position below the tab body.
\item \textbf{Italian tablature}: numbers with 'ledger line'-like segment of string above the tab body: i.e. 7th string: "0" one position above the tab body with one 'ledger line'; 8th string: "0" two positions above the tab body with two 'ledger lines' and so on.
\end{itemize}

Input of is via computer keyboard only: by moving the note entry cursor below (French) or above (Italian) the tab body, 'shadow' slashes or ledger lines will indicate the target string to which the fret mark will be applied; pressing one of the fret keys, will enter (and lay out) the note on that string.

\textbf{Using a mouse}

To enter notes into tablature with a mouse:
- Enter note input mode and select the note or rest duration (see below).
- Click on a string to create a note there. Notes are initially created on fret 0 (or a for French tablatures): to correct, type in the right number from the keyboard.
- You can also increase/decrease the fret mark using Alt+Shift+↑ or Alt+Shift+↓.
- You can enter notes in different voices if required—just as you would in a standard staff.

See also, Edit notes (below).

Select note duration

In note input mode, you can use any of the following methods to set note duration in tablature:
- Press Shift+1 to Shift+9: Sets duration from a 128th note to a longa (availability of these shortcuts may depend on the platform and/or keyboard layout);
- Press NumPad 1 to NumPad 9: Sets duration from a 128th note to a longa (if a numeric keypad exists and NumLock is on);
- Click on a note duration icon in the Note Input toolbar above the document window;
- Press Q to decrease the selected duration and W to increase it.

Edit notes

Note input mode

To edit an existing fret mark in note-input mode:
- Position the cursor above the fret mark and simply retype the number.
- Increment or decrement the fret mark using Alt+Shift+↑ or Alt+Shift+↓.

Non note input mode

To edit an existing fret mark outside note-input mode:
1. Select one or more fret marks.
2. Use any of the following commands:
   - To increment or decrement, without changing the string: Press ↑/↓.
   - To increment or decrement, changing strings, when possible, to minimize the fret number: Press Alt+Shift+↑/↓.
   - To move to an adjacent string (if the string is free and can produce that note): Press Ctrl+↑/↓ (Mac: Cmd+↑/↓).

Note: The fret mark cannot be higher than the "Number of frets" value set in the Edit String Data dialog.

Crosshead notes

To change a fret mark to a crosshead note:
1. Select one or more fret marks (in non-note-input mode).
2. Press Shift+X to toggles ghost noteheads on/off.

Summary of keyboard commands

Note input mode

<table>
<thead>
<tr>
<th>Type</th>
<th>to get</th>
</tr>
</thead>
<tbody>
<tr>
<td>↑</td>
<td>Select above string as current.</td>
</tr>
<tr>
<td>↓</td>
<td>Select below string as current.</td>
</tr>
<tr>
<td>Shift+1 to Shift+9</td>
<td>Select a duration (128th note to a longa)</td>
</tr>
<tr>
<td>NumPad 1 to NumPad 9</td>
<td>Select a duration (128th note to a longa)</td>
</tr>
<tr>
<td>Q</td>
<td>Decrease current input duration.</td>
</tr>
<tr>
<td>W</td>
<td>Increase current input duration.</td>
</tr>
<tr>
<td>0 to 9</td>
<td>Enter a fret digit / letter.</td>
</tr>
<tr>
<td>A to K</td>
<td>Enter a fret digit / letter (↑ excluded).</td>
</tr>
</tbody>
</table>
### Sound and playback

MuseScore has "Sound and playback" capabilities built-in. This chapter covers the playback controls and ways to extend the instrument sounds.

#### Mid-staff instrument changes

When a musician is required to double on a different instrument for a section of a piece, the instruction to switch instruments is generally placed above the staff at the beginning of that section. A return to the primary instrument is handled in the same manner.

MuseScore enables users to insert a special class of text called **Change Instrument** text for this purpose. This class of text is different from either **Staff** or **System** text in that it links the text to the playback and changes the sound to the new instrument.

**Instrument changes as of version 2.1**

Version 2.1 introduces a greatly improved mid-staff instrument change over previous versions. There are still some limitations that need to be considered prior to using it.

1. Mid-staff instrument changes are limited to the same type of staff. For example, you cannot change between a percussion staff and a pitched instrument staff or vice versa.

2. The instrument name is not changed in the mixer. It will still be listed under the instrument in the original definition of the staff.

3. The key signature is not automatically updated at the instrument change. You must manually change the **Key signature** if needed.

4. You can now enter the notes a musician would play once the instrument is changed and the correct key signature is entered if necessary.

5. Unless you are changing the type of staff, you will always use the **Change Instrument** text.

**Instrument changes in version 2.0**

There are several limitations to this in version 2.0 which should be understood before attempting to use it.

1. Automatic transposition from concert pitch to the appropriate key for the transposing brass and woodwind instruments is not currently supported. For changes to instruments notated in a different key (C flute to E♭ flute;
Oboe to English Horn, etc.), the use of ordinary Staff Text to indicate the change is preferable, and the transposition must be done after the music is entered (using Notes → Transpose from the main menu). To avoid discord on playback, the instrument assigned to that staff should be muted in the F10 Mixer.

2. If it is necessary to hear the new instrument sound on playback, the Change Instrument text function must be used. However, after a mid-staff instrument change where the two instruments on the staff are not notated in the same key, no attempt should be made to enter new music directly from the keyboard. Instead, the music must be (a) pasted in, or (b) entered before the instrument change is affected. New input into measures following an instrument change is subject to two known program bugs, which cannot be resolved in the current 2.0.x versions without adversely affecting backwards compatibility. (This has been fixed in version 2.1.) In addition, the score must remain notated in concert pitch, or discord will result from the transposition. As a convenience to the players, a copy of the part may be saved as a separate file and the required sections transposed to the appropriate key before the part is printed. (Note that transposing a linked part will affect the score as well.)

3. When changing from one concert-pitch instrument to another, or from one transposing instrument to another in the same key (Bb trumpet to Bb cornet or Flugelhorn, etc.), the Change Instrument Text may be used to ensure that the playback sound is altered to the new instrument. Input may be done in the usual manner, and is not affected by the bugs mentioned above.

Incompatibilities

There are some incompatibilities between the two versions.

1. Instrument changes created with version 2.0 and opened in version 2.1 or above will continue to either display the notes wrong or play the notes wrongs as in version 2.0. Deleting and reentering the instrument change will fix most incompatibility issues with only minor changes being needed.

2. Instrument changes created with version 2.1 or above and opened in version 2.0 will generally playback correctly but continue to display the wrong notes.

Add an instrument change

1. Select the start point of the change by clicking on a note or rest.
2. Open the main palette by typing F9 (or by using the View menu), and click on Text to open the text sub-palette.
3. Double-click on Instrument
4. The word "Instrument" will appear above the anchor note or rest.
5. Double-click the word "Instrument", then type Ctrl+A to select all of it.
6. Type the actual text you wish to appear in the score, then click outside the box to exit text edit mode.
7. Right-click the text and choose "Change Instrument..."
8. Choose the instrument, then click OK

![MuseScore: Select Instrument](image)

See also

- Change instrument
- Mid-staff sound change

External links

- How to change instrument sound (e.g. pizz., con sordino) midway through score?

Mixer

The Mixer allows you to change instrument sounds and adjust the volume and panning for each staff.

To display/hide the mixer, use one of the following:

- Press F10 (Mac: fn+F10).
- From the main menu, select View → Mixer.

![MuseScore: Mixer](image)

**Note**: Separate reverb and chorus effects for each channel are not yet implemented; use the synthesizer effects unit instead.

The name of each mixer channel is the same as the Part name in the Staff properties dialog.
Mute and Solo

- To silence a selected staff, tick its "Mute" checkbox. Repeat as required.
- To solo a selected staff, tick the "Solo" checkbox for that staff.

Dials

To turn a dial clockwise, click and drag upwards. To turn a dial counter-clockwise, click and drag downwards. You can also hover the mouse pointer over the dial and then move the mouse wheel. Double-clicking on any dial restores it to its default position.

Sound

The “Sound” drop-down menu lists every instrument supported by your current SoundFont. If you have multiple SoundFonts loaded in the Synthesizer, all the patches from all the SoundFonts (and/or SFZ files) will appear in a single long list—in the order previously set in the Synthesizer.

Tip: To find an instrument, click on the “Sound” list and type the first letter of the instrument name. Repeat as required.

Mid-staff sound change (pizz., con sordino, etc.)

Some instruments come with multiple channels in the Mixer that can be used to change sounds midway through a score. For example, a staff for a stringed instrument (violin, viola, cello etc.) is allocated three channels: one for "arco" (or "normal"), another for "pizzicato" and another for "tremolo." A trumpet staff will have one channel for "normal" and another reserved for "mute," and so on.

The following instructions use pizzicato strings as an example, but the same principle can be applied to any other instrument staff that allows sound changes.

1. Select the first note of the section you want to be pizzicato;
2. From the main menu, choose Add → Text → Staff Text;
3. Type "pizz." This text is for visual reference only and does not affect playback;
4. Right-click on the applied staff text and select Staff Text Properties…;
5. In the "Change Channel" tab of the "Staff Text Properties" dialog, select one or more voices on the left;
6. From the dropdown menu, select pizzicato;
7. Click OK to return to the score.

Every note after the staff text you added now sounds pizzicato. To return to a normal strings sound later in the piece, follow the same guidelines as above except type "arco" in step 3 and select normal in step 6.

See also

- SoundFont
- Synthesizer
- Change instrument

External links
How to change instrument sound (e.g. pizz., con sordino) midway through score

Play mode

Basic playback functions are accessed from the Play toolbar located above the document window:

![Play toolbar icons]

From left to right, the icons are:

- **Rewind to start position**: Playback returns to the beginning of the score, or to the start of the loop (if one is set).
- **Start or stop playback**: See Start/stop playback.
- **Toggle loop playback**: See Loop playback.
- **Play repeats**: Turn off if you want playback to ignore repeats.
- **Pan score during playback**: Turn off if you want the score to remain stationary.
- **Play metronome**: See Metronome playback.

Playback commands

**Start/stop playback**

To start playback:

1. Click on a note, rest or the blank part of a measure to establish the starting point. Note: If no selection is made, playback returns to the place it left off—or, if no previous playback, to the start of the score.
2. Press the play button button; or press Space.

During playback you can jump to a specific note or rest in the score by simply clicking on it.

To stop playback:

- Press the **Playback** button; or press Space.

**During playback**

Once playback has started, the following commands are available:

- Go back to previous chord: ←
- Advance to next chord: →
- Go back to start of previous measure: Ctrl+ ← (Mac: Cmd+ ←)
- Advance to start of next measure: Ctrl+ → (Mac: Cmd+ →)
- Rewind to start of score: Home (Mac: ⇧+Home); or press the **Rewind** button (playback toolbar).

During playback you can still use keyboard shortcuts to open and close panels, such as Play, Synthesizer, Mixer etc.

**Play panel**

To open the Play Panel use one of the following options:

- Press F11 (Mac: Fn+F11).
- From the menu bar, select View → Play Panel.
The Play Panel offers temporary controls over playback, including playback speed (labelled 'tempo'), loop playback (with specified starting and ending positions), and general volume.

**Note:** Changes to the parameters in the Play Panel are not saved with the score: they only affect playback in the current session. Permanent changes to tempo should be made using tempo text. To change the default playback volume of the score, see Synthesizer.

**Count in**

You can switch on and off a count-in to be played each time the playback starts. The count-in plays beats for a full measure (according to nominal time signature at playback starting point); if the starting point is mid-measure or at a 'short' measure (anacrusis), it also plays enough beats to fill that measure. The conductor icon in the play panel enables, or disables count-in.

**Metronome playback**

You can also switch on/off the accompanying metronome as the score is played (see the metronome icon on the play panel).

**Loop playback**

You can loop playback of a selected passage in the score using either the Play toolbar (see image above) or the play panel.

**To loop from the Play toolbar:**

- Playback should be off, and the "Loop playback button" on.
- Select the desired region of the score for loop playback.
- Press the playback button.

Playback will now cycle within the region marked by the blue flags.

- Use the "Loop playback" button to toggle the loop on or off.

**To loop from the Play Panel:**

- Select the note from which you want playback to start and click on the "Set loop in position" button. The "Loop Playback" button becomes active.
- Select the last note of the desired playback region and click on the "Set loop out position" button.
- Press the play button.

Playback will now cycle within the region marked by the blue flags.

- You can use the "Loop playback" button to toggle the loop on or off.

**SoundFonts and SFZ files**

Audio playback is provided by MuseScore's onboard synthesizer, which houses a large selection of virtual (or software) instruments—including percussion and sound effects.

MuseScore supports virtual instruments in two formats:
- **SoundFont** (.sf2/.sf3): A single file containing one or more virtual instruments.
- **SFZ** (.sfz): A set of audio and definition files containing one or more virtual instruments.

**SoundFonts**

A Soundfont (.sf2/.sf3) is a single file containing one or more virtual instruments. As of version 2.2, MuseScore is installed with a SoundFont called **MuseScore_General.sf3**. This is a GM (**General MIDI**) set containing over 128 instruments, sound effects and various drum/percussion kits.

**Note:** Older versions of MuseScore are installed with a different Soundfont: MuseScore 2.0–2.1 with **FluidR3Mono_GM.sf3**; MuseScore 1 with **TimGM6mb.sf2**.

GM (**General MIDI**) is a universal format, so once your score is set up for correct playback using MuseScore's native Soundfont, you should be able to export it in a format of your choice and have it play back on any other user’s computer.

Many different Soundfonts are available on the Internet: some free, some commercial. For a list of free soundfonts, see below.

**Install a SoundFont**

After finding and decompressing a SoundFont (see → below), double-click to open it. In most cases, the SoundFont file type will already be associated with MuseScore, and MuseScore will start and a dialog will appear asking if you want to install the SoundFont. Occasionally an application other than MuseScore will be associated with the SoundFont file type; if this is the case, you will need to right-click or control-click on the file, so as to display a menu from which you can choose to open the file in MuseScore. In either case, when the dialog appears asking if you want to install the SoundFont, click “Yes” to place a copy of the SoundFont file in MuseScore's SoundFonts directory. This directory can be viewed or changed in MuseScore’s Preferences, but the default location is:

- **Windows:** %HOMEPATH%\Documents\MuseScore2\Soundfonts
- **macOS and Linux:** ~/Documents/MuseScore2/Soundfonts

In contrast to user-added SoundFonts, the initial default SoundFont installed with MuseScore is located in a system directory, meant only for that purpose, which should not be modified. This directory and its default SoundFont file is:

- **Windows (32-bit):** %ProgramFiles%\MuseScore 2\sound\MuseScore_General.sf3
- **Windows (64-bit):** %ProgramFiles(x86)%\MuseScore 2\sound\MuseScore_General.sf3
- **macOS:** /Applications/MuseScore 2.app/Contents/Resources/sound/MuseScore_General.sf3
- **Linux (Ubuntu):** /usr/share/mscore-xxx/sounds/MuseScore_General.sf3 (with xxx being the MuseScore version)

**Uninstall**

To uninstall a SoundFont, simply open the folder where its file is installed and delete it.

**SFZ**

An SFZ consists of a bunch of files and directories, an SFZ file and a bunch of actual sound files in WAV or FLAC format, with the SFZ file being a text file that basically describes what sound file is located where and to be used for what instrument and pitch range.

**Note:** For full support of SFZ, MuseScore 2.1 or later is need, prior versions had only limited support, namely for Salamander Grand Piano

**Install an SFZ**

After downloading an SFZ (see → below), you need to manually extract all the files that belong to the SFZ (the SFZ file itself and all the subdirectories) into the directory listed above. Leave the subdirectories and their contents as they are.

**Uninstall**

To uninstall an SFZ, simply open the folder where its files are installed (see above) and delete them all.
Synthesizer

The Synthesizer is MuseScore's central control panel for sound output. Once a SoundFont has been installed, it needs to be loaded into the Synthesizer in order for MuseScore to use it for playback. To make a different SoundFont the default, load it in the Synthesizer and click Set as Default.

To display the Synthesizer, go to View → Synthesizer. For more details, see Synthesizer.

List of downloadable soundfiles

GM SoundFonts

The following sound libraries conform to the General MIDI (GM2) standard. This specification gives you a sound set of 128 virtual instruments, plus percussion kits.

- **GeneralUser GS** (29.8 MB uncompressed)
  Courtesy of S. Christian Collins
- **Magic Sound Font, version 2.0** (67.8 MB uncompressed)
- **Arachno SoundFont, version 1.0** (148MB uncompressed)
  Courtesy of Maxime Abbey
- **MuseScore 1 came with TimGM6mb** (5.7 MB uncompressed)
  License: GNU GPL, version 2
  Courtesy of Tim Brechbill
- **MuseScore 2 (up to version 2.1) comes with FluidR3Mono_GM.sf3** (13.8 MB).
- **MuseScore 2 (as of version 2.2) comes with MuseScore_General.sf3** (35.9 MB) (SF2 version (208 MB)).
  License: released under the MIT license
  Courtesy of S. Christian Collins
- **Timbres of Heaven, version 3.2** (369 MB uncompressed)
  Courtesy of Don Allen

Orchestral soundfiles

- **Sonatina Symphonic Orchestra** (503 MB uncompressed)
  Downloads: SoundFont | SFZ format
  License: Creative Commons Sampling Plus 1.0
- **Aegean Symphonic Orchestra**
  Courtesy of Ziya Mete Demircan (352 MB uncompressed)

Piano soundfiles

**SF2 Pianos**

- **Acoustic grand piano, release 2016-08-04**
Description: Yamaha Disklavier Pro Grand Piano, sf2 format, 36MiB compressed, 113MiB uncompressed, 121 samples, 5 velocity layers
License: Creative Commons Attribution 3.0
Courtesy of [Roberto Gordo Saez](http://freepats.zenvoid.org/)
- Salamander C5 Light
  Courtesy of [Ziya Mete Demircan](http://freepats.zenvoid.org/) (24.5 MB uncompressed)

**SFZ Pianos**

- Salamander Grand Piano
  Downloads: [version 2](http://freepats.zenvoid.org/) | [version 3](http://freepats.zenvoid.org/)
  Description: Yamaha C5, 48kHz, 24bit, 16 velocity layers, between 80 MB and 1.9 GB uncompressed
  License: Creative Commons Attribution 3.0
  Courtesy of Alexander Holm
- Detuned Piano (244 MB uncompressed)
  License: Creative Commons Attribution-ShareAlike 3.0
- Plucked Piano Strings
  Description: 44.1kHz, 16bit, stereo, 168 MB uncompressed
  License: Creative Commons Attribution-ShareAlike 3.0
- The City Piano
  Description: Baldwin Baby Grand, 4 velocity layers, 696 MB uncompressed
  License: Public domain
  Courtesy of Big Cat Instruments
- Kawai Upright Piano, release 2017-01-28
  Description: 68 samples, 44KHz, 24bit, stereo, 2 velocity layers, 58MiB uncompressed
  License: GNU General Public License version 3 or later, with a special exception
  Courtesy of Gonzalo and Roberto

**Unzipping downloaded soundfiles**

Since soundfiles are large, they are often zipped (compressed) into a variety of formats, including .zip, .sfArk, and .tar.gz. You need to unzip (decompress) these files before they can be used:

- ZIP is standard compression format supported by most operating systems.
- sfArk is a compression format designed especially for compressing SoundFont files. To decompress it, use Polyphone (cross-platform software); or this online service: [https://cloudconvert.com/sfark-to-sf2](https://cloudconvert.com/sfark-to-sf2)
- .tar.gz is a popular compression format for Linux. Windows users can use 7-Zip; Mac users can use The Unarchiver, or macOS' built-in Archive Utility. Note that if using 7-Zip, you will need to apply decompression twice —once for GZip and once for TAR.

**Troubleshooting**

If the toolbar play panel is greyed out, or not visible, follow the instructions below to get your sound working again:

1. Right-click on the menu bar and make sure there is a check mark next to the Playback Controls menu item. If this step does not solve your problem, go to Step 2.
2. If the play panel disappears after changing the SoundFont, go to Edit → Preferences... → I/O tab and click OK without making any changes. After restarting MuseScore, the play panel should reappear.

If you are setting up a SoundFont for the first time, please use one of the recommended SoundFonts listed above.

If playback stutters, then your computer may not not able to handle the SoundFont being used. The following advice may help:

- Reduce the amount of RAM (memory) used by MuseScore by using a smaller SoundFont. See the list above for suggestions.
- Increase the amount of RAM available for MuseScore by quitting all applications except MuseScore. If you still have problems and a large SoundFont is important to you, consider more RAM for your computer.

**See also**
Swing

MuseScore’s **swing** feature allows you to change the playback of your score from a straight to a swing rhythm. Swing can be applied globally or only to a section of the score, and is fully variable.

**Apply swing to a score section**

1. Click on the note where you want swing to start;
2. Double-click **Swing** in the Text palette (shown below);
3. Edit the Swing text as required;
4. If you need to vary swing from the default setting, right click the Swing text and select **System text properties...** Click on the “Swing Settings” tab and adjust note duration and “Swing ratio” as required.

Swing text can be edited just like any other text element: you can change it, style it, make it invisible etc.

**Triplet in tempo marking**

Often this notation is used to indicate swing:

\[
\frac{2}{\text{quarter}} = \frac{3}{\text{quarter}}
\]

MuseScore does not have a way to include a triplet in text as a tempo marking, but there is an easy workaround:

1. Add Swing text as described above and make it invisible (shortcut V, or untick “Visible” in the Inspector);
2. Add an appropriate image of the required tempo marking to the score. This can be downloaded from the bottom of the “How To” page: **How to create a visual swing marking**;
3. Resize and reposition the image as required.

**Return to straight rhythm**

If you want playback to return to straight time after a swing section:

1. Add **Swing** text to the first note or rest of the “straight” section (see above).
2. Edit the text to indicate a return to straight time: e.g. “Straight.”
3. Right-click on the text and select **System Text Properties...** Click on the “Swing Settings” tab and set “Swing to “Off.”

**Apply swing globally**

If you wish to apply swing to the whole score, you can do so from the menu:

1. Select Style → General... → Score.
2. In the “Swing Settings” section, set the desired note value and “swing ratio.”

**External links**

- How to change the SoundFont or add another
- The SFZ Format (for details about the sfz specification)
Swing (jazz performance style) (Wikipedia)

Synthesizer

Overview

To display the Synthesizer: from the menu, select View → Synthesizer.

The Synthesizer controls MuseScore's sound output and allows you to:

- Load and organize different sound sample libraries to play back the music
- Apply effects such as reverb and compression
- Adjust overall tuning
- Alter the output volume of both music and the (optional) metronome.

The Synthesizer window is divided into four sections/tabs:

- **Fluid**: A software synthesizer that plays SF2/SF3 SoundFont sample libraries.
- **Zerberus**: A software synthesizer that plays SFZ format sample libraries.
- **Master Effects**: Used to apply multi-effects to the score.
- **Tuning**: Used to adjust overall playback tuning.

Save/Load Synthesizer settings

The buttons at the bottom of the Synthesizer window have the following functions:

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set as Default</td>
<td>Saves all current synthesizer settings as the default settings. These are automatically applied to the Synthesizer when you open MuseScore.</td>
</tr>
<tr>
<td>Load Default</td>
<td>Loads the last saved default settings to the Synthesizer.</td>
</tr>
<tr>
<td>Save to Score</td>
<td>Saves all current synthesizer settings to the current score only.</td>
</tr>
<tr>
<td>Load from Score</td>
<td>Loads the settings from the current score to the synthesizer.</td>
</tr>
</tbody>
</table>

Notes: (1) “Synthesizer settings” include the order of Soundfonts and SFX files, the effects configuration, master tuning and volume. (2) Only one set of Synthesizer settings can be in effect at a time—i.e. if multiple scores are open at once, it is not possible to make changes to the Synthesizer in one score and leave other scores’ settings untouched. (3) Changes to synthesizer settings will not be heard in exported audio files unless saved to the score first (see table, above). See also Tuning (below).

Fluid

Click on the Fluid tab to access the control panel for SF2/SF3 SoundFont sample libraries. By default, the SoundFont FluidR3Mono_GM.sf3 should already be loaded.
You can load, rearrange and delete soundfonts as required. Playback can be shared between any combination of different soundfonts (and/or SFZ files). The order of soundfonts in **Fluid** is reflected in the **default** order of instruments in the **mixer**.

**To load a soundfont**

1. Click on the **Add** button
2. Click on a soundfont in the list.

To be able to load the soundfont, it first needs to be **installed** in your **Soundfonts folder**. This will ensure that it appears in the list in step 2 (above).

**To reorder the soundfonts**

1. Click on a soundfont
2. Use the up/down arrows (on the right-hand side) to adjust the order.
3. Repeat with other soundfonts in the list if required.

If you have not **changed** any sounds in the **Mixer**, then the SoundFont at the top of the list is the one that will be used for playback. However, if you are using the Mixer to play different instruments with sounds from different SoundFonts, playback will only work correctly if you have the same SoundFonts loaded **in the same order** in the Synthesizer. Therefore, if you are using multiple SoundFonts, it is advised to click the **Save to Score** button in the Synthesizer, so that the next time you open that score you can recall the list of SoundFonts loaded (and other Synthesizer settings) with the **Load from Score** button.

**To remove a soundfont**

1. Click on the name of the soundfont
2. Click on the **Delete** button.

This removes the soundfont from the synthesizer but does not **uninstall** it from the Soundfonts folder: it will still be available if you wish to reload it later.

**Zerberus**

Click on the **Zerberus** tab to access the control panel for **SFZ** sound sample libraries. You can add or delete files in a similar way to the **Fluid** tab. Note that, as with Fluid, the the SFZ files must first be **installed** in your **soundfonts** folder before they can be loaded into the synthesizer.

**Volume**

At the right in the Synthesizer are two sliders. One controls the playback volume, the other controls the volume of the optional built-in metronome. You can turn the metronome on or off by clicking the button underneath its volume slider. As with all the rest of the Synthesizer controls, any changes made here are temporary unless saved to the score or set as the new default.
Effects

The **Master Effects** tab of the Synthesizer allows you to adjust the degree of **reverb** and, as of version 2.0.3, **compression** applied to your score.

To turn an effect on or off:

- Select an option from the drop-down list next to **Effect A** or **Effect B** (the effects are applied in series, A → B).

To store and load effects configurations, use the buttons at the bottom of the Synthesizer window. See **Synthesizer settings** (above) for details.

**Zita 1 reverb**

The **Zita 1** stereo reverb module allows you to simulate the ambience of anything from a small room to a large hall. The pre-delay, reverb time and tone of the reverb can be finely tuned using the controls provided:

- **Delay**: Set a pre-delay for the reverb from 20-100 ms.
- **Low RT60** (Low frequency reverb time): Use the grey control to adjust the center frequency (50–1000 Hz) of the low frequency band which you want to affect: the green control adjusts the reverb time (1–8 secs) of this frequency band.
- **Mid RT60** (Mid-range reverb time): Adjust the reverb time (1–8 secs) of the mid-range frequency band.
- **HF Damping**: Adjusts the high frequency component of the reverb. Increasing this value increases the frequency of the cut-off point and makes the reverb appear brighter and longer.
- **EQ1**: Allows you to cut or boost (-15 to +15) a frequency band (center = 40 Hz - 2 KHz) in the **lower** part of the spectrum.
- **EQ2**: Allows you to cut or boost (-15 to +15) a frequency band (center = 160 Hz - 10 KHz) in the **higher** part of the spectrum.
- **Output**: Controls the amount of effect applied. "Dry" is no effect. "Wet" indicates 100% reverb. "Mix" is a 50/50...
balance of wet/dry signal.

**Note:** EQ1 and EQ2 affect the tone of the reverb only, *not* the dry (unprocessed) signal.

To quickly set up an effects patch, set "Output" to "Mix" and adjust the "Mid RT60" control to the desired reverb time. Then fine tune the effect as explained above.

**SC4 compressor**

The SC4 stereo compressor (available as of version 2.0.3) gives you fine control over the playback's dynamic range, reducing the volume variation between loud and soft sounds. It offers the following controls:

- **RMS**: Adjusts the balance between RMS (0) and Peak (1) compression. In the former, the compressor responds to averaged-out levels in the signal; in Peak mode, the compressor responds to peak levels.
- **Attack**: (1.5–400 ms) The length of time it takes for compression to engage fully after the signal exceeds the threshold level.
- **Release**: (2–800 ms) The time it takes for compression to return to zero after the signal falls below the threshold level.
- **Threshold**: (in dB) The signal level above which compression starts to take effect. Lowering the threshold increases the amount of signal that is compressed.
- **Ratio**: The amount of compression applied to the signal above the threshold. The higher the ratio, the greater the compression. Varies between 1:1 to 20:1.
- **Knee**: Allows you to select a range between "soft knee" and "hard knee". The softer the knee, the more gradual the transition between uncompressed and compressed signal.
- **Gain**: Compression tends to lower the volume, so use this control to boost the signal as required.

To quickly set-up, try setting RMS = 1, Threshold = -20 db, Ratio = 6. Increase Gain to restore the lost volume. Then fine-tune as explained above.

**Tuning**

The **Tuning** tab is where you can adjust the program's **master tuning**. For Concert Pitch instruments, A4 = 440 Hz by default.

To change the Master tuning:

- Enter a new value in the **Master tuning** field, then press **Change Tuning**.

**Notes:** (1) This tuning applies to all scores in the current session only. To make this the program default or to store it to a
particular score, see **Save/Load Synthesizer settings**. (2) To apply the new tuning to exported audio files (WAV, MP3, OGG), press **Save to Score** before exporting.

See also

- **SoundFont**
- **Mixer**

**Tempo**

**Tempo markings** can be found in the Tempo palette of the Basic and Advanced workspaces. They are supplied as metronome marks, but can be subsequently edited to display any tempo or expression you want. Playback tempo can be varied throughout the score by using multiple tempo markings, visible or invisible.

**Add a tempo marking**

Use any of the following methods:

- Select a note or rest and press the **keyboard shortcut** Alt+T.
- Select a note or rest, and from the **menu bar** chose Add → Text... → Tempo Marking.
- Select a note or rest and double-click an appropriate metronome mark in the Tempo palette;
- Drag-and-drop a metronome mark from the Tempo palette, directly onto a note or rest.

**Note**: If a tempo marking is applied from the menu or using a keyboard shortcut, the beat note automatically follows the time signature. The advantage of applying from a palette is that you can chose which beat note to use.

**Edit tempo**

To change the tempo of an existing metronome mark in the score:

1. Enter **Edit mode** for the tempo mark in question;
2. Edit the metronome number and/or the beat note as required;
3. Exit Edit mode.

You can also override the tempo of an existing metronome mark from the **Inspector**:

1. Select the tempo mark;
2. Untick "Follow text" in the "Tempo Marking" section of the Inspector;
3. Set the desired playback tempo in the "Tempo" field underneath.

**Note**: Playback may be faster or slower if the tempo setting in the **play panel** is at a percentage other than 100%.

**Edit tempo text**

Tempo marks can be edited and formatted just like any other text object. To set text properties or text style, see **Text styles and properties**.
The tempo indicated by a metronome mark usually persists even if overwritten by an expression—such as Andante, Moderato etc. You can also add further text to a plain metronome mark. e.g.

\textbf{Andante} \begin{tikzpicture}
\node (author) {\textcopyright\space 2019 \space MuseScore\space Inc.};
\end{tikzpicture}

\textit{Overriding the tempo marking}

You can temporarily override the indicated \textit{tempo}, and play the score back at any tempo you like using the \texttt{play panel}:

1. Display the play panel: View → Play Panel or F11 (Mac: fn + F11):

\begin{center}
\includegraphics[width=0.5\textwidth]{play_panel.png}
\end{center}

2. Move the tempo slider up or down as required. The tempo is shown both as an absolute value and as a percentage of the currently indicated tempo mark. Double-click the tempo slider to reset it.

\textit{Note}: BPM is always measured and displayed in quarter note beats per minute, regardless of the (denominator of the) time signature in effect.

\textit{Ritardando and accelerando playback}

You can simulate \textit{ritardando} ("rit.") and \textit{accelerando} ("accel.") playback by adding hidden tempo markings to the score. The printed indication to the musician should be added as \texttt{staff/system text} in addition.

In the example illustrated below, the tempo was originally 110 BPM (beats per minute). At the ritardando, the tempo decreases by 10 BPM on the first note of each measure. Each tempo change is made invisible by unchecking the \texttt{Visible} checkbox in the \texttt{Inspector}, so that only the ritardando shows on the printed score:

\begin{center}
\includegraphics[width=0.5\textwidth]{ritardando.png}
\end{center}

A \texttt{plugin} has been developed to automate this process: \texttt{TempoChanges} \footnote{http://musescore.org/en/plugins}

\textbf{Fermatas}

Fermatas, available in the Articulations and Ornaments palette, have a \texttt{Time stretch} property that can be set via the \texttt{Inspector}. By default, this property is set to 1.00. To have MuseScore play back a fermata for twice its normal duration, click on the fermata and set "Time stretch" to 2.00. This of course does not work for fermatas applied to barlines, as barlines don't have a duration to stretch.

\textit{See also}

\begin{itemize}
\item Play mode
\item Time signature
\end{itemize}

\textbf{Dynamics}

Dynamics are symbols indicating the loudness of a note or phrase of music. Symbols can be found in the Dynamics palette in either the Basic or Advanced workspace:
**Note:** Overall playback volume of the score can be changed using the volume slider in the Play Panel or Synthesizer.

**Add a dynamic**

To apply a dynamic to the score, use one of the following methods:

- Select a note and double-click a dynamic symbol in a palette.
- Drag a dynamic symbol from a palette onto a note.

For additional dynamics use the Master Palette (Shift+F9). You can also create a custom palette for future use.

To create a crescendo or decrescendo sign, see Hairpin.

**Adjusting playback volume for a dynamic**

Click on the dynamic to select it, and adjust its Velocity in the Inspector—higher for louder, lower for softer.

**Adjusting range for a dynamic**

Via the Inspector you can set the staves affected by a dynamic. The "Dynamic range" is by default set to "part," which means all staves for an instrument will be affected. Changing this to "staff" will limit the dynamic to the staff it is entered on only. Changing this to "System" will cause all instruments to play this dynamic.

**List of dynamics in palettes**

In the Basic workspace, there are 8 options in the Dynamics palette: ppp, pp, p, mp, mf, f, ff, fff.

In the Advanced workspace, there are all of the above plus 15 additional options in the Dynamics palette: fp, sf, sfz, stf, stfz, stfpp, rfz, rf, fz, m, r, s, z, n.

In the Dynamics section of the Master Palette, there are all of the above plus 6 additional options: pppppp, ppppp, pppp, ffff, fffff, ffffffff.

**Edit a dynamic**

Any dynamic can be edited after being added to the score, just like standard text. See Text editing.

**See also**

- Tempo

**External links**

- Video tutorial: Lesson 10 - Articulations, Dynamics and Text
- Dynamics at Wikipedia

**Text**

There are many different kinds of text objects in MuseScore (see tables below); text may also be found incorporated into lines. This chapter shows you how to create, format and edit text objects, and also includes information about the following types of text:

<table>
<thead>
<tr>
<th>Text type</th>
<th>Uses</th>
</tr>
</thead>
<tbody>
<tr>
<td>General purpose text attached to a single staff: appearing only in that instrument</td>
<td></td>
</tr>
</tbody>
</table>

129
Staff text

For other types of text available in MuseScore, follow the links below:

<table>
<thead>
<tr>
<th>Text type</th>
<th>Uses</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tempo marks</td>
<td>Apply metronome and/or expression marks.</td>
</tr>
<tr>
<td>Dynamics</td>
<td>Indicate the loudness of a note or phrase.</td>
</tr>
<tr>
<td>Swing text</td>
<td>Change from straight to swing time, and vice versa.</td>
</tr>
<tr>
<td>Instrument text</td>
<td>Apply mid-staff instrument changes.</td>
</tr>
<tr>
<td>Repeats and jumps</td>
<td>Da Capo, Dal segno, Fine etc.</td>
</tr>
<tr>
<td>Figured bass</td>
<td>Period notation for keyboardists.</td>
</tr>
<tr>
<td>Frame text</td>
<td>Title/composer/lyricist details at the start of a score; songsheet lyrics etc.</td>
</tr>
<tr>
<td>Headers/Footers</td>
<td>Page numbers, copyright info etc. at the top/bottom of a page.</td>
</tr>
<tr>
<td>Text-lines</td>
<td>Voltas, ottavas, pedal lines, guitar barre lines etc.</td>
</tr>
</tbody>
</table>

Text basics

Add text

To add a text-based element to the score, use one of the following general methods:

- **Keyboard shortcut**: For example, press Ctrl+T to enter **Staff text**, Ctrl+L to enter **Lyrics**, and so on.
- **Menu command**: Add → Text allows you to choose from a range of text-based elements.
- **Workspace**: Select a note and double-click an icon in one of the palettes; or, alternatively, drag a symbol from a palette onto the staff, e.g., **Swing text**, **Tempo text** etc.

**Notes**: (1) The exact method depends on the type of text you are adding (see Text). (2) For general-purpose **text boxes** attached to staves, see **Staff and system text**.

Format text

Every text-based element in the score has three levels of formatting:

- **Text style**: This is the highest level of formatting and applies to all text elements in the score of a particular type. For details, see Text style.
- **Text properties**: This applies to the style of one specific text object only. For details, see Text properties.
- **Character formatting**: The style applied to individual text characters during editing. For details, see Text editing.

Adjust position of text objects

To position a text object, use any of the following methods:

- Drag the object.
- Select the object and adjust the horizontal or vertical offset values in the Inspector.
- Select the object and apply any of the following keyboard shortcuts:
  - ←: Move text left 0.1 staff space.
  - →: Move text right 0.1 staff space.
  - ↑: Move text up 0.1 staff space.
  - ↓: Move text down 0.1 staff space.
  - Ctrl+← (Mac: ⌘←): Move text left one staff space.
  - Ctrl+→ (Mac: ⌘→): Move text right one staff space.
  - Ctrl+↑ (Mac: ⌘↑): Move text up one staff space.
  - Ctrl+↓ (Mac: ⌘↓): Moves text down one staff space.
Text anchors

When you apply a text element to the score, its anchor position will depend on the type:

- **Title, Subtitle, Composer, Poet**: Anchored to a frame.
- **Fingering**: Anchored to note heads.
- **Lyrics**: Anchored to a time position (a note/chord, but not a rest).
- **Chord symbol**: Anchored to a time position.
- **Staff text**: Anchored to a time position.
- **System text**: Anchored to a time position.

Text editing

Enter/exit text edit mode

To enter **Text edit mode** use one of the following methods:

- Double click on a text element.
- Right-click on a text element and select **Edit element**.
- Click on a text element and press Ctrl+E (Mac: Cmd+E).

In this mode you can apply formatting to individual characters, including options such as **bold**, **italic**, underline, subscript, superscript, font family and font size. These are accessed from the **Text toolbar** below the document window:

![Text toolbar](image)

To exit **Text edit mode** use one of the following:

- Press Esc.
- Click on a part of the score outside the edit window.

Keyboard shortcuts

In **Text edit mode**, the following keyboard shortcuts are available:

- Ctrl+B (Mac: ⌘+B) toggles **bold face**.
- Ctrl+L (Mac: ⌘+L) toggles **italic**.
- Ctrl+U (Mac: ⌘+U) toggles underline.
- Home End ← → ↑ ↓ moves cursor.
- Backspace (Mac: Delete) removes character to the left of the cursor.
- Del (Mac: → Delete or fn+Delete) removes character to the right of the cursor.
- ⇔ starts new line.
- F2 (Mac: fn+F2) Inserts special characters (see below).

Symbols and special characters

You can use the **Special Characters** window to insert quarter notes, fractions, and many other kinds of special symbols or characters into your text. A few symbols can also be accessed by shortcut (see below).
To open **Special Characters**, use any of the following methods:

- Click on the icon in the text toolbar (below the score window).
- Press F2 (Mac: fn+F2).

**Note**: (1) This only works in **Text edit mode**; (2) The Special Characters dialog should not be confused with the menu item of the same name in the macOS version of MuseScore.

The dialog is divided into 3 tabs: Common symbols, musical symbols and unicode symbols. The musical and unicode tabs are further subdivided into alphabetically-arranged categories.

Double-clicking an item in the Special Characters dialog immediately adds it to the text where the cursor is positioned. Multiple items can be applied without closing the dialog box, and the user can even continue to type normally, delete characters, enter numerical character codes etc., with it open.

**Special character shortcuts**
In **Text edit mode** the following keyboard shortcuts can be used to access certain special characters:

- Ctrl+Shift+B: Flat.
- Ctrl+Shift+F: Forte.
- Ctrl+Shift+H: Natural.
- Ctrl+Shift+M: Mezzo.
- Ctrl+Shift+N: Niente.
- Ctrl+Shift+P: Piano (dynamic mark).
- Ctrl+Shift+R: Rinforzando.
- Ctrl+Shift+S: Sforzando.
- Ctrl+Shift+Z: Z.
- Ctrl+Shift#+: Sharp.

**See also**

- [Chord symbol](#)
- [Lyrics](#)
- [Frame](#)
- [Edit mode](#)

**Text styles and properties**

**Text Style**

This is the highest level of text formatting and applies to all text elements in the score of a particular type. Staff text objects, for example, have a unique style, as do all tempo markings, all lyrics, all chord symbols and so on. Editing a text style allows you to change the appearance of all objects which share that style *in one go*.

**Edit style**

To edit a text style, use any of the following methods:

- From the main menu, chose **Style → Text**. Then select the relevant style from the list.
- Right-click a text object and select **Text Style**.

This will display the **Edit Text Styles** dialog:
The options available are divided into categories:

- **Text**
  - **Font**: name of the font such as "Times New Roman" or "Arial"
  - **Size**: size of the font in points
  - **Style**: style of the font, italic, bold, underline
  - **Color**: click on the color demonstrated to change
  - **Size follows "Staff space"** setting: whether size follows the distance between two lines in a 5-lines standard staff
  - **System flag**: text applies to all staves of a system.

- **Offset**
  - **Horizontal**
  - **Vertical**
  - **Offset Unit**: in mm or Staff space units

- **Alignment**
  - **Horizontal**: left, right, center
  - **Vertical**: align top edge of text to reference point, center text vertical to reference point, center text vertical to text baseline or align bottom edge of text to reference point

- **Frame**
  - **Frame**: add a frame around the text
  - **Frame Type**: Circle or Box
  - **Border thickness**: thickness of the line of the frame in space units
  - **Border radius**: for box frame, radius of rounded corner
  - **Text margin**: inner frame margin in space units
  - **Foreground color**: of the frame border
  - **Background color**: of the background within the frame.

**Note**: Opacity is set by the parameter "Alpha channel" in the colors dialogs: a value between 0, transparent, and 255, opaque.

**Create a new text style**

1. From the menu bar, select **Style → Text...**; or right-click on a text object and select **Text Style...**;
2. Click on **New**;
3. Set a name;
4. Set all properties as desired.

This text style will be saved along with the score. It will not be available in other scores, unless you explicitly save the style sheet and load it with another score.
Apply options

You can apply any changes made to either the score or the part you are seeing, by pressing Apply and then OK.

If you are in one of the parts of your score, you also have the option to use the Apply to all parts button before OK, so you don’t have to manipulate all parts individually.

Reset text to style

If you have made changes to an individual piece of text and you want to return it to the defined text style for the score, or if you changed the style with an old version of MuseScore and you want the style to correspond to the default text style in MuseScore 2, you can use the Reset Text to Style option.

Select the text you want to reset to style and click on Reset Text to Style in the Inspector. If you need all text from a given style to be "reset", right-click on one, then from the context menu choose Select → All Similar Elements first.

Save and load text styles

Text styles (together with all other styles in a document) can be saved as a style file and loaded into other MuseScore files. See Save and load style.

Text Properties

This is the next level down in the formatting hierarchy and affects the style of the text in one specific text object only.

Edit properties

To edit the text properties of a particular object—and no other:

  - Right click on the text and select Text Properties….

This displays the following dialog:

![Text Properties Dialog](image)

Most of the properties on display will be familiar from the Edit Text Styles dialog. You also have a Reset to Style button allowing you to apply a style to the object from a drop-down list.

See also

- Text editing
- Header/Footer
- Behavior of applied text and lines
Staff and system text

For general-purpose text, use Staff Text or System Text. The difference between these two types of text is whether you want it to apply to a single staff, or the whole system. This matters when extracting parts: staff text will only appear in a part that contains the specific instrument the text is attached to, while system text will appear in all parts. Additionally, if you choose to hide empty staves, any staff text belonging to an empty staff will also be hidden. System text is never hidden by the "hide empty staves" feature.

Staff text

Staff text is general purpose text associated with a particular staff at a particular location in the score. To create staff text, choose a location by selecting a note or rest and then use the menu option Add → Text → Staff Text, or use the shortcut Ctrl+T (Mac: ⌘+T). A small text box appears and you can immediately start typing. You can exit the text box at any time (even without typing anything) by pressing Esc.

Staff text can, for example, be used to apply indications such as "Solo" or "Pizzicato" to one staff in a score. Depending on what the instructions of the staff text are, MIDI playback of that staff at the text location can be altered to match the instructions by right-clicking on the staff text and selecting Staff Text Properties… See Mid-staff sound change.

System text

System text is used when you wish to apply text indications to a whole system rather than just to one staff line. This makes a difference when extracting parts, or if you choose to hide empty staves. To create system text, choose a location by selecting a note or rest and then use the menu option Add → Text → System Text, or use the shortcut Ctrl+Shift+T (Mac: ⌘+Shift+T). A small text box appears and you can immediately start typing. You can exit the text box at any time (even without typing anything) by pressing Esc.

See also

- Mid-staff sound change

External links

- How to change instrument sound (e.g. pizz., con sordino) midway through score

Chord symbols

Chord symbols are an abbreviated way of representing musical chords (see Chord names and symbols (Wikipedia) for further details). For example:

```
FMaj7  (B7#11)  B♭  F♯/A  Gm
```

Enter a chord symbol

1. Select a note or a slash;
2. Press Ctrl+K (Mac: ⌘+K).

The cursor is now positioned above the score ready for input. Enter the chord symbol just like normal text, as follows:

- Root note: A, B, C, D, E, F, G.
- Sharp: # (hash symbol).
- Flat: b (small letter "b").
- Double sharp: x (small letter "x") or ## (two hash symbols).
- Double flat: bb (small letter "b" twice).
- Natural: natural (no space before "natural").
- For other symbols, see Chord symbol syntax (below).

When you exit the chord symbol, the characters you have typed will automatically assume the correct format: by default a root note typed in lower case will turn into upper case (for alternative options, see Automatic Capitalization); a "#" or "b" will turn into a proper sharp (♯) or flat (♭) and so on. Do not try to use actual flat and sharp signs as MuseScore will not
After you have finished entering a chord symbol you can either:

- Move the cursor forward or backwards to continue entering or editing chord symbols (see commands below).
- Exit chord symbol mode by pressing Esc.

**Note:** To fill measures with slashes, see Fill with slashes or Toggle rhythmic slash notation.

### Keyboard Commands

The following commands are available during chord symbol entry:

- **Space** move Cursor to next note, rest, or beat
- **Shift+Space** move cursor to previous note, rest, or beat
- **Ctrl+Space** (Mac: ⌘+Space) add a space to the chord name
- **:** move cursor to next beat
- **:** move cursor to previous beat
- **Tab** move cursor to next measure
- **Shift+Tab** move cursor to previous measure
- **Ctrl plus number (1 - 9)** move Cursor by duration corresponding to number (e.g.; half note for 6)
- **Esc** exit.

### Chord symbol syntax

MuseScore understands most of the abbreviations used in chord symbols:

- **Major:** M, Ma, Maj, ma, maj, Δ (type t or ˆ for the triangle)
- **Minor:** m, mi, min, -
- **Diminished:** dim, ° (entered with lowercase letter o, shows as ° if using the Jazz style, as o otherwise)
- **Half-diminished:** ø (type ø, zero). Alternatively, you can, of course, chose abbreviations such as mi7b5 etc.
- **Augmented:** aug, +
- The following abbreviations are also valid: extensions and alterations like b9 or #5, sus, alt, and no3; inversions and slash chords, such as C7/E; commas; parentheses, which can enclose part, or even all, of a chord symbol.

### Edit a chord symbol

An existing chord symbol can be edited in a similar way to ordinary text: See Text editing.

### Transpose chord symbols

Chord symbols are automatically transposed by default if you apply the menu Transpose command to the containing measures. If this is not required, you can untick the “Transpose chord symbols” option in the same dialog.

### Chord symbol text

To adjust the appearance of all chord symbol text, use any of the following options:

- From the main menu, choose Style → Text... → Chord Symbol
- Right click on any chord symbol and select Text Style...

This displays the Edit Text Styles dialog, allowing you to make changes to any text property.

### Chord symbol style

Formatting options for chord symbols are available in Style → General... → Chord Symbols, Fretboard Diagrams. Adjustable properties are listed under the following headings:

#### Appearance

Three options are possible: **Standard** and **Jazz** and **Custom**. You can select between these using the radio buttons.

- In the **Standard** style, chords are rendered simply, with the font determined by your chord symbol text style.
In the Jazz style, the MuseJazz font is used for a handwritten look, with distinctive superscript and other formatting characteristics. The Jazz style is selected by default if you use any of the Jazz templates.

The Custom style option allows you to customise the look of chord symbols (and also ensures compatibility with older scores). Select a customised Chord symbols style file in the field below: this can be created by copying and modifying one of the pre-existing files in the “styles” folder. Documentation can be found in the same folder. Note, however, that this is for advanced users only, and there is no guarantee these files will be supported in the future.

Note spelling

By default, MuseScore uses letter names for chord symbols. For users in regions where other note naming schemes are used, MuseScore provides the following controls:

- **Standard**: A, B♭, B, C, C♯, ...
- **German**: A, B♭, H, C, C♯, ...
- **Full German**: A, B, H, C, Cis, ...
- **Solfeggio**: Do, Do♯, Re♭, Re, ...
- **French**: Do, Do♯, Ré♭, Ré, ...

Automatic Capitalization

By default, MuseScore automatically capitalizes all note names on exit, regardless of whether you entered them in upper or lower case. However, you can also choose other automatic capitalization options:

- **Lower case minor chords**: c, cm, cm7, ...
- **Lower case bass notes**: C/e, ...
- **All caps note names**: DO, RE, MI, ...

You can also turn off the automatic capitalization completely, in which case note names are simply rendered the way you type them.

Positioning

- **Default vertical position**: The height at which the chord symbol is applied above the staff (negative values can be used)
- **Distance to fretboard diagram**: If a fretboard diagram is present, this value is the height at which the chord symbol is applied above the diagram (negative values can be used).
- **Minimum chord spacing**: The space to leave between chord symbols.
- **Maximum barline distance**: Changes the size of the gap between the last chord symbol in the measure and the following barline. You only need to adjust this value if there is a continuous problem in the score with overlap between the last symbol in one measure and the first symbol in the next.

**Note**: In addition to the settings described here, the default position of applied chord symbols is also determined by settings in the Text Styles dialog. The effect is cumulative.

**Capo**

Enter the number of the capo position at which you want to display substitute chords, in brackets, after all chord symbols in the score.

**Fingering**

Fingering symbols for various instruments are found in the Fingering palette in the Advanced workspace.
Keyboard music employs the numbers 1–5 to represent fingers of the left or right hand. There is also fingering positioner plugin to help you optimize the layout of piano or keyboard fingerings.

Guitar music uses the numbers 0–4 to represent left-hand fingering (T is occasionally used for the thumb). Right-hand fingering is indicated by the letters p, i, m, a, c. Circled numbers represent instrument strings.

The last five symbols in the palette are used for lute fingering in historical music. Note: To enable display of fingering in tablature, right-click on the TAB, select Staff Properties → Advanced style properties, and tick “Show Fingerings”.

Add fingering to a single note

Use any of the following methods:

- Select a note and double click one of the fingering symbols in a Palette.
- Drag and drop a fingering symbol from a palette onto a note.

When fingering is added to a note, the focus immediately shifts to the symbol, so you can adjust it right away.

Add fingering to several notes

1. Select the desired notes;
2. Double-click a fingering symbol in a palette.

Adjust position of fingering

Single fingering

To change the position of one symbol, use any of the following methods:

- For fine adjustments (0.1 sp) use the arrow keys; For larger adjustments (1 sp) use Ctrl+Arrow.
- Change horizontal and vertical offsets in the Inspector.
- Drag the symbol using your mouse.

Multiple fingering

To change the position of multiple symbols:

1. Select the desired fingering symbols;
2. Adjust using the horizontal and vertical offset fields in the Inspector.

Note: You can also use the fingering positioner plugin mentioned above to optimize the layout of piano fingerings.

To restore a symbol to its default position, select it and press Ctrl+R.

Edit fingering text

Fingering is a form of text symbol and can be edited and styled like any other. Right-clicking on the symbol gives you a range of options.

Lyrics

Enter a lyrics line

First line
1. Enter the notes of the melody line;
2. Select the note where you want to start entering lyrics;
3. To enter **lyrics mode**, type Ctrl+L (Mac: ⌘+L); or from the main menu, select Add → Text → Lyrics;
4. Type a syllable;
5. Use the following options to continue entering lyrics:
   - **Go to the next syllable**: Press Space (or Ctrl+→) at the end of a syllable.
   - **Hyphen** (to connect syllables): Press - at the end of a syllable.
   - **Go to the previous syllable**: Press Shift+Space (or Ctrl+←).
   - **Move left**: Press ← (left arrow). If the cursor is at the beginning of a syllable, it will jump to the previous one.
   - **Move right**: Press → (right arrow). If the cursor is at the end of a syllable, it will jump to the next one.
   - **Move to the syllable below**: Press ↓ (down arrow).
   - **Move to the syllable above**: Press ↑ (up arrow).
   - **Start new lyrics line**: Press ↵ (Return) at the end of an existing lyrics syllable *(Note: Don’t use the Enter key from the numeric keypad!)*.
6. To exit **lyrics mode**, press Esc.

**Subsequent lines**

If you want to add another lyrics line to an existing one (e.g. a 2nd or 3rd verse etc.):

1. Chose one of the following options:
   - Select the note where you want to start the new lyrics line. Enter **lyrics mode** as shown in step 3 *(above)*. The cursor moves to a new (blank) line.
   - Enter **text edit mode** on an existing syllable, go to the end of the syllable and press ↵ (Return). The cursor moves to the next line.
2. Continue entering lyrics from step 4 *(above)*.

**Example:**

```
A - des - te, fi - del - cs,
Can - tet nunc hym - nos
Er - go qui na - tus
```

**Special characters**

In most cases, lyrics can be *edited* just like normal text. However, special keyboard shortcuts are required to enter the following characters:

- **Character space**: Ctrl+Space (Mac: ⌘+Space).
- **- (hyphen)**: Ctrl+- (Mac: ⌘+-) or AltGr+-.
- **Line feed**: Ctrl+↵ (Mac: ⌘+Return) or Enter (from the numeric keypad).

**Melisma**

A **melisma** is a syllable or word that extends over two or more notes. It is indicated by an underline extending from the base of a syllable to the last note of the melisma. The underline is created by positioning the cursor at the end of a syllable and pressing Shift+-; once for each note in the melisma. See the image below:
The above lyric was created in the following manner:

1. Type the letters, soul.
2. At the end of the word, press Shift+_
3. Type the letters To, then press Esc.

For non-last syllables to extend, just use additional dashes-, usually only one of them will show (more when the distance between the syllables is large enough), and the syllable will right-align to the first note, similar to last syllables that got notated with a melisma, see above.

Elision (Lyric) slur / Synalepha

Two syllables under a note can be joined with an elision slur, also known as a "lyric slur" or "synalepha". For example:

To create the example lyric text, starting with the syllable text "te":

1. Type te;
2. Click on the keyboard icon , or press F2 to open the Special Characters palette;
3. Use one of the following options:
   - Double-click one of the three elision slurs in the "Common Symbols" tab: "Narrow elision", "Elision", or "Wide elision" (these can be found between the "C Clef" and the "p" dynamic—see image below):
Double-click the elision slur found after the 7/8 fraction in the "Common Symbols" tab (next to last character in the image above). Depending on the font, add one or more spaces before/after the slur using Ctrl+Space (Mac: ⌘+Space).

**Note:** Not all fonts include the "undertie" character (U+203F "undertie", present in "Special Characters" mainly for compatibility with MuseScore 1.x scores). To find out which fonts on your computer support it, see "fontlist“ (look for any font that shows a tie between "te" and "A" instead of a blank rectangle).

4. Type A.

**Edit Lyrics**

1. Enter text edit mode on an existing syllable;
2. Use standard text editing commands to make changes;
3. Continue entering lyrics (see above); or exit lyrics mode by pressing Esc.

**Adjust position of lyrics**

The top and bottom margins and the line height of all lyric lines can be set globally:

1. From the menu, select Style → General... → Page;
2. Adjust the properties marked "Lyrics top margin," "Lyrics bottom margin" and "Lyrics line height" (see General: Page: Lyrics Margins).

To adjust the position of a particular lyrics line:

1. Select the lyrics line: i.e. right click on a word in the line, and (from the menu) chooseSelect → More...; then check the relevant options, which should include "Same system";
2. Adjust the Horizontal and Vertical offsets in the Inspector.

**Copy lyrics to clipboard**

To copy all lyrics to the clipboard (as of version 2.0.3):

- From the menu bar, select Edit → Tools → Copy Lyrics to Clipboard.

**Paste lyrics from clipboard**

To copy and paste lyrics from a text file (say) into a score:

1. Enter the notes in the score to which the lyrics will be attached.
2. Set up your lyrics in a text file, with appropriate spaces, hyphens, line-breaks etc.
3. Copy the lyrics from the text-file into the clipboard.
4. Select the start note in MuseScore, and press Ctrl+L (Mac: Cmd+L) (step 3 under Enter lyrics in a score).
5. Repeatedly applying paste will enter successive words of the lyrics. You may need to enter melismas and make other corrections as you go along.

See also
- Text
- Chord symbol

External links
- How to insert Lyrics
- How to move lyrics
- How to copy lyrics, or lyrics with rhythm
- How to add a block of text to a score
- Video tutorial: MuseScore in Minutes: Lesson 6 - Text, Lyrics and Chords

Rehearsal marks

Rehearsal marks can be used in a number of ways:
- To identify specific points in a score to facilitate rehearsing.
- As bookmarks in the score to which you can instantly navigate—using the Find/Search command.
- To mark the various sections in the score.

Typically, rehearsal marks consist of one or more letters and/or numbers, and appear in sequence in the score—e.g. A, B, C..., or 1, 2, 3... etc. Alternatively, they may display measure numbers (usually larger than standard measure numbers, boldface and/or enclosed in boxes). Multi-measure rests are automatically broken before and after rehearsal marks.

Rehearsal marks can be added to the score (i) automatically—which ensures that they are named in sequence—or (ii) manually, allowing you to name them as you wish.

Add a rehearsal mark

Manual Placement

To create a rehearsal mark manually:

1. Click on a note (or rest) at the desired location;
2. Select one of the following options:
   - Press Ctrl+M (Mac: Cmd+M);
   - From the menu, chose Add → Text → Rehearsal Mark;
3. Enter the desired text.

Automatic placement

Add an alphanumeric rehearsal mark

Use either of the following options:
- Click on a note (or rest) at the desired location, then double-click the [B1] rehearsal mark icon in the “Text” palette.
- Drag and drop the rehearsal mark from the “Text” palette onto the score.

Notes: (1) By default, marks are added in the sequence, A, B, C etc. (2) To change the format of subsequently-added marks (to lower case letters, or numbers), edit the previous rehearsal mark accordingly. (3) Marks added between existing rehearsal marks append a number or letter to the previous mark: it is a good idea to apply the Resequence command afterwards (see below).

Add a measure-number rehearsal mark

1. Add the first rehearsal mark in the series as an alphabetical one; then edit it to read the same as the number of the
2. Add subsequent marks as shown above. They will automatically adopt the measure-number format.

Automatically resequence rehearsal marks

MuseScore allows the user to automatically re-order a series of rehearsal marks if they have got out of sequence for any reason. Use the following method:

1. Before making a selection, you can, if desired, establish a new format for the rehearsal marks (lower/upper case, number, or measure number) by manually altering the first mark in the range accordingly.
2. Select the range of measures you wish to apply the Resequence command to (if there is no selection then the program assumes you wish to resequence all measures).
3. From the menu, select Edit → Tools → Resequence Rehearsal Marks.

MuseScore automatically detects the sequence based on the first rehearsal mark in the selection—all rehearsal marks in the selection are then altered accordingly. The following sequences are possible:

- A, B, C etc.
- a, b, c etc.
- Numerical: 1, 2, 3 etc.
- Numerical: according to measure numbers. This requires the number of the first mark in the series to be equal to the number of the measure it is attached to.

Text style

Rehearsal marks are a variety of system text, appearing both on the score and on every part. By default, they are in a large bold font, and enclosed in frames with rounded corners. All aspects of their appearance can be changed globally via the rehearsal mark Text style.

Search for a rehearsal mark

See Find (Viewing and navigation).

See also

- Text properties

External links

- Rehearsal Letter (Wikipedia article)

Formatting

Layout and formatting

Layout and formatting options for the score can be accessed mainly from the Layout and Style menus.

Ways to affect layout

This section lists the main commands and dialogs affecting score layout. Other formatting options are covered in either Layout menu or Style menu below (for text, see Text styles and properties).

From the Layout menu:

- Page Settings: Adjust the overall dimensions of your score such as page size, page margins, and scaling.
- Increase Stretch/Decrease Stretch: Adjust the score spacing by stretching or squashing selected measures.

From the Style menu:

- Score Style: Set overall score details, such as music font, display of multi-measure rests, and whether to hide empty staves.
- Page Style: Adjust staff and system spacing, score and lyric margins etc.
• **Measure Style**: Set the measure spacing, which affects the number of measures per line.

• **Sizes**: Set the default size of “small” and grace notes, small staves and small clefs.

Other commands:

• **Add/Remove line breaks**: Set the number of measures per system.

• **Breaks and spacers**: Apply line, page or section breaks. You can also add extra space between particular systems or staves where needed.

**Layout menu**

**Page Settings...**

See [Page settings](#).

**Reset**

The **Reset** command restores all selected score elements to their default position. It also restores the default directions of note stems and beams. To apply:

1. **Select** the elements or the region of the score that you wish to reset. Or use Ctrl+A to select the whole score.
2. **Press** Ctrl+R; or from the menu select Layout → Reset.

**Increase Stretch/Decrease Stretch**

![Image](image.png)

Increase or decrease the horizontal spacing of notes within selected measures. To apply:

1. **Select** a range of measures. Or use Ctrl+A to select the whole score.
2. Chose one of two options:
   - **To increase stretch**:
     - Use the shortcut } (right curly bracket) (Mac: Ctrl+Alt+9);
     - Or from the menu bar, select Layout → Increase Stretch;
   - **To decrease stretch**:
     - Use the shortcut { (left curly bracket) (Mac: Ctrl+Alt+8);
     - Or from the menu bar, select Layout → Decrease Stretch.

See also [Measure Properties: Layout stretch](#). This allows you to set the stretch more precisely.

**Reset Stretch**

To reset stretch to the default spacing of 1:

1. **Select** a range of measures. Or use Ctrl+A to select the whole score.
2. From the menu, select Layout → Reset Stretch.

**Reset Beam Mode**

To restore beams to the mode defined in the local time signatures:

1. **Select** the section of the score you want to reset. If nothing is selected, the operation will apply to the whole score;
2. **Select** Layout → Reset Beam Mode.
See also Beams.

Regroup Rhythms

As of version 2.1, this option corrects note ties, durations and beaming so that they are grouped according to standard music notation practice. For example:

Before:

After:

Any notes that are tied and are the same length as a dotted note will be changed to the dotted note with two limitations. (i) Only the last note of a group of tied notes will have a single dot. Notes with more than one dot are not produced using this option. (ii) Dotted notes will not span from one group of beamed notes to another unless their duration is the same as all of the beam groups it covers. Any notes with more than one dot will be regrouped according to the above rules.

To apply:

1. Select the section of the score you want to reset. If nothing is selected, the operation will apply to the whole score;
2. Select Layout → Regroup Rhythms.

Note: This is an experimental feature and there are known bugs. Articulations and ornaments are deleted and some pitches respelt. Ties across barlines may be lost on UNDO.

Style menu

General: Score

To open the Score dialog: from the menu, select Style → General... → Score.
This dialog allows you to set global properties, such as the music font, display of multimeasure rests, whether or not to hide empty staves, "swing" playback etc.

- **Musical symbols font**: Choice of display in Emmentaler, Bravura or Gonville fonts.
- **Musical text font**: Choice of display in Emmentaler, Bravura, Gonville or MuseJazz fonts.
- **Display in concert pitch**: Tick this option to display the score at concert pitch. If unticked the score is displayed at written pitch.
- **Create multimeasure rests**: Tick to display multimeasure rests.
  - **Minimum number of empty measures**: The default is 2.
  - **Minimum width of measure**: The default width is 4 sp.
- **Hide empty staves**: This option saves space by hiding those staves in a system which consist of only empty measures. Used for condensed scores.
- **Don't hide empty staves in first system**: Always display staves in first system even if they consist of empty measures.
- **Display note values across measure bar**: A feature useful for notating early music. See Unbarred notation.
- **Hide instrument name if there is only one instrument**: You don’t usually need to display the instrument name in this case.
- **Swing setting**: The default is off. Choice of swung eighth or sixteenth notes.
  - **Select swing ratio**: The default setting is 60%.

See also, Swing

**General**: Page

To open the **Page** dialog: from the menu, select Style → General... → Page.
This dialog allows you to adjust the space above and below systems, staves, lyrics, and vertical frames; and between the score and the top/bottom page margins. You can also control the display of key signatures, time signatures and clefs.
Distance to page margins

- **Music top margin**: The distance between the top staff line of the first staff on the page and the top page margin.
- **Music bottom margin**: The distance between the bottom staff line of the last staff on the page and the bottom page margin.

Distance between staves

- **Staff distance**: The space between staves which are not part of a grand staff (see below).
- **Grand staff distance**: The space between staves that share the same instrument—such as the piano, organ, or those of a guitar staff/tab pair.

*Note*: To alter the space above one particular staff see Extra distance above staff (Staff properties).

Distance between systems

- **Min. system distance**: The minimum distance allowed between one system and the next.
- **Max. system distance**: The maximum distance allowed between one system and the next.

Lyrics Margins

- **Lyrics top margin**: The height of the margin above the top lyrics line (in a system).
- **Lyrics bottom margin**: The height of the margin underneath the bottom lyrics line (in a system).
- **Lyrics line height**: The distance between lyrics line (in a system), expressed as a percentage of the line height associated with the lyrics text style.

Vertical frame margins

- **Vertical frame top margin**: The default margin height above a vertical frame.
- **Vertical frame bottom margin**: The default margin height below a vertical frame.

Last system fill threshold

- If the last system is longer than this percentage of the page width, it gets stretched to fill that width.

Clefs and key signatures

- **Create clef for all systems**: Untick this box to prevent a clef from automatically displaying at the start of any system except the first.
- **Create key signature for all systems**: Untick this box to prevent a key signature from automatically displaying at
the start of any system except the first.

Ticking the following boxes, allows the display of courtesy elements at the end of systems:

- Create courtesy time signatures:
- Create courtesy key signatures
- Create courtesy clefs

General: Header, Footer, Numbers

Open from the menu: Style → General... → Header, Footer, Numbers.
You can show the content of a score’s meta tags (see Score information) or show page numbers in a header or footer for your score. To create a header or footer for a score with linked parts, make sure the main score is in the active tab. To create a header or footer for an individual part, that part needs to be the active tab.

If you hover with your mouse over the Header or Footer text region, a list of macros will appear, showing their meaning, as well as the existing meta tags and their content.

You can create different Headers and Footers for even and odd pages, such as putting page numbers on the right for odd-numbered pages and on the left for even-numbered pages.

You can also edit whether and how often measure numbers appear.

**General: System**

Open from the menu: Style → General... → System.
This dialog allows you to:

- Set the **distance** between system brackets or braces and the start barlines.
- Set the **width** of system brackets and braces.

See also **Brackets**.

**General: Measure**
See **General style: Measure**.

**General: Barlines**

Open from the menu: **Style → General... → Barlines.**

- Control whether to show barlines at the beginning of a staff or multiple staves.
- **Scale barlines to staff size** affects “small” staves only. See [Barline adjustment possibilities](#) (external link) for
- Control proportion of thickness and distance within double barlines, including repeat barlines.

**General: Notes**

Open from the menu: Style → General... → Notes.

This page can also be accessed direct from the score by right-clicking on any note and selecting "Style..." Here you can adjust the distance and thickness of note-related objects (stems, ledger lines, dots, accidentals). Changing these would be unusual.
General: Clefs

Open from the menu: Style → General... → Clefs.

You can choose between Serif and Standard clef for your tablature sheet.

General: Arpeggios

Open from the menu: Style → General... → Arpeggios.
Here you can change the thickness, spacing and hook height of the following arpeggio and strum symbols:

```
\|/|/\|/
```

Changes to these properties would be unusual.

**General: Beams**

Open from the menu: Style → General... → Beams.
General: Slurs/Ties

Open from the menu: Style → General... → Slurs/Ties.
General: Sizes

Open from the menu: Style → General... → Sizes.
Sets the proportional size of “small” and grace notes, as well as small staves and clefs. Changing this would be unusual.

**General:** Hairpins, Volta, Ottawa

Open from the menu: **Style** → **General...** → **Hairpins, Volta, Ottawa.**
The button returns the setting to the original value.

**General:** Pedal, Trill

Open from the menu: Style → General... → Pedal, Trill.
General: Chord Symbols, Fretboard Diagrams

Open from the menu: Style → General... → Chord Symbols, Fretboard Diagrams.
This section allows you to adjust the format and positioning of chord symbols and fretboard diagrams.

**Appearance**: Chose a default chord symbol style—Standard, Jazz or Custom.

**Note Spelling**: Chose the spelling convention for chord symbols and whether to use capital or small letters.

**Positioning**:
- **Default vertical position**: The default vertical distance in space units (sp.) between a newly-applied chord symbol
and the music staff. Negative values may be used.

- **Distance to fretboard diagram:** The distance (in sp. units) from a chord symbol to a fretboard diagram when both are applied to the same location on a staff. This value overrides the above “Default vertical position” setting. The user can choose to place a chord symbol below a fretboard diagram by entering a negative value.

- **Minimum chord spacing:** The minimum space to allow between chord symbols.

- **Maximum barline distance:** Increases the distance between the final chord symbol in a measure and the following barline. You may wish to adjust this value if there is a recurring problem in the score with overlap between the final chord symbol in one measure and the following chord symbol.

**Capo:** Enter the number of the capo position at which you want to display substitute chords, in brackets, for all chord symbols in the score.

**Fretboard diagrams:**

- **Default vertical position:** the distance in sp. units from a newly applied fretboard diagram to a staff. A negative value may be used.

- **Scale:** Increase or decrease the size of the fretboard diagram in the score.

- **Fret offset number font size:** Increase or decrease the size of a fret number displayed next to a diagram.

- **Position Left/Right:** Display fret number to the left or right of the fretboard diagram.

- **Barre line thickness:** Make barre lines in fretboard diagrams thicker or thinner.

**General: Figured Bass**

Open from the menu: Style → General... → Figured Bass.
Options about figured bass font, style and alignment.
See also Figured bass

General: Articulations, Ornaments

Open from the menu: Style → General... → Articulations, Ornaments.
Position of articulation with respect to the notes and staves

**General: Accidentals**

Open from the menu: Style → General... → Accidentals.
Options about naturals at key signature changes

**General: Tuplets**

Open from the menu: Style → General... → Tuplets.
Apply and OK buttons

By pressing the Apply button you can see how the changes you have made in the dialogs affect the score without closing the window. Press OK to save your changes to the score and close the window.

Apply to all parts in one go

When in a part tab while changing layout and formatting, you can use the Apply to all Parts button to apply all changes (either in Layout → Page Settings… or Style → General…) to apply the new settings to all parts in just one click.

Save/Load style

It is easy to transfer a complete set of styles (all General Style settings, all text styles, and page settings) from one score to the other using the Save/Load Style functions.

To save a customized style:

1. Go to Style → Save Style…
2. Name and save the style file (the default folder is set in your Preferences). Styles are stored as *.mss files.

Note: You can also define a preferred style for scores and parts in the Score section of MuseScore’s Preferences.

To load a customized style:

1. Go to Style → Load Style…
2. Navigate to and select the Style file (.mss) and click Open (or double click on the file).

All existing styles in the score should update automatically.

See also

- To edit spacing between notes
- Upgrading from MuseScore 1.x, local relayout

External links

- Tutorial – How to create large-print stave notation (MSN)
General style: Measure

If you change a measure style property (see image above), MuseScore automatically adjusts the score to maintain the correct spacing between notes and rests according to best music engraving practice. It will also correctly reposition any elements attached to notes or rests, such as fingerings, dynamics, lines etc.

All settings related to measure width and note spacing are minimum values. Measures are automatically stretched, if
necessary, to maintain existing page margins.

All the properties listed below use the staff space (abbreviated to "sp") as the basic unit of measurement. See Page settings: Scaling for more details.

Options

- **Minimum measure width**
  Sets the minimum horizontal length of measures. In measures containing very little content (e.g., a single whole note or whole measure rest), the measure will only shrink as far as this minimum.

- **Spacing (1=tight)**
  Condenses or expands the space after notes or rests. This setting thus affects not only space between notes but also between the last note and the ending barline. For the space between the beginning of the measure and the first note or rest, see Barline to note distance (below).

  **Note:** Changes to an individual measure’s Stretch (under Layout → Increase Stretch, Decrease Stretch) are calculated after, and proportional to, the global Spacing setting.

- **Barline to note distance**
  Sets the distance between the barline which begins a measure and the first note or rest in that measure. For the initial measures of systems, which start with clefs instead of barlines, use Clef/key right margin (below).

- **Barline to grace note distance**
  Sets the distance between a barline and a grace note that occurs before the first actual note in a measure (independently of the "Barline to note distance" setting).

- **Barline to accidental distance**
  Sets the distance between a barline and an accidental placed before the first note in a measure (independently of the "Barline to note distance" setting).

- **Note to barline distance**
  (To be added).

- **Minimum note distance**
  Specifies the smallest amount of space MuseScore will allow after each note (depending on other factors, more space may be allowed).

- **Clef left margin**
  Sets the distance between the very beginning of each line and the clef. (This option is rarely needed.)

- **Key signature left margin**
  Sets the distance between the key signature and the clef preceding it.

- **Time signature left margin**
  Sets the distance between the time signature and the key signature or clef preceding it.

- **Clef/key right margin**
  Sets the distance between the material at the beginning of each line (such as the clef and key signature) and the first note or rest of the first measure on the line. (Note that, although not named in the option, if a time signature is present, it is the element from which the spacing begins.)

- **Clef to barline distance**
  Sets the distance between a barline and a clef change preceding it.

- **Multi-measure rest margin**
  Sets the distance between a multi-measure rest and the barlines on either side.

- **Staff line thickness**
  Sets the thickness of the lines of the staff, which allows you to make the staff thicker and darker, if you need greater visibility on your printouts.

Page settings

Page settings allows you to adjust the overall dimensions of your score such as page size, page margins, and scaling. It
is one of the main layout tools in MuseScore—along with the options available from Style → General...

To open the **Page settings** dialog: from the menu, select **Layout → Page Settings**.

**Page size**

Here you can select the paper format, either by standard name (e.g., Letter or A4), or by specifying the height and width in either mm or inches (use the radio buttons to choose which unit of measurement to use). The initial default page size depends on your localization—in the United States, Letter size paper is standard.

You can also choose to format your music in **Landscape** or **Portrait** orientation using the radio buttons. Prior to version 2.1 unchecking **Landscape** enabled **Portrait** format. You can optionally use **Two sided** layout (i.e., book format, with mirror left and right margins for even and odd pages—see below).

**Odd/Even Page Margins**

The **Even Page Margins** and **Odd Page Margins** settings allow you to define the printable area of your pages. Aside from changing the margins around the music on the page, other settings, such as the positions of headers and footers, are calculated relative to the margins defined here.

If the "Two sided" checkbox under "Page Size" is selected, you can set margins differently for mirroring odd and even pages. Otherwise, only one set of margins can be modified, but will apply to all pages.

To display page margins in your score on screen (though not in print), go to **View → Show Page Margins**.

**Scaling**

The **Scaling** property allows you to increase or decrease the size of your score.

In MuseScore, the sizes of score elements, such as note heads, note stems, accidentals, clefs etc., are defined in terms of a unit of measurement called a **staff space** (abbreviated to "sp"). One staff space is equal to the space between two lines of a music staff (or one-quarter the size of the full five-line staff).

As you change the "Staff space" setting (under **Scaling**), all score elements follow suit and thus correct proportions are maintained. The exception is **Text** in which you can set an *absolute* value, independent of "Scaling."

**Note:** Changing the "Scaling" does not always change the number of systems per page, because system distance can vary between limits set under "Min system distance" and "Max system distance" (see Style → General... → Page).

**Miscellaneous**
First page number

Sets the number of the first page of the particular score. Page numbers below 1 won't get printed—e.g., setting the first page number to -1 would result in the first and second page showing no page number, and page number 1 appearing on the third page.

Apply to all Parts

The Apply to all Parts button is available when modifying apart, rather than the main score (see Part extraction). If you change the page settings of one part and want the rest of the parts to have the same settings, this button will apply the change to all parts in one go.

Breaks and spacers

The Breaks & Spacers palette in the Advanced workspace contains the following non-printing symbols:

![Breaks & Spacers Palette](image)

The first three symbols are called breaks; the blue up and down arrows are known as spacers.

Breaks

A break can be applied to either a measure or a frame. There are three types:

- **System break** (called a line break prior to version 2.2): Forces the next part of the score to start in a new system.
- **Page break**: Forces the next part of the score to start on a new page.
- **Section break**: Divides the score into sections (see below), and forces the next part of the score to start in a new system. It can be combined with a page break if required.

Notes: (1) Blue break symbols are visible on the screen, but do not appear on printouts. (2) To add (or remove) system breaks over all or part of the score, see Add/Remove system breaks. (3) To split a measure, see Measure operations: Split and join.

Add a break to a measure

Breaks can be added using either (1) a keyboard shortcut; or (2) a break symbol from a palette.

Using a keyboard shortcut

To add a System (Line) break or a Page break only:

1. Click on any one of the following elements:
   - Barline;
   - Measure;
   - Measure range (as of version 2.2);
   - Notehead (as of version 2.2);
   - A text element associated with a staff (e.g. lyric syllable, chord symbol, staff text etc.) (as of version 2.2);
2. Chose one of the following options:
   - **System (Line) break**: Press + (toggle).
   - **Page break**: Press Ctrl + (Mac: Cmd + ) (toggle).

Note: If you select a measure range, the break will be applied before and after the selection.

Using a palette symbol

Any break can be added from a workspace palette:

1. Select any one of the following elements:
   - Barline;
   - Measure;
   - Measure range (as of version 2.2);
Notehead (as of version 2.2);
A text element associated with a staff (e.g. lyric syllable, chord symbol, staff text etc.) (as of version 2.2);
2. Double click a break symbol in a palette (toggle).

**Note:** If you select a measure range, the break will be applied before and after the selection.

- Alternatively, drag a break symbol from a palette onto a measure.

**Add a break to a frame**

To add a break to a frame, use one of the following options:

- Drag a break from a palette onto a frame.
- Select a frame then double-click a palette break symbol.

**Move a break**

To reposition a break:

1. Enter edit mode for the break in question;
2. Use the keyboard arrow buttons as described in Adjust position of text objects.

**Delete breaks**

Use one of the following options:

- Select one or more breaks and press Del.

See also: Add / Remove system breaks.

**Section break**

A **Section break**, as the name suggests, is used to create separate sections within a score. Like **system break**, it forces the next measure or frame to begin a new system, and can also be used in association with a **page break** if required. A section break could be used, for example, to divide a piece into separate movements.

Each section can have its own measure numbering independent of the rest of the score. By default, the first measure of a section is numbered “1” (see image below), though like the first measure of the score itself, the number is not displayed unless configured in the **measure properties** dialog. The same dialog can be used to change the numbering according to your preference.

If you change Time signature or Key signature at the beginning of the new section, there will be no courtesy signature at the end of the previous section. See example below:

![Image of a section break example](image)

When you play back the score, the program adds a short pause between each section. In addition, the first **end repeat barline** in a section always sends the playback cursor to the beginning of the section, so **start repeat barline** is optional.

Right click a Section break and select **Section Break Properties**... to specify:

- Pause length;
- If the new section's first system shows long instrument names;
- If the new section starts numbering measures at 1.

**Spacer**

A **Spacer** looks like a blue UP or DOWN arrow and is used to add extra space above or below a system (it cannot be applied to a frame).
Add a spacer

Use either of the following options:

- Select a measure, then double-click a palette spacer symbol.
- Drag a spacer symbol from a palette onto a measure.

Blue spacer symbols are visible on the screen, but do not appear on printouts.

**Note:** Spacers are designed for *local* adjustments only. If you wish to adjust the space between staves across the whole score, use the settings in **Style → General... → Page** instead.

Adjust a spacer

To adjust the height of a spacer, chose one of these options:

- Double-click the spacer and drag the blue end-handle up and down.
- Double-click the spacer and use the ↑ ↓ keys and/or Ctrl+↑ ↓ to move the end-handle up and down.
- Click (or double-click) on the spacer and adjust the height property in the Inspector.

Delete a spacer

- Click on the spacer and press the Del key.

See also

- Add / Remove system breaks

Frames

A **Frame** is a rectangular container for empty space, text or pictures in the score. It can be one of three types:

- **Horizontal**: Used to create a break in a particular system. Can contain one or more text objects and/or images.
- **Vertical**: Inserted above a system or appended to the last system. Can contain one or more text objects and/or images.
- **Text**: Inserted above a system or appended to the last system. Can contain one text object only.

**Horizontal frame**

A **horizontal frame** is used to create a break in a system. For example, you can:

- Create a coda, with an adjustable gap separating it from the rest of the score (as in the example below).

![Horizontal Frame Example](image)

- Create an offset at the beginning of the score, where there is no staff name to perform the same function.
- Create an adjustable right margin at the end of a system.
- Create space for some text or image(s).
- Create a space between a 'historical incipit' and the beginning of the modern edition.

**Insert/append horizontal frame**

See **Create a Frame** (below).

**Adjust width of horizontal frame**

Use one of the following methods:

- Double-click the frame and drag the handle to the right or left.
- Select the frame and adjust "Width" in the Inspector.
Notes: (1) "Left Gap" and "Right Gap" are currently unused (version 2.x); (2) It is possible to create a ‘Negative-width’ horizontal frame, by dragging the edit-handle back over the left border of the frame. However, this is not a standard feature and once editing is finished you cannot reselect the frame.

Add text or image to horizontal frame

To add text:

- Right-click on the frame and select Add → Text.

To add an image:

- Right-click on the frame and select Add → Image.

Vertical frame

A **vertical frame** can be inserted above a system or appended to the last system. It can contain one or more text objects and/or images. The height is adjustable and the width equals the system width.

It can be used, for example, to:

- Create an area at the head of a score for Title/Subtitle/Composer/Lyricist text etc. (see below).
- Add single- or multi-column lyric text (at the end of a score).
- Create a title page.
- Create subtitles and other annotations between systems.

Insert/append vertical frame

See **Create a Frame** (below).

Adjust height of vertical frame

Use one of the following methods:

- Double-click the frame and drag the handle up or down.
- Select the frame and adjust "Height" in the **Inspector**.

Edit vertical frame properties

Selecting the frame allows you to adjust various parameters in the **Inspector**:

![Inspector](image)

- **Top Gap**: Adjusts distance between frame and element above (negative values not currently supported).
- **Bottom Gap**: Adjusts distance between frame and element below (Negative values can be entered).
- **Height**: Adjusts height of the frame.
- **Left Margin**: Moves left-aligned text objects to the right.
- **Right Margin**: Moves right-aligned text objects to the left.
- **Top margin**: Moves top-aligned text objects downwards (see also **Style → General... → Page**).
- **Bottom Margin**: Moves bottom-aligned text objects upwards (see also **Style → General... → Page**).

Add text or image to vertical frame
To add text:

- Right-click on the frame and select Add → Text/Title/Subtitle/Composer/Lyricist.

To add an image:

- Right-click on the frame and select Add → Image.

You can create as many objects as you like within a frame. Their positions can be adjusted independently by dragging or, more accurately, by altering the offset values in the Inspector. To format text objects, see Text editing and Text styles and properties.

Insert horizontal frame in vertical frame

- Right-click on the frame and select Add → Insert Horizontal Frame.

The horizontal frame is automatically left-aligned and fills the entire vertical frame. To right-align it:

1. Reduce the width of the horizontal frame.
2. Deselect the frame then drag it to the right. To restore left-alignment, drag the frame to the left.

"Title" frame

A vertical frame is automatically created at the beginning of a score, showing the title, subtitle, composer, lyricist etc., when you fill in the information fields provided on page 1 of the New Score Wizard.

If the score does not have a vertical frame at the beginning, you can create one as follows:

- Right-click on an empty space in the document window and select Text → Title/Subtitle/Composer/Lyricist.

Text frame

A Text frame looks like a vertical frame, but is specialised for text input: one text object is allowed per frame. The height automatically expands to fit the content and there is no height adjustment handle.

A text frame can be used, for example, to:

- Create lyric text at the end of a score.
- Create subtitles and other annotations between systems.

Insert/ append text frame

See Create a Frame (below).

Edit text frame properties

Selecting the frame allows you to adjust various parameters in the Inspector:

**Top Gap:** Adjusts distance between frame and element above (negative values not currently supported).

**Bottom Gap:** Adjusts distance between frame and element below (negative values can be entered).

**Height:** Not applicable to text frames.

**Left Margin:** Moves left-aligned text objects to the right.

**Right Margin:** Moves right-aligned text objects to the left.

**Top margin:** Moves top-aligned text objects downwards.

**Bottom Margin:** Moves bottom-aligned text upwards.

Create a frame

Insert a frame into the score

1. **Select** a measure.
2. Chose one of the following options:
   - From the menu select Add → Frames → Insert...
   - Right-click on an empty space in the score window and select Frames → Insert...
Append a frame to the score

Chose one of the following options:

- From the menu select Add → Frames → Append...
- Right-click on an empty space in the score window and select Frames → Append...

Delete a frame

Select the frame and press Del.

Apply a break

Line, page or section breaks can be applied to frames as well as measures. Use one of two methods:

- Select a frame and double-click a palette break symbol (for example, in the Breaks & Spacers palette).
- Drag a break symbol from a palette onto a frame.

See also

- Text Properties: to put a visual frame (border) around text.
- Insert measures: to insert measures before a frame.

External links

- How to add a block of text to a score
- Page Formatting in MuseScore 1.1 - 1. Frames, Text & Line Breaks [video]

Images

You can use Images to illustrate scores, or to add symbols that are not included in the standard palettes. MuseScore supports the following formats:

- PNG (*.png)
- JPEG (*.jpg and *.jpeg)
- SVG (*.svg) (MuseScore currently does not support SVG shading, blurring, clipping or masking.)

Add image

Use one of the following options:

- Drag-and-drop an image file (from outside MuseScore) either into a frame or onto a note or rest in the score.
- Right-click on a frame, select Add → Picture, then pick an image from the file selector.

Cut/copy and paste image

1. Click on an image in the score.
2. Apply any of the standard copy/cut commands.
3. Click on a note, rest or frame.
4. Apply any of the standard paste commands.

Modify image

To modify the width/height of an image, double-click it and drag any of the handles. If you want to adjust width or height separately, untick "Lock aspect ratio" first in the Inspector.

You can adjust the position of an image by simply dragging it.

See also

- Image capture
- Custom palettes
MuseScore's **image capture** feature allows you to save a snapshot of any part of the score window. PNG, PDF and SVG formats are supported.

### Save a snapshot

1. Click on the **Toggle image capture** button, 📸.
2. Press Shift + drag, to create a new selection rectangle.
3. Fine tune the rectangle position, if required, by dragging it and/or changing the "Position" values in the "Lasso" section of the **Inspector**.
4. Fine tune the rectangle area, if required, by dragging the handles, and/or changing the "Size" values in the Inspector.
5. Right-click on the selection rectangle to open the **Image Capture** menu. Select the desired option:
   - **Save As (Print Mode)**. This saves an image of the selection area as it would look if printed, e.g.
     ![Image Capture example](image1.png)
   - **Save as (Screenshot Mode)**. This saves a selection of the actual screen, including any line break symbols, invisible elements etc., e.g.
     ![Image Capture example](image2.png)

You can save the image in either PNG (default), SVG or PDF format.

### Image capture menu

Right-clicking on the selection rectangle opens the **Image Capture** menu:
- **Copy image**: Chose this to copy an image before pasting it in the same or another MuseScore file.
- **Resolution**: Set the resolution, and hence the size of the saved or copied image. Try 100 dpi to start with, if you are unsure.
- **Transparent background**: Turn image transparency on or off.
- **Auto re-size to page**: Adjusts the selection rectangle to fit the page.
- **Resize to A/B/C/D**: Chose a customised selection rectangle (as set below).
- **Set Standard Size**: Resize the selection rectangle, then chose "Set size A/B/C/D" to store it.

See also

- Image

External links

- Create an ossia with image capture
- How to create an ossia with another staff

**Align elements**

While dragging an element:

- Press Ctrl to constrain movement to the horizontal only.
- Press Shift to constrain movement to the vertical only.

**Snap to grid**

Snap to grid is a feature which allows you to **drag** an element in precise steps—useful for exact positioning.

To enable snap to grid, select an element and click one or both of the snap to grid buttons, located to the right of the horizontal and vertical offset fields in the Inspector. You can then drag the element in steps equal to the **grid spacing**.

The default value is 0.5 sp.

To change the **grid spacing**:

1. Right-click on any of the snap to grid buttons in the Inspector, and select Configure Grid.
2. Set values for the horizontal and vertical grid spacing as required. Note that this is a fractional setting.

**Advanced topics**

**Accessibility**

**Introduction**

This document is written for blind and visually impaired users of MuseScore 2.x. It is not intended to provide a full description of all of the features of MuseScore; you should read this in conjunction with the regular MuseScore documentation.

MuseScore comes with support for the free and open source NVDA screen reader for Windows. The features in this document have been tested on Windows with NVDA. There is no support at the moment for other screen readers such as Jaws for Windows, or VoiceOver for macOS, which may work differently, or not at all.

At this point in time, MuseScore 2.x is mostly accessible as a score reader, not so much as a score editor. This document will focus on the score reading features, with only a brief description of score editing.

**Initial setup**

When you run MuseScore for the first time, you may want to permanently disable the Start Center window. To do so, go close the Start Center window first, then the Edit menu (Alt+E), choose Preferences, and in there, uncheck Show Start Center. Save and close the preferences window.
Finding your way around

The user interface in MuseScore works much like other notation programs, or other document-oriented programs in general. It has a single main document window in which you can work with a score. MuseScore supports multiple document tabs within this window. It also supports a split-screen view to let you work with two documents at once, and you can have multiple tabs in each window.

In addition to the score window, MuseScore has a menu bar that you can access via the shortcuts for the individual menus:

- File: Alt+F
- Edit: Alt+E
- View: Alt+V
- Add: Alt+A
- Notes: Alt+N
- Layout: Alt+L
- Style: Alt+S
- Plugins: Alt+P
- Help: Alt+H

Of these, only the File menu is of much interest when using MuseScore as a score reader. Once opening a menu, it may take several presses of the Up or Down keys before everything is read properly.

There are also a number of toolbars, palettes, and subwindows within MuseScore, and you can cycle through the controls in these using Tab (or Shift+Tab to move backwards through this same cycle). When you first start MuseScore, or load a score, focus should be in the main score window. Pressing Tab takes you to a toolbar containing a series of buttons for operations like New, Open, Play, and so forth. Tab will skip any buttons that aren’t currently active. The names and shortcuts (where applicable) for these buttons should be read by your screen reader.

Once you have cycled through the buttons on the toolbar, the next window Tab will visit is the Palette. This would be used to add various elements to a score, but it is not currently accessible except for two buttons that are visited by Tab: a drop down to select between different workspaces (a saved arrangement of palettes), and a button to create a new workspace.

If you have opened one of the optional windows, such as the Inspector, or the Selection Filter, the Tab key will also visit these. You can close windows you do not need by going to the View menu and making sure none of the first set of checkboxes are selected (the windows that appear before the Zoom settings). By default, only the Start Center, Palettes and Inspector should be selected. See Initial Setup for instructions for disabling the Start Center. F9 can be used to toggle the Palettes while F8 will toggle the Inspector.

To return focus to the score window after visiting the toolbar, or a subwindow, press Esc. This also clears any selection you may have made in the score window.

The score window

When you first start MuseScore 2.x, an empty example score entitled “My First Score” is loaded by default. If you wish to experiment with editing features, this would be a good place to begin. Otherwise, you will probably want to start by loading a score. MuseScore uses the standard shortcuts to access system commands like Ctrl+O (Mac: Cmd+O) to open a file, Ctrl+S (Mac: Cmd+S) to save, Ctrl+W (Mac: Cmd+W) to close, etc.

If you press Ctrl+O (Mac: Cmd+O) to load a score, you are presented with a fairly standard file dialog. MuseScore can open scores in its own format (MSCZ or MSCX) as well as import scores in the standard MusicXML format, in MIDI format, or from a few other programs such as Guitar Pro, Capella, and Band-in-a-Box. Once you have loaded a score, it is displayed in a new tab within the score window. You can move between the tabs in the score window using Ctrl+Tab (does not apply for Mac).

There are a few interesting things you can do with a loaded score besides reading it note by note. You can press Space to have MuseScore play the score for you. You can use File / Export to convert to another format, including PDF, PNG, WAV, MP3, MIDI, MusicXML, etc. And of course, you can print it via File / Print or Ctrl+P (Mac: Cmd+P).

If a score contains multiple instruments, it may already have linked parts generated. Linked parts are presented as part tabs within score tabs, but currently, there is no way to navigate these part tabs using the keyboard. The parts would not normally contain information different from the score; they would just be displayed differently (each part on its own page). If a score does not already have parts generated, you can do so through File / Parts, and that dialog is accessible. If you wish to print the parts, you can work around the inability of accessing part tabs individually by using the File / Export Parts dialog, which automatically exports PDF’s (or other formats) for all parts in one step.
Score reading

When you first load a score, the score window has the keyboard focus, but there will be nothing selected. The first step to reading a score is to select something, and the most natural place to begin is with the first element of the score. Ctrl+Home (Mac: Cmd+Home) will do this. You will probably also want to use this, should you ever clear your selection by pressing Esc.

As you navigate between elements, your screen reader should give the name of the selected element (most likely the clef at the beginning of the top staff of your score). You will hear it read the name of the element (for example, “Treble clef”) and also give position information (for example, “Measure 1; Beat 1; Staff 1”). The amount of information read is not currently customizable, but we tried to place the most important first so you can quickly move on to the next element before it has finished reading, or just ignore the rest of what is read. Pressing Shift currently interrupts the reading, which might also be useful.

Most navigation in MuseScore is centered around notes and rests only – it will skip clefs, key signatures, time signatures, barlines, and other elements. So if you just use the standard Right and Left keys to move through your score, you will only hear about notes and rests (and the elements attached to them). However, there are two special navigation commands that you will find useful to gain a more complete summarization of the score:

- Next element: Ctrl+Alt+Shift+Right (Mac: Cmd+Option+Shift+Right)
- Previous element: Ctrl+Alt+Shift+Left (Mac: Cmd+Option+Shift+Left)

These commands include clefs and other elements that the other navigation commands skip, and also navigate through all voices within the current staff, whereas other navigation commands such as Right and Left only navigate through the currently selected voice until you explicitly change voices. For instance, if you are on a quarter note on beat 1 of measure 1, and there are two voices in that measure, then pressing Right will move on to the next note of voice 1—which will be on beat 2—whereas pressing Ctrl+Alt+Shift+Right (Mac: Cmd+Option+Shift+Right) will stay on beat 1 but move to the note on voice 2. Only once you have moved through all notes on the current beat on the current staff will the shortcut move you on to the next beat. The intent is that this shortcut should be useful for navigating through a score if you don’t already know what the contents are.

When you navigate to an element, your screen reader should read information about it. For notes and rests, it will also read information about elements attached to them, such as lyrics, articulations, chord symbols, etc. For the time being, there is no way to navigate directly to these elements.

One important note: Up and Down by themselves, with Shift, or with Ctrl / Cmd are not useful shortcuts for navigation! Instead, they change the pitch of the currently selected note or notes. Be careful not to inadvertently edit a score you are trying to read. Up and Down should only be used with Alt/Option if your intent is navigation only. See the list of navigation shortcuts below.

Moving forwards or backwards in time

The following shortcuts are useful for moving “horizontally” through a score:

- Next element: Ctrl+Alt+Shift+Right
- Previous element: Ctrl+Alt+Shift+Left
- Next chord or rest: Right
- Previous chord or rest: Left
- Next measure: Ctrl+Right
- Previous measure: Ctrl+Left
- Go to measure: Ctrl+F
- First element: Ctrl+Home
- Last element: Ctrl+End

Moving between notes at a given point in time

- The following shortcuts are useful for moving “vertically” through a score:

- Next element: Ctrl+Alt+Shift+Right
- Previous element: Ctrl+Alt+Shift+Left
- Next higher note in voice, previous voice, or staff above: Alt+Up
- Next lower note in voice, next voice, or staff below: Alt+Down
- Top note in chord: Ctrl+Alt+Up
- Bottom note in chord: Ctrl+Alt+Down
The Alt+Up and Alt+Down commands are similar to the Ctrl+Alt+Shift+Right and Ctrl+Alt+Shift+Left commands in that they are designed to help you discover the content of a score. You do not need to know how many notes are in a chord, how many voices are in a staff, or how many staves are in a score in order to move vertically through the score using these commands.

Filtering score reading

Excluding certain elements like lyrics, or chord names while reading the score is possible by using the Selection filter. Uncheck those elements you don't want to read.

Score playback

The Space bar serves both to start and stop playback. Playback will start with the currently selected note if one is selected; where playback was last stopped if no note is selected; or at the beginning of the score on first playback.

MuseScore supports looped playback so you can repeat a section of a piece for practice purposes. To set the “in” and “out” points for the loop playback via the Play Panel (F11):

1. First select the note in the score window where the loop should start
2. Go to the Play Panel and press the Set loop In position toggle button
3. Back to the score window, navigate to the note where you want the loop to end
4. Switch again to Play Panel, and press the Set loop Out position toggle button
5. To enable or disable the loop, press the Loop Playback toggle button

You can also control the loop playback and control other playback parameters, such as overriding the basic tempo of a score, using the View / Play Panel (F11).

Score editing

Score editing is currently not very accessible – too many score elements require intervention of the mouse in order to place objects onto a score. Additionally, visual reference and manual adjustment of the position of various elements is sometimes necessary due to MuseScore's limited support for conflict avoidance of elements.

In contrast, MuseScore does often provide ample default, and a platform to experiment with the basics of note input. To enter note input mode, first navigate to the measure in which you would like to enter notes, then press “N”. Almost everything about note input is designed to be keyboard accessible, and the standard documentation should be good to help you through the process. Bear in mind that MuseScore can either be in note input or normal mode, and it won't always be clear which mode of these you are in. When in doubt, press Esc. If you were in note input mode, this will take you out. If you were in normal mode, you will stay there, although you will also lose your selection.

Customization

You can customize the keyboard shortcuts using Edit / Preferences / Shortcuts. At some point, we may provide a set of special accessibility-optimized shortcuts and/or a way of saving and loading sets of shortcut definitions.

External links

- Creating a New Score in MuseScore with NVDA
- Inputting notes in MuseScore with NVDA
- Creating Modified Stave Notation in MuseScore

Albums

The Album Manager allows you to prepare a list of multiple scores and save the list as an album file (*.album), print all the scores as one long print job with consistent page numbers, or even join the scores into a single new MSCZ score. This is ideal for preparing an exercise book or combining multiple movements of an orchestration.

To open the Album Manager, go to File → Album...
Create album

1. To create a new album, click the New button. Fill in a title in the "Album Name:" box at the top.
2. To add scores to the album, click Add Score. A file selection dialog will appear and let you choose one or multiple scores from your file system. Click OK.
3. The scores you add will appear in a list in the Album Manager. You can rearrange their order by selecting a score and clicking the Up or Down button.

Load album

If you have previously created an album, you can open it through the Album Manager by clicking the Load button. A file selection dialog will appear to let you load the .album file from your file system.

Print album

To print an album as if it were a single document, click Print Album. The scores loaded into the Album Manager are printed in the order they are listed in with the correct page numbers, ignoring the page number offset values in Layout → Page Settings... → First page number for all but the first score. As the album is printed in one print job, double-sided printing (duplex printing) also works as expected.

Join scores

To combine multiple scores into a single .mscz file, click Join Scores. The scores are combined in the selected order into one single score. If not already present, line- and section breaks are added to the last measure or frame of each score in the combined file.
All style settings are taken from the first score, different style settings from subsequent score are ignored.

All the scores should have the same number of parts and staves for this to work correctly, ideally with the same instruments in the same order. If the scores have the same total number of instruments but not the same ones, or not in the same order, then the instrument names from the first score will overwrite ones from subsequent scores. If some of the scores have fewer instruments than the first score, then empty staves will be created for those sections. Any part or staff that is not present in the first score will be lost in the joined score.

Save album

Upon clicking the Close button, you will be prompted to save your album as a .album file. This file is not the same as a joined score; it simply consists of the list of scores. Album files can be loaded into the Album Manager as described above.

Cross-staff notation

In piano scores, it is common to write a musical phrase extending across both staves—bass and treble. This can be entered in MuseScore as follows:

1. Enter all notes in one staff:
2. Ctrl+Shift↓ moves the selected note, or chord to the next staff (Mac: ⌘+Shift↓):

Note: this moves the whole chord, not just a single note from a multi note chord. If you need notes in the old staff at the same place, use voices.

3. To adjust the beam, double-click it to show the handles. Use the keyboard arrows or drag the handles to change the beam angle and position:

See also

- Connect barlines: How to extend barlines over multiple staves.

External links

- How to span a chord or stem over two staves (MuseScore “Howto”)

Early music features

MuseScore 2 offers several specialized functions to create engravings of early music (particularly medieval and renaissance) akin to commercial editions from the 20th century onwards.

Unbarred (or unmetered) notation

In MuseScore, notes lasting longer than the duration of a measure are normally tied across barlines. However MuseScore has a special feature which allows it to display the note values intact, without splitting and tying them in this way. This enables you to notate music which is unbarred (i.e. not divided into measures), such as that of the renaissance:

1. From the menu bar, select Style → General... → Score.
2. Tick the box labelled “Display note values across measure bar.”
3. Click "OK" or "Apply." The existing score is immediately updated.

Example

1. The example below shows an excerpt from the original score of "De Profundis Clamavi" for 4 voices by Nicolas Champion:

![Original score](image)

2. The same excerpt displayed in MuseScore:

![MuseScore version](image)

3. And after activating "Display note values across measure bar."

![MuseScore version](image)

4. To get rid of the barlines, just untick the "Show barlines" box in the Staff properties dialog. See also Mensurstrich (below).

Note: The feature is still in development and may contain bugs. The longest supported note value is the longa (a dotted longa is still broken up and tied over).

Mensurstrich

Since a complete lack of barlines could make performing the music more difficult for current musicians, many modern engravers settled on a compromise called Mensurstrich, where barlines are drawn between, but not across, staves.
To place barlines between staves:

1. Enter edit mode by double-clicking a barline in a staff above where you want the Mensurstriche;
2. Hold Shift and drag the lower handle of the barline down until it meets the top of the staff below;
3. Hold Shift and drag the upper handle of the barline down until it meets the bottom of the current staff;
4. Exit edit mode by pressing Esc or clicking on a blank area of the document window.

Alternatively, you can use the Inspector:

1. In the staff below the proposed Mensurstriche, uncheck "Show barlines" in the Staff properties dialog;
2. In the staff above where you want the Mensurstriche, right-click on one barline and chose Select → All Similar Elements in Same Staff;
3. In the Inspector, under "Barline," make the following settings: "Spanned staves" = 2; "Spanned from" = 8; "Spanned to = 0."

Note: To reset barlines, select the relevant barlines and make the following settings: "Spanned staves" = 1; "Spanned from" = 0; "Spanned to = 8."

Ambitus

Before there was the concept of an absolute pitch, performers were required to transpose vocal music to a singable range for their ensemble "on the fly." To aid them, an ambitus was sometimes included, marking the entire range of a voice at the beginning of the piece.

To apply an ambitus, use one of the following methods:

- Drag the ambitus symbol (from the Lines palette of the Advanced workspace) onto a clef.
- Select a clef, then double-click the ambitus symbol (in the Lines palette of the Advanced workspace).

When applied, the ambitus automatically displays the note range of the score: if there is a section break then only the note range of the section is displayed. Beyond the section break a new ambitus may be applied.

The note range of the ambitus can be adjusted manually by selecting it and changing the "Top note" and "Bottom note" values in the Inspector. For automatic adjustment click the Update Range button in the inspector.

Mensural time signatures
In the mensural notation system, time signatures did not define the length of a measure, but the length of breves and semibreves. MuseScore supports mensural time symbols as a display method in the Time signature properties dialog rather than as symbols, but they are just for show, as the proportion of e.g. half notes per whole notes cannot be modified. One way to make use of these symbols is to replicate when composers of the renaissance had multiple voices in different time signatures simultaneously without using tuplets. Edit the time signature on a per-staff basis, as long as the beginning and end of a measure in all staves match up. If they do not, then consider increasing the size of the measures to the lowest common denominator.

De Profundis Clamavi for 5 voices by Josquin Des Prez

See also

- Measure Operations: Split and join

Figured bass

Adding a new figured bass indication

1. Select the note to which the figured bass applies
2. Press the Figured Bass shortcut (default Ctrl+G; can be changed in Preferences)
3. Enter the text in the editor ‘blue box’ as required (see below)
4. Press Space to move to the next note ready for another figured bass indication (or click outside the editor box to exit it)

With Space, the editor advances to the next note, or rest of the staff to which figured bass is being added. To move to a point in between, or to extend a figured bass group for a longer duration, see below Group Duration.

Tab advances the editing box to the beginning of the next measure.

Shift+Space moves the editing box to the previous staff note or rest.

Shift+Tab moves the editing box to the beginning of the previous measure.

Text format

Digits

Digits are entered directly. Groups of several digits stacked one above the other are also entered directly in a single text, stacking them with Enter.

De Profundis Clamavi for 5 voices by Josquin Des Prez
Accidentals

Accidentals can be entered using regular keys:

**To enter:** type:

- double flat \(\texttt{bb}\)
- flat \(b\)
- natural \(h\)
- sharp \(\#\)
- double sharp \(\texttt{##}\)

These characters will automatically turn into the proper signs when you leave the editor. Accidentals can be entered before, or after a digit (and of course, in place of a digit, for altered thirds), according to the required style; both styles are properly aligned, with the accidental ‘hanging’ at the left, or the right.

Combined shapes

Slashed digits or digits with a cross can be entered by adding, / or + after the digit (combining suffixes); the proper combined shape will be substituted when leaving the editor:

The built-in font can manage combination equivalence, favoring the more common substitution:

- 1+, 2+, 3+, 4+ result in 1₂ 2₃ 3₄ (or 1₂ 2₃ 4₄)  
- and 5\(\), 6\(\), 7\(\), 8\(\), 9\(\) result in 5₆ 7₈ 9₉ (or 5₆ 7₈ 9₉)

Please remember that / can only be combined with 5; any other ‘slashed’ figure is rendered with a question mark.

+ can also be used before a digit; in this case it is not combined, but it is properly aligned (‘+’ hanging at the left side).

Parentheses

Open and closed parentheses, both round: ‘(’, ‘)’ and square: ‘[’, ‘]’, can be inserted before and after accidentals, before and after a digit, before and after a continuation line; added parentheses will not disturb the proper alignment of the main character.

Notes:

- The editor does not check that parentheses, open and closed, round or square, are properly balanced.
Several parentheses in a row are non-syntactical and prevent proper recognition of the entered text.
A parenthesis between a digit and a combining suffix (‘+’, ‘\’, ‘/’) is accepted, but prevents shape combination.

**Continuation lines**

Continuation lines are input by adding an ‘_’ (underscore) at the end of the line. Each digit of a group can have its own continuation line:

![Example of continuation lines](image)

Continuation lines are drawn for the whole duration of the figured bass group.

**'Extended' continuation lines**

Occasionally, a continuation line has to connect with the continuation line of a following group, when a chord degree has to be kept across two groups. Examples (both from J. Boismortier, *Pièces de viole*, op. 31, Paris 1730):

![Examples of extended continuation lines](image)

In the first case, each group has its own continuation line; in the second, the continuation line of the first group is carried 'into' the second.

This can be obtained by entering several (two or more) underscores "___" at the end of the text line of the first group.

**Duration**

Each figured bass group has a duration, which is indicated by a light gray line above it (of course, this line is for information only and it is not printed or exported to PDF).

Initially, a group has the same duration of the note to which it is attached. A different duration may be required to fit several groups under a single note or to extend a group to span several notes.

To achieve this, each key combination of the list below can be used:

- to advance the editing box by the indicated duration
- AND
- to set the duration of the previous group up to the new editing box position.

Pressing several of them in sequence without entering any figured bass text repeatedly extends the previous group.

**Type:**

<table>
<thead>
<tr>
<th>Type</th>
<th>to get</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+1</td>
<td>1/64</td>
</tr>
<tr>
<td>Ctrl+2</td>
<td>1/32</td>
</tr>
<tr>
<td>Ctrl+3</td>
<td>1/16</td>
</tr>
<tr>
<td>Ctrl+4</td>
<td>1/8 (quaver)</td>
</tr>
<tr>
<td>Ctrl+5</td>
<td>1/4 (crochet)</td>
</tr>
<tr>
<td>Ctrl+6</td>
<td>half note <em>(minim)</em></td>
</tr>
<tr>
<td>Ctrl+7</td>
<td>whole note <em>(semibreve)</em></td>
</tr>
<tr>
<td>Ctrl+8</td>
<td>2 whole notes <em>(breve)</em></td>
</tr>
</tbody>
</table>

(The digits are the same as are used to set the note durations)

Setting the exact figured bass group duration is only mandatory in two cases:

1. When several groups are fit under a single staff note (there is no other way).
When continuation lines are used, as line length depends on the group duration.

However, it is a good practice to always set the duration to the intended value for the purposes of plugins and MusicXML.

**Editing existing figured basses**

To edit a figured bass indication already entered:

- Select it, or the note it belongs to and press the same **Figured Bass** shortcut used to create a new one or
- Double-click it

The usual text editor box will open with the text converted back to plain characters ('b', '#' and 'h' for accidentals, separate combining suffixes, underscores, etc.) for simpler editing.

Once done, press Space to move to a next note, or click outside the editor box to exit it, as for newly created figured basses.

**Style**

To configure how figured bass is rendered: from the menu, select **Style → General → Figured Bass.**
• **Font**: The dropdown list contains all the fonts which have been configured for figured bass. A standard installation contains only one font, "MuseScore Figured Bass," which is also the default font.

• **Size**: Select a font-size in points. *Note*: This value is also modified by any change made to *Scaling* (Layout → Page Settings...), or *Scale* ("Staff properties").

• **Vertical Position**: The distance (in spatia) from the top of the staff to the top margin of the figured bass text. Negative values go up (figured bass above the staff) and positive values go down (figured bass below the staff: a value greater than 4 is needed to step over the staff itself).

• **Line Height**: The distance between the base line of each figured bass line, as a percentage of font size.

The following picture visualizes each numeric parameter:

![Vertical Position Diagram]

• **Alignment**: Select the vertical alignment: with *Top*, the top line of each group is aligned with the main vertical position and the group ‘hangs’ from it (this is normally used with figured bass notation and is the default); with *Bottom*, the bottom line is aligned with the main vertical position and the group ‘sits’ on it (this is sometimes used in some kinds of harmonic analysis notations):

![Alignment Examples]

• **Style**: Chose between "Modern" or "Historic." The difference between the two styles is shown below:
Proper syntax

For the relevant substitutions and shape combinations to take effect and for proper alignment, the figured bass mechanism expects input texts to follow some rules (which are in any case, the rules for a syntactical figured bass indication):

- There can be only one accidental (before or after), or only one combining suffix per figure;
- There cannot be both an accidental and a combining suffix;
- There can be an accidental without a digit (altered third), but not a combining suffix without a digit.
- Any other character not listed above is not expected.

If a text entered does not follow these rules, it will not be processed: it will be stored and displayed as it is, without any layout.

Summary of keys

<table>
<thead>
<tr>
<th>Type:</th>
<th>to get:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+G</td>
<td>Adds a new figured bass group to the selected note.</td>
</tr>
<tr>
<td>Space</td>
<td>Advances the editing box to the next note.</td>
</tr>
<tr>
<td>Shift+Space</td>
<td>Moves the editing box to the previous note.</td>
</tr>
<tr>
<td>Tab</td>
<td>Advances the editing box to the next measure.</td>
</tr>
<tr>
<td>Shift+Tab</td>
<td>Moves the editing box to the previous measure.</td>
</tr>
<tr>
<td>Ctrl+1</td>
<td>Advances the editing box by 1/64, setting the duration of the previous group.</td>
</tr>
<tr>
<td>Ctrl+2</td>
<td>Advances the editing box by 1/32, setting the duration of the previous group.</td>
</tr>
<tr>
<td>Ctrl+3</td>
<td>Advances the editing box by 1/16, setting the duration of the previous group.</td>
</tr>
<tr>
<td>Ctrl+4</td>
<td>Advances the editing box by 1/8 (quaver), setting the duration of the previous group.</td>
</tr>
<tr>
<td>Ctrl+5</td>
<td>Advances the editing box by 1/4 (crochet), setting the duration of the previous group.</td>
</tr>
<tr>
<td>Ctrl+6</td>
<td>Advances the editing box by a half note (minim), setting the duration of the previous group.</td>
</tr>
<tr>
<td>Ctrl+7</td>
<td>Advances the editing box by a whole note (semibreve), setting the duration of the previous group.</td>
</tr>
<tr>
<td>Ctrl+8</td>
<td>Advances the editing box by two whole notes (breve), setting the duration of the previous group.</td>
</tr>
<tr>
<td>Ctrl+Space</td>
<td>Enters an actual space; useful when figure appears &quot;on the second line&quot; (e.g., 5 4 -&gt; 3).</td>
</tr>
<tr>
<td>B</td>
<td>Enters a double flat.</td>
</tr>
<tr>
<td>B</td>
<td>Enters a flat.</td>
</tr>
<tr>
<td>H</td>
<td>Enters a natural.</td>
</tr>
<tr>
<td>#</td>
<td>Enters a sharp.</td>
</tr>
<tr>
<td>##</td>
<td>Enters a double sharp.</td>
</tr>
<tr>
<td>_</td>
<td>Enters a continuation line.</td>
</tr>
<tr>
<td>_</td>
<td>Enters an extended continuation line.</td>
</tr>
</tbody>
</table>

File formats

MuseScore can import and export a wide variety of file formats, allowing you to share and publish scores in the format that best meets your needs.

MuseScore native format

MuseScore saves files in the following native formats:

- *.MSCZ: The default MuseScore file format. Being compressed it takes up relatively little disk space.
- *.MSCX: An uncompressed MuseScore file format.
- *.MSCZ, / *.MSCX: These are backup files. Notice the point (full stop) added before the file name, and the comma
A note about fonts: MuseScore does not embed text fonts in saved or exported native format files. If you want your MuseScore file to be viewed by other MuseScore users, make sure you are using the built-in FreeSerif or FreeSans font families for your text, or a font that the other parties have installed too. If a system does not have the fonts specified in your original file, MuseScore will use a fallback option, which may cause your score to appear differently.

MuseScore format (*.mscz)

MSCZ is the standard MuseScore file format and recommended for most uses. A score saved in this format takes up very little disk space, but preserves all the necessary information. The format is a ZIP-compressed version of .mscx files and includes any images.

Uncompressed MuseScore format (*.mscx)

MSCX is the uncompressed version of the MuseScore file format. A score saved in this format will retain all information, except images. It can be opened with a text editor, allowing the user access to the file's source code.

MuseScore backup file (*.mscz, *.mscx)

Backup files are created automatically and saved in the same folder as your normal MuseScore file. The backup copy contains the previously saved version of the MuseScore file and can be important if your normal copy becomes corrupted, or for looking at an older version of the score.

The backup file adds a period to the beginning of the file name (.) and a comma (,) to the end (e.g. if your normal file is called "untitled.mscz", the backup copy will be "untitled.mscz,"), and the period and comma need to be removed from the name in order to open the backup file in MuseScore. As it is stored in the same folder as your normal MuseScore file, you may also need to give it a unique name (e.g. changing ".untitled.mscz," to "untitled-backup1.mscz").

Note: In order to see the MuseScore backup files, you may need to change your system settings to "Show hidden files". See also How to recover a backup copy of a score (MuseScore 2.x).

Graphic files (export only)

MuseScore can export a score as a graphic file in either PDF, PNG or SVG format.

PDF (*.pdf)

PDF (Portable Document Format) files are ideal for sharing your sheet music with others who do not need to edit the content. This is a very widely-used format and most users will have a PDF viewer of some kind on their computers.

To set the resolution of exported PDFs:
1. From the menu bar, chose Edit → Preferences... (Mac: MuseScore → Preferences...), and select the "Export" tab;
2. Set the resolution in the "PDF" section.

PNG (*.png)

PNG (Portable Network Graphics) files are based on a bitmap image format, widely supported by software on Windows, Mac OS, and Linux, and very popular on the web. MuseScore creates PNG images as they would appear if printed, one image per page.

To set the resolution of exported PNG images:
1. From the menu bar, chose Edit → Preferences... (Mac: MuseScore → Preferences...), and select the "Export" tab;
2. Set the resolution and transparency in the PNG/SVG section.

Note: If you want to create images that show only parts of the score (with or without screen-only items such as frame boxes, invisible notes, and out-of-range note colors), use Image capture instead.

SVG (*.svg)

SVG (Scalable Vector Graphics) files can be opened by most web browsers (except Internet Explorer before version 9) and most vector graphics software. However, most SVG software does not support embedded fonts, so the appropriate
MuseScore fonts must be installed to view these files correctly. SVG is the format used on MuseScore.com for all scores saved online since May 2017 (coinciding with the release of MuseScore 2.1: before this the format was PNG).

To set resolution and transparency of exported SVG files, see the instructions under PNG (above). Note that MuseScore does not (yet) support gradients on export (although it does for images in a score).

Audio files (export only)

MuseScore can create normalised, stereo audio of the score in any of the following formats WAV, MP3, OGG VORBIS, FLAC. To export an audio file:

1. From the menu, select File → Export...;
2. Chose the desired format from the dropdown menu, then press Save.

You can adjust the sample rate of all audio formats as follows:

1. From the menu bar, select Edit → Preferences... (Mac: MuseScore → Preferences...), and click on the Export tab;
2. Set "Sample rate" in the "Audio" section.

WAV audio (*.wav)

WAV (Waveform Audio Format) is an uncompressed sound format. This was developed by Microsoft and IBM, and is widely supported by software for Windows, OS X, and Linux. It is an ideal format for use when creating CDs, as full sound quality is preserved. For sharing via email or the internet, use a compressed alternative such as MP3.

MP3 (*.mp3)

MP3 is a very widely-used compressed audio format. MP3 files are ideal for sharing and downloading over the internet due to their relatively small size.

For Windows and Mac users with an older version of MuseScore (Windows: prior to 2.2, Mac prior to 2.3.2), an additional library, lame_enc.dll (Windows) or libmp3lame.dylib (Mac), must be installed to create MP3 files (for Linux, it is up to the distribution maintainer whether or not to include this). MuseScore will prompt you for its location on the first attempt of an MP3 export. You can get it at http://lame.buanzo.org/ (note that it is necessary to rename the file to libmp3lame.dylib for MuseScore to recognize it). Homebrew users just need to run brew install lame.

As of version 2.1 you can set the MP3 bitrate:

1. From the menu bar, chose Edit → Preferences... (Mac: MuseScore → Preferences...), and select the "Export" tab;
2. Set the MP3 bitrate in the "Audio" section.

FLAC audio (*.flac)

Free Lossless Audio Codec (FLAC) is compressed audio format. FLAC files are approximately half the size of uncompressed audio and just as good quality. Windows and OS X do not have built-in support for FLAC, but software such as the free and open source VLC media player can play FLAC files on any operating system.

Ogg Vorbis (*.ogg)

Ogg Vorbis is intended as a patent-free replacement for the popular MP3 audio format (which MuseScore also supports—see above). Like MP3, Ogg Vorbis files are relatively small (often a tenth of uncompressed audio), but some sound quality is lost. Windows and OS X do not have built-in support for Ogg Vorbis. However, software such as VLC media player and Firefox can play Ogg files on any operating system.

Share with other music software

MuseScore can import and export MusicXML and MIDI files; it is also able to import a variety of native format files from other music notation programs.

MusicXML (*.xml, *.musicxml)
MusicXML is the universal standard for sheet music. It is the recommended format for sharing sheet music between different scorewriters, including MuseScore, Sibelius, Finale, and more than 100 others. As of version 2.2, MuseScore exports as .musicxml, and imports both, *.xml and *.musicxml.

Compressed MusicXML (*.mxl)

Compressed MusicXML creates smaller files than regular MusicXML. This is a newer standard and isn't as widely supported by older scorewriters, but MuseScore has full import and export support.

MIDI (*.mid, *.midi, *.kar)

MIDI (Musical Instrument Digital Interface) is a format widely supported by sequencers and music notation software. For details of the protocol see the MIDI Association website.

MIDI files are very useful for playback purposes but contain little in the way of score layout information (formatting, pitch spelling, voicing, ornaments, articulations, repeats, key signatures etc.). To share files between different music notation software, MusicXML is recommended instead.

For details about how to import MIDI files see MIDI import.

MuseData (*.md) (import only)

MuseData is a format developed by Walter B. Hewlett beginning in 1983 as an early means of sharing music notation between software. It has since been eclipsed by MusicXML, but several thousand scores in this format are still available online.

Capella (*.cap, *.capx) (import only)

CAP and CAPX files are created by the score writer Capella. MuseScore imports version 2000 (3.0) or later fairly accurately (2.x doesn't work, while the *.all format from 1.x versions is not supported at all).

Bagpipe Music Writer (*.bww) (import only)

BWW files are created by the niche score writer Bagpipe Music Writer.

BB (*.mgu, *.sgu) (import only)

BB files are created by the music arranging software, Band-in-a-Box. MuseScore's support is currently experimental.

Overture (*.ove) (import only)

OVE files are created by the score writer Overture. This format is mainly popular in Chinese-language environments, such as Mainland China, Hong Kong, and Taiwan. MuseScore's support is currently experimental.

Guitar Pro (*.gtp, *.gp3, *.gp4, *.gp5, *.gpx) (import only)

GP files are created by Guitar Pro.

See also

- Open/Save/Export/Print
- Recovered files

External links

- How to recover a backup copy of a score

Fretboard diagrams

A range of fretboard (or chord) diagrams for the guitar are pre-provided in the Fretboard Diagrams palette in the Advanced Workspace (versions prior to 2.0.3 feature only one diagram).
You can create a chord diagram for any fretted, stringed instrument by editing an existing one. It can be saved to a custom palette for future use if required.

**Add a fretboard diagram**

To add a fretboard diagram to the score, use one of the following methods:

- Select a note in voice 1 and double-click a fretboard diagram from a palette.
- Drag and drop a fretboard diagram from a palette to the desired position in the score.

**Edit fretboard diagram**

1. Right-click on a diagram in the score and select Fretboard Diagram Properties...
2. Adjust the number of instrument strings, using the "Strings" spin box at the bottom left of the window.
3. Adjust the fret position number using the scroll bar on the right-hand side.
4. Adjust how many frets to display (height-wise) using the Frets spin-box at the bottom right of the window.
5. To place a dot on a string fret, click on that fret. To remove the dot, click on the fret again.
6. Click just above the diagram to toggle a string between:
   - Open (o)
   - Mute/unplayed (x)
   - No indication.
7. To create a barre or partial barre:
   i. Make sure the desired fret position is clear of black dots (click on a dot to remove it);
   ii. Hold Shift and click on the fret where you want the barre to begin. **Note:** Only one barre can be applied per diagram;
   iii. To delete a barre, click on the black dot where the barre begins.

For example, to create a full-barre F# chord, from a C chord:

1. Place the C fretboard diagram on the score, right-click on it and select Fretboard Diagram Properties....
2. Click on the relevant fret positions to establish the fingering dots.
3. Set "Frets" to "4" and fret number (right-hand scroll bar) to "2." The diagram should now look like this:

![Fretboard Diagram for C chord](image)

4. Create the barre by holding Shift and clicking on the second fret of the 6th string. Click "OK" to exit and you should get this:

![Full-barre F# chord](image)

The same principle applies if you want a partial barré. For example, the partial barré in an A7 chord is created by pressing Shift, then clicking on the 4th string, second fret:
Adjust position, size, color

The size ("Scale"), color and position of a fretboard diagram can be changed by clicking on it and altering the relevant values in the Inspector.

The position of the fretboard diagram can also be adjusted in Edit mode:

1. Double-click on the diagram (or click on it and press Ctrl+E (Mac: Cmd+E); or right-click on it and select Edit element).
2. Press the arrow keys for fine positioning (0.1 sp. at a time); or press Ctrl+Arrow (Mac: Cmd+Arrow) for larger adjustments (1 sp. at a time).

Fretboard diagram style

Some default properties of fretboard diagrams (barre thickness, vertical position, size etc.) can be adjusted from the menu: select Style → General… → Chord Symbols, Fretboard Diagrams. Any changes made here affect all existing diagrams, as well as those applied subsequently.

MIDI import

MuseScore can import MIDI files (.mid/.midi/.kar) and convert them into music notation. To import, use the standard Open command.

Initially, the program renders the MIDI to notation using certain default settings. AMIDI Import Panel appears at the bottom of the screen, showing a list of tracks (only tracks with note events are shown) and the operations available for each track. You can change these settings on a track-by-track basis and then reimport the data: The "Apply" button (at the top) submits any changes with immediate effect. The "Cancel" button immediately cancels any unsaved changes. The final result should be a better quality score reproduction of the file.

Use Shift+Wheel or Ctrl+Wheel to scroll track options horizontally; scroll tracks vertically without those modifiers.

If there are multiple tracks, then one more track is added at the top of the list to select all tracks at once.

In the MIDI Import Panel, you can choose which tracks to import and reorder them. Some information about each track is displayed: sound, staff name, and lyrics, if any. The presence of the lyric column is an indication that the file contains a lyric track—assignable to different tracks through the drop-down menu.

The MIDI import panel updates the relevant information of whatever file is in view, if the user has several open. If the MIDI import panel is no longer required, it can be closed by clicking the close button in the top-left corner. The panel will reappear after clicking on the button "Show MIDI import panel" which appears right after the panel is closed.

After saving the score, the MIDI Import Panel will not be available, because MuseScore is no longer importing a MIDI file.

Available operations

MuseScore instrument
Assign a MuseScore instrument (listed in instruments.xml or in specified custom xml file in Preferences) that defines staff name, clef, transposition, articulations, etc.

**Quantization**

Quantize MIDI notes by some regular grid. The grid MAX resolution can be set via the drop-down menu:

- Value from preferences (default) - quantization value is taken from the main Preferences dialog of MuseScore (in the "Import" tab)
- Quarter, Eighth, 16th, 32nd, 64th, 128th - user-defined values

However, the actual quantization grid size is adaptive and reduces when the note length is small, so for each note the quantization value is different. But there is an upper limit for the quantization value, and that value can be set by the user as "max. quantization".

For example, if some note is long - say, half note, and the max. quantization is set to 8th, then the note will be quantized with the 8th-note grid, not the half- or quarter-note grid as it supposed to be by the algorithm.

Such quantization scheme allows to quantize all notes in the score (with different lengths!) adequately.

**Max. voices**

Sets maximum count of allowed musical voices.

**Search tuplets**

When enabled, this option attempts to detect tuplets and applies the corresponding quantization grid to the tuplet chords.

**Is human performance**

If enabled, this option reduces the accuracy of MIDI-to-score conversion in favor of readability. It is useful for unaligned MIDI files, when no regular quantization grid is provided. For such files the automatic beat tracking algorithm is used which tries to detect the bar positions throughout the piece.

**2x less measure count**

The option is active for unaligned MIDI files (when "Is human performance" is checked by default). It halves measure count obtained in the internal beat tracking operation. It may be convenient when the beat tracking gives 2x more frequent bar subdivision than necessary.

**Time signature**

The option is active for unaligned MIDI files. The user can choose an appropriate time signature for the whole piece if the default detected value is wrong. The option is useful because it handles imported tuplets correctly unlike the direct time signature setting from the palette.

**Split staff**

This option is suited mainly for piano tracks - to assign notes to the left or right hand of the performer. It uses constant pitch separation (the user may choose the pitch via sub-options) or floating pitch separation (depending on the hand width - sort of a guess from the program point of view).

For drum tracks ("Percussion" sound in the track list) it splits the staff into multiple staves, each of which gets only one drum pitch (i.e. drum sound). There is also a sub-option to allow/disallow the application of the square bracket for the newly created set of drum tracks.

**Clef changes**

Small clefs can be inserted within a staff to keep chords closer to the 5 staff lines. Clef changes depend on the average pitch of the chord. Tied groups of notes are not broken by the clef insertion (if it occurs, one can report a bug for algorithm in importmidi_clef.cpp). This option is available for non-drum tracks only.

**Simplify durations**

Reduces number of rests to form more "simple" note durations. For drum tracks this option can remove rests and lengthen notes as well.

**Show staccato**

Option to show/hide staccato markings in the score.

**Dotted notes**

Controls whether MuseScore will use dotted notes or ties.

**Show tempo text**

Shows/hides tempo text markings in the score.

**Show chord names**

Shows/hides chord names in the score, if any, for XF MIDI file format.

**Recognize pickup measure**

When enabled, this option doesn’t change the time signature of the first bar that is shorter than the second bar. It is also called anacrusis. This option is only available for all tracks at once.

**Detect swing**

MuseScore tries to detect swing, and automatically replace a pattern of 4th + 8th notes in triplets (for the most common swing feel, 2:1), or a dotted 8th + 16th pattern (for shuffle, 3:1), with two straight 8ths and a “Swing” or “Shuffle” text at the beginning.
Master palette

The **Master Palette** is a repository of symbols used to populate the **workspaces** (Basic, Advanced, and Custom). It is also used to create new **Time Signatures** and **Key Signatures**.

To open, use either of the following options:

- Press Shift+F9 (Mac: fn+Shift+F9).
- From the menu, select **View → Master Palette**.

The Master palette is divided into sections based on symbol type. Hovering the mouse over an item shows a **tool tip** (a short definition in black on yellow background).

To transfer a Master palette item to a **custom palette**:

- Drag the symbol from the Master Palette window into a custom palette.

**Note**: Except for the **Symbols** section (below), it is not usual to add items directly to the score from the Master palette: use the workspace palettes instead. However, if desired, items can be added directly using either (i) drag-and-drop or (ii) by selecting one or more notes/rests and double-clicking the item.

**Symbols**

The **Symbols** section of the Master Palette is a large repository of hundreds of musical symbols in addition to those found in the preset **workspaces**. You can open it from the Master Palette, or directly from the score by using the shortcut Z.
Find a symbol

The symbols are listed under their respective musical font types: use the font menu on the bottom right of the box to specify Emmentaler, Gonville or Bravura. You can search for a particular symbol by entering a keyword in the search box.

Apply a symbol

To add an item to the score from the Symbols section, use any of the following options:

- Drag and drop a symbol onto a staff.
- Select a note or rest and double-click a symbol.

The position of the symbol can be adjusted by dragging or by changing the horizontal / vertical offsets in the Inspector. Color and visibility can also be adjusted in the Inspector.

Note: Elements from the Symbols section do not follow any positioning rules (in many cases unlike identical elements from other sections of the Master Palette), nor do they affect score playback.

Connect symbols

Elements from the Symbols section can be connected to each other on the score page, so that they can be moved as one unit:

1. Apply first symbol to the score. Adjust position as required.
2. Double click, or drag-and-drop, a second element onto the first symbol. Adjust position as required.

Drag the first element and the attached element will follow.

See also

- Palettes and workspaces
- Symbols and special characters (add musical symbols to text objects)

Note input modes

From version 2.1, you can enter notation using one of several new note input modes—in addition to the pre-existing Step-time and Re-pitch modes. These are accessed by clicking a small dropdown arrow next to the note entry button on the note input toolbar.
Step-time

This is the method of note entry that MuseScore has had from the beginning. You enter notes in Step-time mode by choosing a duration using the mouse or keyboard, and then choosing a pitch using the mouse, keyboard, MIDI keyboard or virtual piano.

For details see Basic note entry.

Re-pitch

**Re-pitch** mode allows you to correct the pitches of a sequence of notes while leaving their durations unchanged (not to be confused with Accidental: Respell pitches).

1. Select a note as your starting point;
2. If you are using a pre-2.1 version of the program press N to enter note-input mode. This step is optional from 2.1 onwards.
3. Select the **Re-Pitch** option from the Note input drop-down menu (or, for pre-2.1 versions, from the note input toolbar); or use the keyboard shortcut, Ctrl+Shift+I (Mac: Cmd+Shift+I).
4. Now enter pitches using the keyboard, MIDI keyboard or virtual piano keyboard.

You can also use the **Re-pitch** function to create a new passage from an existing one of the same sequence of durations —by copying and pasting the latter, then applying Re-pitch.

Rhythm

Rhythm mode allows you to enter durations with a single keypress. Combining Rhythm and Re-pitch modes makes for a very efficient method of note entry.

1. Select your starting point in the score and enter Rhythm mode.
2. Select a duration from the note input toolbar, or press a duration shortcut (numbers 1-9) on your computer keyboard. A note will be added to the score with the selected duration. In contrast to **Basic note entry**, pressing the . key will toggle dotting or not dotting all subsequent durations. All following rhythms will be dotted until the . key is pressed again. Unlike **Basic note entry**, the dot is to be pressed prior to entering the rhythm.
3. Entering rests is similar to adding dotted notes. Press the 0 key to toggle entering rests. All rhythms entered will be rests until the 0 key is pressed again. This can be used concurrently with dotted notes.
4. Continue pressing duration keys to enter notes with the chosen durations.
5. Now use **Re-pitch mode** to set the pitches of the notes you just added.

Real-time (automatic)

The Real-time modes basically allow you to perform the piece on a MIDI keyboard (or MuseScore's virtual piano keyboard) and have the notation added for you. However, you should be aware of the following limitations which currently apply:

- It is not possible to use a computer keyboard for Real-time input
- You cannot enter tuplets or notes shorter than the selected duration
- You cannot enter notes into more than one voice at a time

However, these restrictions mean that MuseScore has very little guessing to do when working out how your input should
be notated, which helps to keep the Real-time modes accurate.

In the automatic version of Real-time input, you play at a fixed tempo indicated by a metronome click. You can adjust the tempo by changing the delay between clicks from the menu: Edit → Preferences... → Note Input (Mac: MuseScore → Preferences... → Note Input).

1. Select your starting position in the score and enter Real-time (automatic) mode.
2. Select a duration from the note input toolbar.
3. Press and hold a MIDI key or virtual piano key (a note will be added to the score).
4. Listen for the metronome clicks. With each click the note grows by the selected duration.
5. Release the key when the note has reached the desired length.

The score stops advancing as soon as you release the key. If you want the score to continue advancing (e.g. to allow you to enter rests) then you can use the Real-time Advance shortcut to start the metronome.

Real-time (manual)

In the manual version of Real-time input, you have to indicate your input tempo by tapping on a key or pedal, but you can play at any speed you like and it doesn't have to be constant. The default key for setting the tempo (called "Real-time Advance") is Enter on the numeric keypad (Mac: fn+Return), but it is highly recommended that you change this to a MIDI key or MIDI pedal (see below).

1. Select your starting position in the score and enter Real-time (manual) mode.
2. Select a duration from the note input toolbar.
3. Press and hold a MIDI key or virtual piano key (a note will be added to the score).
4. Press the Real-time Advance key. With each press the note grows by the selected duration.
5. Release the note when it has reached the desired length.

Real-time Advance shortcut

The Real-time Advance shortcut is used to tap beats in manual Real-time mode, or to start the metronome clicks in automatic Real-time mode. It is called "Real-time Advance" because it causes the input position to move forward, or "advance", through the score.

The default key for Real-time Advance is Enter on the numeric keypad (Mac: fn+Return), but it is highly recommended that you assign this to a MIDI key or MIDI pedal via MuseScore's MIDI remote control. The MIDI remote control is available from the menu: Edit → Preferences... → Note Input (Mac: MuseScore → Preferences... → Note Input).

Alternatively, if you have a USB footswitch or computer pedal which can simulate keyboard keys, you could set it to simulate Enter on the numeric keypad.

See also

- Note input
- Copy and paste

External links

- Video: Semi-Realtime MIDI Demo Part 1: New note entry modes (available as of MuseScore 2.1)
- Introduction to the new Repitch Mode (YouTube)

Noteheads

A range of alternative noteheads – in addition to the "normal" – can be found in the Note Heads palette of the Advanced workspace and via the Inspector (see Change notehead group, below).

Note: The design of the notehead may vary depending on the music font selected (Emmentaler, Gonville or Bravura). Those in the palette are displayed as half notes in Bravura font.

Notehead groups

MuseScore supports a number of notehead styles:

- Normal: A standard notehead.
• **Crosshead** (Ghost note): Used in percussion notation to represent cymbals. It also indicates muted and/or percussive effects in stringed instruments such as the guitar.

• **Diamond**: Used to indicate harmonic notes in instruments such as the guitar, violin etc.

• **Slash**: Used to notate rhythmic values.

• **Triangle**: Used in percussion notation.

• **Shape notes**: Do, Re, Mi, Fa, Sol, La, Ti.

• **Circle cross**: Used in percussion notation.

• **Alternative Brevis**: Used in early music notation.

• **Brackets** (Parentheses): When applied, these go around the existing note (or accidental).

### Change notehead group

To change the shape of one or more noteheads in the score, use one of the following:

- Select one or more notes and double click a notehead in a palette
- Drag a notehead from a palette onto a note in the score.
- Select one or more notes and change the notehead in the Inspector, using the drop-down list under **Note → Head group** (not supported for drum staves).

### Change notehead type

Occasionally you may need to change the apparent duration of a notehead—i.e. **notehead type**—without altering its actual, underlying duration:

1. Select one or more notes.
2. Chose one of the following options from the **Inspector** under **Note → Head type**:
   - **Auto**: Automatic, i.e, apparent duration = actual duration.
   - **Whole**: Whole notehead, regardless of actual duration.
   - **Half**: Half notehead, regardless of actual duration.
   - **Quarter**: Quarter notehead, regardless of actual duration.
   - **Breve**: Breve notehead, regardless of actual duration.

### Shared noteheads

When two notes in different voices, but of the same written pitch, fall on the same beat, one of two things may happen:

- The notes may **share** the same notehead.
- The notes may be **offset**: i.e. arranged side by side.

MuseScore follows standard music notation practice as follows:

- Notes with stems in the same direction do not share noteheads.
- Dotted notes do not share noteheads with undotted notes.
- Black notes do not share noteheads with white notes.
- Whole notes never share noteheads.

**Note**: If two unison notes occur in the same voice they are always offset.

### Change offset noteheads to shared

Offset noteheads can be turned into shared noteheads in one of two ways:

- Make the smaller-value notehead invisible by selecting it and using the keyboard shortcut (or unchecking the "Visible" option in the **Inspector**).
- Alter the notehead type of the shorter-duration note to match the longer one by switching "Head type" in the "Note" section of the Inspector.

### Examples of notehead sharing

1. In the first example below, the notes of voices 1 and 2 share noteheads by default, because they are all black, undotted notes:
2. By contrast, in the next example, white notes cannot share noteheads with black notes, so are offset to the right:

To create a shared notehead, make the black eighth note invisible or change its head type to match that of the white note (as explained above):

Remove duplicate fret marks

In certain cases, a shared notehead, when pasted to tablature staff, may result in two separate fret marks on adjacent strings. To correct this, make any extraneous tablature notes invisible by selecting them and using the keyboard shortcut V (or by unchecking the "visible" option in the Inspector).

External links

- Shape notes at Wikipedia.
- Ghost notes at Wikipedia.

Parts

MuseScore not only allows you to create and print the full score but also the individual instrument parts.

Note: In the current version of MuseScore, only one part can be generated per single staff (or grand staff or staff/TAB system). If you want to create a part for a particular voice, you need to ensure that it has its own staff as well.

Set up all parts at once

This is the most straightforward method. Parts are generated on a one-to-one basis from the corresponding Instruments in the score:

1. From the menu, select File → Parts...;
2. Click the New All button (parts are named with the instrument name, and a number added to differentiate parts that have the same label in the main score);
3. Click OK.

The parts can now be accessed by clicking on tabs above the document window.

Define specific parts

This method allows you to generate specific parts (rather than all-at-once), or to alter a previous parts set-up. It also allows you to specify multi-instrument parts, and define part names differently from the corresponding instruments, if needed.

The following instructions use a string quartet as an example, but the same principles apply for any other ensemble:

1. From the menu, select File → Parts...

2. In the Parts window click New to create a “part definition;”

3. In the right pane, type the words you want to use for the “Part title” (this also serves for the corresponding part of the filename when exporting);

4. Pick the instrument that you want to appear in your part by marking the relevant box in the right-hand pane. Usually, you only want one instrument per part, but sometimes you might need a part that includes more than one instrument (such as multiple percussion staves). MuseScore allows you to mark as many instruments per part as you need;
5. Repeat steps two through four (above) for each part as needed;

6. Once you're done, click OK to dismiss the Parts window.

You have now finished setting up the parts. You do not need to do this again, unless you add or remove an instrument from your full score.

Delete a Part

1. Open the Parts dialog (File → Parts...);
2. Select the relevant Part in the "Select Part" section;
3. Press Delete.

Export the parts

1. From the menu, select File → Export Parts...;
2. Navigate to the place you want them to be exported to and select the file format (PDF is the default);
3. For filename just enter whatever prefix is useful for all parts, or leave the default (the filename of your score);
4. Click OK.

This will generate files with the names "<title>" + "." + "<part name>.<extension>". In addition, when exporting as PDF, this will also generate "<title>" + "-Score_And_Parts.pdf".

Save the parts

Parts and score are "linked", which means that any change to the content in one will affect the other, but changes to the layout will not. When you have the parts created, they are saved along with the score (if you open the score you have tabs for the score and every part you created).

However, if you wish to save a part individually:

1. Make sure the part is "active." Select its tab if not;
2. From the menu, select File → Save As....

Print a part

1. Make sure the part is "active." Select its tab if not;
2. From the menu, select File → Print to open the print dialog.

Plugins
Overview

Plugins are small pieces of code that add a particular feature to MuseScore. By enabling a plugin, a new menu option will be appended to the Plugins menu in MuseScore to accomplish a given action on the score or a part of it.

Some plugins come pre-installed with MuseScore—see → below. You can find many more plugins in the plugin repository. Some plugins there work with MuseScore 2; others will only work with older versions of MuseScore, some work with either.

To tell one from the other: for MuseScore 2.x the plugin code files have an extension of .qml, for older versions, it is .js.

Installation

Note that some plugins may require the installation of other components (fonts, e.g.) to work. Check the plugin's documentation for more information.

Most plugins are provided as ZIP archives, so download the plugin's .zip file and uncompress it to one of the directories mentioned below. If a plugin is provided directly as an (unzipped) .qml file, simply download and place into one of these directories.

Once a plugin is installed, it needs to be enabled in the Plugin Manager in order to use it—see → below.

Windows

MuseScore looks for pre-installed plugins in %ProgramFiles%/MuseScore 2/Plugins (or %ProgramFiles(x86)%/MuseScore 2/Plugins for the 64-bit versions) and in %LOCALAPPDATA%/MuseScore/MuseScore 2/plugins on Vista, Seven and 10 or C:/Documents and Settings/USERNAME/Local Settings/Application Data/MuseScore/MuseScore 2/plugins (adjusted to your language version) on XP.

To install new plugins, the above folders should not be used or modified. Instead you can add other plugins to %HOMEPATH%/Documents/MuseScore2/Plugins, or specify a different folder to look for plugins in MuseScore's Preferences.

macOS

On macOS, MuseScore looks for pre-installed plugins in the MuseScore bundle in/Applications/MuseScore 2.app/Contents/Resources/plugins (to reveal files in the app bundle, right click on MuseScore 2.app and choose "Show package contents") and in ~/Library/Application Support/MuseScore/MuseScore 2/plugins.

To install new plugins, the above folders should not be used or modified. Instead you can add other plugins to ~/Documents/MuseScore2/Plugins, or specify a different folder to look for plugins in MuseScore's Preferences.

Linux

In Linux, MuseScore looks for plugins in /usr/share/mscore-2.0/plugins and in ~/local/share/data/MuseScore/MuseScore 2/plugins.

To install new plugins, the above folders should not be used or modified. Instead you can add other plugins to ~/Documents/MuseScore2/Plugins, or specify a different folder to look for plugins in MuseScore's Preferences.

Enable/disable plugins

To be able to access the installed plugins from the Plugins menu, they need to be enabled in the Plugin Manager:
Create/edit/run plugins

It is possible to create new or edit existing plugins and run them via the Plugin Creator:
Here also the documentation of all available elements can be found

**Plugins installed by default**

Some plugins come pre-installed with MuseScore, but they are not enabled by default. See → above to enable plugins.

**ABC Import**

This plugin imports ABC text from a file or the clipboard. Internet connection is required, because it uses an external web-service for the conversion, which uses abc2xml and gets send the ABC data, returns MusicXML and imports that into MuseScore.

**Break Every X Measures**

This plugin enters line breaks in the interval you select on the selected measures or, if no measures are selected, the entire score. It is no longer being distributed and has been replaced by Edit → Tools → Add/Remove Line Breaks. If you ever used an early beta version of MuseScore 2, though, you may still see the plugin left over.

**Notes → Color Notes**

This demo plugin colors notes in the selected range (or the entire score), depending on their pitch. It colors the note head of all notes in all staves and voices according to the Boomwhackers convention. Each pitch has a different color. C and C♯ have a different color. C♯ and D♭ have the same color.

To color all the notes in black, just run that plugin again (on the same selection). You could also use the 'Remove Notes Color' plugin for this.

**Create Score**

This demo plugin creates a new score. It creates a new piano score with 4 quarters C D E F. It's a good start to learn how to make a new score and add notes from a plugin.

helloQml

This demo plugin shows some basic tasks.

**Notes → Note Names**
This plugin names notes in the selected range or the entire score. It displays the names of the notes (as staff text) as per MuseScore's language settings, for voices 1 and 3 above the staff, for voices 2 and 4 below the staff, and for chords in a comma separated list, starting with the top note.

Panel

This demo plugin creates a GUI panel.

random

Creates a random score.

random2

Creates a random score too

run

This demo plugin runs an external command. Probably this will only work on Linux.

scorelist

This test plugin iterates through the score list.

ScoreView

Demo plugin to demonstrate the use of a ScoreView

Walk

This test plugin walks through all elements in a score

See also

- Tools

Preferences

You can customize many of MuseScore's default behaviors via the menu Edit → Preferences... (Mac: MuseScore → Preferences...).

The Preferences dialog has multiple tabs:

- General
- Canvas
- Note Input
- Score
- I/O
- Import
- Export
- Shortcuts
- Update

Reset All Preferences to Default will reset all preferences to the ones MuseScore had when you installed it.

Cancel will close the dialog without applying changes.

General
Here you can define:

- **Program Start**: Tick the boxes as appropriate to specify which **score** and what **panels** (Play Panel, Navigator, Start Center) you want to see when MuseScore opens.
- **Folders**: Specify the default folders for score files, **style files**, custom score **templates**, **plugins**, additional **SoundFonts** and **images**.
- **Language**: Chose the language used by the program. Translations may be updated from here too. Note that language translation updates can also be done via the menu: Help → Resource Manager.
- **Theme / Style** (prior to version 2.1): Specify a dark or light theme and the size of icons.
- **Auto Save**: How frequently the program autosaves.
- **OSC Remote Control**:

**Canvas**

Use Canvas to set your preferred color and wallpaper for the score background and paper. The default "Background" is grey (RGB 221, 221, 221; Alpha 221) and the default "Paper," white.
• **Background**: Use this to set the color or background around the score pages. Select “Color” then click on the bar to the right and make a choice from the color picker; or select "Wallpaper," click on the file icon and set a background image.

• **Paper**: Sets the color or background of the score pages. Controls identical to "Background" (above).

• **Scroll Pages**: This defines the way that the pages are layed out in the score. Chose "Horizontally" for a row layout, or "Vertically" for a column layout.

• **Miscellaneous**: “Draw antialiased” (the default option) makes diagonal lines and edges of shapes look smoother. "Proximity for selecting elements" controls the distance the mouse may be from an object and still act on it. Smaller numbers require more precision, making it harder to click on small objects. Larger numbers are less precise, making it harder not to click on nearby objects unintentionally. Choose a comfortable working value.

### Note input

![MuseScore Preferences](image)

On this tab there are note input and MIDI remote control preferences. Here the following can be set:

#### Note Input

- **Enable MIDI Input**: Leave checked to allow MIDI input of notes.
- **Color notes outside of usable pitch range**: For details, see Coloring of notes outside an instrument's range and Usable pitch range (Staff properties: all staves).
- **Delay between notes in automatic real-time mode** (as of version 2.1): See Real-time (automatic).
- **Play notes when editing**: When ticked, MuseScore sounds the note when it is entered or selected. Tick “Play whole chord when adding note,” if you want to hear all the notes of a chord when it is added to. You can also edit the “Default duration”.

#### MIDI Remote Control

**Midi Remote Control** allows you to use certain keys on your MIDI keyboard to enter notes and rests and select note durations, without involving the computer mouse or (computer) keyboard. The default setting is off.

**To assign a command to a MIDI key:**

1. Ensure that "MIDI Remote Control" is checked (your MIDI keyboard should be connected before opening the program).
2. Click the red button next to the option you wish to assign a MIDI key to: the red button now lights up.
3. Press a MIDI keyboard key. The red button becomes unlit and the green button lights up instead. The MIDI key has now been assigned to the desired option.
4. Repeat “2” and “3” to assign other keys.

Once you have defined your key settings you can use the MIDI keyboard to control note input operations. You can verify your key settings by observing the MuseScore Note Input toolbar while pressing the MIDI keys.
To temporarily deactivate Midi Remote Control: uncheck "Midi Remote Control": all MIDI input key action buttons are now greyed out. **Note**: Your key assignments are always saved between MuseScore sessions and are not affected by deactivation.

**Notes**: (1) The "Clear" option turns off all the green buttons for the current MuseScore session but all the user-recorded MIDI key settings are retained and will be reloaded on the next session. (2) A MIDI key setting that is activated cannot afterwards be turned off, and the green button will always remain lit: however it can be overwritten with a different MIDI key by using the red button again. (3) If the same MIDI key is accidentally assigned to more than one option, then all the associated green buttons remain lit although only one will work. To fix, see "(2)".

### Score

![Score Preferences](image)

Score preferences include

- Default instrument list files (two may be selected)
- Default style for score and parts
- Default zoom

### I/O

![I/O Preferences](image)

Attention: Any changes on this page require a restart of MuseScore. Precise MIDI output timing is only possible via JACK.
API / Device

This enables you to set the audio interface (API) and specify the device to be used for audio playback: e.g. built-in speakers/headphones, USB headset, wireless, etc.

MIDI Input/Output/Output Latency

When an external MIDI input device is connected, its identifier appears in MIDI Input. As of MuseScore 2.2, when the device is connected for the first time, you also need to select the correct MIDI Output option in order to enable note input and correct audio playback (e.g. in Windows, this might be "MMS<device name>"): then close and reopen the program to confirm the changes.

Versions of MuseScore prior to 2.2 only have the "MIDI Input" option. The correct MIDI output is automatically specified as long as the MIDI input device is connected correctly.

Jack Audio Server

Check these options as required if using the JACK Audio Connection Kit.

Import

These settings determine how files from other sources are imported:

- Using either the built in MuseScore style or a style you choose
- Guitar Pro and Overture character sets
- MusicXML layout options
- Shortest note in MIDI files

Export
These settings determine how MuseScore files are exported:

- PNG/SVG image resolution (in DPI) and whether to use transparent background
- Whether to expand repeats in exported MIDI files
- Digital audio sample rate
- MP3 bitrate (as of MuseScore 2.1)
- Whether to export the layout and how to export system and page breaks to MusicXML

Shortcuts

Every action possible with MuseScore is listed, with the associated shortcut if it exists. To define a new shortcut, select an existing entry in the list and click Define... (or just double click the entry), then enter the new shortcut using up to four keys. You can also reset any shortcut in the list to its default value, or clear a shortcut you select. Shortcuts listed in preferences appear next to their associated commands in the menus.

Note: Some shortcuts, including default ones, may not work with some keyboards.

The list of shortcuts can be printed out or exported to other media (pdf etc.) using the Print button in the bottom right of the
This sets whether MuseScore will check for updates at startup.

Updates may be checked manually in Help → Check for updates.

See also

- Keyboard shortcuts
- Language settings and translation updates
- Update checking

Recovered files

If MuseScore or your computer should crash, or if power is lost, a pop-up message upon restarting MuseScore will ask if you wish to restore the previous session.

If you click No, any work from your previous session will be lost. If you click Yes, MuseScore will attempt to recover the files that were open.

Behavior of saving after session recovery

When MuseScore recovers files after a crash, it renames them with the full path name added in front of the original file name. This very long name will appear in the tab(s) above the active score window. On some operating systems, when a user saves any of these recovered files, it will be saved in the folder in which the program itself is running. This is not necessarily the same directory in which the scores were saved when they were created. You may not be able to locate the revised file in the usual folder.
To avoid this, **do not use** "Save" the first time you save a recovered file. Use the "Save As..." menu item **before** making any revisions to the score, to save each recovered file under either its original name or a new name. This will open a window to allow you to navigate to the correct folder and directory. **This is important in order to ensure that the file is saved to the folder in which you expect to find it later.**

**Finding recovered files**

In the event that "Save" is used instead of "Save As..." with a recovered file, you will have to find the files in your computer. The actual location of those files will vary, depending on your operating system, and in which directory MuseScore is installed.

For Windows 7, with a default installation of MuseScore to the x86 program files directory, recovered files are auto-saved to C:\Program Files (x86)\MuseScore 2\bin (actually %ProgramFiles(x86)%\MuseScore 2\bin).

For Windows 10, look in C:\Users\[User Name]\AppData\Local\VirtualStore\Program Files (x86)\MuseScore 2\bin (actually %LOCALAPPDATA%\VirtualStore\%ProgramFiles(x86)\MuseScore 2\bin).

You may need to run a system-wide search in order to find files saved directly after a session recovery. Use keywords from the original file name as well as wildcards, and specify the date modified.

**See also**

Save/Export/Print

**External links**

How to recover a backup copy of a score

**Score properties**

The **Score Properties** dialog contains the document meta tags such as "workTitle," "Composer," "Copyright" etc. To view the dialog:

1. Make sure that the applicable score or instrument part is the active tab;
2. From the menu, select File → Score Properties (File → Info... in versions earlier than 2.0.3).

Several meta tags are generated automatically when you create a score using the **New Score Wizard**, and others may be added later. Meta tags can also be incorporated into a header or footer if required—see **below**.

**Edit meta tags**

1. Make sure that the applicable score or instrument part is the active tab;
2. From the menu, select File → Score Properties (File → Info... in versions earlier than 2.0.3);
3. Edit the text of the various meta tags as required;
4. To add another meta tag, click on the New button. Fill in the "New tag name" field and press OK;

Preexisting meta tags

Every score has the following fields available in Score Properties. Some are automatically filled in on score creation, while others will be empty unless specifically changed. The first four items in the following list are not user-modifiable, and cannot be used in the header or footer (they are not really meta tags).

- **File Path**: The score file's location on your Computer (2.0.3 and later).
- **MuseScore Version**: The version of MuseScore the score was last saved with.
- **Revision**: The revision of MuseScore the score was last saved with.
- **API-Level**: The file format version.
- **arranger**: (empty)
- **composer**: As entered in the New Score Wizard (which is also used to fill the composer text in the top vertical frame)—be aware that later changes to one are not reflected in the other.
- **copyright**: As entered in the New Score Wizard. Copyright info appears as seemingly uneditable text at the bottom of every page of a score, but it can be edited or removed by changing the value here.
- **creationDate**: Date of the score creation. This could be empty, if the score was saved in test mode (see Command line options).
- **lyricist**: As entered in the New Score Wizard (which is also used to fill the corresponding lyricist text in the top vertical frame)—be aware that later changes to one are not reflected in the other.
- **movementNumber**: (empty)
- **movementTitle**: (empty)
- **originalFormat**: This tag exists only if the score got imported and then contains the format the score got imported from (see file formats).
- **platform**: The platform the score was created on: "Microsoft Windows", "Apple Macintosh", "Linux" or "Unknown". This might be empty if the score was saved in test mode.
- **poet**: (empty)
- **source**: May contain a URL if the score was downloaded from or saved to MuseScore.com.
- **translator**: (empty)
- **workNumber**: (empty)
- **workTitle**: As entered in the New Score Wizard (which is also used to fill the corresponding title text in the top vertical frame)—be aware that later changes to one are not reflected in the other.
When working on multiple scores that belong to one larger work, the nomenclature is like this: **workNumber** and **workTitle** are the number and title of the larger work (e.g. opus 8, “Le quattro stagioni” (The four seasons) by Antonio Vivaldi), **movementNumber** is the number of the movement you’re working on (e.g. 3 for Autumn) and **movementTitle** is its title (“L’autunno”). It is customary, when using the New Score Wizard, to create a work with the **movementTitle** as title (even though it ends up in **workTitle** then) and, directly after creating the score, fixing up this information in the Score Properties dialogue. This ensures that the title frame of the printed score contains the information you expect but the metadata is also correct.

Every part additionally has the following meta tag, generated and filled on part creation:

- **partName**: Name of the part as given on part creation (which is also used to fill the corresponding part name text in the top vertical frame—be aware that later changes to one are not reflected in the other).

**Header/Footer**

To show the content of one or more meta tags in a header or footer for your score/part:

1. Make sure that the correct score or instrument part is the active tab;

2. From the menu, select **Style → General... → Header, Footer, Numbers**;

If you hover with your mouse over the Header or Footer text region, a list of macros will appear, showing their meaning, as well as the existing meta tags and their content.
3. Add tags (e.g. $:workTitle:) and macros (e.g. $M$) to the appropriate boxes, as required;

4. Click Apply to see how the header or footer looks in the score. Make corrections to the dialog if required;

5. If an instrument part is in the active tab, click Apply to all parts, if you want to apply these settings to all the score parts;

6. Click OK to assign the header or footer and exit the dialog.

See also

- Layout and formatting: Header and footer
- Command line options: Test mode

Staff properties

The Staff Properties dialog allows you to make changes to the display of a staff, adjust its tuning and transposition, change instrument etc. To open:

- Right-click on a staff and select Staff Properties....

Staff Properties dialog, as of version 2.1.
Staff Types

For practical purposes, there are four different types of staff:

1a. **Standard staff I**. A pitched staff used for most instruments except fretted, plucked-string ones.
1b. **Standard staff II**. A pitched staff containing a *fretted, plucked-string instrument*, with options to set the number of instrument strings and tuning.
2. **Tablature staff**. A staff containing a *fretted, plucked-string instrument*, which displays music as a series of fret-marks on strings. Also contains options to set the number of instrument strings and tuning.
3. **Percussion staff**. A pitched staff for percussion instruments.

It is possible to change one type of staff into another using the *Instruments* dialog, as long as the original staff is loaded with the right instrument. For example, in order to change a standard staff to tablature, it must contain a plucked-string instrument. Similarly, to change a standard staff to a percussion staff you need to ensure that it has an appropriate percussion instrument loaded and so on.

Most options in the Staff properties dialog are common to all staves, but each type also has one or two specific options of its own.

**Staff Properties: all staves**

The following Staff Properties options are common to *all* staves:

**Lines**
The number of lines making up the staff.

**Line Distance**
The distance between two staff lines, measured in spaces (abbr.: sp). If you set this to a higher value, the lines are spaced more widely apart; a lower value and they are closer together. It is *not* recommended to change this value for the standard group, for which the default distance is 1.0 (instead, change the actual size of the sp unit in Page settings); other groups may have different default values (for instance, tablature usually has a line distance of 1.5 sp).

**Extra distance above staff**
Increases or decreases the distance between the selected staff and the one above *in all systems*. However, it does not apply to the top staff of a system, which is controlled by the minimum/maximum system distance (see *Layout and formatting: Style → General... → Page*).

Alternatively, you can alter the "Extra distance above staff" directly from the score page:
1. Press and hold the Shift key.
2. Click on an empty space in a staff and drag it up or down with the mouse.

**Note**: To alter the spacing above just *one* staff line in a particular system, see *Breaks and spacers*.

**Scale**
Changes the size of the *selected* staff and all associated elements, as a percentage (to adjust the *overall* score size, use *Scaling* from the Layout → Page Settings... menu).

**Never Hide**
Never hide this staff. This overrides any "Hide empty staves" setting in *Layout and Formatting: Style → General... → Score*.

**Show clef**
Whether the staff clef will be shown.

**Show time signature**
Whether the staff time signature(s) will be shown or not.

**Show barlines**
Whether the staff barlines will be shown.

**Hide system barline**
Show/hide barline at left-hand edge of the staff.

**Do not hide if system is empty**
Never hide this staff, even if the entire system is empty. This overrides any "Hide empty staves" setting in *Layout and...*
Small staff
Create a reduced-size staff. You can set the default from the menu in Layout and Formatting: Style → General... → Sizes.

Invisible staff lines
Make staff lines invisible.

Staff line color
Use a color picker to change the color of the staff lines.

Part name
The name of the part. This is also displayed in the Mixer and the Instruments dialog.

Instrument
The instrument loaded in the Instruments (i) or Select Instrument dialog. The sound associated with this instrument can be changed, if desired, in the Mixer.

Long instrument name
Name displayed to the left of the staff in the first system of the score. The long instrument name may also be edited directly as a text object (as of version 2.1): see Text editing.

Short instrument name
Name displayed to the left of the staff in subsequent systems of the score. The short instrument name may also be edited directly as a text object (as of version 2.1): see Text editing. Editing affects all occurrences in the score.

Usable pitch range
- Amateur: Notes outside this range will be colored olive green/dark yellow in the score.
- Professional: Notes outside this range will be colored red in the score.

To disable out-of-range coloration of notes: From the menu, select Edit → Preferences... (Mac: MuseScore → Preferences...), click on the “Note Input” tab, and uncheck “Color notes outside of usable pitch range.”

See also, Coloring of notes outside an instrument’s range.

Transpose written pitches (as of version 2.1) / Play transposition
This option ensures that the staves of transposing instruments display music at the correct written pitch. Set the transpose in term of a musical interval (plus octave if required) up or down. For plucked-string instruments such as the guitar, this property can be used to create the effect of applying a capo.

Navigation arrows (as of version 2.1)
Use the ↑ and ↓ buttons, at the bottom left of the Staff Properties window, to navigate to the previous or next staff.

Staff Properties: plucked strings only
Staves of fretted, plucked-string instruments have a few extra options in addition to those listed above.

Number of strings
Displays the number of instrument strings.

Edit String Data...
This button opens a dialog box which allows you to set the number and tuning of strings. See Change string tuning.

Advanced Style Properties
Clicking the Advanced Style Properties... button opens a window giving access to advanced display options for the staff. These will vary depending on the staff type chosen: see the relevant sections below for details.

Change staff type
At the bottom of the Advanced Style Properties dialog there are a number of buttons which allow you to easily change the following:

- The number of lines displayed by a percussion staff
- The staff type of a plucked-string instrument For example, you can change from standard staff to tablature and vice
versa, or select from a number of tablature options.

1. Make a selection from the drop-down list labelled "Template";
2. Press < Reset to Template >;
3. Press OK to accept the changes and exit the dialog (or Cancel to cancel the operation).

Standard and Percussion staff options

Show key signature
Whether the staff key signature will be shown.

Show ledger lines
Whether the staff ledger lines will be shown.

Stemless
If checked, staff notes will have no stem, hook or beam.

Tablature staff options

Upside down
If not checked, the top tablature line will refer to the highest string and the bottom tablature line will refer to the lowest string (most common case). If checked, the top tablature line will refer to the lowest string and the bottom tablature line will refer to the highest line (used in Italian style lute tablatures).

Tablature staff options: Fret Marks

Fret marks are the numbers or letters used to indicate the location of notes on the fingerboard. The following group of properties define the appearance of fret marks:

Font
The font used to draw fret marks. As of version 2.1, 8 fonts are provided supporting all the necessary symbols in 8 different styles (modern Serif, modern Sans, Renaissance, Phalèse, Bonneuil-de Visée, Bonneuil-Gaultier, Dowland, Lute Didactic).

Size
Font size of fret marks in typographic points. Built-in fonts usually look good at a size of 9-10pt.

Vertical offset
MuseScore tries to place symbols in a sensible way and you do not usually need to alter this value (set to 0) for built-in fonts. If the font has symbols not aligned on the base line (or in some other way MuseScore does not expect), this property allows you to move fret-marks up (negative offsets) or down (positive offsets) for better vertical positioning. Values are in sp.

Numbers / Letters
Whether to use numbers (‘1’, ‘2’...) or letters (‘a’, ‘b’...) as fret marks. When letters are used, ‘j’ is skipped and ‘k’ is used for the 9th fret.

On lines / Above lines
Whether marks should be placed on the string lines or above them.

Continuous / Broken
Whether string lines should pass ‘through’ fret marks or should stop at them.

Example of numbers on broken lines:
```
      2 2 2 5 
    2 0 0 0 2  
  0 0 0 0 0  2
      2 2 2
```

Example of letters above continuous lines:
Example of 'upside down' tablature (same contents as number example above):

Show back-tied fret marks
If unticked, only the first note in a series of tied notes is displayed. If ticked, all notes in the tied series are displayed.

Show fingerings
From version 2.1, tick to allow the display of fingering symbols applied from a palette.

Tablature staff options: Note Values

This group of properties defines the appearance of the symbols indicating note values.

Font
The font used to draw the value symbols. Currently 5 fonts are provided supporting all the necessary symbols in 5 different styles (modern, Italian tablature, French tablature, French baroque (headless), French baroque). Used only with the Note symbols option.

Size
Font size, in typographic points. Built-in fonts usually look good at a size of 15pt. Used only with the Note symbols option.

Vertical offset
Applies only when Note symbols is selected (see below). Use negative offset values to raise the note value symbols, positive values to lower them.

Shown as:
- None: No note value will be drawn (as in the examples above)
- Note symbols: Symbols in the shape of notes will be drawn above the staff. When this option is selected, symbols are drawn only when the note value changes, without being repeated (by default) for a sequence of notes all of the same value. E.g.

  ![Example of note symbols](image)

- Stems and beams: Note stems and beams (or hooks) will be drawn. Values are indicated for each note, using the same typographic devices as for a regular staff; all commands of the standard Beam Palette can be applied to these beams too. E.g.

  ![Example of stems and beams](image)

Repeat:
If several notes in sequence have the same duration, you can specify if and where to repeat the same note symbol. i.e.

- Never
- At new system
- At new measure
Note: This option is only available if "Shown as: Note symbols" is selected (see above).

Stem style:
- **Beside staff**: Stems are drawn as fixed height lines above/below the staff.
- **Through staff**: Stems run through the staff to reach the fret marks.

Note: This option is only available when "Shown as: Stems and Beams" is selected (see above).

Stem position:
- **Above**: Stems and beams are drawn above the staff.
- **Below**: Stems and beams are drawn below the staff.

Note: This option is only available when "Shown as: Stems and Beams" and "Stem style: Beside staff" is selected (see above).

Half notes:
- **None**
- **As short stems**
- **As slashed stems**

Note: This option is only available when "Shown as: Stems and Beams" and "Stem style: Beside staff" is selected (see above).

Show rests
Whether note symbols should be used to indicate also the rests; when used for rests, note symbols are drawn at a slightly lower position. Used only with the *Note symbols* option.

Preview
Displays a short score in tablature format with all the current parameters applied.

Change instrument
You can change any instrument in a score to a different instrument at any time. The following method updates instrument sound, staff name, and staff transposition all at once.

1. Right-click on an empty part of any measure OR on the instrument name and choose **Staff Properties...**;
2. Click on **Change Instrument...** (under "Part Properties");
3. Choose your new instrument and click **OK** to return to the Staff Properties dialog;
4. Click **OK** again to return to the score.

Not to be confused with **Mid-staff instrument change**.

External links
- How to turn a staff into an ossia

Tools
A number of useful commands can be found in the **Edit → Tools** submenu.

Add / Remove system/line breaks
This tool adds or removes **system breaks** (**Line breaks** prior to version 2.2) over all or part of the score:

1. **Select** a range of measures: if no selection is made, the command is applied to the whole score.
2. Chose **Edit → Tools → Add/Remove System (Line) Breaks...**. The following dialog appears.
3. Chose one of the following options:
   - Break systems/lines every X (select number) measures.
   - Add system/line breaks at the end of each system.
   - Remove current system/line breaks.
4. Press OK.

**Explode**

The *explode* command allows you to select a passage of music in a single staff and split (explode) the chords into their constituent notes. The top note of each chord is retained on this "source staff" while lower notes are moved to subsequent staves. **Explode only affects notes in voice 1.**

**Note:** If the desired passage also contains notes in other voices apart from voice 1, you should, instead, cut and paste each voice to a separate staff with the help of the selection filter.

**To explode a section of the score:**

1. Make sure all notes to be exploded are in voice 1.
2. Ensure that there are enough staves underneath the "source staff" to receive the exploded notes. Create extra staves if necessary in the Instruments dialog.
3. Chose one of two options:
   - Select a range of measures in the "source staff": this allows all notes to be exploded if there are enough staves available.
   - Select a range of measures that includes both the source staff and also extends downwards to include one or more destination staves: This limits the number of exploded notes to the number of selected staves.

**Notes:** (1) MuseScore will discard the lowest note(s) of any chord that contains more notes than the number of staves in the selection. (2) If a given chord has fewer notes than the number of destination staves, then notes will be duplicated as needed so that every staff receives a note. (3) Any existing music in the destination staves is overwritten. (4) If you select a partial measure, the explode command will automatically expand it to a full measure.

**Implode**

The *Implode* command works in the opposite way to "explode":

- If several staves are selected, all voice 1 notes in underlying staves are copied to the top staff.
- If just one staff is selected, all notes in voices 1–4 are combined into voice 1.

**Note:** Implode works best if the rhythms of selected underlying staves are similar to that of the top staff—the latter providing the rhythmic template for the operation.

**Apply implode to multiple staves**

1. Select a range of measures in a staff and extend this selection downwards to include the other staves to be imploded.
2. Chose Edit → Tools → Implode.

The voice 1 notes of underlying staves are copied to the top staff in the selection.

**Apply implode to a single staff**

1. Select a range of measures in the desired staff.
2. Chose Edit → Tools → Implode.

All selected notes in the staff are now displayed in voice 1.
Fill with slashes

This command fills the selection with slashes, one per beat:

1. Select one or more measures;
2. From the menu, select Edit → Tools → Fill With Slashes.

If a measure is empty the slashes are added to voice 1, full-sized and centered on the middle line of the staff:

![Slash Example](image)

**Notes:** (1) If there are already notes in a measure in the selection, the command will put the slashes into the first available empty voice. (2) Voice 2 slashes are full-sized and centered on the middle line of the staff; voices 3 slashes appear small and above the staff; voice 4 slashes are small and below the staff. (3) If a measure contains notes in all 4 voices, voice 1 will be overwritten. (4) All slashes are set to not transpose or playback.

Toggle rhythmic slash notation

This command toggles selected notes between normal notes and rhythmic slash notation:

1. Select a range of notes or measures (Note: use the selection filter if you need to exclude certain voices);
2. From the menu, select Edit → Tools → Toggle Rhythmic Slash Notation.

The selected noteheads are changed to slash noteheads which do not transpose or playback.

![Slash Example](image)

Slash-notehead notes in voices one or two are fixed to the middle staff line; those in voices three or four are small ("accent" notation) and fixed above or below the staff:

![Slash Example](image)

In percussion staves, notes in voices 3 and 4 are not converted to small slashes but to small notes above or below the staff.

Requence rehearsal marks

The **Resequence Rehearsal Marks** command allows you to re-order the numbering/lettering of rehearsal marks if, for any reason, they have got out of sequence. For details see **Automatically resequence rehearsal marks**.

Copy lyrics to clipboard

This command, available in MuseScore 2.0.3 and above, copies all the lyrics of the score to the clipboard:

- From the menu, select Edit → Tools → Copy Lyrics to Clipboard.

See also

- Breaks and spacers
- Rehearsal marks
New features in MuseScore 2

For an overview about the new features, see What's New in MuseScore 2, Release notes for MuseScore 2.0, Release notes for MuseScore 2.0.1, Release notes for MuseScore 2.0.2, MuseScore 2.0.2 is released, Release notes for MuseScore 2.0.3, MuseScore 2.0.3 is released, Release notes for MuseScore 2.1, MuseScore 2.1 is released, Release notes for MuseScore 2.2, MuseScore 2.2.1 is released, Release notes for MuseScore 2.2.1, Release notes for MuseScore 2.3, MuseScore 2.3.1 is released, Release notes for MuseScore 2.3.1, MuseScore 2.3.2 is released, Release notes for MuseScore 2.3.2, and Changes for MuseScore 2.0.

Documentation of new features are available in the chapter they belong to logically (except the one that is referring to upgrading from 1.x), but for users coming from 1.x here's a collection of links to be able to see at a glance what can be done now...

See also

- Album (→ Advanced topics)
- View modes: Continuous view and Navigator (→ Basics)
- Copy and paste: Selection filter (→ Basics)
- Custom palettes (→ Advanced topics)
- Early music features (→ Advanced topics)
- Figured bass (→ Advanced topics)
- Grid-based movement of symbols and staff text (→ Text)
- Image capture (→ Formatting)
- Inspector and object properties (→ Advanced topics)
- Measure operations: Split and join (→ Basics)
- MIDI import (→ Sound and playback)
- Mid-staff instrument change (→ Sound and playback)
- Part extraction (new options available) (→ Advanced Topic)
- Rehearsal marks: Automatic next rehearsal mark and Search for a rehearsal mark (→ Text)
- Save/Export (→ Basics)
- Staff type properties (→ Advanced topics)
- Swing (→ Sound and playback)
- Tablature (→ Advanced topics)
- Workspace (→ Basics)
- Master palette (→ Advanced topics)
- Layout and formatting (some options have changed, and there is a new “apply to all parts” feature) (→ Formatting)
- Break and spacer: Section break (→ Formatting)
- Selection modes: Select all similar new options (same subtype) (→ Basics)
- Create a new score: start center (→ Basics)
- Languages settings and translation updates (→ Basics)
- Helping and improve translation (→ Support)
- Accidentals: Respell pitches (→ Notation)
- Re-pitch mode (→ Advanced topics)
- Tools (→ Advanced topics)
- Score Information (→ Advanced topics)

Upgrade from MuseScore 1.x

How to upgrade MuseScore

Download and install the latest version from the download page as described at Installation. If you want to remove 1.x, check the installation page of the 1.x handbook.

Installing MuseScore 2 won’t uninstall 1.x—both versions can coexist peacefully and can even be used in parallel. So this isn’t really an upgrade but an installation of a new and different program.

Opening 1.x scores in MuseScore 2

MuseScore 2 significantly improved the typesetting quality to make scores attractive and easier to read. Improvements cover many items such as beam slope, stem height, layout of accidentals in chords and general note spacing. However, this means that sheet music made with MuseScore 1.x looks slightly different from sheet music made with 2.x.

It also means that scores saved with 2.x won’t open with 1.x.
To prevent you from accidentally overwriting your 1.x scores, 2.x treats them as an import, which means:

- The score gets marked as being modified, even if you haven't change anything
- On exiting MuseScore you're asked to save the score (as a result from the above)
- MuseScore uses the “Save As” dialog to save it, not the “Save” dialog
- MuseScore uses the score's title to create a default filename rather than taking the old filename

Relayout

If you did not manually adjust the layout of a 1.x score, then MuseScore uses the 2.x typesetting engine to layout the score. If you did touch the layout of the 1.x score, the individual adjustments you may have made should remain after opening it in MuseScore 2.x, but due to slight changes in the surrounding layout they may still not appear correct in context. If you wish to reset even manual adjustments to use the 2.x typesetting engine throughout, select the complete score with the shortcut Ctrl+A (Mac: Cmd+A) and reset the layout with Ctrl+R (Mac: Cmd+R).

Getting the sound from MuseScore 1.x

While the sound in 2.x has been much improved, you may still prefer the sound from MuseScore 1.x. In that case, you can get the 1.x sound in 2.x by downloading the 1.3 SoundFont and add it in 2.x. You can do this in two steps:

1. Download the 1.3 SoundFont named TimGM6mb
2. Install and use the TimGM6mb SoundFont in 2.0

Support

This chapter describes how to find help using MuseScore: the best places to look, the best way to ask a question on the forums, and tips for reporting a bug.

Helping improve translations

You can help translate the MuseScore software and documentation into your own language, as mentioned in Development / Translating.

Software translation

1. Ask in the forum to improve translation
2. Connect to Transifex/MuseScore http://translate.musescore.org, which will redirect you to https://www.transifex.com/projects/p/musescore
3. Select the language and then the section you want to help with (musescore or instruments)
4. Click on the “translate” button (the button text will depend on your language...)
5. Search for “strings” (informational meaning) you want to translate (you could filter "already translated items"

Here is a technical explanation: Continuous translation for MuseScore 2.0

Website and handbook translation

See Translation instructions

See also

- Language Settings and Update Translation, Update Translation

How to ask for support or file bug reports

Before submitting your support request in the forum, please:

- Look for a solution in the Handbook (search the Handbook)
- Check the How Tos, FAQ and Tutorials
- Search the forums of the website to see if someone has already encountered the same problem

If posting in either the issue tracker (for established reports), or forum (for inquiries/discussions):

- Try to reproduce the issue with the latest nightly. You may also view and version history to check whether it
has been fixed/implemented already.

- Please include as much of the following information as you know and limit each issue to one report:
  - Version/revision of MuseScore you are using (e.g. version 2.1, revision871c8ce). Check Help → About...
    (Mac: MuseScore → About MuseScore...).
  - Operating system being used (e.g. Windows 7, macOS 10.12 or Ubuntu 14.04)
  - If reporting a bug, describe the precise steps that lead to the problem (where do you click, what keys do you
    press, what do you see, etc.).
    If you are not able to reproduce the problem with the steps, it is probably not worth reporting it as the
    developers will not be able to reproduce (and solve) it either. Remember that the goal of a bug report is not
    only to show the problem, but to allow others to reproduce it easily.

- Please remember:
  - attach the score that shows the problem —use the "File attachments" option at the bottom of the page, just
    above the Save and Preview buttons when you’re typing your post.

External links

- How to write a good bug report: step-by-step instructions

Revert to factory settings

Recent versions of MuseScore have the option to revert back to the standard built-in presets or "factory-settings". This
can be necessary if your settings are corrupted. Warning: Reverting to factory settings removes any changes you have
made to the preferences, palettes, or window settings. This is not a commonly needed procedure; consult the forums first,
as there may be a way to solve your problem without resetting everything.

MuseScore 2.0.3 and above

In recent versions it is possible to revert from within MuseScore, providing that MuseScore itself is able to start.
Go to Help → Revert to Factory Settings. A warning dialog will appear:

![Warning dialog](image)

Clicking Yes resets all MuseScore's settings as if the program was installed for the first time, and MuseScore will
immediately restart. No will safely cancel the revert.

MuseScore 2.0 through 2.0.2

In older versions of MuseScore, or in later versions if they do not start, you must run this process via the command line.

Instructions for Windows

1. If you have MuseScore open, you need to close it first (File → Quit)
2. Type Windows key+R to open the Run dialog (TheWindows key is the one with the logo for Microsoft Windows).
   Alternatively select Start using your mouse.
3. Click Browse...
4. Look for MuseScore.exe on your computer. The location may vary depending on your installation, but it is probably
   something similar to My Computer → Local Disk → Program Files (or Program Files (x86)) → MuseScore 2 → bin
   → MuseScore.exe
5. Click Open to leave the Browse dialog and return to the Run dialog. The following text (or something similar) should
display in the Run dialog

C:\Program Files\MuseScore 2\bin\MuseScore.exe (actually %ProgramFiles%\MuseScore 2\bin\MuseScore.exe)

For 64-bit Windows, the location is

C:\Program Files (x86)\MuseScore 2\bin\MuseScore.exe (actually %ProgramFiles(x86)%\MuseScore 2\bin\MuseScore.exe)

For the Windows Store version (Windows 10), it is pretty well hidden, search for it via Windows Explorer

6. Click after the quote and add a space followed by a hyphen and a capital F:

7. Press OK

After a few seconds, MuseScore should start and all the settings reverted to "factory settings".

For advanced users, the main preference file is located at:

- Windows Vista or later: C:\Users\<USERNAME>\AppData\Roaming\MuseScore\MuseScore2.ini
  (actually %APPDATA%\MuseScore\MuseScore2.ini)
- Windows XP or earlier: C:\Documents and Settings\<USERNAME>\Application Data\MuseScore\MuseScore2.ini

The other preferences (palettes, session, shortcuts, workspaces...) are in:

- Windows Vista or later: C:\Users\<USERNAME>\AppData\Local\MuseScore\MuseScore2\
  (actually %APPDATA%\MuseScore\MuseScore2\)
- Windows XP or earlier: C:\Documents and Settings\<USERNAME>\Local Settings\Application Data\MuseScore\MuseScore2\

For the Windows Store version (Windows 10), these are pretty well hidden, search for them via Windows Explorer

Instructions for MacOS

1. If you have MuseScore open, you need to quit the application first (MuseScore → Quit)
2. Open Terminal (in Applications/Utilities, or via Spotlight search) and a session window should appear
3. Type (or copy/paste) the following command into your terminal line (include the '/' at the front):

   /Applications/MuseScore 2.app/Contents/MacOS/mscore -F

This resets all MuseScore preferences to factory settings and immediately launches the MuseScore application. Note that you cannot quit the Terminal without quitting MuseScore. You can safely quit MuseScore, quit the Terminal, and then reopen MuseScore in the normal fashion, ready to continue using.

For advanced users, the main MuseScore preference file is located at ~/.Library/Preferences/org.musescore.MuseScore2.plist.

The other preferences (palettes, session, shortcuts, workspaces...) are in ~/.Library/Application Support/MuseScore/MuseScore2/.

Instructions for Linux

The following is true for Ubuntu, and most likely all other Linux distributions and UNIX-style operating systems.

1. If you have MuseScore open, you need to quit the application first (File → Quit)
2. From the Ubuntu main menu, choose Applications → Accessories → Terminal. A Terminal session window should appear
3. Type, (or copy/paste) the following command into your terminal line (Ctrl+Shift+V to paste in Terminal):

   mscore -F

   Or, if you are using the AppImage version, you must first use the cd command to change directory to wherever you saved the AppImage. For example, if you saved it to your Desktop:

   cd ~/Desktop
   ./MuseScore*.AppImage -F

This resets all MuseScore preferences to factory settings and immediately launches the MuseScore application. You can now quit Terminal, and continue using MuseScore.

For advanced users, the main MuseScore preference file is located at ~/.config/MuseScore/MuseScore2.ini.
The other preferences (palettes, session, shortcuts, workspaces...) are in ~/.local/share/data/MuseScore/MuseScore2/.

See also

- Command line options

**Known incompatibilities**

**Hardware incompatibilities**

The following software is known to crash MuseScore on startup:

- Samson USB Microphone, driver name “Samson ASIO Driver”, samsonasiodriver.dll. [More info](#)
- Digidesign MME Refresh Service. [More info](#)
- Windows XP SP3 + Realtek Azalia Audio Driver. [More info](#)
- Wacom tablet. [More info](#) and [QTBUG-6127](#)

**Software incompatibilities**

- Maple virtual cable is known to prevent MuseScore from closing properly.
- KDE (Linux) window settings can cause the whole window to move when dragging a note. Changing the window settings of the operating system avoids the problem.
- Nitro PDF Creator may prevent MuseScore from starting on Windows 10, if being used as the default printer. Same for Amyumi/Quickbooks PDF Printer, see [here](#) and also some cloud printing services, see [here](#).
- Creative Sound Blaster Z Series ASIO driver may prevent MuseScore from starting on Windows 10.
- Untrusted Font Blocking policy prevents MuseScore from starting (except in debug mode, i.e. using the -d option) on Windows 10. (Solution in the links provided [here](#))

**AVG Internet Security hangs MuseScore**

MuseScore requires access to your internet connection with AVG. MuseScore doesn't need an internet connection to function, but if AVG blocks it, MuseScore hangs.

If AVG prompts you, **Allow** MuseScore and check “Save my answer as a permanent rule and do not ask me next time.”

If it doesn't prompt you anymore,

1. Open the AVG user interface (right-click on the AVG icon, close to your clock) -> Open AVG User Interface
2. Click on **Firewall**
3. Click **Advanced Settings**
4. Click **Applications**
5. Find MSCORE.EXE in the list and double click it
6. Change **Application Action** to **Allow for All**

**Font problem on macOS**

MuseScore is known to display notes as square when some fonts are damaged on macOS.

To troubleshoot this issue:

1. Go to Applications -> Font Book
2. Select a font and press ⌘+A to select them all
3. Go to File -> Validate Fonts
4. If any font is reported as damaged or with minor problems, select it and delete it
5. Restart MuseScore if necessary

In **Bug in noteheads**[1], a user believes to have found the font “Adobe Jenson Pro (ajenson)” to be the culprit, regardless of not being reported as broken, or problematic as per the above validation, and solved the problem by deleting that font, so this is worth checking too.

**Font problem on Linux**

If the default desktop environment application font is set to bold, MuseScore will not display the notes properly.

To troubleshoot this issue (gnome 2.*/MATE users):
1. Right-click on your desktop and select Change Desktop background
2. Click on Fonts tab
3. Set Regular style for Application font
4. Restart MuseScore if necessary

For GNOME 3/SHELL users
1. Open the shell and open "Advanced Settings"
2. Click on the Fonts option in the list
3. Set the default font to something non-bold
4. Restart MuseScore if necessary

Save As dialog empty on Linux

Some users reported that the Save As dialog is empty on Debian 6.0 and Lubuntu 10.10. To troubleshoot this issue:

1. Type the following in a terminal
   
   which mscore

2. The command will answer with the path of mscore. Edit it with your preferred text editor and add the following line at the beginning
   
   export QT_NO_GLIB=1

Launch MuseScore and the problem should be solved.

Appendix

Keyboard shortcuts

Most keyboard shortcuts can be customized via the menu: select Edit → Preferences... → Shortcuts (Mac: MuseScore → Preferences... → Shortcuts). Below is a list of some of the initial shortcut settings.

Navigation

Beginning of score: Home (Mac: Fnl ←)
Last page of score: End (Mac: Fnl →)
Find (measure number, rehearsal mark, or pXX when XX is a page number): Ctrl+F (Mac: Cmd+F)

Next score: Ctrl+Tab
Previous score: Shift+Ctrl+Tab

Zoom in: Ctrl++ (doesn't work on some systems) (Mac: Cmd++); or Ctrl (Mac: Cmd) + scroll up
Zoom out: Ctrl+- (Mac: Cmd+); or Ctrl (Mac: Cmd) + scroll down

Next page: Pg Dn; or Shift + scroll down (Mac: Fn+↓)
Previous page: Pg Up; or Shift + scroll up (Mac: Fn+↑)

Next measure: Ctrl→ (Mac: Cmd→)
Previous measure: Ctrl← (Mac: Cmd←)

Next note: →
Previous note: ←

Note below (within a chord or on lower staff): Alt↓
Note above (within a chord or on higher staff): Alt↑

Top note in chord: Ctrl+Alt+↑ (Ubuntu uses this shortcut for Workspaces instead)
Bottom note in chord: Ctrl+Alt+↓ (Ubuntu uses this shortcut for Workspaces instead)

Note input

Begin note input mode: N
Leave note input mode: N or Esc

Duration

1 ... 9 selects a duration. See also Note input.

Half duration of previous note: Q
Double duration of previous note: W
Decrease duration by one dot: (as of version 2.1) Shift+Q (e.g. a dotted quarter note becomes a quarter note; a quarter note becomes a dotted eighth note)
Increase duration by one dot: (as of version 2.1) Shift+W (e.g. an eighth note becomes a dotted eighth note; a dotted eighth note becomes a quarter note)

Voices

To select a voice in note input mode.

Voice 1: Ctrl+Alt+1 (Mac: Cmd+Option+1)
Voice 2: Ctrl+Alt+2 (Mac: Cmd+Option+2)
Voice 3: Ctrl+Alt+3 (Mac: Cmd+Option+3)
Voice 4: Ctrl+Alt+4 (Mac: Cmd+Option+4)

Pitch

Pitches can be entered by their letter name (A-G), or via MIDI keyboard. See Note input for full details.

Repeat previous note or chord: R (the repeat can be of a different note value by selecting duration beforehand)
Repeat selection: R (The selection will be repeated from the first note position after the end of the selection)
Raise pitch by octave: Ctrl+↑ (Mac: Cmd+↑)
Lower pitch by octave: Ctrl+↓ (Mac: Cmd+↓)
Raise pitch by semi-tone (prefer sharp): ↑
Lower pitch by semi-tone (prefer flat): ↓
Raise pitch diatonically: Alt+Shift+↑
Lower pitch diatonically: Alt+Shift+↓

Change enharmonic spelling in both written and concert pitch views: J
Change enharmonic spelling in current view only: Ctrl+J (Mac: Cmd+J)

Rest: 0 (zero)

Interval

Add interval above current note: Alt+[Number]

Layout

Flip direction (stem, slur, tie, tuplet bracket, etc.): X
Mirror note head: Shift+X
Increase stretch of measure(s): }
Decrease stretch of measure(s): |
Line break on selected barline: Return
Page break on selected barline: Ctrl+Return (Mac: Cmd+Return)
Adjust space above a staff (except the top staff) for the whole score: Press Shift, click on the staff and drag

Articulations

Staccato: Shift+S
Tenuto: Shift+N
Sforzato (accent): Shift+V
Marcato: Shift+O
Grace note (acciaccatura): /
Crescendo: <
Decrescendo: >

**Text entry**

Staff text: Ctrl+T (Mac: Cmd+T)
System text: Ctrl+Shift+T (Mac: Cmd+Shift+T)
*Tempo* text: Alt+T
Rehearsal Mark: Ctrl+M (Mac: Cmd+M)

**Lyrics entry**

Enter lyrics on a note: Ctrl+L (Mac: Cmd+L)
Previous lyric syllable: Shift+Space
Next lyric syllable: if the current and the next syllables are separated by a `-`, then `Space`
Move lyric syllable left by 0.1sp: ←
Move lyric syllable right by 0.1sp: →
Move lyric syllable left by 1sp: Ctrl← (Mac: Cmd←)
Move lyric syllable right by 1sp: Ctrl→ (Mac: Cmd→)
Move lyric syllable left by 0.01sp: Alt←
Move lyric syllable right by 0.01sp: Alt→
Up to previous stanza: Ctrl↑ (Mac: Cmd↑)
Down to next stanza: Ctrl↓ (Mac: Cmd↓)

*For more lyric shortcuts, see* [Lyrics](#).

**Display**

Navigator: F12 (Mac: fn+F12)
Play Panel: F11 (Mac: fn+F11)
Mixer: F10 (Mac: fn+F10)
Palette: F9 (Mac: fn+F9)
Inspector: F8 (Mac: fn+F8)
Piano Keyboard: P
Selection filter: F6
Display full screen: Ctrl+U

**Miscellaneous**

Toggle visibility on selected element(s): V
Show Instruments dialog: I
Toggle multi-measure rests on or off: M

**See also**

- Preferences: Shortcuts

**Known limitations of MuseScore 2.x**

While all members of the development team did their best to make the software easy to use and bug-free, there are some known issues and limitations in MuseScore 2.x.

**Local time signatures**

The local time signature feature, which allows you to have different time signatures in different staves at the same time, is very limited. You can only add a local time signature to measures that are empty, and only if there are no linked parts. When adding notes to measures with local time signatures, you can enter notes normally via note input mode, but copy and paste does not work correctly and may lead to corruption or even crashes. The join and split commands are disabled for measures with local time signatures.

**Regroup Rhythms**
The Regroup Rhythms command found under the Layout menu may have unintended side effects, including changing the spelling of pitches and deleting some elements like articulations, glissandos, tremolos, grace notes and, esp. on undo, ties. Use this tool with caution on limited selections, so that you can tell if any unwanted changes are made.

Tablature staff linked with standard staff

When entering multiple-note chords on a standard staff in a linked staff/tablature system, the notes should be entered in order from the top (first) string to the bottom string to ensure correct fret assignment.

This limitation does not apply if entering notes directly onto a tablature staff, or when using an unlinked staff/tablature system.

Mixer

Changing settings in the mixer other than the sound doesn't mark the score 'dirty'. That means if you close a score you may not get the warning “Save changes to the score before closing?”. Changing mixer values are also not undoable.

Header & footer

There is no way to edit Header and Footer in a WYSIWYG manner. The fields in Style → General → Header, Footer, Numbers are plain text. They can contain “HTML like” syntax, but the text style, layout, etc. can’t be edited with a WYSIWYG editor.

Command line options

You can launch MuseScore from the command line by typing

- `mscore [options] [filename]` (Mac and Linux)
- `MuseScore.exe [options] [filename]` (Windows)

[options] and [filename] are optional. For this to work the MuseScore executable must be in %PATH% (Windows) resp. $PATH (Mac and Linux). If it is not, see Revert to factory settings for detailed instructions on how and where to find and execute the MuseScore executable from the command line on the various supported platforms.

The following options are available

- `-?`, `-h`, `--help`
  Display help (doesn't work on Windows)
- `-v`, `--version`
  Displays MuseScore's current version in the command line without starting the graphical interface (doesn't work on Windows)
- `--long-version`
  Displays MuseScore's current version and revision in the command line without starting the graphical interface (doesn't work on Windows)
- `-d`, `--debug`
  Starts MuseScore in debug mode
- `-L`, `--layout-debug`
  Starts MuseScore in layout debug mode
- `--no-synthesizer`
  Disables the integrated software synthesizer
- `--no-midi`
  Disables MIDI input
- `--use-audio <driver>`
  Use audio driver: jack, alsa, pulse, portaudio
- `--new-score`
  Starts with the new score wizard regardless of preference setting for start mode
- `--dump-midi-in`
  Displays all MIDI input on the console
- `--dump-midi-out`
  Displays all MIDI output on the console
- `--export-to <filename>`
  Exports the currently opened file to the specified <filename>. The file type depends on the filename extension. This option switches to the “converter” mode and avoids any graphical interface. You can also add a filename before the -
if you want to import and export files from the command line. For example:

```bash
mscore -o "My Score.pdf" "My Score.mscz"
```

- `-r`, `--image-resolution <dpi>`
  Determines the output resolution for the output to PNG images in the converter mode. The default resolution is taken from Preferences, Export, PNG/SVG.

- `-T`, `--trim-image <margin>`
  Trims exported PNG and SVG images to remove surrounding whitespace around the score. The specified number of pixels of whitespace will be added as a margin; use 0 for a tightly cropped image. For SVG, this option works only with single-page scores.

- `-x`, `--gui-scaling <factor>`
  Scales the score display and other GUI elements by the specified factor, for use with high resolution displays.

- `-D`, `--monitor-resolution <dpi>`
  Specify monitor resolution, for use with high resolution displays (as of version 2.1).

- `-S`, `--style <style>`
  Loads a style file; useful when you convert with the `-o` option

- `-p`, `--plugin <name>`
  Execute the named plugin

- `--template-mode`
  Save template mode, no page size

- `-F`, `--factory-settings`
  Use only the standard built-in presets or “factory-settings” and delete preferences. For details, see Revert to factory settings

- `-R`, `--revert-settings`
  Use only the standard built-in presets or “factory-settings”, but do not delete preferences

- `-i`, `--load-icons`
  Load icons from the file system. Useful if you want to edit the MuseScore icons and preview the changes

- `-j`, `--job <filename>`
  Process a conversion job (as of version 2.1)

- `-e`, `--experimental`
  Enable experimental features. See e.g. Layer (experimental)

- `-c`, `--config-folder <pathname>`
  Set config path

- `-t`, `--test-mode`
  Enable test mode

- `-M`, `--midi-operations <filename>`
  Specify MIDI import operations file; See this example file: midi_import_options.xml

- `-w`, `--no-webview`
  No web view in Start Center

- `-P`, `--export-score-parts`
  Used with `-o <filename>.pdf`, export score and parts

- `-n`, `--no-fallback-font`
  Don’t use Bravura as fallback musical font

- `-f`, `--force`
  Used with `-o`, ignore warnings reg. score being corrupted or from wrong version (as of version 2.1)

- `-b`, `--bitrate <bitrate>`
  Used with `-o <filename>.mp3`, sets bitrate in kbps (as of version 2.1)

- `-E`, `--install-extension <extension file>`
  Install an extension, load soundfont as default unless if `-e` is passed too (as of version 2.3)

### Qt Toolkit Options

- `-style= <style>`
  Determines the style of the GUI application. Possible values are "motif", "windows" and "platinum". Depending on the platform other styles may be available

- `--stylesheet= <stylesheet>`
  Sets the application stylesheet. The value of "stylesheet" is a path to a file that contains the stylesheet

- `--platform <platformname>[;options]`
  Specifies the Qt Platform Abstraction (QPA) plugin.

  Example: MuseScore.exe -platform windows:fontengine=freetype

See also
The glossary is a work in progress—please help if you can. You can discuss this page in the documentation forum.

The list below is a glossary of frequently used terms in MuseScore as well as their meaning. The differences between American English and British English are marked with "(AE)" and "(BE)", respectively.

Acciaccatura

A short grace note which appears as a small note with a stroke through the stem. It is quickly executed and technically takes no value from its associated note.

Accidental

A sign appearing in front of a note that raises or lowers its pitch. The most common accidentals are sharps, flats, or naturals, but double sharps and double flats are also used. Also koron, and sori and other quarter tone accidentals. Accidentals affect all notes on the same staff position only for the remainder of the measure in which they occur, but they can be canceled by another accidental. In notes tied across a barline, the accidental continues across the barline to the tied note, but not to later untied notes on the same staff position in that measure.

Anacrusis

See Pickup measure.

Anchor

The point of attachment to the score of objects such as Text and Lines: When the object is dragged, the anchor appears as small brown circle connected to the object by a dotted line. Depending on the object selected, its anchor may be attached to either (a) a note (e.g. fingering), (b) a staff line (e.g. staff text), or (c) a barline (e.g. repeats).

Appogiatura

A long grace note which takes value from its associated note. Its functions include: passing tone, anticipation, struck suspension, and escape tone.

Bar (BE)

See measure.

Barline

Vertical line through a staff, staves, or a full system that separates measures.

Beam

Notes with a duration of an eighth or shorter either carry a flag or a beam. Beams are used for grouping notes.

BPM

Beats Per Minute is the unit for measuring tempo. See metronome mark.

Breve

A double whole note or breve is a note that has the duration of two whole notes.

Cent

An interval equal to one hundredth of a semitone.

Chord

A group of two or more notes sounding together. To select a chord in MuseScore, press the and click on a note. In the Inspector, however, the word "Chord" only covers notes in the same voice as the selected note(s).

Clef

Sign at the beginning of a staff, used to tell which are the musical notes on the lines and between the lines. Clefs are very useful for transposition.

Concert pitch

Enables you to switch between concert pitch and transposing pitch (see Concert pitch and Transposition).

Crotchet (BE)

See Quarter note.

Demisemiquaver (BE)

A thirty-second note.
See → tuplet.

Edit mode
The program mode from which you can edit various score elements.

Eighth note
A note whose duration is an eighth of a whole note (semibreve). Same as a quaver (BE).

Endings
See → volta.

Enharmonic notes
Notes that sound the same pitch but are written differently. Example: G♯ and A♭ are enharmonic notes.

Flat
Sign (♭) that indicates that the pitch of a note has to be lowered one semitone.

Grace note
Grace notes appear as small notes in front of a normal-sized main note. See → acciaccatura and → appoggiatura.

Grand Staff (AE)
Great Stave (BE)
A system of two or more staves, featuring treble and bass clefs, used to notate music for keyboard instruments and the harp.

Half Note
A note whose duration is half of a whole note (semibreve). Same as a minim (BE).

Hemidemisemiquaver (BE)
A sixty-fourth note.

Interval
The difference in pitch between two notes, expressed in terms of the scale degree (e.g. major second, minor third, perfect fifth etc.). See Degree (Music) (Wikipedia).

Jump
In MuseScore, "jumps" are notations such as "D.S. al Coda", found in the "Repeats & Jumps" palette.

Key Signature
Set of → sharps or → flats at the beginning of the → staves. It gives an idea about the tonality and avoids repeating those signs all along the → staff.
A key signature with B flat means F major or D minor tonality.

Koron
An Iranian → accidental which lowers the pitch of a note by a quarter tone (in comparison to the → flat which lowers a note by a semitone). It is possible to use this accidental in a → key signature.
See also → sori.

Longa
A longa is a quadruple whole note.

Ledger Line
Line(s) that are added above or below the staff.

Measure (AE)
A segment of time defined by a given number of beats. Dividing music into bars provides regular reference points to pinpoint locations within a piece of music. Same as → bar (BE).

Metronome mark
Metronome marks are usually given by a note length equaling a certain playback speed in → BPM. In MuseScore, metronome marks are used in Tempo texts.

Minim (BE)
See → Half note.

Natural
A natural (♮) is a sign that cancels a previous alteration on notes of the same pitch.

Normal mode
The operating mode of MuseScore outside note input mode or edit mode: press Esc to enter it. In Normal mode you can navigate through the score, select and move elements, adjust Inspector properties, and alter the pitches of existing notes.

Note input mode
The program mode used for entering music notation.

Operating System
OS
Underlying set of programs which set up a computer, enabling additional programs (such as MuseScore). Popular OSes are Microsoft Windows, macOS, and GNU/Linux.
Not to be confused with a sheet music → system.

Part
Music to be played or sung by one or a group of musicians using the same instrument. In a string quartet, 1st part = Violin 1, 2nd part = Violin 2, 3rd part = Viola, 4th part = Cello; in a choir there might be parts for soprano, alto, tenor and bass. A part has one or more → staves (e.g. Piano has 2 staves, Organ can have 2 or 3 staves).

Pickup Measure (also known as an Anacrusis or Upbeat)
Incomplete first measure of a piece or a section of a piece of music. See Measure duration and Create new score: Pickup measure. Also Exclude from measure count.

Quadruplet
See → tuplet.

Quarter note
A note whose duration is a quarter of a whole note (semibreve). Same as a crotchet (BE).

Quaver (BE)
See → eighth note.

Quintuplet
See → tuplet.

Re-pitch mode
Allows you to rewrite an existing passage of music by changing the note pitches without altering the rhythm.

Semibreve (BE)
A whole note (AE). It lasts a whole measure in 4/4 time.

Semiquaver (BE)
A sixteenth note.

Semihemidemisemiquaver (Quasihemidemisemiquaver) (BE)
An hundred and twenty eighth note.

Sextuplet
See → tuplet.

SFZ
A virtual instrument format supported by MuseScore (along with → SoundFonts). An SFZ library consists of one or more SFZ text files, each defining a particular instrument setup, and many audio sound samples.

Sharp
Sign (♯) that indicates that the pitch of a note has to be raised one semitone.

Slur
A curved line over or under two or more notes, meaning that the notes will be played smooth and connected (legato).
See also → tie.

Sori
An Iranian accidental which raises the pitch of a note by a quarter tone (in comparison to the sharp which raises it by a semitone). It is possible to use this accidental in a → key signature.
See also → koron.

SoundFont
A virtual instrument format supported by MuseScore (along with → SFZ). A SoundFont is a special type of file (extension .sf2, or .sf3 if compressed) containing sound samples of one or more musical instruments. In effect, a virtual synthesizer which acts as a sound source for MIDI files. MuseScore 2.2 comes with the SoundFont "MuseScore_General.sf3" pre-installed.

Spatium (plural: Spatia)
Space
Staff Space
sp (abbr./unit)
The distance between two lines of a normal 5-line staff. In MuseScore this unit influences most size settings. See also Page settings.

Staff (AE)
Stave (BE)
Group of one to five horizontal lines used to lay on musical signs. In ancient music notation (before 11th century) the staff/stave may have any number of lines (the plural of 'staff' is 'staves', in BE and AE).

Step-time input
MuseScore's default note input mode, allowing you to enter music notation one note (or rest) at a time.

System
Set of staves to be read simultaneously in a score.
See also → Operating System (OS).

Tie
A curved line between two or more notes on the same pitch to indicate a single note of combined duration:

- Quarter note + Tie + Quarter note = Half note
- Quarter note + Tie + Eighth note = Dotted Quarter note
- Quarter note + Tie + Eighth note + Tie + 16th note = Double Dotted Quarter note

See also → slur.

**Transposition**

The act of moving the pitches of one or more notes up or down by a constant interval. There may be several reasons for transposing a piece, for example:

1. The tune is too low or too high for a singer. In this case the whole orchestra will have to be transposed as well —easily done using MuseScore.
2. The part is written for a particular instrument but needs to be played by a different one.
3. The score is written for an orchestra and you want to hear what the individual instruments sound like. This requires changing the transposing instrument parts to concert pitch.
4. A darker or a more brilliant sound is desired.

**Triplet**

See → tuplet.

**Tuplet**

A tuplet divides its next higher note value by a number of notes other than given by the time signature. For example a → triplet divides the next higher note value into three parts, rather than two. Tuplets may be: triplets, → duplets, → quintuplets, and other.

**Upbeat**

See → pickup measure.

**Velocity**

The velocity property of a note controls how loudly the note is played. This usage of the term comes from MIDI synthesizers. On a keyboard instrument, it is the speed with which a key is pressed that controls its volume. The usual scale for velocity is 0 (silent) to 127 (maximum).

**Voice**

Polyphonic instruments like Keyboards, Violins, or Drums need to write notes or chords of different duration at the same time on the same → staff. To write such things each horizontal succession of notes or chords has to be written on the staff independently. In MuseScore you can have up to 4 voices per staff. Not to be confused with vocalists, singing voices like soprano, alto, tenor and bass, which are better viewed as instruments.

**Volta**

In a repeated section of music, it is common for the last few measures of the section to differ. Markings called voltas are used to indicate how the section is to be ended each time. These markings are often referred to simply as → endings.

**External links**

- [http://www.robertcarney.net/musical-terms-definitions.htm](http://www.robertcarney.net/musical-terms-definitions.htm)

**Table of Contents**

**Getting started**

- Installation
- Create new score
- Language settings and translation updates
- Checking for updates

**Basics**

- [Create new score](#) (→ Getting started)
- Note input
- Concert pitch
- Copy and paste
- Edit mode
- Measure operations
- Palette
- Preferences
- Save/Export/Print
- Selection modes
- Undo and redo
- View modes
- File format
- Share scores online

**Notation**

- *Note input* (→ Basics)
- *Palette* (→ Basics)
- Accidental
- Arpeggio and glissando
- Bar line
- Beam
- Bracket
- Breath and pause
- Clef
- Drum notation
- Grace note
- Hairpin
- Key signature
- Lines
- Measure rest
- Repeat
- Slur
- Tie
- Time signature
- Transposition
- Tremolo
- Tuplet
- Voices
- *Volta* (1st and 2nd time endings)

**Sound and playback**

- MIDI import
- Mid-staff instrument change
- Play mode
- Soundfont
- Swing
- Tempo
- Dynamics
- Change and adjust sound

**Text**

- Grid-based movement of symbols and staff text
- Rehearsal marks
- Text editing
- Text style
- Chord symbols
- Fingering
- Lyrics
- *Tempo* (→ Sound and playback)

**Formatting**
Advanced topics

- Accessibility
- Album
- Cross staff beaming
- Custom palette
- Early music features
- Figured bass
- Fretboard diagram
- Inspector and object properties
- Master palette
- Part extraction
- Plugins
- Replace pitches without changing rhythms
- Score information
- Staff type properties
- Tablature
- Tools
- Nonexistent node nid: 39841

New features in MuseScore 2.0

- What's New in MuseScore 2
- MuseScore 2.0 Release Notes
- Changes for MuseScore 2.0.
  - Album (→ Advanced topics)
  - View modes: Continuous view and Navigator (→ Basics)
  - Copy and paste: Selection filter (→ Basics)
  - Custom palette (→ Advanced topics)
  - Early music features (→ Advanced topics)
  - Figured bass (→ Advanced topics)
  - Grid-based movement of symbols and staff text (→ Text)
  - Image capture (→ Formatting)
  - Inspector and object properties (→ Advanced topics)
  - Measure operations: Split and join (→ Basics)
  - MIDI import (→ Sound and playback)
  - Mid-staff instrument change (→ Sound and playback)
  - Part extraction (new options available) (→ Advanced Topic)
- Rehearsal marks: Automatic next rehearsal mark and Search for a rehearsal mark (→ Text)
  - Save/Export (→ Basics) - Staff type properties (→ Advanced topics)
  - Swing (→ Sound and playback)
  - Tablature (→ Advanced topics)
  - Nonexistent node nid: 39841 (→ Advanced topics)
  - Master palette (→ Advanced topics)
  - Layout and formatting (some options have changed, and there is a new "apply to all parts" feature) (→ Formatting)
  - Breaks and spacers, section break (→ Formatting)
  - Selection modes, select all similar new options (same subtype) (→ Basics)
  - Create a new score, start center (→ Basics)
  - Languages settings and translation Updates (→ Basics)
  - Helping and improve translation (→ Support)
  - Accidentals, respell pitches (→ Notation)
  - Replace pitches without changing rhythms (→ Advanced topics)
  - Tools (→ Advanced topics)
**Support**

- Helping and improve translation
- How to ask for support or file reports
- Revert to factory settings
- Known incompatibilities

**Appendix**

- Keyboard shortcuts
- Known limitations of MuseScore 2.x
- Command line options
- Glossary
- Handbook for MuseScore 1.x (🔗)